트윈 애니메이션

시작하기 전에

참고:

Animate(이전의 Flash Professional CC)의 요소 대부분과 마찬가지로, 애니메이션에는 ActionScript가 필요하지 않습니다. 하지만 원하는 경우에는 ActionScript를 사용하여 애니메이션을 만들 수 있습니다.

트윈을 만들기 전에 다음과 같은 Animate 개념을 이해하면 도움이 됩니다.

  • 스테이지에서 그리기

  • 타임라인 레이어 및 단일 레이어와 여러 레이어에 있는 객체의 쌓인 순서

  • 스테이지속성 관리자에서 객체 이동 및 변형

  • 객체 수명 및 특정 시점에 객체 선택하기를 포함한 타임라인 사용. 기본 원리에 대해 배우려면 프레임 및 키프레임을 참조하십시오.

  • 심볼 및 심볼 속성. 트위닝 가능한 심볼 유형에는 동영상 클립, 버튼, 그래픽 등이 있습니다. 텍스트도 트위닝 가능합니다.

  • 중첩된 심볼. 심볼 인스턴스가 다른 심볼 안에 중첩될 수 있습니다.

  • 선택 사항: 선택 도구와 세부 선택 도구를 사용하여 베지어 곡선 편집. 이러한 도구는 트윈 모션 경로를 편집할 때 사용할 수 있습니다. 자세한 내용은 모션 편집기를 사용한 모션 트윈 편집을 참조하십시오.

이러한 개념에 대한 자세한 내용은 이 페이지의 하단에 있는 링크 목록을 참조하십시오.

모션 트윈 이해

모션 트윈은 서로 다른 프레임에서 한 객체 속성에 대해 각기 다른 값을 지정하여 만들어지는 애니메이션입니다. Animate에서는 이러한 두 프레임 사이에 해당 속성 값을 계산합니다. 트윈이라는 용어는 "in between(중간)"에서 유래된 것입니다.

예를 들어 프레임 1에서 스테이지 왼쪽에 심볼을 배치하고 프레임 20에서 스테이지 오른쪽으로 이동할 수 있습니다. 트윈을 만들면 Animate에서 그 사이에 있는 동영상 클립의 모든 위치를 계산합니다. 그 결과, 왼쪽에서 오른쪽으로 그리고 프레임 1에서 프레임 20으로 이동하는 심볼의 애니메이션이 만들어집니다. 그 사이의 각 프레임에서 Animate는 동영상 클립을 스테이지에서 해당 거리의 20분의 1만큼 이동합니다.

트윈 범위는 객체가 시간 경과에 따라 변하는 하나 이상의 속성을 갖는 타임라인의 프레임 그룹입니다. 트윈 범위는 타임라인에서 단일 레이어의 파란색 배경이 있는 프레임 그룹으로 나타납니다. 이러한 트윈 범위는 단일 객체로 선택하여 타임라인의 한 위치에서 다른 레이어를 포함한 다른 위치로 드래그할 수 있습니다. 각 트윈 범위에서 스테이지에 있는 객체 하나만 애니메이션으로 만들 수 있습니다. 이 객체를 트윈 범위의 대상 객체라고 합니다.

속성 키프레임은 트윈 대상 객체에 대한 하나 이상의 속성 값이 명시적으로 정의된 트윈 범위 내 프레임입니다. 이러한 속성에는 위치, 알파(투명도), 색상 농도 등이 포함될 수 있습니다. 사용자가 정의하는 각 속성에는 고유의 속성 키프레임이 있습니다. 단일 프레임에 여러 개의 속성을 설정하면 이러한 속성의 각 속성 키프레임이 해당 프레임에 놓입니다. 모션 편집기에서 트윈 범위의 각 속성과 해당 속성 키프레임을 볼 수 있습니다. 트윈 범위 컨텍스트 메뉴에서 타임라인에 표시할 속성 키프레임의 유형을 선택할 수도 있습니다.

프레임 1에서 프레임 20으로 동영상 클립을 트위닝하는 앞의 예제에서는 프레임 1 및 프레임 20이 속성 키프레임입니다. 속성 관리자, 모션 편집기 및 Animate의 다른 많은 도구를 사용하여 애니메이션을 적용할 속성의 값을 정의할 수 있습니다. 선택한 프레임에서 이러한 속성 값을 지정하면 Animate에서 해당 트윈 범위에 필요한 속성 키프레임을 추가합니다. Animate에서는 만들어진 속성 키프레임 사이의 프레임에 이러한 각 속성의 값을 삽입합니다.

참고:

"키프레임"은 스테이지에서 심볼 인스턴스가 처음으로 나타나는 타임라인의 프레임을 의미합니다. "속성 키프레임"이라는 별도의 용어는 모션 트윈에서 특정 시간 또는 프레임에 객체의 속성에 대해 정의된 값을 의미합니다.

트위닝된 객체가 트위닝하는 동안 스테이지에서 위치를 변경하면 트윈 범위에 이와 연관된 모션 경로가 나타납니다. 이 모션 경로는 트위닝된 객체가 스테이지에서 이동하는 동안 따르는 경로입니다. 선택 도구, 세부 선택 도구, 앵커 변환 도구, 앵커 제거 도구, 자유 변형 도구수정 메뉴의 명령을 사용하여 스테이지의 모션 경로를 편집할 수 있습니다. 위치를 트위닝하지 않는 경우 스테이지에 모션 경로가 나타나지 않습니다. 타임라인의 트윈 범위에 기존 경로를 붙여넣어 이 경로를 모션 경로로 적용할 수도 있습니다.

트위닝된 애니메이션은 파일 크기를 최소화하면서 시간의 경과에 따라 움직이고 모양이 변경되는 효과를 만드는 데 매우 유용합니다. 트위닝된 애니메이션에서는 지정한 속성 키프레임 값만 FLA 파일에 저장되고 SWF 파일로 제작됩니다.

트위닝 가능한 객체 및 속성

트위닝할 수 있는 객체 유형에는 동영상 클립, 그래픽 및 버튼 심볼, 텍스트 필드 등이 있습니다. 트위닝할 수 있는 이러한 객체의 속성은 다음과 같습니다.

  • 2D X 및 Y 위치

  • 3D Z 위치 (동영상 클립만 해당)

  • 2D 회전(z축 주위)

  • 3D X, Y 및 Z 회전 (동영상 클립만 해당)

    3D 모션을 사용하려면 FLA 파일의 제작 설정에서 ActionScript 3.0 및 Flash Player 10 이상을 지정해야 합니다. Adobe AIR은 3D 모션도 지원합니다.

  • X 및 Y 기울이기

  • X 및 Y 배율

  • 색상 효과

    색상 효과에는 알파(투명도), 밝기, 농도 및 고급 색상 설정이 있습니다. 색상 효과는 심볼 및 TLF 텍스트에만 트위닝될 수 있습니다. 이러한 속성을 트위닝함으로써 객체가 페이드 인되거나 한 색상에서 다른 색상으로 페이드되는 것처럼 보이게 만들 수 있습니다.

    클래식 텍스트에서 색상 효과를 트위닝하려면 텍스트를 심볼로 변환하십시오.

  • 필터 속성(그래픽 심볼에는 필터를 적용할 수 없음)

모션 트윈과 클래식 트윈의 차이

Animate에서는 모션을 만드는 두 가지 유형의 트윈을 지원합니다. 모션 트윈은 기능이 강력하고 만들기 쉽습니다. 모션 트윈을 사용하면 트위닝된 애니메이션을 보다 세밀하게 제어할 수 있습니다. 이전 버전의 Animate에서 만든 모든 트윈을 포함하는 클래식 트윈은 만들기가 더 복잡합니다. 모션 트윈에서 트윈을 보다 많이 제어하는 반면 클래식 트윈에서는 일부 사용자에게 필요한 일부 특정 기능을 제공합니다.

모션 트윈과 클래식 트윈의 차이점은 다음과 같습니다.

  • 클래식 트윈은 키프레임을 사용합니다. 키프레임은 객체의 새 인스턴스가 나타나는 프레임입니다. 모션 트윈에는 하나의 객체 인스턴스만 연관될 수 있고 키프레임 대신 속성 키프레임을 사용합니다.

  • 모션 트윈은 전체 트윈 범위에 걸쳐 하나의 대상 객체로 구성됩니다. 클래식 트윈을 사용하면 같거나 서로 다른 심볼의 인스턴스를 포함하는 두 개의 키프레임 사이를 트위닝할 수 있습니다.

  • 모션 트윈과 클래식 트윈 모두 특정 유형의 객체만 트위닝할 수 있습니다. 허용되지 않는 객체 유형에 모션 트윈을 적용하면 트윈이 만들어질 때 Animate에서 해당 객체 유형을 동영상 클립으로 변환할 수 있습니다. 클래식 트윈을 적용하면 이러한 객체 유형이 그래픽 심볼로 변환됩니다.

  • 모션 트윈은 텍스트를 트위닝 가능 유형을 간주하고 텍스트 객체를 동영상 클립으로 변환하지 않습니다. 클래식 트윈은 텍스트 객체를 그래픽 심볼로 변환합니다.

  • 모션 트윈 범위에는 프레임 스크립트가 허용되지 않습니다. 클래식 트윈은 프레임 스크립트를 허용합니다.

  • 트윈 대상의 객체 스크립트는 모션 트윈 범위 중간에 변경할 수 없습니다.

  • 모션 트윈 범위는 타임라인에서 확장하거나 크기를 조절할 수 있으며 단일 객체로 취급합니다. 클래식 트윈은 타임라인에서 개별적으로 선택 가능한 프레임 그룹으로 구성됩니다.

  • 모션 트윈 범위에서 개별 프레임을 선택하려면 Ctrl 키(Windows) 또는 Command 키(Macintosh)를 누른 상태에서 프레임을 클릭합니다.

  • 클래식 트윈의 경우 트윈 내 키프레임 사이의 프레임 그룹에 부드럽게를 적용할 수 있습니다. 모션 트윈의 경우 모션 트윈 범위의 전체 길이에 걸쳐 부드럽게가 적용됩니다. 모션 트윈의 특정 프레임에만 부드럽게를 적용하려면 사용자 정의 부드러운 곡선을 만들어야 합니다.

  • 클래식 트윈을 사용하여 농도 및 알파 투명도와 같은 서로 다른 두 색상 효과 사이에 애니메이션을 적용할 수 있습니다. 모션 트윈은 트윈당 하나의 색상 효과를 적용할 수 있습니다.

  • 모션 트윈만 사용하여 3D 객체에 애니메이션을 적용할 수 있습니다. 클래식 트윈을 사용하여 3D 객체에 애니메이션을 적용할 수 없습니다.

  • 모션 트윈만 모션 프리셋으로 저장할 수 있습니다.

  • 모션 트윈의 경우 심볼을 교체하거나 속성 키프레임에 표시할 그래픽 심볼의 프레임 번호를 설정할 수 없습니다. 이러한 기술을 포함하는 애니메이션의 경우 클래식 트윈이 필요합니다.

  • 같은 레이어에 여러 개의 클래식 트윈 또는 모션 트윈이 있을 수는 있지만 두 가지 유형의 트윈 모두가 같은 레이어에 있을 수는 없습니다.

추가 리소스

다음 문서 및 리소스에서는 모션 트윈과 클래식 트윈 간의 차이점을 다룹니다.

모션 프리셋 적용

모션 프리셋은 스테이지의 객체에 적용할 수 있는 미리 구성된 모션 트윈입니다. 객체를 선택하고 모션 프리셋 패널에서 적용 버튼을 클릭하기만 하면 됩니다.

모션 프리셋을 사용하면 Animate에서 애니메이션을 추가하는 기본적인 방법을 신속하게 익힐 수 있습니다. 프리셋 작동 방식을 파악하면 자신만의 애니메이션을 쉽게 만들 수 있습니다.

사용자 정의 프리셋을 만들어 저장할 수도 있습니다. 즉, 기존 모션 프리셋을 수정하거나 사용자 정의 트윈을 직접 만들 수 있습니다.

모션 프리셋 패널에서는 프리셋을 가져오거나 내보낼 수도 있습니다. 공동 작업하는 사람들과 프리셋을 공유하거나 Animate 디자인 커뮤니티 멤버들이 공유하는 프리셋을 활용할 수 있습니다.

프리셋을 사용하면 프로젝트 제작 및 개발 과정에서 상당한 시간을 절약할 수 있습니다. 특히 비슷한 종류의 트윈을 자주 사용하는 경우 더욱 그렇습니다.

참고:

모션 프리셋에는 모션 트윈만 포함될 수 있습니다. 클래식 트윈은 모션 프리셋으로 저장할 수 없습니다.

모션 프리셋 미리 보기

Animate에 포함된 각 모션 프리셋에는 모션 프리셋 패널에서 확인할 수 있는 미리 보기가 있습니다. 미리 보기를 통해 애니메이션이 해당 문서의 객체에 적용되면 어떻게 나타날지 파악할 수 있습니다. 만들거나 가져오는 사용자 정의 프리셋의 경우 자체 미리 보기를 추가할 수 있습니다.

  1. 모션 프리셋 패널을 엽니다.

  2. 목록에서 모션 프리셋을 선택합니다.

    패널 위쪽의 미리 보기 창에서 미리 보기가 재생됩니다.

  3. 미리 보기의 재생을 멈추려면 모션 프리셋 패널의 바깥쪽을 클릭합니다.

모션 프리셋 적용

스테이지에서 트위닝 가능 객체(심볼 인스턴스 또는 텍스트 필드)를 선택한 상태로 적용 버튼을 클릭하면 프리셋이 적용됩니다. 객체당 하나의 프리셋만 적용할 수 있습니다. 하나의 객체에 두 번째 프리셋을 적용할 경우 첫 번째 프리셋이 두 번째 프리셋으로 바뀝니다.

스테이지에 있는 객체에 프리셋을 적용하면 타임라인에서 만들어진 트윈이 모션 프리셋 패널과 아무 관계 없어집니다. 모션 프리셋 패널에 있는 프리셋을 삭제하거나 이름을 변경해도 이전에 해당 프리셋으로 만든 트윈에는 영향을 주지 않습니다. 패널에서 기존 프리셋 위에 새 프리셋을 덮어 저장하는 경우 원래 프리셋으로 이미 만들어 놓은 트윈에는 영향을 주지 않습니다.

각 모션 프리셋에는 특정 개수의 프레임이 포함되어 있습니다. 프리셋을 적용하면 타임라인에서 만들어진 트윈 범위에 이 개수의 프레임이 포함됩니다. 대상 객체에 다른 길이의 트윈이 이미 적용된 경우 해당 모션 프리셋 길이에 맞게 트윈 범위가 조정됩니다. 프리셋이 적용된 후에 타임라인에서 트윈 범위의 길이를 조정할 수 있습니다.

3D 모션을 포함하는 모션 프리셋은 동영상 클립 인스턴스에만 적용할 수 있습니다. 그래픽 또는 버튼 심볼이나 클래식 텍스트 필드에는 트위닝된 3D 속성이 적용되지 않습니다. 2D 또는 3D 모션 프리셋은 2D 또는 3D 동영상 클립에 적용할 수 있습니다.

참고:

3D 동영상 클립의 z축 위치에 애니메이션 효과를 적용하는 모션 프리셋을 사용하면 동영상 클립의 x 및 y 위치가 변경된 것처럼 보일 수 있습니다. 3D 소실점(3D 심볼 인스턴스 속성 관리자에서 설정)에서 스테이지 가장자리까지 걸쳐 있는 보이지 않는 원근선 뒤에서 z축을 따라 이동이 발생하기 때문입니다.

모션 프리셋을 적용하려면

  1. 스테이지에서 트위닝 가능 객체를 선택합니다. 모션 프리셋을 트위닝 불가능 객체에 적용하려고 할 경우 객체를 심볼로 변환하도록 하는 대화 상자가 표시됩니다.

  2. 모션 프리셋 패널에서 프리셋을 선택합니다.

  3. 패널의 적용 버튼을 클릭하거나 패널 메뉴에서 현재 위치에 적용을 선택합니다.

    스테이지에 있는 동영상 클립의 현재 위치에서 모션이 시작되도록 모션이 적용됩니다. 프리셋에 연관된 모션 경로가 있는 경우 해당 모션 경로가 스테이지에 표시됩니다.

    스테이지에 있는 객체의 현재 위치에서 모션이 끝나도록 프리셋을 적용하려면 Shift 키를 누른 상태에서 적용 버튼을 클릭하거나 패널 메뉴에서 현재 위치에서 종료를 선택합니다.

선택된 각 프레임에 트위닝 가능 객체가 하나씩만 포Before working with motion tweens, become familiar with the basic use of the함되어 있을 경우 별도 레이어에 있는 선택된 프레임 여러 개에 모션 프리셋을 적용할 수도 있습니다.

트윈을 사용자 정의 모션 프리셋으로 저장

자체 트윈을 만들거나 모션 프리셋 패널에서 적용한 트윈을 변경하는 경우 이를 새 모션 프리셋으로 저장할 수 있습니다. 모션 프리셋 패널의 사용자 정의 프리셋 폴더에 새로운 프리셋이 나타납니다.

사용자 정의 트윈을 프리셋으로 저장하려면

  1. 다음 중 하나를 선택합니다.
    • 타임라인에서의 트윈 범위
    • 사용자 정의 트윈이 적용된 스테이지의 객체
    • 스테이지에 있는 모션 경로
  2. 모션 프리셋 패널의 선택 항목을 프리셋으로 저장 버튼을 클릭하거나 선택 항목의 컨텍스트 메뉴에서 모션 프리셋으로 저장을 선택합니다.

    모션 프리셋 패널에 새로운 프리셋이 나타납니다. Animate가 프리셋을 XML 파일로 저장합니다. 이러한 파일은 다음 디렉토리에 저장됩니다.

    • Windows: <하드 디스크>\Documents and Settings\<사용자>\Local Settings\Application Data\Adobe\Animate CC\<언어>\Configuration\Motion Presets\

    • Macintosh: <하드 디스크>/Users/<사용자>/Library/Application Support/Adobe/Animate CC/<언어>/Configuration/Motion Presets/

참고:

사용자 정의 프리셋을 저장, 삭제 또는 이름 변경한 경우 실행 취소할 수 없습니다.

모션 프리셋 가져오기

모션 프리셋은 XML 파일로 저장됩니다. XML 트윈 파일을 가져와서 모션 프리셋 패널에 추가합니다. 참고로, XML 파일로 가져온 모션 프리셋은 클래식 트윈에만 추가할 수 있습니다.

  1. 모션 프리셋 패널 메뉴에서 [가져오기]를 선택합니다.

  2. 열기 대화 상자에서 가져올 XML 파일을 찾아 열기를 클릭합니다.

Animate에서 XML 파일이 열리고 모션 프리셋이 패널에 추가됩니다.

모션 프리셋 내보내기

모션 프리셋을 XML 파일로 내보내 다른 Animate 사용자와 공유할 수 있습니다.

  1. 모션 프리셋 패널에서 프리셋을 선택합니다.

  2. 패널 메뉴에서 내보내기를 선택합니다.

  3. 다른 이름으로 저장 대화 상자에서 XML의 이름 및 저장 위치를 선택하고 저장을 클릭합니다.

모션 프리셋 삭제

모션 프리셋 패널에서 프리셋을 제거할 수 있습니다. 프리셋을 제거하면 Animate가 해당 XML 파일을 디스크에서 삭제합니다. 나중에 다시 사용하려는 프리셋이 있으면 먼저 복사본을 백업하여 내보내는 것이 좋습니다.

  1. 모션 프리셋 패널에서 삭제할 프리셋을 선택합니다.

  2. 다음 중 하나를 수행합니다.
    • 패널 메뉴에서 제거를 선택합니다.
    • 패널에서 항목의 제거 버튼을 클릭합니다.

사용자 정의 프리셋 미리 보기 만들기

사용자 정의 모션 프리셋의 미리 보기를 만들 수 있습니다. 트위닝된 애니메이션을 보여주는 SWF 파일을 모션 프리셋 XML 파일과 같은 디렉토리에 저장하면 됩니다.

  1. 트위닝된 애니메이션을 만들어 사용자 정의 프리셋으로 저장합니다.
  2. 트윈의 데모만 포함한 FLA 파일을 만듭니다. 사용자 정의 프리셋과 같은 이름으로 FLA를 저장합니다.
  3. 제작 명령을 사용하여 FLA 파일에서 SWF 파일을 만듭니다.

  4. SWF 파일을 저장된 사용자 정의 모션 프리셋 XML 파일과 같은 디렉토리에 넣습니다. 이러한 파일은 다음 디렉토리에 저장됩니다.
    • Windows: <하드 디스크>\Documents and Settings\<사용자>\Local Settings\Application Data\Adobe\Animate CC\<언어>\Configuration\Motion Presets\
    • Macintosh: <하드 디스크>/Users/<사용자>/Library/Application Support/Adobe/Animate CC/<언어>/Configuration/Motion Presets/

이제 모션 프리셋 패널에서 사용자 정의 트윈이 선택되면 미리 보기가 표시됩니다.

트윈 애니메이션 만들기

트위닝된 애니메이션을 만들기 위한 단계

시작하기 전에

속성에 애니메이션 적용을 시작하기 전에 다음을 염두에 두십시오.

ActionScript는 필요하지 않음. Animate에 있는 여러 항목과 마찬가지로 애니메이션은 ActionScript를 필요로 하지 않습니다. 하지만 원하는 경우에는 ActionScript를 사용하여 애니메이션을 만들 수 있습니다.

타임라인 및 속성 편집의 기초. 모션 트윈에 대한 작업을 시작하기 전에 타임라인 및 속성 편집의 기본적인 사용법에 익숙해지십시오. 기본 원리에 대해 배우려면 프레임 및 키프레임을 참조하십시오.

스테이지, 속성 관리자 또는 모션 편집기에서 개별적으로 속성 키프레임을 편집할 수 있습니다. 다양한 유형의 단순 모션 트윈을 만들 때 모션 편집기를 사용해도 되고 안 해도 됩니다.

모션 편집기는 Animate CC에서 더 이상 사용되지 않습니다.

심볼 인스턴스 및 텍스트 필드만. Animate는 심볼 인스턴스 및 텍스트 필드만 트위닝합니다. 다른 모든 객체 유형은 트윈 적용 시 심볼에 래핑됩니다. 심볼 인스턴스에는 중첩된 심볼이 포함될 수 있으며, 중첩된 심볼은 자체 타임라인에서 트위닝될 수 있습니다.

한 트윈에 하나의 객체. 트윈 레이어의 최소 기본 단위는 트윈 범위입니다. 트윈 레이어의 트윈 범위는 하나의 심볼 인스턴스 또는 텍스트 필드만 포함할 수 있습니다. 심볼 인스턴스는 트윈 범위의 대상이라고 합니다. 하지만 단일 심볼이 여러 개의 객체를 포함할 수 있습니다.

대상 변경. 트윈 범위에 두 번째 심볼 또는 텍스트 필드를 추가하면 트윈에 원래 있던 심볼이 바뀝니다. 다른 심볼을 라이브러리에서 타임라인의 트윈 범위로 드래그하거나, 수정 > 심볼 > 심볼 교체 명령을 사용하여 트윈의 대상 객체를 변경할 수 있습니다. 트윈을 제거하거나 분리하지 않고 트윈 레이어에서 심볼을 삭제할 수 있습니다. 그러면 나중에 다른 심볼 인스턴스를 트윈에 추가할 수 있습니다. 언제든지 대상 심볼의 유형을 변경하거나 심볼을 편집할 수도 있습니다.

모션 경로 편집. 트윈에 모션이 포함된 경우 모션 경로가 스테이지에 표시됩니다. 모션 경로는 각 프레임에서 트위닝된 객체의 위치를 보여 줍니다. 제어점을 드래그하여 스테이지에서 모션 경로를 편집할 수 있습니다. 트윈/역기구학 레이어에는 모션 안내선을 추가할 수 없습니다.

역기구학을 사용한 트윈에 대한 자세한 내용은 뼈대 애니메이션 만들기를 참조하십시오.

트윈이 타임라인에 추가되는 방법

레이어에 있는 객체에 트윈을 추가하면 Animate가 다음 중 하나를 수행합니다.

  • 레이어를 트윈 레이어로 변환합니다.

  • 레이어에 있는 객체의 원래 쌓인 순서를 유지하기 위해 새 레이어를 만듭니다.

레이어는 다음과 같은 규칙에 따라 추가됩니다.

  • 레이어에 선택된 객체 외에 다른 객체가 없을 경우 레이어는 트윈 레이어로 변경됩니다.

  • 선택 항목이 레이어의 쌓인 순서에서 맨 아래에 있는 경우(다른 모든 객체의 아래에 있음) Animate는 원래 레이어 위에 레이어를 만듭니다. 이 새 레이어 안에는 선택되지 않은 항목이 있습니다. 원래 레이어가 트윈 레이어가 됩니다.

  • 선택 항목이 레이어의 쌓인 순서에서 맨 위에 있는 경우(다른 모든 객체의 위에 있음) Animate는 새 레이어를 만듭니다. 선택 항목이 새 레이어로 이동하고, 해당 레이어가 트윈 레이어가 됩니다.

  • 선택 항목이 레이어의 쌓인 순서에서 중간에 있는 경우(해당 선택 항목의 위와 아래에 모두 객체가 있음) Animate는 두 개의 레이어를 만듭니다. 한 레이어 안에는 새 트윈이 있고, 그 위에 있는 다른 레이어 안에는 쌓인 순서 위쪽에 있는 선택되지 않은 항목이 있습니다. 쌓인 순서 아래쪽에 있는 선택되지 않은 항목은 새로 삽입된 레이어 아래쪽의 원래 레이어에 보관됩니다.

트윈 레이어에는 트윈 범위를 비롯하여 정적 프레임과 ActionScript가 포함될 수 있지만, 트윈 범위가 들어 있는 트윈 레이어의 프레임에는 트위닝된 객체 이외의 객체가 포함될 수 없습니다. 동일한 프레임에서 객체를 추가하려면 별도의 레이어에 배치하십시오.

트윈으로 위치에 애니메이션 적용

객체가 스테이지에서 이동하거나 미끄러지도록 만들려면

  1. 스테이지에서 트위닝할 심볼 인스턴스 또는 텍스트 필드를 선택합니다. 객체는 일반, 안내선, 마스크 또는 마스크 처리와 같은 레이어 유형 중 하나에 포함될 수 있습니다.

    선택 항목에 다른 객체가 포함되어 있거나 한 레이어의 여러 객체가 포함되어 있는 경우 Animate는 해당 선택 항목을 동영상 클립 심볼로 변환할 것을 제안합니다.

    선택 항목을 반전하려면 객체를 마우스 오른쪽 버튼으로 클릭하고 선택 항목 반전을 선택합니다.

     
  2. 다음 중 하나를 수행합니다.

    • 삽입 > 모션 트윈을 선택합니다.

    • 선택 항목 또는 현재 프레임을 마우스 오른쪽 버튼으로 클릭(Windows)하거나 Control 키를 누른 상태에서 클릭(Macintosh)하여 컨텍스트 메뉴에서 모션 트윈 생성을 선택합니다.

    트윈을 위해 선택 항목을 심볼로 변환” 대화 상자가 나타나면 [확인]을 클릭하여 선택 항목을 동영상 클립 심볼로 변환합니다.

    트위닝된 객체가 레이어의 유일한 항목인 경우 Animate는 객체가 포함된 레이어를 트윈 레이어로 변환합니다. 레이어에 다른 객체가 있으면 Animate가 레이어를 삽입하여 쌓기 순서를 유지합니다. Animate는 트위닝된 객체를 자체 레이어에 배치합니다.

    원래 객체가 타임라인의 첫 번째 프레임에만 있을 경우 트윈 범위의 길이는 1초와 같습니다. 원래 객체가 연속된 두 개 이상의 프레임에 있었던 경우 트윈 범위는 원래 객체가 차지한 프레임 수를 포함하게 됩니다.

  3. 타임라인의 트윈 범위 끝을 드래그하여 범위를 원하는 프레임 수로 줄이거나 늘립니다. 트윈에 있는 기존 속성 키프레임은 범위의 끝과 비례하여 이동합니다.

    기존 키프레임을 이동하지 않고 범위의 끝을 이동하려면 Shift 키를 누른 채로 트윈 범위의 끝을 드래그합니다.

  4. 트윈에 모션을 추가하려면 트윈 범위 내 프레임에 재생 헤드를 배치하고 객체를 새 위치로 드래그합니다.

    트윈 범위의 첫 번째 프레임이 있는 위치에서 새 위치로의 경로를 나타내는 모션 경로가 스테이지에 표시됩니다. 사용자가 객체의 X 및 Y 속성을 명시적으로 정의했으므로 재생 헤드를 포함하는 프레임에서 X 및 Y에 대해 속성 키프레임이 추가됩니다. 속성 키프레임이 트윈 범위에 작은 마름모로 표시됩니다.

    참고:

    기본적으로 타임라인에는 모든 속성 유형의 속성 키프레임이 표시됩니다. 트윈 범위를 마우스 오른쪽 버튼으로 클릭(Windows)하거나 Command 키를 누른 상태에서 클릭(Macintosh)하고 키프레임 보기 > 속성 유형을 선택하여 표시할 속성 키프레임의 유형을 선택할 수 있습니다.

  5. 객체에 다른 위치를 지정하려면 트윈 범위 내 다른 프레임에 재생 헤드를 배치하고 스테이지의 객체를 다른 위치로 드래그합니다.

    지정한 모든 위치를 포함하도록 모션 경로가 조정됩니다.

  6. 3D 회전 또는 위치를 트위닝하려면 3D 회전 또는 3D 평행 이동 도구를 사용합니다. 먼저 3D 속성 키프레임을 추가할 프레임에 재생 헤드를 배치해야 합니다.

참고:

한 번에 트윈을 여러 개 만들려면 트위닝 가능 객체를 여러 레이어에 배치하고 모두 선택한 후 삽입 > 모션 트윈을 선택합니다. 동일한 방법으로 여러 객체에 모션 프리셋을 적용할 수도 있습니다.

속성 관리자를 사용하여 다른 속성 트위닝

모션 트윈 만들기 명령을 사용하여 회전, 배율, 투명도, 농도(심볼 및 TLF 텍스트만 해당) 같은 심볼 인스턴스 또는 텍스트 필드의 대다수 속성에 애니메이션을 적용할 수 있습니다. 예를 들어 심볼 인스턴스의 알파(투명도) 속성을 편집하여 화면으로 페이드 인되도록 할 수 있습니다. 모션 트윈을 사용하여 애니메이션을 적용할 수 있는 속성의 목록은 트윈 가능한 객체 및 속성을 참조하십시오.

  1. 스테이지에서 심볼 인스턴스 또는 텍스트 필드를 선택합니다.

    선택 항목에 다른 객체가 포함되어 있거나 한 레이어의 여러 객체가 포함되어 있는 경우 Animate는 선택 항목을 동영상 클립 심볼로 변환할 것을 제안합니다.

  2. 삽입 > 모션 트윈을 선택합니다.

    트윈을 위해 선택 항목을 심볼로 변환” 대화 상자가 나타나면 [확인]을 클릭하여 선택 항목을 동영상 클립 심볼로 변환합니다.

    단일 키프레임에만 있는 객체에 트윈을 적용하면 재생 헤드가 새 트윈의 마지막 프레임으로 이동합니다. 그렇지 않으면 재생 헤드가 이동하지 않습니다.

  3. 속성 값을 지정하려는 트윈 범위의 프레임에 재생 헤드를 배치합니다.

    재생 헤드를 트윈 범위의 다른 프레임에 배치할 수 있습니다. 트윈은 트윈 범위에서 첫 번째 프레임의 속성 값으로 시작합니다. 이 프레임이 항상 속성 키프레임이 됩니다.

  4. 스테이지에서 객체를 선택한 상태로 알파(투명도), 회전, 기울이기 같은 위치 이외의 속성 값을 설정합니다. 속성 관리자도구 패널의 도구 중 하나를 사용하여 값을 설정합니다.

    범위의 현재 프레임이 속성 키프레임이 됩니다.

    참고:

    트윈 범위에 있는 속성 키프레임의 다양한 유형을 표시할 수 있습니다. 선택 항목을 마우스 오른쪽 버튼으로 클릭(Windows)하거나 Control 키를 누른 상태에서 클릭(Macintosh)하고 컨텍스트 메뉴에서 키프레임 보기 > 속성 유형을 선택합니다.

  5. 타임라인에서 재생 헤드를 이동하여 스테이지에서 트윈을 미리 봅니다.

  6. 속성 키프레임을 추가하려면 재생 헤드를 범위의 원하는 프레임으로 이동시키고 속성 관리자에서 속성 값을 설정합니다.

기존 트윈 레이어에 트윈 추가

기존 트윈 레이어에 트윈을 추가할 수 있습니다. 그러면 애니메이션이 있는 Animate 내용을 만들 때 더 적은 수의 레이어를 사용할 수 있습니다.

  • 다음 중 하나를 수행합니다.
    • 레이어에 빈 키프레임을 추가(삽입 > 타임라인 > 빈 키프레임)하고, 키프레임에 항목을 추가한 다음 항목을 트위닝합니다.
    • 별도의 레이어에 트윈을 만든 다음 범위를 원하는 레이어로 드래그합니다.
    • 정적 프레임을 다른 레이어에서 트윈 레이어로 드래그한 후 정적 프레임의 객체에 트윈을 추가합니다.
    • Alt 키(Windows) 또는 Option 키(Macintosh)를 누른 채 드래그하여 같은 레이어 또는 다른 레이어에 있는 기존 범위를 복제합니다.
    • 같은 레이어 또는 다른 레이어에서 트윈 범위를 복사하여 붙여 넣습니다.

참고:

트윈 범위의 아무 프레임에서나 모션 트윈의 대상 객체를 클립보드로 복사할 수 있습니다.

트윈 애니메이션의 모션 경로 편집

다음과 같은 방법으로 모션 트윈의 모션 경로를 편집하거나 변경할 수 있습니다.

  • 트윈 범위의 프레임에서 객체의 위치를 변경합니다.

  • 전체 모션 경로를 스테이지의 다른 위치로 이동합니다.

  • 선택 도구, 세부 선택 도구 또는 자유 변형 도구를 사용하여 경로의 모양이나 크기를 변경합니다.

  • 변형 패널 또는 속성 관리자를 사용하여 경로의 모양이나 크기를 변경합니다.

  • 수정 > 변형 메뉴의 명령을 사용합니다.

  • 사용자 정의 획을 모션 경로로 적용합니다.

  • 모션 편집기를 사용합니다.

모션 경로 항상 표시 옵션을 사용하여 스테이지에 있는 모든 레이어의 모든 모션 경로를 동시에 표시할 수 있습니다. 이와 같이 표시하면 상호 교차하는 서로 다른 모션 경로에 대해 여러 애니메이션을 디자인할 때 유용합니다. 모션 경로나 트윈 범위가 선택되어 있을 때 속성 관리자 옵션 메뉴에서 이 옵션을 선택할 수 있습니다.

선택 도구 및 세부 선택 도구를 사용하여 모션 경로의 모양 편집

선택 도구 및 세부 선택 도구를 사용하여 모션 경로를 변형할 수 있습니다. 선택 도구를 사용하여 세그먼트를 드래그하여 변형할 수 있습니다. 트윈의 속성 키프레임은 경로에 제어점으로 표시됩니다. 세부 선택 도구를 사용하여 각 위치 속성 키프레임에 해당하는 경로의 제어점 및 베지어 핸들을 표시할 수 있습니다. 이러한 핸들을 사용하여 속성 키프레임 지점 주위 경로를 변형할 수 있습니다.

원과 같이 직선이 아닌 모션 경로를 만드는 경우 경로를 따라 이동 시 트위닝된 객체를 회전해야 할 수 있습니다. 경로를 기준으로 일정 방향을 유지하려면 속성 관리자에서 경로 방향으로 옵션을 선택합니다.

모션 경로(왼쪽) 방향이 아닌 모션 경로(오른쪽)로 트위닝된 객체입니다.

  1. 도구 패널에서 선택 도구를 클릭합니다.

  2. 스테이지에서 모션 경로가 표시되도록 트윈 대상 인스턴스를 클릭합니다.

  3. 선택 도구를 사용하여 모션 경로의 세그먼트를 드래그하여 변형합니다. 먼저 세그먼트를 클릭하여 선택하면 안 됩니다.

  4. 경로에서 속성 키프레임 지점의 베지어 제어점을 표시하려면 세부 선택 도구를 클릭한 후 경로를 클릭합니다.

    속성 키프레임 지점은 모션 경로 위에 제어점(작은 마름모)으로 표시됩니다.

  5. 제어점을 이동하려면 세부 선택 도구를 사용하여 드래그합니다.

  6. 제어점 주위에서 경로의 곡선을 조정하려면 세부 선택 도구로 제어점의 베지어 핸들을 드래그합니다.

    핸들이 확장되어 있지 않으면 Alt 키(Windows) 또는 Option 키(Macintosh)를 누른 상태에서 제어점을 드래그하여 핸들을 확장할 수 있습니다.

  7. 앵커 포인트를 삭제하려면 앵커 포인트 삭제 도구를 사용하여 클릭합니다. 선택 도구로 생성되는 대부분의 앵커 포인트는 둥근점입니다. 앵커 포인트를 변환하려면 앵커 포인트 변환 도구를 사용하여 클릭합니다. 그러면 앵커가 각도 포인트로 변경됩니다.

  8. 일반 앵커 포인트에서와 마찬가지로 포인트에서 새 베지어 핸들을 꺼내서 배치할 수도 있습니다.

    참고:

    앵커 포인트 추가 도구를 사용하여 경로에 앵커 포인트를 추가할 수는 없습니다.

트위닝된 객체의 위치 변경

모션 경로를 편집하는 가장 간단한 방법은 트윈 범위의 프레임에서 스테이지에 있는 트윈의 대상 인스턴스를 이동하는 것입니다. 현재 프레임에 아직 속성 키프레임이 없으면 Animate에서 속성 키프레임을 추가합니다.

  1. 대상 인스턴스를 이동하려는 프레임에 재생 헤드를 배치합니다.
  2. 선택 도구를 사용하여 대상 인스턴스를 스테이지의 새 위치로 드래그합니다.

새 위치를 포함하도록 모션 경로가 업데이트됩니다. 모션 경로의 기타 모든 속성 키프레임은 원래 위치에 유지됩니다.

스테이지에서 모션 경로의 위치 변경

스테이지에서 전체 모션 경로를 드래그하거나 속성 관리자에서 해당 위치를 설정할 수 있습니다.

  1. [도구] 패널에서 [선택 도구]를 클릭합니다.
  2. 다음 중 하나를 수행하여 모션 경로를 선택합니다.
    • 타임라인에서 트윈 범위를 클릭한 후에 스테이지에서 모션 경로를 클릭합니다.
    • 스테이지에서 트위닝된 객체를 클릭한 후에 모션 경로를 클릭합니다.
    • 윤곽을 모션 경로 및 대상 인스턴스 주위로 드래그하여 모두 선택합니다.
  3. 다음 중 하나를 수행하여 모션 경로를 이동합니다.
    • 스테이지에서 경로를 원하는 위치로 드래그합니다.
    • 속성 관리자에서 경로의 X 및 Y 값을 설정합니다. X 값 및 Y 값은 모션 경로 경계 상자의 왼쪽 위 모서리에 있습니다.
    • 화살표 키를 사용하여 모션 경로를 이동합니다.

참고:

모션 경로의 위치를 지정하여 트윈 대상 인스턴스 및 모션 경로를 이동시키려면 인스턴스와 경로를 모두 선택한 다음 속성 관리자에서 X 및 Y 위치를 입력합니다. 모션 경로가 없는 트위닝된 객체를 이동시키려면 해당 객체를 선택한 다음 속성 관리자에서 X 및 Y 값을 입력합니다.

자유 변형 도구를 사용하여 모션 경로 편집

  1. 도구 패널에서 자유 변형 도구를 클릭합니다.

  2. 자유 변형 도구를 사용하여 모션 경로를 클릭합니다. 트윈 대상 인스턴스는 클릭하면 안 됩니다.

  3. 자유 변형 도구를 사용하여 경로를 크기 조절, 기울이기 또는 회전합니다.

참고:

또한 세부 선택 도구로 선택한 다음 Ctrl 키(Windows) 또는 Command 키(Macintosh)를 눌러 모션 경로에서 자유 변형을 수행할 수도 있습니다. 이 키를 누르면 자유 변형 도구와 동일한 컨트롤이 표시됩니다. 그런 다음 키를 누른 상태로 드래그하여 변형을 수행할 수 있습니다.

재생 헤드는 트윈의 첫 번째 프레임에 있기 때문에 크기 조절은 모든 트위닝된 프레임에 적용됩니다. 새로운 속성 키프레임이 만들어지지 않습니다.

트윈에서 모션 경로 삭제

  1. 선택 도구를 사용하여 스테이지에서 모션 경로를 클릭하여 선택합니다.

  2. Delete 키를 누릅니다.

모션 경로를 획으로 복사

  1. 스테이지에서 모션 경로를 클릭하여 선택합니다.

  2. 편집 > 복사를 선택합니다.

그리고 나서 경로를 다른 레이어에 다른 모션 트윈에 대한 모션 경로 또는 획으로 붙여넣을 수 있습니다.

사용자 정의 획을 모션 경로 적용

별도의 레이어 또는 별도의 타임라인의 획을 트윈의 모션 경로로 적용할 수 있습니다.

  1. 트윈 레이어와 별도의 레이어에 있는 획을 선택하고 클립보드에 복사합니다.

    획은 닫혀 있으면 안 됩니다. 끊기지 않은 획만 사용할 수 있습니다.

  2. 타임라인에서 트윈 범위를 선택합니다.

  3. 트윈 범위를 여전히 선택한 상태로 획을 붙여넣습니다.

    Animate에서 이 획을 선택된 트윈 범위에 대한 새로운 모션 경로로 적용합니다. 이제 트윈의 대상 인스턴스가 새로운 획을 따라 이동합니다.

  4. 트윈의 시작점과 끝점을 반대로 바꾸려면 트윈 범위를 마우스 오른쪽 버튼으로 클릭(Windows)하거나 Control 키를 누른 상태에서 클릭(Macintosh)하고 트윈 범위 컨텍스트 메뉴에서 모션 경로 > 경로 반전을 선택합니다.

로빙 속성 키프레임 사용

로빙 속성 키프레임은 타임라인의 특정 프레임에 연결되지 않은 키프레임입니다. Animate에서는 모션 속도가 트윈 전체에서 일관되도록 로빙 키프레임의 위치를 조정합니다.

로빙 키프레임은 공간적 속성인 X, Y 및 Z에만 사용할 수 있습니다. 트위닝된 객체를 다른 프레임의 다른 위치로 드래그하여 스테이지에서 모션 경로를 편집한 경우 이러한 키프레임이 유용합니다. 이 방법으로 모션 경로를 편집하면 주로 모션이 다른 선분보다 빠르거나 느린 경로 선분이 만들어집니다. 이는 경로 선분의 프레임 수가 다른 선분의 경우보다 크거나 작기 때문입니다.

애니메이션 속도를 트윈 전체에서 일관되게 설정하는 경우 로빙 속성 키프레임을 사용하는 것이 좋습니다. 속성 키프레임이 로빙으로 설정되면 Animate에서는 트위닝된 객체가 트윈의 각 프레임에서 동일한 거리를 이동하도록 트윈 범위에서 속성 키프레임의 위치를 조정합니다. 그리고 나서 트윈의 시작 및 끝에 있는 가속의 모양이 실감나도록 부드럽게를 사용하여 이동을 조정할 수 있습니다.

사용자 정의 경로를 트윈에 붙여넣으면 Animate에서 속성 키프레임을 기본적으로 로빙으로 설정합니다.

전체 트윈에 대해 로빙 키프레임을 활성화하려면

  • 타임라인에서 트윈 범위를 마우스 오른쪽 버튼으로 클릭(Windows)하거나 Command 키를 누른 상태에서 클릭(Macintosh)하고 컨텍스트 메뉴에서 모션 경로 > 키프레임을 로빙으로 전환을 선택합니다.

트윈의 개별 속성 키프레임에 대해 로빙을 활성화하려면

  • 모션 편집기에서 속성 키 프레임을 마우스 오른쪽 버튼으로 클릭(Windows)하거나 Command 키를 누른 상태에서 클릭(Macintosh)한 다음 컨텍스트 메뉴에서 로빙을 선택합니다. 모션 편집기에 대한 자세한 내용은 모션 편집기를 사용한 속성 곡선 편집을 참조하십시오.

속성 키프레임이 로빙으로 설정되면 모션 편집기에 사각형 대신 둥근점으로 표시됩니다.

참고:

트윈 범위에 대한 로빙 키프레임을 활성화한 다음 비활성화하는 경우 키프레임은 로빙 활성화 결과로 범위에서 자신의 위치를 유지합니다.

로빙 키프레임이 해제된 모션 경로입니다. 프레임이 고르지 않게 분포되어 모션 속도가 고르지 않게 됩니다.

로빙 키프레임이 설정된 동일한 모션 경로로, 경로를 따라 프레임이 고르게 분포되고 모션 속도가 고르게 됩니다.

트윈 범위의 속성 키프레임 보기 및 편집

  • 한 범위에서 서로 다른 속성에 대한 속성 키프레임을 포함하는 프레임을 보려면 해당 범위를 선택하고 범위 컨텍스트 메뉴에서 키프레임 보기를 선택한 후 하위 메뉴에서 속성 유형을 선택합니다.

  • 범위에서 속성 키프레임을 제거하려면 Ctrl 키(Windows) 또는 Command 키(Macintosh)를 누른 상태에서 속성 키프레임을 클릭하여 선택한 다음 속성 키프레임을 마우스 오른쪽 버튼으로 클릭(Windows)하거나 Control 키 누른 상태에서 클릭(Macintosh)하고 키프레임을 삭제할 속성 유형에 대해 키프레임 지우기를 선택합니다.

  • 범위에 특정 속성 유형의 속성 키프레임을 추가하려면 Ctrl 키(Windows) 또는 Command 키(Macintosh)를 클릭하여 범위에서 프레임을 하나 이상 선택합니다. 마우스 오른쪽 버튼을 클릭(Windows)하거나 Control 키를 누른 상태에서 클릭(Macintosh)하고 범위 컨텍스트 메뉴에서 키프레임 삽입 > 속성 유형을 선택합니다. Animate에서 선택한 프레임에 속성 키프레임을 추가합니다. 속성 키프레임을 추가하기 위해 선택한 프레임에서 대상 인스턴스의 속성을 설정할 수도 있습니다.

  • 범위에 모든 속성 유형의 속성 키프레임을 추가하려면 키프레임을 추가할 프레임에 재생 헤드를 배치하고 삽입 > 타임라인 > 키프레임을 선택하거나 F6 키를 누릅니다.

  • 트윈의 모션 방향을 반대로 바꾸려면 범위 컨텍스트 메뉴에서 모션 경로 > 경로 반전을 선택합니다.

  • 트윈 범위를 정적 프레임으로 변경하려면 해당 범위를 선택하고 범위 컨텍스트 메뉴에서 트윈 제거를 선택합니다.

  • 트윈 범위를 프레임별 애니메이션으로 변환하려면 해당 범위를 선택하고 범위 컨텍스트 메뉴에서 프레임별 애니메이션으로 변환을 선택합니다.

  • 속성 키프레임을 동일한 트윈 범위 또는 다른 트윈 범위의 다른 프레임으로 이동하려면 Ctrl 키(Windows) 또는 Command 키(Macintosh)를 누른 상태에서 속성 키프레임을 클릭하여 선택한 다음 속성 키프레임을 새 위치로 드래그합니다.

  • 속성 키프레임을 트윈 범위의 다른 위치에 복사하려면 Ctrl 키(Windows) 또는 Command 키(Macintosh)를 누른 상태에서 속성 키프레임을 클릭하여 선택한 다음 Alt 키(Windows) 또는 Option 키(Macintosh)를 누른 상태에서 속성 키프레임을 새 위치로 드래그합니다.

트윈에 3D 속성 키프레임 추가 또는 제거

  • 다음 중 하나를 수행합니다.
    • 도구 패널에서 3D 도구를 사용하여 3D 속성을 추가합니다.
    • 타임라인의 트윈 범위를 마우스 오른쪽 버튼으로 클릭(Windows)하거나 Control 키를 누른 상태에서 클릭(Macintosh)하고 컨텍스트 메뉴에서 3D 트윈을 선택합니다.
    • 트윈 범위에 3D 속성 키프레임이 없는 경우 Animate에서는 각각의 기존 X/Y 위치 및 회전 속성 키프레임에 3D 속성 키프레임을 추가합니다. 트윈 범위에 이미 3D 속성 키프레임이 포함되어 있는 경우 Animate에서는 해당 3D 속성 키프레임을 제거합니다.

트윈 범위 이동 또는 복제

타임라인 패널에서 드래그함으로써 트윈 범위 또는 트윈 범위의 일부를 복제하거나 이동할 수 있습니다.

  • 타임라인에서 다른 위치로 이동하려면 트윈 범위를 드래그합니다.

  • 타임라인에서 새 위치에 복제하려면 Alt 키를 누른 채로 트윈 범위를 드래그합니다.

모션 트윈 복사하여 붙여넣기

한 트윈 범위에서 다른 트윈 범위로 트위닝된 속성을 복사할 수 있습니다. 트위닝된 속성은 새 대상 객체에 적용되지만 대상 객체의 위치는 변경되지 않습니다. 이 기능을 통해 새 대상 객체의 위치를 변경하지 않고 스테이지의 한 영역에 있는 트윈을 다른 영역의 객체에 적용할 수 있습니다.

  1. 복사할 트위닝된 속성이 포함된 트윈 범위를 선택합니다.
  2. 편집 > 타임라인 > 모션 복사를 선택합니다.

  3. 복사한 트윈을 받을 트윈 범위를 선택합니다.
  4. 편집 > 타임라인 > 모션 붙여넣기를 선택합니다.

    Animate에서 트위닝된 속성을 대상 트윈 범위에 적용하고 복사한 트윈 범위에 맞게 트윈 범위의 길이를 조정합니다.

    모션 트윈을 액션 패널에 복사하거나 다른 프로젝트에서 ActionScript®로 사용하려면 ActionScript 3.0으로 모션 복사 명령을 사용하십시오.

모션 트윈 속성 복사하여 붙여넣기

선택한 프레임의 속성을 동일한 트윈 범위 또는 다른 트윈 범위의 다른 프레임에 복사할 수 있습니다. 이때 속성 값은 속성을 붙여넣을 당시 선택된 프레임에만 추가됩니다. 해당 프레임의 트위닝된 객체에 색상 효과, 필터 또는 3D 속성이 이미 적용되어 있는 경우에만 색상 효과, 필터 및 3D 속성의 복사된 속성 값을 붙여넣습니다. 2D 위치 속성은 3D 트윈에 붙여넣을 수 없습니다.

이러한 지침에서는 환경 설정(편집 > 환경 설정)에서 범위에 따라 선택이 설정되어 있다고 가정합니다.

  1. 트윈 범위에서 단일 프레임을 선택하려면 Ctrl+Alt(Windows) 또는 Command+Option(Macintosh)을 누른 채로 프레임을 클릭합니다.
  2. 선택한 프레임을 마우스 오른쪽 버튼으로 클릭(Windows)하거나 Control 키를 누른 상태에서 클릭(Macintosh)하고 컨텍스트 메뉴에서 속성 복사를 선택합니다.

  3. Ctrl+Alt(Windows) 또는 Command+Option(Macintosh)을 누른 상태에서 프레임을 클릭하여 복사한 속성을 받을 단일 프레임을 선택합니다.

    대상 프레임은 트윈 범위에 있어야 합니다.

  4. 복사한 속성을 선택한 프레임에 붙여넣으려면 다음 중 하나를 수행합니다.
    • 복사된 속성을 모두 붙여넣으려면 대상 트윈 범위의 선택한 프레임을 마우스 오른쪽 버튼으로 클릭(Windows)하거나 Command 키를 누른 상태에서 클릭(Macintosh)하고 컨텍스트 메뉴에서 속성 붙여넣기를 선택합니다.
    • 복사된 속성의 일부만 붙여넣으려면 대상 트윈 범위의 선택한 프레임을 마우스 오른쪽 버튼으로 클릭(Windows)하거나 Command 키를 누른 상태에서 클릭(Macintosh)하고 컨텍스트 메뉴에서 속성 선택하여 붙여넣기를 선택합니다. 대화 상자가 나타나면 붙여넣을 속성을 선택하고 확인을 클릭합니다.

Animate에서 선택된 프레임에 붙여넣은 각 속성에 대해 속성 키프레임을 만들고 모션 트윈을 다시 보간합니다.

트윈 범위를 프레임별 애니메이션으로 변환

클래식 또는 모션 트윈 범위를 프레임별 애니메이션으로 변환할 수 있습니다. 프레임별 애니메이션에서 각 프레임에는 각각 애니메이션 심볼의 개별 인스턴스를 포함하는 개별 키프레임(속성 키프레임이 아님)이 포함되어 있습니다. 프레임별 애니메이션에는 보간 속성 값이 포함되어 있지 않습니다. 자세한 내용은 프레임별 애니메이션을 참조하십시오.

  • 변환할 트윈 범위를 마우스 오른쪽 버튼으로 클릭(Windows)하거나 Control 키를 누른 상태에서 클릭(Macintosh)하고 컨텍스트 메뉴에서 프레임별 애니메이션으로 변환을 선택합니다.

타임라인에서 애니메이션 트윈 범위 편집

Animate에서 애니메이션을 만들 때 우선 타임라인에서 트윈 범위를 설정하는 것이 적합한 경우가 있습니다. 레이어와 프레임에 객체의 초기 배열을 설정하면 속성 관리자 또는 모션 편집기에서 트위닝된 속성 값을 변경하여 트윈을 완료할 수 있습니다.

타임라인에서 트윈 범위 및 프레임을 선택하려면 다음 중 하나를 수행합니다. 일반 환경 설정(편집 > 환경 설정)에서 범위에 따라 선택이 설정되어 있어야 합니다.

  • 전체 트윈 범위를 선택하려면 해당 범위를 클릭합니다.

  • 연속적이지 않은 범위를 포함한 여러 트윈 범위를 선택하려면 Shift 키를 누른 상태에서 각 범위를 클릭합니다.

  • 트윈 범위 내 단일 프레임을 선택하려면 Ctrl+Alt(Windows) 또는 Command+Option(Macintosh)을 누른 상태에서 범위 내 프레임을 클릭합니다.

  • 트윈 범위 내 연속된 여러 프레임을 선택하려면 범위 내에서 Ctrl+Alt(Windows) 또는 Command+Option(Macintosh)을 누른 채로 드래그합니다.

  • 서로 다른 레이어의 여러 트윈 범위 내에서 프레임을 선택하려면 Ctrl+Alt(Windows) 또는 Command+Option(Macintosh)을 누른 채로 여러 레이어에서 드래그합니다.

  • 트윈 범위에서 개별 속성 키프레임을 선택하려면 Ctrl+Alt(Windows) 또는 Command+Option(Macintosh)을 누른 채로 속성 키프레임을 클릭합니다. 그런 다음 새 위치로 드래그할 수 있습니다.

타임라인에서 트윈 범위를 사용하여 작업하기 위한 키보드 수정자의 전체 목록은 Flashthusiast.com에서 확인할 수 있습니다.

트윈 범위 이동, 복제 또는 삭제

  • 범위를 동일 레이어의 새 위치로 이동하려면 해당 범위를 드래그합니다.

    참고: 레이어를 잠그면 스테이지에서 편집할 수 없으나 타임라인에서는 편집할 수 있습니다. 다른 범위 위로 범위를 이동하면 두 번째 범위의 겹쳐진 프레임이 사용됩니다.

  • 트윈 범위를 다른 레이어로 이동하려면 범위를 레이어로 드래그하거나 새 레이어에 복사하여 붙여넣습니다.

    트윈 범위를 기존 일반 레이어, 트윈 레이어, 안내선 레이어, 마스크 레이어 또는 마스크 처리 레이어로 드래그할 수 있습니다. 새 레이어가 일반 빈 레이어인 경우 트윈 레이어가 됩니다.

  • 범위를 복제하려면 Alt 키(Windows) 또는 Command 키(Macintosh)를 누른 상태에서 범위를 타임라인의 새 위치로 드래그하거나 해당 범위를 복사하여 붙여넣습니다.

  • 범위를 삭제하려면 해당 범위를 선택하고 범위 컨텍스트 메뉴에서 프레임 제거 또는 프레임 지우기를 선택합니다.

인접한 트윈 범위 편집

  • 두 개의 연속된 트윈 범위 간 분리선을 이동하려면 분리선을 드래그합니다.

    각 트윈이 다시 계산됩니다.

  • 두 개의 연속된 트윈 범위의 인접한 시작 프레임과 끝 프레임을 분리하려면 Alt 키(Windows) 또는 Command 키(Macintosh)를 누른 상태에서 두 번째 범위의 시작 프레임을 드래그합니다.

    이렇게 하면 두 개의 범위 사이 프레임에 공간이 만들어집니다.

  • 트윈 범위를 두 개의 별도 범위로 분할하려면 Ctrl 키(Windows) 또는 Command 키(Macintosh)를 누른 상태에서 범위 내의 단일 프레임을 클릭하고 범위 컨텍스트 메뉴에서 모션 분할을 선택합니다.

    두 트윈 범위 모두 동일한 대상 인스턴스를 갖게 됩니다.

    참고: 두 개 이상의 프레임을 선택한 경우 모션을 분할할 수 없습니다. 분할된 트윈에 부드럽게가 적용된 경우 두 개로 분할된 작은 트윈의 모션이 원래 모션과 동일하지 않을 수 있습니다.

  • 연속된 두 개의 트윈 범위를 연결하려면 두 범위를 선택하고 범위 컨텍스트 메뉴에서 모션 연결을 선택합니다.

트윈 범위 길이 편집

  • 애니메이션의 길이를 변경하려면 트윈 범위의 오른쪽 또는 왼쪽 가장자리를 드래그합니다.

    한 범위의 가장자리를 다른 범위의 프레임으로 드래그하면 두 번째 범위의 프레임이 바뀝니다.

  • 스테이지에서 트위닝된 객체를 트윈의 한쪽 끝을 지나 확장하려면 Shift 키를 누른 상태에서 트윈 범위의 한쪽 끝 프레임을 드래그합니다. Animate는 프레임을 트위닝하지 않고 범위 끝에 프레임을 추가합니다.

    동일한 레이어의 트윈 범위 뒤에 있는 프레임을 선택하고 F6 키를 누를 수도 있습니다.Animate는 트윈 범위를 확장하고 모든 속성에 대한 속성 키프레임을 선택된 프레임에 추가합니다. F5 키를 누르면 Animate는 프레임을 추가하되 선택된 프레임에 속성 키프레임을 추가하지 않습니다.

    참고: 두 범위가 가까이 인접한 상황에서 범위 끝에 정적 프레임을 추가하려면 먼저 인접한 범위를 이동하여 새 프레임을 위한 공간을 만드십시오.

트윈 범위 내에서 프레임 추가 또는 제거

  • 범위 내에서 프레임을 제거하려면 Ctrl 키(Windows) 또는 Command 키(Macintosh)를 누른 상태에서 드래그하여 프레임을 선택하고 범위 컨텍스트 메뉴에서 프레임 제거를 선택합니다.

  • 범위 내에서 프레임을 잘라내려면 Ctrl 키(Windows) 또는 Command 키(Macintosh)를 누른 상태에서 드래그하여 프레임을 선택하고 범위 컨텍스트 메뉴에서 프레임 잘라내기를 선택합니다.

  • 기존 트윈 범위에 프레임을 붙여넣으려면 Ctrl 키(Windows) 또는 Command 키(Macintosh)를 누른 상태에서 드래그하여 바꿀 프레임을 선택하고 범위 컨텍스트 메뉴에서 프레임 붙여넣기를 선택합니다.

    전체 범위를 다른 범위에 붙여넣기만 하면 두 번째 범위 전체가 바뀝니다.

트윈의 대상 인스턴스 바꾸기 또는 제거

트윈 범위의 대상 인스턴스를 바꾸려면 다음 중 하나를 수행합니다.

  • 범위를 선택한 다음 새 심볼을 라이브러리 패널에서 스테이지로 드래그합니다.

  • 라이브러리 패널에서 새 심볼을 선택하고 스테이지에서 트윈의 대상 인스턴스를 선택한 다음 수정 > 심볼 > 심볼 교체를 선택합니다.

  • 범위를 선택하고 클립보드에서 심볼 인스턴스 또는 텍스트를 붙여넣습니다.

트윈을 제거하지 않고 트윈 범위의 대상 인스턴스를 제거하려면 해당 범위를 선택하고 Delete 키를 누릅니다.

(Animate CC에서 더 이상 사용 안 됨) ActionScript 3.0으로 모션 복사

ActionScript 3.0

타임라인에서 모션 트윈이 정의된 속성을 ActionScript 3.0으로 복사하고, 해당 모션을 액션 패널이나 ActionScript 3.0을 사용하는 Animate 문서의 소스 파일(예: 클래스 파일)의 다른 심볼에 적용합니다.

fl.motion 클래스를 사용하여 Animate에서 생성된 ActionScript를 특정 프로젝트에 대해 사용자 정의할 수 있습니다. 자세한 내용은 ActionScript 3.0 언어 및 구성 요소 참조 설명서fl.motion 클래스를 참조하십시오.

[ActionScript 3.0으로 모션 복사]는 모션 트윈의 다음 속성을 캡처할 수 있습니다.

  • 위치

  • 크기 조절

  • 경사

  • 회전

  • 변형점

  • 색상

  • 블렌드 모드

  • 경로 방향

  • 비트맵 설정으로 캐시

  • 부드럽게

  • 필터

  • 3D 회전 및 위치

  1. 복사할 모션 트윈이 포함된 트윈 범위(타임라인에서) 또는 객체(스테이지에서)를 선택합니다.

    트윈 범위 또는 트위닝된 객체만 ActionScript 3.0로 복사하도록 선택할 수 있습니다.

  2. 다음 중 하나를 수행합니다.
    • 편집 > 타임라인 > ActionScript 3.0으로 모션 복사를 선택합니다.
    • 스테이지에서 트윈 범위 또는 트위닝된 인스턴스를 마우스 오른쪽 버튼으로 클릭(Windows)하거나 Control 키를 누른 상태에서 클릭(Macintosh)하고 ActionScript 3.0으로 모션 복사를 선택합니다.

XML 파일로 저장된 모션 트윈을 사용한 작업

Animate에서는 XML 파일로 저장된 모션 트윈을 사용하여 작업할 수 있습니다. 기본적으로 Animate에서는 모든 모션 트윈에 다음 명령을 적용할 수 있습니다.

  • XML로 모션 복사
  • XML로 모션 내보내기
  • XML로 모션 가져오기
XML로 모션 복사
 
지정된 프레임에서 스테이지에 있는 객체에 적용된 모션 속성을 복사할 수 있습니다.
  1. 모션 트윈을 만듭니다.
  2. 타임라인에서 키프레임을 선택합니다.
  3. [명령] > [XML로 모션 복사]로 이동합니다.
모션 속성이 XML 데이터로 클립보드에 복사됩니다. 그러면 텍스트 편집기를 사용하여 XML 파일로 작업할 수 있습니다.
 
XML로 모션 내보내기
 
스테이지의 객체에 적용되는 모션 속성을 저장이 가능한 XML 파일로 내보낼 수 있습니다.
  1. 모션 트윈을 만듭니다.
  2. [명령] > [XML로 모션 내보내기]로 이동합니다.
  3. 파일을 저장할 적합한 위치를 찾아봅니다.
  4. XML 파일 이름을 입력하고 [저장]을 클릭합니다.
XML 파일로 모션 트윈이 지정한 위치에 내보내집니다.
 
XML로 모션 가져오기
 
모션 속성이 정의된 기존 XML 파일을 가져올 수 있습니다.
  1. 스테이지에서 객체를 선택합니다.
  2. [명령] > [XML로 모션 가져오기]로 이동합니다.
  3. 위치를 찾아보고 XML 파일을 선택합니다. [확인]을 클릭합니다.
  4. [모션 선택하여 붙여넣기] 대화 상자에서 선택한 객체에 적용하려는 속성을 선택합니다.
  5. [확인]을 클릭합니다.
 

모션 트윈 소개

트윈으로 위치에 애니메이션 적용

객체가 스테이지에서 이동하거나 미끄러지도록 만들려면

  1. 스테이지에서 트위닝할 심볼 인스턴스 또는 텍스트 필드를 선택합니다. 객체는 일반, 안내선, 마스크 또는 마스크 처리와 같은 레이어 유형 중 하나에 포함될 수 있습니다.

    선택 항목에 다른 객체가 포함되어 있거나 한 레이어의 여러 객체가 포함되어 있는 경우 Animate는 해당 선택 항목을 동영상 클립 심볼로 변환할 것을 제안합니다.

    선택 내용을 반전하려면 객체를 마우스 오른쪽 버튼으로 클릭하고 선택 내용 반전을 선택합니다.

     
  2. 다음 중 하나를 수행합니다.

    • 삽입 > 모션 트윈을 선택합니다.

    • 선택 항목 또는 현재 프레임을 마우스 오른쪽 버튼으로 클릭(Windows)하거나 Control 키를 누른 상태에서 클릭(Macintosh)하여 컨텍스트 메뉴에서 모션 트윈 생성을 선택합니다.

    트윈을 위해 선택 항목을 심볼로 변환” 대화 상자가 나타나면 [확인]을 클릭하여 선택 항목을 동영상 클립 심볼로 변환합니다.

    트위닝된 객체가 레이어의 유일한 항목인 경우 Animate는 객체가 포함된 레이어를 트윈 레이어로 변환합니다. 레이어에 다른 객체가 있으면 Animate가 레이어를 삽입하여 쌓기 순서를 유지합니다. Animate는 트위닝된 객체를 자체 레이어에 배치합니다.

    원래 객체가 타임라인의 첫 번째 프레임에만 있을 경우 트윈 범위의 길이는 1초와 같습니다. 원래 객체가 연속된 두 개 이상의 프레임에 있었던 경우 트윈 범위는 원래 객체가 차지한 프레임 수를 포함하게 됩니다.

  3. 타임라인의 트윈 범위 끝을 드래그하여 범위를 원하는 프레임 수로 줄이거나 늘립니다. 트윈에 있는 기존 속성 키프레임은 범위의 끝과 비례하여 이동합니다.

    기존 키프레임을 이동하지 않고 범위의 끝을 이동하려면 Shift 키를 누른 채로 트윈 범위의 끝을 드래그합니다.

  4. 트윈에 모션을 추가하려면 트윈 범위 내 프레임에 재생 헤드를 배치하고 객체를 새 위치로 드래그합니다.

    트윈 범위의 첫 번째 프레임이 있는 위치에서 새 위치로의 경로를 나타내는 모션 경로가 스테이지에 표시됩니다. 사용자가 객체의 X 및 Y 속성을 명시적으로 정의했으므로 재생 헤드를 포함하는 프레임에서 X 및 Y에 대해 속성 키프레임이 추가됩니다. 속성 키프레임이 트윈 범위에 작은 마름모로 표시됩니다.

    참고:

    기본적으로 타임라인에는 모든 속성 유형의 속성 키프레임이 표시됩니다. 트윈 범위를 마우스 오른쪽 버튼으로 클릭(Windows)하거나 Command 키를 누른 상태에서 클릭(Macintosh)하고 키프레임 보기 > 속성 유형을 선택하여 표시할 속성 키프레임의 유형을 선택할 수 있습니다.

  5. 객체에 다른 위치를 지정하려면 트윈 범위 내 다른 프레임에 재생 헤드를 배치하고 스테이지의 객체를 다른 위치로 드래그합니다.

    지정한 모든 위치를 포함하도록 모션 경로가 조정됩니다.

  6. 3D 회전 또는 위치를 트위닝하려면 3D 회전 또는 3D 평행 이동 도구를 사용합니다. 먼저 3D 속성 키프레임을 추가할 프레임에 재생 헤드를 배치해야 합니다.

트윈 애니메이션 만들기

트위닝된 애니메이션을 만들기 위한 단계

시작하기 전에

속성에 애니메이션 적용을 시작하기 전에 다음을 염두에 두십시오.

ActionScript는 필요하지 않음. Animate에 있는 여러 항목과 마찬가지로 애니메이션은 ActionScript를 필요로 하지 않습니다. 하지만 원하는 경우에는 ActionScript를 사용하여 애니메이션을 만들 수 있습니다.

타임라인 및 속성 편집의 기초. 모션 트윈에 대한 작업을 시작하기 전에 타임라인 및 속성 편집의 기본적인 사용법에 익숙해지십시오. 기본 원리에 대해 배우려면 프레임 및 키프레임을 참조하십시오.

스테이지, 속성 관리자 또는 모션 편집기에서 개별적으로 속성 키프레임을 편집할 수 있습니다. 다양한 유형의 단순 모션 트윈을 만들 때 모션 편집기를 사용해도 되고 안 해도 됩니다.

모션 편집기는 Animate CC에서 더 이상 사용되지 않습니다.

심볼 인스턴스 및 텍스트 필드만. Animate는 심볼 인스턴스 및 텍스트 필드만 트위닝합니다. 다른 모든 객체 유형은 트윈 적용 시 심볼에 래핑됩니다. 심볼 인스턴스에는 중첩된 심볼이 포함될 수 있으며, 중첩된 심볼은 자체 타임라인에서 트위닝될 수 있습니다.

한 트윈에 하나의 객체. 트윈 레이어의 최소 기본 단위는 트윈 범위입니다. 트윈 레이어의 트윈 범위는 하나의 심볼 인스턴스 또는 텍스트 필드만 포함할 수 있습니다. 심볼 인스턴스는 트윈 범위의 대상이라고 합니다. 하지만 단일 심볼이 여러 개의 객체를 포함할 수 있습니다.

대상 변경. 트윈 범위에 두 번째 심볼 또는 텍스트 필드를 추가하면 트윈에 원래 있던 심볼이 바뀝니다. 다른 심볼을 라이브러리에서 타임라인의 트윈 범위로 드래그하거나, 수정 > 심볼 > 심볼 교체 명령을 사용하여 트윈의 대상 객체를 변경할 수 있습니다. 트윈을 제거하거나 분리하지 않고 트윈 레이어에서 심볼을 삭제할 수 있습니다. 그러면 나중에 다른 심볼 인스턴스를 트윈에 추가할 수 있습니다. 언제든지 대상 심볼의 유형을 변경하거나 심볼을 편집할 수도 있습니다.

모션 경로 편집. 트윈에 모션이 포함된 경우 모션 경로가 스테이지에 표시됩니다. 모션 경로는 각 프레임에서 트위닝된 객체의 위치를 보여 줍니다. 제어점을 드래그하여 스테이지에서 모션 경로를 편집할 수 있습니다. 트윈/역기구학 레이어에는 모션 안내선을 추가할 수 없습니다.

역기구학을 사용한 트윈에 대한 자세한 내용은 뼈대 애니메이션 만들기를 참조하십시오.

타임라인에 트윈 추가

레이어에 있는 객체에 트윈을 추가하면 Animate가 다음 중 하나를 수행합니다.

  • 레이어를 트윈 레이어로 변환합니다.

  • 레이어에 있는 객체의 원래 쌓인 순서를 유지하기 위해 새 레이어를 만듭니다.

레이어는 다음과 같은 규칙에 따라 추가됩니다.

  • 레이어에 선택된 객체 외에 다른 객체가 없을 경우 레이어는 트윈 레이어로 변경됩니다.

  • 선택 항목이 레이어의 쌓인 순서에서 맨 아래에 있는 경우(다른 모든 객체의 아래에 있음) Animate는 원래 레이어 위에 레이어를 만듭니다. 이 새 레이어 안에는 선택되지 않은 항목이 있습니다. 원래 레이어가 트윈 레이어가 됩니다.

  • 선택 항목이 레이어의 쌓인 순서에서 맨 위에 있는 경우(다른 모든 객체의 위에 있음) Animate는 새 레이어를 만듭니다. 선택 항목이 새 레이어로 이동하고, 해당 레이어가 트윈 레이어가 됩니다.

  • 선택 항목이 레이어의 쌓인 순서에서 중간에 있는 경우(해당 선택 항목의 위와 아래에 모두 객체가 있음) Animate는 두 개의 레이어를 만듭니다. 한 레이어 안에는 새 트윈이 있고, 그 위에 있는 다른 레이어 안에는 쌓인 순서 위쪽에 있는 선택되지 않은 항목이 있습니다. 쌓인 순서 아래쪽에 있는 선택되지 않은 항목은 새로 삽입된 레이어 아래쪽의 원래 레이어에 보관됩니다.

트윈 레이어에는 트윈 범위를 비롯하여 정적 프레임과 ActionScript가 포함될 수 있지만, 트윈 범위가 들어 있는 트윈 레이어의 프레임에는 트위닝된 객체 이외의 객체가 포함될 수 없습니다. 동일한 프레임에서 객체를 추가하려면 별도의 레이어에 배치하십시오.

속성 관리자를 사용하여 다른 속성 트위닝

모션 트윈 만들기 명령을 사용하여 회전, 배율, 투명도, 농도(심볼 및 TLF 텍스트만 해당) 같은 심볼 인스턴스 또는 텍스트 필드의 대다수 속성에 애니메이션을 적용할 수 있습니다. 예를 들어 심볼 인스턴스의 알파(투명도) 속성을 편집하여 화면으로 페이드 인되도록 할 수 있습니다. 모션 트윈을 사용하여 애니메이션을 적용할 수 있는 속성의 목록은 트윈 가능한 객체 및 속성을 참조하십시오.

  1. 스테이지에서 심볼 인스턴스 또는 텍스트 필드를 선택합니다.

    선택 항목에 다른 객체가 포함되어 있거나 한 레이어의 여러 객체가 포함되어 있는 경우 Animate는 선택 항목을 동영상 클립 심볼로 변환할 것을 제안합니다.

  2. 삽입 > 모션 트윈을 선택합니다.

    트윈을 위해 선택 항목을 심볼로 변환” 대화 상자가 나타나면 [확인]을 클릭하여 선택 항목을 동영상 클립 심볼로 변환합니다.

    단일 키프레임에만 있는 객체에 트윈을 적용하면 재생 헤드가 새 트윈의 마지막 프레임으로 이동합니다. 그렇지 않으면 재생 헤드가 이동하지 않습니다.

  3. 속성 값을 지정하려는 트윈 범위의 프레임에 재생 헤드를 배치합니다.

    재생 헤드를 트윈 범위의 다른 프레임에 배치할 수 있습니다. 트윈은 트윈 범위에서 첫 번째 프레임의 속성 값으로 시작합니다. 이 프레임이 항상 속성 키프레임이 됩니다.

  4. 스테이지에서 객체를 선택한 상태로 알파(투명도), 회전, 기울이기 같은 위치 이외의 속성 값을 설정합니다. 속성 관리자도구 패널의 도구 중 하나를 사용하여 값을 설정합니다.

    범위의 현재 프레임이 속성 키프레임이 됩니다.

    참고:

    트윈 범위에 있는 속성 키프레임의 다양한 유형을 표시할 수 있습니다. 선택 항목을 마우스 오른쪽 버튼으로 클릭(Windows)하거나 Control 키를 누른 상태에서 클릭(Macintosh)하고 컨텍스트 메뉴에서 키프레임 보기 > 속성 유형을 선택합니다.

  5. 타임라인에서 재생 헤드를 이동하여 스테이지에서 트윈을 미리 봅니다.

  6. 속성 키프레임을 추가하려면 재생 헤드를 범위의 원하는 프레임으로 이동시키고 속성 관리자에서 속성 값을 설정합니다.

기존 트윈 레이어에 트윈 추가

기존 트윈 레이어에 트윈을 추가할 수 있습니다. 그러면 애니메이션이 있는 Animate 내용을 만들 때 더 적은 수의 레이어를 사용할 수 있습니다.

  • 다음 중 하나를 수행합니다.
    • 레이어에 빈 키프레임을 추가(삽입 > 타임라인 > 빈 키프레임)하고, 키프레임에 항목을 추가한 다음 항목을 트위닝합니다.
    • 별도의 레이어에 트윈을 만든 다음 범위를 원하는 레이어로 드래그합니다.
    • 정적 프레임을 다른 레이어에서 트윈 레이어로 드래그한 후 정적 프레임의 객체에 트윈을 추가합니다.
    • Alt 키(Windows) 또는 Option 키(Macintosh)를 누른 채 드래그하여 같은 레이어 또는 다른 레이어에 있는 기존 범위를 복제합니다.
    • 같은 레이어 또는 다른 레이어에서 트윈 범위를 복사하여 붙여 넣습니다.

Animate에서는 선택한 모션 트윈을 설명하는 ActionScript 3.0 코드를 시스템 클립보드에 복사합니다. 이 코드에서는 트윈을 프레임별 애니메이션으로 설명합니다.

복사된 코드를 사용하려면 복사된 트윈을 받을 심볼 인스턴스가 포함된 Animate 문서의 액션 패널에 코드를 붙여 넣습니다. addTarget() 함수를 호출하는 행의 주석 처리를 제거하고 해당 행의 <인스턴스 이름> 텍스트를 애니메이션 효과를 적용할 심볼 인스턴스의 이름으로 바꿉니다.

붙여넣은 ActionScript로 애니메이션 효과를 적용할 심볼 인스턴스의 이름을 지정하려면 스테이지에서 인스턴스를 선택하고 속성 관리자에서 이름을 입력합니다.

타임라인에서 트윈 범위를 선택하고 속성 관리자에서 모션 트윈의 이름을 입력하여 모션 트윈 인스턴스의 이름을 지정할 수도 있습니다. 그러면 ActionScript 3.0 코드에서 트윈 범위를 참조할 수 있습니다.

ActionScript 3.0으로 애니메이션 효과를 적용하는 방법에 대한 자세한 내용은 ActionScript 3.0 언어 및 구성 요소 참조 설명서fl.motion 클래스를 참조하십시오.

참고 사항

 

이 작업에는 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License의 라이센스가 부여되었습니다.  Twitter™ 및 Facebook 게시물은 Creative Commons 약관을 적용받지 않습니다.

법적 고지 사항   |   온라인 개인 정보 보호 정책