Program Acrobat DC umożliwia wyświetlanie i przekształcanie zawartości 3D wysokiej jakości, która została utworzona w profesjonalnych programach CAD 3D i osadzona w plikach PDF. Można na przykład wyświetlać i ukrywać wybrane części modelu 3D, przeglądać jego wnętrze i swobodnie obracać jego części.

Początkowo model 3D jest wyświetlany w postaci dwuwymiarowego obrazu podglądu. Kliknięcie na modelu 3D przy zaznaczonym narzędziu Rączka lub Zaznaczanie powoduje uaktywnienie modelu 3D, otwarcie paska narzędziowego 3D i rozpoczęcie odtwarzania animacji.

Zaznaczony obiekt 3D
Zaznaczony obiekt 3D

A. Drzewo modelu B. Pasek narzędziowy 3D C. Obiekt 3D 

Włącz odtwarzanie treści 3D w pliku PDF

Gdy otworzysz plik PDF z treścią 3D, u góry pojawi się żółty pasek z komunikatem „Wyświetlanie treści 3D zostało wyłączone. Włącz tę funkcję, jeśli dokument jest zaufany”.

Automatyczne odtwarzanie treści 3D jest domyślnie wyłączone
Automatyczne odtwarzanie treści 3D jest domyślnie wyłączone

Aby włączyć wyświetlanie treści 3D w bieżącym dokumencie:

Kliknij przycisk Opcje, a następnie wybierz odpowiednią opcję:

  • Ufaj temu dokumentowi tylko raz
  • Zawsze ufaj temu dokumentowi

Aby trwale włączyć wyświetlanie treści 3D:

  • Przejdź do menu Edycja > Preferencje > 3D i Multimedia, a następnie zaznacz pole wyboru Włącz odtwarzanie treści 3D.

Aby uzyskać więcej informacji, zobacz artykuł Włączanie treści 3D w pliku PDF.

Przegląd paska narzędziowego 3D

Pasek narzędziowy 3D jest wyświetlany po uaktywnieniu narzędzia Rączka i kliknięciu modelu 3D. Ta operacja powoduje uaktywnienie modelu 3D i odtworzenie animacji, które ustawiono do odtwarzania po uaktywnieniu pliku. Pasek narzędziowy 3D jest wyświetlany zawsze nad lewym górnym narożnikiem modelu 3D i nie może zostać przesunięty w inne miejsce. Po prawej stronie narzędzia Obrót zostanie wyświetlona niewielka strzałka, którą można kliknąć, aby ukryć lub rozwinąć pasek narzędziowy.

Pasek narzędziowy 3D pozwala zmniejszać, powiększać, obracać i przesuwać obiekty 3D. Za pomocą drzewa modelu można ukrywać i wyodrębniać poszczególne części modelu, a także czynić je przezroczystymi.

Operacje na modelu 3D wykonuje się, zaznaczając i przeciągając różne narzędzia nawigacyjne. W pewnym sensie oglądanie komputerowego modelu 3D przypomina oglądanie nieruchomego modelu 3D na wyświetlaczu cyfrowego aparatu fotograficznego. Obiekt można obracać, przesuwać (w górę, w dół i na boki), a także zmniejszać i powiększać.

Narzędzia nawigacyjne 3D

Obróć 

Pozwala obracać obiekty 3D na ekranie. Sposób przemieszczania obiektów zależy od widoku początkowego, miejsca rozpoczęcia i kierunku przeciągania kursora.

Uwaga:

Obiekt można też obracać za pomocą narzędzia Rączka. Upewnij się, że w panelu 3D okna dialogowego Preferencje zaznaczona jest opcja Włącz zaznaczenie zawartości 3D za pomocą narzędzia Rączka.

Obrót

Pozwala obracać model 3D równolegle względem dwóch określonych osi — x i z.

Przesuń

Pozwala przesuwać obiekt w pionie lub w poziomie. Obiekt można też przesuwać przy użyciu narzędzia Rączka, przeciągając przy naciśniętym klawiszu Ctrl.

Powiększ

Pozwala przybliżyć lub oddalić (powiększyć lub zmniejszyć) obiekt 3D. Ten sam efekt można uzyskać, przeciągając kursor narzędzia Rączka z wciśniętym klawiszem Shift.

Idź

Umożliwia obracanie sceny w poziomie podczas przeciągania w poziomie. Umożliwia przechodzenie w przód lub wstecz w obrębie sceny podczas przeciągania w pionie; zachowuje stałą wysokość niezależnie od sposobu przeciągania. Narzędzie Idź jest szczególnie przydatne w przypadku architektonicznych modeli 3D. Aby zmienić szybkość przechodzenia, należy zmienić domyślne jednostki wyświetlania w preferencjach (3D).

Uwaga:

Narzędzie Idź staje się dostępne po wybraniu ustawienia preferencji, które powoduje połączenie narzędzi, a także po kliknięciu modelu 3D prawym przyciskiem myszy i wybraniu polecenia Narzędzia > Idź.

Wznieś

Umożliwia nawigację w obrębie modelu z zachowaniem orientacji powierzchni. Przeciągnij z naciśniętym prawym przyciskiem myszy wewnątrz okna 3D. Poruszanie się za pomocą narzędzia Wznieś przebiega tym wolniej, im bliżej znajduje się obiekt. Przeciągnij kursor w lewo lub w prawo, aby dokonać obrotu.

Aby obracać widok kamery, kliknij lewym przyciskiem myszy wewnątrz okna 3D i przeciągaj w celu obracania widokiem. Chcąc ustawić kamerę w początkową stronę, przesuń mysz do pierwotnej pozycji kliknięcia.

Przy użyciu kółka myszy możesz szybko poruszać się w przód lub w tył zgodnie z kierunkiem widoku kamery. Jest to przydatne w przypadku utraty orientacji w modelu lub nadmiernego powiększenia powierzchni.

Właściwości kamery

Umożliwia określenie kąta, wyrównania i innych właściwości kamery definiujących obiektyw, za pośrednictwem którego jest przeglądany model 3D. Właściwości kamery są składnikami widoków, ale należy je ustawiać niezależnie.

Narzędzie Pomiar 3D 

Umożliwia pomiar części oraz odległości między nimi w modelu 3D.

Kontrolki widoku paska narzędziowego 3D

Domyślnie Widok 

Pozwala przywrócić domyślne (predefiniowane) ustawienia powiększenia, przesunięcia, obrotu i rzutowania modelu 3D. Aby ustawić inny widok jako domyślny, można użyć menu Opcje w okienku Widok drzewa modelu. W tym celu można też użyć polecenia Zarządzaj widokami w menu Widoki paska narzędziowego 3D.

Uwaga:

Obiekt 3D może całkowicie zniknąć z widoku (czyli, przywołując wcześniejsze analogie z aparatem fotograficznym, znaleźć się poza zasięgiem obiektywu). Aby obiekt stał się ponownie widoczny, należy przejść na pasek narzędziowy 3D i kliknąć ikonę Widok domyślny.

Menu Widoki

Zawiera listę wszystkich dostępnych widoków modelu 3D.

Przełącz drzewo modelu 

Pozwala otworzyć lub ukryć drzewo modelu.

Odtwórz/Zatrzymaj animację  

Pozwala odtwarzać i zatrzymywać animacje sterowane kodem JavaScript. Wyskakujące menu Odtwórz/Wstrzymaj animację zawiera suwak, który można przeciągać w obie strony, aby przechodzić do różnych miejsc w sekwencji animacji.

Użyj rzutu ortogonalnego/perspektywicznego 

Pozwala przełączać się między perspektywicznym i ortogonalnym rzutowaniem modelu 3D.

Menu Tryb renderowania modelu 

Pozwala określić sposób wyświetlania kształtu 3D. Ilustrowany przewodnik można znaleźć na stronie Przykłady trybów renderowania modelu.

Menu Włącz dodatkowe oświetlenie 

Zawiera listę różnych efektów świetlnych, które umożliwiają ulepszenie oświetlenia obiektu 3D. Należy wypróbować różne efekty wizualne, aby uzyskać odpowiedni wynik.

Kolor tła 

Pozwala otworzyć próbnik kolorów, za pomocą którego można wybrać inny kolor przestrzeni otaczającej obiekt.

Włącz przecięcie 

Pozwala wyświetlać lub ukrywać przecięcia obiektu. Aby otworzyć okno dialogowe Właściwości przekroju poprzecznego, kliknij menu podręczne. Więcej informacji można znaleźć w artykule Tworzenie przecięć.

Dodaj zawartość multimedialną/komentarz 3D

Umożliwia dodanie notatki do dowolnej części modelu 3D. Notatka jest na stałe dołączona do widoku. Zobacz Dodawanie komentarzy do projektów 3D w plikach PDF.

Preferencje 3D

W oknie dialogowym Preferencje i panelu 3D i zawartość multimedialna można określić, czy pasek narzędziowy 3D i drzewo modelu mają być wyświetlane domyślnie. Można określić także domyślne renderowanie i dopuszczalność animacji.

Włącz odtwarzanie treści 3D

Dynamiczny charakter treści 3D sprawia, że są one potencjalnie zagrożone powstawaniem luk w zabezpieczeniach. Dlatego też automatyczne odtwarzanie treści 3D w plikach PDF jest domyślnie wyłączone. Zaznacz tę opcję, aby włączyć wyświetlanie treści 3D w plikach PDF.

Preferowane renderowanie

Pozwala określić mechanizm renderingu, który ma istotny wpływ na jakość i wydajność przetwarzania. W zależności od używanego systemu konieczna może być zmiana mechanizmu renderującego. W przypadku wybrania opcji DirectX® lub OpenGL renderowanie odbywa się za pomocą mikroprocesora karty graficznej. Jeśli wybrana została opcja Oprogramowanie, cała operacja trwa dłużej, ale jej wyniki będą bardziej zgodne z modelem obowiązującym w oryginalnej aplikacji.

Włącz renderowanie sprzętowe dla starszych kart wideo

Umożliwia wymuszenie użycia przyspieszenia sprzętowego (również dla kart graficznych, które nie obsługują cieniowania pikseli).

Włącz renderowanie dwustronne

Niektóre części modelu posiadają dwie strony. Aby zaoszczędzić czas i miejsce, można odznaczyć tę opcję, aby renderować tylko stronę odwróconą do użytkownika. Jeśli użytkownik zajrzy do wnętrza części renderowanej jednostronnie, to tylna strona nie będzie widoczna.

Preferowany tryb renderowania PMI 3D

Umożliwia określenie trybu PMI używanego podczas renderowania. Można wybrać jedną z następujących opcji:

Użyj ustawienia zawartości — podczas renderowania informacji PMI jest używane ustawienie poszczególnych informacji PMI w celu określenia, czy ma być używany bufor Z (Z-buffer).

Zawsze renderuj PMI 3D z przodu modelu — podczas renderowania informacji PMI bufor Z jest ignorowany niezależnie od ustawienia w pliku.

Zawsze renderuj PMI 3D, korzystając z bufora Z-buffer — podczas renderowania informacji PMI bufor Z jest zawsze włączany niezależnie od ustawienia w pliku.

Otwórz drzewo modelu przy aktywacji modelu 3D

Określa czy Drzewo modelu wyświetlane jest po uaktywnieniu modelu 3D. Aby użyć ustawienia, które zostało określone przez autora podczas dodawania modelu 3D do pliku PDF, wybierz opcję Użyj ustawienia adnotacji.

Domyślny stan paska narzędziowego

Pozwala określić, czy po uaktywnieniu modelu 3D pasek narzędziowy ma być wyświetlony, czy ukryty. Aby użyć ustawienia, które zostało określone przez autora podczas dodawania modelu 3D do pliku PDF, wybierz opcję Użyj ustawienia adnotacji.

Włącz zaznaczenie zawartości za pomocą narzędzia Rączka

Umożliwia użytkownikowi zaznaczanie i podświetlanie części modelu 3D za pomocą narzędzia Rączka. Jeśli ta opcja nie jest wybrana, do zaznaczania obiektów służy narzędzie Dane obiektu (Narzędzia > Obiekty interaktywne > Zaznacz obiekt).

Połącz narzędzia na pasku narzędziowym 3D

Wybranie tej opcji powoduje umieszczenie narzędzi manipulacji i nawigacji pod narzędziem Obrót, co skraca pasek narzędziowy 3D.

Włącz przejścia widoków

Niektóre modele 3D zawierają animowane przejścia między widokami. Aby uniemożliwić wyświetlanie takiej animacji 3D, należy usunąć zaznaczenie tej opcji.

Pokazuj oś orientacji 3D

Umożliwia włączenie lub wyłączenie wyświetlania osi wskazującej bieżącą orientację sceny 3D.

Schemat optymalizacji dla wolnego odtwarzania klatek

Umożliwia określenie, w jaki sposób jest obsługiwana animacja złożonych modeli, gdy szybkość odtwarzania klatek staje się mała. Opcja Brak umożliwia pozostawienie małej szybkości odtwarzania klatek bez negatywnego wpływu na wyświetlane elementy. Opcja Obwiednia powoduje, że zamiast części są wyświetlane trójwymiarowe płaszczyzny zawierające części, co pozwala zachować dużą szybkość odtwarzania klatek. Opcja Pomiń obiekty powoduje, że niektóre części modelu nie są wyświetlane, co pozwala zachować dużą szybkość odtwarzania klatek.

Próg szybkości odtwarzania klatek

Umożliwia ustawienie minimalnej szybkości odtwarzania klatek przez przeciągnięcie suwaka lub wprowadzenie liczby w polu wartości. Jeśli szybkość odtwarzania klatek spadnie poniżej określonej liczby klatek na sekundę, stosowana jest opcja Schemat optymalizacji dla wolnego odtwarzania klatek.

Ta zawartość jest licencjonowana na warunkach licencji Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Posty z serwisów Twitter™ i Facebook nie są objęte licencją Creative Commons.

Informacje prawne   |   Zasady prywatności online