Etapy pracy przy tworzeniu dostępnych plików PDF

W ogólnym zarysie proces tworzenia dostępnych plików PDF obejmuje kilka podstawowych etapów:

  1. Rozważenie kwestii związanych z dostępnością dokumentu przed przekonwertowaniem dokumentu na format PDF.
  2. W razie potrzeby dodawanie opisów i pól formularzy do wypełnienia oraz określanie kolejności tabulacji.
  3. Dodawanie innych funkcji dostępności do pliku PDF.
  4. Tworzenie znaczników w pliku PDF.
  5. Sprawdzanie pliku PDF i korygowanie błędów znaczników

Powyższa kolejność etapów sprawdza się w większości zastosowań. Można jednak wykonać te zadania w innej kolejności albo powtarzać niektóre etapy. Zawsze jednak należy rozpocząć od przeanalizowania dokumentu, ustalenia jego przeznaczenia i wykorzystania tych informacji do określenia odpowiedniej procedury.

Dodatkowe zasoby

Więcej informacji o tworzeniu dostępnych plików PDF zawierają następujące zasoby

Rozważenie kwestii związanych z dostępnością dokumentu przed przekonwertowaniem dokumentu na format PDF

Wszędzie tam, gdzie to możliwe, dostępność dokumentów PDF powinna być rozpatrywana przy tworzeniu dokumentu źródłowego w jej aplikacji (np. procesorze tekstu lub aplikacji DTP).

Typowe zadania wykonywane w aplikacji źródłowej obejmują dodawanie tekstu zastępczego do elementów graficznych, optymalizowanie tabel oraz stosowanie stylów akapitu i innych elementów struktury dokumentu, które można przekonwertować na znaczniki. Aby uzyskać więcej informacji, zobacz Tworzenie oznakowanych PDF z programów źródłowych.

Dodawanie opisów i pól formularzy do wypełnienia oraz określanie kolejności dostępu

Jeśli w pliku PDF znajdują się pola formularza, użyj opcji Narzędzia > Dostępność > Uruchom rozpoznawanie pól formularza w celu wykrycia pól formularza i umożliwienia ich wypełniania.

Narzędzia formularzy pozwalają tworzyć pola formularzy do wypełnienia, takie jak przyciski, pola wyboru, wyskakujące menu i pola tekstowe. Po utworzeniu pola wpisz opis tego pola w polu Podpowiedź narzędzia w oknie dialogowym Właściwości. Czytniki ekranu będą odczytywać ten tekst na głos. Dodatkowe informacje zawiera temat Tworzenie pól formularza.

Uwaga:

Aby dodać opisy do pól formularza, można użyć narzędzia Kolejność odczytu w programie Acrobat Pro.

Więcej informacji na temat ustawiania kolejności tabulatorów na podstawie struktury dokumentu można znaleźć w artykule Ustawianie nawigacji dla pól formularzy.

Dodawanie innych funkcji dostępności do pliku PDF

W programie Acrobat Pro ten etap obejmuje określenie języka dokumentu, upewnienie się co do zgodności ustawień zabezpieczeń z czytnikami ekranu, utworzenie dostępnych łączy oraz dodanie zakładek. Aby uzyskać więcej informacji, zobacz Określanie języka dokumentu, Określanie ustawień zabezpieczeń tak, by nie kolidowały z czytnikami ekranu, Dodawanie dostępnych łączy oraz Informacje o zakładkach.

W programie Acrobat Pro ten etap obejmuje określenie języka dokumentu, upewnienie się co do zgodności ustawień zabezpieczeń z czytnikami ekranu oraz dodanie zakładek. Aby uzyskać więcej informacji, zobacz Określanie języka dokumentu, Określanie ustawień zabezpieczeń tak, by nie kolidowały z czytnikami ekranu oraz Informacje o zakładkach.

Tworzenie znaczników w pliku PDF

Dodanie znaczników w programie Acrobat umożliwia zwiększenie dostępności plików PDF. Jeśli plik PDF nie zawiera znaczników, program Acrobat próbuje dodać znaczniki automatycznie, kiedy użytkownik odczytuje dokument lub ponownie wlewa tekst, jednak rezultaty tego procesu mogą nie być zadowalające. Kiedy plik PDF zawiera znaczniki, drzewo struktury logicznej dokumentu wysyła zawartość do czytnika ekranu lub innych programów i urządzeń wspomagających w odpowiedniej kolejności.

Najlepsze efekty przynosi dodanie znaczników do dokumentu podczas konwersji na format PDF w aplikacji źródłowej. Takimi aplikacjami są na przykład Adobe FrameMaker®, Adobe InDesign®, Microsoft Word oraz OpenOffice Writer. Jeśli nie jest dostępna aplikacja źródłowa umożliwiająca wygenerowanie pliku PDF ze znacznikami, w każdej chwili można dodać znaczniki do pliku PDF w programie Acrobat.

Dodawanie znaczników do dokumentu podczas konwersji na PDF wymaga użycia aplikacji źródłowej obsługującej znaczniki plików PDF. Dodawanie znaczników podczas konwersji umożliwia aplikacji źródłowej wygenerowanie drzewa struktury logicznej dokumentu na podstawie stylów akapitu i innych informacji strukturalnych zawartych w dokumencie źródłowym. Drzewo struktury logicznej dokumentu odzwierciedla prawidłową kolejność odczytu oraz odpowiednie poziomy znaczników. Ta metoda dodawania znaczników pozwala lepiej zinterpretować strukturę złożonych układów dokumentów, takich jak osadzone paski, przylegające do siebie kolumny, nieregularne wyrównanie tekstu lub tabele. Dodawanie znaczników podczas konwersji umożliwia także prawidłowe opatrzenie znacznikami zawartych w pliku łączy, odsyłaczy i tekstów zastępczych (jeśli są dostępne).

Aby dodać znaczniki do dokumentu PDF w programie Acrobat, wybierz polecenie Narzędzia > Dostępność > Dodaj znaczniki do dokumentu. To polecenie działa ze wszystkimi plikami PDF pozbawionymi znaczników, np. z plikami utworzonymi za pomocą drukarki Adobe PDF. Program Acrobat analizuje zawartość pliku PDF, interpretując poszczególne elementy stron, ich strukturę hierarchiczną oraz zamierzoną kolejność odczytu każdej strony. Następnie program tworzy drzewo znaczników odzwierciedlające te informacje. Program tworzy także znaczniki dla wszelkich łączy, odnośników i zakładek osadzonych w dokumencie w programie Acrobat.

Polecenie Dodaj znaczniki do dokumentu tworzy prawidłowe znaczniki dla większości standardowych układów. W przypadku złożonych elementów strony struktura i kolejność odczytu mogą zostać zinterpretowane niepoprawnie. Do takich elementów należą przylegające do siebie kolumny, nieregularnie wyrównany tekst, pola formularzy nieprzeznaczone do wypełniania oraz tabele pozbawione obramowania. Dodawanie znaczników do takich stron za pomocą polecenia Dodaj znaczniki do dokumentu może spowodować nieprawidłowe zestawienie elementów lub niewłaściwą sekwencję znaczników. Tego rodzaju błędy będą z kolei powodować problemy z kolejnością odczytu pliku PDF.

Informacje o znakach wodnych i czytnikach ekranu

Znak wodny może być dodany do oznakowanego pliku PDF bez dodawania go do drzewa znaczników. Jeśli znak wodny nie zostanie dodany do drzewa znaczników, to dokument będzie bardziej przejrzysty dla osób korzystających z czytników ekranu, ponieważ znak wodny nie będzie odczytywany jako zawartość dokumentu.

Najlepszym sposobem dodania znaku wodnego, który nie będzie kolidował z czytnikami ekranu, jest umieszczenie nieoznakowanego pliku PDF zawierającego znak wodny w oznakowanym pliku PDF.

Sprawdzanie pliku PDF i korygowanie błędów znaczników (Acrobat Pro)

Po utworzeniu znaczników w pliku PDF sprawdź, czy w dokumencie nie ma problemów z kolejnością odczytu, błędów znaczników ani błędów dostępności, a następnie usuń te błędy w razie potrzeby.

Niezależnie od metody użytej w celu dodania znaczników do pliku PDF, należy w programie Acrobat wykonać korygowanie znaczników i kolejności odczytu złożonych układów strony lub nietypowych elementów strony. Na przykład polecenie Dodaj znaczniki do dokumentu nie zawsze rozróżnia istotne obiekty graficzne od ozdobnych elementów strony, takich jak obramowania, linie i elementy tła. Wszystkie te elementy mogą zostać nieprawidłowo oznaczone jako rysunki. Polecenie to może również nieprawidłowo oznaczać znaki graficzne w obrębietekstu,np. inicjały wpuszczone jako rysunki, zamiast załączyć je do znacznika reprezentującego blok tekstu. Błędy tego typu mogą zaburzyć drzewo znaczników i kolejność odczytu, na której opiera się dana technologia wspomagająca.

Jeśli znaczniki są dodawane do dokumentu w programie Acrobat, aplikacja tworzy raport błędów po zakończeniu procesu dodawania znaczników. Posługując się tym raportem, można usunąć ewentualne problemy ze znacznikami. W celu zidentyfikowania innych problemów ze znacznikami, kolejnością odczytu i dostępnością w dowolnym pliku PDF można także użyć narzędzia Pełne sprawdzanie lub narzędzia Kolejność odczytu. Aby uzyskać więcej informacji, zobacz Sprawdzanie dostępności przy pomocy Pełnego sprawdzania oraz Sprawdzanie i poprawianie kolejności odczytu.

Tworzenie oznaczonego pliku PDF ze strony internetowej

Plik PDF utworzony ze strony internetowej jest dostępny tylko jako źródło HTML, na którym plik jest oparty. Jeśli na przykład strona internetowa używa tabel do nadania odpowiedniego układu, kod HTML tabeli może nie odzwierciedlać kolejności odczytu wymaganej w pliku PDF ze znacznikami, chociaż struktura zawarta w kodzie HTML wystarcza do prawidłowego wyświetlenia wszystkich elementów w przeglądarce.

W zależności od złożoności strony internetowej wiele problemów można usunąć w programie Acrobat Pro za pomocą narzędzia Kolejność odczytu lub przez zmodyfikowanie drzewa znaczników w programie Acrobat.

Aby poprawnie utworzyć pliki PDF ze stron internetowych, należy najpierw określić logiczną kolejność odczytu w kodzie HTML. Przed przystąpieniem do takiej konwersji warto zapoznać się z informacjami zawartymi w dokumencie Web Content Accessibility Guidelines (Wskazówki dotyczące dostępności zawartości internetowej), publikowanym przez organizację World Wide Web Consortium (W3C) Więcej informacji można znaleźć we wskazówkach dostępnych w witrynie internetowej organizacji W3C.

  1. Wykonaj jedną z następujących czynności:
    • W programie Acrobat wybierz polecenie Plik > Utwórz > PDF ze strony internetowej, wprowadź adres strony internetowej i kliknij przycisk Ustawienia.

    • W programie Microsoft Internet Explorer na pasku narzędziowym Adobe PDF kliknij strzałkę w dół obok przycisku Konwertuj i wybierz polecenie Właściwości.

  2. Na zakładce Ogólne zaznacz opcję Utwórz znaczniki PDF, a następnie kliknij przycisk OK
  3. Określ pozostałe opcje zależnie od potrzeb, a następnie kliknij przycisk Utwórz.

Tworzenie oznakowanych PDF z programów źródłowych

W większości przypadków oznakowane dokumenty PDF tworzy się za pomocą odpowiednich programów źródłowych, takich jak Adobe FrameMaker®, Adobe InDesign lub Microsoft Word. Przeważnie metoda taka zapewnia lepsze wyniki niż znakowanie dokumentu w programie Acrobat.

Odpowiednie skonfigurowanie modułu PDFMaker umożliwia tworzenie oznakowanych dokumentów PDF w programach Microsoft Excel, PowerPoint i Word.

Więcej informacji na temat tworzenia dostępnych plików PDF można znaleźć pod adresem www.adobe.com/accessibility.

Więcej informacji na ten temat można znaleźć w dokumentacji używanej aplikacji zewnętrznej.

Informacje o znacznikach w łączonych plikach PDF

Istnieje możliwość utworzenia jednego pliku PDF z różnych plików, pochodzących z różnych aplikacji. Połączone pliki mogą na przykład pochodzić z edytorów tekstu, prezentacji slajdów, arkuszy danych i stron internetowych. Wybierz polecenie Plik > Utwórz > Połącz pliki w jeden plik PDF.

Podczas konwersji program Acrobat otwiera każdą z aplikacji, dodaje znaczniki do plików PDF i scala te pliki w jeden oznaczony plik PDF.

Konwersja tego typu nie zawsze poprawnie interpretuje strukturę dokumentu w połączonym pliku PDF, ponieważ pliki składowe mają często różny format. Program Acrobat Pro może służyć do stworzenia dostępnego pliku PDF z kilku dokumentów.

Po scaleniu wielu plików PDF w jeden plik PDF ze znacznikami warto ponownie utworzyć znaczniki w scalonym dokumencie. W wyniku połączenia plików PDF ze znacznikami i bez nich powstaje plik PDF częściowo opatrzony znacznikami, który nie będzie dostępny dla osób niepełnosprawnych. Niektórzy użytkownicy, na przykład osoby korzystające z czytników ekranu, nie są świadome istnienia stron niezawierających znaczników. Jeśli wśród wybranych plików istnieją pliki bez znaczników, należy rozpocząć całą operację od ich utworzenia. Jeśli żaden plik PDF nie zawiera znaczników, należy dodać znaczniki do scalonego pliku PDF po zakończeniu wstawiania, zastępowania i usuwania stron.

Podczas wstawiania, zastępowania i usuwania stron program Acrobat dodaje istniejące znaczniki do drzewa znaczników scalonego pliku PDF w następujący sposób:

  • Podczas wstawiania strony do pliku PDF program Acrobat dodaje znaczniki nowej strony (jeśli istnieją) na końcu drzewa znaczników. Ta kolejność jest stosowana nawet wtedy, gdy nowe strony są wstawiane na początku lub w środku dokumentu.

  • Podczas zastępowania stron w pliku PDF program Acrobat dodaje znaczniki nowych stron (jeśli istnieją) na końcu drzewa znaczników. Ta kolejność jest stosowana nawet wtedy, gdy zastępowane są strony na początku lub w środku dokumentu. Program Acrobat zachowuje wszelkie znaczniki zastąpionych stron (jeśli istnieją).

  • Podczas usuwania stron z pliku PDF program Acrobat zachowuje wszelkie znaczniki usuniętych stron (jeśli istnieją).

Strony, dla których kolejność znaczników w drzewie struktury logicznej jest nieprawidłowa, mogą powodować problemy w czytnikach ekranu. Czytniki ekranu odczytują sekwencję znaczników drzewa w kolejności od góry do dołu i mogą dotrzeć do znaczników wstawionych stron dopiero na końcu drzewa. Aby rozwiązać ten problem, należy zmodyfikować sekwencję znaczników w drzewie za pomocą programu Acrobat Pro. Duże grupy znaczników należy rozmieścić w tej samej kolejności co strony. Aby uniknąć tego kroku, warto zaplanować wstawianie stron na końcu pliku PDF i tworzenie dokumentu kolejno od początku do końca. Jeśli na przykład strona tytułowa zostanie utworzona w osobnym pliku PDF, należy dodać plik z zawartością do strony tytułowej, mimo że dokument z zawartością jest większy. Spowoduje to, że znaczniki zawartości zostaną umieszczone za znacznikami strony tytułowej. Późniejsza modyfikacja ułożenie znaczników w programie Acrobat Pro nie jest konieczna.

Znaczniki pozostałe po usuniętych lub zastąpionych stronach nie są łączone z zawartością dokumentu. Stanowią one duże puste obszary w drzewie znaczników. Takie niepotrzebne znaczniki zwiększają rozmiar pliku, spowalniają pracę czytników ekranu i mogą zakłócać ich działanie. W celu uzyskania jak najlepszych wyników etap dodawania znaczników należy wykonać jako ostatni w procesie konwersji. Do usuwania znaczników usuniętych stron z drzewa znaczników należy użyć programu Acrobat Pro.

Aby uzyskać więcej informacji, zobacz Tworzenie scalonych plików PDF.

Narzędzia do tworzenia dostępnych formularzy PDF

Firma Adobe oferuje szereg narzędzi przeznaczonych do tworzenia dostępnych formularzy PDF:

Acrobat Pro, Acrobat Standard

Za pomocą jednej tych aplikacji można otwierać formularze PDF ze znacznikami lub bez nich (oprócz formularzy PDF utworzonych w programie Adobe Designer) i dodawać do nich pola przeznaczone do wypełniania, takie jak pola tekstowe, pola wyboru i przyciski. Następnie za pomocą innych funkcji tych aplikacji należy dodać do formularza funkcje dostępności. Można dodać opisy pól formularza, dodać znaczniki do formularzy, w których ich nie ma, ustawić kolejność dostępu, zmodyfikować znaczniki oraz wykonać inne zadania związane z zapewnianiem dostępności pliku PDF.

Aplikacje źródłowe

Większość aplikacji źródłowych używanych do projektowania formularzy nie zachowuje interaktywnych pól formularzy podczas konwersji na format PDF. W takim przypadku pola formularzy przeznaczone do wypełniania należy dodać za pomocą programu Acrobat Pro. Ponadto, jeśli znaczniki zostaną dodane do formularza podczas konwersji na format PDF, aplikacja źródłowa może wygenerować nieodpowiednie znaczniki dla etykiet tekstowych pól formularza. Na przykład w złożonym formularzu etykiety tekstowe wszystkich pól mogą zostać połączone w jeden wiersz. W rezultacie czytniki ekranu nie będą w stanie interpretować ich jako pojedynczych etykiet. Rozdzielanie takich etykiet w programie Acrobat Pro w celu wyeliminowania problemów z kolejnością odczytu może być czasochłonne. W takim przypadku lepszym rozwiązaniem może być utworzenie w aplikacji źródłowej formularza PDF bez znaczników. Następnie, przed dodaniem znaczników do całego dokumentu, w programie Acrobat Pro można dodać pola formularzy przeznaczone do wypełniania za pomocą narzędzi Formularze. Niektóre formularze są na tyle proste, że plik PDF ze znacznikami można utworzyć bezpośrednio w aplikacji źródłowej. Następnie, po dodaniu pól formularzy przeznaczonych do wypełniania, można wykonać delikatną korektę w programie Acrobat Pro.

Etapy tworzenia dostępnych formularzy PDF

W programie Acrobat można otwierać formularze PDF ze znacznikami i bez nich, dodawać pola formularzy do uzupełnienia oraz opisy pól i tekst zastępczy, ustawiać kolejność dostępu, a także dodawać znaczniki do formularzy (jeśli nie zostały dodane wcześniej). Znaczniki wszystkich formularzy PDF mogą być edytowane za pomocą narzędzia Kolejność odczytu i drzewa znaczników.

Projektowanie formularza dla potrzeb dostępności

Formularze posiadają zwykle układy bardziej złożone od typowych dokumentów występujących zwykle w postaci jednej kolumny. Powodzenie operacji analizowania i dodawania znaczników do formularzy w aplikacji zależy w dużej mierze od formatowania i układu oryginalnego dokumentu, a także od typów pól użytych w dokumencie.

Przy projektowaniu formularza, warto załączać nagłówki, instrukcje i pola, w których będą umieszczane dane. W wersji najprostszej, opatrz każde pole etykietą. Oraz dodaj specjalne instrukcje do pól, które tego wymagają. Użyj narzędzi graficznych, aby narysować linie i ramki. Nie używaj znaków, takich jak podkreślnik lub linia pionowa, ponieważ mogą one zakłócić pracę czytników ekranu.

Dodawanie opisów do pól formularzy umożliwia czytnikom ekranu identyfikację pól. Użytkownicy będą słyszeć te opisy odczytywane po wejściu na takie pole. Opisy pól powinny być zwięzłe i pełne. Na przykład w przypadku pola, w którym użytkownik wprowadza swoje imię, odpowiednim opisem jest „Imię”. W opisach należy unikać podawania instrukcji typu „Wpisz nazwisko”.

Określanie i sprawdzanie kolejności dostępu w formularzu

Kolejność dostępu do pól formularza umożliwia osobom niepełnosprawnym używanie klawiatury do przechodzenia z pola do pola zgodnie z logiką danego formularza. W celu określenia kolejności dostępu w formularzach PDF należy ustawić opcję Użyj struktury dokumentu. Kolejność dostępu do pól formularza można sprawdzić za pomocą następujących poleceń wydawanych za pomocą klawiatury:

  • Klawisz Tab przenosi zaznaczenie na następne pole

  • Skrót Shift+Tab przenosi zaznaczenie na poprzednie pole

  • Klawisz spacji umożliwia zaznaczenie opcji

  • Klawisze strzałek umożliwiają wybieranie opcji lub elementów list

Dodawanie znaczników do formularza PDF i usuwanie błędów znaczników

Jeśli formularz PDF zawiera już znaczniki, w celu dodania znaczników do poszczególnych pól formularza należy użyć narzędzia Kolejność odczytu w programie Acrobat. Narzędzie to umożliwia także korektę wszelkich błędów kolejności odczytu etykiet tekstu w polach formularza. Na przykład, połączone linie pól mogą być rozdzielone na poszczególne pola.

Ta zawartość jest licencjonowana na warunkach licencji Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Posty z serwisów Twitter™ i Facebook nie są objęte licencją Creative Commons.

Informacje prawne   |   Zasady prywatności online