Criar máscaras

Você pode criar uma ou mais máscaras para cada camada em uma composição usando um dos seguintes métodos:

Quando você cria máscaras em uma camada, os nomes de máscara aparecem no contorno do painel Linha de tempo na ordem em que você cria as máscaras. Para organizar e controlar as máscaras, deverá renomeá-las.

Observação:

Para renomear uma máscara, selecione-o e pressione Enter (Windows) ou Return (Mac OS) ou clique com o botão direito do mouse (Windows) ou com a tecla Control (Mac OS) no nome da máscara e escolha Renomear.

Para criar máscaras adicionais para uma camada no painel Camada, verifique se o menu Destino no painel Camada está definido como Nenhum; caso contrário, você substitui a máscara de destino em vez de criar uma nova máscara. Você também pode bloquear uma máscara para evitar alterações nela.

Seleções de menu para especificar uma máscara para direcionar no painel Camada
Seleções de menu para especificar uma máscara para direcionar no painel Camada

A. Menu Exibir B. Menu Destino 

Ao criar ou editar máscaras, observe o painel Informações para saber por exemplo o nome da máscara e o número de vértices na máscara.

Observação:

Para criar uma máscara que você possa mover independentemente da camada principal que estiver mascarando, faça o seguinte:

  1. Crie uma máscara em uma camada sólida branca separada, e use essa camada sólida como máscara de fosco de faixa para a camada principal.
  2. Use o pai para tornar a camada sólida um filho da camada principal, para que a máscara se mova com a camada principal como se fosse aplicada diretamente. Como a camada sólida é uma camada filho, também é possível animá-la independentemente de seu pai.
  3. Use o controle de movimento para que a camada sólida (e consequentemente a máscara) siga objetos em movimento na camada principal. (Consulte Converter uma camada em um fosco de controle e Camadas pai e filho.)

Criar uma máscara retangular ou elíptica numericamente

  1. Selecione uma camada no painel Composição, ou exiba uma camada no painel Camada.
  2. Escolha Camada > Máscara > Nova máscara. Uma nova máscara aparece no painel Composição ou painel Camada com suas alças nas bordas externas do quadro.
  3. Escolha Camada > Máscara > Forma de máscara.
  4. Selecione Redefinir para, escolha Retângulo ou Elipse no menu Forma e especifique o tamanho e a localização da caixa delimitadora da máscara.

Criar uma máscara a partir de valores de canal com o Traçado automático

  1. Você pode converter o canal alfa, vermelho, verde, azul ou luminância de uma camada em uma ou mais máscaras usando o comando Traçado automático.
  2. O Traçado automático cria quantas máscaras de Bézier conforme necessário para contornar os valores especificados de canais na camada.
  3. Isso cria máscaras com o menor número de vértices possível em conformidade com as configurações escolhidas.
  4. É possível modificar uma máscara criada com o Traçado automático tal como você faria com qualquer outra máscara, e você pode vincular seu caminho a outros tipos de caminho, como caminhos de forma em uma camada de forma, usando expressões.

Quando você aplica o Traçado automático, as camadas afetadas são definidas automaticamente para Melhor qualidade para assegurar resultados exatos.

Observação:

Para reduzir o número de máscaras criadas pelos Traçado automático, aplique um efeito de máscara à camada para isolar o tema antes de o Traçado automático.

  1. No painel Linha de tempo, siga um destes procedimentos:
    • Para criar quadros-chave de máscara em um único quadro, arraste o indicador do tempo atual até ao quadro desejado.
    • Para criar quadros-chave de máscara em um intervalo de quadros, defina um espaço de trabalho que abranja esse intervalo.
  2. Selecione uma ou mais camadas.
  3. Escolha Camada > Traçado automático.
  4. Selecione uma das seguintes opções:

    Quadro atual

    Cria quadros-chave de máscara somente no quadro atual.

    Área de trabalho

    Cria quadros-chave de máscara para quadros dentro do espaço de trabalho.

  5. Defina uma das seguintes opções:

    Inverter

    Inverte a camada de entrada antes de procurar bordas.

    Desfoque

    Desfoca a imagem original antes de gerar o resultado do traçado. Selecione essa opção para reduzir pequenos artefatos e suavizar bordas irregulares no resultado do traçado. Desmarque essa opção para rastrear rigorosamente os detalhes em uma imagem de alto contraste. Especifica o raio, em pixels, da área usada na operação de desfoque. Valores maiores produzem mais desfoque.

    Tolerância

    A extensão, em pixels, que é permitida ao caminho traçado se afastar dos contornos do canal.

    Limite

    Especifica, como uma porcentagem, o valor que um canal do pixel deve ter para que esse pixel seja considerado parte de uma borda. Os pixels com valores de canal acima do limite são mapeados para branco e são opacos; os pixels com valores abaixo do limite são mapeados para preto e são transparentes.

    Área mínima

    Especifica o menor componente na imagem original que será traçado. Por exemplo, um valor de 4 remove componentes com menos de 2 pixels de largura por 2 pixels de altura do resultado do traçado.

    Arredondamento do canto

    Especifica o arredondamento da curva da máscara nos vértices. Digite um valor maior para curvas mais suaves.

    Aplicar à nova camada

    Aplica a máscara a um novo sólido do mesmo tamanho da camada selecionada. Este controle é selecionado automaticamente para camadas que têm Contrair transformações ativada – cria uma nova camada com o mesmo tamanho que a composição que contém a camada.

    Visualização

    Selecione para visualizar os resultados da máscara e os resultados das diversas opções do comando Traçado automático.

Criar formas e camadas de forma

Crie uma camada de forma desenhando no painel Composição com uma ferramenta de forma ou a ferramenta Caneta. Você pode depois adicionar atributos de forma a formas existentes ou criar novas formas em essa camada de forma. Por padrão, se você desenhar no painel Composição quando uma camada de forma estiver selecionada, você cria uma nova forma em essa camada de forma, acima das formas ou grupo de formas selecionados. Caso desenhe no painel Composição com uma ferramenta de forma ou a ferramenta Caneta quando uma camada de imagem, não uma camada de forma, estiver selecionada, você cria uma máscara.

Observação:

Pressione F2 para desmarcar todas as camadas antes de desenhar no painel Composição para criar uma nova camada de forma.

É possível criar formas e camadas de forma usando um dos seguintes métodos:

Na maioria dos casos, uma nova forma tem um preenchimento e um traçado que corresponda às configurações Preenchimento e Traçado no painel Ferramentas no momento em que a forma é desenhada. Você pode usar os mesmos controles no painel Ferramentas para alterar esses atributos para uma forma selecionada após ter sido desenhada. As formas criadas a partir de texto são criadas com preenchimentos e traçados que correspondem aos preenchimentos e traçados do texto original.

Observação:

Para desenhar uma máscara em uma camada de forma, clique no botão Ferramenta cria máscara no painel Ferramentas com uma ferramenta de forma ou a ferramenta Caneta ativada. Para obter mais informações sobre como criar máscaras, consulte Criar máscaras.

Converter gravação de imagens de arte vetorial em formas | CC, CS6

Nas versões anteriores do After Effects era possível importar um arquivo Illustrator (.ai), EPS (.eps) ou PDF (.pdf), no entanto não era possível modificar o arquivo. Agora é possível criar uma camada de forma a partir de uma camada de gravação de arte vetorial e depois modificar a camada de forma.

Com a capacidade de bisel e extrusão de objetos no After Effects, é possível excluir o trabalho artístico (por exemplo, logotipos extruídos), também. Consulte Extrusão de texto e camadas de forma.

Para converter uma camada de gravação de arte vetorial em camada de forma:

  1. Selecione Camada > Criar formas a partir da camada de vetor. Uma camada de forma correspondente aparecerá acima da camada de gravação e a camada de gravação será silenciada.

    Os seguintes problemas são conhecidos:

    • Nem todos os recursos de arquivos do Illustrator são preservados no momento. São exemplos: opacidade, imagens e gradientes.
    • As formas convertidos ignoram substituições PAR especificados na caixa de diálogo Interpretar gravação.
    • Gradientes e tipos não compatíveis podem mostrar como formas de cinza de 50%.
    • Arquivos com milhares de caminhos podem importar muito lentamente sem feedback.
    • O comando de menu funciona em uma única camada selecionada por vez.
    • Se você importar um arquivo do Illustrator como uma composição (ou seja, várias camadas), não será possível converter todas as camadas em uma única passagem. Entretanto, é possível importar o arquivo como gravação e usar o comando para converter a camada única de gravação em formas.

Neste vídeo de Todd Kopriva e video2brain, veja como converter rapidamente os gráficos vetoriais do Illustrator para camadas de forma e animar os caminhos no After Effects CS6. Esse processo é mais simples do que nas versões anteriores do After Effects.

Criar uma forma ou máscara arrastando com as ferramentas de forma

As ferramentas de forma são as ferramentas Retângulo , Retângulo arredondado , Elipse , Polígono e Estrela .

Observação:

Para ativar e percorrer as ferramentas de forma, pressione Q.

Um polígono é uma estrela sem uma propriedade Raio interno ou Arredondamento interno, por isso o nome da forma criada para um polígono ou uma estrela é o mesmo: polystar.

Você pode criar uma máscara arrastando com uma ferramenta de forma em uma camada selecionada no painel Composição ou no painel Camada. Você pode criar uma forma arrastando com uma ferramenta de forma em uma camada de forma selecionada no painel Composição. Se você arrastar com uma ferramenta de forma no painel Composição sem nenhuma camada selecionada, você cria uma forma em uma nova camada de forma.

Observação:

Para desenhar uma máscara em uma camada de forma, clique no botão Ferramenta cria máscara no painel Ferramentas com uma ferramenta de forma ativada.

Ao criar uma forma arrastando com uma ferramenta de forma no painel Composição, você cria um caminho de forma paramétrica. Para criar um caminho da forma de Bézier, pressione a tecla Alt (Windows) ou Option (Mac OS) antes de clicar para começar a arrastar. Solte a tecla antes de concluir a operação de arrastar. Todos os caminhos de máscara são caminhos de Bézier. (Consulte Sobre formas e camadas de forma.)

A operação de arrastar começa quando você clica no painel Composição ou no painel Camada para começar a desenhar e termina quando você solta o botão do mouse. Pressionar teclas modificadoras em momentos diferentes durante uma operação de arrastar gera resultados diferentes:

  • Para reposicionar uma forma ou uma máscara enquanto estiver desenhando, mantenha a barra de espaço ou o botão do meio do mouse pressionados ao arrastar.

  • Para redimensionar um círculo, elipse, quadrado, quadrado arredondado, retângulo ou retângulo arredondado ao redor de seu centro enquanto desenha, mantenha pressionada a tecla Ctrl (Windows) ou Command (Mac OS) depois de começar a arrastar. Não solte a tecla até você soltar o botão do mouse para terminar de desenhar.

  • Para cancelar a operação de desenho, pressione Esc.

Observação:

Cada ferramenta de forma mantém as configurações da operação de desenho mais recente com essa ferramenta. Por exemplo, se você desenhar uma estrela e modificar o número de pontos para ser 10, então a próxima estrela que você desenhar também terá 10 pontos. Para redefinir as configurações de uma ferramenta e criar uma forma com as configurações padrão, clique duas vezes na ferramenta no painel Ferramentas. (Consulte Criar uma forma ou máscara com o tamanho da camada.)

Desenhar retângulos, retângulo arredondados, quadrados e quadrados arredondados

  1. Selecione a ferramenta Retângulo ou a ferramenta Retângulo arredondado e faça o seguinte:
    • Para desenhar um retângulo ou um retângulo arredondado, arraste na diagonal.
    • Para desenhar um quadrado ou um quadrado arredondado, pressione Shift e arraste na diagonal.
  2. (Opcional) Se desenhar um retângulo arredondado ou quadrado arredondado, faça o seguinte antes de soltar o botão do mouse:
    • Para aumentar ou diminuir o arredondamento do canto, pressione a tecla de seta para cima ou para baixo ou rode a roda do mouse para a frente ou para trás.
    • Para definir o arredondamento do canto para o mínimo ou o máximo, pressione a tecla de seta para a esquerda ou para a direita.
  3. Solte o botão do mouse para terminar de desenhar. Se desenhar um quadrado ou um quadrado arredondado, solte a tecla Shift após soltar o botão do mouse.

Observação:

Os quadrados são criados para serem quadrados de acordo com a taxa de proporção de pixels da composição. Se a taxa de proporção de pixels da composição não for 1, então os quadrados aparecem apenas no painel Composição se o botão Alternar taxa de proporções de pixel estiver selecionado na parte inferior do painel Composição.

Desenhar elipses e círculos

  1. Selecione a ferramenta Elipse e siga um destes procedimentos:
    • Para desenhar uma elipse, arraste na diagonal.
    • Para desenhar um círculo, pressione a tecla Shift e arraste na diagonal.
  2. Solte o botão do mouse para terminar de desenhar. Se desenhar um círculo, solte a tecla Shift após soltar o botão do mouse.

Observação:

Os círculos são criados para serem circulares de acordo com a taxa de proporção de pixels da composição. Se a taxa de proporção de pixels da composição não for 1, então os círculos aparecerão apenas no painel Composição se o botão Alternar taxa de proporções de pixel estiver selecionado na parte inferior do painel Composição.

Desenhar polígonos e estrelas

  1. Selecione a ferramenta Polígono ou a ferramenta Estrela e faça o seguinte:
    • Arraste para redimensionar e girar o polígono ou estrela enquanto desenha.
    • Pressione a tecla Shift e arraste para dimensionar polígono ou a estrela enquanto desenha, impedindo a rotação.
  2. (Opcional) Faça o seguinte antes de soltar o botão do mouse:
    • Para adicionar ou remover pontos, pressione a tecla de seta para cima ou para baixo ou rode a roda do mouse para a frente ou para trás.
    • Para aumentar ou diminuir o arredondamento externo, pressione a tecla de seta para a esquerda ou para a direita.
    • Para manter o raio interno de uma constante em estrela à medida que você move o mouse para aumentar o raio externo, mantenha pressionada a tecla Ctrl (Windows) ou Command (Mac OS).
    • Para aumentar ou diminuir o arredondamento interno de uma estrela, pressione a tecla Page Up ou Page Down.
  3. Solte o botão do mouse para terminar de desenhar. Se arrastar com a tecla Shift pressionada para impedir a rotação, solte a tecla Shift após soltar o botão do mouse.

Crie uma forma ou uma máscara de Bézier usando a ferramenta Caneta

Você pode criar uma máscara de Bézier usando a ferramenta Caneta em uma camada selecionada no painel Composição ou no painel Camada. Você pode criar uma forma com um caminho de Bézier usando a ferramenta Caneta em uma camada de forma selecionada no painel Composição. Se você desenhar com a ferramenta Caneta no painel Composição sem nenhuma camada selecionada, você cria uma forma em uma nova camada de forma.

Crie um caminho de RotoBézier é semelhante à criação de um caminho de Bézier manual. A principal diferença é que as linhas de direção de vértices e a curvatura de segmentos de caminho são calculadas automaticamente.

Criar um caminho de Bézier manual usando a ferramenta Caneta

  1. Com a ferramenta Caneta selecionada e a opção RotoBézier desmarcada no painel Ferramentas, clique no painel Composição onde deseja inserir o primeiro vértice.
  2. Clique onde deseja colocar o próximo vértice. Para criar um segmento curvado, arraste a alça da linha de direção para criar a curva desejada.

    Observação:

    Para reposicionar um vértice depois que você clicou para posicioná-lo, mas antes tiver soltado o botão do mouse, mantenha pressionada a barra de espaço enquanto arrasta.

    O último vértice que você adiciona aparece como um quadrado sólido, indicando que ele está selecionado. Os vértices adicionados anteriormente tornam-se vazados e desmarcados, ao adicionar mais vértices.

  3. Repita a etapa 2 até que você esteja pronto para finalizar o caminho.
  4. Finalize o caminho executando um dos seguintes procedimentos:
    • Para fechar o caminho, posicione o ponteiro sobre o primeiro vértice e, quando o ícone de círculo fechado aparecer junto ao ponteiro clique no vértice.

    Observação:

    Também é possível fechar um caminho clicando duas vezes no último vértice ou escolher Camada > Caminho da forma e máscara > Fechado.

    • Para deixar o caminho aberto, ative uma ferramenta diferente, ou pressione F2 para desmarcar o caminho.

Desenhar segmentos de caminho de Bézier manuais retos com a ferramenta Caneta

O caminho mais simples que você pode desenhar com a ferramenta Caneta é uma linha reta, que é feita clicando com a ferramenta Caneta para criar dois vértices. Se você continuar clicando, é possível criar um caminho composto de segmentos de linha reta conectados por pontos de vértice.

Clicar com a ferramenta Caneta cria segmentos retos
Clicar com a ferramenta Caneta cria segmentos retos.

  1. Posicione a ferramenta Caneta onde deseja que o segmento reto inicie e clique para posicionar um vértice. (Não arraste.)
  2. Clique novamente onde você deseja que o segmento termine. (Clique com a tecla Shift pressionada para restringir o ângulo entre segmentos no ponto de vértice a um múltiplo inteiro de 45°.)
  3. Continue clicando para definir vértices para segmentos retos adicionais.

Desenhar segmentos de caminho de Bézier manuais curvados com a ferramenta Caneta

Crie um segmento de caminho curvado arrastando as linhas de direção. O comprimento e a direção das linhas de direção determinam a forma da curva.

Observação:

Arraste com a tecla Shift pressionada para restringir o ângulo das linhas de direção a múltiplos inteiros de 45°. Arraste com a tecla Alt (Windows) ou com a tecla Option (Mac OS) pressionada para modificar apenas a linha de direção de saída.

  1. Posicione a ferramenta Caneta no local onde deseja que a curva inicie e mantenha o botão do mouse pressionado.

    Um vértice é exibido e o ponteiro da ferramenta Caneta muda para uma ponta de seta.

  2. Arraste para alterar o comprimento e a direção de ambas as linhas de direção de um vértice e depois solte o botão do mouse.
    Desenhando o primeiro vértice em um caminho curvado
    Desenhando o primeiro vértice em um caminho curvado

    A. Posicionando a ferramenta Caneta B. Começando a arrastar (botão do mouse pressionado) C. Arrastando para estender as linhas de direção 
  3. Posicione a ferramenta Caneta no local em que deseja que o segmento curvado termine e execute um dos procedimentos a seguir:
    • Para criar uma curva em forma de C, arraste na direção oposta da direção que você arrastou a linha de direção anterior e depois solte o botão do mouse.
    Desenhando o segundo vértice em um caminho curvado
    Desenhando o segundo vértice em um caminho curvado

    A. Começando a arrastar B. Arrastando longe da linha de direção anterior, criando uma curva C C. Resultado após soltar o botão do mouse 
    • Para criar uma curva em S, arraste na mesma direção da linha de direção anterior e depois solte o botão do mouse.
    Desenho de uma curva S
    Desenho de uma curva S

    A. Começando a arrastar B. Arrastando na mesma direção da linha de direção anterior, criando uma curva S C. Resultado após soltar o botão do mouse 
  4. Continue arrastando a ferramenta Caneta a partir de locais diferentes para criar uma série de curvas suaves.

Criar uma forma ou máscara com o tamanho da camada

  1. Selecione o destino da nova máscara ou forma:
    • Para criar uma forma em uma camada de forma existente, selecione a camada de forma.
    • Para criar uma forma em uma nova camada de forma com as dimensões da composição, desmarque todas as camadas pressionando F2.
    • Para criar uma máscara, selecione uma camada no painel Linha de tempo, no painel Camada, ou no painel Composição. Para criar uma máscara em uma camada de forma, selecione Ferramenta cria máscara o painel Ferramentas com uma ferramenta de forma ativada.
    • Para substituir um caminho de máscara, selecione a máscara do painel Linha de tempo, no painel Camada ou no painel Composição.
    • Para substituir um caminho de forma, selecione o caminho da forma (não o grupo) no painel Composição ou no painel Linha de tempo.
  2. No painel Ferramentas, clique duas vezes na ferramenta Retângulo , Retângulo arredondado , Elipse , Polígono ou Estrela .

Criar formas e máscaras a partir de caracteres de texto

O comando Criar formas a partir do texto extrai os contornos de cada caractere, cria formas a partir dos contornos e coloca as formas em uma nova camada de forma. Você pode usar essas formas como usa qualquer outra forma.

O comando Criar máscaras a partir de texto extrai os contornos de cada caractere, cria máscaras a partir dos contornos e coloca as máscaras em uma nova camada de cor sólida. Você pode usar essas máscaras como usa qualquer outra máscara.

Observação:

Algumas famílias de fontes, como Webdings, incluem caracteres que são imagens gráficas, em vez de texto. Converter o texto de essas famílias de fontes pode ser uma boa maneira de iniciar com elementos gráficos simples em camadas de forma.

Criar formas a partir de texto

  1. Selecione o texto a ser convertido para formas:
    • Para criar formas para todos os caracteres em uma camada de texto, selecione a camada de texto no painel Linha de tempo ou no painel Composição.
    • Para criar formas para caracteres específicos, selecione os caracteres no painel Composição.
  2. Siga um destes procedimentos:
    • Escolha Camada > Criar formas a partir do texto.
    • Clique com o botão direito (Windows) ou clique com a tecla Control (Mac OS) na camada ou texto e escolha Criar formas a partir do texto no menu de contexto.

A opção Vídeo para a camada de texto está desativada.

A nova camada de forma é criada no topo da ordem de empilhamento de camadas. A nova camada contendo um grupo de formas para cada caractere selecionado, mais as propriedades de preenchimento e traçado que correspondem aos preenchimentos e traçados do texto.

Para caracteres que consistem em caminhos composto, como i e e, vários caminhos são criados e combinados com a operação de caminho Mesclar caminhos.

Os efeitos, máscaras, estilos de camada e quadros-chave e expressões para propriedades no grupo de propriedades Transformar da camada de texto são copiados para a nova camada de forma ou camada de cor sólida.

Criar máscaras a partir de texto

  1. Selecione o texto a ser convertido para máscaras:
    • Para criar máscaras para todos os caracteres em uma camada de texto, selecione a camada de texto no painel Linha de tempo ou no painel Composição.
    • Para criar máscaras para caracteres específicos, selecione os caracteres no painel Composição.
  2. Siga um destes procedimentos:
    • Escolha Camada > Criar máscaras a partir de texto.
    • Clique com o botão direito (Windows) ou clique com a tecla Control (Mac OS) na camada ou texto e escolha Criar máscaras a partir de texto do menu de contexto.

A opção Vídeo para a camada de texto está desativada.

A nova camada de cor sólida é criada no topo da ordem de empilhamento de camadas.

Para caracteres que consistem em caminhos compostos, como i e e, são criadas várias máscaras e combinadas com o modo de máscara Subtrair.

Copiar um caminho do Illustrator, Photoshop ou Fireworks

É possível copiar um caminho do Illustrator, Photoshop ou Fireworks e colá-lo no After Effects como um caminho de máscara ou de forma.

Para disponibilizar dados copiados do Illustrator compatíveis com o After Effects, a opção AICB deve estar selecionada na seção Arquivos e área de transferência na caixa de diálogo Preferências do Adobe Illustrator.

Para um caminho importado do Photoshop ser dimensionado corretamente, o documento do Photoshop deve ter uma resolução de 72 dpi. 72 dpi é a configuração de resolução de documentos criados no Photoshop usando uma predefinição Filme e Vídeo.

Observação:    você também pode usar uma caminho copiado do Illustrator, Photoshop ou Fireworks como caminho de movimento do After Effects. Consulte Criar um caminho de movimento a partir de um caminho de máscara, forma ou pintura para obter mais informações.

Caminho desenhado no Adobe Illustrator (esquerda) e colado no After Effects como uma máscara (direita)
Caminho desenhado no Adobe Illustrator (esquerda) e colado no After Effects como uma máscara (direita)

  1. No Illustrator, Photoshop ou Fireworks, selecione um caminho inteiro e escolha Editar > Copiar.
  2. No After Effects, siga um destes procedimentos para definir um destino para a operação de colagem:
    • Para criar uma nova máscara, selecione uma camada.
    • Para substituir um caminho de máscara ou de forma existente, selecione sua propriedade Caminho.

    Observação:

    Para colar um caminho como um caminho de forma, selecione a propriedade Caminho de uma forma existente em uma camada de forma. Essa seleção indica ao After Effects onde é o destino da operação de colagem; caso o destino não seja especificado dessa maneira, o After Effects supõe que o destino seja a camada inteira e desenha consequentemente uma nova máscara. Se não houver nenhuma propriedade Caminho – talvez porque a camada de forma esteja vazia – então você pode desenhar um caminho de espaço reservado com a ferramenta Caneta e colar o caminho do Illustrator no caminho de espaço reservado.

  3. Escolha Editar > Colar.

    Se você colar vários caminhos em um caminho de forma, o primeiro caminho vai para o caminho de forma e os caminhos restantes serão colados em novos caminhos de máscara. Isso ocorre porque os caminhos diferentes do primeiro não têm um destino claramente definido, portanto são adicionados à camada inteira como máscaras.

Andrew Devis mostra como usar caminhos do Illustrator como caminhos de movimento no After Effects em este vídeo no site da Creative COW.

Criar uma máscara ou forma a partir de um caminho de movimento

Você pode copiar quadros-chave de posição, quadros-chave de ponto de ancoragem ou quadros-chave de ponto de controle do efeito e colar esses quadros-chave em um caminho de máscara ou caminho de forma selecionado. Quando você cria caminhos de máscara ou caminhos de forma a partir de caminhos de movimento, certifique-se de que copia quadros-chave de uma única propriedade Posição somente – não copie os quadros-chave de qualquer outra propriedade.

Observação:

Desenhe um caminho de movimento com Desenho de trajetória e depois cole o caminho em um caminho de máscara ou caminho de forma.

Criar uma máscara ou forma a partir de um caminho de movimento
O caminho de movimento da nave espacial (acima) é copiado na camada de plano de fundo (parte inferior esquerda) e usado pelo efeito Vegas (parte inferior direita).

Observação:

Ao copiar entre um caminho de máscara e um caminho de movimento, lembre-se de que os valores do caminho de máscara são expressos no sistema de coordenadas da camada (espaço de camada), enquanto os valores do caminho de movimento são expressos no sistema de coordenadas da composição (espaço de composição). Essa diferença pode fazer com que o caminho colado seja deslocado, sendo necessário reposicionar o caminho depois de colado. (Consulte Sistemas de coordenadas: espaço de composição e espaço de camada.)

Criar um caminho de máscara a partir de um caminho de movimento

  1. No painel Linha de tempo, clique no nome da propriedade Posição ou propriedade Ponto de ancoragem a partir do qual deseja copiar o caminho de movimento. (Isso seleciona todos os quadros-chave. Para selecionar apenas alguns quadros-chave de um caminho de movimento, clique neles com a tecla Shift pressionada.)
  2. Escolha Editar > Copiar.
  3. Para criar uma nova máscara, selecione a camada na qual deseja criar a máscara e escolha Camada > Máscara > Nova máscara.
  4. No painel Linha de tempo, clique no nome da propriedade Caminho da máscara da máscara na qual deseja colar os quadros-chave do caminho de movimento.
  5. Escolha Editar > Colar.
    Selecionar e copiar quadros-chave de posição
    Seleção e cópia de quadros-chave Posição (esquerda); e colagem dos mesmos na propriedade Caminho da máscara selecionado (à direita)

Criar um caminho de forma a partir de um caminho de movimento

  1. No painel Linha de tempo, clique no nome da propriedade Posição ou propriedade Ponto de ancoragem a partir do qual deseja copiar o caminho de movimento. (Isso seleciona todos os quadros-chave. Para selecionar apenas alguns quadros-chave de um caminho de movimento, clique neles com a tecla Shift pressionada.)
  2. Escolha Editar > Copiar.
  3. Para criar uma nova camada de forma, pressione F2 para desmarcar todas as camadas e, em seguida, clique no painel Composição com a ferramenta Caneta para criar um caminho de Bézier de ponto único.
  4. Pressione SS para revelar a propriedade Caminho da forma. Clique no nome da propriedade Caminho em que deseja colar os quadros-chave do caminho de movimento.
  5. Escolha Editar > Colar.

Duplicar um grupo de formas durante a transformação

Quando um grupo de formas é selecionado no modo de seleção de grupo, é possível duplicar o grupo enquanto o move, gira ou redimensiona no painel Composição.

  • Mantenha a tecla Alt (Windows) ou Option (Mac OS) pressionada enquanto arrasta para transformar um grupo.

    O ponteiro se transforma em um ponteiro de duplicação ( ou ) enquanto pressiona a tecla e posiciona o ponteiro próximo da caixa de transformação do grupo.

Esta obra está licenciada sob uma licença não adaptada da Creative Commons Attribution-Noncommercial-Share Alike 3.0  As publicações do Twitter™ e do Facebook não são cobertas pelos termos do Creative Commons.

Avisos legais   |   Política de privacidade online