Guia do Usuário Cancelar

Camadas 3D

  1. Guia do usuário do After Effects
  2. Versões beta
    1. Visão geral do programa Beta
    2. Página inicial do After Effects Beta
  3. Introdução
    1. Introdução ao After Effects
    2. Novidades no After Effects 
    3. Notas de versão | After Effects
    4. Requisitos de sistema do After Effects
    5. Atalhos de teclado no After Effects
    6. Formatos de arquivo compatíveis | After Effects
    7. Recomendações de hardware
    8. After Effects para Apple Silicon
    9. Planejamento e configuração
  4. Espaços de trabalho
    1. Itens gerais da interface do usuário
    2. Conheça a interface do After Effects
    3. Fluxos de trabalho
    4. Espaços de trabalho, painéis e visualizadores
  5. Projetos e composições
    1. Projetos
    2. Noções básicas da composição
    3. Pré-composição, aninhamento e pré-renderização
    4. Exibir informações detalhadas de desempenho com o Criador de perfil de composição
    5. Renderizador de composição CINEMA 4D
  6. Importação de gravação
    1. Preparação e importação de imagens estáticas
    2. Importação do After Effects e do Adobe Premiere Pro
    3. Importação e interpretação de vídeo e áudio
    4. Preparo e importação de arquivos de imagem 3D
    5. Importação e interpretação de itens de gravação
    6. Trabalhar com itens de gravação
    7. Detectar pontos de edição usando a Detecção de edição de cena
    8. Metadados XMP
  7. Textos e gráficos
    1. Texto
      1. Formatação de caracteres e o painel Caractere
      2. Efeitos de texto
      3. Criação e edição de camadas de texto
      4. Formatação de parágrafos e o painel Parágrafo
      5. Extrusão de texto e camadas de forma
      6. Animação de texto
      7. Exemplos e recursos de animação de texto
      8. Modelos de texto dinâmico
    2. Animações
      1. Trabalhar com Modelos de animações no After Effects
      2. Usar expressões para criar listas suspensas em Modelos de animações
      3. Trabalhar com propriedades essenciais para criar Modelos de animações
      4. Substituir imagens e vídeos em Modelos de animações e Propriedades essenciais
      5. Anime de maneira mais rápida e fácil usando o painel Propriedades
  8. Desenho, pintura e caminhos
    1. Visão geral de camadas de forma, caminhos e gráficos vetoriais
    2. Ferramentas de pintura: Pincel, Carimbo e Borracha
    3. Traçados de forma cônica
    4. Atributos de forma, operações de pintura e operações de caminho para camadas de forma
    5. Use o efeito de forma Deslocar caminhos para alterar formas
    6. Criação de formas
    7. Criar máscaras
    8. Remover objetos de seus vídeos com o painel Preenchimento com reconhecimento de conteúdo
    9. Pincel tipo rotoscópio e Refinar fosco
  9. Camadas, marcadores e câmera
    1. Seleção e organização de camadas
    2. Modos de mesclagem e estilos de camadas
    3. Camadas 3D
    4. Propriedades da camada
    5. Criação de camadas
    6. Gerenciamento de camadas
    7. Marcadores de camada e de composição
    8. Câmeras, luzes e pontos de interesse
  10. Animação, quadros-chave, rastreamento de movimento e chaveamento
    1. Animação
      1. Noções básicas de animação
      2. Animação com ferramentas Marionete
      3. Gerenciamento e animação de caminhos de forma e máscaras
      4. Animação de desenho e captura de formas usando o After Effects
      5. Ferramentas de animação diversas
      6. Trabalhar com animação orientada por dados
    2. Quadro-chave
      1. Interpolação do quadro-chave
      2. Definir, selecionar e excluir quadros-chave
      3. Editar, mover e copiar quadros-chave
    3. Rastreamento de movimento
      1. Rastrear e estabilizar movimento
      2. Reconhecimento facial
      3. Rastreamento de máscara
      4. Referência de máscara
      5. Velocidade
      6. Esticamento e remapeamento de tempo
      7. Timecode e unidades de exibição de tempo
    4. Aplicação de máscara
      1. Aplicação de máscara
      2. Efeitos de máscara
  11. Transparência e composição
    1. Visão geral e recursos da composição e transparência
    2. Canais alfa e máscaras
    3. Foscos de controle e foscos móveis
  12. Ajustar cor
    1. Noções básicas de cores
    2. Gerenciamento de cores
    3. Efeitos de correção de cores
    4. Gerenciamento de cores OpenColorIO e ACES
  13. Predefinições de animação e efeitos
    1. Visão geral das predefinições de animação e efeitos
    2. Lista de efeitos
    3. Gerenciador de efeitos
    4. Efeitos de simulação
    5. Efeitos de estilo
    6. Efeitos de áudio
    7. Efeitos de distorção
    8. Efeitos de perspectiva
    9. Efeitos de canal
    10. Efeitos de geração
    11. Efeitos de transição
    12. O efeito Reparo do obturador de rolagem
    13. Efeitos Desfoque e Tornar nítido
    14. Efeitos de Canal 3D
    15. Efeitos de utilitários
    16. Efeitos de fosco
    17. Efeitos Ruído e Granulação
    18. Efeito de ampliação com preservação de detalhes
    19. Efeitos obsoletos
  14. Expressões e automação
    1. Expressões
      1. Noções básicas de expressão
      2. Entender sobre a linguagem de expressões
      3. Utilização de controles de expressão
      4. Diferenças de sintaxe entre os mecanismos de expressão Javascript e Legacy ExtendScript
      5. Edição de expressões
      6. Erros de expressão
      7. Utilização do editor de expressões
      8. Usar expressões para editar e acessar propriedades de texto
      9. Referência de idioma de expressão
      10. Exemplos de expressão
    2. Automação
      1. Automação
      2. Scripts
  15. Vídeo imersivo, VR e 3D
    1. Construa ambientes VR no After Effects
    2. Aplicar efeitos de vídeo imersivo
    3. Ferramentas de composição para vídeos VR/360
    4. Renderizador 3D avançado
    5. Importar e adicionar modelos 3D à composição
    6. Importação de modelos 3D das bibliotecas da Creative Cloud
    7. Iluminação com base na imagem
    8. Extração e animação de luzes e câmeras de modelos 3D
    9. Rastreamento de movimento de câmera 3D
    10. Projetar e aceitar sombras
    11. Animações de modelos 3D incorporadas
    12. Coletor de sombras
    13. Extração de dados de profundidade 3D
    14. Trabalhar no Espaço de design 3D
    15. Gizmos de transformação 3D
    16. Faça mais com a animação 3D
    17. Visualização de alterações em projetos 3D em tempo real com o mecanismo Mercury 3D.
    18. Adicionar design responsivo aos gráficos 
  16. Exibições e visualizações
    1. Visualizar
    2. Visualização de vídeo com o Mercury Transmit
    3. Modificação e utilização de exibições
  17. Renderização e exportação
    1. Noções básicas de renderização e exportação
    2. Codificação em H.264 no After Effects
    3. Exportar um projeto do After Effects como um projeto do Adobe Premiere Pro
    4. Conversão de filmes
    5. Renderização de vários quadros
    6. Renderização automatizada e renderização de rede
    7. Renderização e exportação de imagens estáticas e sequências de imagens estáticas
    8. Utilização do codec GoPro CineForm no After Effects
  18. Trabalho com outros aplicativos
    1. Dynamic Link e After Effects
    2. Trabalhar com o After Effects e outros aplicativos
    3. Sincronizar configurações no After Effects
    4. Bibliotecas da Creative Cloud no After Effects
    5. Plug-ins
    6. Cinema 4D e Cineware
  19. Colaboração: Frame.io e Team Projects
    1. Colaboração no Premiere Pro e After Effects
    2. Frame.io
      1. Instalar e ativar o Frame.io
      2. Usar Frame.io com Premiere Pro e After Effects
      3. Perguntas frequentes
    3. Team Projects
      1. Introdução ao Team Projects
      2. Criar um Projeto de equipe
      3. Colaborar com o Team Projects
  20. Memória, armazenamento e desempenho
    1. Memória e armazenamento
    2. Como o After Effects lida com problemas de memória insuficiente durante uma visualização    
    3. Melhorar o desempenho
    4. Preferências
    5. GPU e os requisitos de driver de GPU para o After Effects
  21. Knowledge Base
    1. Problemas conhecidos
    2. Problemas corrigidos
    3. Perguntas frequentes
    4. After Effects e macOS Ventura
    5. Como o After Effects lida com problemas de memória insuficiente durante uma visualização
Observação:

O conteúdo do artigo se aplica em geral ao renderizador 3D clássico. Para obter informações sobre o renderizador com rastreado de raio 3D, consulte Extrusão de texto e camadas de forma e assista a este tutorial em vídeo.

Visão geral e recursos de camadas 3D

Quando você converte uma camada em uma camada 3D, a camada em si permanece simples, mas ganha propriedades adicionais: Posição (z), Ponto de ancoragem (z), Escala (z), Orientação, Rotação X, Rotação Y, Rotação Z e propriedades das Opções de material. As propriedades Opções de material especificam como a camada interage com a luz e as sombras. Apenas as camadas 3D interagem com as sombras, luzes e câmeras.

Camadas 2D e camadas com propriedades 3D
Camadas 2D (à esquerda) e camadas com propriedades 3D (direita)

Os caracteres individuais nas camadas de texto podem ser opcionalmente subcamadas 3D, com suas propriedades 3D. Uma camada de texto com a opção Ativar por caractere 3D selecionada se comporta como uma pré-composição, que consiste em uma camada 3D para cada caractere. Todas as camadas da câmera e de luz têm propriedades 3D.

Por padrão, as camadas têm uma profundidade (posição do eixo z) 0. No After Effects, a origem do sistema de coordenadas está no canto superior esquerdo; x (largura) aumenta da esquerda para a direita, y (altura) aumenta de cima para baixo e z (profundidade) aumenta de próximo para distante. Alguns aplicativos de vídeo e 3D usam um sistema de coordenadas que é girado em 180 graus ao redor do eixo x ; nesses sistemas, y aumenta da parte inferior para a superior, e z aumenta de longe para perto.

Você pode transformar uma camada 3D em relação ao espaço de coordenadas da composição, ao espaço de coordenadas da camada ou a um espaço personalizado selecionando um modo de eixo.

Você pode adicionar efeitos e máscaras a camadas 3D, camadas 3D compostas com camadas 2D e criar e animar camadas de câmera e de luz para exibir ou iluminar camadas 3D a partir de qualquer ângulo. Ao renderizar para saída final, as camadas 3D são renderizadas da perspectiva da câmera ativa. (Consulte Criar uma camada de câmera e alterar as configurações da câmera.)

Todos os efeitos são 2D, inclusive efeitos que simulam distorções 3D. Por exemplo, ver uma camada com o efeito Saliência de lado não mostra uma protrusão.

Como ocorre com todas as máscaras, as coordenadas da máscara em uma camada 3D estão no espaço de coordenadas 2D da camada.

Converter camadas 3D

Ao converter uma camada para 3D, o valor de profundidade (z) é adicionado à sua posição, ao ponto de ancoragem e às propriedades de escala, e a camada ganha propriedades de Orientação, Rotação Y, Rotação X e Opções de material. A propriedade Rotação única foi renomeada para Rotação Z.

Ao converter uma camada 3D novamente em 2D, as propriedades Rotação Y, Rotação X, Orientação e Opções de material são removidas, incluindo todos os valores, quadros-chave e expressões. (Esses valores não podem ser restaurados convertendo a camada de volta à camada 3D). As propriedades Ponto de ancoragem, Posição e Escala permanecem, juntamente com os quadros-chave e as expressões, mas seus valores z ficam ocultos e serão ignorados.

Converter uma camada em uma camada 3D

  1. Selecione a opção Camada 3D para a camada no painel Linha do tempo ou selecione a camada e escolha Camada > Camada 3D.

Converter uma camada de texto em uma camada 3D com as propriedades 3D por caractere habilitadas

  1. Escolha Animação > Animar texto > Habilitar 3D por caractere ou escolha Habilitar 3D por caractere no menu Animação para a camada do painel Linha de tempo.

Converter uma camada 3D em uma camada 2D

  1. Desmarque a opção Camada 3D para a camada no painel Linha do tempo ou selecione a camada e escolha Camada > Camada 3D.

Mostrar ou ocultar os eixos 3D e os controles de camada

Os eixos 3D são setas codificadas por cores: vermelho para x, verde para y e azul para z.

  • Para mostrar ou ocultar os eixos 3D, ícones de wireframe de luz e câmera, alças de camada e o ponto de interesse, selecione Exibir > Mostrar controles de camada.
Observação:

Se o eixo que você deseja manipular for difícil de ver, tente uma configuração diferente no menu Selecionar layout de exibição na parte inferior do painel Composição.

  • Para mostrar ou ocultar um conjunto de eixos de referência 3D persistentes, clique no botão Opções de grade e guias na parte inferior do painel Composição e escolha Eixos de referência 3D.

Chris e Trish Meyer fornecem um tutorial em vídeo no site da ProVideo Coalition que demonstra o uso dos controles de camada de eixo 3D.

Mover uma camada 3D

  1. Selecione a camada 3D que deseja mover.
  2. Siga um destes procedimentos:
    • No painel Composição, use a ferramenta Seleção  para arrastar a ponta da seta do controle de camada do eixo 3D correspondente ao eixo ao longo do qual você deseja mover a camada. Pressione Shift e arraste para mover a camada mais rapidamente.
    • No painel Linha de tempo, modifique os valores da propriedade Posição.
    Observação:

    Pressione P para mostrar a Posição.

    • Para mover as camadas selecionadas para que os pontos de ancoragem fiquem no centro na exibição atual, escolha Camada > Transformar > Centralizar na exibição ou pressione Ctrl+Home (Windows) ou Command+Home (Mac OS).

Girar ou orientar uma camada 3D

É possível girar uma camada 3D alterando os valores Orientação ou Rotação. Em ambos os casos, a camada vai girar em torno do seu ponto de ancoragem. As propriedades Orientação e Rotação diferem na forma como a camada se move quando você as anima.

Ao animar a propriedade Orientação de uma camada 3D, a camada gira o mais direto possível para alcançar a orientação especificada. Ao animar qualquer propriedade de rotação X, Y ou Z, a camada gira ao longo de cada eixo individual específico de acordo com os valores de propriedades individuais. Em outras palavras, os valores de Orientação especificam um destino angular, enquanto os valores de Rotação especificam uma rota angular. Anime as propriedades de rotação para fazer uma camada girar várias vezes.

Animar a propriedade de orientação é, muitas vezes, melhor para um movimento natural e suave, enquanto animar as propriedades de rotação fornece um controle mais preciso.

Girar ou orientar uma camada 3D no painel Composição

  1. Selecione a camada 3D que deseja girar.
  2. Selecione a ferramenta de rotação e escolha Orientação ou Rotação no menu Definir para determinar se a ferramenta afetará as propriedades Orientação ou Rotação.
  3. No painel Composição, siga um destes procedimentos:
    • Arraste a ponta da seta de controle de camada do eixo 3D correspondente ao eixo em torno do qual você quer girar a camada.
    • Arraste uma alça de camada. Arrastar uma alça de vértice gira a camada ao redor do eixo z; arrastar uma alça central esquerda ou direita gira a camada ao redor do eixo y; arrastar uma alça superior ou inferior gira a camada ao redor do eixo x.
    • Arraste a camada.
    Observação:

    Arrastar com a tecla Shift pressionada, restringirá suas alterações a incrementos de 45 graus.

Girar ou orientar uma camada 3D no painel Linha do tempo

  1. Selecione a camada 3D que deseja girar.
  2. No painel Linha do tempo, modifique os valores das propriedades Rotação ou Orientação.
    Observação:

    Pressione R para mostrar as propriedades Rotação e Orientação.

Recursos online sobre a rotação e a orientação de camadas 3D

Donat Van Bellinghen fornece algumas expressões no fórum AE Enhancers para posicionar e orientar uma camada 3D no plano definido por três pontos.

Modos de eixo

Os modos de eixo especificam em qual conjunto de eixos uma camada 3D é transformada. Escolha um modo no painel Ferramentas.

Modo de eixo local

Alinha os eixos à superfície de uma camada 3D.

Modo de eixo mundial

Alinha os eixos às coordenadas absolutas da composição. Independentemente das rotações executadas em uma camada, os eixos sempre representam o espaço 3D relativo ao mundo 3D.

Modo de eixo de exibição

Alinha os eixos à exibição selecionada. Por exemplo, suponha que uma camada esteve girada e a exibição mudou para uma exibição personalizada; qualquer transformação subsequente feita na camada enquanto o modo Eixo de exibição ocorre ao longo dos eixos que correspondem à direção do qual você está visualizando a camada.

As diferenças entre os modos de eixo só são relevantes se você tiver uma câmera 3D em uma composição.

O painel Ferramentas lembra o último modo de eixo 3D usado ao sair e reiniciar o After Effects.

Observação:

As ferramentas de câmera sempre se ajustam ao longo dos eixos locais da exibição, portanto a ação das ferramentas de câmera não é afetada pelos modos de eixo.

Angie Taylor explica os modos de eixo 3D neste tutorial.

Interações de camadas 3D, ordem de renderização e transformações recolhidas

As posições de determinados tipos de camadas na ordem de empilhamento de camadas no painel Linha do tempo evitam que grupos de camadas 3D sejam processados juntos para determinar interseções e sombras.

Uma sombra projetada por uma camada 3D não afeta uma camada 2D ou qualquer camada que esteja do outro lado da camada 2D na ordem de empilhamento de camadas. Da mesma forma, uma camada 3D não faz intersecção com uma camada 2D ou com qualquer camada que esteja do outro lado da camada 2D na ordem de empilhamento de camadas. Não existe nenhuma restrição para luzes.

Interações de camada 3D, ordem de renderização e transformações recolhidas
Intersecção de camadas 3D (à esquerda) e camadas 3D impedidas de fazer intersecção pela camada 2D interposta (direita)

Assim como as camadas 2D, outros tipos de camadas também impedem que as camadas 3D de ambos os lados façam intersecção ou projetem sombras umas nas outras:

  • Uma camada de ajuste

  • Uma camada 3D com um estilo de camada aplicado

  • Uma camada de pré-composição 3D a qual um efeito, uma máscara fechada (com um modo de máscara diferente de Nenhum) ou fosco de controle foi aplicado

  • Uma camada de pré-composição 3D sem transformações recolhidas

Uma pré-composição com transformações recolhidas (opção Transformações recolhidas selecionada) não interfere na interação de camadas 3D em nenhum dos lados, desde que todas as camadas na pré-composição sejam camadas 3D. Recolher transformações expõe as propriedades 3D das camadas que compõem a pré-composição. Basicamente, recolher transformações neste caso, permite que cada camada 3D seja composta na composição principal individualmente, em vez de criar um composto 2D único para a camada de pré-composição e fazer a composição desta na composição principal. A desvantagem é que essa configuração elimina a capacidade de especificar determinadas configurações de camada para a pré-composição como um todo, como o modo de mesclagem, a qualidade e o desfoque de movimento.

As sombras projetadas pelas camadas 3D continuamente rasterizadas (incluindo camadas de texto) não são afetadas por efeitos aplicados a essa camada. Se quiser que a sombra mostre os resultados do efeito, pré-componha a camada com o efeito.

Observação:

Para garantir que as sombras permaneçam onde esperado em uma camada 3D com um fosco de controle, pré-componha a camada 3D e a camada de fosco de controle juntas (mas não recolha as transformações) e aplique as sombras à pré-composição.

Os efeitos em camadas de vetor rasterizadas continuamente com propriedades 3D são renderizados em 2D e, em seguida, projetados na camada 3D. A projeção não ocorre para composições com transformações recolhidas.

 Adobe

Receba ajuda com mais rapidez e facilidade

Novo usuário?

Adobe MAX 2024

Adobe MAX:
a conferência da criatividade

14 a 16 de outubro, Miami Beach e online

Adobe MAX

A conferência da criatividade

14 a 16 de outubro, Miami Beach e online

Adobe MAX 2024

Adobe MAX:
a conferência da criatividade

14 a 16 de outubro, Miami Beach e online

Adobe MAX

A conferência da criatividade

14 a 16 de outubro, Miami Beach e online