Sobre a interpolação do quadro-chave espacial e temporal

A interpolação é o processo de preenchimento de dados desconhecidos entre dois valores conhecidos. Defina quadros-chave para especificar valores de propriedades em determinados tempos chave. After Effects interpola os valores para a propriedade para todos os tempos entre quadros-chave.

Uma vez que uma interpolação gera valores de propriedade entre quadros-chave, a interpolação é, às vezes, chamada tweening. A interpolação entre quadros-chave pode ser usada para animar movimento, efeitos, níveis de áudio, ajustes de imagem, transparência, alterações de cor e muitos outros elementos visuais e áudio.

Depois de criar quadros-chave e caminhos de movimento para alterar valores ao longo do tempo, você pode querer realizar ajustes mais precisos à forma como essa alteração ocorre. O After Effects oferece vários métodos de interpolação que afetam como os valores intermediários são calculados.

A interpolação temporal é a interpolação de valores no tempo; a interpolação espacial é a interpolação de valores no espaço. Algumas propriedades – como Opacidade – têm apenas um componente temporal. Outras propriedades – como Posição – também têm componentes espaciais.

Interpolação temporal e o gráfico de valor

Usando o gráfico de valor no Editor de gráfico, é possível fazer ajustes precisos em quadros-chave de propriedade temporal que você criou para sua animação. O gráfico de valor exibe valores x como vermelho, y como verde e valor z (somente 3D) como azul. O gráfico de valor oferece informações completas sobre o valor de quadros-chave em qualquer ponto no tempo em uma composição e permite controlá-lo. Além disso, o painel Informações exibe o método de interpolação temporal de um quadro-chave selecionado.

Interpolação espacial e o caminho de movimento

Quando você aplica ou altera a interpolação espacial de uma propriedade como Posição, você ajusta o caminho de movimento no painel Composição. Os diferentes quadros-chave no caminho de movimento oferecem informações sobre o tipo de interpolação em qualquer ponto no tempo. O painel Informações exibe o método de interpolação espacial de um quadro-chave selecionado.

Ao criar alterações espaciais em uma camada, o After Effects usa o Bézier automático como interpolação espacial padrão.

Observação:

Para alterar o padrão para interpolação linear, escolha Editar > Preferências > Geral (Windows) ou After Effects > Preferências > Geral (Mac OS) e selecione Interpolação espacial padrão para linear. Alterar a configuração de preferência não afeta os quadros-chave que já existem ou os novos quadros-chave em propriedades para as quais os quadros-chave já existem.

Interpolação do caminho de movimento: Linear, Bézier automático, Bézier contínuo, Bézier e Em espera
Interpolação do caminho de movimento 

A. Linear B. Bézier automático C. Bézier contínuo D. Bézier E. Retenção 

Em alguns casos, a interpolação espacial Bézier automático para quadros-chave Posição pode causar movimento para trás e para frente indesejado (bumerangue) entre dois quadros-chave com valores iguais. Nesse caso, você pode alterar o quadro-chave anterior para usar a interpolação de retenção ou alterar os dois quadros-chave para usar interpolação linear.

Recursos online sobre a interpolação do quadro-chave

Aharon Rabinowitz oferece um conjunto de tutoriais em vídeo no site da Creative COW que descrevem a edição e a solução do problema do movimento bumerangue que se origina de ter intencionalmente a interpolação espacial de Bézier automático definida para quadros-chave de valor igual:

Antony Bolante oferece informações e ilustrações sobre interpolação do quadro-chave em um artigo no site da Peachpit Press.

Métodos de interpolação do quadro-chave

No modo de barra de camadas, a aparência de um ícone de quadro-chave depende do método de interpolação que você escolhe para o intervalo entre quadros-chave. Quando metade do ícone é cinza-escuro , a metade escura indica que nenhum quadro-chave está adjacente a este lado ou que a interpolação é substituída pela interpolação de retenção aplicada ao quadro-chave anterior.

Por padrão, um quadro-chave usa um método de interpolação, mas você pode aplicar dois métodos: o método de entrada se aplica ao valor da propriedade à medida que o tempo atual se aproxima de um quadro-chave e o método de saída se aplica ao valor da propriedade à medida que o tempo atual deixa um quadro-chave. Quando você define diferentes métodos de interpolação de entrada e de saída, o ícone do quadro-chave no modo de barra de camadas muda em conformidade. Ele exibe a metade esquerda do ícone de interpolação de entrada e a metade direita do ícone de interpolação de saída.

Observação:

Para alternar entre ícones do quadro-chave e de números de quadro-chave, selecione Usar ícones do quadro-chave ou Usar índices do quadro-chave no painel Linha de tempo.

Ícones do quadro-chave no painel Linha de tempo no modo de barra de camadas: Linear; Linear de entrada, Retenção de saída; Bézier automático; Bézier contínuo ou Bézier; Linear de entrada, Bézier de saída
Exemplos de ícones do quadro-chave no painel Linha de tempo no modo de barra de camadas 

A. Linear B. Linear de entrada, Retenção de saída C. Bézier automático D. Bézier contínuo ou Bézier E. Linear de entrada, Bézier de saída 

Todos os métodos de interpolação usados pelo After Effects são baseados no método de interpolação Bézier , que fornece alças de direção de forma que você possa controlar as transições entre os quadros-chave. Os métodos de interpolação que não usam alças de direção são versões restringidas de interpolação de Bézier e são convenientes para determinadas tarefas.

Para saber mais sobre como os diversos métodos de interpolação afetam as propriedades temporais, experimente configurar pelo menos três quadros-chave com valores diferentes para uma propriedade de camada temporal – como Opacidade – e alterar os métodos de interpolação como você visualiza o gráfico de valor no modo Editor de gráfico no painel Linha de tempo.

Para saber mais sobre como os diversos métodos de interpolação afetam um caminho de movimento, experimente configurar pelo menos três quadros-chave para uma propriedade espacial – como Posição – com diferentes valores em um caminho de movimento e alterar os métodos de interpolação ao visualizar o movimento no painel Composição.

Observação:

Para alterar os métodos de interpolação, clique com o botão direito do mouse em um quadro-chave, selecione Interpolação do quadro-chave no menu exibido e escolha uma opção no menu Interpolação temporal.

Para clarificar os exemplos nas descrições a seguir dos métodos de interpolação, o resultado de cada método é descrito como se você o tivesse aplicado a todos os quadros-chave de uma propriedade de camada. Na prática, é possível aplicar quaisquer métodos de interpolação disponíveis a qualquer quadro-chave.

Nenhuma interpolação

Nenhuma interpolação é o estado em que uma propriedade não tem nenhum quadro-chave – quando o cronômetro está desativado e o ícone de feixe I aparece no painel Linha de tempo sob o indicador do tempo atual. Neste estado, quando você define o valor de uma propriedade, mantém esse valor para a duração da camada, a menos que substituído por uma expressão. Por padrão, nenhuma interpolação é aplicada a uma propriedade de camada. Se qualquer quadro-chave estiver presente para uma propriedade de camada, algum tipo de interpolação está em uso.

Interpolação linear

A interpolação linear cria uma taxa de modificação uniforme entre quadros-chave, que pode adicionar uma aparência mecânica às animações. After Effects interpola os valores entre dois quadros adjacentes o mais diretamente possível sem contar com os valores de outros quadros-chave.

Se você aplicar interpolação linear a todos os quadros-chave de uma propriedade de camada temporal, a alteração começará imediatamente no primeiro quadro-chave e continua até o próximo quadro-chave em uma velocidade constante. No segundo quadro-chave, a taxa de alteração muda instantaneamente para a taxa entre ele e o terceiro quadros-chave. Quando a camada atinge o valor final de um quadro-chave, a alteração para imediatamente. No gráfico de valor, o segmento que conecta dois quadros-chave na interpolação linear aparece como uma linha reta.

Interpolação de Bézier

A interpolação de Bézier oferece o controle mais preciso porque você ajusta manualmente a forma de gráfico de valor ou segmentos de caminho de movimento em ambos os lados do quadro-chave. Diferentemente de Bézier automático ou Bézier contínuo, as duas alças de direção em um quadro-chave de Bézier funcionam independentemente tanto no gráfico de valor e caminho de movimento.

Se você aplicar interpolação de Bézier a todos os quadros-chave de uma propriedade de camada, o After Effects cria uma transição suave entre os quadros-chave. A posição inicial das alças de direção é calculada usando o mesmo método utilizado na interpolação Bézier automático. O After Effects mantêm posições das alças de direção existentes à medida que você muda um valor de quadro-chave de Bézier.

Ao contrário dos outros métodos de interpolação, a interpolação de Bézier permite criar qualquer combinação de curvas e linhas retas no caminho de movimento. Como as duas alças de direção de Bézier funcionam de maneira independente, um caminho de movimento de curva pode de repente se transformar em um canto agudo em um quadro-chave de Bézier. A interpolação espacial de Bézier é ideal para desenhar um caminho de movimento que segue uma forma complexa, como uma rota de mapa ou o contorno de um logotipo.

As posições de alças de direção existentes permanecem conforme você move um quadro-chave de caminho de movimento. A interpolação temporal aplicada em cada quadro-chave controla a velocidade de movimento ao longo do caminho.

Interpolação Bézier automático

A interpolação Bézier automático cria uma taxa de suavização de modificação através de um quadro-chave. Você pode usar a interpolação espacial de Bézier para criar o caminho de um carro que vira em um uma curva de estrada.

Quando você altera um valor de quadro-chave de Bézier automático as posições das alças de direção de Bézier automático mudam automaticamente para manter uma transição suave entre quadros-chave. Os ajustes automáticos alteram a forma do gráfico de valor ou os segmentos de caminho de movimento em qualquer um dos lados do quadro-chave. Se o quadro-chave anterior e os subsequentes também usarem a interpolação Bézier automático, a forma dos segmentos no lado oposto dos quadros-chave anteriores ou seguintes também mudam. Se você ajustar uma alça de direção de Bézier automático manualmente, o quadro-chave será convertido para Bézier contínuo .

Bézier automático é a interpolação espacial padrão.

interpolação Bézier contínuo

Como a interpolação Bézier automático, a interpolação Bézier contínuo cria uma taxa suave de modificação através de um quadro-chave. Contudo, você define as posições das alças de direção de Bézier contínuo manualmente. Os ajustes que você faz mudam a forma do gráfico de valor ou segmentos de caminho de movimento em qualquer um dos lados do quadro-chave.

Se você aplicar interpolação Bézier contínuo a todos os quadros-chave de uma propriedade, o After Effects ajusta os valores de cada quadro-chave para criar transições suaves. O After Effects mantém essas transições suaves conforme você move um quadro-chave de Bézier contínuo em qualquer um dos caminhos de movimento ou gráfico de valor.

Interpolação de retenção

A interpolação de retenção está disponível somente como um método de interpolação temporal. Use-a para alterar o valor de uma propriedade de camada ao longo do tempo, mas sem uma transição gradual. Este método é útil para efeitos de estroboscópio ou quando você deseja que camadas apareçam ou desapareçam de repente.

Se você aplicar interpolação temporal de retenção a todos os quadros-chave de uma propriedade de camada, o valor do primeiro quadro-chave permanece constante até o próximo quadro-chave, quando os valores mudam imediatamente. No gráfico de valor, o segmento de gráfico após um quadro-chave de retenção aparece como uma linha reta horizontal.

Embora a interpolação de retenção esteja disponível somente como um método de interpolação temporal, os quadros-chave no caminho de movimento são visíveis, mas eles não são conectados pelos pontos de posição e camada. Por exemplo, se você animar a propriedade Posição de uma camada usando Interpolação de retenção, a camada é retida no valor da posição do quadro-chave anterior até que o indicador do tempo atual atinja o próximo quadro-chave, em cujo ponto a camada desaparece e aparece na nova posição.

É fácil congelar o quadro atual na duração da camada usando o comando Congelar quadro. Para congelar um quadro, posicione o indicador do tempo atual no quadro que deseja congelar. Certifique-se de que a camada esteja selecionada e depois escolha Camada > Tempo > Congelar quadro. O remapeamento de tempo é ativado e um Quadro-chave de retenção colocado na posição do indicador do tempo atual para congelar o quadro.

Observação:

Se você tiver ativado o remapeamento de tempo anteriormente, qualquer quadro-chave criado é excluído ao aplicar o comando Congelar quadro.

Você pode usar interpolação de retenção somente para interpolação temporal de saída (para quadros seguindo um quadro-chave). Se você criar um quadro-chave seguindo uma quadro-chave de retenção, o novo quadro-chave usa a interpolação de retenção de entrada.  

Observação:

Para aplicar ou remover a interpolação de retenção como interpolação de saída para um quadro-chave, selecione o quadro-chave no painel Linha de tempo e escolha Animação > Alternar quadro-chave de retenção.

Aplicar e alterar métodos de interpolação do quadro-chave

Você pode aplicar e alterar o método de interpolação para qualquer quadro-chave. Você pode aplicar alterações na caixa de diálogo Interpolação do quadro-chave ou pode aplicá-las diretamente em um quadro-chave no modo da barra de camadas, em um caminho de movimento ou no Editor de gráfico. Você também pode alterar a interpolação padrão que o After Effects usa para propriedades espaciais.

Para obter informações sobre o uso de Atenuação simples para facilitar automaticamente a velocidade entre quadros-chave, consulte Controlar a velocidade entre quadros-chave.

Alterar método de interpolação com a caixa de diálogo Interpolação do quadro-chave

A caixa de diálogo Interpolação do quadro-chave oferece opções para definir a interpolação temporal e espacial e – para propriedades espaciais somente – configurações itinerantes.

  1. No modo da barra de camadas ou no Editor de gráfico, selecione os quadros-chave que deseja alterar.
  2. Escolha Animação > Interpolação do quadro-chave.
  3. Para Interpolação temporal, escolha uma das seguintes opções:

    Configurações atuais

    Preserva os valores de interpolação já aplicados aos quadros-chave selecionados. Escolha essa opção quando vários quadros-chave ou quadros-chave ajustados manualmente são selecionados e você não quiser alterar as configurações existentes.

    Linear, Bézier, Bézier contínuo, Bézier automático e Retenção

    Aplique um método de interpolação temporal usando valores padrão.

  4. Se você selecionou quadros-chave de uma propriedade de camada espacial, escolha uma das seguintes opções de Interpolação espacial:

    Configurações atuais

    Preserva as configurações de interpolação já aplicadas aos quadros-chave selecionados.

    Linear, Bézier, Bézier contínuo e Bézier automático

    Aplique um método de interpolação espacial usando valores padrão.

  5. Se você selecionou quadros-chave de uma propriedade de camada espacial, use o menu Itinerante para escolher como um quadro-chave determina sua posição no tempo e clique em OK:

    Configurações atuais

    Preserva o método atualmente aplicado de posicionar os quadros-chave selecionados no tempo.

    Deslocar no tempo

    Suaviza a taxa de modificação através dos quadros-chave selecionados automaticamente variando sua posição no tempo, com base nas posições dos quadros-chave imediatamente antes e após a seleção.

    Bloquear no tempo

    Mantém os quadros-chave selecionados na sua posição atual no tempo. Ficam no lugar a menos que você os mova manualmente.

    Para obter mais informações sobre a suavização da taxa de alteração através de quadros-chave selecionados, consulte Suavizar o movimento com quadros-chave itinerantes.

Alterar o método de interpolação com a ferramenta Seleção no modo da barra de camadas

  1. Usando a ferramenta Seleção, siga um desses procedimentos:
    • Se o quadro-chave usa interpolação Linear, com a tecla Ctrl (Windows) ou Command (Mac OS) pressionada, clique no quadro-chave para alterá-lo para Bézier automático .

    • Se o quadro-chave usa interpolação Bézier, Bézier contínuo ou Bézier automático com a tecla ctrl (Windows) ou Command (Mac OS) pressionada, clique no quadro-chave para arrastá-lo para Linear.

Alterar o método de interpolação no Editor de gráfico

  • Clique no quadro-chave com a ferramenta Converter vértice para alternar entre a interpolação Linear e Bézier automático.
  • Selecione um ou mais quadros-chave e, em seguida, clique no botão Retenção, Linear ou Bézier automático da tela para mudar o método de interpolação.
Botões de interpolação no Editor de gráfico: converter quadros-chave selecionados em Retenção; Converter quadros-chave selecionados em Linear; Converter quadros-chave selecionados em Bézier automático
Botões de interpolação no Editor de gráfico

A. Converter quadros-chave selecionados em Retenção B. Converter quadros-chave selecionados em Linear C. Converter quadros-chave selecionados em Bézier automático 

Modificar as alças de direção de Bézier no Editor de gráfico

No Editor de gráfico, os quadros-chave que usam interpolação de Bézier têm alças de direção anexados a eles. É possível retrair, estender ou girar as alças de direção para ajustar a curva de interpolação de Bézier em um gráfico de valor. É possível retrair ou estender as alças de direção para ajustar a curva em um gráfico de velocidade.

Por padrão, quando você retrai ou estende uma alça de direção, a alça oposta no quadro-chave se move com ele. As alças de direção de divisão tornam as duas alças de direção anexadas ao quadro-chave se comportarem independentemente.

  • Para retrair ou estender as alças de direção, arraste a alça de direção para próximo ou longe do centro de seu quadro-chave com a ferramenta Seleção.
  • Para dividir as alças de direção, com a tecla Alt (Windows) ou o Option (Mac OS) pressionada, clique em um quadro-chave com a ferramenta Seleção. Você também pode arrastar com a tecla Alt (Windows) ou Option (Mac OS) pressionada fora de uma quadro-chave para desenhar novas alças, se as alças já existam ou não.
  • Para manipular as alças de direção de dois quadros-chave vizinhos simultaneamente, arraste o segmento de gráfico de valor entre os quadros-chave.
Estender uma alça de direção Bézier no gráfico de velocidade
Estender uma alça de direção Bézier no gráfico de velocidade

Esta obra está licenciada sob uma licença não adaptada da Creative Commons Attribution-Noncommercial-Share Alike 3.0  As publicações do Twitter™ e do Facebook não são cobertas pelos termos do Creative Commons.

Avisos legais   |   Política de privacidade online