Sobre arquivos importados e itens de gravação

Importe arquivos de origem para um projeto como base de itens de gravação e use-os como origens de camadas. O mesmo arquivo pode ser a origem para vários itens de gravação, cada um com suas próprias configurações de interpretação. Cada item de gravação pode ser usado como origem de uma ou mais camadas. Trabalhe com coleções de camadas em uma composição.

Você trabalha essencialmente com itens de gravação no painel Projeto. Use o painel Gravação para avaliar a gravação e executar tarefas de edição simples, como aparo de duração de um item de gravação.

Você pode importar vários tipos diferentes de arquivos, coleções de arquivos ou componentes de arquivos como origens para artigos individuais de gravação, incluindo arquivos de imagem de movimento, arquivos de imagens estáticas, sequências de imagem estática e arquivos de áudio. Pode inclusive criar itens de gravação você mesmo no After Effects, como sólidos e pré-composições. Você pode importar itens de gravação para um projeto a qualquer momento.

Ao importar arquivos, o After Effects não copia os dados da imagem em si para o projeto, mas cria um link de referência para a origem do item de gravação, mantendo os arquivos do projeto relativamente pequenos.

Se você excluir, renomear ou mover um arquivo de origem importado, você quebra o link de referência para esse arquivo. Quando um link é desfeito, o nome do arquivo de origem aparece em itálico no painel Projeto e a coluna Caminho do arquivo lista ele como ausente. Se o item de gravação estiver disponível, você poderá restabelecer o link – geralmente basta clicar duas vezes no item e selecionar o arquivo novamente.

Observação:

Você pode encontrar itens de gravação cujos itens de origem estão ausentes digitando ausente no campo de pesquisa no painel Projeto. Consulte Pesquisar e filtrar nos painéis Linha de tempo, Projeto e Efeitos e predefinições.

Para reduzir o tempo de renderização e melhorar o desempenho, muitas vezes é melhor preparar a gravação antes de importá-la para o After Effects. Por exemplo, é melhor redimensionar ou cortar uma imagem estática no Photoshop antes de a colocar no After Effects, em vez de dimensionar e cortar a imagem no After Effects. É melhor executar uma operação uma vez no Photoshop que forçar o After Effects a realizar a mesma ação muitas vezes por segundo – uma vez para cada quadro no qual a imagem é exibida.

Para economizar tempo e minimizar o tamanho e a complexidade de um projeto, importe um item de origem como um único item de gravação e use-o várias vezes em uma composição. Contudo, ocasionalmente é útil duplicar um item de gravação e interpretar de forma diferente. Por exemplo, você pode usar a mesma gravação em duas taxas de quadros diferentes.

Se você usar outro aplicativo para modificar um item de gravação que é usado em um projeto, as alterações aparecerão no After Effects na próxima vez que você abrir o projeto ou selecionar o item de gravação e escolher Arquivo > Recarregar gravação.

Observação:

Para substituir o item de gravação de origem de uma camada por outro item de gravação, sem afetar as alterações feitas às propriedades de camada, selecione a camada e clique na tecla Alt (Windows) ou Option (Mac OS) e arraste o novo item de gravação para a camada no painel Linha de tempo.

Observação:

Para substituir todas as utilizações dos itens de gravação selecionados por outro item de gravação, selecione os itens de gravação no painel Projeto e, em seguida, clique com a tecla Alt (Windows) ou Option (Mac OS) e arraste o novo item de gravação para um item de gravação selecionado no painel Projeto.

Quando o After Effects importa vídeo e áudio em alguns formatos, ele processa e armazena em cache versões desse itens que pode acessar prontamente ao gerar visualizações. Esse cache aumenta consideravelmente o desempenho das visualizações, porque os itens de vídeo e áudio não precisam de ser reprocessados para cada visualização. 

Para obter mais informações sobre como importar ativos, consulte este tutorial em vídeo no site da Creative COW por Andrew Devis.

Codificação e decodificação nativas de arquivos do QuickTime

O After Effects pode decodificar e codificar nativamente arquivos do QuickTime (.mov) com os codecs GoPro Cineform no Mac OS e no Windows. Isso significa que você não precisa instalar codecs adicionais para usar e criar esses arquivos.

Em MOV, o After Effects tem suporte de importação nativo para os seguintes formatos sem compactação:

  • DV, IMX, MPEG2, XDCAM, h264, JPEG, Avid DNxHD, Avid DNxHR, Apple ProRes, AVCI e GoPro CineForm

O suporte à exportação nativa está disponível para os seguintes formatos não compactados:

  • Avid DNxHD, Avid DNxHR, DV e GoPro CineForm

Observação:

Porque o After Effects pode importar e exportar nativamente muitos codecs (listados acima), o QuickTime não é necessário no Windows. Para obter mais detalhes sobre problemas de compatibilidade, leia a publicação do blog QuickTime no Windows

Formatos de importação suportados

Alguns nomes de extensão de arquivo – como, por exemplo, MOV, AVI, MXF, FLV e F4V – denotam os formatos do arquivo do contêiner em vez de denotar o formato de dados específico de áudio, vídeo ou imagem. Os arquivos de contêiner podem conter dados codificados utilizando diversos esquemas de compactação e codificação. O After Effects pode importar estes arquivos de contêiner, mas a capacidade de importar os dados contidos depende de quais codecs (especificamente decodificadores) estão instalados.

Ao instalar codecs adicionais, você pode ampliar a capacidade do After Effects importar tipos de arquivos adicionais. Muitos codecs devem ser instalados no sistema operacional (Windows ou Mac OS) e funcionam como componentes dentro dos formatos QuickTime ou Vídeo para Windows. Entre em contato com o fabricante do seu hardware ou software para obter mais informações sobre os codecs que funcionam com os arquivos criados pelos dispositivos e aplicativos específicos.

Importar e usar alguns arquivos requer a instalação de plug-ins de importação adicionais. (Consulte Plug-ins.)

O Adobe Premiere Pro pode capturar e importar muitos formatos que o After Effects não pode importar nativamente. É possível transferir dados do Adobe Premiere Pro para o After Effects de várias maneiras. (Consulte Trabalhar com o Adobe Premiere Pro e o After Effects).

Formatos de áudio

  • Documento de som da Adobe (ASND, arquivos com diversas faixas importados como uma faixa única)

  • Advanced Audio Coding (AAC, M4A)

  • Audio Interchange File Format (AIF, AIFF)

  • MP3 (MP3, MPEG, MPG, MPA, MPE)

  • Vídeo para Windows (AVI; requer o QuickTime no Mac OS)

  • Waveform (WAV)

Formatos de imagem estática

  • Adobe Illustrator (AI, AI4, AI5, EPS, PS; rasterizada continuamente)
  • Adobe PDF (PDF; primeira página; rasterizada continuamente)
  • Adobe Photoshop (PSD)
  • Bitmap (BMP, RLE, DIB)
  • Camera Raw (TIF, CRW, NEF, RAF, ORF, MRW, DCR, MOS, RAW, PEF, SRF, DNG, X3F, CR2, ERF)
  • Cineon/DPX (CIN, DPX com arquivos DPX 8-, 10-, 12- e 16-bpc, incluindo os com canal alfa e timecode)
  • RLA/RPF distinto (RLA, RPF; 16bpc; importa dados da câmera)
  • EPS
  • GIF
  • JPEG (JPG, JPE)
  • Dados da câmera Maya (MA)
  • Maya IFF (IFF, TDI; 16bpc)
  • OpenEXR (EXR, SXR, MXR; 32bpc)
  • PICT (PCT)
  • Portable Network Graphics (PNG; 16 bpc)
  • Radiance HDR (, RGBE, XYZE; 32 bpc)
  • SGI (SGI, BW, RGB; 16 bpc)
  • Softimage (PIC)

Observação:

Os plug-ins do efeito Canal 3D do software de fnord são incluídos no After Effects para fornecer acesso às camadas e aos canais de vários arquivos OpenEXR. (Consulte Usar canais em arquivos OpenEXR.)

Observação:

O After Effects também pode ler arquivos de ZPIC que correspondem aos arquivos PIC importados. Consulte Importação e uso de arquivos 3D de outros aplicativos.)

  • Targa (TGA, VDA, ICB, VST)

  • TIFF (TIF)

Observação:

É possível importar arquivos de qualquer formato de imagem estática como uma sequência. Consulte Preparar e importar imagens estáticas.

Formatos de vídeo e animação

  • GIF Animado (GIF)
  • Avid DNxHR
  • HEVC (H.265) MPEG-4
  • Suporte para arquivos ARRIRAW de câmeras ARRI ALEXA ou ARRIFLEX D-21
    Para obter mais informações sobre os arquivos ARRIRAW, consulte as Perguntas frequentes do ARRIRAW no site do Grupo ARRI.
  • CinemaDNG

Observação: CinemaDNG é um subconjunto de Camera Raw. Um subconjunto de configurações de Camera Raw pode ser acessado em Mais opções na caixa de diálogo Interpretar gravação. O gerenciamento de cores para CinemaDNG inclui os mesmos espaços de cores que o After Effects CameraRAW existente: Adobe RGB, sRGB IEC619662.1, ColorMatch RGB e ProPhoto RGB.

  • DV (em contêiner MOV ou AVI, ou como transmissão sem contêiner DV)
  • Imagem elétrica (IMG, EI)
  • FLV, F4V
  • QuickTime (MOV; 16bpc, somente para codecs que não têm decodificadores nativos)
  • Vídeo para Windows (AVI, WAV; requer o QuickTime no Mac OS)

  • Arquivo do Windows Media (WMV, WMA, ASF; somente Windows)

  • XDCAM HD e XDCAM EX

  • RED (R3D)
  • Media eXchange Format (MXF)

MXF é o formato do contêiner. O After Effects somente pode importar alguns tipos de dados contidos em arquivos MXF. O After Effects pode importar a variedade Op-Atom de arquivos MXF usados por câmeras de vídeo Panasonic para gravar em mídias Panasonic P2. O After Effects pode importar vídeo desses arquivos MXF utilizando os codecs AVC-Intra 50, AVC-Intra 100, DV, DVCPRO, DVCPRO50 e DVCPRO HD. O After Effects também pode importar arquivos XDCAM HD no formato MXF, o formato MXF OP1, que contém vídeo em MPEG-2 que é compatível com o formato XDCAM HD.

  • Formatos MPEG-1, MPEG-2 e MPEG-4: MPEG, MPE, MPG, M2V, MPA, MP2, M2A, MPV, M2P, M2T, M2TS (AVCHD), MP4, M4V, M4A
  • SWF (rasterizado continuamente)

Formatos de projeto

  • Adobe Premiere Pro 1.0, 1.5, 2.0, CS3, CS4, CS5, CS6 e CC (PRPROJ; somente para 1.0, 1.5 e 2.0 Windows) e projetos posteriores

  • Adobe After Effects 6.0 e projetos binários posteriores no After Effects CS5 (AEP, AET)

  • O After Effects 7 pode abrir projetos do After Effects 3.0 pelo After Effects 7.

  • Adobe After Effects CS4 e projetos XML posteriores (AEPX)

O plug-in Automatic Duck Pro Import AE vem incluído agora com o aplicativo e é chamado Pro Import After Effects. Com ele, é possível importar arquivos AAF e OMF de um sistema Avid, arquivos XML do Final Cut Pro 7 ou anterior e arquivos de projeto do Motion 4 ou anterior. Para obter mais informações sobre como usar o Pro Import After Effects, consulte o guia do usuário, acessível escolhendo Arquivo > Importar > Pro Import After Effects, e clique no botão Ajuda.

Também é possível importar projetos do Final Premiere Pro e trazer os componentes do projeto para o After Effects.


Observação:

 

  • O After Effects também pode ler arquivos EIZ que correspondem aos arquivos EI importados. Consulte (Importação e uso de arquivos 3D de outros aplicativos.)
  • Alguns formatos de dados MPEG são armazenados em formato de contêiner com extensões de arquivo que não são reconhecidos pelo After Effects; exemplos incluem .vob e .mod. Em alguns casos, você pode importar esses arquivos para o After Effects depois de alterar a extensão de arquivo para uma das extensões de arquivo reconhecidas. Em função de variações na implementação em esses formatos de contêiner, a compatibilidade não é garantida.
  • Para obter informações sobre formatos MPEG, consulte o site MPEG e a página MPEG no site da Wikipedia.
  • Antes de trabalhar com o QuickTime, leia o alerta emitido pelo United States Computer Emergency Readiness Team em abril de 2016, que recomenda aos usuários do Windows desinstalar o Apple QuickTime dos computadores.
  • Os arquivos R3D são interpretados como contendo cores de 32 bpc em espaço de cores HDTV não linear (Rec. 709). As configurações de cores Configurações da origem RED R3D não preservam os valores com brilho demasiado. Os ajustes de cores realizados no After Effects preservam cores demasiado brilhantes quando você trabalha em uma cor de 32 bpc (bits por canal). Para evitar o recorte, manipule a exposição no After Effects, em vez de na fase de interpretação da gravação na caixa de diálogo Configurações da origem RED R3D.
  • O After Effects pode importar ativos XDCAM HD da Sony se foram gravados em arquivos MXF. O After Effects não pode importar ativos XDCAM HD no formato IMX. O After Effects pode importar ativos XDCAM EX da Sony armazenados como arquivos de essência com a extensão de arquivo .mp4 em um diretório BPAV. Para obter informações sobre o formato XDCAM, consulte esse documento PDF no site da Sony.
  • Os arquivos SWF são importados com um canal alfa. O áudio não é mantido. Os conteúdos interativos e a animação com script não são mantidos. A animação definida por quadros-chave no filme principal de nível superior é mantida.

Importar itens de gravação

É possível importar arquivos de mídia para seu projeto usando a caixa de diálogo Importar ou arrastando. Os itens de gravação importados aparecem no painel Projeto.

Se a caixa de diálogo Interpretar gravação for exibida após a importação de um item de gravação, ela contém um canal alfa não rotulado e você deve selecionar um método de interpretação de canais alfa para que o After Effects determine como interpretar o canal alfa. (Consulte Interpretação do canal alfa: pré-multiplicado ou simples.)

Importar itens de gravação usando a caixa de diálogo Importar

  1. Escolha Arquivo > Importar > Arquivo, escolha Arquivo > Importar > Vários arquivos ou clique duas vezes em uma área vazia do painel Projeto.

    Se você selecionar Importar vários arquivos, é possível executar a próxima etapa mais de uma vez sem precisar selecionar várias vezes o comando Importar.

    Observação:

    Para exibir somente arquivos de gravação suportados (com exceção dos arquivos de projeto), selecione Todos os arquivos de gravação no menu Arquivos do tipo (Windows) ou Ativar (Mac OS).

  2. Siga um destes procedimentos:
    • Selecione um arquivo e clique em Abrir.

    • Clique com a tecla Ctrl (Windows) ou com a tecla Command (Mac OS) em vários arquivos para selecioná-los e clique em Abrir.

    • Clique em um arquivo e clique com a tecla Shift pressionada no outro arquivo para selecionar um intervalo de arquivos e clique em Abrir.

    • (somente Windows) Selecione uma pasta inteira e clique em Importar pasta.

    Observação:

    Se a opção Sequência estiver selecionada, vários arquivos da pasta serão importados como uma sequência de imagens estáticas.  

Itens de gravação de importação arrastando

Observação:

Se desejar sempre que os arquivos de imagens estáticas em camadas que você arrasta no After Effects sejam importados como uma composição, escolha Editar > Preferências > Importar (Windows) ou After Effects > Preferências > Importar (Mac OS) e escolha Composição ou Composição – Manter tamanho da camada do menu Arrastar vários itens de importação como. (Consulte Importar uma sequência de imagens estáticas como uma composição.)

  • Para importar um único arquivo, arraste-o do Windows Explorer (Windows) ou Finder (Mac OS) para o painel Projeto.
  • Para importar o conteúdo de uma pasta como uma sequência de imagens estáticas que aparecem no painel Projeto como um único item de gravação, arraste uma pasta do Windows Explorer (Windows) ou Finder (Mac OS) no painel Projeto.
  • Para importar o conteúdo da pasta como itens de gravação individuais que aparecem no painel Projeto em uma pasta, arrastar com a tecla Alt do Windows Explorer (Windows) ou Option do Finder (Mac OS) arraste uma pasta para o painel Projeto.
  • Para importar um arquivo de saída renderizado do painel Fila de renderização, arraste o módulo de saída correspondente do painel Fila de renderização para o painel Projeto.

Observação:

Se você arrastar um módulo de saída do painel Fila de renderização para o painel Projeto antes da renderização, o After Effects cria um item de gravação de espaço reservado. Referências ao item de gravação de espaço reservado são substituídas automaticamente quando o módulo de saída é renderizado; o próprio item de gravação de espaço reservado não é substituído.

Interpretar itens de gravação

O After Effects usa um conjunto de regras internas para interpretar cada item de gravação que você importa de acordo com a melhor previsão para a taxa de proporção de pixels do arquivo de origem, a taxa de quadros, o perfil de cores e o tipo de canal alfa. Se a previsão do After Effects estiver errada, ou se desejar usar a gravação de forma diferente, você pode modificar essas regras para todos os itens de gravação de um determinado tipo editando o arquivo de regras de interpretação (interpretation rules.txt), ou pode modificar a interpretação de um item de gravação específico usando a caixa de diálogo Interpretar gravação.

As configurações de interpretação dizem ao After Effects o seguinte sobre cada item da gravação:

Observação:

Em todos os casos, as informações serão usadas para decidir sobre como interpretar dados no item de gravação importado – para informar o After Effects sobre a gravação de entrada. As configurações de interpretação na caixa de diálogo Interpretar gravação devem corresponder às configurações usadas para criar o arquivo de gravação de origem. Não use as configurações de interpretação para tentar especificar configurações para a saída renderizada final.

Em geral, não é necessário alterar as configurações de interpretação. Entretanto, se um item de gravação não é de um tipo comum, o After Effects pode precisar de informações adicionais do para interpretar corretamente.

Use os controles na seção Gerenciamento de cores da caixa de diálogo Interpretar gravação para informar o After Effects como interpretar as informações de cor em um item de gravação. Esta etapa geralmente é somente necessária quando o item de gravação não contém um perfil de cores incorporado.

Quando você visualiza no painel Gravação, você verá os resultados das operações de interpretação da gravação.

Jeff Almasol fornece um script em seu site de redefinery que pode ser usado para fazer a suposição de pulldown de 3:2, de pulldown de 24Pa, ou a interpretação de canal alfa mais conveniente.

Observação:

Selecione Visualizar na caixa de diálogo Interpretar gravação para visualizar os resultados das configurações feitas em essa caixa de diálogo antes de aceitar as alterações.

Interpretar um único item de gravação usando a caixa de diálogo Interpretar gravação

  1. Selecione um item de gravação no painel Projeto e siga um destes procedimentos:
    • Clique no botão Interpretar gravação na parte inferior do painel Projeto.

    • Arraste o item de gravação para o botão Interpretar gravação.

    • Escolha Arquivo > Interpretar gravação > Principal.

    • Pressione Ctrl+Alt+G (Windows) ou Command+Option+G (Mac OS).

Interpretar um proxy usando a caixa de diálogo Interpretar gravação

  1. Selecione o item de gravação original no painel Projeto e siga um destes procedimentos:
    • Clique no botão Interpretar gravação , na parte inferior do painel Projeto, pressionando Alt (Windows) ou Option (Mac OS).

    • Arraste com a tecla Alt (Windows) ou arraste com a tecla Option (Mac OS) o item de gravação para o botão Interpretar gravação.

    • Escolha Arquivo > Interpretar gravação > Proxy.

Aplicar configurações Interpretar gravação a vários itens de gravação

É possível garantir que os itens diferentes de gravação usem as mesmas configurações copiando as configurações de interpretação de um item e aplicando-as aos outros.

  1. No painel Projeto, selecione o item com as configurações de interpretação que deseja aplicar.
  2. Escolha Arquivo > Interpretar gravação > Lembrar interpretação.
  3. Selecione um ou mais itens de gravação no painel Projeto.
  4. Escolha Arquivo > Interpretar gravação > Aplicar interpretação.

Editar regras de interpretação para todos os itens de um tipo específico

O arquivo de regras de interpretação contém regras que especificam como o After Effects interpreta itens de gravação. Na maioria dos casos, você não precisa personalizar o arquivo de regras de interpretação. Ao importar um item de gravação, o After Effects procura uma correspondência no arquivo de regras de interpretação e determina as configurações de interpretação da gravação. É possível substituir essas configurações após a importação, usando a caixa de diálogo Interpretar gravação.

Na maioria dos casos, o nome do arquivo de regras de interpretação é interpretation rules.txt; contudo, algumas atualizações do After Effects instalam um novo arquivo de regras de interpretação com um nome que indica o número da versão atualizada e o aplicativo atualizado usa este novo arquivo. Se tiver feito alterações no arquivo de regras de interpretação antigo, talvez seja necessário aplicar as alterações no arquivo novo, também.

Os locais do arquivo de regras de interpretação no After Effects:

  • (Windows) <drive>\Users\<username>\AppData\Roaming\Adobe\After Effects <15.1>
  • (Mac OS) <drive>/Users/<username>/Library/Preferences/Adobe/After Effects <15.1>

Os locais do arquivo de regras de interpretação nas versões anteriores do After Effects:

  • (Windows) <drive>\Users\<username>\AppData\Roaming\Adobe\After Effects <14.x>
  • (Mac OS) <drive>/Users/<username>/Library/Preferences/Adobe/After Effects <14.x>
  1. Saia do After Effects.
  2. Como precaução, faça uma cópia de backup do arquivo de regras de interpretação. Por padrão, esse arquivo está no mesmo local que o aplicativo After Effects.
  3. Abra o arquivo de regras de interpretação em um editor de texto.
  4. Modifique as configurações de acordo com as instruções do arquivo.

    Observação:

    Forneça um código de tipo de arquivo de quatro caracteres para cada tipo de gravação ou codec. Se você não souber o código de um arquivo ou codec em um projeto, pressione Alt (Windows) ou Option (Mac OS) enquanto seleciona o arquivo no painel Projeto. O código de tipo de arquivo e código codec (se o arquivo estiver compactado) é exibido na última linha da descrição do arquivo na parte superior do painel Projeto.

  5. Salve o arquivo interpretation rules.txt.

Interpretação do canal alfa: pré-multiplicado ou simples

Os arquivos de imagem com canais alfa armazenam informações de transparência em uma de duas maneiras: simples ou pré-multiplicado. Embora os canais alfa sejam os mesmos, os canais de cores diferem.

Com canais simples (ou sem fosco) , as informações de transparência são armazenadas somente no canal alfa, e não em nenhum dos canais de cores visíveis. Com canais simples, os resultados de transparência não são visíveis até que a imagem seja exibida em um aplicativo que ofereça suporte a canais simples.

Com canais pré-multiplicados (ou fosco), as informações de transparência são armazenadas no canal alfa e também em canais visíveis RGB, que são multiplicados pela cor de fundo. Os canais pré-multiplicados são ditos às vezes serem foscos com cor. As cores de áreas semitransparentes, como bordas difusas, são alteradas para a cor de fundo em proporção ao grau de transparência.

Alguns softwares permitem especificar a cor de fundo com a qual os canais são pré-multiplicados; caso contrário, a cor de fundo é geralmente preto ou branco.

Os canais simples retêm informações de cor mais precisas que os canais pré-multiplicados. Os canais pré-multiplicados são compatíveis com uma maior variedade de programas, como o Apple QuickTime. Geralmente, a opção de usar imagens com canais simples ou pré-multiplicados foi feita antes de receber os ativos para editar e compor. O Adobe Premiere Pro e o After Effects reconhecem canais simples e pré-multiplicados, mas somente o primeiro canal alfa que encontram em um arquivo contém vários canais alfa.

Definir a interpretação do canal alfa pode evitar problemas ao importar um arquivo, como cores indesejadas na borda de uma imagem ou uma perda de qualidade da imagem nas bordas do canal alfa. Por exemplo, se os canais são interpretados como simples quando são realmente pré-multiplicados, as áreas semitransparentes mantêm alguma da cor de fundo. Se a imprecisão de cor, como um halo, aparece ao longo das arestas semitransparentes em uma composição, tente alterar o método de interpretação.

Canais pré-multiplicados
Um item de gravação com canais pré-multiplicados (parte superior) aparece com um halo preto ao ser interpretado como Simples – Sem fosco (parte inferior esquerda). Quando o item de gravação é interpretado como Pré-multiplicado – Fosco com cor e a cor de fundo é especificada como preto, o halo não aparece (parte inferior direita).

Use o efeito Remover cor fosca para remover halos de áreas semi-transparentes de uma camada ao não multiplicá-lo.

Definir a interpretação do canal alfa de um item de gravação

  1. No painel Projeto, selecione um item de gravação.
  2. Escolha Arquivo > Interpretar gravação > Principal.
  3. Se você quiser alternar áreas opacas ou transparentes da imagem, selecione Inverter alfa.
  4. Na seção Alfa, selecione um método de interpretação:

    Adivinhar

    Tenta determinar o tipo de canais usados na imagem. Se o After Effects não puder presumir seguramente, ele emite um som.

    Ignorar

    Ignora as informações de transparência contidas no canal alfa.

    Simples – Sem fosco

    Interpreta os canais como simples.

    Pré-multiplicado – Fosqueado com cor

    Interpreta canais como pré-multiplicados. Use o conta-gotas ou o seletor de cores para especificar a cor de fundo com a qual os canais foram pré-multiplicados.

Definir as preferências do canal alfa padrão

  1. Escolha Editar > Preferências > Importar (Windows) ou After Effects > Preferências > Importar (Mac OS).
  2. Escolha as opções no menu Interpretar alfa não rotulado como. As opções nesse menu são semelhantes às opções na caixa de diálogo Interpretar gravação. Perguntar ao usuário especifica que a caixa de diálogo Interpretar gravação abrirá cada vez que um item de gravação com um canal alfa não rotulado é importado.

Taxa de quadros

A taxa de quadros da composição determina o número de quadros exibidos por segundo e como o tempo é dividido em quadros na régua de tempo e na exibição de tempo. Em outras palavras, a taxa de quadros da composição especifica quantas vezes por segundo as imagens são amostradas nos itens de gravação de origem e especifica as divisões de tempo em que os quadros-chave podem ser definidos.

Observação:

O After Effects contém um menu para o timecode com quadro não ignorado ou com quadro ignorado na caixa de diálogo Configurações da composição. Nas versões anteriores, essa opção não era uma configuração global por projeto.

A taxa de quadros da composição é determinada normalmente pelo tipo de saída que você deseja. O vídeo NTSC tem uma taxa de quadros de 29,97 quadros por segundo (fps), o vídeo PAL tem uma taxa de quadros de 25 fps e o clipe de filme geralmente tem uma taxa de quadros de 24 fps. Dependendo do sistema de transmissão, o vídeo DVD pode ter a mesma taxa de quadros que o vídeo NTSC ou PAL ou uma taxa de quadros de 23,976. Os desenhos animados destinados a CD-ROM ou à Web, em geral, têm uma taxa de quadros de 10 a 15 fps.

Observação:

Definir a taxa de quadros da composição para o dobro da taxa do formato de saída faz com que o After Effects exiba cada campo da gravação de origem entrelaçada como seu próprio quadro separado no painel Composição. Esse processo permite ajustar os quadros-chave e os campos individuais e ganhar precisão ao animar máscaras.

Ao renderizar um filme para saída final, você pode escolher usar a taxa de quadros da composição ou outra taxa de quadros. A capacidade de definir a taxa de quadros para cada módulo de saída é útil quando você usa a mesma composição para criar a saída para várias mídias.

Suporte a gravações com alta taxa de quadros

Você pode ajustar qualquer o campo de taxa de quadros para um máximo de até 999 qps na versão de abril de 2017 do After Effects. A atualização permite que você use taxas de quadro mais altas para renderizar, diferentemente das versões anteriores, onde a taxa de quadros máxima que você podia ajustar para uma composição era 99 qps.

Cada item de gravação de movimento em uma composição pode ter sua própria taxa de quadros. A relação entre a taxa de quadros do item de gravação e a taxa de quadros da composição determina como a suavidade da camada é reproduzida. Por exemplo, se a taxa de quadros do item de gravação é 30 fps e a taxa de quadros da composição é 30 fps, então sempre que a composição avançar um quadro, o próximo quadro do item da gravação é exibido. Se a taxa de quadros do item de gravação é 15 fps e a taxa de quadros de composição 30 fps, cada quadro do item de gravação aparece em dois quadros sucessivos de composição. (Esse processo presume, é claro, o caso simples em que nenhum esticamento de tempo ou mesclagem de quadros foi aplicado à camada.)

Use, preferencialmente, a gravação de origem que corresponde à taxa de quadros da saída final. Assim, o After Effects renderiza cada quadro, e a saída final não omite, não duplica nem interpola quadros. Se, no entanto, a gravação de origem tem uma taxa de quadros ligeiramente diferente da que deseja para a saída final (por exemplo, gravação de 30 fps e saída final de 29,97 fps), é possível fazer com que a taxa de quadros da gravação corresponda à taxa de quadros da composição fazendo sua conformação.

Conformar a taxa de quadros de um item de gravação não modifica o arquivo original, somente a referência cruzada que o After Effects usa. Ao fazer a conformação, o After Effects altera a duração interna dos quadros, mas não o conteúdo do quadro. Posteriormente, a gravação é reproduzida a uma velocidade diferente. Por exemplo, se você conforma a taxa de quadros de 15 fps para 30 fps, a gravação reproduz duas vezes mais rápido. Na maioria dos casos, faça a conformação da taxa de quadros somente quando a diferença entre a taxa de quadros da gravação e a taxa de quadros da saída for pequena.

Observação:

Fazer a conformação pode alterar a sincronização da gravação visual com uma trilha de áudio, porque alterando a taxa de quadros altera a duração do vídeo, mas deixa o áudio inalterado. Se quiser esticar o áudio e vídeo, use o comando Esticar tempo. (Consulte Esticar tempo em uma camada.) Os quadros-chave aplicados à gravação de origem permanecem em seus locais originais (mantendo a sincronização dentro da composição, mas não o conteúdo visual da camada). Talvez seja necessário definir localizações do quadro-chave após a conformação de um item de gravação.

Você pode alterar a taxa de quadros para qualquer filme ou sequência de imagens estáticas. Por exemplo, é possível importar uma sequência de dez imagens estáticas e especificar uma taxa de quadros para o item de gravação de 5 quadros por segundo (fps); esta sequência terá uma duração de dois segundos quando usada em uma composição.

Observação:

Quando você importa uma sequência de imagens estáticas, é assumida a taxa de quadros especificada pela preferência Gravação sequencial na categoria Importar. A taxa padrão é de 30 quadros por segundo (fps). Você pode alterar a taxa de quadros após a importação reinterpretando o item de gravação. (Consulte Interpretar itens de gravação.)

As taxas de quadros mais baixas tendem a dar a impressão de irrealidade, de forma que muitos usuários preferem trabalhar com uma taxa de quadros inferior como 24 quadros por segundo para fluxos de trabalho criativos em vez de trabalhar em 29,97 quadros por segundo que é o padrão para vídeo NTSC.

Observação:

Se você remover o pulldown de 3:2 de gravação de vídeo entrelaçado, o After Effects define automaticamente a taxa de quadros do item de gravação resultante para quatro quintos da taxa de quadros original. Ao remover o pulldown de 3:2 de vídeo NTSC, a taxa de quadros resultante é 24 fps.

A taxa de quadros da composição deve corresponder à taxa de quadros do formato da saída final. Na maioria dos casos, basta escolher uma predefinição das configurações da composição. Ao contrário, defina a taxa de quadros para cada item de gravação para a taxa de quadros da gravação de origem original.

Trish e Chris Meyer oferecem dicas e truques relativos à conformação de itens de gravação para uma taxa de quadros específica em um artigo (PDF) no site da Artbeats.

Alterar a taxa de quadros de um item de gravação

  1. Selecione o item de gravação no painel Projeto.
  2. Escolha Arquivo > Interpretar gravação > Principal.
  3. Selecione Conformar com a taxa de quadros, insira uma taxa de quadros nova para Quadros por segundo e clique em OK.

Observação:

Em vez de utilizar Interpretar gravação para alterar a taxa de quadros de um item de gravação, você pode esticar o tempo de uma camada com base no item de gravação. Por exemplo, esticar o tempo de uma camada em 100,1% para converter entre 30 fps e 29,97 fps. Esticar o tempo altera a velocidade de áudio e do vídeo. (Consulte Esticar o tempo em uma camada.)

Alterar a taxa de quadros de uma composição

  1. Escolha Composição > Configurações da composição.
  2. Siga um destes procedimentos:
    • Escolha uma predefinição das configurações da composição no menu Predefinição.

    • Defina o valor da Taxa de quadros.

Observação:

Jeff Almasol fornece um script no site redefinery para definir a taxa de quadros e duração da composição atual e de todas as composições aninhadas dentro dela.

Taxa de proporção de pixels e taxa de proporção do quadro

A Taxa de proporção de pixels (PAR) é a relação largura/altura de um pixel em uma imagem. A Taxa de proporção do quadro (algumas vezes chamada taxa de proporção da imagem ou IAR) é a relação largura/altura do quadro de imagem.

Taxa de proporção do quadro
Uma taxa de proporção do quadro de 4:3 (esquerda) e 16:9 panorâmica (direita)

A maioria dos monitores dos computadores usam pixels quadrados, mas muitos formatos de vídeo ITU-R- incluindo ITU-R 601 (D1) e DV – usam pixels retangulares não quadrados.

Alguns formatos de saída de vídeo têm a mesma taxa de proporção do quadro, mas usam uma taxa de proporção de pixels diferente. Por exemplo, alguns digitalizadores NTSC geram uma taxa de proporção do quadro de 4:3, com pixels quadrados (taxa de proporção de pixels de 1.0), e um quadro com dimensões de pixel de 640x480. O NTSC D1 gera a mesma taxa de proporção do quadro de 4:3, mas usa pixels não quadrados (taxa de proporção de pixels de 0,91) e um quadro com dimensões de pixel de 720x486. Os pixels do D1, que são sempre não quadrados, são orientados verticalmente em sistemas que produzem vídeo NTSC e horizontalmente em sistemas que produzem vídeo PAL.

Se você exibir pixels não quadrados em um monitor com pixels quadrados sem alteração, as imagens e movimento aparecerão distorcidos; por exemplo, círculos serão ovais. Entretanto, quando exibidos em um monitor de vídeo, as imagens estão corretas. Quando você importa a gravação de origem NTSC D1 ou DV do After Effects, a imagem parece ligeiramente mais ampla que em um sistema D1 ou DV. (A gravação PAL D1 parece ligeiramente mais estreita.) O oposto ocorre quando você importa uma gravação anamórfica usando panorâmica NTSC D1/DV ou panorâmica PAL de D1/DV. Os formatos de vídeo em tela panorâmica têm uma taxa de proporção do quadro de 16:9.

Observação:

Para visualizar pixels não quadrados em seu monitor, clique no botão Alternar correção da taxa de proporção de pixels na parte inferior do painel Composição. A qualidade da correção da taxa de proporção de pixels das visualizações é afetada pela preferência Qualidade de zoom na categoria Visualizações. (Consulte Preferências da Qualidade do visualizador.)

Pixels quadrados e não quadrados
Pixels quadrados e não quadrados

A. Pixels quadrados e taxa de proporção do quadro de 4:3 B. Pixels não quadrados e taxa de proporção do quadro de 4:3 C. Pixels não quadrados exibidos em um monitor de pixel quadrado 

Se um item de gravação usar pixels não quadrados, o After Effects indica a taxa de proporção de pixels do lado da imagem em miniatura do item de gravação no painel Projeto. É possível alterar a interpretação da taxa de proporção de pixels para itens de gravação individuais na caixa de diálogo Interpretar gravação. Certificando-se de que os itens de gravação sejam interpretados corretamente, é possível combinar itens de gravação com taxas de proporção de pixels diferentes na mesma composição.

O After Effects lê e grava taxa de proporção de pixels diretamente dos filmes QuickTime. Por exemplo, se você importar um vídeo capturado em tela panorâmica (16:9 DV), o After Effects etiqueta-o automaticamente e corretamente. De modo semelhante, os arquivos AVI e PSD contêm informações que exibem explicitamente a taxa de proporção de pixels das imagens.

Se um item de gravação não contém informações que indicam explicitamente a taxa de proporção de pixels da imagem, o After Effects utiliza as dimensões em pixels do quadro do item de gravação para fazer uma estimativa. Ao importar um item de gravação com dimensões em pixels D1 de 720x486 ou dimensões em pixels DV de 720x480, o After Effects interpreta automaticamente o item de gravação como D1/DV NTSC. Ao importar um item de gravação com dimensões em pixels D1 ou DV de 720x576, o After Effects interpreta automaticamente o item de gravação como D1/DV PAL. Contudo, você pode se certificar de que todos os arquivos sejam interpretados corretamente olhando no painel Projeto ou na caixa de diálogo Interpretar gravação.

Observação:

Garanta que redefine a taxa de proporção de pixels como Pixels quadrados quando você importar um arquivo que acontece ter dimensões em pixels D1 ou DV – por exemplo, uma imagem não DV que acontece ter dimensões em pixels de 720x480.

A configuração da taxa de proporção de pixels da composição deve corresponder à taxa de proporção de pixels do formato da saída final. Na maioria dos casos, basta escolher uma predefinição das configurações da composição. Ao contrário, defina a taxa de proporção de pixels para cada item de gravação para a taxa de proporção de pixels da gravação de origem original.

Trish e Chris Meyer oferecem dicas e truques em relação à taxa de proporção de pixels em dois documentos PDF no site da Artbeats:

Chris Pirazzi fornece detalhes técnicos sobre taxas de proporção de pixels no seu site Lurker's Guide to Video.

Atualizar taxas de proporção de pixels para valores corretos

O After Effects CS3 e anterior usam taxas de proporção de pixels para formatos de vídeo de definição padrão que ignoram o conceito abertura total. Por não representar o fato de que a abertura total difere da abertura de produção no vídeo de definição padrão, as taxas de proporção de pixels usadas pelo After Effects CS3 e anterior eram ligeiramente imprecisas. As taxas de proporção de pixels incorretas fazem com que certas imagens pareçam ligeiramente distorcidas.

Observação:

A abertura total é a parte da imagem que está livre de artefatos e distorções que aparecem nas bordas de uma imagem. A abertura de produção é a imagem inteira.

Todd Kopriva resume informações sobre as taxas de proporção de pixels corrigidas no site da Adobe.

A tabela a seguir fornece detalhes sobre valores das proporções de pixel no After Effects:

formato

valor no After Effects CS4 e posterior

valor anterior

D1/DV NTSC

0,91

0,9

D1/DV NTSC Widescreen

1,21

1,2

D1/DV PAL

1,09

1,07

D1/DV PAL Widescreen

1,46

1,42

A discrepância está limitada a esses formatos de definição padrão antigos para os quais a abertura total difere da abertura de produção. A discrepância não existe em formatos mais recentes.

Os projetos e composições recentes criados no After Effects CS4 e posterior usam, por padrão, os valores da taxa de proporção de pixels corretos.

Os projetos e composições criados no After Effects CS3 ou anterior estão atualizados para usar as taxas de proporção de pixels corretas quando esses projetos são abertos no After Effects CS4 e posterior.

Observação:

Se você tiver um arquivo de regras de interpretação personalizado, deverá atualizá-lo com os valores da taxa de proporção de pixels corretos.

Se você usar itens de gravação de pixels quadrados que são criados para preencher o quadro em uma composição com pixels não quadrados, você pode descobrir que a alteração nas taxas de proporção de pixels causa uma diferença no comportamento. Por exemplo, se você criou anteriormente itens de gravação de pixels quadrados 768x576 para usar em uma composição PAL D1/DV, você deverá criar esses itens com dimensões de pixels quadrados de 788x576.

As predefinições das configurações da composição para equivalentes de pixel quadrado de formatos de definição padrão mudaram como se segue:

formato

dimensões em pixels no After Effects CS4 e posterior

dimensões anteriores em pixels

equivalente a pixel quadrado NTSC D1

720 x 534

720 x 540

equivalente a pixel quadrado NTSC D1 Widescreen

872 x 486

864 x 486

equivalente a pixel quadrado PAL D1/DV

788 x 576

768 x 576

equivalente a pixel quadrado PAL D1/DV Widescreen

1050 x 576

1024 x 576

Modificar interpretação da taxa de proporção de pixels de um item de gravação

  1. Selecione um item de gravação no painel Projeto.
  2. Escolha Arquivo > Interpretar gravação > Principal.
  3. Escolha uma taxa no menu Taxa de proporção de pixels e clique em OK.

Alterar taxa de proporção de pixels de uma composição

  1. Escolha Composição > Configurações da composição.
  2. Siga um destes procedimentos:
    • Escolha uma predefinição das configurações da composição no menu Predefinição.

    • Escolha um valor no menu Taxa de proporção de pixels.

Taxas de proporção de pixels comuns

Taxa de proporção de pixel

Quando utilizar

Pixels quadrados

1,0

A gravação tem um tamanho de quadro de 640 x 480 ou 648 x 486, é 1920 x 1080 HD (não HDV ou DVCPRO HD), é HD 1280 x 720 ou HDV, ou foi exportada de um aplicativo que não suporta pixels não-quadrados. Essa configuração também pode ser adequada para gravações que foram transferidas de um filme ou para projetos personalizados.

D1/DV NTSC

0,91

A gravação tem um tamanho de quadro de 720 x 486 ou 720 x 480 e o resultado desejado é uma taxa de proporção de quadro de 4:3. Essa configuração também pode ser adequada para gravações que foram exportadas do aplicativo que funciona com pixels não quadrados, como um aplicativo de animação 3D.

D1/DV NTSC Widescreen

1,21

A gravação tem o tamanho de quadro de 720 x 486 ou 720 x 480 e o resultado desejado é uma taxa de proporção de quadro de 16:9.

D1/DV PAL

1,09

A gravação tem o tamanho de quadro de 720 x 576 e o resultado desejado é uma taxa de proporção de quadro de 4:3.

D1/DV PAL Widescreen

1,46

A gravação tem o tamanho de quadro de 720 x 576 e o resultado desejado é uma taxa de proporção de quadro de 16:9.

Anamórfico 2:1

2.0

A gravação foi feita usando uma lente anamórfica de filme, ou foi anamorficamente transferida de um quadro de filme com uma taxa de proporção de 2:1.

HDV 1080/DVCPRO HD 720, HD anamórfico 1080

1,33

A gravação tem o tamanho de quadro de 1440 x 1080 ou 960 x 720 e o resultado desejado é uma taxa de proporção de quadro de 16:9.

DVCPRO HD 1080

1,5

A gravação tem o tamanho de quadro de 1280 x 1080 e o resultado desejado é uma taxa de proporção de quadro de 16:9.

Esta obra está licenciada sob uma licença não adaptada da Creative Commons Attribution-Noncommercial-Share Alike 3.0  As publicações do Twitter™ e do Facebook não são cobertas pelos termos do Creative Commons.

Avisos legais   |   Política de privacidade online