Use esta página para saber mais sobre o painel Gráficos essenciais no After Effects e como trabalhar com Modelos de animações e propriedades mestre.

O painel Gráficos essenciais permite construir controles personalizados para animações e compartilhá-los como modelos de Animações através das Bibliotecas da Creative Cloud ou como arquivos locais. O painel Gráficos essenciais funciona como um reservatório no qual você pode adicionar diferentes controles, alterá-los e empacotá-los como modelos de Animações compartilháveis. Um novo espaço de trabalho para trabalhar com o painel Gráficos essenciais no After Effects, denominado Gráficos essenciais, está disponível na barra do espaço de trabalho. Você pode acessar o espaço de trabalho em Janela > Espaço de trabalho.

Há quatro maneiras principais de usar o painel Gráficos essenciais no After Effects:

  • Como uma superfície de controle no After Effects: use o painel Gráficos essenciais como uma superfície de controle para suas composições. Arraste os parâmetros da linha de tempo ao painel Gráficos essenciais para criar atalhos para os elementos na composição que você altera com frequência.
  • Para criar propriedades mestre que funcionem como controles mestre para permitir a modificação de propriedades de efeito e de camada de uma composição quando estas estão aninhadas em outra composição.
  • Para exportar os Modelos de animações (.mogrt): encapsule seu projeto do After Effects em um Modelo de animações que possa ser editado diretamente no Premiere Pro. Todas as imagens de origem, vídeos e composições necessárias para manter o seu design são compactadas no modelo. Somente os controles que você expõe estão disponíveis para personalização no Premiere Pro que permitem reter o controle criativo do seu design.
  • Para agrupar controles, controlar as propriedades das fontes e adicionar controles para fontes de dados de planilhas CSV e TSV a um Modelo de animações. É possível acessar os grupos pelo menu Adicionar formatação no painel Gráficos essenciais. O comando Adicionar comentário pode ser acessado nesse menu.

Criar Modelos de animações no After Effects

Criar Modelos de animações no After Effects
Assista a este vídeo para saber mais sobre a criação de Modelos de animações no After Effects

Trabalhar com o painel Gráficos essenciais

Composições no painel Gráficos essenciais

No painel Gráficos essenciais, use o menu suspenso Mestre para selecionar uma composição no projeto para começar a criar um Modelo de animações.

Exibir composições a partir do menu Principal
Exibir composições a partir do menu Principal

Para abrir uma composição no painel Gráficos essenciais no After Effects, siga um destes procedimentos:

  • Para abrir a composição atual, selecione Composição > Abrir nos gráficos essenciais.
  • Para abrir uma determinada composição, clique com o botão direito do mouse em uma composição no painel Projeto e selecione Abrir nos gráficos essenciais.
  • Para abrir qualquer composição no seu projeto, clique no menu Principal no painel Gráficos essenciais.

Composição mestre

A composição mestre é a composição atual no painel Gráficos essenciais. Você pode adicionar propriedades compatíveis da composição mestre ao painel. Também é possível adicionar propriedades de composições que estão na hierarquia da composição mestre.

As propriedades da composição que não estão na hierarquia da composição mestre são consideradas propriedades não relacionadas. Quando você adiciona propriedades não relacionadas ao painel Gráficos essenciais, uma mensagem de aviso é exibida. As propriedades ainda são adicionadas ao painel, mas são realçadas em vermelho e não têm nenhum efeito quando a composição é exportada como Modelo de animações. 

Dica: para usar propriedades não relacionadas, aninhe a composição com as propriedades na composição mestre ou na hierarquia.

Observação:

As propriedades não relacionadas não funcionam quando a composição é exportada como um Modelo de animações.

Adicionar e modificar controles

Adicionar controles

Você pode adicionar propriedades compatíveis de qualquer efeito ou de qualquer grupo de propriedades da camada como - Transformar, Máscaras e Opções de material.

Tipos de controles suportados:

  • Caixa de seleção
  • Cor
  • Controle deslizante numérico (isto é, uma propriedade numérica de valor único), como Transformar > Opacidade ou o efeito de controle de expressão do Controle deslizante
  • Texto de origem
  • Propriedades de pontos em 2D, como Transformar > Ponto de ancoragem, Transformar > Posição e o efeito de controle da expressão Controle de ponto
  • Propriedades de escala em 2D, como Transformar > Escala
  • Propriedades de ângulo, como Transformar > Girar e o efeito controle da expressão Controle de ângulo

Se você adicionar propriedades não compatíveis, o After Effects exibe uma mensagem de aviso: “Erro do After Effects: o tipo de propriedade ainda não é compatível para uso nos Modelos de animações.”

Para adicionar um controle, arraste uma única ou várias propriedades selecionadas na Linha de tempo até o painel Gráficos essenciais.

Também é possível usar o comando Adicionar propriedade ao painel Gráficos essenciais para adicionar propriedades ao painel Gráficos essenciais a partir dos painéis Linha de tempo ou Controles de efeito. Use qualquer uma das seguintes etapas para adicionar propriedades:

  • Selecione uma propriedade no painel Linha de tempo e, em seguida, selecione Animação > Adicionar propriedade a Gráficos essenciais.
  • Clique com o botão direito do mouse em uma propriedade no painel Linha de tempo ou no painel Controles de efeito e, em seguida, selecione Adicionar propriedade a Gráficos essenciais no menu.

Também é possível atribuir um atalho do teclado ao comando Adicionar propriedade ao painel Gráficos essenciais. Para saber as etapas, consulte Editor de atalhos visuais de teclado.

Adicionar controles no painel Gráficos essenciais
Adicionar controles no painel Gráficos essenciais

Exibir propriedades compatíveis

Caso queira apenas exibir as propriedades compatíveis pelo painel Gráficos essenciais, clique no botão Isolar propriedades compatíveis no painel. O botão filtra as propriedades e exibe as propriedades compatíveis na linha de tempo.

Exibir as propriedades isoladas
Exibir as propriedades isoladas

Controles Modificar

É possível usar o painel Gráficos essenciais para personalizar os controles das seguintes maneiras:

  • Renomear um controle: para renomear um controle, siga um destes procedimentos:
    • Clique no campo de nome do controle e digite um novo nome.
    • Arraste e realce o nome atual e digite um novo nome.
  • Revelar as propriedades de origem: para revelar as propriedades de origem de um controle na linha de tempo, clique com o botão direito do mouse no nome do controle e selecione Revelar na linha de tempo a partir do menu de contexto. A opção de revelação abre a composição relacionada mesmo se ela estiver fechada.
  • Reorganizar os controles: para reorganizar os controles, arraste-os para cima ou para baixo no painel.

Os controles que você adiciona ao painel Gráficos essenciais estão vinculados às propriedades de origem. Alterar o valor de um controle também altera o valor das propriedades na composição. Por exemplo, se você alterar a Opacidade para 50% no painel, o valor de Opacidade na composição também mudará para 50%.

Os valores de composição são atualizados simultaneamente à medida que você deslizar o valor de controles numéricos no painel. Para desativar o recurso de atualização dinâmica, mantenha pressionada a tecla Option (Mac) ou Alt (Win) ao deslizar.

Criar grupos de controles

Agrupe os controles no painel Gráficos essenciais para melhorar a navegação e reduzir a desordem. Isso é especialmente útil ao adicionar longas listas de controles editáveis ou as propriedades principais de composições aninhadas ao painel.

Para criar um grupo, clique no menu Adicionar formatação, no canto inferior esquerdo do painel Gráficos essenciais, em seguida, selecione Adicionar grupo.

Para adicionar um controle a um grupo, arraste-o para o nome do grupo.

Controles da fonte

Ao adicionar uma camada de texto ao painel Gráficos essenciais, é possível modificar e controlar a família de fontes, o estilo e tamanho de fonte e o estilo falso dessa camada em um Modelo de animações. Use as seguintes etapas para adicionar controles de propriedade de fonte ao painel:

  1. Adicione a propriedade Texto de origem de uma camada de texto ao painel Gráficos essenciais.

  2. Clique na opção Editar propriedades do lado direito da linha de controle.

     

  3. Selecione as propriedades de fonte para controlar das seguintes opções:

    • Habilitar seleção de fonte personalizada - acrescenta os controles Família de fontes e Estilo de fonte.
    • Habilitar ajuste de tamanho da fonte - acrescenta o controle Tamanho da fonte.
    • Habilitar estilos falsos - acrescenta Negrito Falso, Itálico falso, Todas em maiúsculas e Minúsculas.

    Clique em OK.

Observação:

Os controles de fonte não são suportados como as propriedades principais de uma composição aninhada.

Adicionar comentários no painel Gráficos essenciais

Para adicionar comentários, clique no botão Adicionar comentário na parte inferior do painel Gráficos essenciais. É possível adicionar vários comentários, renomeá-los e reordená-los. Também é possível desfazer e refazer a adição de comentários, classificá-los novamente e removê-los, se necessário.

  • Para renomear, clique no campo de nome do comentário e digite um novo nome. 
  • Para reordenar, arraste o comentário para cima ou para baixo no painel.

Para excluir um comentário, selecione o comentário e pressione a tecla Backspace ou Delete.

Modificar controles
Modificar controles

Observação:

Ao duplicar uma composição no painel Projetos (pressione as teclas command e D no Mac ou control e D no Windows), o After Effects duplica propriedades e comentários adicionados ao painel Gráficos essenciais dessa composição.

Exportar como modelos de animações

Nomeie o modelo

Para renomear o Modelo de animações, clique no campo de nome do modelo e insira um novo nome.

Definir o quadro de pôster para o modelo

É possível definir o quadro de pôster para o modelo. O quadro de pôster é usado como a imagem em miniatura do modelo nas bibliotecas da Creative Cloud e no painel Gráficos essenciais no Premiere Pro.

Para definir o quadro de pôster, siga estas etapas:

  1. Na composição mestre, posicione o indicador de tempo atual no quadro que deseja selecionar.

  2. Clique no botão Definir tempo de pôster no painel Gráficos essenciais.

Exportar um modelo

Para exportar uma composição como um Modelo de animações, siga estas etapas:

  1. Clique no botão Exportar modelo de animações na parte inferior do painel Gráficos essenciais. As composições na hierarquia da composição mestre são incluídas no modelo.

  2. Na caixa de diálogo Exportar como modelo de animações, clique no menu Destino. Os destinos disponíveis são:

    • Bibliotecas da Creative Cloud: adicione modelos às suas Bibliotecas da Creative Cloud.
    • Gráficos essenciais: adicione modelos à pasta local por padrão. Os modelos armazenados na pasta Gráficos essenciais estão diretamente disponíveis no painel Gráficos essenciais no Premiere Pro.
    • Unidade local: salve modelos em um diretório local. Os modelos que você salvar no seu diretório local não estão automaticamente disponíveis no painel Gráficos essenciais no Premiere Pro.
  3. Exportar Modelos de animações
    Exportar Modelos de animações

    Marque uma caixa de seleção em Compatibilidade:

    • Avise-me se esse modelo de Animação usa fontes que não estão disponíveis no Adobe Fonts: ative essa opção se quiser que o After Effects avise você sobre quaisquer fontes usadas pela composição que não estejam disponíveis no Adobe Fonts.
    • Avise-me se o After Effects precisa ser instalado para personalizar este Modelo de animações: ative esta opção apenas se desejar exportar os recursos independentes do After Effects, por exemplo, plug-ins de terceiros.

    Para obter mais informações sobre como adicionar ativos às bibliotecas da Creative Cloud, consulte Bibliotecas da Creative Cloud no After Effects.

    Observação:

    Essas opções exibem somente avisos, elas não alteram o conteúdo do Modelo de animações. Para editar o projeto e atender aos requisitos, cancele a exportação e faça as alterações. Depois, exporte o Modelo de animações novamente.

  4. Escolha o destino da exportação no menu Destino e clique em OK.

Observação:

É possível criar Modelos de animações (arquivos .mogrt) que não exigem que o usuário tenha o After Effects instalado no computador para personalizá-los. Certifique-se de que seus modelos cumprem os seguintes requisitos para garantir que a instalação do After Effects não seja necessária para o usuário do .mogrt: 

  • Somente o renderizador de composição 3D clássico é compatível. Os renderizadores CINEMA 4D e Raios 3D não são compatíveis.
  • Todos os efeitos incluídos com o After Effects são compatíveis, exceto: Correção de desfoque de vibração da câmera, Suavidade da cor de abertura sintética, Maxon CINEWARE, Marionete e Estabilizador de distorção.
  • A gravação de Link dinâmico não é suportada como sequências do Premiere Pro ou cenas do Character Animator CC em uma composição do After Effects.
  • Não há suporte para gravação de formato FLV e plug-ins de terceiros.

Abrir modelos de animações como projetos

Para editar o Modelo de animações do After Effects (arquivos .mogrt), é possível abri-lo no After Effects como um arquivo de projeto. Após editar o modelo, exporte-o novamente como um arquivo.mogrt.

Para abrir um Modelo de animações como um projeto, siga as seguintes etapas:

  1. Selecione Arquivo > Abrir projeto.

  2. Na caixa de diálogo Abrir projeto, selecione um arquivo .mogrt e, em seguida, clique em Abrir.
  3. Ao abrir um arquivo .mogrt como um projeto, o After Effects extrai o arquivo de projeto e os ativos. Na caixa de diálogo Extrair "<filename>.mogrt", escolha uma localização para onde extrair os conteúdos do arquivo .mogrt e, em seguida, clique em Extrair.

Também é possível modificar um Modelo de animações usado em uma sequência no Premiere Pro 12.1 ao seguir as seguintes etapas:

  1. No After Effects, abra o arquivo .mogrt como um projeto. Modifique uma ou mais composições ou adicione ou altere os controles no painel Gráficos essenciais.
  2. Após fazer as edições, no painel Gráficos essenciais, clique no botão Exportar modelo de animações. É possível substituir o arquivo .mogrt original ou selecionar uma nova localização ou nome para o arquivo atualizado.
  3. No Premiere Pro, pressione Option (no MacOS) ou Alt (no Windows) e arraste o arquivo .mogrt novo ou atualizado da guia Pesquisar do painel Gráficos essenciais até o clipe .mogrt existente na sequência. O Premiere Pro atualiza a guia Editar do painel Gráficos essenciais com os novos controles.
  1. No After Effects, abra o arquivo .mogrt como um projeto. Modifique as composições ou adicione ou altere controles no painel Gráficos essenciais.

  2. Após editar, no painel Gráficos essenciais, clique no botão Exportar modelo de animações. É possível substituir o arquivo .mogrt original ou selecionar uma nova localização ou nome para o arquivo atualizado.

  3. No Premiere Pro, na guia Pesquisardo painel Gráficos essenciais, pressione Opt (MacOS) ou Alt (Win) e arraste o arquivo .mogrt novo ou atualizado até o clipe .mogrt existente na sequência. O Premiere Pro atualiza a guia Editar do painel Gráficos essenciais com os novos controles.

Trabalhar com Modelos de animações orientados por dados

Os Modelos de animações orientados por dados permitem personalizar com rapidez e precisão os gráficos de barras, gráficos de linhas e muito mais, sem entrada manual ou conhecimento profundo dos modelos de animações.

Com esse recurso, é possível adicionar controles para CSV (valores separados por vírgulas) e TSV (valores separados por tabulação) ao painel Gráficos essenciais. Ao exportar esses Modelos de animações com controles de dados para o Premiere Pro, é possível alterá-los ou substituí-los no Premiere Pro.

Outro uso é que os controles de dados no painel Gráficos essenciais podem funcionar como um navegador ou um editor de dados para camadas de dados CSV ou TSV na composição sem exportar como um modelo. Ao adicionar uma composição com dados da planilha ao painel, ele exibe quaisquer dados relacionados que sejam editáveis. Se estiver trabalhando com uma composição aninhada, os controles de dados não são acessíveis como propriedades principais dessa composição.

Use as etapas a seguir para adicionar controles de dados ao painel Gráficos essenciais:

  1. Importar arquivo CSV ou TSV para o seu projeto e adicioná-lo à composição.

  2. No painel Linha de tempo, gire para abrir as propriedade de camada da camada de dados.

  3. Selecione e arraste o grupo de propriedade de dados da camada para o painel Gráficos essenciais.

É possível modificar as seguintes propriedades para os dados da planilha no painel Gráficos essenciais:

  • Propriedades da planilha: clique em Editar propriedades à direita do grupo de dados para modificar o seguinte:
    • Tipo de propriedade de dados: escolha o tipo de dados para os valores em cada coluna. Use essa opção para alterar como os valores da planilha são representados no Premiere Pro. Um autor do After Effects define o tipo de cada coluna no After Effects. No Premiere Pro, o tipo é traduzido como uma cadeia de caracteres de texto, um controle deslizante de texto para números, ou um valor hexadecimal para a cor (por exemplo, #EE0473).
    • Linha mínimas: no Premiere Pro, é possível modificar o número de linhas usado no Modelo de animações. Defina o número mínimo de linhas permitido.
  • Linhas: no Premiere Pro, é possível modificar o número de linhas usado no Modelo de animações. Defina o número máximo de linhas permitido.
  • Propriedades de dados:
    • Nomes de coluna: modifique os nomes de colunas exibidas no Modelo de animações.
    • Valores de dados: modifique o valor de uma célula da planilha. Para escolher a linha para editar, altere o menu Linha na parte superior do grupo Valores de dados.

Observação:

Ao adicionar o grupo Propriedade de dados de uma camada de dados ao painel, ele remove as expressões que vinculam as propriedade de dados da camada ao arquivo de dados de origem. Isso os altera para valores estáticos. Se você modificar o arquivo de dados de origem fora do After Effects, os valores de dados estáticos são atualizados automaticamente.

Para obter mais informações sobre como usar esses modelos no Premiere Pro, consulte Trabalhar com Modelos de animações orientados por dados.

Observação:

Se estiver trabalhando com arquivos .tsv, especialmente no Excel em alemão (mas ele afeta qualquer idioma que usar uma vírgula decimal em vez de um ponto decimal), o Excel salva os arquivos .tsv como arquivos .txt. É necessário alterar manualmente a extensão de arquivo para .tsv antes de anexá-lo a um Modelo de animações no Premiere Pro.

Como alternativa, é possível usar outras ferramentas de planilha, como o Open Office ou o Planilhas Google.

Noções básicas das propriedades mestre

Propriedades mestre funcionam como controles mestre que permitem acessar propriedades de efeito e de camada de uma composição quando esta está aninhada em outra composição. Isso pode economizar tempo ao construir animações complexas por meio de várias composições aninhadas porque você não tem que abrir pré-composições separadas para exibir suas propriedades. As propriedades mestre podem anular os valores e quadros-chave originais, o que permite reutilizar a mesma composição como várias instâncias com valores diferentes. A composição de origem permanece a mesma, suas edições apenas criam novas instâncias que podem ser renderizadas após a edição da sua composição. Consulte o Glossário de propriedades mestre para obter uma lista de termos usados para explicá-las.

Para criar Propriedades mestre, no painel Gráficos essenciais, adicione as propriedades de uma composição aninhada ou aninhe a composição (Camada > Pré-Composição) após adicionar as propriedades. Para obter mais informações sobre os tipos de propriedade suportados pelo painel Gráficos essenciais, consulte Tipos de controles suportados. Assim que você aninhar a composição, o painel Linha de tempo exibe o grupo de Propriedades mestre da camada de pré-composição.

O fluxo de trabalho principal para criar as Propriedades mestre é semelhante ao modo como você cria controles para um modelo de animação. A diferença é como você usa as propriedades - se você usa as propriedades mestre em uma pré-composição no After Effects ou em um modelo de animação no Premiere Pro.

Glossário de termos

Consulte o glossário de termos (novo e já existente) para compreender os termos usados normalmente ao se trabalhar com as composições e propriedades mestre:

Aninhamento e pré-composição
Aninhamento e pré-composição

Aninhar: colocar uma composição dentro de outra composição.

Pré-composição: uma composição que está aninhada dentro de outra composição em um projeto.

Hierarquia de composição principal e composição secundária
Hierarquia de composição principal e composição secundária

Quando uma composição, por exemplo, composição A, é colocada dentro de outra composição, por exemplo, composição B, a composição A se torna a composição principal que contém a composição B, que é a composição secundária.

Propriedades mestre e composição mestre
Propriedades mestre e composição mestre

Uma composição definida como Mestre no Painel de Gráficos essenciais é a Composição mestre. No caso de uma composição mestre, ao adicionar uma propriedade de efeito ou de camada a partir da Linha de tempo ao painel Gráficos essenciais, a propriedade é chamada de propriedade Mestre.

Propriedade de origem
Propriedade de origem

A propriedade de camada ou de efeito a que uma propriedade mestre se refere.

Propriedade vinculada
Propriedade vinculada

É a propriedade mestre de uma pré-composição quando a propriedade de origem não for modificada.

Propriedade desvinculada
Propriedade desvinculada

É uma propriedade mestre de uma pré-composição quando a propriedade de origem for modificada.

Para alterar o valor, o quadro-chave ou a expressão de uma propriedade mestre em uma pré-composição.

Trabalhar com propriedades mestre

Propriedades vinculadas - ao aninhar uma composição mestre, as propriedades mestre dessa pré-composição são vinculadas às propriedades de origem. Por exemplo, se a composição B estiver aninhada na composição A, as propriedades de efeito e de camada da composição B são as propriedades de origem. Da composição B, as propriedades adicionadas ao painel Gráficos essenciais são as propriedades mestre. Ao modificar as propriedades de origem, as propriedades mestre da pré-composição também mudam.

Propriedades desvinculadas - ao modificar as propriedades mestre da pré-composição, elas se tornam desvinculadas. Desvincular cria uma instância da composição mestre. É possível modificar as propriedades mestre e de origem de forma independente.

Ao modificar uma propriedade mestre, há a anulação do valor ou dos quadros-chave de propriedade de origem. A pré-composição é uma instância única da composição mestre e somente essa instância é renderizada com o valor ou os quadros-chave modificados.

Botões de puxar e empurrar

Ao modificar uma propriedade mestre, os botões de puxar e empurrar do painel Linha de tempo estão habilitados e o nome da propriedade mestre fica em negrito. Essas são as indicações de que uma propriedade está desvinculada.

Os botões de puxar e empurrar vinculam novamente uma propriedade mestre com a propriedade de origem. Há botões de puxar e empurrar para cada propriedade mestre e para o grupo de propriedades mestre.

  • Puxar rejeita o valor, os quadros-chave e a expressão modificados de uma propriedade mestre.
  • Empurrar aplica o valor, os quadros-chave e a expressão modificados de uma propriedade mestre à propriedade de origem.

Após clicar em um botão de puxar ou de empurrar, as propriedades mestre são vinculadas novamente às propriedades de origem e desabilitam os botões de puxar e empurrar.

Botões de puxar e empurrar
Botões de puxar e empurrar

Ao empurrar uma propriedade mestre modificada de volta para a propriedade de origem, todas as instâncias da mesma composição mestre são atualizadas se a mesma propriedade mestre estiver vinculada. Por exemplo, é possível criar uma composição mestre para uma rolagem de crédito e aninhá-la várias vezes, e modificar a propriedade mestre de cor em apenas uma das pré-composições. Ao empurrar o novo valor de cor de volta ao valor de origem, todas as instâncias da composição mestre renderizam com o novo valor de cor.

Vincular propriedades mestre novamente

  • Para vincular novamente várias propriedades mestre de uma pré-composição a suas propriedades de origem:

Selecione as propriedades mestre específicas e clique no botão de Puxar ou no de Empurrar no grupo Propriedades mestre.

Vincular várias propriedades mestre novamente
Vincular várias propriedades mestre novamente
  • Para vincular novamente todas as propriedades mestre de uma pré-composição a suas propriedades de origem: 

Desmarque todas as propriedades mestre no painel Linha de tempo e clique nos botões de Puxar ou Empurrar no grupo Propriedades mestre.

Vincular todas as propriedades mestre novamente
Vincular todas as propriedades mestre novamente

Modificar as propriedades mestre do texto de origem

No contexto de uma composição principal, não é possível usar as ferramentas de digitação para modificação as propriedades do texto de origem no painel Composição.

Para modificar a string de texto de uma propriedade mestre, realize uma das opções a seguir:

  • Clique com o botão direito na propriedade mestre Texto de origem e selecione Editar valor. Edite a string de texto na caixa de diálogo e depois clique em OK.
  • Aplique uma expressão à propriedade mestre Texto de origem. Não esqueça de colocar a nova string entre aspas duplas. Por exemplo, "Luiza lustrava o lustre listrado".

Esta obra está licenciada sob uma licença não adaptada da Creative Commons Attribution-Noncommercial-Share Alike 3.0  As publicações do Twitter™ e do Facebook não são cobertas pelos termos do Creative Commons.

Avisos legais   |   Política de privacidade online