Visão geral do reconhecimento facial

O reconhecimento facial permite detectar e reconhecer com precisão as faces das pessoas. O rastreamento de máscara simples permite que você aplique efeitos apenas nas faces, como a correção de cores seletiva ou o desfoque na face de uma pessoa, e muito mais.

No entanto, com o Reconhecimento facial, é possível reconhecer partes específicas do rosto, como pupilas, boca e nariz, o que permite isolar e trabalhar estas características faciais com maior detalhe. Por exemplo, altere as cores dos olhos ou exagere os movimentos da boca sem ajustes quadro a quadro.

O After Effects também permite medir as características faciais. O reconhecimento de medidas faciais fornece detalhes sobre como é abrir a boca ou um olho. Com cada ponto de dados isolado, é possível refinar imensamente o conteúdo. Além disso, você também pode exportar dados de reconhecimento detalhados para o Adobe Character Animator para melhorar a animação de personagem com base em desempenho.

O controlador de face funciona em grande parte automaticamente, mas você pode obter melhores resultados ao iniciar a análise em um quadro que mostra uma visualização frontal e vertical da face. A iluminação adequada no rosto pode melhorar a precisão da detecção da face.

No painel Controlador, existem duas opções de rastreamento de face:

  • Rastreamento de face (Somente o contorno): utilize essa opção se você deseja apenas rastrear o contorno da face.
  • Reconhecimento facial (Recursos detalhados): use esta opção se deseja detectar os olhos (incluindo a sobrancelha e pupila), o nariz e a boca e, opcionalmente, extrair as medições de diversas características. Esta opção é necessária se você deseja utilizar os dados de reconhecimento no Character Animator.

    Caso esteja usando a opção Características detalhadas, um efeito de Pontos de reconhecimento facial será aplicado à camada. O efeito contém vários pontos de controle de efeito 2D com quadros-chave, cada um anexado aos traços faciais detectados (por exemplo, os cantos dos olhos e da boca, a localização das pupilas, a ponta do nariz).

Rastreamento do contorno de uma face

  1. No After Effects, selecione Arquivo > Importar > Arquivo. Navegue até o local da gravação e adicione-a ao projeto.

    Painel Projeto
  2. Arraste a gravação do painel Projeto até uma Composição para adicionar uma nova camada.

    Adicionar uma camada à composição
  3. Posicione o indicador de tempo atual (CTI) em um quadro que exibe a visualização frontal e vertical da face que deseja reconhecer.

    Observação:

    A detecção de face é aprimorada se o quadro inicial que será rastreado tiver uma face frontal orientada verticalmente.

    Detecção de face
  4. Desenhe uma máscara fechada livremente em torno da face, incluindo os olhos e a boca. A máscara define a região de pesquisa para detectar traços faciais. Se várias máscaras estiverem selecionadas, a máscara superior é utilizada.

    Desenhar uma máscara
  5. Com a máscara escolhida, selecione Janela > Rastreador para abrir o painel do Rastreador. Defina o Método de rastreamento como Rastreamento de face (Somente contorno).

    Escolher um método de reconhecimento
  6. No painel Controlador, é possível controlar um quadro por vez para garantir que o reconhecimento esteja funcionando corretamente e, em seguida, clicar no botão para iniciar a análise de todos os quadros.

  7. Uma vez que a análise é concluída, os dados de reconhecimento facial tornam-se disponíveis na composição.

    Dados do reconhecimento facial na composição

Como reconhecer características detalhadas e extrair as medidas faciais

  1. No After Effects, selecione Arquivo > Importar > Arquivo. Navegue até o local da gravação e adicione-a ao projeto.

  2. Arraste a gravação do painel Projeto até uma Composição para adicionar uma nova camada.

  3. Posicione o Indicador de tempo atual em um quadro que exibe a visualização frontal e vertical da face que você deseja rastrear.

    Observação:

    A detecção de face é aprimorada se o quadro inicial que será rastreado tiver uma face frontal orientada verticalmente.

  4. Desenhe uma máscara fechada livremente em torno da face, incluindo os olhos e a boca. A máscara define a região de pesquisa para detectar traços faciais. Se várias máscaras estiverem selecionadas, a máscara superior é utilizada.

  5. Com a máscara escolhida, selecione Janela > Rastreador para abrir o painel do Rastreador. Defina o Método de rastreamento como Rastreamento de face (Traços detalhados).

  6. No painel Controlador, é possível controlar um quadro por vez para garantir que o reconhecimento esteja funcionando corretamente e, em seguida, clicar no botão para iniciar a análise de todos os quadros.

  7. Uma vez que a análise é concluída, os dados de reconhecimento tornam-se disponíveis com um novo efeito, chamado Pontos de reconhecimento facial. Você pode optar por acessar os dados de reconhecimento facial na composição ou no painel Efeitos (Janela > Controles do efeito).

    Controles de efeito dos pontos de reconhecimento da face
  8. Mova o indicador de tempo atual para um quadro que mostra uma expressão neutra na face (a pose de descanso). As medidas da face em outros quadros são relativas ao quadro de pose de descanso. No painel Controlador, clique em Definir pose de descanso.

  9. No painel Controlador, clique em Extrair e copiar as medidas faciais. Um efeito Medidas de face é adicionado à camada, e os quadros-chave são criados com base em cálculos dos dados de quadro-chave dos Pontos de rastreamento de face. Os dados do quadro-chave das Medidas de face são copiados para a área de transferência com a finalidade de utilizar o Character Animator.

    Observação:

    Os quadros-chave para as Medidas de face são gerados com base nos dados do quadro-chave dos Pontos de reconhecimento facial em relação à Pose de descanso (consulte a Etapa 8).

    Controles de efeito das medidas da face

Referência dos dados do reconhecimento facial

Pontos de reconhecimento facial

O efeito Controlador facial cria pontos de controle de efeitos para diversas características faciais, que você pode exibir no painel Linha do tempo.

Medidas da face

Caso tenha usado a opção Características detalhadas, é possível extrair ainda mais informações sob a forma de medidas paramétricas das características faciais, conhecidas como Medidas de face. Todas as medidas mostradas para a face reconhecida são relacionadas ao quadro de Pose de descanso.

Deslocamento de face

Indica a posição da face, deslocando para 0% em um quadro de Pose de descanso. Os seguintes pontos de dados são disponibilizados, indicando os valores de deslocamento nos eixos x, y e z:

  • Deslocamento X
  • Deslocamento Y
  • Deslocamento Z

Orientação de face

Indica as orientações tridimensionais de face. A orientação é medida usando os seguintes pontos de dados, indicativo dos eixos x, y e z:

  • Orientação X
  • Orientação Y
  • Orientação Z

Olho esquerdo

Indica diversos pontos de medição para o olho esquerdo e inclui os seguintes pontos de dados:

  • Distância da sobrancelha esquerda
  • Abertura de pálpebra esquerda
  • Olhar esquerdo X
  • Olhar esquerdo Y

Olho direito

Indica diversos pontos de medição para o olho direito e inclui os seguintes pontos de dados:

  • Distância da sobrancelha direita
  • Abertura da pálpebra direita
  • Olhar direito X
  • Olhar direito Y

Boca

Indica diversos pontos de medição para a boca e inclui os seguintes pontos de dados:

  • Deslocamento X da boca
  • Deslocamento Y da boca
  • Dimensionar largura da boca
  • Dimensionar altura da boca

Esta obra está licenciada sob uma licença não adaptada da Creative Commons Attribution-Noncommercial-Share Alike 3.0  As publicações do Twitter™ e do Facebook não são cobertas pelos termos do Creative Commons.

Avisos legais   |   Política de privacidade online