Uso de memória (RAM) no After Effects de 64 bits

Preferências de Memória e multiprocessamento

Defina preferências de memória e multiprocessamento ao selecionar Editar > Preferências > Memória (Windows) ou After Effects > Preferências > Memória (Mac OS).

Quando você altera as configurações na caixa de diálogo Memória e multiprocessamento, o After Effects atualiza dinamicamente o texto útil na caixa de diálogo que reporta como irá alocar e usar a memória e as CPUs.

A preferência RAM reservada para outros aplicativos é relevante se a opção Renderizar vários quadros simultaneamente estiver ou não selecionada. As configurações na categoria Multiprocessamento do After Effects são relevantes apenas se a opção Renderizar vários quadros simultaneamente estiver selecionada.

Todd Kopriva fornece informações sobre configurações ideais da memória e do processador no site da Adobe.

RAM reservada para outros aplicativos

Aumente esse valor para deixar mais RAM disponível para o sistema operacional e para aplicativos diferentes do After Effects e o aplicativo com que ele compartilha um pool de memória. (Consulte Pool de memória compartilhada entre o After Effects, o Premiere Pro e o Adobe Media Encoder.) Se souber que vai usar um aplicativo específico junto com o After Effects, verifique os requisitos de sistema e defina esse valor para, no mínimo, a quantidade mínima de RAM necessária para esse aplicativo. Como o desempenho é melhor quando a memória adequada é deixada para o sistema operacional, você não pode definir esse valor abaixo de um valor mínimo de linha de base.

Pool de memória compartilhado entre o After Effects, Premiere Pro, Prelude, Media Encoder, Photoshop, SpeedGrade e Audition

O After Effects compartilha um pool de memória com aplicativos do Adobe CC. Isso é indicado no painel de preferências Memória pelos ícones de cada um desses aplicativos no painel superior. Os ícones ficam esmaecidos para aplicativos que não estão em execução.

Um balanceador de memória impede a troca de RAM para disco gerenciando dinamicamente a memória alocada a cada um dos aplicativos. Cada aplicativo é registrado com o balanceador de memória com algumas informações básicas: requisitos mínimos de memória, memória máxima que pode ser usada, memória atual em uso e uma prioridade. A prioridade tem três configurações: baixa, normal e mais alta. O maior é reservado no momento para o After Effects e PremierePro,quando for o aplicativo ativo.Normalé para o After Effects em segundo plano ou o Adobe Media Encoder em primeiro plano. Baixa é para os servidores em segundo plano do Premiere Pro ou do Adobe Media Encoder em segundo plano.

Observação:

Um exemplo de um resultado prático do pool de memória compartilhado é que, ao iniciar o Premiere Pro, a quantidade de RAM para o After Effects disponível para visualizações diminuirá. Ao sair do Premiere Pro, a memória será imediatamente liberada para o After Effects, o que prolonga a duração possível de visualizações de RAM.

Caixa de diálogo Memória

A caixa de diálogo Detalhes de memória contém mais informações sobre a memória RAM instalada, além do uso atual e permitido de RAM. Também inclui processos de lista da tabela multicoluna relacionada aos aplicativos. A tabela inclui informações sobre cada processo, como a ID, o Nome do aplicativo, o Mínimo de memória necessária, o Máximo de memória utilizável, o Máximo de memória permitida, a Memória atual e a Prioridade atual.

Para abrir a caixa de diálogo, selecione Editar > Preferências > Memória (Windows) ou After Effects > Preferências > Memória (Mac OS), em seguida, clique no botão Detalhes na parte inferior da caixa de diálogo de preferências.

Você pode copiar as informações para a área de transferência com o botão Copiar.

Requisitos de memória (RAM) para renderização

Os requisitos de memória para renderização de um quadro (seja para visualizações ou para saída final) aumentam com o requisito de memória da camada de uso mais intensivo de memória na composição.

O After Effects renderiza cada quadro de uma composição uma camada por vez. Por esse motivo, os requisitos de memória de cada camada individual é mais relevante que a duração da composição ou o número de camadas na composição para determinar se um certo quadro pode ser renderizado com a memória disponível. O requisito de memória para uma composição equivale à necessidade de memória da única camada mais intensiva de memória na composição.

Os requisitos de memória de uma camada aumentam em várias circunstâncias, incluindo:

  • Aumento da profundidade de bits de cor do projeto

  • Aumento da resolução da composição

  • Uso de uma imagem de origem maior

  • Ativação do gerenciamento de cores

  • Adicionando uma máscara

  • Adição de propriedades 3D por caractere

  • Pré-composição sem transformações de recolhimento

  • Uso de certos modos de mesclagem, estilos de camada ou efeitos, especialmente aqueles que envolvem várias camadas

  • Aplicar algumas opções de saída, como pulldown de 3:2, cortes e redimensionamento

  • Adicionar sombras e efeitos de profundidade do campo ao usar camadas 3D

O After Effects exige um bloco contíguo de memória para armazenar cada quadro; ele não pode armazenar um quadro em partes na memória fragmentada. Para obter informações sobre a quantidade de RAM necessária para armazenar um quadro descompactado, consulte Requisitos de memória para arquivos de saída.

Observação:

Para obter dicas sobre como reduzir os requisitos de memória e aumentar o desempenho, consulte Melhorar o desempenho simplificando seu projeto.

Limpar memória (RAM)

Ocasionalmente, o After Effects pode exibir uma mensagem de alerta indicando que requer mais memória para exibir ou renderizar uma composição. Se receber um alerta de falta de memória, libere memória ou reduza os requisitos de memória das camadas que usam muita memória e tente novamente.

É possível liberar memória imediatamente com comandos do menu Editar > Limpar:

  • Toda memória
  • Memória em cache de imagens
  • Toda memória e cache de disco
  • Desfazer
  • Instantâneo

Limpar a memória é mais rápido em grandes projetos. Limpar a memória não sincroniza o banco de dados do projeto. Se quiser forçar a sincronização do banco de dados do projeto, pressione a tecla Option (Mac OS) ou Alt (Windows) e escolha Editar > Limpar > Toda a memória. Você pode fazer isso se o painel Composição não for corretamente atualizado e os comandos Limpar > Toda a memória ou Toda a memória ou cache em disco não forem eficazes. 

Solução de problemas de memória

Erro: “Não é possível alocar memória suficiente para renderizar o quadro atual…”

Diminua os requisitos de memória para a renderização desse quadro ou instale mais RAM.

Erro: “Não é possível alocar [n] MB de memória.”

Diminua os requisitos de memória para a renderização desse quadro ou instale mais RAM.

Erro: “Os buffers de imagem de tamanho [largura]x[altura] @ [profundidade] ([n] GB) excedem os limites internos.”

Diminua os requisitos de memória para a renderização desse quadro.

Observação:

A quantidade máxima de memória que um quadro poderá ocupar é de 2 GB.

Erro: “A alocação de memória de [n] GB excede os limites internos.”

Diminua os requisitos de memória para a renderização desse quadro.

Observação:

O tamanho máximo para uma alocação de memória única é de 2 GB.

Requisitos de armazenamento para arquivos de saída

Use a seguinte fórmula para determinar o número de megabytes necessários para armazenar um quadro descompactado em resolução total:

(altura em pixels) x (largura em pixels) x (o número de bits por canal) / 2.097.152

Observação:

O valor 2.097.152 é um fator de conversão que representa o número de bytes por megabyte (220), o número de bits por bytes (8) e o número de canais por pixel (4).

Alguns exemplos de tamanhos de quadro e requisitos de memória, em megabytes (MB) por quadro:

  • Quadro DV NTSC (720x480) em um projeto de 8 bpc: 1,3 MB

  • Quadro D1/DV PAL (720x576) em um projeto de 8 bpc: 1,6 MB

  • Quadro HDTV (1920x1080) em um projeto de 16 bpc: 16 MB

  • Quadro digital de cinema 4K (4096x2304) em um projeto de 32 bpc: 144 MB

Como o vídeo normalmente é compactado durante a codificação ao renderizar a saída final, você não pode simplesmente multiplicar a quantidade de memória necessária para um único quadro pela taxa de quadros e a duração da composição para determinar a tamanho do espaço em disco necessário para armazenar a saída final do seu filme. Contudo, esse cálculo pode-lhe dar uma ideia vaga do espaço máximo de armazenamento necessário. Por exemplo, um segundo (aproximadamente 30 quadros) de vídeo descompactado de definição padrão de 8 bpc requer aproximadamente 40 MB. Um filme longa-metragem nessa taxa de dados exigiria mais de 200 GB para armazenar. Mesmo com compactação DV, que reduz o tamanho do arquivo para 3,6 MB por segundo do vídeo, esse requisito de armazenamento significa mais de 20 GB de um filme longa-metragem típico.

Não é incomum para um projeto de longa metragem com sua maior profundidade de bits de cor, maior tamanho do quadro e taxas de compactação muito menores, exigir terabytes de armazenamento de gravação e filmes de saída renderizada.

Caches: cache de RAM, cache de disco e cache de mídia

Ao trabalhar em uma composição, o After Effects armazena temporariamente alguns quadros e imagens de origem renderizados na RAM, para que a visualização e a edição possam ser executadas mais rapidamente. O After Effects não armazena em cache os quadros que necessitam de pouco tempo para renderizar. Os quadros permanecem descompactados no cache de imagens.

O After Effects também armazena em cache aos níveis de gravação e camada para visualizações mais rápidas; as camadas que foram modificadas são renderizadas durante a visualização e as camadas inalteradas são compostas a partir do cache.

Quando o cache de RAM estiver cheio, qualquer novo quadro adicionado ao cache de RAM substituirá um quadro que já foi armazenado em cache antes. Quando o After Effects renderiza quadros para visualizações, ele deixa de adicionar quadros ao cache de imagem quando o cache está cheio e passa a reproduzir apenas os quadros que cabem no cache de RAM.

As barras verdes na régua de tempo dos painéis Linha de tempo, Camada e Gravação marcam os quadros colocados em cache para a RAM. As barras azuis no painel Linha de tempo marcam os quadros colocados em cache para o disco.

Indicadores do cache de camada

Os indicadores do cache de camada permitem visualizar quadros em cache em uma base por camada. Isso é útil ao tentar determinar quais camadas serão armazenadas em cache em uma composição.

Ative a opção Indicadores de cache de camada pressionando Ctrl (Windows) ou Command (Mac) e selecione Mostrar Indicadores de cache no menu do painel Linha de tempo. A opção Mostrar Indicadores de cache deve estar ativada no menu para consultar os indicadores.

Observação:

A exibição dos indicadores de cache diminui ligeiramente o desempenho.

O cache de RAM é limpo automaticamente quando você sair do After Effects.

É possível limpar o cache daRAMou o cache da RAM e o do disco no menu Editar > Limpar.

Selecione Editar > Limpar > Toda memória e cache de disco para limpar o conteúdo de todos os caches da RAM (como o comando existente Toda memória) e o conteúdo do cache de disco (como o botão Esvaziar o cache de disco existente nas preferências de Cache de mídia e de disco).

O After Effects limpa a memória mais rápido para grandes projetos. Limpar a memória não sincroniza o banco de dados do projeto. Se quiser forçar a sincronização do banco de dados do projeto, pressione a tecla Option (Mac OS) ou Alt (Windows) e escolha Editar > Limpar > Toda a memória. Você pode fazer isso se o painel Composição não for corretamente atualizado os compandos Limpar > Toda a memória ou Toda a memória e o cache em disco não forem eficazes. 

Observação:

Limpar o cache de disco para uma versão do After Effects não limpa o cache de outras versões. Por exemplo, limpar o cache de disco da After Effects CC não afetará o cache de disco da After Effects CS6.

Cache de desempenho global

O cache global de desempenho consiste no seguinte:

Cache de RAM global: quando você modifica uma composição, os quadros no Cache de RAM não são apagados automaticamente, sendo reutilizados se você desfizer a alteração ou restaurar o estado anterior da composição. Os quadros mais antigos no Cache de RAM serão apagados quando o Cache de RAM estiver cheio e o After Effects precisar armazenar novos quadros em cache.
Cache de disco persistente: os quadros em cache em disco ainda estarão disponíveis, mesmo após o fechamento do After Effects.

Para obter mais informações sobre o cache de desempenho global, consulte a publicação do blog intitulada “Recursos da GPU (CUDA, OpenGL) no After Effects” no blog da equipe do After Effects.

Vídeo: cache de desempenho global

Vídeo: cache de desempenho global
Nesse vídeo de Brian Maffitt e Total Training, veja como os recursos do cache de desempenho global podem economizar tempo ao compor.
Brian Maffitt e Total Training

 

Neste vídeo de Todd Kopriva e video2brain, aprenda sobre o cache do desempenho global e cache de disco persistente, e veja como esses recursos tornam a renderização e re-renderização de camadas muito mais rápidas e mais fáceis.

Observação:

O cache de disco não é usado para visualizações de É usado apenas para visualizações sem execução em tempo real de quadros em cache e áudio. (Consulte Visualização.)

O cache de disco é ativado por padrão. Para preferências de cache de disco e para ativar ou desativar o cache de disco:

  1. Escolha Editar > Preferências > Cache de mídia e disco (Windows) ou After Effects > Preferências > Cache de mídia e disco (Mac OS) e marque ou desmarque Ativar cache de disco.

As preferências de cache de disco permitem selecionar uma pasta para conter o cache.

  1. Clique no botão Escolher pasta e clique em OK (Windows) ou Escolher (Mac OS).

Para esvaziar o cache de disco:

  1. Clique no botão Esvaziar o cache de disco ou selecione Limpar toda a memória e opção Cache de disco do menu Editar.

Observação:

Mesmo quando o cache de disco estiver ativado, cada quadro deve poder caber em um bloco contíguo de RAM. Ativar o cache de disco não ajuda ao nível de limitações relacionadas a RAM inadequada para guardar ou renderizar um único quadro da composição.

Para melhorar o desempenho com o cache de disco, selecione uma pasta que esteja em um disco rígido físico diferente da gravação de origem. É recomendado que a pasta esteja no disco rígido que usa um controlador de unidade diferente do disco com a gravação de origem. Um disco rígido veloz ou um SSD com o máximo de espaço alocado possível são recomendados para a pasta de cache de disco. A pasta de cache de disco não pode ser a pasta raiz do disco rígido.

Como no cache de RAM, o After Effects utiliza apenas o cache de disco para armazenar um quadro se for mais rápido recuperar um quadro do cache do que para renderizar novamente o quadro.

A configuração Tamanho máximo do cache de disco especifica o número de gigabytes de espaço em disco para usar. O tamanho do cache de disco padrão é definido como 10% o tamanho total do volume, com até 100 GB.  

Observação:

O aplicativo verifica para garantir que haja 10 GB de espaço livre acima do que é definido em Preferências > Cache de disco e mídia. O After Effects avisa se não houver espaço suficiente para o cache de disco.

Cache global de RAM

O cache global de RAM oferece as seguintes vantagens:

  • Os quadros em cache são restaurados após desfazer/refazer.
  • Os quadros em cache são restaurados quando uma composição ou uma camada retorna a um estado anterior, como desativar a visibilidade de uma camada e depois ativar novamente.
  • Os quadros reutilizáveis são reconhecidos em qualquer lugar na Linha de tempo (por exemplo, ao usar expressões de loop, remapeamento de tempo ou copiar/colar de quadros-chave), não apenas os quadros adjacentes.
  • Os quadros reutilizáveis são reconhecidos nas camadas duplicadas ou composições duplicadas;
  • O cache não será destruído automaticamente por uma fila de renderização usando algo que não seja das Configurações atuais.

Nesse vídeo da Learn by Video, você vai ver como os caches de RAM e disco são usados ​para economizar tempo, e como renderizar as composições em segundo plano para que não seja preciso esperar que uma visualização seja renderizada para que você possa retomar o trabalho.

Cache de disco persistente

Após salvar um projeto, os quadros em cache de disco são retidos mesmo após o fechamento do projeto ou do After Effects. O protocolo é chamado cache de disco persistente.O cache de disco já não é mais esvaziado ao final de uma sessão. Com o recurso de cache de disco persistente, os quadros armazenados no cache de disco são preservados entre sessões. Isso economiza tempo de renderização ao trabalhar em um projeto ou em outros projetos que usam os mesmos quadros em cache.

Na abertura de um projeto, o cache de disco é pesquisado em busca de quadros que correspondam aos quadros do projeto e os torna disponíveis para uso. O cache de disco contém quadros de todos os projetos que você abriu na mesma sessão ou em sessões anteriores, de modo que os quadros em cache de disco de um projeto serão recuperados para reutilização em outros projetos que precisam desses mesmos quadros. À medida que o cache é pesquisado, marcas azuis aparecem gradualmente em sua linha de tempo.

Observação:

Como as versões anteriores do After Effects não armazenavam tudo em disco que era necessário para esse recurso, salve novamente o CS5.5 e projetos anteriores, para testar o cache persistente.

Observação:

Os quadros do Pincel tipo rotoscópio não são armazenados em cache persistente.

Observação:

A área de trabalho do cache de fundo também usa o cache de disco para armazenar quadros. Consulte Aprimorar o desempenho usando o cache de desempenho global.

Tutorial em vídeo: como otimizar o After Effects para obter alto desempenho

Tutorial em vídeo: como otimizar o After Effects para obter alto desempenho
O Gerente de produto sênior, Steve Forde, mostra como otimizar o After Effects para obter um alto desempenho.
Steve Forde

Armazenar espaço de trabalho em cache em segundo plano

É possível preencher o cache de disco para o espaço de trabalho de uma composição (ou várias áreas de trabalho da mesma composição ou de várias composições) para continuar trabalhando. Quando não esperar fazer alterações em uma composição, especialmente se ela for usada nas composições downstream, você pode renderizar os quadros no cache de disco em segundo plano. Normalmente, o aplicativo tenta identificar quadros apropriados difíceis de renderizar que devem ser colocados no cache de disco, mas este comando forçará os quadros a serem renderizados para o cache de disco para uma recuperação mais rápida na próxima vez que forem necessários.

  1. Para armazenar em cache uma composição em disco em segundo plano:

    Certifique-se de que o cache de disco esteja ativado em Editar > Preferências > Cache de disco e mídia (Windows) ou Premiere Pro > Preferências > Cache de disco e mídia (MacOS).

    Observação:

    Para obter melhores resultados, use um grande cache de disco em uma unidade rápida que seja diferente da unidade de gravação de origem. As unidades de SSD funcionam bem para armazenamento em cache de disco.

  2. Defina o espaço de trabalho para os quadros a serem armazenados em cache no disco.

  3. Selecione Composição > Armazenar espaço de trabalho em cache em segundo plano ou use o atalho do teclado Ctrl + Enter (Windows) ou Cmd + Enter (MacOS).

    Para cancelar o armazenamento de espaço de trabalho em cache em segundo plano, escolha Composição > Armazenar espaço de trabalho em cache em segundo plano.

O projeto é salvo em um arquivo temporário no disco e, depois, uma instância do After Effects de segundo plano é lançada para renderizá-lo. O progresso da renderização aparece no painel Informações. Os quadros renderizados aparecem como marcas de cache azuis porque estão no cache de disco. Os caches de camada e composições aninhadas só vão ficar em cache de disco se valer a pena (suficientemente difíceis de renderizar).

Você pode colocar em fila diferentes seções da mesma composição ou composições diferentes ou até mesmo um projeto diferente, mas apenas um espaço de trabalho está sendo renderizada por vez em segundo plano.

Observação:

Se fizer alterações em uma área de trabalho em fila, a renderização existente continuará usando as configurações anteriores. Os indicadores de cache azuis não reaparecerão quando você desfizer para esse estado.

Para colocar em cache várias composições no segundo plano:

  1. Defina o espaço de trabalho em cada composição que deseja colocar em cache.

  2. Selecione as composições no painel Projeto.

  3. Siga um destes procedimentos:

    • Selecione Composição > Armazenar espaço de trabalho em cache em segundo plano
    • Pressione Ctrl+Enter (Windows) ou Cmd+Enter (MacOS)
    • Escolha Armazenar espaço de trabalho em cache em segundo plano no menu de contexto

     

Para cancelar as renderizações de cache em segundo plano atuais e pendentes:

  1. Selecione Composição >Cancelar armazenamento em cache do espaço de trabalho em segundo plano.

Se vários trabalhos de segundo plano estiverem em execução, o número de trabalhos será exibido como parte do comando de menu.

Cache de mídia

Quando o After Effects importa vídeo e áudio em alguns formatos, ele processa e armazena em cache versões desse itens que pode acessar prontamente ao gerar visualizações. Os arquivos de áudio importados são todos adaptados a um novo arquivo .cfa, e os arquivos MPEG são indexados a um novo arquivo .mpgindex. O cache de mídia aumenta muito o desempenho para visualizações, porque os itens de vídeo e de áudio não são reprocessados para cada visualização.

Observação:

Ao importar um arquivo pela primeira vez, você poderá observar um atraso enquanto a mídia estiver sendo processada e armazenada em cache.

Um banco de dados mantém links para cada um dos arquivos de mídia armazenados em cache. Esse banco de dados de cache de mídia é compartilhado com Adobe Media Encoder, Premiere Pro, Encore e Soundbooth, por isso cada um pode ler o mesmo conjunto de arquivos de mídia em cache e escrever neles. Se você alterar o local do banco de dados a partir de qualquer um desses aplicativos, o local também será atualizado para os outros aplicativos. Cada aplicativo pode utilizar sua própria pasta de cache, mas o mesmo banco de dados controla todas.

  1. Escolha Editar > Preferências > Cache de mídia e disco (Windows) ou After Effects > Preferências > Cache de mídia e disco (Mac OS), e siga um destes procedimentos:

    • Clique em um dos botões Escolher pasta para alterar o local do banco de dados de cache de mídia ou o próprio cache de mídia.
    • Clique em Limpar banco de dados e cache para remover arquivos adaptados e indexados do cache e para remover respectivas entradas do banco de dados. Este comando remove somente os arquivos associados aos itens de gravação para os quais o arquivo de origem não está mais disponível.

    Observação:

    Antes de clicar no botão Limpar banco de dados e cache, certifique-se de que todos os dispositivos de armazenamento que contêm sua mídia de origem usada recentemente estejam conectados ao seu computador. Se a gravação for determinada como ausente porque o dispositivo de armazenamento no qual está localizada não está conectado, os arquivos respectivos na cache de mídia serão removidos. Esta remoção resulta na necessidade de uniformizar ou reindexar a gravação quando você tentar utilizá-la posteriormente.

Observação:

A limpeza do banco de dados e da cache com o botão Limpar banco de dados e cache não remove os arquivos associados aos itens de gravação cujos arquivos de origem ainda estejam disponíveis. Para remover manualmente os arquivos adaptados e os arquivos de índice, navegue para a pasta de cache de mídia e exclua os arquivos. O local da pasta de cache de mídia é exibido nas preferências Cache de mídia em conformidade. Se o caminho estiver truncado, clique no botão Escolher pasta para mostrar o caminho.

Esta obra está licenciada sob uma licença não adaptada da Creative Commons Attribution-Noncommercial-Share Alike 3.0  As publicações do Twitter™ e do Facebook não são cobertas pelos termos do Creative Commons.

Avisos legais   |   Política de privacidade online