Meer informatie over het gebruiken van het deelvenster Bestanden voor het beheren, overbrengen en synchroniseren van bestanden en mappen tussen lokale en externe sites in Dreamweaver. Bekijk hier ook hoe de auto-herstelfunctie in Dreamweaver werkt.

In het deelvenster Bestanden in Dreamweaver kunt u bestanden die aan uw site zijn gekoppeld bekijken en beheren. U kunt schakelen tussen de FTP-Weergave en de Git-weergave in het deelvenster Bestanden om de bestanden te beheren met een FTP-server of met Git-opslagplaatsen.

U opent het deelvenster Bestanden door te klikken op Venster > Bestanden of te drukken op F8 (Windows) of Shift-⌘-F (Mac).

Opmerking:

Als u geen site opzet, vermeldt het deelvenster Bestanden simpelweg alle stations of mappen in uw systeem. U kunt het alleen gebruiken om bestanden te bekijken. U kunt bestanden niet overbrengen tussen een extern systeem en uw lokale systeem. 

Zie Over Dreamweaver-sites voor meer informatie over de voordelen van het opzetten van een site en voor instructies over hoe u een site maakt.

Lees verder voor meer informatie over het gebruik van het deelvenster Bestanden in elk van deze weergaven.

Werken met het deelvenster Bestanden in de FTP-weergave

U kunt de FTP-weergave gebruiken om bestanden en mappen te bekijken, om te controleren of ze aan een Dreamweaver-site zijn gekoppeld en om standaard onderhoudsbewerkingen voor bestanden uit te voeren, zoals bestanden openen en verplaatsen. Met het deelvenster Bestanden kunt u ook bestanden beheren en van en naar een externe server overzetten.

Nadat u een site hebt ingesteld in Dreamweaver, kunt u het deelvenster Bestanden op de volgende manieren gebruiken:

  • Toegang krijgen tot sites, een server en lokale stations
  • Bestanden en mappen weergeven
  • Bestanden en mappen beheren in het deelvenster Bestanden
  • Bestanden en mappen synchroniseren tussen lokale en externe servers

Lees verder voor informatie over het gebruik van het deelvenster Bestanden in de FTP-weergave.

Opties in het deelvenster Bestanden

In de meest eenvoudige versie van het deelvenster Bestanden wordt een lijst weergegeven met alleen de lokale bestanden op uw computer. Naarmate u meer werkt met het deelvenster Bestanden (een site opzet, verbindingen maakt met externe servers, in- en uitchecken inschakelt), worden meer opties weergegeven in het deelvenster Bestanden.

Zo ziet het deelvenster Bestanden eruit:

  • Als er geen site is gedefinieerd in Dreamweaver
  • Als er wel een site, maar geen server is gedefinieerd
  • Als er een site is gedefinieerd, worden serververbindingen gedefinieerd en wordt het in- en uitchecken van bestanden ingeschakeld

Zie Over Dreamweaver-sites voor informatie over het definiëren van een site en een server.

Als er geen site is gedefinieerd in Dreamweaver

Hoe het deelvenster Bestanden eruit ziet als er geen site is gedefinieerd in Dreamweaver
Hoe het deelvenster Bestanden eruit ziet als er geen site is gedefinieerd in Dreamweaver

Als er wel een site, maar geen server is gedefinieerd

Als u een Dreamweaver-site definieert, worden de bestanden binnen uw site weergegeven. Het deelvenster Bestanden bevat ook een knop, Servers definiëren, met een prompt om het definiëren van verbindingen naar externe en testservers te starten.

Hoe het deelvenster Bestanden eruitziet als er een site is gedefinieerd in Dreamweaver, maar er geen servers zijn gedefinieerd
Hoe het deelvenster Bestanden eruitziet als er een site is gedefinieerd in Dreamweaver, maar er geen servers zijn gedefinieerd

Als er een site en servers zijn gedefinieerd en in- en uitchecken is ingeschakeld

U kunt alle opties in het deelvenster Bestanden gebruiken nadat u een site en server hebt gedefinieerd. Als u in- en uitchecken inschakelt, kunt u deze opties ook gebruiken.

Lees verder als u meer wilt weten over wat u met het deelvenster Bestanden kunt doen.

Voor informatie over het inschakelen van in- en uitchecken, zie Bestanden inchecken en uitchecken.

Het deelvenster Bestanden als er een site, verbindingen met externe servers en in- en uitchecken zijn ingeschakeld
Het deelvenster Bestanden als er een site, verbindingen met externe servers en in- en uitchecken zijn ingeschakeld

A. Site (pop-upmenu) B. Bestandsweergave C. Verbinding maken met externe server D. Bestanden van externe server ophalen E. Bestanden op de externe server plaatsen F. Bestanden uitchecken G. Bestanden inchecken H. Synchroniseren met externe server I. Uitvouwen/samenvouwen J. Vernieuwen K. Bestandsactiviteit 

U kunt het deelvenster Bestanden verplaatsen indien nodig, en voorkeuren instellen voor het deelvenster.

Opmerking:

De knoppen voor de weergave Sitebestanden, de testserverweergave en Synchroniseren verschijnen uitsluitend in het uitgevouwen deelvenster Bestanden.

Site pop-upmenu

Hiermee kunt u een Dreamweaver-site selecteren en de bestanden van die site weergeven. U kunt het menu Site ook gebruiken om alle bestanden op uw lokale schijf te openen, vergelijkbaar met Windows Verkenner (Windows) of de Finder (Mac).

Bestandsweergave

U kunt bestanden bekijken uit de lokale hoofdmap van de site, externe server of testserver. Selecteer een optie in het pop-upmenu om bestanden in de betreffende weergave te bekijken.

Verbinding maken met externe server

(FTP-, RDS- en WebDAV-protocol) Verbinding maken met de externe site of de verbinding verbreken. Dreamweaver verbreekt standaard de verbinding met een externe site als deze langer dan 30 minuten niet is gebruikt (alleen FTP). Om die tijdslimiet te veranderen, selecteert u Bewerken > Voorkeuren (Windows) of Dreamweaver > Voorkeuren (Macintosh); vervolgens selecteert u Site in de categorielijst aan de linkerzijde.

Bestanden van externe server ophalen

Kopieert de geselecteerde bestanden van de externe site naar uw lokale site (en overschrijft daarbij de bestaande lokale kopie van het bestand, als die er is). Als In- en uitchecken van bestanden inschakelen is ingeschakeld, zijn de lokale kopieën alleen-lezen; de bestanden blijven beschikbaar op de externe server zodat andere teamleden kunnen uitchecken. Als In- en uitchecken van bestanden inschakelen in uitgeschakeld, hebben de bestandskopieën zowel lees- als schrijfrechten.

Bestanden op de externe server plaatsen

Kopieert de geselecteerde bestanden van de lokale site naar de externe site.

Bestanden uitchecken

Brengt een kopie van het bestand over van de externe server naar uw lokale site (overschrijft de bestaande lokale kopie van het bestand, als die er is) en markeert het bestand als uitgecheckt op de server. Deze optie is niet beschikbaar als In- en uitchecken van bestanden inschakelen is uitgeschakeld voor de huidige site.

Bestanden inchecken

Brengt een kopie van het lokale bestand over naar de externe server en stelt het bestand ter beschikking voor bewerking door anderen. Het lokale bestand wordt alleen-lezen. Deze optie is niet beschikbaar als In- en uitchecken van bestanden inschakelen is uitgeschakeld voor de huidige site.

Synchroniseren met externe server

Synchroniseert de bestanden tussen de lokale en externe mappen.

Uitvouwen/samenvouwen

Hiermee vouwt u het deelvenster Bestanden uit of samen om een of twee vensters weer te geven. In de Uitgebreide weergave is ook een extra optie - FTP-logboek van site weergeven - beschikbaar. Als het deelvenster Bestanden is samengevouwen, geeft het de inhoud van de lokale site, de externe site of de testserver weer in de vorm van een bestandenlijst. Als het is uitgevouwen, geeft het de lokale site en de externe site of de testserver weer.

Vernieuwen

Hiermee vernieuwt u de lokale en externe mappenlijsten. Gebruik deze knop om de mappenlijsten manueel te vernieuwen als u Automatisch vernieuwen lijst lokale bestanden of Automatisch vernieuwen lijst externe bestanden hebt uitgeschakeld in het dialoogvenster Sitedefinitie.

Bestandsactiviteit

Geeft de bestandsactiviteiten op de achtergrond weer.

FTP-logboek van site weergeven is beschikbaar als u het deelvenster Bestanden uitvouwt door te klikken op het pictogram Uitvouwen/samenvouwen.

FTP-logboek van site weergeven

Geeft de bestanden structuur van de externe en lokale sites weer in de deelvensters van het deelvenster Bestanden. (Met een voorkeursinstelling bepaalt u welke site in het linker venster verschijnt en welke in het rechter venster.) De weergave Sitebestanden is de standaardweergave voor het deelvenster Bestanden.

Opmerking:

De bestanden die Dreamweaver kopieert, zijn de bestanden die u in het actieve deelvenster van het deelvenster Bestanden selecteert. Als het deelvenster Extern actief is, worden de geselecteerde externe of testserverbestanden naar de lokale site gekopieerd; als het deelvenster Lokaal actief is, kopieert Dreamweaver de externe of testserverversie van de geselecteerde lokale bestanden naar de lokale site.

Opmerking:

De bestanden die Dreamweaver kopieert, zijn de bestanden die u in het actieve deelvenster van het deelvenster Bestanden selecteert. Als het deelvenster Lokaal actief is, worden de geselecteerde lokale bestanden naar de externe site of testserver gekopieerd; als het deelvenster Extern actief is, kopieert Dreamweaver de lokale versies van de geselecteerde externe serverbestanden naar de externe site.

Als u een bestand dat nog niet bestaat, op de externe site plaatst en In- en uitchecken van bestanden inschakelen is ingeschakeld, wordt het bestand aan de externe site toegevoegd als 'uitgecheckt'. Klik op de knop Bestanden inchecken als u een bestand wilt toevoegen zonder de status uitgecheckt.

Bestanden en mappen weergeven

U kunt bestanden en mappen weergeven in het deelvenster Bestanden, ongeacht of ze aan een Dreamweaver-site zijn gekoppeld of niet. Als u sites, bestanden of mappen bekijkt in het deelvenster Bestanden, kunt u het formaat van de weergavezone wijzigen en kunt u, voor Dreamweaver-sites, het deelvenster Bestanden uit- of samenvouwen.

Voor Dreamweaver-sites kunt u het deelvenster Bestanden ook aanpassen door de weergave te wijzigen, uw lokale of externe site, die standaard in het samengevouwen deelvenster wordt weergegeven. Of u kunt tussen de inhoudsweergaven overschakelen in het uitgevouwen deelvenster Bestanden met de optie Altijd tonen.

Bestanden zoeken in het deelvenster Bestanden (Mac OS, alleen Creative Cloud-gebruikers)

U kunt de functie Live zoeken gebruiken om bestanden te zoeken op basis van de bestandsnaam of de aanwezige tekst in bestanden. De geselecteerde site in het deelvenster Bestanden wordt gebruikt voor de zoekopdracht. Als er geen site is geselecteerd in het deelvenster, wordt de zoekoptie niet weergegeven. Zie Bestanden zoeken op bestandsnaam of inhoud voor meer informatie.

De grootte van het weergavegebied in het uitgevouwen deelvenster Bestanden wijzigen

Versleep in het deelvenster Bestanden (Venster > Bestanden), met het deelvenster uitgevouwen, de balk tussen de twee weergaven om het weergavegebied van het rechter- of linkerdeelvenster te vergroten of te verkleinen.

De siteweergave in het deelvenster Bestanden wijzigen (alleen voor Dreamweaver-sites)

U kunt het deelvenster Bestanden gebruiken om bestanden te bekijken uit de lokale hoofdmap van de site, externe server of testserver.

Selecteer in het samengevouwen deelvenster Bestanden (Venster > Bestanden) de optie Lokale weergave, Externe server of Testserver in het pop-upmenu Siteweergave.

Lokale weergave staat standaard in het menu Siteweergave.

Bestanden bekijken in de lokale hoofdmap van de site, externe servers en testservers
Bestanden bekijken in de lokale hoofdmap van de site, externe servers en testservers

Bestanden weergeven buiten een Dreamweaver-site

Met het pop-upmenu Site kunt u op uw computer bladeren op vergelijkbare wijze als met Windows Verkenner (Windows) of de Finder (Macintosh).

Werken met bestanden in de FTP-weergave

U kunt bestanden openen of de naam ervan wijzigen, bestanden toevoegen, verplaatsen of verwijderen, of het deelvenster Bestanden vernieuwen nadat u wijzigingen hebt aangebracht.

Voor Dreamweaver-sites kunt u ook bepalen welke bestanden (op de lokale of externe site) werden bijgewerkt sinds de laatste keer ze werden overgebracht.

Een bestand openen

  1. Selecteer in het deelvenster Bestanden (Venster > Bestanden) een site, server of station in het pop-upmenu (waarin de huidige site of server of het huidige station wordt weergegeven).
  2. Ga naar het bestand dat u wilt openen.
  3. Voer een van de volgende handelingen uit:
    • Dubbelklik op het pictogram van het bestand.

    • Klik met de rechtermuisknop (Windows) of klik terwijl u Control ingedrukt houdt (Macintosh) op het pictogram van het bestand en selecteer Openen.

      Dreamweaver opent het bestand in het documentvenster.

Een bestand of map maken

  1. Selecteer in het deelvenster Bestanden (Venster > Bestanden) een bestand of map.

    Dreamweaver maakt een nieuw bestand of een nieuwe map aan in de geselecteerde map, of in dezelfde map waarin het geselecteerde bestand staat.

  2. Klik met de rechtermuisknop (Windows) of terwijl u Control ingedrukt houdt (Macintosh), en selecteer vervolgens Nieuw Bestand of Nieuwe map.
  3. Voer een naam in voor het nieuwe bestand of de nieuwe map.
  4. Druk op Enter (Windows) of Return (Macintosh).

Een bestand of map verwijderen

  1. Selecteer in het deelvenster Bestanden (Venster > Bestanden) het bestand dat of de map die u wilt verwijderen.
  2. Klik met de rechtermuisknop (Windows) of klik terwijl u Control ingedrukt houdt (Macintosh) en selecteer Bewerken > Verwijderen.

De naam van een bestand of map wijzigen

  1. Selecteer in het deelvenster Bestanden (Venster > Bestanden) het bestand of de map waarvan u de naam wilt wijzigen.
  2. Voer een van de volgende handelingen uit om de naam van het bestand of de map te activeren:
    • Klik op de bestandsnaam, wacht even en klik nogmaals.

    • Klik met de rechtermuisknop (Windows) of klik terwijl u Control ingedrukt houdt (Macintosh) op het pictogram van het bestand en selecteer Bewerken > Naam wijzigen.

  3. Overschrijf de bestaande naam met de nieuwe naam.
  4. Druk op Enter (Windows) of Return (Macintosh).

Een bestand of map verplaatsen

  1. Selecteer in het deelvenster Bestanden (Venster > Bestanden) het bestand dat of de map die u wilt verplaatsen.
  2. Voer een van de volgende handelingen uit:
    • Kopieer het bestand of de map en plak het/ze op de nieuwe locatie.

    • Sleep het bestand of de nam naar de nieuwe locatie.

  3. Vernieuw het deelvenster Bestanden om het bestand of de map op de nieuwe locatie weer te geven.

Het deelvenster Bestanden vernieuwen

Om de weergave in het deelvenster Bestanden te vernieuwen, voert u een van de volgende handelingen uit:

  • Klik met de rechtermuisknop (Windows) of klik terwijl u Control ingedrukt houdt (Macintosh) op een bestand of map en selecteer Vernieuwen.
  • (Alleen Dreamweaver-sites) Klik op de knop Vernieuwen in de werkbalk van het deelvenster Bestanden (met deze optie worden beide vensters vernieuwd).

Opmerking:

Dreamweaver vernieuwt het deelvenster Bestanden als u wijzigingen aanbrengt in een andere toepassing; keer vervolgens terug naar Dreamweaver.

Zoeken naar bestanden op uw Dreamweaver-site

In Dreamweaver kunt u heel gemakkelijk zoeken naar geselecteerde, geopende, uitgecheckte of recentelijk gewijzigde bestanden op uw site. U kunt ook zoeken naar bestanden die nieuwer zijn op uw lokale of externe site.

Zoeken naar een geopend bestand op uw site

  1. Open het bestand in het documentvenster.
  2. Selecteer Site > Zoeken op de site.

    Dreamweaver selecteert het bestand in het deelvenster Bestanden.

    Opmerking:

    Als het geopende bestand in het documentvenster geen deel uitmaakt van de huidige site in het deelvenster Bestanden, probeert Dreamweaver vast te stellen tot welke van uw Dreamweaver-sites het bestand behoort. Als het huidige bestand tot slechts één lokale site behoort, wordt deze site door Dreamweaver in het deelvenster Bestanden geopend en wordt het bestand vervolgens gemarkeerd.

Uitgecheckte bestanden op een Dreamweaver-site zoeken en selecteren

Klik in de rechterbovenhoek van het samengevouwen deelvenster Bestanden (Venster > Bestanden) op het menu Opties en selecteer vervolgens Bewerken > Uitgecheckte bestanden selecteren.

Dreamweaver selecteert het bestand in het deelvenster Bestanden.

Zoeken naar een geselecteerd bestand op uw lokale of externe site

  1. Selecteer het bestand in de weergave Extern of Lokaal van het deelvenster Bestanden (Venster > Bestanden).
  2. Klik met de rechtermuisknop (Windows) of klik terwijl u Control ingedrukt houdt (Macintosh) en selecteer Zoeken op lokale site of Zoeken op externe server (afhankelijk van de plaats waar u het bestand hebt geselecteerd).

    Dreamweaver selecteert het bestand in het deelvenster Bestanden.

Bestanden zoeken en selecteren die nieuwer zijn op de lokale site dan op de externe site

Klik in de rechterbovenhoek van het samengevouwen deelvenster Bestanden (Venster > Bestanden) op het menu Opties en selecteer Bewerken > Nieuwere lokale selecteren.

Dreamweaver selecteert bestanden in het deelvenster Bestanden.

Bestanden zoeken en selecteren die nieuwer zijn op de externe site dan op de lokale site

Klik in de rechterbovenhoek van het samengevouwen deelvenster Bestanden (Venster > Bestanden) op het menu Opties en selecteer Bewerken > Nieuwere externe selecteren.

Dreamweaver selecteert het bestand in het deelvenster Bestanden.

Zoeken naar recentelijk gewijzigde bestanden op uw site

  1. Klik in de rechterbovenhoek van het samengevouwen deelvenster Bestanden (Venster > Bestanden) op het menu Opties en selecteer Bewerken > Onlangs gewijzigd selecteren.
  2. Voer een van de volgende handelingen uit om de zoekdatums voor het rapport aan te geven:
    • Als u in het rapport alle bestanden wilt opnemen die de laatste paar dagen zijn gewijzigd, selecteert u 'Bestanden gemaakt of gewijzigd in de laatste' en voert u in het tekstvak een getal in.

    • Als u in het rapport alle bestanden wilt opnemen die in een specifieke tijdsperiode zijn gewijzigd, klikt u op het keuzerondje 'Bestanden gemaakt of gewijzigd tussen' en geeft u een datumbereik op.

    Onlangs gewijzigde bestanden zoeken
    Onlangs gewijzigde bestanden zoeken

  3. U kunt desgewenst in het tekstvak Gewijzigd door een gebruikersnaam invoeren om uw zoekopdracht te beperken tot die bestanden die zijn gewijzigd door een specifieke gebruiker binnen het datumbereik dat u hebt opgegeven.

    Opmerking:

    Deze optie is alleen beschikbaar voor rapporten over Contribute-sites.

  4. Selecteer een keuzerondje om, indien nodig, aan te geven waar u bestanden die in het rapport worden vermeld, wilt weergeven:

    Lokale computer

    als de site statische pagina's bevat.

    Testserver

    als de site dynamische pagina's bevat.

    Andere locatie

    als u een pad in het tekstvak wilt invoeren.

    Opmerking:

    Voor deze optie wordt aangenomen dat u een testserver hebt gedefinieerd in het dialoogvenster Sitedefinitie. Als u geen testserver hebt gedefinieerd en een URL-voorvoegsel hebt ingevoerd voor deze server, of als u het rapport voor meer dan één site uitvoert, is deze optie niet beschikbaar.

  5. Klik op OK om uw instellingen op te slaan.

    Dreamweaver markeert de bestanden die zijn gewijzigd binnen de geselecteerde tijdsperiode, in het deelvenster Bestanden.

Ongebruikte bestanden opsporen en verwijderen

U kunt zoeken naar bestanden op uw site die niet meer worden gebruikt door andere bestanden, en deze bestanden vervolgens verwijderen.

  1. Selecteer Site > Site-opties > Koppelingen op de hele site controleren.

    Dreamweaver controleert alle koppelingen op de site en geeft de verbroken koppelingen weer in het deelvenster Resultaten.

  2. Selecteer Zwevende bestanden in het menu van het deelvenster Koppelingencontrole.
    Zwevende bestanden - bestanden zonder inkomende koppelingen bekijken
    Zwevende bestanden - bestanden zonder inkomende koppelingen bekijken

    Alle bestanden zonder inkomende koppelingen worden in Dreamweaver weergegeven. Dit betekent dat er geen bestanden op uw site aanwezig zijn met koppelingen naar deze bestanden.

  3. Selecteer de bestanden die u wilt verwijderen en druk op Delete.

    Opmerking:

    Hoewel er geen enkel ander bestand op de site een koppeling bevat naar deze bestanden, kunnen bepaalde weergegeven bestanden een koppeling bevatten naar andere bestanden. Wees daarom voorzichtig bij het verwijderen van bestanden.

Toegang krijgen tot sites, een server en lokale stations

U kunt de bestanden en mappen op uw Dreamweaver-sites, en ook bestanden en mappen die geen deel uitmaken van een Dreamweaver-site, openen, wijzigen en opslaan. U kunt niet alleen toegang krijgen tot Drive-sites, maar ook tot een server, een lokaal station of uw bureaublad.

Voordat u toegang kunt krijgen tot een externe server, moet u Dreamweaver zodanig instellen dat het programma met deze server kan samenwerken.

Opmerking:

U kunt bestanden het beste beheren door een Dreamweaver-site te maken. Voor informatie over de voordelen van het maken van een site en informatie over hoe u een site maakt, zie Over Dreamweaver-sites.

Een bestaande Dreamweaver-site openen

Selecteer in het deelvenster Bestanden (Venster > Bestanden) een site in het menu (waarin de huidige site of server of het huidige station wordt weergegeven).
Een bestaande Dreamweaver-site openen
Een bestaande Dreamweaver-site openen

Een map openen op een externe FTP- of RDS-server

  1. Selecteer in het deelvenster Bestanden (Venster > Bestanden) een servernaam in het menu (waarin de huidige site of server of het huidige station wordt weergegeven).

    Opmerking:

    Er worden servernamen weergegeven van servers waarvoor u Dreamweaver zodanig hebt geconfigureerd dat het programma daarmee kan samenwerken.

  2. U kunt nu bestanden op de normale manier openen en bewerken.

Een lokaal station op uw computer openen

  1. Selecteer in het deelvenster Bestanden (Venster > Bestanden) een desktopcomputer, lokaal station of cd-romstation in het menu (waarin de huidige site of server of het huidige station wordt weergegeven).
  2. Ga naar een bestand en voer een van de volgende handelingen uit:
    • Bestanden openen in Dreamweaver of een andere toepassing
    • Bestandsnamen wijzigen
    • Bestanden kopiëren
    • Bestanden verwijderen
    • Bestanden slepen
      • Als u een bestand sleept van de ene Dreamweaver-site naar een andere site of naar een map die geen deel uitmaakt van een Dreamweaver-site, wordt dit bestand door Dreamweaver gekopieerd naar de locatie waar u het bestand neerzet.
      • Als u een bestand sleept binnen een en dezelfde Dreamweaver-site, wordt het bestand door Dreamweaver verplaatst naar de locatie waar u het bestand neerzet.
      • Als u een bestand sleept dat geen deel uitmaakt van een Dreamweaver-site, naar een map die geen deel uitmaakt van een Dreamweaver-site, wordt het bestand door Dreamweaver verplaatst naar de locatie waar u het bestand neerzet.

    Opmerking:

    Als u een bestand wilt verplaatsen dat standaard door Dreamweaver wordt gekopieerd, houdt u de Shift-toets (Windows) of de Command-toets (Macintosh) ingedrukt terwijl u sleept. Als u een bestand wilt kopiëren dat standaard door Dreamweaver wordt verplaatst, houdt u de Control-toets (Windows) of de Option-toets (Macintosh) ingedrukt terwijl u sleept.

Gegevens van bestanden en mappen die in het deelvenster Bestanden worden weergegeven, aanpassen

Als u een Dreamweaver-site in het deelvenster Bestanden weergeeft, wordt standaard alleen de structuur van bestanden en mappen weergegeven. U kunt echter de weergave van het deelvenster Bestanden aanpassen om de volgende gegevens weer te geven:

  • Notities
  • Grootte
  • Type
  • De datum waarop een bestand voor het laatst is gewijzigd
  • Gegevens uitchecken
Om deze kolommen in de weergave van het deelvenster Bestanden op te nemen, klikt u met de rechtermuisknop op de werkbalk en selecteert u de opties die u wilt zien.
Het weergeven en verbergen van bestand- en mapgegevens in het deelvenster Bestanden
Het weergeven en verbergen van bestand- en mapgegevens in het deelvenster Bestanden

U kunt wat extra kolomaanpassing doen met het dialoogvenster Sites beheren > Geavanceerde instellingen > Kolommen bestandsweergave:

De kolommen van de bestandsweergave aanpassen met het dialoogvenster Sites beheren > Geavanceerde instellingen > Kolommen bestandsweergave
De kolommen van de bestandsweergave aanpassen met het dialoogvenster Sites beheren > Geavanceerde instellingen > Kolommen bestandsweergave

De volgorde van kolommen wijzigen

In het deelvenster Sites beheren > Geavanceerde instellingen > Kolommen bestandsweergave, selecteert u een kolomnaam en klikt u vervolgens op de pijl omhoog of omlaag om de positie van de geselecteerde kolom te wijzigen.

Opmerking:

U kunt de positie van elke kolom wijzigen, behalve van de kolom Naam, die altijd de eerste kolom is.

Kolomgegevens toevoegen, verwijderen of wijzigen

  1. Selecteer Site > Sites beheren.
  2. Selecteer een site en klik op Bewerken.
  3. Vouw de categorie Geavanceerde instellingen uit en selecteer de categorie Kolommen Bestandsweergave.
  4. Selecteer een kolom en klik op de plusknop (+) om een kolom toe te voegen.

  5. Voer in het tekstvak Kolomnaam een naam voor de kolom in.
    Het toevoegen van aangepaste kolommen
    Het toevoegen van aangepaste kolommen

  6. Selecteer een waarde in het menu Koppelen aan ontwerpnotities of typ uw eigen waarde.

    Opmerking:

    U moet aan een nieuwe kolom een ontwerpnotitie koppelen om te zorgen dat er gegevens in het deelvenster Bestanden kunnen worden weergegeven.

  7. Selecteer een uitlijning om te bepalen hoe de tekst binnen de kolom moet worden uitgelijnd.
  8. Schakel de optie Tonen in of uit om de kolom weer te geven of te verbergen.
  9. Selecteer Delen met alle gebruikers van deze site om de kolom te delen met alle gebruikers die met de externe site verbonden zijn.

U verwijdert een kolom door dit te selecteren en op het minteken (-) te klikken. 

Opmerking:

De kolom wordt onmiddellijk en zonder een vraag om bevestiging verwijderd, dus bedenk goed of u de kolom wilt verwijderen voordat u op de minknop (–) klikt.

Kolommen sorteren in het deelvenster Bestanden

Klik in het deelvenster Bestanden op de koptekst van de kolom die u wilt sorteren.

Opmerking:

Klik nogmaals op de koptekst om de volgorde waarin Dreamweaver de items in de kolom weergeeft (oplopend of aflopend), om te draaien.

Automatisch herstellen van bestanden

Als Dreamweaver onverwacht vanwege systeemfouten, stroomuitvallen of andere problemen stopt, sluit dan kunt u alle niet-opgeslagen wijzigingen herstellen die zijn aangebracht in de bestanden waar u aan werkte.

De auto-herstelfunctie maakt automatisch een back-up van alle niet-opgeslagen bestanden in Dreamweaver. Als een crash optreedt, wordt het volgende dialoogvenster weergegeven tijdens volgende starts van Dreamweaver.

Opmerking:

U moet uw bestand voor Dreamweaver ten minste één keer hebben opgeslagen om het te kunnen herstellen.

Automatisch herstellen in Dreamweaver
Automatisch herstellen in Dreamweaver

Wanneer Dreamweaver crasht en u dit weer opent, kunt u de laatste wijzigingen in een bestand herstellen of verwijderen:

  • Herstellen: selecteer deze optie om de automatisch opgeslagen versie van uw bestand te openen
  • Verwijderen: selecteer deze optie om de laatst opgeslagen versie van uw bestand te openen

Opmerking:

Automatisch opslaan in Dreamweaver gebeurt ongeveer om de vijf seconden (afhankelijk van het besturingssysteem).

Werken met het deelvenster Bestanden in de Git-weergave

In de Git-weergave van het deelvenster Bestanden kunt u verbinding maken met Git-opslagplaatsen en bestanden beheren met behulp van Git. Het deelvenster Bestanden werkt als een interface waarmee u verschillende bewerkingen kunt uitvoeren, zoals bestanden doorvoeren, voorbereiden, terugdraaien, toevoegen aan gitignore enzovoort.

U kunt de Git-Weergave gebruiken om de volgende handelingen uit te voeren:

  • De bestanden die aan een site zijn gekoppeld, bekijken in Git-opslagplaatsen
  • Bestanden en mappen synchroniseren tussen uw lokale opslagplaats en Git
  • De niet-gevolgde, voorbereide en doorgevoerde bestanden weergeven
  • Toegang krijgen tot de Git-terminal

Vanuit dit deelvenster kunt u ook een Git-opslagplaats initialiseren als dat nog niet is gebeurd. Wanneer u een site maakt in Dreamweaver, kunt u een Git-opslagplaats koppelen aan uw site. Als u dit nog niet hebt gedaan toen u de site maakte, kunt u een Git-opslagplaats initialiseren via het deelvenster Bestanden.

Als u een opslagplaats wilt initialiseren, klikt u op Git initialiseren in het deelvenster Bestanden. De bestanden die aan uw site zijn gekoppeld, zijn direct zichtbaar in de Git-weergave, samen met hun status.

Git-opslagplaatsen initialiseren via het deelvenster Bestanden
Git-opslagplaatsen initialiseren via het deelvenster Bestanden

De status van bestanden bekijken

U kunt de status van de bestanden die aan een Git-opslagplaats zijn gekoppeld, bekijken in het deelvenster Bestanden. Wanneer u een Git-opslagplaats initialiseert, worden de bestanden groen weergegeven. Dit betekent dat de bestanden niet worden gevolgd en nog niet in Git bestaan.

Wanneer u een bestand doorvoert, wordt het bestand wit weergegeven in het deelvenster Bestanden. Dit betekent dat het bestand is doorgevoerd in de Git-opslagplaats die u hebt gekozen. 

Wanneer u een bestand bewerkt en opslaat nadat het is doorgevoerd, verandert de kleur van het bestand in geel in het deelvenster Bestanden. Dit geeft aan dat de bestanden in de lokale opslagplaats en in de Git-opslagplaats niet synchroon zijn.

Voor meer informatie over de workflow voor versiebeheer in Git raadpleegt u Git gebruiken voor versiebeheer.

Vertakkingen maken en beheren

U kunt vertakkingen lokaal maken en beheren met het deelvenster Bestanden. Als u een vertakking wilt maken, selecteert u de vervolgkeuzelijst boven in het deelvenster. Klik op Vertakkingen beheren en klik op het plusteken (+) in het dialoogvenster Vertakkingen beheren.

U kunt de oorspronkelijke vertakking kiezen en een nieuwe vertakking maken. U kunt ook een vertakking verwijderen en een vertakking samenvoegen met een andere vertakking.

Voor meer informatie over het beheren van lokale vertakkingen met het deelvenster Bestanden raadpleegt u Vertakkingen maken en beheren.

Git-basisbewerkingen uitvoeren

U kunt niet alleen vertakkingen initialiseren en beheren, maar ook diverse Git-bewerkingen uitvoeren via het deelvenster Bestanden. Selecteer een bestand in het deelvenster Bestanden, klik erop met de rechtermuisknop en voer een van de volgende handelingen uit:

  • Klik op Toevoegen aan .gitignore als u het geselecteerde bestand wilt toevoegen aan de map gitignore. Deze bestanden worden niet verwerkt door Git en er kunnen geen bewerkingen worden uitgevoerd met deze bestanden.
  • Klik op Verwijderen uit .gitignore als u een bestand wilt verwijderen uit de map gitignore.
  • Klik op Faseren als u het geselecteerde bestand wilt voorbereiden. Voorbereiden komt één stap na het doorvoeren van een bestand in Git.
  • Klik op Fasering opheffen als u de voorbereiding van een bestand ongedaan wilt maken.
  • Klik op Alles faseren om alle bestanden in de opslagplaats voor te bereiden.
  • Klik op Alle faseringen opheffen om de voorbereiding van alle bestanden in de opslagplaats ongedaan te maken.
  • Klik op Diff om de wijzigingen in het bestand tussen de vorige doorvoerbewerking en de huidige versie weer te geven.
  • Klik op Bestandsgeschiedenis om de geschiedenis van wijzigingen en doorvoerbewerkingen van het geselecteerde bestand weer te geven.
  • Klik op Bestand terugdraaien om alle aangebrachte wijzigingen in het bestand te verwijderen en de vorige doorgevoerde versie te herstellen.
  • Klik op Alle faseringsitems doorvoeren om de bestanden die u hebt voorbereid door te voeren in deze opslagplaats.
Git-handelingen uitvoeren in het deelvenster Bestanden
Git-handelingen uitvoeren in het deelvenster Bestanden

Voor informatie over elk van deze handelingen en over Git in Dreamweaver raadpleegt u Git gebruiken in Dreamweaver.

Dit werk is gelicentieerd onder de Creative Commons Naamsvermelding/Niet-commercieel/Gelijk delen 3.0 Unported-licentie  De voorwaarden van Creative Commons zijn niet van toepassing op Twitter™- en Facebook-berichten.

Juridische kennisgevingen   |   Online privacybeleid