将文本添加到文档中

通过键入、粘贴或从文字处理应用程序置入文本,可向文档中添加文本。如果文字处理应用程序支持拖放功能,还可将文本拖入 InDesign 框架。对于大的文本块,“置入”命令是向文档中添加文本的有效通用方法。InDesign 支持多种文字处理、电子表格和文本文件格式。

置入或粘贴文本时,不需要先创建文本框架;InDesign 会自动为您创建一个文本框架。

置入文本时,可选择“显示导入选项”来决定是否保持导入文本的样式和格式。粘贴文本前,可选择“剪贴板处理首选项”下的“所有信息”或“纯文本”来决定粘贴文本是否包括色板和样式等其他信息。

注意:

如果导入到文档中的文本包括用于突出显示的粉红色、绿色或其他颜色,则可能是因为启用了一个或多个排版首选项。打开“首选项”对话框中的“排版”部分,并注意“突出显示”下启用了哪些选项。例如,如果粘贴文本的格式中包括不可用的字体,则该文本将以粉红色突出显示。

在文档中键入文本

  1. 要在文本框架中置入插入点,执行以下操作之一:
    • 使用“文字工具” ,拖动以创建一个新文本框架,或者单击现有文本框架。

    • 使用“选择工具”在现有文本框架内双击。将自动选择“文字工具”。

  2. 开始键入。

如果已经在主页上创建了文本框架,则在文档页面上的框架内单击时按住 Ctrl+Shift (Windows) 或 Command+Shift (Mac OS)。这将在文档页面上创建主页框架的一个副本。然后便可使用“文字工具”向所选框架中添加文本。

使用直接输入键入亚洲文字

  1. 选择“编辑”>“首选项”>“高级文字”(Windows) 或“InDesign”>“首选项”>“高级文字”(Mac OS)。
  2. 选择“直接输入非拉丁文字”,然后单击“确定”。

您可以使用系统输入法(如果可用)添加 2 个字节和 4 个字节的字符。此输入法尤其适用于输入亚洲字符。

插入占位符文本

InDesign 可添加稍后可用真实文本轻松替换的占位符文本。添加占位符文本,可使您对文档的设计有一个更完整的认识。

  1. 使用“选择工具”选择一个或多个文本框架,或使用“文字工具”单击文本框架。
  2. 选择“文字”>“用假字填充”。

如果将占位符文本添加到与其他框架串接的框架中,那么占位符文本将添加到第一个文本框架的开始(如果所有框架都为空)或现有文本的末尾(如果串接的框架中已包含一些文本),直到最后一个串接框架的末尾。

要删除或替换占位符文本,请双击串接内的任一框架,选择“编辑”>“全选”,然后删除该文本。

注意:

要更改用作占位符文本的文本,请用要使用的文本创建一个文本文件,将其命名为 Placeholder.txt,并存储在应用程序文件夹中。

粘贴文本

如果将文本粘贴到 InDesign 中时,插入点不在文本框架内,则会创建新的纯文本框架。如果插入点位于文本框架内,则会将文本粘贴到该框架中。如果粘贴时已经选中了文本,则粘贴的文本将覆盖选中文本。

从另一个应用程序粘贴文本

  1. 要保留格式以及样式和索引标志符等信息,请打开“首选项”对话框的“剪贴板处理”部分,并选择“粘贴”下的“所有信息”。要在粘贴时删除这些项目和其他格式,请选择“仅文本”。
  2. 剪切或复制其他应用程序或 InDesign 文档中的文本。
  3. 如果您愿意,可以选择文本或在文本框架中单击。否则,文本将被粘贴到其自身的新框架中。
  4. 执行以下操作之一:
    • 选择“编辑”>“粘贴”。如果粘贴的文本未包括所有格式,则可能需要为 RTF 文档更改“导入选项”对话框中的设置。

    • 选择“编辑”>“粘贴时不包含格式”。(从其他应用程序粘贴文本时,如果选择了“剪贴板处理首选项”中的“纯文本”,那么“粘贴时不包含格式”选项将变暗。)

注意:

也可从其他应用程序拖移文本并将其放到 InDesign 文档中,或直接从 Windows 资源管理器或 Mac OS Finder 中将文本文件或文字处理程序文件插入 InDesign 文档中。该文本将被添加到新框架中。按住 Shift 键并拖动鼠标可删除格式。在“首选项”对话框的“剪贴板处理”部分中选择的选项将决定是否保留索引标志符和色板等信息。

粘贴文本时自动调整间距

粘贴文本时,会根据上下文自动添加或删除空格。例如,如果剪切一个单词然后将其粘贴到两个单词之间,那么将确保在该单词之前和之后都留有空格。如果将该单词粘贴到句子末尾,则不会在句点之前添加空格。

注意:

此功能主要用于处理罗马文本。而且,仅当在“字符”面板中将要粘贴的罗马文本设置为罗马语言时,才能使用此功能。

  1. 选择“编辑”>“首选项”>“文字”(Windows) 或“InDesign”>“首选项”>“文字”(Mac OS)。
  2. 选择“剪切和粘贴单词时自动调整间距”,然后单击“确定”。

拖放文本

可在“文章编辑器”或“版面视图”中使用鼠标拖放文本。甚至可以将文本从“文章编辑器”拖动到版面窗口(或反之),或拖动到“查找/更改”等对话框中。从锁定或登记的文章中拖动文本将会复制文本,而不移动文本。还可以在拖放文本时复制文本或创建新框架。

Jeff Witchel 在使用 InDesign 拖放文本中提供了一份有关拖放操作的视频教程。

  1. 要启用拖放功能,请选择“编辑”>“首选项”>“文字”(Windows) 或“InDesign”>“首选项”>“文字”(Mac OS),接下来选择“在版面视图中启用”、“在文章编辑器中启用”(InDesign) 或者“在条样/文章视图中启用”(InCopy),然后单击“确定”。
  2. 选择要移动或复制的文本。
  3. 将指针置于所选文本上,直到显示拖放图标 ,然后拖动该文本。

    拖动时,所选文本保留原位,但将显示一条竖线,以指示释放鼠标按钮时该文本将出现的位置。竖线会出现在将鼠标拖到其上的任一文本框架中。

  4. 执行以下操作之一:
    • 要将文本拖动到新位置,请将竖线置于希望文本出现的地方,然后释放鼠标按钮。

    • 要将文本拖动到新框架中,请在开始拖动后按住 Ctrl 键 (Windows) 或 Command 键 (Mac OS),然后先释放鼠标按钮,再释放该键。

    • 要在拖动文本时不包含格式,请在开始拖动后按住 Shift 键,然后先释放鼠标按钮,再释放该键。

    • 要复制文本,请在开始拖动后按住 Alt 键 (Windows) 或 Option 键 (Mac OS),然后先释放鼠标按钮,再释放该键。

注意:

也可以使用这些修改键的组合。例如,要将无格式文本复制到新框架中,请在开始拖动之后按住 Alt+Shift+Ctrl (Windows) 或 Option+Shift+Command (Mac OS)。

如果拖动文本的间距不正确,请选择“文字首选项”中的“自动调整间距”选项。

置入(导入)文本

置入文本或电子表格文件时,可指定相应选项以确定设置导入文本格式的方式。

  1. (可选)要创建指向将置入的文件的链接,请在“首选项”对话框中单击“文件处理”,然后选择“置入文本和电子表格文件时创建链接”。

    选择该选项会创建指向置入文件的链接。可以使用“链接”面板,以更新、重新链接或删除指向文本文件的链接。但如果在 InDesign 中设置链接文本的格式,则在更新链接时可能不会保留格式。如果不选择该选项,则会嵌入(而不是链接)导入文本和电子表格文件。

  2. 执行以下操作之一:
    • 要为置入的文本创建新框架,请确保未出现任何插入点且未选择任何文本或框架。

    • 要将文本添加到框架,请使用“文字工具” 选择文本或置入插入点。

    • 要替换现有框架的内容,请使用选择工具来选择框架。如果该框架是串接的,会出现载入的文本光标。

    注意:

    如果使用这种方法意外地替换了文本文件或图形,请选择“编辑”>“还原替换”,然后单击或拖动以创建一个文本框架。

  3. 选择“文件”>“置入”。
  4. 如果希望导入的文件能替换所选框架的内容、替换所选文本或添加到文本框架的插入点,则选择“替换所选项目”。取消选择该选项可将导入的文件排列到新框架中。
  5. 选择“显示导入选项”,然后双击要导入的文件。
  6. 设置导入选项,然后单击“确定”。

如果尚未指定现有框架来接收文本,那么指针将变成载入的文本图标,准备在单击或拖移的任意位置排列文本。

注意:

根据“文章”面板中的设置,置入的文本框架可以转换为纯文本框架或框架网格。可以选择“文字”>“排版方向”>“水平”或“垂直”,以便确定框架的排版方向。文本置入框架网格中之后,在“网格”工具中设置的文档默认值将会应用于该框架网格。根据需要,应用网格格式。

如果收到警告,提示未找到请求的过滤器,则表示可能正尝试从其他文字处理应用程序或从早期版本的 Microsoft® Word(如 Word 6)中置入文件。在文件的原应用程序中打开文件并将其存储为 RTF 格式,可保留该应用程序大多数格式。

如果所导入 Microsoft Excel 文档的单元格中显示红点,请调整单元格大小或文本属性,使溢流内容变为可见。还可以将文件置入为无格式制表符分隔文本,然后将制表符分隔文本转换为表。

关于导入过滤器

InDesign 从文本文件导入大多数字符和段落格式属性,却忽略大多数页面布局信息,如边距和分栏设置(可在 InDesign 中设置它们)。注意下列事项:

  • 一般情况下,InDesign 导入文字处理应用程序中指定的所有格式信息,但 InDesign 中不支持的文字处理功能信息除外。

  • InDesign 可将导入的样式添加到其自己的文档样式列表中。导入的样式旁将出现一个磁盘图标 。(请参阅将 Word 样式转换为 InDesign 样式。)

  • 在“置入”对话框中选择“显示导入选项”时或导入 Excel 文件时,将出现导入选项。如果取消选择“显示导入选项”,则 InDesign 将使用最后一次用于相似文档类型的导入选项。所设置的选项一直有效,直至更改它们。

  • 如果 InDesign 不能找到按照文件类型或文件扩展名识别文件的过滤器,则出现一条警告消息。为在 Windows 中取得最佳效果,请对要导入的文件类型使用标准扩展名(如 .doc.、.docx、txt、.rtf、.xls 或 .xlsx)。可能需要在文件的原应用程序中打开文件,并将其存储为其他格式,如 RTF 或纯文本。

有关导入过滤器的更多信息,请参阅过滤器自述文件 (PDF),网址为:www.adobe.com/go/lr_indesignfilters_cs5_cn

Microsoft Word 和 RTF 导入选项

如果在置入 Word 或 RTF 文件时选择“显示导入选项”,则可以从下列选项中进行选择:

目录文本

将目录作为文本的一部分导入到文章中。这些条目作为纯文本导入。

索引文本

将索引作为文本的一部分导入到文章中。这些条目作为纯文本导入。

脚注

导入 Word 脚注。脚注和引用将保留,但会根据文档的脚注设置重新编号。如果 Word 脚注没有正确导入,请尝试将 Word 文档另存成 RTF 格式,然后导入该 RTF 文件。

尾注

将尾注作为文本的一部分导入到文章的末尾。

使用弯引号

确保导入的文本包含左右弯引号 (“ ”) 和弯单引号(’),而不包含直双引号 (" ") 和直单引号 (')。

移去文本和表的样式和格式

从导入的文本(包括表中的文本)移去格式,如字体、文字颜色和文字样式。如果选中该选项,则不导入段落样式和随文图。

保留页面优先选项

选择删除文本和表的样式和格式时,可选择“保留页面优先选项”以保持应用到段落某部分的字符格式,如粗体和斜体。取消选择该选项可删除所有格式。

转换表为

选择移去文本、表的样式和格式时,可将表转换为无格式表或无格式的制表符分隔的文本。

如果希望导入无格式文本和格式表,则导入无格式文本,然后将表从 Word 粘贴到 InDesign。

保留文本和表的样式和格式

在 InDesign 或 InCopy 文档中保留 Word 文档的格式。可使用“格式”部分中的其他选项来确定保留样式和格式的方式。

手动分页

确定 Word 文件中的分页在 InDesign 或 InCopy 中的格式设置方式。选择“保留分页符”可使用 Word 中用到的同一分页符,或者选择“转换为分栏符”或“不换行”。

导入随文图

在 InDesign 中保留 Word 文档的随文图。

导入未使用的样式

导入 Word 文档的所有样式,即使未应用于文本的样式也导入。

将项目符号和编号转换为文本

将项目符号和编号作为实际字符导入,保留段落的外观。但在编号列表中,不会在更改列表项目时自动更新编号。

修订

选择此选项会导致 Word 文档中的修订标记显示在 InDesign 文档中。在 InDesign 中,可以在文章编辑器中查看修订。

自动导入样式

将 Word 文档的样式导入到 InDesign 或 InCopy 文档中。如果“样式名称冲突”旁出现黄色警告三角形,则表明 Word 文档的一个或多个段落或字符样式与 InDesign 样式同名。

要确定解决这些样式名称冲突的解决方法,请从“段落样式冲突”和“字符样式冲突”菜单中选择一个选项。如果选择“使用 InDesign 样式定义”,导入的样式文本将基于 InDesign 样式来进行格式设置。如果选择“重新定义 InDesign 样式”,导入的样式文本将基于 Word 样式来进行格式设置,并且将会更改使用 Word 样式设置格式的现有 InDesign 文本。选择“自动重命名”可重命名导入的 Word 样式。例如,如果 InDesign 和 Word 都具有 Subheading 样式,则在选中“自动重命名”时,导入的 Word 样式将重命名为 Subheading_wrd_1。

注意:

InDesign 将转换段落和字符样式,但不会转换项目符号和编号列表样式。 

自定样式导入

通过此选项,可以使用“样式映射”对话框来选择对于导入文档中的每个 Word 样式,应使用哪个 InDesign 样式。

存储预设

存储当前的 Word 导入选项以便以后重复使用。指定导入选项,单击“存储预设”,键入预设的名称,并单击“确定”。下次导入 Word 样式时,可从“预设”菜单中选择创建的预设。如果希望所选的预设用作将来导入 Word 文档的默认值,请单击“设置为默认值”。

文本文件导入选项

如果在置入文本文件时选择“显示导入选项”,则可从下列选项进行选择:

字符集

指定创建文本文件时所使用的计算机语言字符集,如 ANSI、Unicode UTF8 或 Windows CE。默认选择是与 InDesign 或 InCopy 的默认语言和平台相对应的字符集。

指定创建文本文件时使用的计算机语言字符集,如 ANSI、Unicode UTF8、Shift JIS 或 Chinese Big 5。默认选择是与 InDesign 或 InCopy 的默认语言和平台相对应的字符集。

平台

指定文件是在 Windows 还是在 Mac OS 中创建文件。

将词典设置为

指定导入的文本使用的词典。

额外回车符

指定如何导入额外的段落回车符。选择“在每行结尾删除”或“在段落之间删除”。

替换

用制表符替换指定数目的空格。

使用弯引号

确保导入的文本包含左右弯引号 (“ ”) 和弯单引号(’),而不包含直双引号 (" ") 和直单引号 (')。

Microsoft Excel 导入选项

导入 Excel 文件时可从下列选项进行选择:

工作表

指定要导入的工作表。

视图

指定是导入任何存储的自定或个人视图,还是忽略这些视图。

单元格范围

指定单元格的范围,使用冒号 (:) 来指定范围(如 A1:G15)。如果工作表中存在指定的范围,则在“单元格范围”菜单中将显示这些名称。

导入视图中未存储的隐藏单元格

包括格式设置为 Excel 电子表格中的隐藏单元格的任何单元格。

指定电子表格信息在文档中显示的方式。

有格式的表

InDesign 将尝试保留 Excel 中使用的相同格式,尽管它或许不会保留每个单元格中文本的格式。如果采用链接的方式而并非使用嵌入方式来引用电子表格,则在更新链接时,将会覆盖所有应用于 InDesign 表中的格式。

无格式的表

导入表时,不会从电子表格中导入任何格式。如果选择此选项,可以将表样式应用于导入的表。如果文本格式是使用段落和字符样式来设置的,则即使更新指向电子表格的链接,该格式也会保留。

无格式制表符分隔文本

表导入为制表符分隔文本,然后可以在 InDesign 或 InCopy 中将其转换为表。

仅设置一次格式

InDesign 保留初次导入时 Excel 中使用的相同格式。如果电子表格是链接的而不是嵌入的,则在更新链接时会忽略链接表中对电子表格所作的格式更改。该选项在 InCopy 中不可用。

表样式

将指定的表样式应用于导入的文档。仅当选中“无格式的表”时该选项才可用。

单元格对齐方式

指定导入文档的单元格对齐方式。

包含随文图

在 InDesign 中保留 Excel 文档的随文图。

包含的小数位数

指定电子表格中数字的小数位数。

使用弯引号

确保导入的文本包含左右弯引号 (“ ”) 和弯单引号(’),而不包含直双引号 (" ") 和直单引号 (')。

标记文本导入选项

使用标记文本格式可导入(或导出)能够利用 InDesign 格式功能的文本文件。标记文本文件是一种文本文件,其中包含的信息描述了您希望 InDesign 应用的格式。正确的标记文本几乎能够描述 InDesign 文章中出现的任何格式,包括所有段落级属性、字符级属性和特殊字符。

有关指定标记的信息,请参阅 www.adobe.com/go/learn_id_taggedtext_cs5_cn(PDF) 上的“标记文本”。

导入标记文本文件并在“置入”对话框中选择“显示导入选项”时,可以使用下列选项:

使用弯引号

确保导入的文本包含左右弯引号 (“ ”) 和弯单引号(’),而不包含直双引号 (" ") 和直单引号 (')。

移去文本格式

从导入的文本删除格式,如字体、文字颜色和文字样式。

解决文本样式冲突的方法

标记文本文件的样式与 InDesign 文档的样式冲突时,指定要应用的字符或段落样式。选择“出版物定义”,可使用 InDesign 文档中该样式已有的定义。选择“标记文件定义”,可使用标记文本中定义的样式。

置入前显示错误标记列表

显示无法识别的标记列表。如果显示列表,可选择取消或继续导入。如果继续,则文件可能不会按预期显示。

将 Word 或 RTF 导入选项存储为预设

  1. 在置入 Word 或 RTF 文件时,确保选择“显示导入选项”,然后选择“打开”。
  2. 在“导入选项”对话框中,指定需要的设置。
  3. 单击“存储预设”,键入预设名称,然后单击“确定”。
  4. (可选)单击“设置为默认值”可在每次导入该文件类型的文件时使用预设。

然后,可以在每次打开 Word 或 RTF 文件时,从“导入选项”对话框的“预设”菜单中选择自定预设。

导入 Buzzword 文档

Buzzword 是一种基于 Web 的文本编辑器,利用它,用户可以在 Web 服务器上创建和存储文本文件。在 InDesign CS5 中,您可以导入和导出 Buzzword 文档中的文本。

导入 Buzzword 文档时,会创建一个基于 URL 的链接,指向服务器上的 Buzzword 文档。当 Buzzword 文档在 InDesign 之外更新时,您可以使用“链接”面板在 InDesign 中更新导入的版本。但是,该操作会删除您在 InDesign 中对 Buzzword 文本执行的所有更改。

注意:

Acrobat.com Buzzword 应用程序仅提供英语、法语和德语版本。

  1. 选择“文件”>“从 Buzzword 置入”。

  2. 如果您尚未登录 CS Live,请单击“登录”,然后指定您的电子邮件地址和密码,最后单击“登录”

    登录之后,“置入 Buzzword 文档”对话框就会显示您可以导入的 Buzzword 文档的列表。

  3. 选择一个或多个要导入的文档,或将 Buzzword 文档的 URL 粘贴至“粘贴 URL”字段中。

  4. 选择以下任意选项,然后单击“确定”。

    显示导入选项

    如果选中此选项,则在您置入文件前会出现“Buzzword 导入选项”对话框。

    替换选定项目

    选中此选项可以替换文档中当前选定的对象。

    链接至文档

    选中此选项可以在 Buzzword 文档和置入的文本之间创建一个链接。如果您建立了一个链接并更新了 Buzzword 文档,则“链接”面板会指示该文件已经过修改。如果您更新了链接,则 InDesign 中的文本也会进行更新。但是,您在 InDesign 中对文本所执行的格式更改将会丢失。

  5. 如果您选择了“显示导入选项”,请指定“Buzzword 导入选项”对话框中的设置。

    此对话框包含“RTF 导入选项”对话框中提供的大多数选项。请参阅 Microsoft Word 和 RTF 导入选项。目前,Buzzword 还没有样式功能,因此现在所有的样式选项都无效。

  6. 在载入的文本光标处,单击或拖动以创建文本框架。

默认情况下,在 InDesign 中置入的文本不会链接到原文本文件。但是,如果在置入文件前选中“文件处理”首选项中的“置入文本和电子表格文件时创建链接”,则该文本文件的名称将出现在“链接”面板中。可以使用“链接”面板更新和管理文件。更新链接的文本文件时,在 InDesign 中进行的任何编辑或格式更改都将丢失。由于存在这种危险,因此在编辑原文件时链接文本文件并不自动更新。但是,您可以使用“链接”面板轻松地更新内容或取消链接(嵌入)文件。

  1. 执行以下操作之一:
    • 要将此更改应用于某个文档,请打开该文档。

    • 要将此更改应用到您创建的所有新文档,请关闭全部文档。

  2. 选择“编辑”>“首选项”>“文件处理”(Windows) 或“InDesign”>“首选项”>“文件处理”(Mac OS)。
  3. 要在置入文件中创建链接,请选择“置入文本和电子表格文件时创建链接”。如果该选项已启用,则可使用“链接”面板来更新、重新链接或删除链接。如果该选项未启用,则文本文件是嵌入(非链接)的。

注意:

要取消链接(嵌入)某个链接的文本文件,请在“链接”面板中选择该文件,然后从“链接”面板菜单中选择“取消链接”。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略