存储文档

存储一个文档会存储当前版面、对源文件的引用、当前显示的页面以及缩放级别。经常存储有助于保护您的工作。可以将文件存储为下列类型之一:

  • 常规文档。

  • 文档副本,使用另一个名称为该文档创建一个副本,同时保持原始文档为现用文档。

  • 模板,通常作为一个未命名的文档打开。模板可以包含预设为其他文档的起点的设置、文本和图形。

    存储文档还会更新作为 InDesign 文档一部分的元数据(或文件信息)。此元数据包括缩览图预览、文档中使用的字体、颜色色板和“文件信息”对话框中的所有元数据,所有这些都可以提高搜索效率。例如,可以搜索使用特定颜色的所有文档。

    可以在 Bridge 和“文件信息”对话框的“高级”区域查看此元数据。通过使用首选项设置,可以控制存储时是否更新预览。只要存储文档,就会更新其他元数据(字体、颜色和链接)。

    “存储”、“存储为”和“存储副本”命令以 InDesign 文件格式存储文档。有关以其他文件格式存储文档的信息,请参阅“索引”。

    如果打算存储文档以便将其交付给印前服务提供商来完成最终输出,InDesign 可自动将所有必需的文件(如链接图形和字体)集合到一个文件夹中。(请参阅包文件。)

注意:

在导出以下格式的 EPUB 时,在“文件”>“文件信息”对话框中输入的信息,会在“元数据”选项卡中更新:

  • 固定版面 EPUB
  • 可重排版面 EPUB

  1. 执行以下操作之一:
    • 要使用新名称存储文档,请选择“文件”>“存储为”,指定位置和文件名,然后单击“存储”。新命名的文件变成现用文档。使用“存储为”命令可能减小文件大小。

    • 若要使用同一名称存储现有文档,请选择“文件”>“存储”。

    • 若要使用现有的位置和文件名存储所有打开的文档,请按 Ctrl+Alt+Shift+S (Windows) 或 Command+Option+Shift+S (Mac OS)。

    • 若要使用新名称存储文档副本,请选择“文件”>“存储副本”,指定位置和文件名,然后单击“保存”。已存储的副本不会变为现用文档。

注意:

应避免使用在某些操作系统中具有特殊含义的保留字符,以免出现问题。例如,避免在文件名的首字母中使用句点,避免在文件名中使用空格、制表符及下列字符:/ \ : ; * ? < > , $ %。同样,即使在使用非英语版本的 InDesign 时,也应避免使用重音字符(如 ü、ñ 和 é)。如果在其他平台上打开该文件,可能会出现问题。

注意:

如果您经常同时打开多个文档,并且希望同时存储这些文档,请使用键盘快捷键。选择“编辑”>“键盘快捷键”,从“产品区域”菜单中选择“视图, 导航”,然后在“命令”列表中选择“存储全部”。随后,您就可以编辑或添加快捷键。您可以使用“快速应用”来指定“存储全部”命令。

在存储的文档中包含预览

文档和模板的缩览图预览可以使您在 Adobe Bridge 和 Adobe Mini Bridge 中轻松地识别这些文件。存储文档或模板时会创建预览。文档预览仅包括第一跨页的 JPEG 图像,而模板预览则包括模板中每一页的 JPEG 图像。您可以根据自己的需求,控制预览的大小和页数。例如,1024x1024 的超大尺寸支持在打开文件之前以高分辨率快速扫描页面内容。

可以在“首选项”或“存储为”对话框中启用该选项。因为预览增加了文件大小和存储文档所需的时间,所以更倾向于使用“存储为”对话框来根据需要启用该选项。

  1. 执行以下操作之一:
    • 要在每次存储文档时包含预览,请选择“编辑”>“首选项”>“文件处理”(Windows) 或“InDesign”>“首选项”>“文件处理”(Mac OS)。

    • 要包含特定文档的预览效果,请选择“文件”>“存储为”

    • 若要包含特定内容的预览效果,请选择“文件”>“将内容存储为”。

  2. 选择“总是存储文档的预览图像”。
  3. 如果要使用“首选项”对话框设置预览,请从“页面”菜单中选择预览的页数,然后从“预览大小”菜单中选择预览大小。

    注意:

    “存储为”对话框中选择预览选项的同时也会在“首选项”对话框中选择该选项,并且使用默认的“页面”和“预览大小”设置。

存储 InDesign Markup (IDML) 文档

有时,您可能希望以交换标记格式存储 InDesign 文件。当在 InDesign 中打开 QuarkXPress 或 PageMaker 出版物、打开在早期版本的 InDesign 中创建的文档或文档出现问题(如不能删除颜色色板)时,使用这种格式进行存储特别有用。

  1. 选择“文件”>“存储”(CS6) 或“文件”>“导出”(CS5)。
  2. “存储类型”(Windows) 或“存储格式”(Mac OS) 菜单中,选择“InDesign Markup (IDML)”。
  3. 单击“存储”。

只能在 InDesign CS5 和 InDesign CS4 中打开保存的 IDML 文件,所有早期版本的 InDesign 都无法完成此操作。

有关将 IDML 用于开发的信息,请参阅 www.adobe.com/go/learn_id_indesignmarkup_cs4_cn

存储为早期 InDesign 版本

要在 InDesign CS5 中打开 InDesign CS6 文档,请在 InDesign CS6 中,将文档存储(“文件”>“存储”)为 InDesign 标记语言 (IDML)。(IDML 格式取代了在早期版本中用于降版存储的 INX 交换格式。)

要在 InDesign CS4 中打开 InDesign CS5 文档,请在 InDesign CS5 中,将文档导出(“文件”>“导出”)为 InDesign 标记语言 (IDML)。(IDML 格式取代了在早期版本中用于降版存储的 INX 交换格式。)

确保运行 InDesign 早期版本的计算机已使用适当的增效工具更新,以便可以打开导出的 IDML 文件。通过选择“帮助”>“更新”并按照提示进行操作,运行 InDesign 早期版本的用户可以获取兼容性增效工具。还可以从 Adobe 网站安装增效工具:请访问 Adobe 网站上的产品更新页,并从产品列表中选择 InDesign。

在早期版本的 InDesign 中打开文档也称为“降版存储”。

注意:

当您在 InDesign 早期版本中打开文档时,可能会修改或漏掉使用特定于 InDesign 更高版本的功能创建的内容。

  1. 选择“文件”>“存储”(CS6) 或“文件”>“导出”(CS5)。
  2. “文件类型”(Windows) 或“文件格式”(Mac OS) 菜单中选择“InDesign Markup (IDML)”。
  3. 单击“存储”。

可以在 InDesign 的早期版本中打开 .idml 文件,以将其转换为未命名的 InDesign 文档。

注意:

要在 InDesign CS3 中打开 InDesign CS5 文档,请在 InDesign CS4 中打开导出的 IDML 文件,将其存储并导出为 InDesign CS3 交换文档 (INX),然后就可以在 InDesign CS3 中打开导出的 INX 文件。请确保所有 InDesign 版本都是最新的。

使用元数据

元数据 是一组有关文件的标准化信息,如作者姓名、分辨率、色彩空间、版权以及为其应用的关键字。您可以使用元数据来优化工作流程以及组织文件。

关于 XMP 标准

元数据信息是使用可扩展元数据平台 (XMP) 标准进行存储的,Adobe Bridge、Adobe Illustrator、Adobe InDesign 和 Adobe Photoshop 均基于该标准。XMP 建立在 XML 的基础上,在大多数情况下,元数据将存储在文件中。如果无法将信息存储在文件中,则会将元数据存储在称为附属文件 的单独文件中。XMP 便于在 Adobe 应用程序之间以及发布工作流程之间交换元数据。例如,可以将某个文件的元数据存储为模板,然后将该元数据导入其它文件中。

以其它格式(如 EXIF、IPTC (IIM)、GPS 和 TIFF)存储的元数据是用 XMP 同步和描述的,因此,可以更方便地对其进行查看和管理。其他应用程序和功能也可以使用 XMP 来传递并存储信息,例如,传递并存储那些可以使用 Adobe Bridge 进行搜索的版本注释信息。

在大多数情况下,即使文件格式发生了变化(例如从 PSD 更改为 JPG),文件中也会保留此元数据。将文件放在 Adobe 文档或项目中时,也会保留元数据。

注意:

可以使用 XMP 软件开发工具包来自定元数据的创建、处理和交换过程。例如,可以使用 XMP SDK 在“文件信息”对话框中添加字段。有关 XMP 和 XMP SDK 的详细信息,请访问 Adobe 网站。

在 Adobe Bridge 和 Adobe Creative Suite 组件中使用元数据

许多可用来组织、搜索和跟踪文件和版本的 Adobe Bridge 强大功能都取决于文件中的 XMP 元数据。Adobe Bridge 提供了两种使用元数据的方法:通过“元数据”面板,以及通过“文件信息”对话框 (InDesign) 或“内容文件信息”对话框 (InCopy)。

在某些情况下,相同元数据属性会存在多个视图。例如,可能在一个视图中将属性标记为“作者”,而在另一个视图中将其标记为“创建者”,但它们指的是同一个基本属性。即使为特定工作流程自定了这些视图,它们也会通过 XMP 保持为标准化视图。

使用“文件简介”对话框添加元数据

“文件信息”对话框将显示当前文档的相机数据、文件属性、编辑历史记录、版权和作者信息。“文件信息”对话框还会显示自定元数据面板。您可以直接在“文件信息”对话框中添加元数据。您在字段中输入的任何信息会覆盖现有元数据,并且会将新值应用于所有选中的文件。

  1. 选择“文件”>“文件信息”(InDesign) 或“文件”>“内容文件信息”(InCopy)。
  2. 从对话框顶部的选项卡中选择下列任意选项:

    注意:

    使用向左箭头键和向右箭头键滚动选项卡,或者单击下指箭头,然后从列表中选择一个类别。

    说明

    用于输入有关文件的文档信息,如文档标题、作者、说明和可用于搜索该文档的关键字。要指定版权信息,请从“版权状态”弹出菜单中选择“受版权保护”。然后输入版权所有者、公告文本以及拥有版权的个人或公司的 URL。

    IPTC

    包括四个区域:“IPTC 内容”描述图像的视觉内容。“IPTC 联系人”列出摄影师的联系信息。“IPTC 图像”列出图像的描述性信息。“IPTC 状态”列出工作流程和版权信息。

    相机数据

    包括两个区域:相机数据 1 显示有关用于拍摄照片的相机和设置的只读信息,例如品牌、机型、快门速度和光圈大小。相机数据 2 列出有关照片的只读文件信息,包括像素尺寸和分辨率。

    视频数据

    列出有关视频文件的信息(包括视频帧的宽度和高度),并且允许输入磁带名称和场景名称等信息。

    音频数据

    用于输入有关音频文件的信息,包括标题、艺术家、比特率和循环设置。

    移动 SWF

    列出有关移动媒体文件的信息,包括标题、作者、描述和内容类型。

    类别

    让您根据美联社类别输入信息。

    原点

    用于输入对新闻报道有用的文件信息,包括文件的创建时间和位置、传送信息、特别说明以及标题信息。

    DICOM

    列出 DICOM 图像的患者、研究、系列和设备信息。

    历史记录

    显示用 Photoshop 保存的图像的 Adobe Photoshop 历史记录信息。只有在安装 Adobe Photoshop 之后,才会显示“历史记录”选项卡。

    Illustrator

    用于为打印、Web 或移动输出应用文档配置文件。

    高级

    显示使用命名空间和属性存储元数据的字段和结构,例如文件格式及 XMP、EXIF 和 PDF 属性。

    原始数据

    显示关于文件的 XMP 文本信息。

  3. 在任何显示的字段中键入要添加的信息。
  4. 单击“确定”以应用更改。

将元数据导出为 XMP 文件

可以将元数据存储在一个 XMP 文件中,以便与其他用户共享。这些 XMP 文件可以用作填充 InDesign 文档和其他使用支持 XMP 的应用程序创建的文档的模板。导出的模板存储在一个所有支持 XMP 的应用程序都可以访问的共享位置中。这些模板还会显示在“文件信息”对话框底部的弹出菜单中。

  1. 选择“文件”>“文件信息”(InDesign) 或“文件”>“内容文件信息”(InCopy)。
  2. 请从对话框底部的弹出菜单中选择“导出”。
  3. 键入文件名,选择存储文件的位置,然后单击“存储”。

    注意:

    要在资源管理器 (Windows) 或 Finder (Mac OS) 中查看元数据模板,请单击“文件信息”对话框底部的弹出菜单,然后选择“显示模板文件夹”。

导入 XMP 文件中的元数据

从导出的 XMP 模板文件中将元数据导入一个文档时,可以指定是要清除当前文档中的所有元数据并添加新的元数据,保留除匹配元数据之外的所有元数据,还是将匹配元数据添加到现有元数据中。

  1. 选择“文件”>“文件信息”(InDesign) 或“文件”>“内容文件信息”(InCopy)。
    • 从对话框底部的弹出菜单中选择一个 XMP 文件,选择导入选项,然后单击“确定”。

    • 从对话框底部的弹出菜单中选择“导入”,选择导入选项,然后单击“确定”。然后双击您要导入的 XMP 模板文件。

编辑图像文件中的元数据

在 InDesign 中为置入的图像生成题注时,需要使用所置入图像中的元数据。尽管您可以编辑 InDesign 文档的元数据,但无法在 InDesign 中编辑所置入文件的元数据。不过,利用所置入图像的原始应用程序(使用 Finder、Explorer、Adobe Bridge 或 Adobe Mini Bridge),可以更改其元数据。

  1. 在 InDesign 中,右键单击 (Windows) 或按下 Control (Mac OS) 的同时单击该图像,然后选择“编辑原稿”。

    您也可以选择“编辑工具”,然后选择一个应用程序,如 Adobe Illustrator 或 Adobe Photoshop。

  2. 在原始应用程序中,选择“文件”>“文件信息”

  3. 编辑元数据,然后单击“确定”。

您还可以在 Adobe Bridge 中选择一副图像,然后选择“文件”>“文件信息”来编辑该图像的元数据。请参阅使用“文件简介”对话框添加元数据

解决共享网络保护性关闭问题

  • 对于从网络位置打开且小于 100 MB 的任何文档,即使网络连接中断,InDesign 也不会执行保护性关闭。如果出现临时性网络中断后网络连接得以恢复,那么您可以继续工作,并且可以将文档存储在网络上。如果您要尝试在网络中断时存储文档,则可以选择将文档存储在本地。
  • 对于大于 100 MB 的文档,会继续执行现有行为 - 如果在处理此类文档时网络连接中断,InDesign 将执行保护性关闭。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略