选择文本

  1. 使用“文字工具”,执行下列操作之一:
    • 将 I 形光标拖过字符、单词或整个文本块以选择它。
    • 双击一个字可选择该字。不会选择单词两边的空格。
    • 在行的任意位置单击三次以选择整行。如果取消选择“三击以选择整行”首选项,单击三次将选择整个段落。

    • 如果选择“三击以选择整行”选项,在段落中的任意位置单击四次可选择整个段落。

    • 单击五次以选择整篇文章,或在文章的任意位置单击并选择“编辑”>“全选”

注意:

如果使用以上任一操作选择包含附注锚点的文本,则会同时选中附注及其内容。

如果无法选择框架中的文本,则可能是因为该文本框架位于锁定图层或位于主页上。请尝试解锁图层或者转到主页。此外,还可能是因为该文本框架位于另一个文本框架或透明对象的下面。请参阅选择被覆盖框架中的文本

更改单击三次所执行的操作

  1. 选择“编辑”>“首选项”>“文字”(Windows) 或“InDesign”>“首选项”>“文字”(Mac OS)。
  2. 选择“三击以选择整行”以使单击三次可选择整行(这是默认设置)。如果希望单击三次可选择段落,则取消选择该选项。

选择被覆盖框架中的文本

  1. 使用“选择工具”,按住 Ctrl 键 (Windows) 或 Command 键 (Mac OS),然后单击以选择文本框架。
  2. 选择“文字工具”,然后在文本框架内单击或选择文本。

查看隐藏(非打印)字符

  1. 选择“文字”>“显示隐藏的字符”。
  2. 如果隐藏字符仍未显示,请关闭预览模式。选择“视图”>“屏幕模式”>“正常”和选择“视图”>“叠印预览”都可以取消选中预览模式。

将显示非打印字符,如用于空格、制表符、段落末尾、索引标志符和文章末尾的字符。这些特殊字符仅在文档窗口和文章编辑器窗口中可见;它们不能打印,也不能输出到 PDF 和 XML 等格式中。隐藏字符的颜色与图层颜色相同。

非打印字符隐藏时(上)和可见时(下)的情况
非打印字符隐藏时(上)和可见时(下)的情况

Anne Marie Concepcion 在 InDesign 特殊字符免费指南中提供了一份特殊字符的完整列表。

隐藏字符的列表

隐藏字符

它表示的内容

段落结尾

软回车(换行符)

空格

文章结尾

自由连字符

不间断连字符

Tab

右对齐制表符

在此缩进对齐

在此处结束嵌套样式

可选分隔符

表意字空格

全角空格

半角空格

不间断空格

不间断空格(固定宽度)

细空格 (1/24)

六分之一空格

窄空格 (1/8)

四分之一空格

三分之一空格

标点空格

数字空格

右齐空格

分栏符

框架分隔符

分页符

奇数页分页符

偶数页分页符

强制换行

InCopy 附注

InCopy 附注(在文章编辑器中)

位置标志符(仅限 InCopy)

索引标志符

索引标志符(在文章编辑器中)

隐藏条件文本

隐藏条件文本(在文章编辑器中)

书签或超链接目标标志符(通常是文本锚点)

书签或超链接目标标志符(在文章编辑器中)

超链接目标(在文章编辑器中)

交叉引用段落

交叉引用超链接(在文章编辑器中)

定位对象

定位对象(在文章编辑器中)

XML 标签

XML 标签(在文章编辑器中)

脚注(在文章编辑器中)

表(在文章编辑器中)

变量(在文章编辑器中)

索引标志符(在文章编辑器中)

添加分栏符、框架分隔符和分页符

在文本中插入特殊分隔符,可控制对栏、框架和页面的分隔。

  1. 使用“文字工具”,在希望出现分隔的地方单击以显示插入点。
  2. 选择“文字”>“插入分隔符”,然后从子菜单中选择一个分隔符选项。

注意:

也可使用数字键盘上的 Enter 键创建分隔符。对于分栏符,请按 Enter 键;对于框架分隔符,请按 Shift+Enter 键;对于分页符,请按 Ctrl+Enter (Windows) 或 Command+Return (Mac OS)。

要删除分隔符,请选择“文字”>“显示隐藏的字符”,以便能看见非打印字符,然后选中分隔符并将其删除。

注意:

如果通过更改段落设置创建分隔符(在“保持选项”对话框中),则分隔符位于包含此设置的段落之前。如果使用特殊字符创建分隔符,则分隔符紧跟在特殊字符之后。

分隔符选项

下列选项显示在“文字”>“插入分隔符”菜单上:

分栏符 

将文本排列到当前文本框架内的下一栏。如果框架仅包含一栏,则文本转到下一串接的框架。

框架分隔符 

将文本排列到下一串接的文本框架,而不考虑当前文本框架的栏设置。

分页符 

将文本排列到下一页面(该页面具有串接到当前文本框架的文本框架)。

奇数页分页符 

将文本排列到下一奇数页面(该页面具有串接到当前文本框架的文本框架)。

偶数页分页符 

将文本排列到下一偶数页面(该页面具有串接到当前文本框架的文本框架)。

段落回车符 

插入一个段落回车符(与按 Enter 键或 Return 键效果相同)。

强制换行 

在字符的插入位置处强制换行,开始新的一行,而非新的一段。这与按 Shift+Enter 或 Shift+Return 的作用相同。强制换行也称为软回车。

自由换行符 

表示文本行在需要换行时的换行位置。自由换行符类似于自由连字符,唯一不同的是换行处没有添加连字符。

“保持选项”对话框和“段落样式选项”对话框提供了相关的分隔符选项。

使用文章编辑器

可在 InDesign 中的版面页面或文章编辑器窗口中编辑文本。在文章编辑器窗口中撰写和编辑时,可以按照“首选项”中指定的字体、大小及间距显示整篇文章,而不会受到版面或格式的影响。您还可以在文章编辑器中查看对文本所执行的修订。

每篇文章都显示在不同的文章编辑器窗口中。文章中的所有文本(包括溢流文本)都显示在文章编辑器中。可以同时打开多个文章编辑器窗口,包括同一篇文章的多个实例。垂直深度标尺指示文本填充框架的程度,直线指示文本溢流的位置。

编辑文章时,所做的更改将反映在版面窗口中。“窗口”菜单会列出打开的文章。不能在文章编辑器窗口中创建新文章。

“文章编辑器”窗口
“文章编辑器”窗口

A. 段落样式 B. 拖动分隔线以调整栏宽 C. 垂直深度标尺 D. 溢流文本指示符 

您可以在文章编辑器中查看和编辑表,在那里,文本显示在连续的列和行中,以便编辑。快速展开或折叠表,并决定是按行还是按列查看表。

如果您打开“修订”功能,则文章编辑器还会显示已添加、删除或编辑的文本。请参阅修订和检查更改

打开文章编辑器

  1. 选择文本框架,在文本框架中单击一个插入点,或从不同的文章选择多个框架。
  2. 选择“编辑”>“在文章编辑器中编辑”。

注意:

要打开同一文章编辑器窗口的其他实例,请激活该文章编辑器,并选择“窗口”>“排列”>“新建窗口”。

返回版面窗口

  1. 在文章编辑器中,执行下列操作之一:
    • 选择“编辑”>“在版面中编辑”。使用这种方法时,版面视图显示的文本选区或插入点位置与文章编辑器中上次显示的相同,文章窗口仍打开但已移到版面窗口的后面。

    • 单击版面窗口。文章窗口仍打开但移到版面窗口的后面。

    • 关闭文章编辑器窗口。

    • 从“窗口”菜单的底部选择文档名称。

显示或隐藏文章编辑器项目

您可以显示或隐藏样式名称列和深度标尺、展开或折叠脚注,以及显示或隐藏用于指示新段落开始位置的分段标记。这些设置会影响所有打开的文章编辑器窗口以及随后打开的窗口。

  • 当文章编辑器处于现用状态时,选择“视图”>“文章编辑器”>“显示样式名称栏”或“隐藏样式名称栏”。也可拖动竖线来调整样式名称栏的宽度。随后打开的文章编辑器窗口具有相同的栏宽。
  • 当文章编辑器处于现用状态时,选择“视图”>“文章编辑器”>“显示深度标尺”或“隐藏深度标尺”。
  • 当文章编辑器处于现用状态时,选择“视图”>“文章编辑器”>“展开全部脚注”或“折叠全部脚注”。
  • 当文章编辑器处于现用状态时,选择“视图”>“文章编辑器”>“显示分段标记”或“隐藏分段标记”。

文章编辑器首选项

使用“文章编辑器显示”首选项更改文章编辑器的外观。虽然文章编辑器几乎禁止所有最基本的文本样式属性,但仍可表示下列对象和属性:

属性

图标

行间对象

XML 标签

变量

超链接源

超链接锚点

交叉引用

隐藏条件文本

附注

脚注

索引标志符

删除的文本

添加的文本

移动的文本

 

文本显示选项

选择显示字体、大小、行间距、文本颜色和背景。还可以指定不同的主题,如选择“传统系统”以在黑色背景上查看黄色文本。这些设置会影响文本在文章编辑器窗口中的显示,但不会影响在版面视图中的显示。

启用消除锯齿

平滑文字的锯齿边缘,并选择消除锯齿的“文字”:LCD 优化、软化或默认设置,它们将使用灰色阴影来平滑文本。LCD 优化使用颜色而非灰色阴影来平滑文本,在具有黑色文本的浅色背景上使用时效果最佳。软化使用灰色阴影,但比默认设置生成的外观亮,且更模糊。

光标选项

更改文本光标的外观。例如,如果希望光标闪烁,请选择“闪烁”。

嵌套框架中的文本不显示在父级文章编辑器窗口中,但可显示在它自己的文章编辑器窗口中。

使用条件文本

条件文本是一种为同一文档创建不同版本的方法。创建条件后,可以将其应用到文本的各种范围。然后,可以通过显示和隐藏条件来创建文档的不同版本。例如,如果要创建一个计算机手册,则可以为 Mac OS 和 Windows 创建各自的条件。在打印 Mac OS 版本的用户指南之前,您可以显示所有应用了“Mac”条件的文本,同时隐藏所有应用了“Windows”条件的文本。然后,您可以反转条件状态,以便打印 Windows 版本的用户指南。

条件文本
显示条件文本

A. 显示所有条件 B. 条件指示符 
隐藏条件文本
隐藏条件文本

A. 隐藏“Mac”条件 B. 隐藏条件符号 

条件只能应用于文本。您可以使定位对象成为条件对象,但只能通过选择定位对象标志符来实现。您可以对表单元格内的文本应用条件,但不能对表单元格、列或行应用条件。您不能对锁定的 InCopy 文章中的文本应用条件。

规划条件文档

在规划包含条件文本的项目时,应检查材料的性质,并考虑文档提交后,如何让多名用户能够依此使用该文档。规划对条件文本进行一致地处理,可使文档更易于使用和维护。请遵循以下原则。

版本数

定义您的最终项目将包含多少个版本。例如,如果要创建一份手册,介绍一个在 Windows 和 Mac OS 平台上运行的程序,则可能至少需要生成两个版本:一个 Windows 版本和一个 Mac OS 版本。如果希望生成的这些版本包含审查时零星添加到文本中的编辑注释,则可能需要更多的版本:带注释的 Mac OS 版本、不带注释的 Mac OS 版本、带注释的 Windows 版本和不带注释的 Windows 版本。

对于带有多个条件的文档,您可以定义条件集。条件集能够应用到文档,以便快速进行版本控制。

所需条件标签数

确定生成所需版本需要使用多少个条件标签。文档的每个版本都由一组唯一的条件标签来定义。例如,一份完成的 Windows 版手册可以通过显示 Windows 条件标签、隐藏 Mac OS 条件标签以及隐藏注释条件标签来定义。在此示例中,您将需要确定是对 Windows 注释使用一个条件标签,对 Mac OS 注释使用另一个条件标签,还是对 Windows 和 Mac OS 注释使用同一个条件标签。

内容的组织

评估文档可以具有条件的程度,及如何组织材料能够简化开发与维护。例如,您可以组织书籍,使条件文本仅限用于少数几个文档。或者,您可以选择在单独的文件中保存特定章节的各个版本,而不是保存在条件文本中,然后对书籍的每个版本使用不同的书籍文件。

在某些情况下,例如在处理多语言时,您也许不想使用条件,而是希望创建可以显示或隐藏的独立图层,每个图层都包括一种语言的文本。

标记策略

确定条件文本的最小单位。例如,如果将文档翻译成另一种语言,则应将整个句子作为建立条件的最小文本单位。由于在翻译过程中文字顺序通常会发生变化,因此对句子的一部分使用条件文本会使翻译变得杂。

若向空格和标点应用条件的操作有不一致的地方,会导致出现多余的空格或拼写错误的单词。确定是否使空格和标点符号具有条件。如果条件文本以标点符号开头或结束,请使标点符号也具有条件。在查看多个版本时,这会使文本更易于阅读。

为避免出现文字空格问题,例如无条件空格后接有条件的空格,应设置条件文本后续空格的处理标准(始终有条件或者始终无条件)。

为避免混乱,应确定条件文本的显示顺序,并在整个文档中使用此顺序。

索引和交叉引用

对文档进行索引时,应注意索引标志符是放在条件文本之内还是之外。请记住,隐藏条件文本中的索引标志符不会包括在生成的索引中。

如果创建指向条件文本的交叉引用,请确保源文本具有相同的条件。例如,如果在“Windows”段落中添加一个交叉引用,而文本锚点出现在“Mac”条件中,则当“Mac”条件处于隐藏状态时,将无法解析该交叉引用。在“超链接”面板中,“HT”显示在交叉引用的旁边。

如果您创建了一个交叉引用,指向一个其中部分文本具有条件的段落,然后更改了该条件的可视性设置,请更新该交叉引用。

创建条件

您创建的条件存储在当前文档中。如果在创建条件时没有打开任何文档,该条件将显示在您创建的所有新文档中。

指定条件指示符(例如红色波浪下划线)可使条件文本更易于识别。

  1. 选择“窗口”>“文字和表”>“条件文本”,显示“条件文本”面板。
  2. 从“条件文本”面板菜单中选择“新建条件”,然后键入条件的名称。
  3. 在“指示符”组中,指定要向其应用条件的指示符的外观。

    默认情况下,指示符(如红色波浪线)设置为在文档中显示,但不会打印或输出。您可以从“条件文本”面板的“指示符”菜单中选择相关选项,以隐藏指示符或打印和输出指示符,这有助于进行检查。

  4. 单击“确定”。

将条件应用到文本

对同一文本可以应用多个条件。默认情况下,条件指示符会标识条件文本。但如果指示符处于隐藏状态,则可以使用“条件文本”面板来确定对当前文本应用了哪些条件。实底选中标记表示该条件已应用于当前文本。灰显的选中标记表示该条件只应用于所选文本的一部分。

  1. 选择要向其应用该条件的文本。
  2. 在“条件文本”面板(“窗口”>“文字和表”>“条件文本”)中,执行下列操作之一:
    • 要应用某一条件,请单击该条件,或单击条件名称旁的框。

    • 要对文本应用某一条件,同时删除已应用到该文本的其他条件,请按住 Alt 键并单击 (Windows) 或按住 Option 键并单击 (Mac OS) 该条件。

    • 要删除某一条件,请单击条件名称旁的框,清除选中标记。或者,单击“[无条件]”,从选定文本中删除所有条件。

注意:

键盘快捷键不能应用于具体条件。但可以使用“快速应用”来应用条件。

显示或隐藏条件

隐藏某一条件时,所有应用了该条件的文本都将隐藏。在文档或书籍中,隐藏条件常常会导致页码发生变化。您可以使用“智能文本重排”功能,在隐藏和显示条件时自动添加和删除页面。

文档中的隐藏条件文本通常会忽略。例如,不会打印或导出隐藏文本;隐藏条件文本中的索引标志符不会包括在生成的索引中;搜索文本或进行文本拼写检查时,不会包括隐藏条件文本。

在隐藏某一条件后,隐藏文本将存储在隐藏条件符号 中。如果选择包含隐藏条件符号的文本并尝试将其删除,InDesign 会提示您确认是否要删除隐藏条件文本。不能对隐藏条件文本应用其他条件、样式或格式。

如果对文本应用了多个条件,则只要其中一个条件处于显示状态,那么即使所有其他条件都处于隐藏状态,也不会隐藏该文本。

  • 要显示或隐藏各个条件,请单击条件名称旁的可视性框。眼睛图标表示条件处于显示状态。
  • 要显示或隐藏所有条件,请从“条件文本”面板菜单中选择“显示全部”或“隐藏全部”。

使用条件集

条件集捕捉所有条件的可视性设置,使您可以快速呈现文档的各个版本。例如,假设您有一个复杂文档,其中包含针对 Mac OS、Windows XP、Vista 和 UNIX 的平台条件;针对英语、法语、德语和西班牙语的语言条件;以及“编辑审阅”、“内部注释”等编辑条件。若要审阅法语的 Vista 版文档,您可以创建一个条件集,只显示 Vista、法语和“编辑审阅”三个条件,隐藏所有其他条件。

虽然实现此效果并不一定要使用条件集,但它们可帮助您快速、可靠地更改各种条件可视性设置。

  1. 根据需要将条件应用到文本。
  2. 如果“条件文本”面板中未显示“集”菜单,请从“条件文本”面板菜单中选择“显示选项”。
  3. 在“条件文本”面板中,根据需要使条件可见或隐藏。
  4. 从“集”菜单中选择“创建新集”,指定集的名称,然后单击“确定”。

    新集将成为现用集。

  5. 执行以下操作之一:
    • 要对文档应用条件集,请从“集”菜单中选择条件集名称。

    • 要覆盖某一条件集,请选择该集,使其成为现用集,然后根据需要更改其中条件的可视性设置。该条件集旁将显示一个加号 (+)。再次选择该条件集可删除覆盖设置。选择“重新定义‘[条件集]’”可用新的可视性设置更新该条件集。

    • 要删除某一条件集,请选中该条件集,然后选择“删除‘[条件集]’”。删除条件集不会删除该集的条件,也不会将条件从应用这些条件的位置删除。

管理条件

  1. 执行以下操作之一:

    删除条件

    选择条件,然后单击“条件文本”面板底部的“删除条件”图标。指定用于替换所删除条件的条件,然后单击“确定”。将对应用过所删除条件的所有文本应用您指定的条件。

    要删除多个条件,请按住 Shift 键并单击以选择多个连续的条件,或者按住 Ctrl 键并单击 (Windows) 或按住 Command 键并单击 (Mac OS) 以选择多个非连续条件,然后单击“删除条件”图标。

    从文本中删除条件

    从文本中删除条件标签不同于从文档中删除标签。从文本中删除标签时,标签保留在文档中,因此以后可以再次应用。

    要从文本中删除条件,请选择该文本,然后单击条件旁的框以清除选中标记,或单击“[无条件]”,从所选文本中删除所有条件。

    载入(导入)条件

    从“条件文本”面板菜单中选择“载入条件”(仅载入条件)或“载入条件和集”。选择要从中导入条件的 InDesign 文档,然后单击“打开”。载入的条件和集将替换所有同名的条件或集。

    InDesign 中无法载入来自 InCopy 文件的条件,但 InDesign 和 InCopy 中都可以载入来自 InDesign 文件的条件。

    载入的集将忽略“条件文本”面板上的当前条件可视性设置。

    同步书籍中的条件

    为确保在书籍的所有文档中使用了相同的条件,请在样式源文档中创建所需条件,在“同步选项”对话框中选择“条件文本设置”,然后同步书籍。

    显示或隐藏条件指示符

    从“条件文本”面板的“指示符”菜单中,选择“显示”或“隐藏”,以显示或隐藏条件指示符。如果要显示某个版本并查看哪些区域具有条件,应显示条件指示符。如果发现在查看版面时,这些条件指示符分散了您的注意力,可隐藏条件指示符。如果要打印和输出条件指示符,请选择“显示并打印”。

    更改条件名称

    在“条件文本”面板中,单击一个条件,稍候,然后单击条件名称以将其选中。键入其他名称。

    编辑条件指示符

    在“条件文本”面板中,双击一个条件,或选择一个条件并从面板菜单中选择“条件选项”。指定指示符设置,然后单击“确定”。

查找和更改条件文本

使用“查找/更改”对话框可查找应用了一个或多个条件的文本,并替换成一个或多个其他条件。

  1. 显示所有要包括在搜索中的条件文本。

    隐藏文本在搜索范围之外。

  2. 选择“编辑”>“查找/更改”。
  3. 如果在此对话框的底部未显示“查找格式”和“更改格式”框,请单击“更多选项”
  4. 单击“查找格式”框,以显示“查找格式设置”对话框。在“条件”下面,选择“[任何条件]”可搜索应用了任何条件的文本,选择“[无条件]”可搜索未应用任何条件的文本,或者选择一个或多个要搜索的具体条件。单击“确定”。

    此功能将查找与所选条件精确匹配的文本。例如,如果您选择了条件 1 和条件 2,则查找结果中不会出现只应用了其中一个条件的文本,也不会出现应用了这两个条件和另一个条件的文本。

  5. 单击“更改格式”框,以显示“更改格式设置”对话框。指定其他格式选项(例如条件或字符样式),然后单击“确定”。

    如果您在“更改格式设置”对话框中选择了“条件”部分,则“[任何条件]”不会对找到的条件文本进行任何更改。如果想要应用其他格式(例如字符样式),可以使用此选项。选择“[无条件]”将从找到的文本中删除所有条件。如果选择了具体条件,请指定是希望该条件替换所找到文本中应用的任何条件,还是希望它添加到文本中。

  6. 单击“查找”,然后使用“更改”、“更改/查找”或“全部更改”按钮替换条件。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略