表单

  1. InDesign 用户指南
  2. 了解 InDesign
    1. InDesign 简介
      1. InDesign 的新功能
      2. 系统要求
      3. 常见问题
      4. 使用 Creative Cloud 库
    2. 工作区
      1. 工作区基础知识
      2. 工具箱
      3. 设置首选项
      4. 触控工作区
      5. 默认键盘快捷键
      6. 文档恢复和还原
  3. 创建文档和设置文档版面
    1. 文档和页面
      1. 创建文档
      2. 使用主页
      3. 使用文档页面
      4. 设置页面大小、边距和出血
      5. 使用文件和模板
      6. 创建书籍文件
      7. 添加基本页码
      8. 编排页码和章节
      9. 转换 QuarkXPress 和 PageMaker 文档
      10. 共享内容
      11. 了解受管理文件的基本工作流程
      12. 存储文档
    2. 网格
      1. 网格
      2. 制定网格的格式
    3. 版面辅助工具
      1. 文档窗口中的
  4. 添加内容
    1. 文本
      1. 将文本添加到框架
      2. 串接文本
      3. InDesign 中的阿拉伯语和希伯来语功能
      4. 创建路径文字
      5. 项目符号和编号
      6. 字形和特殊字符
      7. 文本排版
      8. 文本变量
      9. 生成二维码
      10. 编辑文本
      11. 对齐文本
      12. 在对象周围绕排文本
      13. 定位对象
      14. 链接的内容
      15. 设置段落格式
      16. 设置字符格式
      17. 查找/更改
      18. 拼写检查和语言词典
    2. 排版规则
      1. 在 InDesign 中使用字体
      2. 字偶间距和字符间距
    3. 设置文本格式
      1. 设置文本格式
      2. 制表符和缩进
    4. 审阅文本
      1. 跟踪和检查更改
      2. 在 InDesign 中添加编辑附注
      3. 导入 PDF 注释
    5. 添加引用
      1. 创建目录
      2. 脚注
      3. 创建索引
      4. 尾注
      5. 题注
    6. 样式
      1. 段落样式和字符样式
      2. 对象样式
      3. 首字下沉和嵌套样式
      4. 使用样式
      5. 行距
      1. 设置表的格式
      2. 创建表
      3. 表和单元格样式
      4. 选择和编辑表
      5. 表描边和填色
    7. 交互性
      1. 超链接
      2. 动态 PDF 文档
      3. 书签
      4. 按钮
      5. 表单
      6. 动画
      7. 交叉引用
      8. 设置 PDF 结构
      9. 页面过渡效果
      10. 影片和声音
      11. 表单
    8. 图形
      1. 了解路径和形状
      2. 使用铅笔工具绘图
      3. 用钢笔工具绘图
      4. 应用线条(描边)设置 
      5. 复合路径与形状
      6. 编辑路径
      7. 剪切路径
      8. 更改角点外观
      9. 对齐和分布对象
      10. 链接和嵌入的图形
      11. 集成 AEM Assets
    9. 颜色和透明度
      1. 应用颜色
      2. 使用导入图形中的颜色
      3. 使用色板
      4. 混合油墨
      5. 色调
      6. 了解专色和印刷色
      7. 混合颜色
      8. 渐变
      9. 拼合透明图稿
      10. 添加透明度效果
  5. 共享
    1. 共享与协作        
    2. 共享以供审阅
    3. 审阅 InDesign 共享文档
    4. 管理反馈 
  6. 发布
    1. 导出和发布
      1. Publish Online
      2. 导出 EPUB 内容
      3. Adobe PDF 选项
      4. 将内容导出为 HTML
      5. 导出至 Adobe PDF
      6. 导出为 JPEG 格式
      7. 导出 HTML
      8. DPS 和 AEM Mobile 概述
    2. 打印
      1. 打印小册子
      2. 印刷标记和出血
      3. 打印文档
      4. 油墨、分色和网频
      5. 叠印
      6. 创建 PostScript 和 EPS 文件
      7. 提交前对文件执行印前检查
      8. 打印缩览图和超大文档
      9. 为服务提供商准备 PDF
      10. 准备打印分色
  7. 扩展 InDesign
    1. 自动化
      1. 数据合并
      2. 增效工具
      3. 脚本

表单工作流程

可以在 InDesign 中设计表单,然后直接将其导出到 PDF。InDesign 现在支持表单域和其他表单操作。按钮和表单库(“窗口”>“交互”>“按钮和表单”)包含您可以用来设计交互式表单的表单项目。

通过 InDesign,您可以在 InDesign 内创建简单表单,而不需要在发布之后在 Acrobat 中修改 PDF 文档。您可以在文档页面上添加简单表单元素。支持通用字段类型,如文本字段、单选按钮、复选框或签名。您还可以添加操作,以便通过电子邮件提交表单或者打印表单。

除基本设计之外,您还可以使用 InDesign 中的创意功能,在您的表单中添加一个设计师触控装置。

  • 向 PDF 表单域添加实线描边和填色。
  • 为按钮、复选款和单选框添加自定“开”、“关”和“悬停”状态。
  • 指定文本输入字段的字体大小。

例如,要收集信用卡信息,可以使用信用卡图标作为单选按钮,而选定状态采用不同的图像。

对于高级表单工作流程,您可以导出基本表单,然后继续在 Adobe Acrobat 中对其进行编辑。

添加表单域

使用“按钮和表单”面板可向版面添加表单域。添加交互表单域的步骤与添加按钮的步骤相同,从而您不必学习新步骤。您可以创建用于 Adobe Reader 或 Adobe Acrobat 的表单。通过 InDesign,您可以创建一些通常无法使用 Acrobat 的精美表单。

“按钮和表单”面板
“按钮和表单”面板

  1. 在您想要置入表单域的位置置入一个框架。

  2. 打开按钮和表单面板(窗口 > 交互 > 按钮和表单)。

  3. 选择框架并从类型列表中选择表单元素类型。或者,右键单击框架并选择交互 > 转换为 [...]

  4. 输入表单域的名称。为了创建单选按钮组,所有的单个按钮必须具有相同的名称。

  5. 选取事件并添加与之相关联的操作。添加了“清除表单”、“打印表单”和“提交表单”等操作。执行“提交表单”操作时,将 URL 指定为 mailto:xyz@example.com。

  6. 对于单选按钮复选框按钮:为不同状态设置外观属性。InDesign 为各种状态添加了默认图形,但您也可以添加您自己的图形。

  7. 对于列表框组合框文本域:选择字体系列、字体类型和字体大小。

  8. 指定 PDF 选项:

    • 说明 - 输入的值将显示为工具提示,并且用于创建可访问的表单。
    • 按钮值 - 该值对应于 Acrobat 中的导出值,也可用于标识可访问表单中某个组的单选按钮。

指定跳位顺序

为了创建界面友好的可访问表单,必须指定可用的跳位顺序。用户无需使用指示设备即可浏览表单域。按下 Tab 键会将焦点转移到下一个逻辑字段。

可以采用以下两种方法指定带标签的 PDF 中的跳位顺序:

  • 使用“文章”面板(窗口 > 文章)指定自定跳位顺序
  • 选择对象 > 交互 > 设置跳位顺序

使用“文章”面板指定跳位顺序

使用“文章”面板指定跳位顺序
使用“文章”面板指定跳位顺序

  1. 打开“文章”面板(窗口 > 文章)。

  2. 把表单域拖到“文章”面板中。

  3. 在“文章”面板中,拖动表单域以按照要求的顺序对其重新排序。

注意:

要使屏幕阅读器能够使用指定的顺序,需从“文章”面板菜单中启用用于加标签的 PDF 中的阅读顺序。在导出 PDF 时,记住启用创建带标签的 PDF 选项。


使用“结构”面板指定跳位顺序

  1. 选择对象 > 交互 > 设置跳位顺序

  2. 单击上移下移,按照所需的跳位顺序排列项目。

导出为交互式 PDF 时,应在“PDF 导出”对话框中启用使用跳位顺序的结构

Adobe 徽标

登录到您的帐户