创建书籍文件

书籍文件是一个可以共享样式、色板、主页及其他项目的文档集。您可以按顺序给编入书籍的文档中的页面编号、打印书籍中选定的文档或者将它们导出为 PDF。一个文档可以隶属于多个书籍文件。

添加到书籍文件中的其中一个文档便是样式源。默认情况下,样式源是书籍中的第一个文档,但您可以随时选择新的样式源。在对书籍中的文档进行同步时,样式源中指定的样式和色板会替换其他编入书籍的文档中的样式和色板。

Michael Murphy 在书籍基础知识中提供了一个有关创建书籍的视频教程。

  1. 选择“文件”>“新建”>“书籍”。
  2. 为该书籍键入一个名称,指定位置然后单击“保存”。

    将会出现“书籍”面板。存储的书籍文件文件扩展名为 .indb。

  3. 向书籍文件中添加文档。

向书籍文件中添加文档

创建书籍文件后,便可以在“书籍”面板中打开它。“书籍”面板是书籍文件的工作区域,可以在此添加、删除或重排文档。

  1. 在“书籍”面板菜单中选择“添加文档”,或单击“书籍”面板底部的加号按钮
  2. 选择要添加的 Adobe InDesign 文档,然后单击“打开”。

    注意:

    可以将文件从资源管理器 (Windows) 或 Finder (Mac OS) 窗口拖放到“书籍”面板中。还可以将某文档从一个书籍拖动到另一个书籍中。按住 Alt (Windows) 或 Option (Mac OS),可以复制文档。

  3. 如果添加的文档是在 InDesign 早期版本中创建的,则在添加到书籍时会将它们转换为 Adobe InDesign CS5 格式。在“存储为”对话框中,为转换的文档指定一个新的名称(或保留原来的名称),然后单击“存储”。

    注意:

    在将 Adobe PageMaker 或 QuarkXPress 文档添加到书籍文件中之前,必须对它们进行转换。

  4. 如有必要,可通过将文档向上或向下拖动至列表中适当的位置,来更改它们在面板中的顺序。
  5. 要将某文档指定为样式源,请单击面板中该文档名称旁边的框。

要打开书籍文件中的某个文档,请双击“书籍”面板中该文档的名称。

管理书籍文件

每个打开的书籍文件均显示在“书籍”面板中各自的选项卡中。如果同时打开了多本书籍,则单击某个选项卡可将对应的书籍调至前面,从而访问其面板菜单。

“书籍”面板中的图标表明文档的当前状态,例如“打开”、“缺失”(移动、重命名或删除了文档)、“已修改”(书籍关闭后,编辑了文档或是文档页码或章节编号发生了更改),或“正在使用”(如果其他用户在管理工作流程中打开了该文档)。关闭的文档旁边不会显示图标。

注意:

要查看书籍中任一文档的路径名,请将鼠标指针放在该文档的名称上,直至显示工具提示。也可以从“书籍”面板菜单中选择“文档信息”。

存储书籍文件

书籍文件独立于文档文件。例如,在选择“存储书籍”命令时,InDesign 会存储对书籍(而非对书籍中文档)的更改。

  1. 执行以下操作之一:
    • 要使用新名称存储书籍,请选择“书籍”面板菜单中的“将书籍存储为”,并指定一个位置和文件名,然后单击“保存”。

    • 要使用同一名称存储现有书籍,请选择“书籍”面板菜单中的“存储书籍”,或单击“书籍”面板底部的“存储”按钮 

注意:

如果通过服务器共享书籍文件,应确保使用了文件管理系统,以便不会意外地冲掉彼此所做的修改。

关闭书籍文件

  • 要关闭单个书籍,请选择书籍面板菜单中的“关闭书籍”。
  • 要关闭一起停放在同一面板中的所有打开的书籍,请单击“书籍”面板标题栏上的关闭按钮。

删除书籍文档

  1. 选择“书籍”面板中的文档。
  2. 选择“书籍”面板菜单中的“移去文档”。

删除书籍文件中的文档时,不会删除磁盘上的文件,而只会将该文档从书籍文件中删除。

替换书籍文档

  1. 选择“书籍”面板中的文档。
  2. 选择“书籍”面板菜单中的“替换文档”,找到要用来替换它的文档,然后单击“打开”。

在资源管理器或 Finder 中打开书籍文件

  1. 在“书籍”面板中,选择一个文档。

  2. 从“书籍”面板菜单中,选择“在资源管理器中显示”(Windows) 或“在 Finder 中显示”(Mac OS)。

随即会打开一个浏览器窗口,显示选定的文件。

同步书籍文档

对书籍中的文档进行同步时,指定的项目(样式、变量、主页、陷印预设、交叉引用格式、条件文本设置、编号列表和色板)将从样式源复制到指定的书籍文档中,并替换所有同名项目。

如果在要进行同步的文档中未找到样式源中的项目,则会添加它们。未包含在样式源中的项目则仍保留在要进行同步的文档中。

选择要同步的项目

  1. 选择“书籍”面板菜单中的“同步选项”。
  2. 选择要从样式源复制到其他书籍文档的项目。

    确保选择包含在其他样式定义中的所有样式。例如,对象样式可以包含段落和字符样式,而每个样式都包含色板。

  3. 选择“智能匹配样式组”可以避免复制已移入或移出样式组的具有唯一名称的样式。

    假设样式源在样式组内包含某个字符样式,正在同步的文档在样式组外包含该字符样式。如果选择了此选项,字符样式将移入同步文档的样式组内。

    如果未选择此选项,将在样式组中创建字符样式的第二个实例,并启用匹配样式源的选项。样式组外的字符样式不变。

    注意:

    如果文档包含多个同名样式(例如,样式组内的“字符样式 1”和样式组外的“字符样式 1”),则 InDesign 的行为将与未选择此选项时一样。为获得最佳效果,请使用唯一名称创建样式。

  4. 单击“确定”。

同步书籍文件中的文档

可以在关闭书籍中的文档后同步该书籍。InDesign 可打开已关闭的文档,随意进行更改,然后存储并关闭这些文档。在进行同步时,会更改但不存储处于“打开”状态的文档。

  1. 在“书籍”面板中,单击要作为样式源的文档旁边的空白框;样式源图标  指明哪个文档是样式源。
    选中的样式源
    选中的样式源

  2. 确保在“同步选项”对话框中选择了要从样式源复制的项目。
  3. 在“书籍”面板中,选择要与样式源文档同步的文档。如果未选中任何文档,将同步整个书籍。

    注意:

    要确保未选中任何文档,请单击编入书籍的文档下方的空白灰色区域,这可能需要滚动“书籍”面板或调整其大小。还可以按住 Ctrl (Windows) 键或 Command (Mac OS) 键,并单击选中的文档,从而对其取消选中。

  4. 选择“书籍”面板菜单中的“同步已选中的文档”或“同步书籍”,也可以单击“书籍”面板底部的“同步”按钮 

注意:

选择“编辑”>“还原”,将仅撤消对同步时处于“打开”状态的文档所做的更改。

同步主页

主页的同步方式与其他项目相同,即与样式源中的主页具有相同名称的主页(如 A-Master)将被替换。同步主页对于使用相同设计元素(如动态页眉和页脚)的文档非常有用。但是,若想保留非样式源文档的主页上的页面项目,则不要同步主页,或应创建不同名称的主页。

首次同步主页之后,文档页面上所有被覆盖的主页项目将从主页中分离。因此,如果打算同步书籍中的主页,最好在设计过程一开始就同步书籍中的所有文档。这样,被覆盖的主页项目将保持与主页的连接,从而可以继续根据样式源中修改的主页项目进行更新。

另外,最好只使用一个样式源来同步主页。如果采用不同的样式源进行同步,被覆盖的主页项目可能会与主页分离。如果需要使用不同的样式源进行同步,则同步之前应取消选择“同步选项”对话框中的“主页”选项。

转换以前 InDesign 版本中的书籍文件

对于在 InDesign 早期版本中创建的书籍文件,可以通过在 InDesign CS5 中打开然后存储该文件以实现转换。在同步、更新编号、打印、打包或导出已转换的书籍时,其中包含的文档也将转换为 InDesign CS5 格式。可以决定是覆盖原始文档文件,还是保留原始文档文件。

转换书籍文件以便在 InDesign CS5 中使用

  1. InDesign CS5 中,选取“文件”>“打开”。
  2. 选择在 InDesign 早期版本中创建的书籍文件,然后单击“确定”。

    如果该书籍文件中包含采用以前 InDesign 版本格式存储的文档,则会显示一条警告。

  3. 选择“书籍”面板菜单中的“将书籍存储为”。为转换的书籍文件指定一个新名称,然后单击“保存”。

转换书籍文件中的文档

  1. InDesign CS5 中打开书籍文件。
  2. 在“书籍”面板菜单中:
    • 如果希望在转换期间覆盖原始文档,则选择“自动文档转换”。

    • 如果希望保留原始文档并用新的名称存储转换后的文档,则取消选择“自动文档转换”。(书籍列表将得到更新,其中包括转换后的文件,而不包括原始文件。)

  3. 请执行下列操作之一来转换文档:
    • 选择“书籍”面板菜单中的“同步书籍”。(请参阅同步书籍文档。)

    • 选择“书籍”面板菜单中的“更新编号”>“更新所有编号”。

  4. 如果没有选择“自动文档转换”,则 InDesign 会提示您使用新名称存储每个已转换的文档。

注意:

在打印书籍或将书籍导出到 Adobe PDF 时,也将转换文档。

在书籍中编排页码、章节和段落

可以决定如何在书籍中编排页码、章节和段落。在书籍文件中,页面和章节的编号样式和起始编号由各个文档在“页码和章节选项”对话框或“文档编号选项”对话框中的设置决定。若要打开任一对话框,可以在文档中选择“版面”>“页码和章节选项”,或在“书籍”面板菜单中选择“文档编号选项”。

有关在文档中添加页码的信息,请参阅添加基本页码

对于编号段落(如插图列表),编号由段落样式中包含的编号列表样式定义确定。

页面范围显示在“书籍”面板中每个文档名称的旁边。默认情况下,当在编入书籍的文档中添加或删除页面,或对书籍文件进行更改(如重新排序、添加或删除文档)时,InDesign 会更新“书籍”面板中的页码和章节编号。如果关闭自动更新页码和章节编号的设置,可以手动更新书籍中的编号。

如果书籍更新后,页码不正确,则问题可能是因为“常规”首选项中显示的是绝对页码而不是章节页码。请参阅在“页面”面板中显示绝对页码或章节页码

如果文档处于“缺失”状态或无法打开,则页面范围会显示为“?” 从缺失文档应处位置到书籍结尾均指示:不知道准确的页面范围。更新编号前,应删除或替换缺失的文档。如果出现“正在使用”图标 ,表示使用其他计算机的用户已经在管理工作流程中打开了该文档。必须在此用户关闭该文档之后,您才能更新编号。

更改各文档的页码和章节编号选项

  1. 选择“书籍”面板中的文档。
  2. 选择“书籍”面板菜单中的“文档编号选项”,或在“书籍”面板中双击该文档的页码。
  3. 指定页码和章节编号选项。(请参阅文档编号选项。)
  4. 单击“确定”。

注意:

如果指定书籍中某文档的起始页码,而不是选择“自动页码”,则该文档将从指定页面处开始,相应地书籍中的所有后续文档页码会重新编排。

设置按奇数页或是偶数页开始编号

可以为书籍中的文档设置按奇数页或是偶数页开始编号。

  1. 选择“书籍”面板菜单中的“书籍页码选项”。
  2. 选择“在下一奇数页继续”或“在下一偶数页继续”。
  3. 选择“插入空白页面”以便将空白页面添加到任一文档的结尾处,而后续文档必须在此处从奇数或偶数编号的页面开始,然后单击“确定”。

关闭书籍中的自动页码设置

  1. 选择“书籍”面板菜单中的“书籍页码选项”。
  2. 取消选择“自动更新页面和章节页码”,然后单击“确定”。
  3. 要手动更新页码,请选择“书籍”面板菜单中的“更新编号”>“更新所有编号”。

    也可以只更新页码和节编号或只更新章编号和段落编号。

在书籍中使用顺序段落编号

要对插图列表、表或其他项目使用顺序段落编号,首先应定义一个在段落样式中使用的编号列表。定义的编号列表确定了在书籍中段落编号是否使用跨文档的顺序编号。

  1. 打开书籍中用作样式源的文档。
  2. 选择“文字”>“项目符号列表和编号列表”>“定义列表”。
  3. 单击“新建”定义一个列表,或选择一个现有列表然后选择“编辑”。
  4. 选择“跨文章继续编号”和“从书籍中的上一文档继续编号”。
  5. 单击“确定”。
  6. 定义一个使用编号列表的段落样式,并将其应用于包含该列表的各文档中的文本。(请参阅创建用于动态列表的段落样式。)

注意:

要确保书籍中的所有文档均使用相同的编号列表设置,请选择“同步选项”对话框中的“段落样式”和“编号列表”选项,然后对书籍进行同步。

使用书籍文件的一个好处是:通过单个命令即可输出编入书籍的选定文档或整个书籍,以便打印、印前检查、打包或导出为 EPUB 或 PDF。

  1. 在“书籍”面板中,执行以下操作之一:
    • 要输出特定的文档,请选择所需的文档。

    • 要输出整个书籍,请确保未选中任何文档。

  2. 选择“书籍”面板菜单中的某个输出命令(如“打印书籍”或“打印已选中的文档”)。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略