创建动态的 PDF 文档是一种创建交互式幻灯片的好方式。您可以创建具有按钮、影片和音频剪辑、超链接、书签和页面过渡效果的交互式文档。您还可以在 InDesign 中创建可转换为 Acrobat 格式的文档。

创建交互式 PDF 文档

您可以导出包含下列交互功能的 Adobe PDF 文档。

书签

在 InDesign 文档中创建的书签显示在 Adobe Acrobat 或 Adobe Reader 窗口左侧的“书签”选项卡中。每个书签都能跳转到 PDF 导出文件中的某个页面、文本或图形。请参阅书签

影片和声音剪辑

可以将影片和声音剪辑添加到文档中,也可以链接到 Internet 上的流式视频文件。这些影片和声音剪辑可在 PDF 导出文件中回放。请参阅影片和声音

超链接

在 PDF 导出文档中,单击超链接可以跳转到同一个文档的其他位置、其他文档或网站。请参阅超链接

交叉引用

在 PDF 导出文件中,交叉引用会将读者从文档的一个部分引导到另一部分。交叉引用在用户指南和参考手册中尤为有用。如果将含有交叉引用的文档导出为 PDF,则交叉引用将充当交互式超链接。请参阅交叉引用

页面过渡效果

在全屏模式中,在导出的 PDF 文件中翻页时,页面过渡效果将会应用某种装饰效果(例如溶解或划出效果)。请参阅页面过渡效果

  1. 选择文件 > 导出

  2. 指定文件的名称和位置。

  3. 如果您希望导出的 PDF 的名称与执行下一次导出的文档的名称相同,请选择使用 InDesign 文档名称作为输出文件名

  4. 对于“存储类型”(Windows) 或“存储格式”(Mac OS),请选择“Adobe PDF(交互)”,然后单击存储

  5. 指定导出至交互式 PDF 对话框中的选项,然后单击确定

“导出至交互式 PDF”选项

以下选项会出现在“导出至交互式 PDF”对话框中。

“常规”选项卡

页面

指示是包含文档中的所有页面还是一个页面范围。如果您选择“范围”,请指定一个页面范围,例如,将范围指定为“1-7, 9”,则可以打印第 1 至第 7 页以及第 9 页。请参阅指定要打印的页面

导出为

指示您是否要将文档导出为页面或跨页。

创建单独的 PDF 文件

选择此选项可为每个页面或跨页创建单独的 PDF。

视图

打开 PDF 时的初始视图设置。

版面

打开 PDF 时的初始版面。

演示文稿

选中“以全屏模式打开”,可以在 Adobe Acrobat 或 Adobe Reader 中显示 PDF 而不显示菜单和面板。要自动向前翻页,请选中“翻转页面的频率”并指定页面翻转间隔的秒数。

导出后查看

在默认 PDF 查看应用程序中打开新创建的 PDF 文件。

页面过渡效果

指定一个页面过渡效果,以便在导出时将其应用于所有页面。如果您使用“页面过渡效果”面板来指定过渡效果,请选中“通过文档”选项来使用这些设置。

表单和媒体

选择“包含全部”,以允许影片、声音和按钮在导出的 PDF 文件中进行交互。选择“仅限外观”,将正常状态的按钮和视频海报转变为静态元素。

嵌入页面缩览图

为 PDF 中的每一页嵌入缩略图预览,这会增加文件大小。当 Acrobat 5.0 和更高版本的用户查看和打印 PDF 时,请取消选择此设置;这些版本在您每次单击 PDF 的“页面”面板时,都会动态地生成缩略图。

创建 Acrobat 图层

将每个 InDesign 图层存储为 PDF 中的 Acrobat 图层。这些图层是完全可以导航的,允许 Acrobat 6.0 和更高版本的用户通过单个 PDF 生成此文件的多个版本。

创建带标签的 PDF

在导出过程中,基于 InDesign 支持的 Acrobat 标签的子集自动为文章中的元素添加标签。此子集包括段落识别、基本文本格式、列表和表。(导出为 PDF 之前,还可以在文档中插入并调整标签。请参阅将结构添加到 PDF。)

使用跳位顺序结构

在导出期间,使用通过“对象”>“交互”>“设置跳位顺序”指定的跳位顺序。 此选项仅适用于带标签的 PDF。

“压缩”选项卡

压缩

选择“JPEG(有损式压缩)”可以减少图像数据,但这样可能会降低图像品质。然而,它会尝试在最大程度减少信息损失的情况下缩小文件的大小。选择“JPEG 2000(无损式压缩)”可以导出无损式压缩的文件。选择“自动”可以让 InDesign 确定彩色图像和灰度图像的最佳品质。

JPEG 品质

指定导出图像中的细节量。品质越高,图像大小越大。如果选择“JPEG 2000(无损式压缩)”作为压缩方式,则此选项将变为灰色不可用状态。

分辨率

指定导出的 PDF 中位图图像的分辨率。如果查看者要在导出的 PDF 内放大基于像素的内容,则选择高分辨率尤为重要。选择高分辨率会显著地增加文件的大小。

“高级”选项卡

显示标题

选择当打开 PDF 时要在 Acrobat 标题栏中显示的内容。可用的选项包括“文档标题”和“文件名”。

语言

选择 PDF 的文档语言。这将确定导出的 PDF 的默认语言。如果所需语言不在列表中,您还可以键入标准语言 ISO 代码。

“安全性”选项卡

要求打开文档的口令

选择本选项来要求用户键入您指定打开文档口令。

文档打开口令

指定用户必须键入打开 PDF 文件的口令。

使用口令来限制文档的打印、编辑和其他任务

限制对 PDF 文件安全性设置的访问。如果文件在 Adobe Acrobat 中打开,用户可以查看文件但必须输入指定的许可口令,才能更改文件的“安全性”和“许可”设置。如果文件在 Illustrator、Photoshop 或 InDesign 中打开,用户必须输入许可口令,因为不能在仅查看模式下打开文件。

许可口令

指定要求更改许可设置的口令。如果选择前面的选项,本选项可用。

允许打印

指定允许用户用于 PDF 文档的打印级别。

禁止用户打印文档。

低分辨率 (150 dpi)

允许用户以不高于 150 dpi 的分辨率进行打印。打印速度可能较慢,因为每个页面都作为位图图像打印。

高分辨率

允许用户以任何分辨率进行打印,并将高质量的矢量输出定向到 PostScript 打印机和支持高质量打印高级功能的其它打印机。

允许更改

定义允许在 PDF 文档中执行的编辑操作。

禁止用户对“允许更改”菜单中列出的文档进行任何更改,例如,填写表单域和添加注释。

插入、删除和旋转页面

允许用户插入、删除和旋转页面,以及创建书签和缩览图。

填写表单域和签名

允许用户填写表单并添加数字签名。此选项不允许用户添加注释或创建表单域。

注释、填写表单域和签名

允许用户添加注释和数字签名,并填写表单。此选项不允许用户移动页面对象或创建表单域。

除了提取页面

允许用户编辑文档、创建并填写表单域、添加注释并添加数字签名。

启用复制文本、图像和其他内容

允许用户选择和复制 PDF 的内容。

为视力不佳者启用屏幕阅读器设备的文本辅助工具

允许视力不佳的用户用屏幕阅读器阅读文档,但是不允许他们复制或提取文档的内容。

启用纯文本元数据

允许用户复制和从 PDF 提取内容。选择此选项将允许存储/搜索系统和搜索引擎访问存储在此文档中的元数据。 

创建 PDF 表单(CS5.5 和 CS5)

尽管 InDesign 并没有提供用于添加表单字段的工具,但 Adobe Acrobat 可以实现这项功能。您可以在 InDesign 中创建一个表单,其中包含单选按钮、复选框和文本字段等字段的占位符。随后您可以导出 PDF,并使用 Acrobat 将占位符转换为表单字段。

  1. 在 InDesign 中,创建要用于该表单的文档。使用表格和文本框来创建用于这些字段的占位符。

    您还可以在 InDesign 中添加交互式按钮。

  2. 将文档导出为 Adobe PDF。

  3. 启动表单向导,将占位符转换为表单域。使用表单工具可以添加和编辑表单。有关更多信息,请参阅 Adobe Acrobat 文档。

    • 在 Acrobat X 中,选择“工具”>“表单”>“创建”启动表单向导。

    • 在 Adobe Acrobat 9 中,选择“表单”>“启动表单向导”。

其他资源

Acrobat 小组提供了一篇有关在 Adobe Acrobat 中设计自动域检测的表单的文章。

Michael Murphy 在 Acrobat 友好表单设计中提供了有关创建表单的视频教程。

Bob Bringhurst 在通过 InDesign 创建 PDF 表单中提供了有关设计表单的文章。

预览交互式文档

使用“预览”面板可以预览当前选定范围、当前跨页或整个文档的交互性和动画效果。您可以调整“预览”面板的大小、停放或浮动“预览”面板,也可以将其移至其他显示器。

  1. 选择“窗口”>“交互”>“预览”。

  2. 要预览交互和动画效果,请执行以下任意操作:

    • 单击“设置预览选定范围模式”按钮 ,可以预览当前所选的内容。

    • 单击“设置预览跨页模式”按钮 ,可以预览当前跨页。

    • 单击“设置预览文档模式”按钮 ,可以预览当前文档。

  3. 单击“播放预览”按钮 以预览所选范围、跨页或文档。如有必要,请在“预览”面板中单击这些交互式项目(如按钮)以对其进行测试。

    如果您要预览文档,则可以单击面板底部的“转至上一页”和“转至下一页”箭头,移至不同的页面。

注意:

如果您编辑了文档,则可以通过单击“预览”面板中的“播放预览”按钮来刷新预览。

在 Web 浏览器中预览文档

  1. 从“预览”面板菜单中选择“在浏览器中测试”

  2. 单击文档中的交互式项目以对其进行测试。

编辑预览设置

  1. 从“预览”面板菜单中选择“编辑预览设置”。

    “预览设置”对话框显示的是“导出 SWF”对话框的当前设置。

  2. 根据需要编辑设置。请参阅 SWF 导出选项

使用演示文稿模式

演示文稿模式可以按照演示文稿的形式显示当前的 InDesign 文档。在演示文稿模式下,应用程序菜单、面板、参考线以及框架边缘都是隐藏的。默认情况下,背景区域的颜色较深,这样是为了在文档大小比例与当前显示器尺寸不同时能够加以区分。

演示文稿模式是 Adobe 连接功能的一项非常有用的辅助功能。您可以通过使用“文件”>“共享我的屏幕”命令,启动 Web 会议。在启动屏幕共享后,您可以将自己的 InDesign 文档放到演示文稿模式下。

  1. 选择“视图”>“屏幕模式”>“演示文稿”。

  2. 使用以下任意按键操作。

    操作

    功能

    鼠标单击、向右箭头键或 Page Down 键

    下一跨页

    按下 Shift 键的同时单击鼠标、按下向右箭头键的同时单击鼠标、向左箭头键 或 Page Up 键

    上一跨页

    Esc

    退出演示文稿模式

    Home

    第一个跨页

    End

    最后一个跨页

    B

    将背景颜色更改为黑色

    W

    将背景颜色更改为白色

    G

    将背景颜色更改为灰色

注意:

无法在演示文稿模式下编辑文档。不过,如果有双屏幕的监视器,则可以为同一文档打开两个窗口,并将其中一个窗口放在演示文稿模式下。此方法可让您在设置为“正常”视图的窗口中编辑文档并立即在设置为“演示文稿模式”的窗口中查看效果。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略