用户指南 取消(C)

InDesign 中的阿拉伯语和希伯来语功能

  1. InDesign 用户指南
  2. 了解 InDesign
    1. InDesign 简介
      1. InDesign 的新功能
      2. 系统要求
      3. 常见问题
      4. 使用 Creative Cloud 库
    2. 工作区
      1. 工作区基础知识
      2. 工具箱
      3. 设置首选项
      4. 触控工作区
      5. 默认键盘快捷键
      6. 文档恢复和还原
      7. Capture 扩展
  3. 创建文档和设置文档版面
    1. 文档和页面
      1. 创建文档
      2. 使用主页
      3. 使用文档页面
      4. 设置页面大小、边距和出血
      5. 使用文件和模板
      6. 创建书籍文件
      7. 添加基本页码
      8. 编排页码和章节
      9. 转换 QuarkXPress 和 PageMaker 文档
      10. 共享内容
      11. 了解受管理文件的基本工作流程
      12. 存储文档
    2. 网格
      1. 网格
      2. 制定网格的格式
    3. 版面辅助工具
      1. 文档窗口中的
  4. 添加内容
    1. 文本
      1. 将文本添加到框架
      2. 串接文本
      3. InDesign 中的阿拉伯语和希伯来语功能
      4. 创建路径文字
      5. 项目符号和编号
      6. 字形和特殊字符
      7. 文本排版
      8. 文本变量
      9. 生成二维码
      10. 编辑文本
      11. 对齐文本
      12. 在对象周围绕排文本
      13. 定位对象
      14. 链接的内容
      15. 设置段落格式
      16. 设置字符格式
      17. 查找/更改
      18. 拼写检查和语言词典
    2. 排版规则
      1. 在 InDesign 中使用字体
      2. 字偶间距和字符间距
    3. 设置文本格式
      1. 设置文本格式
      2. 制表符和缩进
    4. 审阅文本
      1. 跟踪和检查更改
      2. 在 InDesign 中添加编辑附注
      3. 导入 PDF 注释
    5. 添加引用
      1. 创建目录
      2. 脚注
      3. 创建索引
      4. 尾注
      5. 题注
    6. 样式
      1. 段落样式和字符样式
      2. 对象样式
      3. 首字下沉和嵌套样式
      4. 使用样式
      5. 行距
      1. 设置表的格式
      2. 创建表
      3. 表和单元格样式
      4. 选择和编辑表
      5. 表描边和填色
    7. 交互性
      1. 超链接
      2. 动态 PDF 文档
      3. 书签
      4. 按钮
      5. 表单
      6. 动画
      7. 交叉引用
      8. 设置 PDF 结构
      9. 页面过渡效果
      10. 影片和声音
      11. 表单
    8. 图形
      1. 了解路径和形状
      2. 使用铅笔工具绘图
      3. 用钢笔工具绘图
      4. 应用线条(描边)设置 
      5. 复合路径与形状
      6. 编辑路径
      7. 剪切路径
      8. 更改角点外观
      9. 对齐和分布对象
      10. 链接和嵌入的图形
      11. 集成 AEM Assets
    9. 颜色和透明度
      1. 应用颜色
      2. 使用导入图形中的颜色
      3. 使用色板
      4. 混合油墨
      5. 色调
      6. 了解专色和印刷色
      7. 混合颜色
      8. 渐变
      9. 拼合透明图稿
      10. 添加透明度效果
  5. 共享
    1. 共享与协作        
    2. 共享以供审阅
    3. 审阅 InDesign 共享文档
    4. 管理反馈 
  6. 发布
    1. 导出和发布
      1. Publish Online
      2. 导出 EPUB 内容
      3. Adobe PDF 选项
      4. 将内容导出为 HTML
      5. 导出至 Adobe PDF
      6. 导出为 JPEG 格式
      7. 导出 HTML
      8. DPS 和 AEM Mobile 概述
    2. 打印
      1. 打印小册子
      2. 印刷标记和出血
      3. 打印文档
      4. 油墨、分色和网频
      5. 叠印
      6. 创建 PostScript 和 EPS 文件
      7. 提交前对文件执行印前检查
      8. 打印缩览图和超大文档
      9. 为服务提供商准备 PDF
      10. 准备打印分色
  7. 扩展 InDesign
    1. 自动化
      1. 数据合并
      2. 增效工具
      3. InDesign 中的 Capture 扩展
      4. 脚本

在中东和北非版本的此软件中,可通过阿拉伯语和希伯来语使用新的功能和改进功能。

Adobe World-Ready Composer

借助 Adobe World-Ready Composer,您可使用中东语言创建内容。您可以键入或混合键入阿拉伯语、希伯来语、英语、法语、德语、俄语和其他拉丁语。

可以在“段落”面板菜单中可用的书写器之间进行选择(“窗口”>“段落”>“面板菜单”)。例如,在 InDesign 中,您可以使用 Adobe World-Ready Paragraph Composer。或者,在 Illustrator 中使用中东语言单行书写器。

Adobe World-Ready Composer
Adobe World-Ready Composer

您也可以使用阿拉伯语和希伯来语名称来保存文件。

文本方向

要创建阿拉伯语和希伯来语内容,您可以将默认文本方向设置为自右向左 (RTL) 方向。并且,对于包含自左向右 (LTR) 文本的文档,您现在可以在两个方向之间无缝切换。

从“段落”面板中选择段落方向。

段落方向选择
段落方向选择

同一段落中包含多种语言时,您可以指定字符级的文本方向。此外,要在插入日期或数子,请在字符级指定文本方向。

从“字符”面板菜单中,选择“字符方向”,然后选择一种方向。

字符方向
字符方向

文章方向

如果使用阿拉伯语和希伯来语,文章的排版通常是从右到左。第一列必须位于框架的右侧,而后续列添加到左侧。如果您的版面包含混合内容,那么不同文章需要不同的方向。

“文章”面板(“窗口”>“文字和表”>“文章”)中,单击一个文章方向。

文章方向
文章方向

自动 Kashida 插入

在阿拉伯语中,通过添加 Kashidas 来对齐文本。Kashidas 会被添加到阿拉伯语字符中以延长字符串。空白处没有被修改。使用自动 Kashida 插入来对齐阿拉伯语文本的段落。

选择段落,并从“段落”面板(“窗口”>“文字和表”>“段落”)中的“插入 Kashida”下拉列表中选择一种设置。可用的选项包括:无、短、中等、长或文体。如果段落已对齐,将只会插入 Kashidas。此设置不适用于具有对齐设置的段落。

要向一组字符应用 Kashidas,请选择字符并从“字符”面板菜单中选择“Kashidas”。

自动 Kashidas
自动 Kashidas

连字

在阿拉伯语和希伯来语中,您可以向字符对自动应用连字。如果在给定的 Open Type 字体中有连字,则这些连字是特定字母对的印刷替代字符。

从“字符”面板菜单或“控制”面板菜单选择“连字”时,会产生该字体中定义的标准连字。

  1. 选择文本。
  2. 在“字符”面板菜单或“控制”面板菜单中选择“连字”。

不过,某些 Open Type 字体包含更多花饰和可选连字(选择“自由连字”后即可生成)。这些连字可在“字符面板”>“OpenType”>“自由连字”中找到。

启用连字
启用自动连字

变音符

在阿拉伯语中,音符或变音符是用来表示辅音长度或短元音的字形。变音符位于文字之上或之下。为获得更好的文本样式,或提高特定字体的可读性,您可以控制变音符的垂直或水平位置:

  1. 选择带有变音符的文本
  2. “字符”面板中,修改与文字关联的变音符的位置。您可以更改的值包括:“调整水平音符的位置”和“调整垂直音符的位置”。
更改变音符的位置
更改变音符的位置

从 Microsoft Word 中复制粘贴

您可以从 Microsoft Word 复制文本,并且将其粘贴至文档中。粘贴文本的对齐方式和方向将自动地设置为阿拉伯语或希伯来语文本的对齐方式和方向。

默认字体

安装中东或北非语言版本时,默认情况下,默认的键入字体将被设置为具体的安装语言。例如,如果您已经安装了启用英语/阿拉伯语的版本,默认字体将被设置为 Adobe Arabic。同样,如果您已经安装启用英语/希伯来语的版本,默认字体将被设置为 Adobe Hebrew(或在 Photoshop 中为 Myriad Hebrew)。

旧版字体支持情况

过去使用的字体(例如,AXT 字体),可以继续在此版本软件中使用。但是,建议在基于文本的元素中使用最新的 Open Type 字体。

默认情况下启用“丢失字形保护”(“编辑”>“首选项”>“高级文字”)。您所使用字体的字形不可用时,将自动处理文本。

数字类型

使用阿拉伯语或希伯来语时,您可以选择想要使用的数字类型。您可以在阿拉伯语、印度语和波斯语版本之间进行选择。

默认情况下,使用阿拉伯语时,自动选定印度语版本,使用希伯来语时,选择阿拉伯语文字数字。但是,您可以根据需要切换为阿拉伯数字:

  1. 在键入的文本中选择数字。
  2. 在“字符”面板中 (Ctrl + T),使用“数字”列表来选择数字必须显示的字体。

通过启用“键入阿拉伯文字时使用本地数字”选项,可以确保使用阿拉伯数字。要使用此选项,请选择“编辑”>“首选项”>“高级文字”。

数字类型选择
数字类型选择

连字

句子词语过多,在文本的一行内无法显示时,将自动换行至下一行。换行时,文本对齐类型有时会导致不必要的空格出现在该行,影响美观或语言正确性。连字符连接使您可以使用连字符在行的末尾拆分词。这种拆分方式可更好的给句子换行。

混合文本:Kashida 插入功能会影响混合文本中连字符连接的方式。启用 Kashida 插入时,会在适当位置插入 Kashida,并且不会用连字号连接非阿拉伯语文本。禁用 Kashida 功能时,只考虑对非阿拉伯语文本使用连字符连接。

希伯来语文本:允许使用连字符连接。要启用用连字符连接并自定义设置,请选择“段落面板”>“面板菜单”>“连字符连接设置”。

“连字符连接”选项
“连字符连接”选项

查找和替换

阿拉伯语和希伯来语用户可以执行全文搜索和替换。除了搜索和替换简单文本之外,您还可以搜索和替换具有特定特性的文本。这些特性可以包括变音符、Kashidas、特殊字符(例如,Alef)、不同语言的数字(例如,北印度语的数字)等等。

执行文本查找和替换:

  • InDesign“编辑”>“查找/更改”

在 InDesign 中,您可以使用“全角半角转换”选项卡(“编辑”>“查找/更改”)在阿拉伯语、北印度语和波斯语之间查找和替换数字。例如,您可以查找使用北印度语键入的数字,并将其转换为阿拉伯语。

字形

阿拉伯语和希伯来语用户可以应用默认字符集中的字形。但是,要从默认字符集或不同语言集浏览、选择和应用字形,请使用“字形”面板:

  • InDesign:“窗口”>“文字和表”>“字形”
  • Illustrator:“窗口”>“文字”>“字形”
浏览、选择和应用字形
浏览、选择和应用字形

对齐替代字

一种字体可以具有字母表中某些字母的替代形状。一些字母的字面变化一般可用于文体或书法目的。少数情况下,出于特殊需求会使用对齐替代字来对齐段落。

使用替代字时,可在段落级别启用对齐替代字。您也可以启用或禁用字符级的对齐替代字功能。只有集成有此功能的字体中,才可使用对齐替代字。因此,只有受支持的字体中才具有启用或禁用此功能的选项。

包含对齐替代字的阿拉伯语字体:Adobe Arabic、Myriad Arabic 和 Adobe Naskh。包含对齐替代字的希伯来语字体:Adobe Hebrew 和 Myriad Hebrew。

  • InDesign

段落级:“窗口”>“段落”面板> 面板菜单 >“字距调整”,然后从“字距调整”列表中选择一个选项。

字符级:“窗口”>“字符”面板 > 面板菜单>“对齐替代字”选项。

  • Photoshop

字符级:“窗口”>“字符”面板>“对齐替代字”复选框。

特殊中东字符的插入

阿拉伯语和希伯来语中的一些字符很难在文本中插入。此外,阿拉伯语和希伯来语键盘布局使得难以键入或包括这些字符。要插入像希伯来语省略号 (Geresh) 或 Maqaf 一样的字符,请从“字符”面板 > 面板菜单 >“插入特殊中东字符”中选择字符。

插入特殊的中东字符
插入特殊的中东字符

表方向

阿拉伯语和希伯来语用户可以设置插入文档中的表的方向。单元格和列顺序、默认语言和文本对齐方式会进行相应的设置。对于阿拉伯语用户,最右边的列是第一列,任何附加列都添加到表的最左列的左边。文章编辑器中也支持表方向 (Ctrl + Y)。

设置新表的方向:

  1. 单击“表”>“插入表”
  2. “插入表”对话框中,从“方向”列表中选择表方向。

更改现有表的方向:

  1. 将光标放置在表内
  2. 打开“表”面板 (Shift + F9),并单击“从左到右表”“从右到左表”图标以设置表的方向。

对于从右到左表,阿拉伯语和北非版本默认为阿拉伯语。希伯来语版本设置为希伯来语。对于从左到右表,阿拉伯语和希伯来语版本默认为英语。北非版本默认为法语。

装订方向

装订方向确定书籍沿其装订的边。使用从左到右语言编写的书籍在左侧装订。使用从右到左语言编写的文档则沿着书籍的最右侧边装订。

右侧装订书籍的页面布局
右侧装订书籍的页面布局

从右到左排版首选项

中性字符

阿拉伯语和希伯来语的一些字符的方向可能看起来含糊不清。字符方向不明晰可能会在字符串的方向和顺序上引起混乱。要确保此类字符的方向清楚、明确,请执行以下操作:

  1. 单击“编辑”>“首选项”>“从右到左”
  2. 选中“根据键盘输入强制中性字符方向”框。

光标控制

在使用键盘上的箭头键时,阿拉伯语和希伯来语用户可以控制光标移动的方向。此光标移动列表(“编辑”>“首选项”>“从右到左”)提供两个选项供您选择:

  • 可视:光标按照箭头键的方向移动。按下向右箭头时,屏幕上的光标向右移动。
  • 逻辑:光标按照键入语言的方向移动。在阿拉伯语和希伯来语中,当按下向右箭头时,光标向左移动(到从右到左语言中的下一个字符)。

页面和章节编号

阿拉伯语和希伯来语用户使用所在地区最常用的首选编号系统。最流行的编号系统有:

  • 阿拉伯语:阿拉伯字母和 Alef-Ba-Tah
  • 法语:希伯来语圣经标准和希伯来语非标准十进制

要选择或更改编号系统,请前往“版面”>“页码和章节选项”,然后从“样式”列表中选择。

对页面和章节进行编号
对页面和章节进行编号

画廊视图和文章编辑器中的排版方向

采用阿拉伯语或希伯来语时,您可以指示排版的方向。转到“编辑”>“首选项”>“文章编辑器显示”,并选中“指示排版方向”框,以启用此功能。启用此功能后,光标具有一个指示排版方向的箭头。

变音符着色

在阿拉伯语文本中,可以针对样式或其他目的对变音符进行不同的着色。例如,变音符可以在词或句子的特定方面进行强调。您可以使用“更改阿拉伯语变音符颜色”查询查找和更改变音符的颜色。

  1. 单击“编辑”>“查找/更改”
  2. “查询”列表中,选择“更改阿拉伯语变音符颜色”
  3. 使用“更改”“全部更改”“更改/查找”按钮,将旧的变音符替代为新颜色的变音符。

您可以根据需要修改和存储查询。

Adobe 徽标

登录到您的帐户

[Feedback V2 Badge]