表描边和填色

  1. InDesign 用户指南
  2. 了解 InDesign
    1. InDesign 简介
      1. InDesign 的新功能
      2. 系统要求
      3. 常见问题
      4. 使用 Creative Cloud 库
    2. 工作区
      1. 工作区基础知识
      2. 工具箱
      3. 设置首选项
      4. 触控工作区
      5. 默认键盘快捷键
      6. 文档恢复和还原
  3. 创建文档和设置文档版面
    1. 文档和页面
      1. 创建文档
      2. 使用主页
      3. 使用文档页面
      4. 设置页面大小、边距和出血
      5. 使用文件和模板
      6. 创建书籍文件
      7. 添加基本页码
      8. 编排页码和章节
      9. 转换 QuarkXPress 和 PageMaker 文档
      10. 共享内容
      11. 了解受管理文件的基本工作流程
      12. 存储文档
    2. 网格
      1. 网格
      2. 制定网格的格式
    3. 版面辅助工具
      1. 文档窗口中的
  4. 添加内容
    1. 文本
      1. 将文本添加到框架
      2. 串接文本
      3. InDesign 中的阿拉伯语和希伯来语功能
      4. 创建路径文字
      5. 项目符号和编号
      6. 字形和特殊字符
      7. 文本排版
      8. 文本变量
      9. 生成二维码
      10. 编辑文本
      11. 对齐文本
      12. 在对象周围绕排文本
      13. 定位对象
      14. 链接的内容
      15. 设置段落格式
      16. 设置字符格式
      17. 查找/更改
      18. 拼写检查和语言词典
    2. 排版规则
      1. 在 InDesign 中使用字体
      2. 字偶间距和字符间距
    3. 设置文本格式
      1. 设置文本格式
      2. 制表符和缩进
    4. 审阅文本
      1. 跟踪和检查更改
      2. 在 InDesign 中添加编辑附注
      3. 导入 PDF 注释
    5. 添加引用
      1. 创建目录
      2. 脚注
      3. 创建索引
      4. 尾注
      5. 题注
    6. 样式
      1. 段落样式和字符样式
      2. 对象样式
      3. 首字下沉和嵌套样式
      4. 使用样式
      5. 行距
      1. 设置表的格式
      2. 创建表
      3. 表和单元格样式
      4. 选择和编辑表
      5. 表描边和填色
    7. 交互性
      1. 超链接
      2. 动态 PDF 文档
      3. 书签
      4. 按钮
      5. 表单
      6. 动画
      7. 交叉引用
      8. 设置 PDF 结构
      9. 页面过渡效果
      10. 影片和声音
      11. 表单
    8. 图形
      1. 了解路径和形状
      2. 使用铅笔工具绘图
      3. 用钢笔工具绘图
      4. 应用线条(描边)设置 
      5. 复合路径与形状
      6. 编辑路径
      7. 剪切路径
      8. 更改角点外观
      9. 对齐和分布对象
      10. 链接和嵌入的图形
      11. 集成 AEM Assets
    9. 颜色和透明度
      1. 应用颜色
      2. 使用导入图形中的颜色
      3. 使用色板
      4. 混合油墨
      5. 色调
      6. 了解专色和印刷色
      7. 混合颜色
      8. 渐变
      9. 拼合透明图稿
      10. 添加透明度效果
  5. 共享
    1. 共享与协作        
    2. 共享以供审阅
    3. 审阅 InDesign 共享文档
    4. 管理反馈 
  6. 发布
    1. 导出和发布
      1. Publish Online
      2. 导出 EPUB 内容
      3. Adobe PDF 选项
      4. 将内容导出为 HTML
      5. 导出至 Adobe PDF
      6. 导出为 JPEG 格式
      7. 导出 HTML
      8. DPS 和 AEM Mobile 概述
    2. 打印
      1. 打印小册子
      2. 印刷标记和出血
      3. 打印文档
      4. 油墨、分色和网频
      5. 叠印
      6. 创建 PostScript 和 EPS 文件
      7. 提交前对文件执行印前检查
      8. 打印缩览图和超大文档
      9. 为服务提供商准备 PDF
      10. 准备打印分色
  7. 扩展 InDesign
    1. 自动化
      1. 数据合并
      2. 增效工具
      3. 脚本

关于表描边和填色

可以通过多种方式将描边(即表格线)和填色添加到表中。使用“表选项”对话框可以更改表边框的描边,并向列和行中添加交替描边和填色。要更改个别单元格或表头/表尾单元格的描边和填色,请使用“单元格选项”对话框,或者使用“色板”、“描边”和“颜色”面板。

默认情况下,使用“表选项”对话框选择的格式将覆盖以前应用于表单元格的任何相应格式。但是,如果在“表选项”对话框中选择“保留本地格式”选项,则不会覆盖应用于个别单元格的描边和填色。

如果要对表或单元格重复使用相同的格式,请创建并应用表样式或单元格样式。

更改表边框

可以使用“表设置”对话框或“描边”面板来更改表边框。

  1. 将插入点放置在单元格中,然后选择“表”>“表选项”>“表设置”。
  2. 在“表边框”下,指定所需的粗细、类型、颜色、色调和间隙设置。(请参阅表描边和填色选项。)
  3. 在“表格线绘制顺序”下,从下列选项中选择绘制顺序:

    最佳连接

    如果选中该选项,则在不同颜色的描边交叉点处行线将显示在上面。此外,当描边(如双线)交叉时,描边会连接在一起,并且交叉点也会连接在一起。

    行线在上

    如果选中该选项,行线会显示在上面。

    列线在上

    如果选中该选项,列线会显示在上面。

    InDesign 2.0 兼容性

    如果选中该选项,行线会显示在上面。此外,当多条描边(如双线)交叉时,它们会连接在一起,而仅在多条描边呈 T 形交叉时,多个交叉点才会连接在一起。

  4. 如果不希望个别单元格的描边格式被覆盖,请选择“保留本地格式”。
  5. 单击“确定”。
注意:

如果要删除表中的描边和填色,请选择“视图”>“其他”>“显示框架边缘”以显示表的单元格边界。

向单元格添加描边和填色

可以使用“单元格选项”对话框、“描边”面板或“色板”面板向单元格添加描边和填色。

使用单元格选项添加描边和填色

通过在“预览”代理示意图中选择或取消选择线,可以确定哪些单元格线是使用描边或填色格式。如果要更改表中所有行或列的外观,请使用交替描边或填色模式(其中,第二种模式设置为 0)。

  1. 使用“文字”工具 ,将插入点放置在要添加描边或填色的单元格中或选择这些单元格。要向表头/表尾行添加描边和填色,请选择位于表起始处的表头/表尾单元格。
  2. 选择“表”>“单元格选项”>“描边和填色”。
  3. 在代理预览区域中,指定哪些线将受描边更改的影响。例如,如果要向选定单元格的外部线而不是内部线添加粗描边,请单击某一内部线以将其取消选择。(选择的线条为蓝色;取消选择的线条为灰色。)
    在代理预览区域中选择要受影响的线条。

    注意:

    在代理预览区域中,双击任意外部线可以选定整个外矩形选取区域。双击任何内部线条可以选择内部线条。在代理中的任意位置单击三次可以选择或取消选择所有线条。

  4. 对于“单元格描边”,请指定所需的粗细、类型、颜色、色调和间隙设置。(请参阅表描边和填色选项。)
  5. 对于“单元格填色”,请指定所需的颜色和色调设置。
  6. 如果需要,选择“叠印描边”和“叠印填充”,然后单击“确定”。

使用“描边”面板为单元格添加描边

“描边”面板在 InDesign 中提供,在 InCopy 中不提供。

  1. 选择要影响的单元格。要将描边应用于表头单元格或表尾单元格,请选择表头行或表尾行。
  2. 选择“窗口”>“描边”以显示“描边”面板。
  3. 在代理预览区域中,指定哪些线将受描边更改的影响。
  4. 在“工具”面调板中,确保选中“对象”按钮  。(如果选中了“文本”按钮  ,则描边更改将影响文本而不影响单元格。)
  5. 指定粗细值和描边类型。

使用“色板”面板向单元格添加填色

  1. 选择要影响的单元格。要将填色应用于表头单元格或表尾单元格,请选择表头行或表尾行。
  2. 选择“窗口”>“颜色”>“色板”以显示“色板”面板。
  3. 确保选中“对象”按钮  。(如果选中了“文本”按钮  ,则颜色更改将影响文本而不影响单元格。)
  4. 选择一个色板。

使用“渐变”面板向单元格添加渐变

  1. 选择要影响的单元格。要将渐变应用于表头单元格或表尾单元格,请选择表头行或表尾行。
  2. 选择“窗口”>“颜色”>“渐变”以显示“渐变”面板。
  3. 单击“渐变曲线”,以便向选定单元格应用渐变。根据需要调整渐变设置。

向单元格添加对角线

  1. 使用“文字”工具 ,将插入点放置在要添加对角线的单元格中或选择这些单元格。
  2. 选择“表”>“单元格选项”>“对角线”。
  3. 单击要添加的对角线类型的按钮。
  4. 在“线条描边”下,指定所需的粗细、类型、颜色和间隙设置;指定“色调”百分比和“叠印”选项。
  5. 在“绘制”菜单中,选择“对角线置于最前”以将对角线放置在单元格内容的前面;选择“内容置于最前”以将对角线放置在单元格内容的后面,然后单击“确定”。

表描边和填色选项

为表或单元格选择描边和填色时,可使用下列选项:

粗细

为表或单元格边框指定线条的粗细度。

类型

指定线条样式,如“粗 - 细”。

颜色

指定表或单元格边框的颜色。列出的选项是“色板”面板中提供的选项。

色调

指定要应用于描边或填色的指定颜色的油墨百分比。

间隙颜色

将颜色应用于虚线、点或线条之间的区域。如果为“类型”选择了“实线”,则此选项不可用。

间隙色调

将色调应用于虚线、点或线条之间的区域。如果为“类型”选择了“实线”,则此选项不可用。

叠印

如果选中该选项,将导致“颜色”下拉列表中所指定的油墨应用于所有底色之上,而不是挖空这些底色。

在表中交替进行描边和填色

可以交替使用描边和填色来提高可读性或改善表的外观。表行中的交替描边和填色不会影响表头行和表尾行。但是,列中的交替描边和填色确实会影响表头行和表尾行。

除非在“表选项”对话框中选择“保留本地格式”选项,否则,交替描边和填色设置会覆盖单元格描边格式。

注意:

如果打算将某种填色或描边应用于表中的每个正文单元格,而不只是交替模式,则仍旧可以使用交替描边和填色设置来创建这种非交替模式。要产生这种效果,请在第二个模式中为“下一个”指定 0。

在表中交替填色之前(左)和之后(右)

向表中添加交替描边

  1. 将插入点放置在单元格中,然后选择“表”>“表选项”>“交替行线”或“交替列线”。
  2. 对于“交替模式”,请选择要使用的模式类型。如果要指定一种模式,请选择“自定”。例如,指定某一列使用黑色粗线,而随后的三列使用黄色细线。
  3. 在“交替”下,为第一种模式和下一种模式指定填色选项。例如,您可能想在第一列中添加一条实线描边,并在下一列中添加一条粗一细双线,以产生交替效果。如果想让描边影响每个行或列,请为“下一个”指定 0。
    注意:

    在跨多个框架的表中,行的交替描边和填色不会在文章中附加框架的开始处重新开始。(请参阅将表拆分到几个框架中。)

  4. 如果希望以前应用于表的格式描边保持有效,则请选择“保留本地格式”。
  5. 可在“跳过第一行”和“跳过最后一行”处,指定表的开始和结束处不希望其中显示描边属性的行数或列数,然后单击“确定”。

向表中添加交替填色

  1. 将插入点放置在单元格中,然后选择“表”>“表选项”>“交替填色”。
  2. 对于“交替模式”,请选择要使用的模式类型。如果要指定一种模式(如一个带有灰色阴影的行后面跟有三个带有黄色阴影的行),请选择“自定”。
  3. 在“交替”下,为第一种模式和后续模式指定填色选项。例如,如果为“交替模式”选择了“每隔两列”,则可以让前两列为灰色阴影,后两列为空白,依此交替下去。如果希望填色应用于每行,请为“下一个”指定 0。
  4. 如果希望以前应用于表的格式填色保持有效,则请选择“保留本地格式”。
  5. 可在“跳过第一行”和“跳过最后一行”处,指定表的开始和结束处不希望其中显示填色属性的行数或列数,然后单击“确定”。

关闭表中的交替描边和交替填色

  1. 将插入点放置在表中。
  2. 选择“表”>“表选项”>“交替行线”、“交替列线”或“交替填色”。
  3. 对于“交替模式”,请选择“无”,然后单击“确定”。

更多此类内容

Adobe 徽标

登录到您的帐户