选择和编辑表

  1. InDesign 用户指南
  2. 了解 InDesign
    1. InDesign 简介
      1. InDesign 的新功能
      2. 系统要求
      3. 常见问题
      4. 使用 Creative Cloud 库
    2. 工作区
      1. 工作区基础知识
      2. 工具箱
      3. 设置首选项
      4. 触控工作区
      5. 默认键盘快捷键
      6. 文档恢复和还原
  3. 创建文档和设置文档版面
    1. 文档和页面
      1. 创建文档
      2. 使用主页
      3. 使用文档页面
      4. 设置页面大小、边距和出血
      5. 使用文件和模板
      6. 创建书籍文件
      7. 添加基本页码
      8. 编排页码和章节
      9. 转换 QuarkXPress 和 PageMaker 文档
      10. 共享内容
      11. 了解受管理文件的基本工作流程
      12. 存储文档
    2. 网格
      1. 网格
      2. 制定网格的格式
    3. 版面辅助工具
      1. 文档窗口中的
  4. 添加内容
    1. 文本
      1. 将文本添加到框架
      2. 串接文本
      3. InDesign 中的阿拉伯语和希伯来语功能
      4. 创建路径文字
      5. 项目符号和编号
      6. 字形和特殊字符
      7. 文本排版
      8. 文本变量
      9. 生成二维码
      10. 编辑文本
      11. 对齐文本
      12. 在对象周围绕排文本
      13. 定位对象
      14. 链接的内容
      15. 设置段落格式
      16. 设置字符格式
      17. 查找/更改
      18. 拼写检查和语言词典
    2. 排版规则
      1. 在 InDesign 中使用字体
      2. 字偶间距和字符间距
    3. 设置文本格式
      1. 设置文本格式
      2. 制表符和缩进
    4. 审阅文本
      1. 跟踪和检查更改
      2. 在 InDesign 中添加编辑附注
      3. 导入 PDF 注释
    5. 添加引用
      1. 创建目录
      2. 脚注
      3. 创建索引
      4. 尾注
      5. 题注
    6. 样式
      1. 段落样式和字符样式
      2. 对象样式
      3. 首字下沉和嵌套样式
      4. 使用样式
      5. 行距
      1. 设置表的格式
      2. 创建表
      3. 表和单元格样式
      4. 选择和编辑表
      5. 表描边和填色
    7. 交互性
      1. 超链接
      2. 动态 PDF 文档
      3. 书签
      4. 按钮
      5. 表单
      6. 动画
      7. 交叉引用
      8. 设置 PDF 结构
      9. 页面过渡效果
      10. 影片和声音
      11. 表单
    8. 图形
      1. 了解路径和形状
      2. 使用铅笔工具绘图
      3. 用钢笔工具绘图
      4. 应用线条(描边)设置 
      5. 复合路径与形状
      6. 编辑路径
      7. 剪切路径
      8. 更改角点外观
      9. 对齐和分布对象
      10. 链接和嵌入的图形
      11. 集成 AEM Assets
    9. 颜色和透明度
      1. 应用颜色
      2. 使用导入图形中的颜色
      3. 使用色板
      4. 混合油墨
      5. 色调
      6. 了解专色和印刷色
      7. 混合颜色
      8. 渐变
      9. 拼合透明图稿
      10. 添加透明度效果
  5. 共享
    1. 共享与协作        
    2. 共享以供审阅
    3. 审阅 InDesign 共享文档
    4. 管理反馈 
  6. 发布
    1. 导出和发布
      1. Publish Online
      2. 导出 EPUB 内容
      3. Adobe PDF 选项
      4. 将内容导出为 HTML
      5. 导出至 Adobe PDF
      6. 导出为 JPEG 格式
      7. 导出 HTML
      8. DPS 和 AEM Mobile 概述
    2. 打印
      1. 打印小册子
      2. 印刷标记和出血
      3. 打印文档
      4. 油墨、分色和网频
      5. 叠印
      6. 创建 PostScript 和 EPS 文件
      7. 提交前对文件执行印前检查
      8. 打印缩览图和超大文档
      9. 为服务提供商准备 PDF
      10. 准备打印分色
  7. 扩展 InDesign
    1. 自动化
      1. 数据合并
      2. 增效工具
      3. 脚本

选择表单元格、行和列

在单元格中选择全部或部分文本时,所选内容和在表外选择文本看起来一样。但是,如果所选内容跨过多个单元格,则单元格及其内容将一并被选择。

如果表跨过多个框架,将鼠标指针停放在除第一个表头行或表尾行以外的任何表头行或表尾行时,就会出现一个锁形图标,表明您不能选择该行中的文本或单元格。要选择表头行或表尾行中的单元格,请转至表的开始位置。

选择单元格

  1. 使用“文字”工具 ,执行以下操作之一:
    • 要选择一个单元格,请单击单元格内部区域,或选中文本,然后选择“表”>“选择”>“单元格”。

    • 要选择多个单元格,请跨单元格边框拖动。小心不要拖动列线或行线,否则会改变表的大小。

注意:

要在选择单元格中的所有文本与选择单元格之间进行切换,请按 Esc 键。

选择整列或整行

  1. 使用“文字”工具 ,执行以下操作之一:
    • 单击单元格内部区域,或选中文本,然后选择“表”>“选择”>“列”或“行”。

    • 将指针移至列的上边缘或行的左边缘,以便指针变为箭头形状(),然后单击鼠标选择整列或整行。

选择行之前和之后

  1. 在表内单击,或选择文本。
  2. 选择“表”>“选择”>“表头行”、“正文行”或“表尾行”。

选择整个表

  1. 使用“文字”工具 ,执行以下操作之一:
    • 在表内单击,或选择文本,然后选择“表”>“选择”>“表”。

    • 将指针移至表的左上角,以便指针变为箭头形状 ,然后单击鼠标选择整个表。

    选择表之前和之后

    • 在整个表上拖动“文字”工具。
注意:

还可以用选择定位图形的方式选择表,即将插入点紧靠表的前面或后面放置,然后按住 Shift 键,同时相应地按向右箭头键或向左箭头键以选择该表。

插入行和列

可以用几种不同的方法插入行和列。

插入行

  1. 将插入点放置在希望新行出现的位置的下面一行或上面一行。
  2. 选择“表”>“插入”>“行”。
  3. 指定所需的行数。
  4. 指定新行应该显示在当前行的前面还是后面,然后单击“确定”。

新的单元格将具有与插入点放置行中的文本相同的格式。

注意:

还可通过在插入点位于最后一个单元格中时按 Tab 键创建一个新行。

插入列

  1. 将插入点放置在希望新列出现的位置旁的列中。
  2. 选择“表”>“插入”>“列”。
  3. 指定所需的列数。
  4. 指定新列应该显示在当前列的前面还是后面,然后单击“确定”。

新的单元格将具有与插入点放置列中的文本相同的格式。

插入多行和多列

  1. 将插入点放置在单元格中,然后选择“表”>“表选项”>“表设置”。
  2. 指定另外的行数和列数,然后单击“确定”。

新行将添加到表的底部;新列则添加到表的右侧。

注意:

还可以使用“表”面板来更改行数和列数。要显示“表”面板,请选择“窗口”>“文字和表”>“表”。

通过拖动的方式插入行或列

添加列时,如果拖动的距离超过了被拖动列宽度的 1.5 倍,就会添加与原始列等宽的新列。如果通过拖动来插入仅一个列,则该列可以比被拖动的列窄或宽。除非被拖动行的“行高”设置为“最少”,否则行也会出现这一情况。在这种情况下,如果通过拖动来仅创建一个行,则 InDesign 就会根据需要调整新行的高度,以便它达到可以包含文本的高度。

  1. 将“文字”工具 放置在列或行的边框上,以便显示双箭头图标( )。
  2. 按住鼠标按钮,然后在向下拖动或向右拖动时按住 Alt 键 (Windows) 或 Option 键 (Mac OS),即可分别创建新行或新列。(如果在按鼠标按钮之前按下 Alt 键或 Option 键,则会显示“抓手”工具,因此,一定要在按 Alt 键或 Option 键之前开始拖动。)
注意:

在表的顶部或左侧边缘,不能通过拖动来插入行或列。这些区域用于选择行或列。

删除行、列或表

  • 要删除行、列或表,请将插入点放置在表中,或者在表中选择文本,然后选择“表”>“删除”>“行”、“列”或“表”。
  • 要使用“表选项”对话框删除行和列,请选择“表”>“表选项”>“表设置”。指定另外的行数和列数,然后单击“确定”。行从表的底部被删除,列从表的右侧被删除。
  • 要使用鼠标删除行或列,请将指针放置在表的下边框或右边框上,以便显示双箭头图标()。按住鼠标按钮,然后在向上拖动或向左拖动时按住 Alt 键 (Windows) 或 Option 键 (Mac OS),以分别删除行或列。
注意:

如果在按鼠标按钮之前按下 Alt 键或 Option 键,则会显示“抓手”工具,因此,一定要在开始拖动后按 Alt 键或 Option 键。

  • 要删除单元格的内容而不删除单元格,请选择包含要删除文本的单元格,或使用“文字”工具选择单元格中的文本。按 Backspace 键或 Delete 键,或者选择“编辑”>“清除”。

更改框架中表的对齐方式

表会采用其创建时所在的段落或单元格的宽度。但是,可以更改文本框架或表的大小,使表比框架宽或窄。在这种情况下,可以决定表在框架中如何对齐。

  1. 将插入点放置在表的右侧或左侧。确保将文本插入点放置在表所在的段落中,而不是表的内部。该插入点所在的高度将和框架中表的高度对齐。
  2. 单击“段落”面板或“控制”面板中的一个对齐方式按钮(如“居中对齐”)。

在表中导航

使用 Tab 键或箭头键可以在表中移动。也可以跳转到特定的行,这在长表中尤其有用。

使用 Tab 键在表中移动

  • 按 Tab 键可以后移一个单元格。如果在最后一个单元格中按 Tab 键,则会新建一行。有关在表中插入制表符和缩进的信息,请参阅对表中的文本设置格式
  • 按 Shift+Tab 键可以前移一个单元格。如果在第一个单元格中按 Shift+Tab 键,插入点将移至最后一个单元格。

使用箭头键在表中移动

通过按箭头键,在表单元格内或表单元格之间浏览。如果在插入点位于某行的最后一个单元格的末尾时按向右箭头键,则插入点会移至同一行中第一个单元格的起始位置。类似地,如果在插入点位于某列的最后一个单元格的末尾时按向下箭头键,则插入点会移至同一列中第一个单元格的起始位置。

跳转到表中的特定行

  1. 选择“表”>“转至行”。
  2. 执行以下操作之一:
    • 指定要跳转到的行号,然后单击“确定”。

    • 如果当前表中定义了表头行或表尾行,请在菜单中选择“表头”或“表尾”,然后单击“确定”。

剪切、复制和粘贴表内容

对于在单元格内选择的文本,剪切、复制和粘贴操作和在表外选择的文本一样。还可以剪切、复制并粘贴单元格及其内容。如果粘贴时插入点位于表中,则多个粘贴的单元格会显示为表中表。还可以移动或复制整个表。

  1. 选择要剪切或复制的单元格,然后选择“编辑”>“剪切”或“复制”。
  2. 执行以下操作之一:
    • 要向表中再嵌入表,请将插入点放置在要显示嵌入表的单元格中,然后选择“编辑”>“粘贴”。

    • 要替换现有单元格,请在表中选择一个或多个单元格(确保选定单元格的下方和右边有足够的单元格),然后选择“编辑”>“粘贴”。

移动或复制表

  1. 要选择整个表,请将插入点放置在表中,然后选择“表”>“选择”>“表”。
  2. 选择“编辑”>“剪切”或“复制”,将插入点移至要显示表的位置,然后选择“编辑”>“粘贴”。

将表转换为文本

  1. 使用“文字”工具 ,将插入点放置在表中,或者在表中选择文本。
  2. 选择“表”>“将表转换为文本”。
  3. 对于列分隔符和行分隔符,请指定要使用的分隔符。

    为获得最佳效果,请对行和列使用不同的分隔符,如列使用制表符,行使用段落等。

  4. 单击“确定”。

将表转换为文本时,表格线会被去除并在每一行和列的末尾插入指定的分隔符。

组合表

使用“粘贴”命令将两个或两个以上表合并到一个表中。

  1. 在目标表中插入空行,插入的行数至少与要从其他表粘贴过来的行数相等。(如果插入的行数少于复制的行数,则无法粘贴。)
  2. 在源表中,选择要复制的单元格。(如果复制的单元格列数多于目标表中的可用单元格列数,则无法粘贴。)
  3. 至少选择一个要插入被复制行的单元格,然后选择“编辑”>“粘贴”。
注意:

如果所粘贴行的格式与表中其他行的格式不同,请定义一个或多个单元格样式,然后将定义的单元格样式应用于粘贴的单元格。单击此定义的单元格样式的同时按住 Alt 键 (Windows) 或 Option 键 (Mac OS) 即可覆盖现有的格式。

Anne-Marie Concepcion 在合并表中提供了一篇有关合并表的文章。

在文章编辑器处理表

选择“编辑”>“在文章编辑器中编辑”时,表及其内容将显示在文章编辑器中。您可以在文章编辑器中编辑表。

在文章编辑器中编辑表

A. “表”图标 B. 溢流图形 

  • 要在文章编辑器中展开或折叠表,请单击表顶部那个表图标左侧的三角形。

  • 要确定是按行还是按列对表进行排序,请右键单击 (Windows) 或按住 Ctrl 键并单击 (Mac OS) 表图标,然后选择“按行排序”或“按列排序”。

  • 使用“版面”视图可以修改表及设置表的格式。在文章编辑器中无法选择列和行。

Adobe 徽标

登录到您的帐户