通过动画效果,您可以使对象在导出的 SWF 文件中移动。例如,您可以在图像中应用移动预设,使其动感十足地从屏幕的左边缓缓飞入。使用以下工具和面板,可以为文档添加动画效果。

单击“播放”按钮可以查看动画
单击“播放”按钮可以查看动画

“动画”面板

应用移动预设并编辑诸如“持续时间”和“速度”之类的设置。

“直接选择工具”和“钢笔工具”

编辑动画对象经过的路径。

“计时”面板

确定页面上对象执行动画的顺序。

“预览”面板

在 InDesign 面板中查看动画。

注意:

鼠标悬停在按钮上方时的效果就是您可以在 InDesign 中添加的一种相关类型的动画。有关更多信息,请参阅“创建”按钮

来自 Infiniteskills.com 的 Jeff Witchel 提供了一个关于动画版面的视频概述。

使用移动预设为文档添加动画

移动预设是可以快速地应用于对象的预制动画。使用“动画”面板可以应用移动预设并更改诸如持续时间和速度之类的动画设置。您也可以通过“动画”面板指定执行动画对象的时间。

这些移动预设与 Adobe Flash CS5 Professional 中提供的移动预设相同。您可以导入任何在 Flash Professional 中创建的自定移动预设。您也可以存储自己创建的移动预设,然后在 InDesign 或 Flash Professional 中使用这些预设。

注意:

动画功能仅在导出 Adobe Flash Player (.SWF) 时受到支持。导出交互式 PDF 时不支持这些功能。要向 PDF 文件添加动画效果,请从 InDesign 将选定内容导出为 SWF 文件,然后将该 SWF 文件置入 InDesign 文档。

  1. 将要添加动画效果的对象置入文档。

  2. 在“动画”面板(“窗口”>“交互”>“动画”)中,从“预设”菜单中选择一个移动预设。

  3. 指定移动预设选项。

  4. 要编辑移动路径,请使用“钢笔工具”和“直接选择工具”。

  5. 使用“计时”面板可以确定这些动画效果的顺序。

  6. 使用“预览”面板可以在 InDesign 中预览动画。

要删除对象的动画效果,请选中该对象,然后单击“动画”面板中的“删除”图标。

注意:

当某些动画效果(如渐显效果)与页面过渡效果或卷边效果结合使用时,在“预览”面板或导出的 SWF 文件中,动画可能不会按预期的效果显示出来。例如,在翻页时,设置为“渐显”的对象最初本不该显示,但这些对象却会显示出来。要避免这种冲突,请不要在具有动画效果的页面上使用页面过渡效果,并关闭“SWF 导出”对话框中的“包含交互卷边”选项。与页面过渡效果和卷边效果一起使用时,可能无法按预期效果显示的移动预设包括:“显示”、“渐显”、各种“飞入”预设、“放大 (2D)”和“迅速移动”。

将选定的对象转换为移动路径

您可以通过先选择一个对象和路径,然后将该路径转换成移动路径的方式来创建动画。如果您选择了两个闭合路径(如两个矩形),则上层的路径会成为移动路径。

  1. 选中您要添加动画效果的对象和要用作移动路径的路径。

    您最多只能转换两个选定的对象。

  2. 在“动画”面板中,单击“转换为移动路径”按钮

  3. 更改“动画”面板中的设置。

移动预设选项

移动预设选项显示在“动画”面板中。单击“属性”选项可以显示高级设置。

名称

指定动画的名称。当设置触发动画的动作时,指定一个描述性的名称将会特别有用。

预设

可以从预定义的移动设置列表中进行选择。

事件

默认情况下,“载入页面”是选中的,即当页面在 SWF 文件中打开时就会播放动画对象。选择“单击页面”则可以在单击页面时触发动画。选择“单击鼠标(自行)”或“悬停鼠标(自行)”,可以分别在单击对象或将鼠标悬停在对象上时触发动画。如果您创建了可以触发动画的按钮动作,则“按钮事件”就会处于选中状态。(请参阅为按钮添加动作。)您可以指定多个事件来触发动画。

如果您选中了“悬停鼠标(自行)”事件,则还可以选择“鼠标指针移开时还原”。当鼠标移开对象时,此选项会还原动画的动作。

创建按钮触发器

单击此按钮可以通过现有对象或按钮触发动画。在单击“创建按钮触发器” 后,请单击触发动画的对象。如有必要,该对象会转换为一个按钮,且同时会打开“按钮”面板。

持续时间

指定动画发生时持续的时间。

播放

指定播放动画的次数,或者可以选择“循环”,使动画重复播放直至被终止。

速度

选择一个选项以确定动画是以稳定速率(无)执行,还是开始时缓慢然后逐渐加速(渐入),亦或是结束时逐渐减速(渐出)。

注意:

当展开“属性”时,以下选项有效。

制作动画

选择“起始时使用当前外观”,可以使用对象的当前属性(缩放比例、旋转角度和位置)作为动画的起始外观。

选择“结束时使用当前外观”,可以使用对象的属性作为动画的结束外观。此选项非常适合在幻灯片中使用。例如,从页面外飞入的对象可以显示在页面上而不显示在粘贴板上,从而改善了印刷文档的外观。

选择“结束时回到当前位置”可以使用当前对象的属性作为运行时动画的起始外观,并使用当前位置作为结束位置。此选项类似于“起始时使用当前外观”,只是结束时对象回到了当前位置,且移动路径发生了偏移。此选项对于特定的预设(如模糊和渐隐)非常有用,可以防止对象在动画结束时显示不正常。

注意:

要在移动路径的末尾显示代理,请单击“动画”面板底部的“显示动画代理”。

制作动画设置
制作动画设置

A. 执行动画前的对象和路径 B. 起始时使用当前外观 C. 结束时使用当前外观 D. 结束时回到当前位置 

旋转

指定动画期间对象完成的旋转角度。

原点

使用代理以指定动画对象上移动路径的原点。

缩放

指定播放期间对象放大或缩小的百分比。

不透明度

选择一个选项以确定动画是始终显示(无),还是逐渐显示(渐显),亦或是逐渐消失(渐隐)。

可见性

选择“执行动画前隐藏”或“执行动画后隐藏”,可以使对象在播放前或播放后不可见。

管理移动预设

您可以将动画设置存储为可在 InDesign 中轻松复用的移动预设。您也可以从能够在 Flash Professional 中打开或与其他 InDesign 用户共享的 XML 文件中导入预设。

存储移动预设以便重复使用

自定预设显示在“动画”面板中“预设”菜单的顶部。

  1. 在“动画”面板中,根据需要更改设置。

  2. 从“动画”面板菜单中选择“存储”。

  3. 键入预设的名称,然后单击“确定”。

删除自定的移动预设

使用“管理预设”对话框可以删除您存储、复制或导入的移动预设。无法删除 InDesign 安装时自带的移动预设。删除某个移动预设时,该预设会同时从“预设”菜单和计算机中删除。

  1. 从“动画”面板菜单中选择“管理预设”。

  2. 选择要删除的预设,然后单击“删除”。

复制移动预设

  1. 从“动画”面板菜单中选择“管理预设”。

  2. 选择要复制的预设,然后单击“复制”。

将移动预设存储为 XML 文件

当您希望与其他 InDesign 用户共享移动预设,或要在 Flash Professional 中打开移动预设时,将移动预设存储为 XML 文件会特别有用。

将移动预设存储为 XML 文件时,移动路径会连同持续时间、速度、缩放、旋转和不透明度设置一起存储。

  1. 从“动画”面板菜单中选择“管理预设”。

  2. 选择一个预设,然后单击“存储为”

  3. 指定移动预设的名称和位置,然后单击“保存”。

导入移动预设

您可以导入那些已经从 InDesign 或 Flash Professional 中作为 XML 文件导出的移动预设。

  1. 从“动画”面板菜单中选择“管理预设”。

  2. 单击“载入”。

  3. 双击您要导入的 .xml 文件。

编辑移动路径

选择具有动画效果的对象时,移动路径会显示在该对象的旁边。

移动路径
移动路径

A. 起始点 B. 结束点 
  1. 要编辑移动路径,请执行以下任意操作:

    • 通过使用与编辑路径相同的方法,利用“直接选择工具”和“钢笔工具”来编辑移动路径。请参阅编辑路径

    • 要通过现有路径创建移动路径,请选择一个路径和对象,然后单击“动画”面板中的“转换为移动路径”按钮

    • 要更改路径的方向,请单击“动画”面板中的“属性”,然后从“制作动画”菜单中选择一个设置。(请参阅移动预设选项。)您也可以先选择移动路径,然后选择“对象”>“路径”>“反转路径”。如果您要还原路径而不移动对象,请依次删除动画、还原路径,然后重做动画。

使用“计时”面板更改动画顺序

使用“计时”面板可以更改动画对象播放的时间顺序。“计时”面板可以根据指定给每个动画的页面事件列出当前跨页上的动画。例如,您可以更改一组在页面载入时发生的动画,然后更改一组在单击页面时发生的动画。

动画对象会按其创建的时间顺序列出。默认情况下,为“载入页面”事件列出的动画会连续地发生。为“单击页面”事件列出的动画会在每次单击页面时依次播放。

您可以更改动画顺序,使对象同时播放,也可以延迟动画的播放。

  1. 选择“窗口”>“交互”>“计时”以显示“计时”面板。

  2. 要确定是否编辑“载入页面”或“单击页面”事件的计时,请从“事件”菜单中选择一个选项。

    仅当有一个或多个项目分配到该事件时,才会发生“载入页面”和“单击页面”事件。

  3. 要编辑计时,请执行以下任意操作:

    • 要更改动画顺序,请上下拖动列表中的项目。最上面的项目最先执行动画。

    • 要延迟动画,请选中该项目,然后指定延迟的秒数。

    • 要一起播放多个动画对象,请在列表中选中这些项目,然后单击“一起播放”按钮 以链接这些项目。按下 Shift 键的同时单击鼠标可以选择一个项目范围,按下 Ctrl (Windows) 或 Command (Mac OS) 键的同时单击鼠标可以选择多个不相邻的项目。

    • 如果您不希望一个或多个链接的项目一起播放,请将其选中,然后单击“单独播放”按钮

    • 要播放特定次数的链接项目或循环进行播放,请选中所有链接在一起的项目,然后指定动画播放次数,或选择“循环”。

    • 要更改触发动画的事件,请选中该项目,然后选择“重新指定为‘载入页面’”或“重新指定为‘单击页面’”。

    • 要将某个项目从当前选定的事件(如“载入页面”或“单击页面”)中删除,请选中“删除项目”。如果未对项目指定任何事件,则该项目会出现在“未指定”类别中,您可以从“事件”菜单中选择该类别。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略