提交前对文件执行印前检查

  1. InDesign 用户指南
  2. 了解 InDesign
    1. InDesign 简介
      1. InDesign 的新功能
      2. 系统要求
      3. 常见问题
      4. 使用 Creative Cloud 库
    2. 工作区
      1. 工作区基础知识
      2. 工具箱
      3. 设置首选项
      4. 触控工作区
      5. 默认键盘快捷键
      6. 文档恢复和还原
  3. 创建文档和设置文档版面
    1. 文档和页面
      1. 创建文档
      2. 使用主页
      3. 使用文档页面
      4. 设置页面大小、边距和出血
      5. 使用文件和模板
      6. 创建书籍文件
      7. 添加基本页码
      8. 编排页码和章节
      9. 转换 QuarkXPress 和 PageMaker 文档
      10. 共享内容
      11. 了解受管理文件的基本工作流程
      12. 存储文档
    2. 网格
      1. 网格
      2. 制定网格的格式
    3. 版面辅助工具
      1. 文档窗口中的
  4. 添加内容
    1. 文本
      1. 将文本添加到框架
      2. 串接文本
      3. InDesign 中的阿拉伯语和希伯来语功能
      4. 创建路径文字
      5. 项目符号和编号
      6. 字形和特殊字符
      7. 文本排版
      8. 文本变量
      9. 生成二维码
      10. 编辑文本
      11. 对齐文本
      12. 在对象周围绕排文本
      13. 定位对象
      14. 链接的内容
      15. 设置段落格式
      16. 设置字符格式
      17. 查找/更改
      18. 拼写检查和语言词典
    2. 排版规则
      1. 在 InDesign 中使用字体
      2. 字偶间距和字符间距
    3. 设置文本格式
      1. 设置文本格式
      2. 制表符和缩进
    4. 审阅文本
      1. 跟踪和检查更改
      2. 在 InDesign 中添加编辑附注
      3. 导入 PDF 注释
    5. 添加引用
      1. 创建目录
      2. 脚注
      3. 创建索引
      4. 尾注
      5. 题注
    6. 样式
      1. 段落样式和字符样式
      2. 对象样式
      3. 首字下沉和嵌套样式
      4. 使用样式
      5. 行距
      1. 设置表的格式
      2. 创建表
      3. 表和单元格样式
      4. 选择和编辑表
      5. 表描边和填色
    7. 交互性
      1. 超链接
      2. 动态 PDF 文档
      3. 书签
      4. 按钮
      5. 表单
      6. 动画
      7. 交叉引用
      8. 设置 PDF 结构
      9. 页面过渡效果
      10. 影片和声音
      11. 表单
    8. 图形
      1. 了解路径和形状
      2. 使用铅笔工具绘图
      3. 用钢笔工具绘图
      4. 应用线条(描边)设置 
      5. 复合路径与形状
      6. 编辑路径
      7. 剪切路径
      8. 更改角点外观
      9. 对齐和分布对象
      10. 链接和嵌入的图形
      11. 集成 AEM Assets
    9. 颜色和透明度
      1. 应用颜色
      2. 使用导入图形中的颜色
      3. 使用色板
      4. 混合油墨
      5. 色调
      6. 了解专色和印刷色
      7. 混合颜色
      8. 渐变
      9. 拼合透明图稿
      10. 添加透明度效果
  5. 共享
    1. 共享与协作        
    2. 共享以供审阅
    3. 审阅 InDesign 共享文档
    4. 管理反馈 
  6. 发布
    1. 导出和发布
      1. Publish Online
      2. 导出 EPUB 内容
      3. Adobe PDF 选项
      4. 将内容导出为 HTML
      5. 导出至 Adobe PDF
      6. 导出为 JPEG 格式
      7. 导出 HTML
      8. DPS 和 AEM Mobile 概述
    2. 打印
      1. 打印小册子
      2. 印刷标记和出血
      3. 打印文档
      4. 油墨、分色和网频
      5. 叠印
      6. 创建 PostScript 和 EPS 文件
      7. 提交前对文件执行印前检查
      8. 打印缩览图和超大文档
      9. 为服务提供商准备 PDF
      10. 准备打印分色
  7. 扩展 InDesign
    1. 自动化
      1. 数据合并
      2. 增效工具
      3. 脚本

“印前检查”面板概述

打印文档或将文档提交给服务提供商之前,可以对此文档进行品质检查。印前检查是此过程的行业标准术语。有些问题会使文档或书籍的打印或输出无法获得满意的效果。在编辑文档时,如果遇到这类问题,“印前检查”面板会发出警告。这些问题包括文件或字体缺失、图像分辨率低、文本溢流及其他一些问题。

您可以配置印前检查设置,定义要检测的问题。这些印前检查设置存储在印前检查配置文件中,以便重复使用。您可以创建自己的印前检查配置文件,也可以从打印机或其他来源导入。

要利用实时印前检查,请在文档创建的早期阶段创建或指定一个印前检查配置文件。如果打开了“印前检查”,则 InDesign 检测到其中任何问题时,都将在状态栏中显示一个红圈图标。您可以打开“印前检查”面板并查看“信息”部分,获得有关如何解决问题的基本指导。

“印前检查”面板

A. 选定的错误 B. 单击页码可查看页面项目 C. “信息”区域提供了有关如何解决选定问题的建议 D. 指定页面范围以限制错误检查 

打开“印前检查”面板

  • 选择窗口 > 输出 > 印前检查

  • 双击文档窗口底部的“印前检查”图标。如果没有检测到任何错误,“印前检查”图标显示为绿色;如果检测到错误,则显示为红色。

定义印前检查配置文件

默认情况下,对新文档和转换文档应用“[基本]”配置文件。此配置文件将标记缺失的链接、修改的链接、溢流文本和缺失的字体。您不能编辑或删除“[基本]”配置文件,但可以创建和使用多个配置文件。例如,在以下情形中,可以切换不同的配置文件:处理不同的文档;使用不同的打印服务提供商;以及在不同生产阶段中使用同一个文件。

请咨询您的印前服务提供商,获取配置文件或了解印前检查配置文件的设置。

定义印前检查配置文件

  1. 从“印前检查”面板菜单或文档窗口底部的“印前检查”菜单中,选择定义配置文件

  2. 单击新建印前检查配置文件 图标 , 然后指定配置文件的名称。

  3. 在每个类别中,指定印前检查设置。框中的选中标记表示包括所有设置。空框表示未包括任何设置。

    链接

    确定缺失的链接和修改的链接是否显示为错误。

    颜色

    确定需要何种透明混合空间,以及是否允许使用 CMY 印版、色彩空间、叠印等项。

    图像和对象

    指定图像分辨率、透明度、描边宽度等项要求。

    文本

    “文本”类别显示缺失字体、溢流文本等项错误。

    文档

    指定对页面大小和方向、页数、空白页面以及出血和辅助信息区设置的要求。

  4. 请先选择存储,以保留对一个配置文件的更改,然后再处理另一个配置文件。或单击确定,以关闭对话框并存储所有更改。

嵌入和非嵌入的配置文件

嵌入配置文件时,配置文件成为文档的一部分。将文件发送给他人时,嵌入配置文件尤为有用。仅仅因为嵌入了配置文件,并不表明必须使用该配置文件。例如,您将带有嵌入配置文件的文档发送给打印服务机构后,打印操作员可以选择对文档使用其他配置文件。

只能嵌入一个配置文件。无法嵌入“[基本]”配置文件。

  1. 要嵌入一个配置文件,请在“配置文件”列表中选择它,然后单击“配置文件”列表右侧的“嵌入”图标

    还可以在“定义配置文件”对话框中嵌入配置文件。

  2. 要取消嵌入一个配置文件,请从“印前检查”面板菜单中选择定义配置文件,选择所需的配置文件,然后从对话框左侧的“印前检查配置文件菜单”中选择取消嵌入配置文件

导出和载入配置文件

您可以导出配置文件供他人使用。导出的配置文件以扩展名 .idpp 存储。

注意:

导出配置文件是备份配置文件设置的一个好办法。当恢复首选项时,配置文件信息将重置。要恢复首选项,您可以载入导出的配置文件。

您也可以载入他人提供的配置文件。您可以载入 *.idpp 文件,也可以载入您指定文档中的嵌入配置文件。

  • 要导出配置文件,请从“印前检查”菜单中选择定义配置文件。从“印前检查配置文件菜单”中选择导出配置文件,指定名称和位置,然后单击存储
  • 若要载入(导入)配置文件, 从 “印前检查”菜单中选择定义配置文件。从“印前检查配置文件菜单”中选择载入配置文件,选择包含要使用的嵌入配置文件的 *.idpp 文件或文档,然后单击打开

删除配置文件

  1. 从“印前检查”菜单中选择定义配置文件

  2. 选择要删除的配置文件,然后单击删除印前检查配置文件 图标 

  3. 单击确定以删除配置文件。

查看和解决印前检查错误

错误列表中只列出了有错误的类别。您可以单击每一项旁边的箭头,将其展开或折叠。

查看错误列表时,请注意下列问题:

  • 在某些情况下,是色板、段落样式等设计元素造成了问题。此时不会将设计元素本身报告为错误。而是将应用有该设计元素的所有页面项列在错误列表中。在这种情况下,请务必解决设计元素中的问题。

  • 溢流文本、隐藏条件或附注中出现的错误不会列出。修订中仍然存在的已删除文本也将忽略。

  • 如果未曾应用某个主页,或者当前范围的页面未应用此主页,则不会列出该主页上有问题的项目。如果某个主页项目存在错误,即使应用了该主页的每个页面上重复出现该错误,“印前检查”面板也只列出一次该错误。

  • 对于非打印页面项、粘贴板上的页面项或者隐藏或非打印图层中出现的错误,只有当“印前检查选项”对话框中指定了相应的选项时,它们才会显示在错误列表中。

  • 要仅输出某些页面,您可以将印前检查限制在页面范围内。在“印前检查”面板的底部指定页面范围。

打开或关闭实时印前检查

默认情况下,对所有文档打开印前检查。

  1. 要对现用文档打开或关闭 印前检查, 请选择“印前检查”面板左上角的“开”选项,或从文档窗口底部的“印前检查“菜单中选择印前检查文档

  2. 要对现用文档打开或关闭 印前检查, 从“印前检查“面板菜单中选择对所有文档启用印前检查

解决错误

  1. 在错误列表中,双击某一行或单击“页面”栏中的页码可以查看该页面项。

  2. 单击“信息”左侧的箭头可以查看有关所选行的信息。

    “信息”面板包括问题描述,并提供了有关如何解决问题的建议。

  3. 修复错误。

选择另一个配置文件

在很多工作流程中,使用不同的配置文件都是很有用的。例如,可以为同时编辑的各个文档选择不同的配置文件,或者可以选择一个新的配置文件,以开始一个新的生产阶段。当选择另一个配置文件时,将重新检查文档。

  1. 打开文档。

  2. 在“印前检查”面板中,从“配置文件”菜单中选择一个配置文件。

如果希望每次处理此文档时都使用此配置文件,请嵌入该配置文件。否则,打开此文档时将使用默认的工作配置文件。

指定印前检查的页面范围

  1. 在“印前检查”面板的底部指定页面范围(例如,1-8)。

指定页面范围的规则与“打印”对话框中的规则相同。此页面范围之外的页面上出现的错误不会列在错误列表中。

设置印前检查选项

  1. 从“印前检查”面板菜单中选择“印前检查选项”。

  2. 指定下列选项,然后单击“确定”。

    工作中的配置文件

    选择用于新文档的默认配置文件。如果要将工作配置文件嵌入新文档中,请选中“将工作中的配置文件嵌入新建文档”。请参阅定义预检配置文件

    使用嵌入配置文件/使用工作中的配置文件

    打开文档时,请确定印前检查操作是使用该文档中的嵌入配置文件,还是使用指定的工作配置文件。

    图层

    指定印前检查操作是包括所有图层上的项、可见图层上的项,还是可见且可打印图层上的项。例如,如果某个项位于隐藏图层上,您可以阻止报告有关该项的错误。

    非打印对象

    选中此选项后,将对“属性”面板中标记为非打印的对象报错,或对应用了“隐藏主页项目”的页面上的主页对象报错。

    粘贴板上的对象

    选中此选项后,将对粘贴板上的置入对象报错。

限制每条错误的行数

限制每条错误的行数可使错误列表更易于管理。例如,在使用 TrueType 字体的文档中,文档中使用的一个 TrueType 字体可能会生成数百个错误。如果将每个错误的行数限制为 25,则列表中只显示前 25 个错误,并在错误旁注明 (25+)。

  1. 从“印前检查”面板菜单中选择限制每个错误的行数,然后指定一个数字。

存储错误报告

您可以选择生成纯文本或 PDF 文件来列出“印前检查”面板中显示的错误。该报告还包括其他统计数据,如时间、文档名称和配置文件名称。

注意:

要获得包括使用的所有字体、油墨、链接及其他项的完整文档清单,请使用“打包”功能来创建报告。

  1. 从“印前检查”面板菜单中选择存储报告

  2. 存储类型 (Windows) 或存储格式 (Mac OS) 菜单中,指定要将文件存储为 PDF 文件还是文本文件。

  3. 指定报告的名称和位置,然后单击存储

印前检查书籍

从“书籍”面板菜单选择“印前检查书籍”后,将检查所有文档(或所有选定的文档)是否存在错误。您可以使用每个文档中的嵌入配置文件,也可以指定要使用的配置文件。绿色、红色或问号图标表示了每个文档的印前检查状态。绿色表示文档没有报错。红色表示有错误。问号表示状态未知。例如,文档可能已关闭、印前检查可能已关闭,或印前检查配置文件已更改。

设置书籍中的印前检查选项

  1. 从“书籍”面板菜单中选择印前检查书籍

  2. 在“印前检查书籍选项”对话框中,指定印前检查选项是要应用到整个书籍,还是仅应用到所选文档。

  3. 在“印前检查配置文件”下,指明是使用在“使用配置文件”菜单中指定的配置文件,还是使用每个文档中的嵌入配置文件。

    指定的配置文件将暂时用于每个文档。在关闭和打开各个文档时,将使用工作配置文件或嵌入的配置文件,具体取决于“印前检查选项”对话框中指定的选项。

  4. 在“包含”下,确定在错误列表中包含哪些项。

    图层

    指定印前检查操作是包括所有图层上的项、可见图层上的项,还是可见且可打印图层上的项。例如,如果某个项位于隐藏图层上,您可以选择不查看针对该项报告的错误。

    粘贴板上的对象

    选中此选项后,将对粘贴板上的置入对象报错。

    非打印对象

    选中此选项后,将对“属性”面板中标记为非打印的对象报错。

  5. 选择生成报告可生成包含错误列表的文本文件或 PDF 文件。所生成的报告将列出书籍中的所有错误。

  6. 单击印前检查

解决书籍中的印前检查错误

当“书籍”面板中某个文档名称的右侧显示红点时,表示该文档包含印前检查错误。

  1. 在“书籍”面板中,双击包含错误的文档。

  2. 可以使用“印前检查”面板查看每个文档中的错误,然后进行必要的更改以修复问题。

样式、色板等设计元素可能会造成错误。在这种情况下,请务必解决样式源文档中的样式或色板错误,然后同步书籍。

如果为书籍印前检查指定的配置文件不是嵌入的文档配置文件,切记,再次打开该文档时,可能会选择不同的配置文件。不同的配置文件可能会产生不同的印前检查错误。

包文件

可以收集使用过的文件(包括字体和链接图形),以轻松地提交给服务提供商。打包文件时,可创建包含 InDesign 文档(或书籍文件中的文档)、任何必要的字体、链接的图形、文本文件和自定报告的文件夹。此报告(存储为文本文件)包括“打印说明”对话框中的信息,打印文档需要的所有使用的字体、链接和油墨的列表,以及打印设置。

InDesign 将执行最新的印前检查。“打包清单”对话框中会指明所有检测出问题的区域。也可将根据文档或 PostScript 文件制作的复合 PDF 文件提供给服务提供商。

  1. 要打开“打包”对话框,执行以下操作之一:
    • 选择文件 > 打包。(如果“文件”菜单中没有出现“打包”选项,请尝试选择一个不同的工作区,如窗口 > 工作区 > 高级。)

    • 在“书籍”面板菜单中,选择打包书籍打包所选文档,具体取决于是 在“书籍”面板中 选择了全部、部分文档还是未选择文档。

    警告图标 表示有问题的区域。

  2. 在“打包”对话框中,执行下列操作之一:

    • 如果通知您存在问题,请单击取消,然后使用“印前检查”面板解决出现问题的区域。

    • 单击有问题的区域(例如“字体”),然后更正问题。如果对文档满意,则再次开始打包过程。

    • 摘要选项卡中选择创建打印说明,以创建打印说明文件。
    • 单击打包以开始打包。

  3. 如果您选中了创建打印说明,则会出现打印说明对话框。填写打印说明。键入的文件名是附带所有其他打包文件的报告的名称。单击继续

  4. 指定存储所有打包文件的位置。

  5. 根据需要选择下列选项:

    复制字体

    复制所有必需的字体文件,而不是整个字体系列。

    复制链接图形

    将链接的图形文件复制到包文件夹位置。

    更新包中的图形链接

    将图形链接更改到打包文件夹位置。

    仅使用文档连字例外项

    选中此选项后,InDesign 将标记此文档,这样当其他用户在具有其他连字和词典设置的计算机上打开或编辑此文档时,不会发生重排。您可以在将文件发送给服务提供商时打开此选项。

    包括隐藏和非打印内容的字体和链接

    打包位于隐藏图层、隐藏条件和“打印图层”选项已关闭的图层上的对象。如果未选择此选项,包中仅包含创建此包时,文档中可见且可打印的内容。

    选择 IDML 选项

    包括 IDML

    对包含此包的 IDML 文件进行打包。这样一来,可以在 InDesign 的旧版本中打开 InDesign 文档/书籍。

    包括 PDF(打印)

    选择对 PDF(打印)进行打包。当前显示的所有 PDF 预设可在打包时使用。最后使用的 PDF 预设是 PDF 预设下拉列表中默认的 PDF 预设。

    注意:

     

    • 如果在 PDF 创建过程中出现任何警告,而 PDF 成功创建,会显示警告消息。 
    • 如果在 PDF/IDML 创建或打包过程中出现任何错误,将回滚整个过程,且不会创建 PDF/IDML。
    • 创建的 IDML 和 PDF 文件的名称与 .indd 文档相同。

    查看报告

    打包后,立即在文本编辑器中打开打印说明报告。要在完成打包过程之前编辑打印说明,请单击“说明”按钮。仅当您在步骤 2 中选择了创建打印说明时,才启用该选项。

  6. 单击打包以继续执行打包。

更正字体错误

在“打包清单”对话框的“字体”区域中,将列出文档中使用的所有字体(包括应用到溢流文本或粘贴板上的文本的字体,以及 EPS 文件、原生 Adobe Illustrator 文件和置入的 PDF 页面中的嵌入字体),并确定字体是否已安装在您的计算机上及是否可用。选择“仅显示有问题项目”显示符合以下类别的字体:

缺失字体

列出文档中使用的但当前计算机上未安装的字体,或者列出可用作文档安装的字体。

不完整字体

列出在当前计算机上有屏幕字体但没有对应打印机字体的字体。

受保护字体

列出由于许可限制而无法嵌入到 PDF 或 EPS 文件中的字体或用作文档安装的字体。

  1. 执行以下操作之一:
    • 关闭“预检”对话框,并在计算机上安装字体。

    • 在“印前检查”对话框的“字体”区域中单击“查找字体”,并搜索、列出和替换文档中使用的字体。

确保文档中使用的字体在计算机或输出设备上已获得许可、安装并激活。

在“打包清单”对话框的“链接和图像”区域中,将列出文档中使用的所有链接、嵌入图像和置入的 InDesign 文件,包括来自链接的 EPS 图形的 DCS 和 OPI 链接。嵌入到 EPS 图形中的图像和置入的 InDesign 文件不作为链接包括在印前检查报告中。印前检查实用程序将显示缺失或过时的链接和任何 RGB 图像(这些图像可能未正确进行分色,除非启用并正确设置了颜色管理)。

注意:

“打包清单”对话框无法检测置入的 EPS、Adobe Illustrator、Adobe PDF、FreeHand 文件中和置入的 .INDD 文件中嵌入的 RGB 图像。为获得最佳效果,请使用“印前检查”面板验证置入图形的颜色数据,或在这些图形的原始应用程序中进行验证。

  1. 要仅查看有问题的图像,请在“打包清单”对话框的“链接和图像”区域中,选中“仅显示有问题项目”。
  2. 要修复链接,执行以下操作之一:
    • 选择有问题的图像,并单击“更新”或“重新链接”。

    • 单击“全部修复”。

  3. 找到正确的图像文件,并单击“打开”。
Adobe 徽标

登录到您的帐户