交叉引用

  1. InDesign 用户指南
  2. 了解 InDesign
    1. InDesign 简介
      1. InDesign 的新功能
      2. 系统要求
      3. 常见问题
      4. 使用 Creative Cloud 库
    2. 工作区
      1. 工作区基础知识
      2. 工具箱
      3. 设置首选项
      4. 触控工作区
      5. 默认键盘快捷键
      6. 文档恢复和还原
  3. 创建文档和设置文档版面
    1. 文档和页面
      1. 创建文档
      2. 使用主页
      3. 使用文档页面
      4. 设置页面大小、边距和出血
      5. 使用文件和模板
      6. 创建书籍文件
      7. 添加基本页码
      8. 编排页码和章节
      9. 转换 QuarkXPress 和 PageMaker 文档
      10. 共享内容
      11. 了解受管理文件的基本工作流程
      12. 存储文档
    2. 网格
      1. 网格
      2. 制定网格的格式
    3. 版面辅助工具
      1. 文档窗口中的
  4. 添加内容
    1. 文本
      1. 将文本添加到框架
      2. 串接文本
      3. InDesign 中的阿拉伯语和希伯来语功能
      4. 创建路径文字
      5. 项目符号和编号
      6. 字形和特殊字符
      7. 文本排版
      8. 文本变量
      9. 生成二维码
      10. 编辑文本
      11. 对齐文本
      12. 在对象周围绕排文本
      13. 定位对象
      14. 链接的内容
      15. 设置段落格式
      16. 设置字符格式
      17. 查找/更改
      18. 拼写检查和语言词典
    2. 排版规则
      1. 在 InDesign 中使用字体
      2. 字偶间距和字符间距
    3. 设置文本格式
      1. 设置文本格式
      2. 制表符和缩进
    4. 审阅文本
      1. 跟踪和检查更改
      2. 在 InDesign 中添加编辑附注
      3. 导入 PDF 注释
    5. 添加引用
      1. 创建目录
      2. 脚注
      3. 创建索引
      4. 尾注
      5. 题注
    6. 样式
      1. 段落样式和字符样式
      2. 对象样式
      3. 首字下沉和嵌套样式
      4. 使用样式
      5. 行距
      1. 设置表的格式
      2. 创建表
      3. 表和单元格样式
      4. 选择和编辑表
      5. 表描边和填色
    7. 交互性
      1. 超链接
      2. 动态 PDF 文档
      3. 书签
      4. 按钮
      5. 表单
      6. 动画
      7. 交叉引用
      8. 设置 PDF 结构
      9. 页面过渡效果
      10. 影片和声音
      11. 表单
    8. 图形
      1. 了解路径和形状
      2. 使用铅笔工具绘图
      3. 用钢笔工具绘图
      4. 应用线条(描边)设置 
      5. 复合路径与形状
      6. 编辑路径
      7. 剪切路径
      8. 更改角点外观
      9. 对齐和分布对象
      10. 链接和嵌入的图形
      11. 集成 AEM Assets
    9. 颜色和透明度
      1. 应用颜色
      2. 使用导入图形中的颜色
      3. 使用色板
      4. 混合油墨
      5. 色调
      6. 了解专色和印刷色
      7. 混合颜色
      8. 渐变
      9. 拼合透明图稿
      10. 添加透明度效果
  5. 共享
    1. 共享与协作        
    2. 共享以供审阅
    3. 审阅 InDesign 共享文档
    4. 管理反馈 
  6. 发布
    1. 导出和发布
      1. Publish Online
      2. 导出 EPUB 内容
      3. Adobe PDF 选项
      4. 将内容导出为 HTML
      5. 导出至 Adobe PDF
      6. 导出为 JPEG 格式
      7. 导出 HTML
      8. DPS 和 AEM Mobile 概述
    2. 打印
      1. 打印小册子
      2. 印刷标记和出血
      3. 打印文档
      4. 油墨、分色和网频
      5. 叠印
      6. 创建 PostScript 和 EPS 文件
      7. 提交前对文件执行印前检查
      8. 打印缩览图和超大文档
      9. 为服务提供商准备 PDF
      10. 准备打印分色
  7. 扩展 InDesign
    1. 自动化
      1. 数据合并
      2. 增效工具
      3. 脚本

编写手册或参考文档的时候,您可能需要添加交叉引用,用以将读者从文章的一个部分引导到另一个部分。示例:有关更多信息,请参阅第 249 页的“田鼠”。您可以指定交叉引用是源于段落样式(如标题样式),还是源于您已创建的文本锚点。您还可以确定交叉引用的格式,如“仅页码”或“整个段落和页码”。

插入交叉引用

使用“交叉引用”面板在文档中插入交叉引用。要打开该面板,请选择“窗口”>“文字和表”>“交叉引用”。

“交叉引用”面板

A. 单击绿色可视指示器可转至目标。 B. 单击页码可选择源。 C. 单击该图标可创建交叉引用。 

被引用的文本称为“目标文本”。从目标文本生成的文本为“源交叉引用”

在文档中插入交叉引用时,您可以从多种预先设计的格式中选择格式,也可以创建您自己的自定格式。可以将某个字符样式应用于整个交叉引用源,也可以应用于交叉引用中的文本。交叉引用格式可在书籍内部同步。

交叉引用源文本可以进行编辑,并且可以换行。

注意:

如果在 InDesign 的“导出 Adobe PDF”对话框中选中了“超链接”,则导出的 Adobe PDF 中将包含交叉引用。如果在“导出 SWF”对话框中选中了“包含超链接”,则导出的 SWF 文件中将包含交叉引用。

插入交叉引用

  1. 将插入点放在要插入交叉引用的位置。
  2. 要打开“新建交叉引用”对话框,请执行以下操作之一:

    • 选择“文字”>“超链接和交叉引用”>“插入交叉引用”。

    • 选择“窗口”>“文字和表”>“交叉引用”,然后从面板菜单中选择“插入交叉引用”。

    • 在面板中单击“创建新的交叉引用”按钮。

  3. 在该对话框中,从“链接到”菜单中选择“段落”或“文本锚点”。

    如果选择“段落”,则可以创建对指定文档中的任何段落的交叉引用。

    如果选择“文本锚点”,则可以创建对包含有您创建的超链接目标的任何文本的交叉引用。(请参阅创建超链接目标。)如果要使用实际目标段落以外的文本,那么创建文本锚点尤为有用。

  4. 对于“文档”,选择包含要引用的目标的文档。弹出式菜单中将列出已存储的所有打开的文档。如果要查找的文档未打开,请选择“浏览”,找到该文件,然后单击“打开”。
  5. 单击左侧框中的段落样式以缩小选择范围,然后选择要引用的段落。(或者,如果选择了“文本锚点”,请选择文本锚点。)
    您还可以使用搜索栏,从段落列表中搜索特定段落。 支持以下类型的搜索:

    • 从起始位置搜索 - 从段落开头匹配序列。
    • 搜索任意位置 - 从段落中的任意位置匹配序列。
  6. 从“格式”菜单中选择您要使用的交叉引用格式。

    您可以编辑这些交叉引用格式,也可以创建您自己的交叉引用格式。请参阅使用交叉引用格式

  7. 为该交叉引用指定 PDF 外观选项。

  8. 单击“确定”。

插入交叉引用时,目标段落的开头将会出现一个文本锚点标志符 。选择“文字”>“显示隐藏的字符”即可查看此标志符。如果移动或删除了此标志符,则无法解析交叉引用。

使用交叉引用格式

默认情况下,“新建交叉引用”对话框中会显示数种交叉引用格式。您可以编辑、删除这些格式,也可以创建您自己的格式。

注意:

如果在文档中删除或编辑了交叉引用格式,并希望将这些格式恢复为默认格式,则可以从面板菜单中选择“载入交叉引用格式”,然后选择拥有未编辑格式的文档。另外还可以同步书籍中的各种交叉引用格式。

创建或编辑交叉引用格式

与其他预设不同,交叉引用格式可以进行编辑或删除。编辑某个交叉引用格式时,使用该格式的所有源交叉引用均会自动更新。

  1. 执行以下操作之一:
    • 从“交叉引用”面板菜单中选择“定义交叉引用格式”。

    • 在创建或编辑交叉引用期间,单击“创建或编辑交叉引用格式”按钮 

  2. 在“交叉引用格式”对话框中,执行下列操作之一:
    • 若要编辑某个格式,请在左侧选择该格式。

    • 若要创建格式,请选择新格式的基础格式,然后单击“创建格式”按钮 。这样将会创建一种与所选格式完全相同的新格式。

  3. 对于“名称”,请指定新格式的名称。
  4. 在“定义”文本框中,根据需要添加或删除文本。单击“构造块”图标 ,从菜单插入构造块。单击“特殊字符”图标 ,选择虚线、空格、引号和其他特殊字符。
  5. 若要将字符样式应用于整个交叉引用,请选择“交叉引用的字符样式”,然后从菜单中选择或创建字符样式。

    另外还可以使用“字符样式”构建单元将字符样式应用于交叉引用中的文本。

  6. 单击“存储”以存储更改。完成后,单击“确定”。

交叉引用构建单元

构建单元

功能

示例

页码

插入页码。

第 <pageNum/> 页

第 23 页

段落编号

在对编号列表的交叉引用中插入段落编号。

请参阅 <paraNum/>

请参阅 1

在此示例中,仅使用段落“1. Animals”中的“1”。

段落文本

在对编号列表的交叉引用中插入没有段落编号的段落文本。

请参阅“<paraText/>”

请参阅“Animals”

在此示例中,仅使用段落“1. Animals”中的“Animals”。

整个段落

插入整个段落,包括段落编号和段落文本。

请参阅“<fullPara/>”

请参阅“1. Animals”

部分段落

用于创建对段落的第一个部分(直至指定分隔符,例如冒号或全角破折号)的交叉引用。

请参阅 <fullPara delim=”:” includeDelim=”false”/>

请参阅“Chapter 7”

在此示例中,仅使用标题“Chapter 7: Dogs and Cats”中的“Chapter 7”。

指定分隔符(例如此示例中的 :),并指示在源交叉引用中是排除("false" 或 "0")还是包含("true" 或 "1")分隔符。

请参阅创建对部分段落的交叉引用

文本锚点名称

插入文本锚点名称。从“超链接”面板菜单中选择“新建超链接目标”便可创建文本锚点。

请参阅 <txtAnchrName/>

请参阅图 1

章节编号

插入章节编号。

第 <chapNum/> 章

第 3 章

文件名

插入目标文档的文件名。

<fileName/> 中

newsletter.indd 中

字符样式

对交叉应用中的文本应用字符样式。

请参阅第 <pageNum> 页上的 <cs name=”bold”><fullPara/></cs>

请参阅第 23 页上的 Animals

指定字符样式名称,并将要应用该字符样式的文本放在 <csname=””> 和 </cs> 标签之间。

请参阅在交叉引用中应用字符样式

创建对部分段落的交叉引用

设计交叉引用格式的时候,可以只包括段落的第一个部分。例如,如果在文档中有类似于“Chapter 7—Granada to Barcelona”的标题,则可以创建只引用“Chapter 7”的交叉引用。

对部分段落的交叉引用

A. 交叉引用源以全角破折号 (^_) 结尾 B. "false" 表示从源中排除全角破折号 

插入部分段落构建单元时,必须执行两项处理。首先,指定引号之间的分隔符。该分隔符是段落的结尾字符。常见分隔符包括冒号 (Chapter 7: Granada)、句点 (Chapter 7. Granada) 和破折号 (Chapter 7—Granada)。若要插入特殊字符(例如全角破折号 (^_)、全角空格 (^m) 和项目符号字符 (^8)),请从单击“特殊字符”图标时所显示的菜单中选择选项。

然后,指示是排除 (Chapter 7) 还是包含 (Chapter 7—) 分隔符字符。使用 includeDelim="false" 可以排除分隔符,而使用 includeDelim="true" 可以包含分隔符。除了 "false" 或 "true" 之外,还可以分别使用 "0" 或 "1"。

在交叉引用中应用字符样式

若要强调交叉引用中的某一文本部分,则可以使用字符样式构建单元。此构建单元由两个标签组成。<cs name=”stylename”> 标签和 </cs> 标签;前者表示应用哪种样式,后者表示字符样式结尾。这两个标签之间的任何文本或构建单元都将采用指定样式接受格式设置。

对交叉引用的某一部分应用字符样式

A. 此标签应用名为“Red”的字符样式。 B. 此标签表示字符样式格式设置结束。 C. 对交叉引用源的其余部分应用名为“粗体”的字符样式。 

  1. 创建要使用的字符样式。
  2. 在“交叉引用格式”对话框中,创建或编辑要应用的格式。
  3. 在“定义”下,选择要为之应用字符样式的文本和构建单元。
  4. 从定义列表右侧的菜单中选择“字符样式”。
  5. 在引号之间键入字符样式的名称,该名称与“字符样式”面板中显示的名称应当完全相同。

    样式名称区分大小写。如果字符样式在某个组中,请首先键入此组的名称,然后键入冒号和字符样式,例如“Style Group 1: Red”

  6. 单击“存储”以存储格式,然后单击“确定”。

载入(导入)交叉引用格式

从其他文档载入交叉引用格式时,传入格式将会替换拥有相同名称的所有现有格式。

在 InCopy 中,只能在独立文档中导入交叉引用格式。不可将格式从 InCopy 文档导入 InDesign 文档。登记文章的时候,如果 InCopy 中新格式或经过修改的格式与 InDesign 文档中的格式发生冲突,则优先选用 InDesign 格式。

  1. 从“交叉引用”面板菜单中选择“载入交叉引用格式”。

  2. 双击包含要导入的交叉引用格式的文档。

另外还可以通过同步书籍,在不同文档中共享交叉引用格式。

删除交叉引用格式

不可删除已经应用于文档中交叉引用的交叉引用格式。

  1. 在“交叉引用格式”对话框中,选择要删除的格式。
  2. 单击“删除格式”按钮

管理交叉引用

插入交叉引用时,“交叉引用”面板会指示交叉引用的状态。例如,图标可以表明目标文本是显示在粘贴板 、主页 、隐藏图层 、溢流文本 中,还是显示在隐藏文本 中。链接到此类目标区域的交叉引用“不可解析”。面板还会报告目标段落是否经过编辑 (又称为“过时”)或是否缺失 。如果找不到目标文本或包含目标文本的文件,则目标文本“缺失”。将鼠标指针放在任何一个图标上便可查看工具提示说明。

在 InCopy 中,仅当注销文章以便进行编辑时才能管理交叉引用。

更新交叉引用

更新图标指示交叉引用目标文本已发生更改或交叉引用源文本已经过编辑。更新交叉引用十分简单。如果目标移动到其他页面,交叉引用则会自动更新。

更新交叉引用时将会删除源文本的所有格式设置变更。

打印或输出期间,如果交叉引用已过时或不可解析,您将会收到通知。

注意:

另外还可以使用“印前检查”面板,设定在交叉引用已过时或不可解析时发送通知。定义配置文件时,请在“文本”部分中选择“交叉引用”。请参阅定义预检配置文件

  1. 选择一个或多个已过时的交叉引用。若要更新所有交叉引用,请不要选择任何交叉引用。
  2. 执行以下操作之一:
    • 在“交叉引用”面板中单击“更新交叉引用”按钮

    • 从“交叉引用”面板菜单中选择“更新交叉引用”。

    • 选择“文字”>“超链接和交叉引用”>“更新交叉引用”。

若要更新书籍中的所有交叉引用,请从书籍面板菜单中选择“更新所有交叉引用”。如有交叉引用仍然不可解析,您将会收到通知。

如果缺失的目标文本已经移动到其他文档,或者包含目标文本的文档已经重命名,则可以重新链接交叉引用。重新链接时将会删除源交叉引用的所有变更。

  1. 在“交叉引用”面板中,选择要重新链接的交叉引用。

  2. 从面板菜单中选择“重新链接交叉引用”。

  3. 找到其中显示目标文本的文档,然后单击“打开”。

如果该文档具有任何其他目标文本,则您可以重新链接其他交叉引用。

编辑交叉引用

若要更改源交叉引用的外观或指定其他格式,可以编辑交叉引用。如果编辑链接到另外一个文档的交叉引用,该文档将会自动打开。

  1. 执行以下操作之一:
    • 选择“文字”>“超链接和交叉引用”>“交叉引用选项”。

    • 在“交叉引用”面板中,双击要编辑的交叉引用。

    • 选择交叉引用,然后从“交叉引用”面板菜单中选择“交叉引用选项”。

  2. 编辑交叉引用,然后单击“确定”。

删除交叉引用

删除交叉引用时,源交叉引用将转换为文本。

  1. 在“交叉引用”面板中,选择一个或多个要删除的交叉引用。

  2. 单击“删除”图标,或者从面板菜单中选择“删除交叉引用”。

  3. 单击“是”确认。

若要完全删除某个交叉引用,也可以选择并删除交叉引用源。

编辑交叉引用源文本

您可以编辑交叉引用源文本。编辑交叉引用文本的好处是可以根据版面组排的需要而更改字偶间距或单词间距,另外还可以设定其他更改。不足之处是更新或重新链接交叉引用之后将会删除所有本地格式设置变更。

Adobe 徽标

登录到您的帐户