创建表

  1. InDesign 用户指南
  2. 了解 InDesign
    1. InDesign 简介
      1. InDesign 的新功能
      2. 系统要求
      3. 常见问题
      4. 使用 Creative Cloud 库
    2. 工作区
      1. 工作区基础知识
      2. 工具箱
      3. 设置首选项
      4. 触控工作区
      5. 默认键盘快捷键
      6. 文档恢复和还原
  3. 创建文档和设置文档版面
    1. 文档和页面
      1. 创建文档
      2. 使用主页
      3. 使用文档页面
      4. 设置页面大小、边距和出血
      5. 使用文件和模板
      6. 创建书籍文件
      7. 添加基本页码
      8. 编排页码和章节
      9. 转换 QuarkXPress 和 PageMaker 文档
      10. 共享内容
      11. 了解受管理文件的基本工作流程
      12. 存储文档
    2. 网格
      1. 网格
      2. 制定网格的格式
    3. 版面辅助工具
      1. 文档窗口中的
  4. 添加内容
    1. 文本
      1. 将文本添加到框架
      2. 串接文本
      3. InDesign 中的阿拉伯语和希伯来语功能
      4. 创建路径文字
      5. 项目符号和编号
      6. 字形和特殊字符
      7. 文本排版
      8. 文本变量
      9. 生成二维码
      10. 编辑文本
      11. 对齐文本
      12. 在对象周围绕排文本
      13. 定位对象
      14. 链接的内容
      15. 设置段落格式
      16. 设置字符格式
      17. 查找/更改
      18. 拼写检查和语言词典
    2. 排版规则
      1. 在 InDesign 中使用字体
      2. 字偶间距和字符间距
    3. 设置文本格式
      1. 设置文本格式
      2. 制表符和缩进
    4. 审阅文本
      1. 跟踪和检查更改
      2. 在 InDesign 中添加编辑附注
      3. 导入 PDF 注释
    5. 添加引用
      1. 创建目录
      2. 脚注
      3. 创建索引
      4. 尾注
      5. 题注
    6. 样式
      1. 段落样式和字符样式
      2. 对象样式
      3. 首字下沉和嵌套样式
      4. 使用样式
      5. 行距
      1. 设置表的格式
      2. 创建表
      3. 表和单元格样式
      4. 选择和编辑表
      5. 表描边和填色
    7. 交互性
      1. 超链接
      2. 动态 PDF 文档
      3. 书签
      4. 按钮
      5. 表单
      6. 动画
      7. 交叉引用
      8. 设置 PDF 结构
      9. 页面过渡效果
      10. 影片和声音
      11. 表单
    8. 图形
      1. 了解路径和形状
      2. 使用铅笔工具绘图
      3. 用钢笔工具绘图
      4. 应用线条(描边)设置 
      5. 复合路径与形状
      6. 编辑路径
      7. 剪切路径
      8. 更改角点外观
      9. 对齐和分布对象
      10. 链接和嵌入的图形
      11. 集成 AEM Assets
    9. 颜色和透明度
      1. 应用颜色
      2. 使用导入图形中的颜色
      3. 使用色板
      4. 混合油墨
      5. 色调
      6. 了解专色和印刷色
      7. 混合颜色
      8. 渐变
      9. 拼合透明图稿
      10. 添加透明度效果
  5. 共享
    1. 共享与协作        
    2. 共享以供审阅
    3. 审阅 InDesign 共享文档
    4. 管理反馈 
  6. 发布
    1. 导出和发布
      1. Publish Online
      2. 导出 EPUB 内容
      3. Adobe PDF 选项
      4. 将内容导出为 HTML
      5. 导出至 Adobe PDF
      6. 导出为 JPEG 格式
      7. 导出 HTML
      8. DPS 和 AEM Mobile 概述
    2. 打印
      1. 打印小册子
      2. 印刷标记和出血
      3. 打印文档
      4. 油墨、分色和网频
      5. 叠印
      6. 创建 PostScript 和 EPS 文件
      7. 提交前对文件执行印前检查
      8. 打印缩览图和超大文档
      9. 为服务提供商准备 PDF
      10. 准备打印分色
  7. 扩展 InDesign
    1. 自动化
      1. 数据合并
      2. 增效工具
      3. 脚本

表是由单元格的行和列组成的。单元格类似于文本框架,可在其中添加文本、定位框架或其他表。可以在 Adobe InDesign CS5 中创建表,也可以从其他应用程序导入表。

注意:

要在 Adobe InCopy 中创建、编辑表并设置表的格式,请确保位于“版面”视图中。

创建表

表是由单元格的行和列组成的。单元格类似于文本框架,可在其中添加文本、随文图或其他表。可以从头开始创建表,也可以通过从现有文本转换的方式创建表。还可以在一个表中嵌入另一个表。

创建一个表时,新建表的宽度会与作为容器的文本框的宽度一致。插入点位于行首时,表插在同一行上;插入点位于行中间时,表插在下一行上。

表随周围的文本一起流动,就像随文图一样。例如,当表上方文本的点大小改变或者添加、删除文本时,表会在串接的框架之间移动。但是,表不能在路径文本框架上显示。

Michael Murphy 在妙用表格设计技巧中提供了一篇有关创建和设置表格式的文章。

来自 InfiniteSkills.com 的 Jeff Witchell 提供了一个关于表设置基本信息的视频演示。

从头开始创建表

使用 InDesign 创建表时,可以选择在现有的文本框架中创建表(使用“插入表”选项)。或者,您也可以创建表并允许 InDesign 创建封闭的文本框架(使用“创建表”选项)。

使用“插入表”选项

  1. 要在现有的文本框架中绘制表,请使用“文字”工具并将插入点置于您希望显示表的位置。

  2. 选择“表”>“插入表”。

    注意:

    如果光标当前不在文本框架中,则可以使用“创建表”选项。

  3. 指定行数和列数。
  4. 如果表内容将跨多个列或多个框架,请指定要在其中重复信息的表头行或表尾行的数量。
  5. (可选)指定一种表样式。
  6. 单击“确定”。

    新表将根据文本框架的宽度进行填充。

使用“创建表”选项

使用“创建表”选项创建表时,不需要先在文档中创建一个文本框架。只要您在文档中绘制了表,InDesign 就会按照所绘制表的大小创建一个文本框架。

  1. 选择“表”>“创建表”。

    注意:

    如果光标当前在文本框架中,则可以使用“插入表”选项。

  2. 指定行数和列数。
  3. 如果表内容将跨多个列或多个框架,请指定要在其中重复信息的表头行或表尾行的数量。
  4. (可选)指定一种表样式。
  5. 单击“确定”。
  6. 使用“表”光标绘制所需要的表。

    InDesign 可根据所绘制区域的大小创建一个文本框架,并将表置于该文本框架中。

表的行高由指定的表样式决定。例如,表样式可以使用一些单元格样式来分别设置表不同部分的格式。如果其中任意一种单元格样式中包括段落样式,则段落样式的行距值决定该部分的行高。如果未使用任何段落样式,则文档的默认嵌条决定行高。(嵌条基于行距值。本文中,嵌条是选定文本中最高文字的大致高度。)

从现有文本创建表

将文本转换为表之前,一定要正确设置文本。

  1. 要准备转换文本,请插入制表符、逗号、段落回车符或其他字符以分隔列。插入制表符、逗号、段落回车符或其他字符以分隔行。(多数情况下,不用编辑文本即可将其转换为表。)
  2. 使用“文字”工具  ,选择要转换为表的文本。
  3. 选择“表“>“将文本转换为表”。
  4. 对于列分隔符和行分隔符,请指出新行和新列应开始的位置。在“列分隔符和行分隔符”字段中,选择“制表符”、“逗号”或“段落”;或者键入字符(如分号 (;))。(下一次从文本创建表时,键入的任意字符均会显示在该菜单中。)
  5. 如果为列和行指定了相同的分隔符,请指出要让表包括的列数。
  6. (可选)指定一种表样式以设置表的格式。
  7. 单击“确定”。

如果任何行所含的项目少于表中的列数,则多出的部分由空单元格来填补。

向表中嵌入表

  1. 执行以下操作之一:
    • 选择要嵌入的单元格或表,然后选择“编辑”>“剪切”或“复制”。将插入点放置在要在其中显示该表的单元格中,然后选择“编辑”>“粘贴”。

    • 单击单元格内部区域,然后选择“表”>“插入表”,指定行数和列数,然后单击“确定”。

  2. 根据需要调整单元格内边距。(请参阅在表中设置文本的格式。)

如果在单元格中创建表,则无法使用鼠标选择溢出单元格边界的任何表部分。请将行或列加大,或者将插入点放置在表的第一部分中,然后使用键盘快捷键移动插入点并选择文本。

从其他应用程序导入表

使用“置入”命令导入包含表的 Microsoft Word 文档或导入 Microsoft Excel 电子表格时,导入的数据是可以编辑的表。可以使用“导入选项”对话框控制格式。

也可以将 Excel 电子表格或 Word 表中的数据粘贴到 InDesign 或 InCopy 文档中。“剪贴板处理”首选项设置决定如何对从另一个应用程序粘贴的文本设置格式。如果选中的是“纯文本”,则粘贴的信息显示为无格式制表符分隔文本,之后可以将该文本转换为表。如果选中“所有信息”,则粘贴的文本显示在带格式的表中。

如果要将文本从其他应用程序粘贴到现有的表中,请插入足够容纳所粘贴文本的行和列,并在“剪贴板处理”首选项中选择“纯文本”,同时确保至少选中一个单元格(除非您想将粘贴的表嵌入到一个单元格中)。

如果希望进一步控制所导入表的格式,或者希望保留电子表格的格式,请使用“置入”命令导入表。如果希望保留指向电子表格的链接,请在“文件处理”首选项设置中选择“置入文本和电子表格文件时创建链接”。

注意:

也可以跨多个选中的表单元格复制和粘贴制表符分隔文本。这种技巧是替换内容,同时保留格式的极佳方法。例如,假设需要更新一份月刊杂志中设置了格式的表格内容。一种可行做法是链接到 Excel 电子表格。但如果内容来自别的源,则可以复制包含新内容的制表符分隔文本,在设置了格式的 InDesign 表中选择单元格范围,然后粘贴。

向表中添加文本

可以将文本、定位对象、XML 标签和其他表添加到单元格中。除非设置固定的行高,否则表行的高度就会加以扩展以便容纳更多的文本行。不能将脚注添加到表中。

  1. 使用“文字”工具 ,执行以下操作之一:
    • 将插入点放置在一个单元格中,然后键入文本。按 Enter 键或 Return 键可在同一单元格中新建一个段落。按 Tab 键可在各单元格之间向前移动(在最后一个单元格处按 Tab 键将插入一个新行)。按 Shift+Tab 键可在各单元格之间向后移动。

    • 复制文本,将插入点放置在单元格中,然后选择“编辑”>“粘贴”。

    • 将插入点放置在要添加文本的单元格中,选择“文件”>“置入”,然后双击一个文本文件。

向表中添加图形

  1. 在要添加图像的表单元格中置入插入点。

  2. 执行以下操作之一:
    • 选择“文件”>“置入”,然后选择一个或多个图形文件。
    • 从 CC Libraries 面板的“图形”类别中选中一个或多个图形,并进行拖放。

    这些图像将显示在置入喷枪上。

  3. 要置入图像,请在每个表单元格内单击。

  4. 执行以下操作之一:
注意:

无法从 CC Libraries 面板的“图形”类别中拖放 InDesign 片段。

当添加的图形大于单元格时,单元格的高度就会扩展以便容纳图形,但是单元格的宽度不会改变,图形有可能延伸到单元格右侧以外的区域。如果在其中放置图形的行的高度已设置为固定高度,则高于这一行高的图形会导致单元格溢流

注意:

为避免单元格溢流,请先将图像放置在表外,调整图像的大小后再将图像粘贴到表单元格中。

也可以使用以下方法来将图像置入表单元格中:

  • 选择“对象”>“定位对象”>“插入”,然后指定设置。随后即可将图形添加到定位对象中。
  • 复制图形或框架,放置插入点,然后选择“编辑”>“粘贴”。

添加表头和表尾

创建长表时,该表可能会跨越多个栏、框架或页面。可以使用表头或表尾在表的每个拆开部分的顶部或底部重复信息。

可以在创建表时添加表头行和表尾行。也可以使用“表选项”对话框来添加表头行和表尾行并更改它们在表中的显示方式。可以将正文行转换为表头行或表尾行。

每个框架重复一次的表头行

注意:

若要将表按顺序编号,如 Table 1A、Table 1B 等,可为表头或表尾添加一个变量。(请参阅为图和表创建动态题注。)

  1. 选择表顶部的行以创建表头行,或选择表底部的行以创建表尾行。
  2. 选择“表”>“转换行”>“作为表头”或“作为表尾”。
  1. 将插入点放置在表中,然后选择“表”>“表选项”>“表头和表尾”。
  2. 指定表头行或表尾行的数量。可以在表的顶部或底部添加空行。
  3. 指定表头或表尾中的信息是显示在每个文本栏中(如果文本框架具有多栏),还是每个框架显示一次,或是每页只显示一次。
  4. 如果不希望表头信息显示在表的第一行中,请选择“跳过第一行”。如果不希望表尾信息显示在表的最后一行中,请选择“跳过最后一行”。

    当希望连续表示表头和表尾时,“跳过第一行”选项尤为有用。例如,对于跨多个页面的表格,您可能希望表头文本为“表 2(续)”。如果不希望在表的第一行显示“(续)”,请选择“跳过第一行”,只在表的第一行键入表 2

  5. 单击“确定”。

您可以执行许多函数来创建类似的行和列,或者复制它们。

您主要可以对表的行和列执行下列函数:

  • 在同一个表中将行和列从一个位置拖放到另一位置。
  • 复制行和列。
  • 将行和列粘贴到另一行/列的前面或后面
  • 将行的内容复制到列,或将列的内容复制到行。

拖放和复制行/列

您可以在同一个表中将行和列从一个位置移到另一位置。按照这些步骤拖放并复制行/列。

  1. 选择要拖放到其他行或列的行或列。确保已选择整个列或行。如果部分选择行或列,则无法拖放它们。

  2. 一个独特的光标悬停在所选行的上方,指明当前显示的是可以移动的选定内容。

  3. 可以拖放项目行。您可以将列和行进行互换。被拖动的行只能作为行进行放置,被拖动的列只能作为列进行放置。

    拖放行和列

    在此,将某一行从一个位置移动到其他位置并不会改变行的总数,即,一共三行。

    注意:

    拖放操作只能在同一表中使用。

  4. 复制行或列,请在选择行或列后按住 Alt(Win) 或 Opt(Mac) 键。可以拖放多个连续选择的行或列。

  5. 将选择的行或列拖放到预期位置。行或列的总数会随着选定实体被复制而增加。

    也可以将内容从表头行和表尾行复制到正文行(按 Alt/Opt 键)。同样,也可以将正文行复制和转换到表头行和表尾行。

您只可以在表头区内拖放表头行(仅适用于存在多个表头行的情况),除非使用 Alt/Opt 键复制行。无法将正文行拖放到表头区内,除非使用 Alt/Opt 键复制行。

复制行/列并在前面/后面粘贴

您可以复制行并粘贴在选定行的前面或后面。使用“在前面/后面粘贴”工作流程,您也可以复制表中的行/列并粘贴到另一表中。

  1. 选择行/列。

  2. 选择列或行。

  3. 选择“表”>“在前面/后面粘贴”。

  1. 执行以下操作之一:
    • 将插入点放置在表头行或表尾行中,然后选择“表”>“转换行”>“作为正文”。

    • 选择“表”>“表选项”>“表头和表尾”,然后指定另外的表头行数或表尾行数。

Adobe 徽标

登录到您的帐户