用户指南 取消(C)

复合路径与形状

  1. InDesign 用户指南
  2. 了解 InDesign
    1. InDesign 简介
      1. InDesign 的新功能
      2. 系统要求
      3. 常见问题
      4. 使用 Creative Cloud 库
    2. 工作区
      1. 工作区基础知识
      2. 工具箱
      3. 设置首选项
      4. 触控工作区
      5. 默认键盘快捷键
      6. 文档恢复和还原
      7. Capture 扩展
  3. 创建文档和设置文档版面
    1. 文档和页面
      1. 创建文档
      2. 使用主页
      3. 使用文档页面
      4. 设置页面大小、边距和出血
      5. 使用文件和模板
      6. 创建书籍文件
      7. 添加基本页码
      8. 编排页码和章节
      9. 转换 QuarkXPress 和 PageMaker 文档
      10. 共享内容
      11. 了解受管理文件的基本工作流程
      12. 存储文档
    2. 网格
      1. 网格
      2. 制定网格的格式
    3. 版面辅助工具
      1. 文档窗口中的
  4. 添加内容
    1. 文本
      1. 将文本添加到框架
      2. 串接文本
      3. InDesign 中的阿拉伯语和希伯来语功能
      4. 创建路径文字
      5. 项目符号和编号
      6. 字形和特殊字符
      7. 文本排版
      8. 文本变量
      9. 生成二维码
      10. 编辑文本
      11. 对齐文本
      12. 在对象周围绕排文本
      13. 定位对象
      14. 链接的内容
      15. 设置段落格式
      16. 设置字符格式
      17. 查找/更改
      18. 拼写检查和语言词典
    2. 排版规则
      1. 在 InDesign 中使用字体
      2. 字偶间距和字符间距
    3. 设置文本格式
      1. 设置文本格式
      2. 制表符和缩进
    4. 审阅文本
      1. 跟踪和检查更改
      2. 在 InDesign 中添加编辑附注
      3. 导入 PDF 注释
    5. 添加引用
      1. 创建目录
      2. 脚注
      3. 创建索引
      4. 尾注
      5. 题注
    6. 样式
      1. 段落样式和字符样式
      2. 对象样式
      3. 首字下沉和嵌套样式
      4. 使用样式
      5. 行距
      1. 设置表的格式
      2. 创建表
      3. 表和单元格样式
      4. 选择和编辑表
      5. 表描边和填色
    7. 交互性
      1. 超链接
      2. 动态 PDF 文档
      3. 书签
      4. 按钮
      5. 表单
      6. 动画
      7. 交叉引用
      8. 设置 PDF 结构
      9. 页面过渡效果
      10. 影片和声音
      11. 表单
    8. 图形
      1. 了解路径和形状
      2. 使用铅笔工具绘图
      3. 用钢笔工具绘图
      4. 应用线条(描边)设置 
      5. 复合路径与形状
      6. 编辑路径
      7. 剪切路径
      8. 更改角点外观
      9. 对齐和分布对象
      10. 链接和嵌入的图形
      11. 集成 AEM Assets
    9. 颜色和透明度
      1. 应用颜色
      2. 使用导入图形中的颜色
      3. 使用色板
      4. 混合油墨
      5. 色调
      6. 了解专色和印刷色
      7. 混合颜色
      8. 渐变
      9. 拼合透明图稿
      10. 添加透明度效果
  5. 共享
    1. 共享与协作        
    2. 共享以供审阅
    3. 审阅 InDesign 共享文档
    4. 管理反馈 
  6. 发布
    1. 导出和发布
      1. Publish Online
      2. 导出 EPUB 内容
      3. Adobe PDF 选项
      4. 将内容导出为 HTML
      5. 导出至 Adobe PDF
      6. 导出为 JPEG 格式
      7. 导出 HTML
      8. DPS 和 AEM Mobile 概述
    2. 打印
      1. 打印小册子
      2. 印刷标记和出血
      3. 打印文档
      4. 油墨、分色和网频
      5. 叠印
      6. 创建 PostScript 和 EPS 文件
      7. 提交前对文件执行印前检查
      8. 打印缩览图和超大文档
      9. 为服务提供商准备 PDF
      10. 准备打印分色
  7. 扩展 InDesign
    1. 自动化
      1. 数据合并
      2. 增效工具
      3. InDesign 中的 Capture 扩展
      4. 脚本

关于复合路径

可以将多个路径组合为单个对象,此对象称作复合路径。当要执行下列任一操作时,请创建复合路径:

  • 向路径中添加透明孔。

  • 使用“创建轮廓”命令将字符转换为可编辑的字体时,保留某些文本字符中的透明孔,如 oe。使用“创建轮廓”命令所创建的始终是复合路径。

  • 应用渐变或添加跨越多个路径的内容。尽管也可以使用“渐变”工具跨多个对象应用渐变,但向复合路径应用渐变通常是一个更好的方法,这是因为您以后可以通过选择任何子路径来编辑整个渐变。使用“渐变”工具在以后编辑时需要选择您最初选择的所有路径。

编辑复合路径的最佳做法

编辑复合路径时请注意下列准则:

  • 对路径属性(如描边和填色)的更改始终改变复合路径中的所有子路径 - 无论您使用哪个选择工具或选择多少个子路径。要保留想要组合的路径的个别描边和填色属性,请改用编组操作。

  • 在复合路径中,任何相对于路径的定界框定位的效果(如渐变或内部粘贴的图像)实际上是相对于整个复合路径(即包含所有子路径的路径)的定界框进行定位的。

  • 如果生成复合路径,然后更改它的属性并使用“释放”命令释放它,则释放的路径将继承复合路径的属性;它们并不会恢复它们的原始属性。

  • 如果文档包含具有许多平滑点的复合路径,则某些输出设备在打印它们时可能出现问题。如果出现问题,请简化或消除复合路径,或使用程序(如 Adobe Photoshop)将它们转换为位图图像。

  • 如果向复合路径应用填色,孔有时并不在您预期的位置显示。对于类似矩形这样的简单路径,很容易识别它的内部(即可以填色的区域),因为其为封闭路径中的区域。但对于复合路径,InDesign 必须确定由复合路径的子路径创建的交集是在内部(填色区域)还是在外部(孔)。每个子路径的方向(创建它的点的顺序)决定它定义的区域是在内部还是在外部。如果希望是孔的子路径已经填充(或反之),可以单击“路径查找器”面板中的“反转路径”,反转该子路径的方向。

包含两个具有相同路径方向(左侧)和相反路径方向(右侧)的子路径的复合路径

创建复合路径

可以用两个或更多个开放或封闭路径创建复合路径。创建复合路径时,所有最初选定的路径将成为新复合路径的子路径。选定路径继承排列顺序中最底层的对象的描边和填色设置。

注意:

如果一个或多个选定对象包含内容(如文本或导入的图像),则复合路径的属性和内容由最底层对象的属性和内容决定。选定的不包含内容的较底层对象不会影响复合路径。

可以通过使用“直接选择”工具 选择某个子路径上的锚点来更改复合路径任何部分的形状。

  1. 使用“选择”工具 选择所有要包含在复合路径中的路径。
  2. 选择“对象”>“路径”>“建立复合路径”。选定路径的重叠之处,都将显示一个孔。
注意:

可以填充由子路径创建的孔或将子路径转换为孔。使用“直接选择”工具在要更改的子路径上选择一点。然后选择“对象”>“路径”>“反转路径”,或单击“路径查找器”面板中的“反转路径”。

在复合路径中将孔更改为填色

每个子路径的方向(创建它的点的顺序)决定它定义的区域是在内部(填色区域)还是在外部(空白)。如果复合路径中的孔有时不在您期望的位置显示,您可以反转该子路径的方向。

两个单独的封闭路径(左侧)和同一复合路径的两个子路径(右侧);复合路径将中心圆用作孔

  1. 使用“直接选择”工具 ,选择复合路径中要反转的部分(或者该部分上的一点)。不要选择整个复合路径。
  2. 执行以下操作之一:
    • 选择“对象”>“路径”>“反转路径”。

    • 单击“路径查找器”面板中的“反转路径”。

分解复合路径

可以通过释放复合路径(将它的每个子路径转换为独立的路径)来分解复合路径。

  1. 使用“选择”工具 ,选择一个复合路径。
  2. 选择“对象”>“路径”>“释放复合路径”。
注意:

当选定的复合路径包含在框架内部,或该路径包含文本时,“释放”命令将不可用。

更改复合路径中的孔

可以通过反转子路径的方向消除由子路径创建的孔,或填充一个已创建孔的子路径。

  1. 使用“直接选择”工具 ,在要反转的子路径上选择一点。不要选择整个复合路径。
  2. 选择“对象”>“路径”>“反转路径”,或单击“路径查找器”面板中的“反转路径”。

创建复合形状

可以使用“路径查找器”面板(“窗口”>“对象和版面”>“路径查找器”)创建复合形状。复合形状可由简单路径或复合路径、文本框架、文本轮廓或其他形状组成。复合形状的外观取决于您所选择的路径查找器按钮。

路径查找器面板

A. 原始对象 B. 添加 C. 减去 D. 交叉 E. 排除重叠 F. 减去后方对象 

添加

跟踪所有对象的轮廓以创建单个形状。

减去

前面的对象在最底层的对象上“打孔”。

交叉

从重叠区域创建一个形状。

排除重叠

从不重叠的区域创建一个形状。

减去后方对象

后面的对象在最顶层的对象上“打孔”。

大多数情况下,生成的形状采用最顶层对象的属性(填色、描边、透明度、图层等)。但在减去形状时,将删除前面的对象。生成的形状改用最底层对象的属性。

将文本框架包含在复合形状中时,文本框架的形状将更改,但文本本身保持不变。要改变文本本身,请使用文本轮廓创建一个复合路径。

用作文本框架的复合形状(左侧)与从文本轮廓创建的复合形状(右侧)的对比

创建复合形状

可以将复合形状作为单个单元进行处理,也可以释放它的组件路径以单独处理每个路径。例如,可以将渐变填色应用于复合形状的某一部分,但不填充此形状的其余部分。

应用于复合形状的渐变(左侧)与应用于复合形状的某一部分的渐变(右侧)的对比

  1. 选择“窗口”>“对象和版面”>“路径查找器”以打开此面板。
  2. 选择要组合到复合形状中的对象。
  3. 在“路径查找器”面板的“路径查找器”部分中,单击按钮(如“添加”)。

也可以从“对象”>“路径查找器”子菜单中选择命令。

释放复合形状中的路径

  1. 选择复合形状。选择“对象”>“路径”>“释放复合路径”。复合形状随即分解为它的组件路径。
    注意:

    要重组组件路径而不丢失应用于各个路径的更改,请在“对象”菜单中选择“编组”,而不要选择“复合路径”>“建立”。

从文本轮廓创建路径

使用“创建轮廓”命令将选定文本字符转换为一组复合路径,您可以像编辑和处理任何其他路径那样编辑和处理这些复合路径。“创建轮廓”命令在为大号显示文字制作效果时使用,但很少用于正文文本或其他较小号的文字。

注意:

如果只希望将彩色描边或渐变填色或描边应用于文本字符,则不必将文本转换为轮廓。可以使用工具箱和“色板”、“颜色”或“渐变”面板将颜色和渐变直接应用于选定字符的描边或填色。

“创建轮廓”命令从实际的 Type 1、TrueType 或 OpenType 文件中获取字体轮廓信息。创建轮廓时,字符将在它们的当前位置进行转换,从而保留所有图形格式设置,如描边和填色。

注意:

一些字体制造商会阻止创建轮廓所需的信息。如果您选择这样的受保护字体并选择“文字”>“创建轮廓”,将显示一条消息,说明无法转换该字体。

将文字转换为轮廓时,文字将失去其提示 信息,此信息为轮廓字体中内置的说明,用于描述如何调整这些字体的形状,以便使系统在字号较小时也能使完美地显示或打印这些字体。因此,在字体较小或分辨率较低时,转换为轮廓的文字可能无法像未转换之前那样显示。

将文字转换为轮廓后,可以执行以下操作之一:

  • 通过使用“直接选择”工具 拖动各个锚点来改变字体。

  • 复制轮廓并使用“编辑”>“贴入内部”命令通过将图像粘贴到已转换的轮廓来给图像添加蒙版。

  • 将已转换的轮廓用作文本框,以便可以在其中键入或放置文本。

  • 更改字体的描边属性。

  • 使用文本轮廓创建复合形状。

处理文本轮廓

A. 转换为文本轮廓前的文字字符 B. 其上粘贴了图像的文本轮廓 C. 用作文本框架的文本轮廓 

由于已转换的文本轮廓成为复合路径集,因此可以使用“直接选择”工具编辑已转换轮廓的各个子路径。还可以通过从复合路径中释放字符轮廓将它们分解为独立的路径。

将文本轮廓转换为路径

默认情况下,从文字创建轮廓将移去原始文本。但如果需要,可以在原始文本的副本上显示轮廓,这样将不会丢失任何文本。

选择文本框架中的文字字符并将其转换为轮廓时,生成的轮廓将成为与文本一起流动的(随文)定位对象。由于已转换的文本已不再是实际的文字,因此您将无法再使用“文字”工具突出显示和编辑字符。此外,与排版相关的控制将不再适用。确保您对转换为轮廓的文字的排版设置满意,并确保创建了原始文本的副本。

  1. 使用“选择”工具 选择文本框架,或使用“文字”工具选择一个或多个字符。
  2. 选择“文字”>“创建轮廓”。

将文本轮廓的副本转换为路径

  1. 使用“选择”工具 选择文本框架,或使用“文字”工具选择一个或多个字符。
  2. 在选择“文字”>“创建轮廓”时按住 Alt (Windows) 或 Option (Mac OS)。副本将不偏不倚地创建在原始轮廓上;如果需要,可使用“选择”工具将它拖开。

更多此类内容

Adobe 徽标

登录到您的帐户

[Feedback V2 Badge]