用户指南 取消(C)

串接文本

  1. InDesign 用户指南
  2. 了解 InDesign
    1. InDesign 简介
      1. InDesign 的新功能
      2. 系统要求
      3. 常见问题
      4. 使用 Creative Cloud 库
    2. 工作区
      1. 工作区基础知识
      2. 工具箱
      3. 设置首选项
      4. 触控工作区
      5. 默认键盘快捷键
      6. 文档恢复和还原
      7. Capture 扩展
  3. 创建文档和设置文档版面
    1. 文档和页面
      1. 创建文档
      2. 使用主页
      3. 使用文档页面
      4. 设置页面大小、边距和出血
      5. 使用文件和模板
      6. 创建书籍文件
      7. 添加基本页码
      8. 编排页码和章节
      9. 转换 QuarkXPress 和 PageMaker 文档
      10. 共享内容
      11. 了解受管理文件的基本工作流程
      12. 存储文档
    2. 网格
      1. 网格
      2. 制定网格的格式
    3. 版面辅助工具
      1. 文档窗口中的
  4. 添加内容
    1. 文本
      1. 将文本添加到框架
      2. 串接文本
      3. InDesign 中的阿拉伯语和希伯来语功能
      4. 创建路径文字
      5. 项目符号和编号
      6. 字形和特殊字符
      7. 文本排版
      8. 文本变量
      9. 生成二维码
      10. 编辑文本
      11. 对齐文本
      12. 在对象周围绕排文本
      13. 定位对象
      14. 链接的内容
      15. 设置段落格式
      16. 设置字符格式
      17. 查找/更改
      18. 拼写检查和语言词典
    2. 排版规则
      1. 在 InDesign 中使用字体
      2. 字偶间距和字符间距
    3. 设置文本格式
      1. 设置文本格式
      2. 制表符和缩进
    4. 审阅文本
      1. 跟踪和检查更改
      2. 在 InDesign 中添加编辑附注
      3. 导入 PDF 注释
    5. 添加引用
      1. 创建目录
      2. 脚注
      3. 创建索引
      4. 尾注
      5. 题注
    6. 样式
      1. 段落样式和字符样式
      2. 对象样式
      3. 首字下沉和嵌套样式
      4. 使用样式
      5. 行距
      1. 设置表的格式
      2. 创建表
      3. 表和单元格样式
      4. 选择和编辑表
      5. 表描边和填色
    7. 交互性
      1. 超链接
      2. 动态 PDF 文档
      3. 书签
      4. 按钮
      5. 表单
      6. 动画
      7. 交叉引用
      8. 设置 PDF 结构
      9. 页面过渡效果
      10. 影片和声音
      11. 表单
    8. 图形
      1. 了解路径和形状
      2. 使用铅笔工具绘图
      3. 用钢笔工具绘图
      4. 应用线条(描边)设置 
      5. 复合路径与形状
      6. 编辑路径
      7. 剪切路径
      8. 更改角点外观
      9. 对齐和分布对象
      10. 链接和嵌入的图形
      11. 集成 AEM Assets
    9. 颜色和透明度
      1. 应用颜色
      2. 使用导入图形中的颜色
      3. 使用色板
      4. 混合油墨
      5. 色调
      6. 了解专色和印刷色
      7. 混合颜色
      8. 渐变
      9. 拼合透明图稿
      10. 添加透明度效果
  5. 共享
    1. 共享与协作        
    2. 共享以供审阅
    3. 审阅 InDesign 共享文档
    4. 管理反馈 
  6. 发布
    1. 导出和发布
      1. Publish Online
      2. 导出 EPUB 内容
      3. Adobe PDF 选项
      4. 将内容导出为 HTML
      5. 导出至 Adobe PDF
      6. 导出为 JPEG 格式
      7. 导出 HTML
      8. DPS 和 AEM Mobile 概述
    2. 打印
      1. 打印小册子
      2. 印刷标记和出血
      3. 打印文档
      4. 油墨、分色和网频
      5. 叠印
      6. 创建 PostScript 和 EPS 文件
      7. 提交前对文件执行印前检查
      8. 打印缩览图和超大文档
      9. 为服务提供商准备 PDF
      10. 准备打印分色
  7. 扩展 InDesign
    1. 自动化
      1. 数据合并
      2. 增效工具
      3. InDesign 中的 Capture 扩展
      4. 脚本
注意:

语言公正:我们将从 InDesign 2022(版本 17.0)起替换掉非包容性的语言,以反映 Adobe 包容性的核心价值观。我们在英语、丹麦语、匈牙利语、西班牙语、意大利语、巴西语、葡萄牙语和日语等语言的帮助文章中,将所有“Master page”均替换为“Parent page”。

串接文本框架

框架中的文本可独立于其他框架,也可在多个框架之间连续排文。要在多个框架(也称为文本框)之间连续排文,必须先连接这些框架。连接的框架可位于同一页或跨页,也可位于文档的其他页。在框架之间连接文本的过程称为串接文本。此过程也称为链接文本框架链接文本框

每个文本框架都包含一个入口和一个出口,这些端口用来与其他文本框架进行连接。空的入口或出口分别表示文章的开头或结尾。端口中的箭头表示该框架链接到另一框架。出口中的红色加号 (+) 表示该文章中有更多要置入的文本,但没有更多的文本框架可放置文本。这些剩余的不可见文本称为溢流文本

串接的框架

A. 文章开头的入口 B. 指示与下一个框架串接关系的出口 C. 文本串接 D. 指示与上一个框架串接关系的入口 E. 指示溢流文本的出口 

选择“视图”>“其他”>“显示文本串接”以查看串接框架的可视化表示。无论文本框架是否包含文本,都可进行串接。

向串接中添加新框架

  1. 使用“选择工具” ,选择一个文本框架,然后单击入口或出口以载入文本图标。

    单击入口可在所选框架之前添加一个框架;单击出口可在所选框架之后添加一个框架。

  2. 将载入的文本图标 放置到希望新文本框架出现的地方,然后单击或拖动以创建一个新文本框架。
注意:

当载入的文本图标处于活动状态时,可以执行许多操作,包括翻页、创建新页面,以及放大和缩小。如果开始串接两个框架后又不想串接,则可单击“工具箱”中的任一工具取消串接。这样不会丢失文本。

向串接中添加现有框架

  1. 使用“选择工具”,选择一个文本框架,然后单击入口或出口以载入文本图标。
  2. 将载入的文本图标放到要连接到的框架上面。载入的文本图标将更改为串接图标。
    向串接中添加现有框架

  3. 在第二个框架内部单击以将其串接到第一个框架。

如果将某个框架网格与纯文本框架或具有不同网格设置的其他框架网格串接,将会重新定义被串接的文本框架,以便与串接操作的源框架网格的设置匹配。

注意:

可以添加自动的“下转...”或“上接...”跳转行,当串接的文章从一个框架跳转到另一框架时,这些跳转行将对其进行跟踪。(请参阅为文章跳转添加自动页码。)

在串接框架序列中添加框架

  1. 使用“选择工具”,单击要将框架添加到的文章的出口。释放鼠标按钮时,将显示一个载入文本图标。
  2. 拖移以创建一个新框架,或单击另一个已创建的文本框架。InDesign 将框架串接到包含该文章的链接框架序列中。
在串接内添加框架(上)及结果(下)

取消串接文本框架

取消串接文本框架时,将断开该框架与串接中的所有后续框架之间的连接。以前显示在这些框架中的任何文本将成为溢流文本(不会删除文本)。所有的后续框架都为空。

  1. 通过使用“选择工具”,执行下列操作之一:
    • 双击入口或出口以断开两个框架之间的连接。
    • 单击表示与另一框架存在串接关系的入口或出口。例如,在一个由两个框架组成的串接中,单击第一个框架的出口或第二个框架的入口。将载入的文本图标放置到上一个框架或下一个框架之上,以显示取消串接图标 。在要从串接删除的框架中单击。
    从串接中删除框架

注意:

要将一篇文章拆分为两篇文章,请剪切要作为第二篇文章的文本,断开框架之间的连接,然后将该文本粘贴到第二篇文章的第一个框架中。

剪切或删除串接文本框架

在剪切或删除文本框架时不会删除文本;文本仍包含在串接中。

从串接中剪切框架

可以从串接中剪切框架,然后将其粘贴到其他位置。剪切的框架将使用文本的副本,不会从原文章中移去任何文本。在一次剪切和粘贴一系列串接文本框架时,粘贴的框架将保持彼此之间的连接,但将失去与原文章中任何其他框架的连接。

  1. 使用“选择工具”,选择一个或多个框架(按住 Shift 键并单击可选择多个对象)。
  2. 选择“编辑”>“剪切”。选中的框架消失,其中包含的所有文本都排列到该文章内的下一框架中。剪切文章的最后一个框架时,其中的文本存储为上一个框架的溢流文本。
  3. 如果要在文档的其他位置使用断开连接的框架,请转到希望断开连接的文本出现的页面,然后选择“编辑”>“粘贴”。

从串接中删除框架

当删除串接中的文本框架时,不会删除任何文本:文本将成为溢流文本,或排列到连续的下一框架中。如果文本框架未连接到其他任何框架,则会删除框架和文本。

  1. 要选择文本框架,执行以下操作之一:
    • 使用“选择工具”单击框架。
    • 使用“文字工具”,按住 Ctrl 键 (Windows) 或 Command 键 (Mac OS),然后单击框架。
  2. 按 Backspace 键或 Delete 键。

手动或自动排文

置入文本或者单击入口或出口后,指针将成为载入的文本图标 。使用载入的文本图标可将文本排列到您的页面上。按住 Shift 或 Alt 键,可确定文本排列的方式。载入文本图标将根据置入的位置改变外观。

将载入的文本图标置于文本框架之上时,该图标 将括在圆括号中。将载入的文本图标置于参考线或网格靠齐点旁边时,黑色指针将变为白色

可以使用下列四种方法排文文本:

方法

功能

手动文本排文 

一次一个框架地添加文本。必须重新载入文本图标才能继续排文文本。

单击时,按住 Alt 键 (Windows) 或 Option 键 (Mac OS),进行半自动排文 

工作方式与手动文本排文相似,区别在于每次到达框架末尾时,指针将变为载入的文本图标,直到所有文本都排列到文档中为止。

按住 Shift 键单击,进行自动排文

自动添加页面和框架,直到所有文本都排列到文档中为止。

单击时按住 Shift+Alt (Windows) 或 Shift+Option (Mac OS),进行固定页面自动排文 

将所有文本都排列到文档中,根据需要添加框架但不添加页面。任何剩余的文本都将成为溢流文本。

要在框架中排文文本,InDesign 会检测是横排类型还是直排类型。使用半自动或自动排文排列文本时,将采用“文章”面板中设置的框架类型和方向。用户可以使用图标获得文本排文方向的视觉反馈。

手动排文

  1. 使用“置入”命令选择一个文件,或单击选中文本框架的出口
  2. 执行以下操作之一:
    • 将载入的文本图标置于现有框架或路径内的任何位置,然后单击。文本将排列到该框架及其他任何与此框架串接的框架中。请注意,文本总是从最左侧的栏的上部开始填充框架,即使单击其他栏时也是如此。
    • 将载入文本图标置于某栏中,以创建一个与该栏的宽度相符的文本框架。该框架的顶部将是您单击的地方。
    • 拖动载入的文本图标,以您所定义区域的宽度和高度创建文本框架。
  3. 如果要置入多个文本,请单击出口并重复步骤 1 和 2,直到置入所有文本。
注意:

如果将文本置入与其他框架串接的框架中,则不论选择哪种文本排文方法,文本都将自动排文到串接的框架中。

半自动排文

  1. 载入的文本图标后,按住 Alt 键单击 (Windows) 或按住 Option 键单击 (Mac OS) 页面或框架。

与手动排文一样,文本每次排文一栏,但是在置入每栏后,载入的文本图标将自动重新载入。

自动排文

  1. 显示载入文本图标时,执行下列操作之一时按住 Shift 键:
    • 单击栏中载入的文本图标,以创建一个与该栏的宽度相等的框架。InDesign 将创建新文本框架和新文档页面,直到将所有文本都添加到文档中为止。
    • 在基于主页文本框架的文本框架内单击。文本将自动排列到文档页面框架中,并会根据需要使用主页框架的属性生成新页面。(请参阅关于主页、堆叠顺序和图层。)

自动排文但不添加页面

  1. 载入的文本图标后,按住 Shift+Alt (Windows) 或 Shift+Option (Mac OS)。

使用智能文本重排

在键入或编辑文本时,可以使用“智能文本重排”功能来添加或删除页面。如果使用 InDesign 作为文本编辑器,则当键入的文本超出当前页面的容纳能力,需要添加新页面时,便会用到此功能。在由于编辑文本、显示或隐藏条件文本,或对文本排列进行其他更改,导致文本排列发生变化的情况下,也可以使用此功能来避免出现溢流文本或空白页面。

默认情况下,“智能文本重排”仅限用于主页文本框架,即主页上的文本框架。如果文档包括对页,则左右两个主页上必须都包含主页文本框架,且主页文本框架必须串接,这样“智能文本重排”才能生效。

您可以更改相关设置,允许在使用非基于主页的文本框架时添加或删除页面。不过,该文本框架至少必须串接到其他页面上的其他一个文本框架,这样“智能文本重排”才能有效。

“智能文本重排”设置显示在“文字”首选项中。这些设置应用于当前文档。若要更改所有新文档的默认设置,请关闭全部文档,然后指定设置。

  1. 选择“编辑”>“首选项”>“文字”(Windows) 或“InDesign”>“首选项”>“文字”(Mac OS)。

  2. 选择“智能文本重排”。

  3. 选择以下任意选项,然后单击“确定”。

将页面添加到

使用此选项可以确定在何处创建新页面。例如,假设文档包含三个页面,前两个页面上有文本框架,第三个页面上有一个占据全页的图形。如果在第二页的末尾键入文字,则您可以决定是在第三页的全页图形之前还是之后添加新页面。如果选择“文章末尾”,将在第二页之后添加新页面。如果选择“文档末尾”,将在具有全页图形的页面之后添加新页面。

在多个章节的文档中,如果选择“章节末尾”,将在章节末尾添加新页面。

限制在主页文本框架内

如果关闭此选项,您还可以在编辑非基于主页的文本框架时添加或删除页面。为避免发生不需要的文本重排,仅当正在编辑的文本框架至少串接到其他页面上的其他一个文本框架时,“智能文本重排”才生效。

注意:在非基于主页的文本框架内使用“智能文本重排”时,无论新框架串接的目标文本框架具有何种属性,添加的页面均具有全页单栏文本框架。

保留对页跨页

此选项确定当文本在文档中间重排时,是否保留对页跨页。如果在文档中间重排文本时,选择了此选项,将添加一个两页的新跨页。如果未选择此选项,将添加单个新页面,且后续页面将“随机排布”。

如果版面中包括跨页左侧或右侧专用的设计元素,请打开此选项。如果左页面和右页面可以互换,则可以关闭此选项。如果文档没有对页,此选项将呈灰显状态。

删除空白页面

选择此选项后,可在编辑文本或隐藏条件时删除页面。仅当空白文本框架是页面上唯一的对象时,才会删除页面。

注意:

若要了解“智能文本重排”可将 InDesign 作为文本编辑器的原因,请创建一个文档,关闭其中的“对页”并选中“主页文本框架”。在“文字”首选项中,确保选中了“智能文本重排”和“删除空白页面”。在首页上,按住 Ctrl+Shift (Windows) 或 Command+Shift (Mac OS),然后单击主页文本框架以将其覆盖。在键入足够多的文本来填充此文本框架后,将自动添加新的页面和文本框架。如果删除足够多的文本,将删除页面。

Adobe 徽标

登录到您的帐户

[Feedback V2 Badge]