默认情况下,在 Adobe InDesign 中创建的对象显示为实底状态,即不透明度为 100%。可以将这些效果应用于使用不透明度和混合模式的对象。重叠对象,向对象添加透明度,或者挖空对象下面的形状。

关于透明度

默认情况下,当您创建对象或描边、应用填色或输入文本时,这些项目显示为实底状态,即不透明度为 100%。您可以通过多种方式使项目透明化。例如,您可以将不透明度从 100%(完全不透明)改变到 0%(完全透明)。降低不透明度后,就可以透过对象、描边、填色或文本看见下方的图稿。

可以使用“效果”面板为对象及其描边、填色或文本指定不透明度,并可以决定对象本身及其描边、填色或文本与下方对象的混合方式。就对象而言,您可以选择对特定对象执行分离混合,以便组中仅部分对象与其下面的对象混合,或者您可以挖空对象而不是与组中的对象混合。

 

透过透明对象显示的底层对象区域
透过透明对象显示的底层对象区域。

效果面板概述

使用“效果”面板(“窗口”>“效果”)可以指定对象或组的不透明度和混合模式,对特定组执行分离混合,挖空组中的对象或应用透明效果。

“效果”面板
在“效果”面板中添加和编辑透明效果

A. 混合模式 B. 级别 C. FX 图标 D. 清除效果 E. FX 按钮 

混合模式

指定透明对象中的颜色如何与其下面的对象相互作用。(请参阅指定颜色混合方式。)

不透明度

确定对象、描边、填色或文本的不透明度。(请参阅设置对象的不透明度。)

级别

告知关于对象的“对象”、“描边”、“填色”和“文本”的不透明度设置,以及是否应用了透明效果。单击词语对象(组或图形)左侧的三角形,可以隐藏或显示这些级别设置。在为某级别应用透明度设置后,该级别上会显示 FX 图标,可以双击该 FX 图标编辑这些设置。

分离混合

将混合模式应用于选定的对象组。(请参阅分离混合模式。)

挖空组

使组中每个对象的不透明度和混合属性挖空或遮蔽组中的底层对象。(请参阅挖空组中对象。)

“清除全部”按钮

清除对象(描边、填色或文本)的效果,将混合模式设置为“正常”,并将整个对象的不透明度设置更改为 100%。

FX 按钮

显示透明效果列表。(请参阅应用透明效果。

显示效果面板选项

  1. 如有必要,选择“窗口”>“效果”,打开“效果”面板菜单并选择“显示选项”。

    在“效果”对话框中也可以获得“效果”面板选项(在选定一个对象后选择“对象”>“效果”>“透明度”),它们以简化形式位于控制面板中。

应用透明效果

  1. 选择一个对象。要将效果应用于图形,请用直接选择工具选择图形。
  2. 选择“窗口”>“效果”以显示“效果”面板。
  3. 选择一个级别以指定您要更改对象的哪些部分:

    对象

    影响整个对象(包括其描边、填色和文本)。

    图形

    仅影响用直接选择工具选择的图形。将此图形粘贴到其他框架时,应用于此图形的效果将与其一同保留。

    影响组中的所有对象和文本。(可以使用直接选择工具将效果应用于组中的对象。)

    描边

    仅影响对象的描边(包括其间隙颜色)。

    填色

    仅影响对象的填色。

    文本

    仅影响对象中的文本而不影响文本框架。应用于文本的效果将影响对象中的所有文本;不能将效果应用于个别单词或字母。

    还可以在“控制”面板中选择级别设置:单击“将效果应用于对象”按钮 ,然后选择“对象”、“描边”、“填色”或“文本”。

  4. 要打开“效果”对话框,执行以下操作之一:
    • 在“效果”面板或“控制”面板中,单击 FX 按钮 ,然后从菜单中选择一种效果。

    • 从“效果”面板菜单,选择“效果”,然后选择一个效果名称。

    • 从上下文菜单,选择“效果”,然后选择一个效果名称。

    • 选择“对象”>“效果”,然后选择一个效果名称。

    • 如有必要,在“效果”面板中单击三角形以显示级别设置,然后在“效果”面板中双击一个级别设置(“对象”、“描边”、“填色”或“文本”)。通过双击,可以打开“效果”对话框并选择一个级别设置。

  5. 选择效果选项和设置。(请参阅常用透明度设置和选项。)

  6. 单击“确定”。

编辑透明效果

  1. 选择一个或多个已应用效果的对象。
  2. 执行下列操作之一,打开“效果”对话框。
    • 在“效果”面板上,双击对象右侧(而非面板底部)的 FX 图标。(可能需要单击词语对象旁的三角形,以显示 FX 图标。)

    • 选择要编辑的效果的级别,在“效果”面板中单击 FX 按钮 ,然后选择一个效果名称。

  3. 编辑效果。

复制透明效果

  1. 要复制透明效果,执行以下操作之一:
    • 要在对象之间复制效果,请选择具有要复制的效果的对象,再在“效果”面板中选择该对象的 FX 图标 ,然后将 FX 图标拖动到另一个对象。只能在同一级别的对象之间拖放效果。

    • 要有选择地在对象之间复制效果,请使用吸管工具 。要控制用吸管工具复制哪些透明度描边、填色和对象设置,请双击该工具打开“吸管选项”对话框。然后,选择或取消选择“描边设置”、“填色设置”和“对象设置”区域中的选项。

    • 要在同一对象中将一个级别的效果复制到另一个级别,请在按住 Alt 键 (Windows) 或 Option 键 (Mac OS) 的同时,在“效果”面板上将一个级别的 FX 图标拖动到另一个级别(“描边”、“填色”或“文本”)。

    注意:

    可以通过拖动 FX 图标将同一个对象中一个级别的效果移到另一个级别。

清除对象的透明效果

  1. 执行以下操作之一:
    • 要清除某对象的全部效果、将混合模式更改为“正常”,以及将“不透明度”设置更改为 100%,请在“效果”面板中单击“清除全部效果”按钮 ,或者在“效果”面板菜单中选择“清除全部透明度”。

    • 要清除全部效果但保留混合和不透明度设置,请选择一个级别并在“效果”面板菜单中选择“清除效果”,或者将 FX 图标 从“效果”面板中的“描边”、“填色”或“文本”级别拖动到“废纸篓”图标。

    • 若要清除效果的多个级别(“描边”、“填色”或“文本”),请选择所需级别,然后单击“废纸篓”图标。

    • 要删除某对象的个别效果,请打开“效果”对话框并取消选择一个透明度效果。

透明效果

InDesign 提供了九种透明效果。用于创建这些效果的许多设置和选项都差别不大。

效果
效果

A. 投影 B. 内阴影 C. 外发光 D. 内发光 E. 斜面和浮雕 F. 光泽 G. 基本羽化 H. 定向羽化 I. 渐变羽化 

投影

在对象、描边、填色或文本的后面添加阴影。

内阴影

紧靠在对象、描边、填色或文本的边缘内添加阴影,使其具有凹陷外观。

外发光和内发光

添加从对象、描边、填色或文本的边缘外或内发射出来的光。

斜面和浮雕

添加各种高亮和阴影的组合以使文本和图像具有三维外观。

光泽

添加形成光滑光泽的内部阴影。

基本羽化、定向羽化和渐变羽化

通过使对象的边缘渐隐为透明,实现边缘柔化。

注意:

除了此处提供的说明之外,另请参阅常用透明度设置和选项。

常用透明度设置和选项

在不同效果中,许多透明效果设置和选项是相同的。常用透明度设置和选项如下:

角度和高度

确定应用光源效果的光源角度。值为 0 表示等于底边;值为 90 表示在对象的正上方。可以单击角度半径或输入度数测量值。如果您要为所有对象使用相同的光源角度,请选择“使用全局光”。此设置已用于投影、内阴影、斜面和浮雕、光泽和羽化效果。

混合模式

指定透明对象中的颜色如何与其下面的对象相互作用。已用于投影、内阴影、外发光、内发光和光泽效果。(请参阅指定颜色混合方式。)

收缩

与大小设置一起,确定阴影或发光不透明和透明的程度;设置的值越大,不透明度越高;设置的值越小,透明度越高。已用于内阴影、内发光和羽化效果。

距离

指定投影、内阴影或光泽效果的位移距离。

杂色

指定输入值或拖移滑块时发光不透明度或阴影不透明度中随机元素的数量。已用于投影、内阴影、外发光、内发光和羽化效果。

不透明度

确定效果的不透明度;通过拖动滑块或输入百分比测量值进行操作。(请参阅设置对象的不透明度。)适用于投影、内阴影、外发光、内发光、渐变羽化、斜面和浮雕以及光泽效果。

大小

指定阴影或发光应用的量。已用于投影、内阴影、外发光、内发光和光泽效果。

跨页

确定大小设置中所设定的阴影或发光效果中模糊的透明度。百分比越高,模糊就越不透明。已用于投影和外发光。

方法

这些设置用于确定透明效果的边缘是如何与背景颜色相互作用的。外发光效果和内发光效果都可使用“柔和”和“精确”方法:

柔和

将模糊应用于效果的边缘。在较大尺寸时,不保留详细的特写。

精确

保留效果的边缘,包括其角点和其他锐化细节。其保留特写的能力优于柔和方法。

使用全局光

将全局光设置应用于阴影。已用于投影、斜面和浮雕以及内阴影效果。

X 位移和 Y 位移

在 X 轴或 Y 轴上按指定的偏移量偏离阴影。已用于投影和内阴影效果。

投影

可以使用投影效果创建三维阴影。可以让投影沿 x 轴或 y 轴偏离,还可以改变混合模式、颜色、不透明度、距离、角度以及投影的大小。使用这些选项可以确定投影是如何与对象和透明效果相互作用的:

对象挖空阴影

对象显示在它所投射投影的前面。

阴影接受其它效果

投影中包含其他透明效果。例如,如果对象的一侧被羽化,则可以使投影忽略羽化,以便阴影不会淡出,或者使阴影看上去已经羽化,就像对象被羽化一样。

单击“控制”面板中的“投影”按钮 ,以将投影快速应用于对象、描边、填色或文本,或将其中的投影删除。

注意:

要选择投影的颜色,请单击“设置阴影颜色”按钮(“混合模式”菜单旁边)并选择一种颜色。

内阴影

内阴影效果将阴影置于对象内部,给人以对象凹陷的印象。可以让内阴影沿不同轴偏离,并可以改变混合模式、不透明度、距离、角度、大小、杂色和阴影的收缩量。

外发光

外发光效果使光从对象下面发射出来。可以设置混合模式、不透明度、方法、杂色、大小和跨页。

内发光

内发光效果使对象从内向外发光。可以选择混合模式、不透明度、方法、大小、杂色、收缩设置以及源设置:

指定发光源。选择“中”使光从中间位置放射出来;选择“边缘”使光从对象边界放射出来。

斜面和浮雕

使用斜面和浮雕效果可以赋予对象逼真的三维外观。结构设置确定对象的大小和形状:

样式

指定斜面样式:外斜面在对象的外部边缘创建斜面;内斜面在内部边缘创建斜面;浮雕模拟在底层对象上凸饰另一对象的效果;枕状浮雕模拟将对象的边缘压入底层对象的效果。

大小

确定斜面或浮雕效果的大小。

方法

确定斜面或浮雕效果的边缘是如何与背景颜色相互作用的:平滑方法稍微模糊边缘(对于较大尺寸的效果,不会保留非常详细的特写);雕刻柔和方法也可模糊边缘,但与平滑方法不尽相同(它保留的特写要比平滑方法更为详细,但不如雕刻清晰方法);雕刻清晰方法可以保留更清晰、更明显的边缘(它保留的特写比平滑或雕刻柔和方法更为详细)。

柔化

除了使用方法设置外,还可以使用软化来模糊效果,以此减少不必要的人工效果和粗糙边缘。

方向

通过选择“向上”或“向下”,可将效果显示的位置上下移动。

深度

指定斜面或浮雕效果的深度。

阴影设置可以确定光线与对象相互作用的方式:

角度和高度

设置光源的高度。值为 0 表示等于底边;值为 90 表示在对象的正上方。

使用全局光

应用全局光源,它是为所有透明效果指定的光源。选择此选项将覆盖任何角度和高度设置。

亮光和阴影

指定斜面或浮雕高光和阴影的混合模式。

光泽

使用光泽效果可以使对象具有流畅且光滑的光泽。可以选择混合模式、不透明度、角度、距离、大小设置以及是否反转颜色和透明度:

反转

选择此选项可以反转对象的彩色区域与透明区域。

基本羽化

使用羽化效果可按照您指定的距离柔化(渐隐)对象的边缘。

羽化宽度

用于设置对象从不透明渐隐为透明需要经过的距离。

 

收缩

与羽化宽度设置一起,确定将发光柔化为不透明和透明的程度;设置的值越大,不透明度越高;设置的值越小,透明度越高。

 

角点

可以选择“锐化”、“圆角”或“扩散”:

锐化:沿形状的外边缘(包括尖角)渐变。此选项适合于星形对象,以及对矩形应用特殊效果。

圆角:按羽化半径修成圆角;实际上,形状先内陷,然后向外隆起,形成两个轮廓。此选项应用于矩形时可取得良好效果。

扩散:使用 Adobe Illustrator 方法使对象边缘从不透明渐隐为透明。

杂色

指定柔化发光中随机元素的数量。使用此选项可以柔化发光。

定向羽化

定向羽化效果可使对象的边缘沿指定的方向渐隐为透明,从而实现边缘柔化。例如,可以将羽化应用于对象的上方和下方,而不是左侧或右侧。

羽化宽度

设置对象的上方、下方、左侧和右侧渐隐为透明的距离。选择“锁定”选项可以将对象的每一侧渐隐相同的距离。

杂色

指定柔化发光中随机元素的数量。使用此选项可以创建柔和发光。

收缩

与羽化宽度设置一起,确定发光不透明和透明的程度;设置的值越大,不透明度越高;设置的值越小,透明度越高。

形状

通过选择一个选项(“仅第一个边缘”、“前导边缘”或“所有边缘”)可以确定对象原始形状的界限。

角度

旋转羽化效果的参考框架,只要您输入的值不是 90 度的倍数,羽化的边缘就将倾斜而不是与对象平行。

渐变羽化

使用渐变羽化效果可以使对象所在区域渐隐为透明,从而实现此区域的柔化。

渐变色标

为每个要用于对象的透明度渐变创建一个渐变色标。

  • 要创建渐变色标,请在渐变滑块下方单击(将渐变色标拖离滑块可以删除色标)。

  • 要调整色标的位置,请将其向左或向右拖动,或者先选定它,然后拖动位置滑块。

  • 要调整两个不透明度色标之间的中点,请拖动渐变滑块上方的菱形。菱形的位置决定色标之间过渡的剧烈或渐进程度。

反向渐变

单击此框可以反转渐变的方向。此框位于渐变滑块的右侧。

不透明度

指定渐变点之间的透明度。先选定一点,然后拖动不透明度滑块。

位置

调整渐变色标的位置。用于在拖动滑块或输入测量值之前选择渐变色标。

文字

线性类型表示以直线方式从起始渐变点渐变到结束渐变点;径向类型表示以环绕方式的起始点渐变到结束点。

角度

对于线性渐变,用于确定渐变线的角度。例如,90 度时,直线为水平走向;180 度时,直线为垂直走向。

使用全局光

可以将相同的光源角度应用于包含阴影因素的透明效果:投影、内阴影以及斜面和浮雕。为这些效果选择“使用全局光”时,光源将由“全局光”对话框中的全局设置决定。

  1. 要打开“全局光”对话框,执行以下操作之一:

    • 从“效果”面板菜单选择“全局光”。

    • 选择“对象”>“效果”>“全局光”。

  2. 输入一个值或者拖动角度半径设置“角度”和“高度”,然后单击“确定”。

设置对象的不透明度

可以将透明度应用于单一对象或选定的对象(包括图形和文本框架),但不能应用于个别文本字符或图层。不过,可以正确地显示和打印具有上述类型透明效果的导入图形。

  1. 选择一个或多个对象。

    如果您选择多个对象且其不透明度设置相互冲突,则词语混合 将显示在“效果”面板中。例如,如果在您选择的多个对象中“填色”不透明度设置不一致,则“透明度”调板将显示“填色:不透明度(混合)”。

  2. 为所有方法选择“对象”、“描边”、“填色”或“文本”:
    • 在“控制”面板中单击“应用效果”按钮 ,然后选择一个选项。

    • 在“效果”面板中单击一个选项(如有必要,单击“对象”旁的三角形,以查看选项)。

  3. 在控制面板或“效果”面板中,键入不透明度的值,或单击“不透明度”设置旁的箭头,然后拖动滑块。当对象的不透明度值降低时,其透明度将增加。

注意:

如果在 InDesign 中直接选择并剪切或复制透明组中的对象,然后将其粘贴到文档中的其他位置,则被粘贴对象将不会变成透明状态,除非之前单独选择了该对象并对其应用了透明度。

将透明度应用于组

除了将透明效果应用于单一对象,还可以将其应用于组。

如果仅选择对象并更改其个别不透明度设置,则所选对象的不透明度将相对于其他对象的不透明度而变化。所有重叠区域的不透明度将累加显示。

相反,如果选择用“编组”命令创建的组,然后更改不透明度,则“效果”面板会将该组视为一个对象(“效果”面板仅显示一个级别选项 -“组”),而且不会更改组中的不透明度。换言之,在透明度层面,组中的对象不会相互作用。

将透明度应用于组
选择单独的对象,然后将不透明度设置为 50%(左);选择组,然后将不透明度设置为 50%(右)

更改透明图稿在屏幕上的外观

使用“显示性能”对话框可以设置透明度首选项。这些首选项控制新文档和已修改首选项存储文档中透明对象在屏幕上的显示品质。也可以将首选项设置为打开或关闭文档的透明度显示。在显示首选项中关闭透明度,并不会导致在打印或导出文件时关闭透明度。

注意:

在打印包含透明效果的文件之前,请务必先检查透明度首选项。打印操作会自动拼合图稿,这可能会影响透明效果的外观。

  1. 选择“编辑”>“首选项”>“显示性能”(Windows) 或“Adobe InDesign”>“首选项”>“显示性能”(Mac OS)。
  2. 在“调整视图设置”部分选择一个选项(“快速”、“典型”、“高品质”),以确定文档中的任何效果的屏幕分辨率。更改的设置仅应用于在此处所选的选项:
    • “快速”选项将关闭透明度,并将分辨率设置为 24 dpi。

    • “典型”显示低分辨率效果,并将分辨率设置为 72 dpi。

    • “高品质”选项将提高效果的显示质量(在 PDF 和 EPS 文件中尤为显著),并将分辨率设置为 144 dpi。

  3. 拖动“透明度”滑块。默认设置为“中等品质”,会显示投影和羽化效果。
  4. 单击“确定”。
  5. 当油墨与混合模式重叠时,请选择“视图”>“叠印预览”。此选项确保可以在屏幕上看到所有油墨是如何与透明度相互作用的。

注意:

使用“视图”菜单,可在“快速显示”、“典型显示”和“高品质显示”之间快速更改透明度显示。

停止显示透明度

要提高显示性能,可以关闭透明度显示。关闭透明度屏幕显示不会导致在打印或导出文件时关闭透明度。

  1. 选择“视图”>“显示性能”>“快速显示”。

删除带有透明度的文档中的白框效果

某些情况下,通常在包含投影或渐变的文档中,出现白框或重影边框的位置都应用了透明效果。当透明效果与某种专色相互作用时就会出现此问题。

为了解决此问题,可以避免同时使用专色和透明度,也可以启用叠印。

若要查看和打印 PDF 文档且不带白框效果,请在 Acrobat 中启用模拟叠印。在 Acrobat 9 中,选择“高级”>“印刷制作”>“输出预览”。在 Acrobat X 中,选择“工具”>“印刷制作”>“输出预览”

如果您在将文档发送给打印机时遇到这种白框效果,请要求服务提供商在 RIP 上启用“PostScript 叠印”。如果上述方法仍不起作用,则可以拼合透明度,然后在发送文件前选择“模拟叠印”选项。在 InDesign 中,当您选择“复合 CMYK”选项时,可以在“打印”对话框的“输出”面板中找到此选项。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略