Guida utente Annulla

Identificare e risolvere i problemi del file

  1. Guida utente di InDesign
  2. Informazioni su InDesign
    1. Introduzione a InDesign
      1. Novità di InDesign
      2. Requisiti di sistema
      3. Domande frequenti
      4. Utilizzo delle Creative Cloud Libraries
    2. Area di lavoro
      1. Nozioni di base sull’area di lavoro
      2. Toolbox
      3. Impostare le preferenze
      4. Area di lavoro Tocco
      5. Scelte rapide da tastiera predefinite
      6. Ripristino e annullamento dei documenti
      7. Estensione Capture
  3. Creazione e disposizione dei documenti
    1. Documenti e pagine
      1. Creare documenti
      2. Utilizzo delle pagine principali
      3. Utilizzo delle pagine dei documenti
      4. Impostazione delle dimensioni della pagina, dei margini e della pagina al vivo
      5. Lavorare con file e modelli
      6. Creare file libro
      7. Aggiungere la numerazione di base alle pagine
      8. Numerazione di pagine, capitoli e sezioni
      9. Convertire documenti di QuarkXPress e PageMaker
      10. Condividere contenuti
      11. Comprendere un flusso di lavoro di base per i file gestiti
      12. Salvare i documenti
    2. Griglie
      1. Griglie
      2. Griglie di formato
    3. Riferimenti layout
      1. Righelli
  4. Aggiungi contenuto
    1. Testo
      1. Aggiungere testo alle cornici
      2. Concatenamento del testo
      3. Funzioni per l’arabo e l’ebraico in InDesign
      4. Creare testo su un tracciato
      5. Elenchi puntati e numerati
      6. Glifi e caratteri speciali
      7. Composizione del testo
      8. Variabili di testo
      9. Generare i codici QR
      10. Modificare il testo
      11. Allineare il testo
      12. Contornare gli oggetti con il testo
      13. Oggetti ancorati
      14. Contenuti collegati
      15. Formattare i paragrafi
      16. Formattare i caratteri
      17. Trova/Sostituisci
      18. Controllo ortografico e dizionari
    2. Composizione tipografica
      1. Utilizzo dei font in InDesign
      2. Crenatura e avvicinamento
    3. Formattare il testo
      1. Formattare il testo
      2. Rientri e tabulazioni
    4. Esaminare il testo
      1. Rilevamento e revisione delle modifiche
      2. Aggiungere note di redazione in InDesign
      3. Importare i commenti PDF
    5. Aggiungere riferimenti
      1. Creare un sommario
      2. Note a piè di pagina
      3. Creare un indice
      4. Note di chiusura
      5. Didascalie
    6. Gli stili
      1. Stili paragrafo e stili carattere
      2. Stili oggetto
      3. Capilettera e stili nidificati
      4. Lavorare con gli stili
      5. Interlinea
    7. Tabelle
      1. Formattare le tabelle
      2. Creare le tabelle
      3. Stili tabella e cella
      4. Selezionare e modificare le tabelle
      5. Tracce e riempimenti delle tabelle
    8. Interattività
      1. Collegamenti ipertestuali
      2. Documenti PDF dinamici
      3. Segnalibri
      4. Pulsanti
      5. Moduli
      6. Gli effetti Animazione
      7. Rimandi
      8. Strutturare i PDF
      9. Transizioni di pagina
      10. Filmati e suoni
      11. Moduli
    9. Grafica
      1. Comprendere tracciati e forme
      2. Disegnare con lo strumento matita
      3. Disegnare con lo strumento penna
      4. Applicare le impostazioni delle linee (tracce) 
      5. Tracciati e forme composte
      6. Modificare i tracciati
      7. Tracciati di ritaglio
      8. Modificare l’aspetto degli angoli
      9. Allineare e distribuire gli oggetti
      10. Grafica collegata e incorporata
      11. Integrare le risorse AEM
    10. Colore e trasparenza
      1. Applicare il colore
      2. Utilizzare colori da grafica importata
      3. Usare i campioni
      4. Inchiostri misti
      5. Tonalità
      6. Comprendere i colori tinta piatta e quadricromia
      7. Miscelare i colori
      8. Sfumature
      9. Convertire la grafica con trasparenza
      10. Aggiungere effetti di trasparenza
  5. Condivisione
    1. Condividere e collaborare        
    2. Condividi per revisione
    3. Revisione di un documento di InDesign condiviso
    4. Gestione del feedback 
  6. Pubblica
    1. Esportare e pubblicare
      1. Publish Online
      2. Esportare contenuti per EPUB
      3. Opzioni Adobe PDF
      4. Esportare i contenuti in formato HTML
      5. Esportare in Adobe PDF
      6. Esportare in formato JPEG
      7. Esportazione HTML
      8. Panoramica di DPS e AEM Mobile
    2. Stampa
      1. Stampare opuscoli
      2. Segni di stampa e pagine al vivo
      3. Stampare documenti
      4. Inchiostri, separazione colore e frequenza dei retini
      5. Sovrastampa
      6. Creare file PostScript ed EPS
      7. Eseguire la verifica preliminare dei file prima della consegna
      8. Stampa di miniature e documenti di grandi dimensioni
      9. Preparare file PDF per i service di stampa
      10. Preparazione delle selezioni colore per la stampa
  7. Estendere InDesign
    1. Automazione
      1. Unione dati
      2. Plug-in
      3. Estensione Capture in InDesign
      4. Script
  8. Risoluzione dei problemi
    1. Problemi risolti
    2. Arresto anomalo all'avvio
    3. Problema cartella Preferenze di sola lettura
    4. Risoluzione dei problemi relativi ai file
    5. Impossibile esportare un PDF
    6. Recupero documenti con InDesign

Riscontri problemi durante l’apertura o il salvataggio dei file di InDesign? Leggete per scoprire di più su probabili cause e le soluzioni.

I problemi a livello di sistema possono causare errori e altri comportamenti anomali. Prima di presumere che un documento sia danneggiato, attenetevi alla seguente procedura:

  1. Esegui lo strumento dell’utilità di ripristino dischi per Windows o macOS.

  2. Verificate che il vostro sistema soddisfi i requisiti minimi di sistema per eseguire la versione più recente di InDesign.

  3. Assicuratevi che InDesign sia aggiornato.

    Aggiornamento di InDesign

I messaggi di sistema InDesign consentono di determinare la causa dell’arresto anomalo fornendo un elenco di scenari che causano problemi. Ecco alcuni scenari e le relative soluzioni:

  Riscontri un problema diverso? Hai bisogno di ulteriore assistenza?

Memoria di sistema insufficiente

InDesign non è in grado di aprire il file quando il sistema non dispone di memoria sufficiente (RAM) per leggere il file. Una delle ragioni per cui si riduce la memoria può essere la presenza di troppe applicazioni aperte sul computer. 

Soluzione

  • Eseguite la pulizia del disco per ridurre il numero di file superflui nell'unità e verificate che la cartella dei file temporanei di Windows sia vuota.
  • Uscite da alcune applicazioni per liberare la memoria di sistema.
  • Se possibile, espandete la RAM del sistema.

Accesso negato

InDesign non è in grado di aprire un file e mostra un messaggio di errore se si verifica uno dei seguenti problemi relativi all’accesso con il file:

Problema

Risoluzione.

Non siete autorizzati ad aprire questo file o le autorizzazioni di accesso richieste non sono disponibili.

Ottenete le autorizzazioni di accesso dal proprietario del file e provate ad accedere nuovamente.

Suggerimento: prima di lavorare su un file condiviso, create una copia locale, se possibile.

Il file è già aperto o è bloccato (in uso) da un altro utente.

Chiudete il file da altre applicazioni o profili utente.

Il file è protetto da password oppure i dati di login o la password del file non sono validi.

Assicuratevi di immettere le credenziali di login corrette.

Il file viene inserito in una rete e il percorso di rete non è raggiungibile.

Controllate la connettività di rete e prova ad accedere nuovamente al file.

File già aperto

InDesign non è in grado di aprire o salvare il file quando è già aperto in un’altra versione di InDesign.

Soluzione

  • Chiudete il file aperto in un'altra versione di InDesign.
  • Se non riuscite a chiudere il file, forzate la chiusura di tutte le versioni di InDesign o riavviate il computer. 
  • Se riscontrate questo problema con il salvataggio del file, provate a cambiare il nome e la posizione del file.

Problemi dispositivo di input/output

InDesign non è in grado di aprire o salvare un file quando l’operazione di lettura o scrittura viene interrotta o non è possibile accedere al file o individuarlo.

Di seguito vengono presentate alcune possibili situazioni in cui si possono verificare interruzioni alle operazioni di lettura o scrittura del file:

Posizione file

Causa

Risoluzione.

Dispositivi rimovibili (stick USB, unità esterna, chiavetta USB, ecc.)

Il dispositivo non è stato rimosso o espulso dal computer in modo sicuro

Assicurati che il dispositivo venga rimosso in modo sicuro dopo un’operazione di lettura o scrittura.

Percorso di rete

Connettività di rete interrotta

Verifica che la connessione di rete sia disponibile.

Posizione condivisa

Il file condiviso non è più disponibile

Assicurati che la posizione condivisa sia accessibile.

File danneggiato

InDesign visualizza un messaggio di errore quando il file è danneggiato oppure tenta di ripristinarlo automaticamente. Selezionate una scheda in base al vostro scenario e seguite i passaggi per la risoluzione dei problemi per provare a ripristinare il contenuto del documento. 

Controllate rapidamente altri fattori esterni

  • Se il documento è stato convertito da Adobe PageMaker, QuarkXPress, o da una versione precedente di InDesign, è necessario riconvertirlo. Se il problema si ripresenta, verificate la presenza di errori nel documento originale nell'app in cui è stato creato prima di convertirlo di nuovo. Un documento PageMaker o QuarkXPress danneggiato rimane probabilmente tale anche dopo la conversione.
  • Se avete ricevuto il documento via e-mail, FTP o supporto rimovibile (come un CD), cercate di ottenerne una copia in un altro modo oppure chiedete al mittente di inviarvelo di nuovo. Un supporto danneggiato o la trasmissione di un'e-mail difettosa possono provocare danni a un documento. Se il documento viene inviato via e-mail, chiedete al mittente di comprimerlo prima dell'invio (ad esempio, utilizzando WinZip o StuffIt di Smith Micro) per proteggere i dati.
  • Disinstalla i plug-in di terze parti da InDesign. A volte i plug-in possono danneggiare i file. Consulta Risoluzione dei problemi dei plug-in di terze parti di InDesign.
  • Utilizza un computer diverso per aprire il documento passando a un ambiente di sistema diverso. È possibile rimuovere le variabili che causano il problema. 
  • InDesign archivia informazioni su plug-in, funzioni e sull'app stessa nei file preferenze: i file InDesign SavedData e InDesign Defaults. Un file delle preferenze di InDesign danneggiato può causare comportamenti anomali con un documento di InDesign. È possibile stabilire se il problema è correlato ai file preferenze semplicemente ripristinandoli o ricreandoli. Per ulteriori informazioni, consulta Ripristino di tutte le preferenze.
  • Aumenta la quantità di spazio disponibile sul disco di avvio. InDesign utilizza file temporanei per archiviare e recuperare i dati; scrive questi file temporanei sul disco di avvio. Come linea guida, lo spazio libero sul disco di avvio dovrebbe essere uguale a tre o cinque volte la dimensione del documento (comprese le immagini collegate) o al dieci percento della capacità del disco, a seconda di quale sia maggiore. È possibile liberare spazio sul disco di avvio eliminando i file non necessari o archiviandoli su partizioni o dischi separati. Per controllare la quantità di spazio disponibile sul disco di avvio:
    • Seleziona l'icona del disco di avvio sul desktop. 
    • Scegli File> Ottieni informazioni > Informazioni generali.
    • Prendi nota della capacità e dello spazio disponibili per il disco.

Soluzione: aprite una copia del documento invece dell'originale.

Quando apri un documento come copia, InDesign legge dal file originale e apre una copia senza titolo. Se puoi aprire una copia del documento, scegli File > Salva con nome, salva la copia con un nome diverso dal documento originale e utilizza la copia al posto del documento originale.

Attenetevi alla seguente procedura per aprire un documento come copia:

  1. Avviate InDesign e scegliete File > Apri.

  2. Selezionate Copia nella finestra di dialogo Apri un file e sfogliate il documento.

  3. Selezionate il documento e fate clic su Apri.

 Prima di iniziare la procedura di risoluzione dei problemi, create una copia di backup del documento danneggiato. Alcune delle seguenti operazioni richiedono la modifica o l'eliminazione di informazioni presenti nel documento.

Una copia di backup del documento consente di recuperare rapidamente le informazioni. Spostate il backup in un'unità locale, se il documento si trova su un volume di rete o su un supporto rimovibile, come un CD o un'unità jump.

Eseguite le procedure descritte nell'ordine in cui sono esposte

  1. Aprire il file in InDesign. 

  2. Scegliete File > Esporta.

  3. Dal menu Salva come, scegliete InDesign Markup (CS4 e versioni successive) o InDesign Interchange (CS3 e versioni precedenti).

  4. Specificate un nome e una posizione per il file, quindi fate clic su Salva.

  5. In InDesign, aprite il file .idml o .inx esportato.

Se il problema è risolto, continuate a utilizzare il file .idml o .inx in sostituzione del documento originale. Se il problema persiste, procedete con il passaggio successivo.

Forzate la ricomposizione di tutte le storie usando la scelta rapida Cmd-Opt-/ su macOS e Ctrl-Alt-/ su Windows.

Eseguire la copia di elementi di una pagina in un nuovo documento spesso comporta la creazione di danni strutturali (interni). Se il problema persiste dopo aver copiato gli elementi di una pagina in un nuovo documento, elimina gli elementi uno ad uno per determinare se il problema è causato da uno di questi.

Seguite questi passaggi per copiare elementi di una pagina in un nuovo documento:

  1. Selezionate File > Nuovo e fate clic su OK nella finestra di dialogo Nuovo documento.

  2. Selezionate Finestra > Affianca per visualizzare entrambi i documenti.

  3. Fate clic sul documento originale per attivarlo.

  4. Selezionate Finestra > Pagine per attivare il pannello Pagine.

  5. Trascinate una pagina o un set di pagine affiancate nella finestra del nuovo documento. InDesign copia la pagina o il set di pagine affiancate nel nuovo documento, aggiungendo pagine se necessario.

  6. Salva il nuovo documento con un nuovo nome (diverso dal nome del documento originale) e prova a riprodurre il problema.

    • Se il problema persiste, il danno non è strutturale (ad esempio, su pagine mastro o di documenti). Elimina gli elementi uno ad uno per determinare se il problema è causato da uno di questi.
    • Se il problema non si ripresenta, il danno è probabilmente strutturale. Ripeti i passaggi da 4 a 7 per ogni pagina o set di pagine affiancate rimanente.

Gli stili creati in InDesign o importati con file creati in altre applicazioni potrebbero essere danneggiati. Inoltre, potrebbero esserci alcune pagine vuote ed elementi non necessari. Per verificare se è così, elimina gli stili e salva di nuovo il documento.

Seguite questi passaggi per eliminare Stili di carattere:

  1. Aprite il documento e scegliete Testo > Stili di carattere.

  2. Selezionate tutti gli stili tranne [Nessuno stile carattere] nel pannello Stili di carattere. Per selezionare più stili, premete Ctrl (Windows) o Comando (macOS) mentre fate clic sugli stili.

  3. Dal menu Stili di carattere, selezionate Elimina stili.

  4. Salvate il documento e verificate se il problema è stato risolto. Se il problema persiste, prova ad eliminare gli stili di paragrafo.

Seguite questi passaggi per eliminare Stili di paragrafo:

  1. Aprite il documento e scegliete Testo > Stili di paragrafo.

  2. Selezionate tutti gli stili tranne [Nessuno stile paragrafo] nel pannello Stili di paragrafo. Per selezionare più stili, premete Ctrl (Windows) o Comando (macOS) mentre fate clic sugli stili.

  3. Dal menu Stili di paragrafo, selezionate Elimina stili.

  4. Salvate il documento e verificate se il problema è stato risolto.

Seguite questi passaggi per eliminare Pagine:

  1. In InDesign, aprite il documento e scegliete Finestra > Pagine.

  2. Nel pannello Pagine, utilizzate lo strumento Selezione per selezionare le pagine che desideri eliminare. Premete Ctrl (Windows) o Comando (macOS) per selezionare più pagine oppure premete il tasto Maiusc per selezionare una serie contigua di pagine.

  3. Nel pannello Pagine, fate clic sull’icona Elimina.

  4. Fate clic su OK per confermare l'eliminazione.

Se il problema si ripresenta dopo aver eliminato alcune pagine, elimina metà delle pagine rimanenti e salva il documento con un nuovo nome. Prova, quindi, a creare nuovamente il problema.

  • Se il problema si ripresenta, una delle pagine rimanenti potrebbe contenere un elemento danneggiato. Continua a eliminare le pagine finché non trovi quella che causa il problema.
  • Se il problema non si ripresenta, una delle pagine eliminate probabilmente conteneva un elemento danneggiato. Ripristina le pagine eliminate fino a che non trovate la pagina che causa il problema.

Dopo aver determinato quale pagina causa il problema, rimuovi e sostituisci gli elementi in essa presenti, tra cui elementi grafici importati, oggetti di disegno di InDesign e cornici di testo.

Per determinare se un problema è causato da un font danneggiato, sostituisci tutti i font utilizzati nel documento con un font standard, ad esempio Arial o Times New Roman. Se il problema si ripresenta, non è dovuto ai font. Se è stato risolto, è possibile che il font o i font originali siano danneggiati o obsoleti. Provate a reinstallare i font originali o cercate di ottenere le versioni aggiornate dal produttore del font.

Se nessuna delle soluzioni precedenti ha esito positivo, ricreate il documento. Eseguite spesso copie di backup e verificate periodicamente il documento per assicurarvi che gli elementi importati non causino il problema.

Problemi imprevisti

Oltre alle situazioni illustrate sopra, InDesign non è in grado di aprire e recuperare un file nei seguenti casi:

  • Errori imprevisti o sconosciuti
  • Il file è danneggiato e non può essere riparato
  • L’estensione del file che stai tentando di aprire non è supportata da InDesign

Soluzione

Consigliamo di condividere i file per aiutarci a scoprire di più sul problema.

Siamo qui per aiutarvi!

Se nessuna soluzione funziona, condividi il file interessato con noi all’indirizzo e-mail idfile@adobe.com. Analizzeremo il problema e ti faremo sapere se il recupero è possibile. 

Quando il file viene condiviso con noi, non solo il team Adobe viene abilitato per trovare una soluzione al problema, ma abbiamo la possibilità di migliorare l’esperienza utente generale identificando e risolvendo altri problemi simili.

Garantiremo che il file rimarrà strettamente riservato e verrà utilizzato solo a scopi di analisi. Verifica che il file che condividi non contenga informazioni personali sensibili.

Faremo del nostro meglio per aiutarti, ma poiché il recupero dipende da diversi fattori, non possiamo promettere una soluzione definitiva.


Risorse correlate

Contattaci

Siamo sempre lieti di ricevere i vostri feedback. Condividete le vostre opinioni con la Community di Adobe InDesign.

Logo Adobe

Accedi al tuo account