Usando il pannello Unione dati in InDesign, potete creare senza difficoltà più variazioni del documento unendo un file sorgente dati (file CSV o TXT) con un documento InDesign. Ad esempio, usate la funzionalità di unione dei dati per creare centinaia di variazioni per lettere modulari, buste o etichette con indirizzi in modo rapido e preciso. La funzione Unione dati è anche detta stampa unione.

Prerequisiti

Tutto ciò di cui avete bisogno per unire i dati è una sorgente dati e un documento di destinazione. 

  • Il file sorgente dati contiene le informazioni che variano in ogni istanza del documento di destinazione, quali i nomi e gli indirizzi dei destinatari di una lettera modulare. Un file sorgente dati è composto da campi e record. I campi sono gruppi di dati specifici, quali il nome dell’azienda o il codice postale, mentre i record sono righe di set completi di dati, quali il nome, l’indirizzo postale, la città, lo stato e il codice postale di una stessa azienda. Un file sorgente dati può essere un file separato da virgole (.csv) o da tabulazioni (.txt) in cui ogni dato è separato dal successivo rispettivamente da una virgola o da una tabulazione.
  • Il documento di destinazione è un documento di InDesign che contiene i segnaposto dei campi di dati, più tutto il materiale standard, il testo e gli altri elementi che rimangono invariati in ogni istanza del documento di unione.

Il documento di unione è il documento di InDesign risultante che contiene i dati standard del documento di destinazione, ripetuti tante volte quanti sono i record della sorgente dati.

Unione dati
Unione dati

A. File sorgente dati B. Documento di destinazione C. Documento di unione 

Pannello Unione dati

Il pannello Unione dati è accessibile da Finestra > Utility. Nel pannello vengono visualizzati il nome e la tipologia di ciascun campo dati. Se nel documento sono stati inseriti campi dati, vengono anche visualizzati i numeri di pagina in cui avete inserito il campo dati.

Pannello Unione dati
Pannello Unione dati

A. Menu Unione dati B. Crea documento unione C. Numero di pagina in cui avete inserito il campo dati D. Anteprima ultimo record E. Anteprima record successivo F. Vai a record G. Anteprima record precedente H. Anteprima primo record I. Anteprima record J. Nome e tipo di campo dati K. Sorgente dati 

Procedura di base per l’unione di dati

1. Pianificate attentamente il documento per stabilire quali campi di dati usare nei documenti sorgente e di destinazione.

Determinate l’aspetto che volete dare al documento finale, in modo da sapere quali campi sono necessari per ottenere l’unione. Ad esempio, per una cartolina da inviare ai clienti, potete utilizzare i seguenti campi di dati:

<<Nome azienda>><<Indirizzo>><<Città>>, <<Stato>><<Codice postale>>

Il foglio di lavoro o il database che usate potrebbe assomigliare al seguente.

Esempio di file di dati
Esempio di file di dati

2. Salvate il file sorgente dati (in genere un foglio di lavoro o un database) in formato di testo delimitato da virgole (.csv) o da tabulazioni (.txt)

Assicuratevi che il file sorgente dati sia strutturato in modo tale da poter includere i campi corretti nel documento di destinazione. Ad esempio, la prima riga di un foglio di lavoro deve contenere i nomi dei campi che userete nel documento di destinazione, quali “Azienda” e “Indirizzo”.

Per ulteriori informazioni, consultate I file sorgente dati.

3. Create un documento di destinazione che includa testo e altri elementi che devono rimanere invariati in ogni versione del documento di destinazione.

Per ulteriori informazioni, consultate I documenti di destinazione.

4. Selezionate la sorgente dati nel pannello Unione dati.

Per ulteriori informazioni, consultate Selezionare una sorgente dati.

5. Inserite i campi visualizzati nel pannello Unione dati nel documento di destinazione.

Potete aggiungere campi di dati sia a una pagina del documento che a una pagina mastro. Se li aggiungete a una pagina mastro, avete a disposizione opzioni aggiuntive.

Per ulteriori informazioni, consultate Inserire campi dati e Aggiungere segnaposto dei campi dati alle pagine mastro.

6. Visualizzate un’anteprima dei record per assicurarvi che il documento di destinazione assuma l’aspetto desiderato.

7. Unite il documento di destinazione al file sorgente dati oppure esportate in formato PDF.

Per ulteriori informazioni, consultate Unire i record.

I file sorgente dati

La sorgente dati in genere viene creata in un’applicazione per fogli di lavoro o database, ma potete crearne una con InDesign o con qualsiasi elaboratore di testi. I file sorgente dati devono essere salvati in formato testo separato da virgole (.csv) o da tabulazioni (.txt). Per ulteriori informazioni sull’esportazione in questi formati, consultate il manuale dell’applicazione sorgente.

In un file di testo delimitato da virgole o da tabulazioni, i record sono separati da segni di paragrafo e i campi da virgole o tabulazioni. Il file sorgente dati può anche includere testo o percorsi che fanno riferimento a immagini presenti sul disco.

Esempio di file sorgente dati delimitato da virgole

Name,Company Name,State 
Bill Tucker,CoreVent Labs,Nevada 
Dat Nguyen,"Brady, Hunt, and Baxter, Inc",Delaware 
Maria Ruiz,"Brinquist Enterprises, Inc.",California

Nota:

Se desiderate includere una virgola o le virgolette in un file delimitato da virgole, inserite il testo fra virgolette, come in “Rossi, Bianchi e Verdi, S.p.A.”. Senza le virgolette ogni nome verrebbe considerato come un campo a parte.

Non è possibile inserire un’interruzione di riga in un campo nel file sorgente dati. Se un campo deve essere diviso su righe diverse, create due diversi campi, ad esempio <<Indirizzo1>> e <<Indirizzo2>>.

Per evitare che nel documento restino righe vuote, al momento dell’unione potete selezionare Elimina righe vuote dai campi vuoti. Tuttavia, se alcuni caratteri o spazi sono presenti nella riga, questa non verrà eliminata.

Aggiungere campi immagine al file sorgente dati

Aggiungendo campi immagine al file sorgente dati, potete far apparire un’immagine diversa in ogni record unito. Ad esempio, quando unite documenti che contengono dati di diverse società, può essere opportuno includere anche i rispettivi logo aziendali.

  1. Aprite il file sorgente dati.
  2. Prima del nome del campo dati digitate un simbolo chiocciola (@) per inserire il testo o il nome di percorso del file immagine.

    Il simbolo @ è necessario solo nella prima riga; quelle successive devono contenere i percorsi delle immagini. I percorsi, che sono sensibili alle maiuscole e minuscole, devono seguire le convenzioni del sistema operativo in cui si trovano i file.

    Nota:

    Se viene visualizzato un messaggio di errore quando digitate il simbolo @ all’inizio del campo, digitate un apostrofo (') prima del simbolo @ (ad esempio, '@Foto) per convalidare la funzione. In alcune applicazioni, quale Microsoft Excel, il simbolo @ è riservato alle funzioni.

(Windows) Esempio di riferimenti a immagini in un file sorgente dati

Nome

Età

@Foto

Bill Tucker

36

C:\Foto\BillTucker.jpg

Dat Nguyen

53

C:\Documenti\dat.gif

Maria Ruiz

26

C:\Foto\Ruiz.psd

(Mac OS) Esempio di riferimenti a immagini in un file sorgente dati

Nome

Età

@Foto

Bill Tucker

36

Mac HD:Foto:BillTucker.jpg

Dat Nguyen

53

Scrivania:Famiglia:dat.gif

Maria Ruiz

26

Mac HD:Foto:Ruiz.psd

Nota:

In InDesign potete visualizzare il percorso di un’immagine nel vostro sistema operativo. Inserite un’immagine in un documento InDesign, quindi usate il pannello Collegamenti per visualizzarne il percorso. Con l’immagine selezionata, scegliete Copia informazioni > Copia percorso completo dal menu del pannello Collegamenti. Dopo aver incollato il percorso nella sorgente dati, potrebbe essere necessario modificarlo. Questa tecnica è particolarmente utile per le immagini che si trovano su un server.

I documenti di destinazione

Dopo avere creato il file dati sorgente, dovete impostare il documento di destinazione e inserirvi i campi del file sorgente dati. Il documento di destinazione contiene testo segnaposto per i campi dei dati e della grafica, ad esempio un’immagine da inserire in tutte le cartoline. Questi campi diventano disponibili dopo aver selezionato una sorgente dati.

Il documento di destinazione contiene campi tratti dalla sorgente dati
Il documento di destinazione contiene campi tratti dalla sorgente dati per i quali è visualizzato del testo segnaposto.

Quando unite i dati, viene creato un nuovo documento in cui i campi sono sostituiti dai dati indicati nel file sorgente dati. Potete inserire campi dati sia in una pagina mastro che in una pagina del documento.

Selezionare una sorgente dati

Prima di inserire i campi nel documento di destinazione, selezionate una sorgente dati nel pannello Unione dati. Potete selezionare una sola sorgente dati per documento di destinazione.

  1. Create o aprite il documento che userete come destinazione.
  2. Scegliete Finestra > Utility > Unione dati.

  3. Dal menu del pannello Unione dati, scegliete Seleziona sorgente dati.

  4. Per modificare le opzioni per il testo delimitato, selezionate Mostra opzioni di importazione.

    InDesign individua automaticamente il tipo di delimitatore e di codifica usati nel file sorgente dati, quindi in genere non è necessario visualizzare le opzioni di importazione. Tuttavia, potete specificare diverse opzioni per codifica e delimitatore, se ritenete che non siano stati identificati correttamente.

  5. Individuate il file sorgente dati e fate clic su Apri.

  6. Se avete selezionato Mostra opzioni di importazione, modificate le opzioni relative al delimitatore e alla codifica secondo necessità, quindi fate clic su OK. I campi dati appaiono nel pannello Unione dati.

Nota:

Se viene visualizzato un avviso di impossibilità di aprire il file o se appaiono campi non corretti nella casella di riepilogo, potrebbe essere necessario modificare il foglio di lavoro o il database e salvarlo in formato delimitato da virgole o testo.

Dopo avere selezionato la sorgente dati e caricato i campi nel pannello Unione dati, le eventuali modifiche apportate alla sorgente dati non vengono applicate al documento di destinazione finché la sorgente dati non viene aggiornata.

Inserire campi dati

Quando selezionate la sorgente dati, nel pannello Unione dati viene visualizzato l’elenco dei nomi dei campi dati. Questi nomi sono identici alle intestazioni delle colonne del file sorgente dati. Vi sono anche icone che indicano se il campo contiene del testo o un’immagine. Quando i campi dati sono aggiunti al documento, diventano segnaposto di campi, ad esempio <<Società>>. Potete selezionare e formattare questi segnaposto come fareste con qualsiasi elemento grafico o di testo.

Potete assegnare un campo immagine a una cornice esistente per creare un’immagine mobile. Oppure, se il cursore testo si trova in una cornice di testo o se è selezionato del testo quando inserite un campo immagine, viene inserito un piccolo segnaposto come cornice agganciata, che potete ridimensionare per determinare le dimensioni delle immagini unite.

Una volta inserito un campo dati, la sorgente dati viene sempre ricordata. Eventuali errori presenti nell’elenco dei campi, quali errori di battitura, campi vuoti e tipi di campo non desiderati, devono essere corretti nell’applicazione sorgente e successivamente aggiornati con il pannello Unione dati.

Inserire un campo dati di testo nel documento di destinazione

  1. Create una cornice di testo su una pagina del documento o su una pagina mastro.

    Per aggiungere i campi dati in una pagina mastro, consultate Aggiungere segnaposto dei campi dati alle pagine mastro.

  2. Portate il cursore nella cornice di testo in cui volete far apparire il segnaposto del campo, oppure selezionate il testo da sostituire.
  3. Per inserire un segnaposto di campo, effettuate una delle seguenti operazioni:
    • Fate clic su un campo nell’elenco del pannello Unione dati.

    • Trascinate il nome di un campo dal pannello Unione dati alla cornice di testo in modo da aggiungere il segnaposto. Se trascinate un campo di testo su una cornice vuota, questa diventa una cornice di testo.

I segnaposto dei campi di testo appaiono nell’applicazione di destinazione circondati da doppie parentesi angolari (ad esempio <<Nome>>) e formattati con gli attributi correnti (quali font e dimensione).

Nota:

Non potete creare un campo valido semplicemente digitando il nome del campo o modificandone uno esistente, ma dovete inserirlo dal pannello Unione dati.

Inserire un campo dati immagine nel documento di destinazione

  • Per inserire un nuovo segnaposto per un elemento grafico agganciato, trascinate un campo immagine su una cornice di testo oppure posizionate il punto d’inserimento in una cornice di testo e fate clic sul campo immagine.
  • Per inserire un nuovo elemento grafico indipendente, trascinate un campo immagine su una cornice vuota o su una cornice grafica esistente. Se trascinate un campo immagine su una cornice vuota, questa diventa una cornice grafica.
  • Per inserire un campo in un gruppo di elementi, celle di tabella o elementi nidificati, trascinate il campo immagine sulla destinazione.

    I segnaposto dei campi immagine sono rappresentati da cornici contenenti il nome del campo.

Aggiungere il codice QR

È possibile integrare un codice QR nel documento di unione. I seguenti tipi di campi per codici QR possono essere aggiunti tramite un flusso di lavoro per unione dati:

  • Testo normale
  • Collegamento Web
  • Messaggio testo
  • E-mail
  • Biglietto da visita

Per generare i codici QR, occorre utilizzare come sorgente dati dei file .csv o .txt contenenti voci nel formato seguente:

  • Testo semplice: nella colonna del codice QR, immettete il testo così com’è.
  • Collegamento ipertestuale: URL:<url> (esempio “URL:http://www.google.com”)
  • Messaggio di testo: SMSTO:<numero telefonico>:<messaggio> (esempio: “SMSTO:9818143551:Hi”)
  • E-mail: MATMSG:\nA:<indirizzo e-mail> (esempio: “MATMSG:\nA:johndoe@adobe.com\nSUB:Ciao;\nBODY:;;”)
  • Biglietto da visita: BEGIN:VCARD\nVERSION:2.1\nN:Smith;John\nFN:John Smith\nORG:Adobe\nTITLE:Engineer\nTEL;CELL:+919876543210\nTEL;WORK;VOICE:123456789\nADR;WORK:;;Street ABC;Seattle;Washington;98101;US\nEMAIL;WORK;INTERNET:abc@adobe.com\nURL:www.adobe.com\nEND:VCARD

Le voci di dati possono essere composte da una combinazione di e-mail, sms, collegamento ipertestuale o testo semplice. Inseritele nel campo .csv e .txt nel formato descritto qui sopra e con il simbolo # nel nome della colonna. Per generare i codici QR, seguite la procedura seguente:

  1. Selezionate Finestra > Utility > Unione dati.

  2. Dal menu a comparsa, scegliete Seleziona sorgente dati.

  3. Selezionate il file dati contenente le informazioni del campo QR. Fate clic su Apri.

  4. Selezionate il segnaposto nel documento.

  5. Fate clic sull’icona Crea documento unione per creare un documento di unione.

Aggiungere segnaposto dei campi dati alle pagine mastro

Se inserite i segnaposto dei dati sulle pagine mastro, avrete i seguenti vantaggi rispetto al loro inserimento sulle pagine del documento:

  • Il documento di unione ottenuto contiene i segnaposto originali sulle pagine mastro e include i risultati dell’unione sulle pagine del documento come elementi della pagina mastro modificati localmente.

  • Il documento di unione mantiene un collegamento con la sorgente dati; se questa viene modificata, potete quindi aggiornare il contenuto del documento di unione scegliendo Aggiorna contenuto nei campi dati. Questa opzione è particolarmente utile se, dopo aver cambiato il layout del documento di unione, dovete aggiungere nuovi dati dalla sorgente dati.

  • Le impostazioni disponibili nella finestra di dialogo Crea documento unione sono le stesse del documento di destinazione. In questo modo potete ricreare rapidamente il documento corrente con lo stesso aspetto. Potete anche usare queste impostazioni condivise per creare un documento identico con una sorgente dati diversa o per creare un nuovo documento con un layout leggermente diverso.

Nota:

Nel caso di campi dati aggiunti a una pagina mastro, accertatevi che la cornice di testo contenente i campi dati sia impostata per consentire modifiche locali. Deselezionate Consenti modifiche locali di elemento mastro con selezione, nel menu del pannello Pagine. Se questa opzione non è selezionata, i dati non vengono uniti. Consultate Creare le pagine mastro.

Non potete inserire campi dati sia sulle pagine mastro che su quelle del documento. Per unire i dati in modo corretto, dovete applicare una mastro che contenga campi dati alla prima pagina del documento.

Nota:

Se appare un messaggio di errore che indica che InDesign non può unire il documento perché non sono presenti segnaposto, potreste aver aggiunto i segnaposto alla pagina mastro sinistra di un documento di una sola pagina. La pagina 1 si basa sulla pagina mastro destra, quindi è in questa pagina mastro che dovete inserire i segnaposto.

Aggiornare, eliminare o sostituire i file sorgente dati

  • Per aggiornare i file sorgente dati, modificate e salvate il file sorgente dati in un formato delimitato da virgole o da tabulazioni, quindi scegliete Aggiorna sorgente dati dal pannello Unione dati.

    Le modifiche si rifletteranno nel pannello Unione dati. Se le modifiche non vengono applicate al documento dopo l’aggiornamento, deselezionate Anteprima, quindi selezionatela di nuovo per riattivarla.

  • Per rimuovere il collegamento con il file sorgente dati, scegliete Rimuovi sorgente dati dal menu del pannello Unione dati.
  • Per passare a un nuovo file sorgente dati, scegliete Seleziona sorgente dati dal menu del pannello Unione dati e indicate il nuovo file sorgente dati. InDesign potrebbe non riconoscere alcuni campi. Nel caso, la soluzione migliore è eliminare e reinserire i campi segnaposto.

Nota:

Se generate un documento di unione da un documento di destinazione in cui i campi dati apparivano sulle pagine mastro, potete aggiornare i campi dati nel documento di unione.

Visualizzare l’anteprima dei record nel documento di destinazione

Prima di unire il documento di destinazione e il file sorgente dati, è utile visualizzare in anteprima i record per assicurarsi che i dati dei campi appaiano correttamente dopo l’unione dati. Quando visualizzate l’anteprima dei record, il pannello Unione dati mostra i dati effettivi del file sorgente dati invece dei segnaposto dei campi. Ad esempio, invece di vedere <<Azienda>>, potreste vedere Adobe . Potete usare i pulsanti di navigazione del pannello Unione dati per passare da un record all’altro.

Se riscontrate problemi in uno o più record, quali errori di battitura o spazi in più, correggete il file sorgente nell’applicazione di origine. Consultate I file sorgente dati.

  1. Fate clic su Anteprima in fondo al pannello Unione dati o scegliete Anteprima dal menu del pannello Unione dati.

  2. Fate clic sui pulsanti di navigazione per passare dai dati di un record a quelli di un altro.

Nota:

Per passare a un record specifico, fate clic sui pulsanti di navigazione in fondo al pannello. Potete anche digitare il numero del record di cui visualizzare l’anteprima nella casella di testo di navigazione in fondo al pannello, quindi premere Invio o A-capo.

Attivare e disattivare l’anteprima

Quando passate da una modalità di anteprima all’altra, potrebbero presentarsi problemi e alcuni potrebbero risolversi da soli. Tenete presente quanto segue:

  • I segnaposto sostituiscono il contenuto in anteprima quando non è selezionata l’opzione Anteprima record. Se eliminate un’immagine e la cornice che la contiene, o eliminate un’intera stringa di testo, quando deselezionate l’opzione Anteprima record non saranno più visibili i segnaposto perché sono stati anch’essi rimossi.

  • Le modifiche impostate nella finestra di dialogo Opzioni inserimento contenuti non vengono applicate finché non fate clic su OK. Inoltre, se è selezionata l’opzione Anteprima record, i dati non rispecchieranno l’aggiornamento delle impostazioni di inserimento finché non la deselezionate e selezionate di nuovo.

  • Se tentate di salvare il documento in modalità di anteprima, viene visualizzato un messaggio in cui si richiede di disattivare la modalità di anteprima prima di salvare il documento.

Modificare i segnaposto dei campi dati

Quando aggiungete un campo dati di testo in un documento, il testo segnaposto del campo viene inserito con gli attributi di formattazione (quali font e dimensione) attivi in corrispondenza del cursore testo. Potete modificare gli attributi del testo segnaposto per applicarli ai dati che lo sostituiranno.

  1. Effettuate una delle seguenti operazioni:
    • Per modificare gli attributi dei segnaposto, selezionate il testo del segnaposto, quindi modificate gli attributi di formattazione come fareste con qualunque altro testo.

    • Per cambiare un segnaposto, selezionate il segnaposto o i dati effettivi e selezionate un nome di campo diverso nel pannello Unione dati.

    • Per eliminare un segnaposto, selezionatelo e premete Backspace o Canc.

Nota:

Nell’Editor brani, i segnaposto di testo sono visualizzati nello stesso formato dei collegamenti ipertestuali. Alcune opzioni del pannello Unione dati non sono disponibili nell’Editor brani.

Impostare le opzioni di inserimento contenuti

Specificate le impostazioni predefinite per il documento corrente o per tutti i futuri progetti di unione dati nella finestra di dialogo Opzioni inserimento contenuti. Potete specificare come viene inserita un’immagine, se le immagini devono essere collegate o incorporate, se eliminare le righe vuote risultanti da campi vuoti e il numero massimo di record da inserire in ogni documento di unione.

  1. Effettuate una delle seguenti operazioni:
    • Per applicare le impostazioni solo al documento corrente, aprite il documento di destinazione.

    • Per applicare le impostazioni a tutti i futuri documenti che create, chiudete tutti i documenti.

  2. Scegliete Finestra > Utility > Unione dati.

  3. Scegliete Opzioni inserimento contenuti dal menu del pannello Unione dati.

  4. Modificate le opzioni di inserimento dei contenuti. Consultate Opzioni di inserimento contenuti.
  5. Fate clic su OK.

Unire i record

Dopo avere formattato il documento di destinazione e inserito i campi del file sorgente dati, potete unire i dati sorgente con il documento di destinazione. Potete unire i record a un altro documento InDesign o direttamente in un PDF. Viene così creato un nuovo documento o file PDF basato su quello di destinazione in cui i campi del documento di destinazione sono sostituiti dai relativi dati provenienti dal file sorgente dati.

Quando unite un documento che contiene dei segnaposto per campi di dati sulle pagine mastro, questi elementi delle pagine mastro saranno copiati nelle pagine mastro del documento appena generato.

Unire i record singoli o i record multipli

  1. Con il documento di destinazione aperto, effettuate una delle operazioni seguenti:
    • Scegliete Crea documento unione dal menu del pannello Unione dati o fate clic sul pulsante Crea documento unione .

    • Scegliete Esporta in PDF dal menu del pannello Unione dati.

    Crea documento unione
    Crea documento unione
  2. Nella scheda Record, in Record da unire, selezionate Tutti i record per unire tutti i record del file sorgente dati; selezionate Record singolo per unire un record specifico; oppure inserite un valore Intervallo corrispondente alla serie di record da unire.

  3. Per Record per pagina di documento, effettuate una delle seguenti operazioni:

    • Selezionate Record singolo in modo che ogni record cominci dall’inizio della pagina successiva.

    • Scegliete Record multipli per creare più di un record per pagina. Questa opzione è utile ad esempio per stampare etichette con indirizzi.

      Non potete unire più record se i campi dati appaiono sulla pagina di un documento di una pubblicazione a più pagine o se i campi dati appaiono su più pagine mastro.

  4. Per aprire automaticamente un resoconto di eventuale testo non inserito durante l’unione dei dati nel documento di InDesign, selezionate Genera resoconto testo non inserito durante la creazione del documento. Consultate Resoconto testo non inserito.

  5. Per visualizzare un avviso di collegamento mancante in caso di immagini non disponibili, selezionate Avverti se mancano le immagini.

  6. Se avete selezionato Record multipli nella scheda Record, fate clic sulla scheda Layout di record multipli e specificate le seguenti opzioni:

    • Per Margini, digitate i valori desiderati per la distanza tra le guide dei margini e ogni bordo della pagina.

    • Per Layout dei record, selezionate Prima le righe o Prima le colonne, quindi specificate la spaziatura da inserire fra le colonne e le righe.

  7. Se avete selezionato Record multipli, selezionate Anteprima layout con più record per controllare le modifiche apportate nella finestra di dialogo Crea documento unione. Per navigare tra i record, potete fare clic sui pulsanti relativi alle pagine.

  8. Fate clic sulla scheda Opzioni e specificate le opzioni di inserimento. Consultate Opzioni di inserimento contenuti.

  9. Al termine, fate clic su OK.

  10. Se state effettuando l’esportazione direttamente in PDF, specificate le opzioni PDF e fate clic su Esporta. Specificate un nome di file e un percorso, quindi fate clic su Salva. Consultate Opzioni Adobe PDF.

Se il file sorgente dati fa riferimento a un file in formato non supportato o le immagini non sono disponibili, potrebbe essere opportuno modificare il file sorgente dati affinché faccia riferimento a un file supportato, correggere i percorsi che rimandano a file mancanti o semplicemente spostare i file nelle cartelle corrette in modo che vengano trovati e inseriti.

Limitazioni nell’unione di record multipli

Potete scegliere Record multipli per creare più di un record per pagina. Ad esempio, per la stampa di etichette di indirizzi, è necessario stampare più etichette su una stessa pagina. Il modo con cui i record vengono presentati nella pubblicazione unita dipende principalmente dalle opzioni di layout. Viene di seguito proposto un elenco di possibili limitazioni relative all’uso dell’opzione Record multipli:

  • Non potete unire più record se i campi dati appaiono sulla pagina di un documento di una pubblicazione a più pagine o se i campi dati appaiono su più pagine mastro.

  • L’unione dati consente l’uso di segnaposto di una sola dimensione.

  • Se si cancella un record nella pubblicazione unita, i record restanti non verranno ridisposti nel segnaposto vuoto.

Unione di dati in un file PDF

Le opzioni disponibili per effettuare l’unione dati in file PDF corrispondono a quelle disponibili per la creazione di un documento di unione dati InDesign. Il PDF risultante usufruisce dei vantaggi delle specifiche PDF XObjects per le parti statiche della pagina, che consentono di ottenere un file PDF efficiente e di dimensioni ridotte.

Aggiornare i campi dati

Dopo aver unito un documento con segnaposto di dati sulle pagine mastro, potete modificare il layout del documento di unione e aggiornare comunque i valori dei campi dati nella sorgente dati. Per aggiornare i campi dati mantenendo inalterato il layout del documento, scegliete Aggiorna campi dei dati. Quest’opzione è disponibile solo in un documento di unione in cui i segnaposto dei dati appaiono sulle pagine mastro.

  1. Apportate le modifiche necessarie al file sorgente dati, quindi salvate e chiudete il file sorgente dati.
  2. Nel documento di unione, scegliete Aggiorna campi dei dati.

Le modifiche che avete apportato aggiornando i campi dati appaiono in un file registro.

Nota:

Questa opzione dà i risultati migliori quando vi limitate a modificare o aggiungere i record nel file sorgente dati. Se aggiungete campi segnaposto o nuovi campi alla sorgente dati, o modificate le impostazioni nella finestra di dialogo Crea documento unione, create un nuovo documento di unione mediante l’opzione Crea documento unione.

Resoconti testo non inserito

Il Resoconto testo non inserito viene visualizzato se nella finestra di dialogo Crea documento unione è selezionata l’opzione Genera resoconto testo non inserito e se uno o più campi contengono testo non inserito dopo l’unione dati.

Il resoconto contiene un elenco numerato di tutte le istanze di testo non inserito, con il numero della pagina in cui appare il testo, il numero di caratteri e parole non inseriti e un frammento del testo non inserito.

Se il resoconto compare quando create un documento di unione dati, utilizzatelo per correggere la condizione di testo non inserito. Ad esempio, potete aumentare la dimensione della cornice di testo, ridurre la dimensione font o modificare il testo.

Opzioni di inserimento contenuti

Le seguenti opzioni appaiono nella finestra di dialogo Opzioni inserimento contenuti:

Adatta immagini proporzionalmente

Mantiene le proporzioni dell’immagine, ma la ridimensiona adattandola alla cornice (impostazione predefinita).

Adatta immagini a cornici

Ridimensiona ogni immagine in modo che acquisisca le stesse proporzioni della cornice.

Adatta cornici a immagini

Mantiene invariate le dimensioni dell’immagine e adatta la cornice.

Mantieni dimensioni cornice e immagine

Inserisce l’immagine nelle sue dimensioni originarie nella cornice, allineata all’angolo in alto a sinistra della cornice. Se è troppo grande per la cornice, l’immagine viene ritagliata.

Riempi cornici proporzionalmente

Inserisce l’immagine in modo da riempire completamente la cornice sfruttando l’intera altezza o larghezza dell’immagine e ritagliando il resto.

Adatta in base al contenuto

Adatta automaticamente un’immagine all’interno di una cornice sulla base del contenuto dell’immagine e della dimensione della cornice.

Centra nella cornice

Allinea il centro dell’immagine al centro della cornice. Questa opzione è disattivata se è stata selezionata l’opzione Adatta in base al contenuto.

Collega immagini

Crea un collegamento, o percorso, al file di immagine originario. Se questa opzione non è selezionata, tutti i dati dell’immagine saranno incorporati nel documento di InDesign.

Elimina righe vuote dai campi vuoti

Rimuove i ritorni a capo inseriti per i campi vuoti. L’opzione è particolarmente utile per i mailing in cui vi è un campo indirizzo opzionale. I ritorni a capo normali (non forzati) vengono ignorati. Se alcuni caratteri o spazi sono presenti nella riga, questa non verrà eliminata.

Limite record per documento

Specifica il numero massimo di record da inserire in ogni documento di unione. Al raggiungimento di questa soglia, viene creato un nuovo documento con il numero di pagine necessarie per contenere i rimanenti record da unire (fino al limite di record). L’opzione è disponibile solo quando è selezionato Record singolo.

Limite pagine per documento

Specifica il numero massimo di pagine per ciascun documento di unione. Quando viene raggiunta la soglia, viene creato un nuovo documento con il numero di pagine necessarie per contenere i rimanenti record da unire (fino al limite per pagina). Questa opzione è disponibile solo quando durante l’unione è selezionata l’opzione Record multipli nel menu Record per pagina di documento.

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online