يشرح هذا المستند طريقة تعيين أزرار الإجراءات في نماذج PDF. (إذا كنت تبحث عن معلومات حول طريقة إنشاء نموذج من الصفر وتوزيع نموذج أو تتبع نموذج أو تعبئة نموذج وتوقيعه، فانقر فوق الرابط المناسب أعلاه. لاستكشاف الأسئلة الشائعة عن النماذج، انقر فوق رابط الأسئلة الشائعة عن النماذج.)

 

حول الأزرار

ترتبط الأزرار عادة بالنماذج، لكن يمكنك إضافتهم إلى أي وثيقة. يمكن أن تفتح الأزرار ملفاً، وتشغل صوتاً أو فيلماً، وتسلم بيانات إلى خادم ويب، وأكثر. عندما تقرر كيفية بدء العملية، تذكر أن الأزرار توفر الإمكانيات التالية التي لا توفرها الروابط والإشارات المرجعية.

  • يمكن أن يقوم الزر بتنشيط عملية واحدة أو سلسلة من العمليات.

  • يمكن أن يقوم زر بتغيير مظهر في استجابة لعمليات ماوس.

  • يمكن أن يتم نسخ الزر بسهولة في العديد من الصفحات.

  • عمليات الماوس يمكن أن تنشط عمليات زر مختلفة. على سبيل المثال، يمكن لـ Mouse Down (نقرة) وMouse Up (تحرير بعد نقرة) وMouse Enter (تحريك المؤشر فوق الزر) وMouse Exit (تحريك المؤشر بعيدًا عن الزر) جميعًا بدء تشغيل إجراء مختلف لنفس الزر.

    الأزرار هي طريقة سهلة وبسيطة لتتيح للمستخدمين بدء عملية في ملفات PDF. يمكن أن يكون للأزرار تركيب من العلامات والأيقونات لتوجيه المستخدمين من خلال سلسلة من العمليات أو الأحداث بالتغيير الذي يحدث عند تحريك الماوس. على سبيل المثال، يمكنك إنشاء أزرار بعناوين "Play"، "Pause"، و"Stop" وأيقونات مناسبة. ثم يمكنك ضبط عمليات لتلك الأزرار لتشغيل، وإيقاف مؤقت، وإيقاف قصاصة فيلم. يمكنك تحديد أي تركيب من سلوك الماوس لزر وتعيين أي تركيب من العمليات لسلوك الماوس.

إضافة زر إلى نموذج Acrobat PDF

  1. تأكد أنك في وضع التحرير بتحديد Tools >‏ Prepare Form ثم تحديد Button في شريط الأدوات. يصبح مؤشرك على شكل علامة تنشين.

  2. على الصفحة، انقر فوق أين تريد إضافة الزر لإنشاء زر بالحجم الافتراضي. من أجل زر بحجم مخصص، اسحب مستطيل لتحديد حجم الزر.
  3. قم بالنقر المزدوج على حقل زر، ثم حدد اسم، نص الملاحظات المختصرة، وخصائص عامة أخرى.
  4. انقر فوق صفحة Appearance، ثم قم بتعيين خيارات لتحدد كيف سيبدو الزر على الصفحة. تذكر، إذا قمت بتحديد لون خلفية، لن تتمكن من أن ترى من خلاله أي صور خلف الزر. تؤثر خيارات النص على العنوان الذي تحدده في صفحة Options، وليس اسم الزر في صفحة General.

    ملاحظة:

    إذا كان Enable Right-To-Left Language Options محدداً في لوحة International من مربع الحوار Preferences، فإن صفحة Appearance تتضمن خيارات لتغيير نمط الخانة واتجاه النص للأزرار.

  5. انقر فوق صفحة Options، وحدد خيارات لتحدد كيف تظهر العناوين والأيقونات على الزر.
  6. انقر فوق صفحة Actions. قم بتعيين خيارات لتحدد ماذا يحدث عند نقر الزر، مثل الانتقال إلى صفحة مختلفة أو عرض مشهد فيديو.
  7. انقر فوق Close.

    ملاحظة:

    إذا كنت تقوم بإنشاء مجموعة من الأزرار، قد ترغب في انجذاب الكائن إلى خطوط الشبكة أو الأدلة.

  8. لمعاينة الزر واختباره، انقر فوق Preview في الجهة اليمنى من شريط الأدوات. بعد الانتهاء، يمكنك إما النقر فوق Edit للعودة إلى الأداة Prepare Form أو النقر فوق رمز علامة الزائد في الجهة اليمنى من شريط الأدوات لإغلاق الأداة.

إضافة زر إرسال

عندما تقوم بتوزيع نموذج، يتحقق Acrobat آلياً من النموذج. إذا لم يجد زر إرسال، فإنه يقوم بإضافة زر Submit Form إلى شريط رسالة الوثيقة. يمكن للمستخدمين نقر زر Submit Form النماذج المكتملة إليك. إذا لم تكن تنوِ استخدام الزر Submit Form الذي تم إنشاؤه بواسطة Acrobat، فيمكنك إضافة زر إرسال مخصص إلى النموذج الخاص بك.

  1. إذا لم تكن في وضع تحرير النموذج، فاختر Tools ‏> Prepare Form.

  2. باستخدام الأداة Button ، اسحب عبر المساحة المطلوب أن يظهر فيها الزر. قم بالنقر المزدوج على الزر واضبط الخيارات في صفحات General وOptions.

  3. في علامة التبويب Options، اختر خيارًا في القائمة Layout لتسمية الزر وصورة الرمز أو كليهما. قم بتنفيذ أي من الأمرين التاليين أو كلاهما:

    • اكتب نصًا في المربع Label لتعريف الزر على أنه زر الإرسال.

    • انقر Choose Icon وإما أن تكتب المسار إلى ملف الصورة أو انقر Browse وحدد مكان ملف الصورة المطلوب استخدامه.

  4. في علامة التبويب Actions، اختر Submit A Form في القائمة Select Action وانقر فوق Add.

  5. في مربع الحوار Submit Form Selections، قم بأحد الإجراءات التالية:
    • لتجميع بيانات نموذج على خادم، اكتب الموقع في المربع Enter a URL for this link. على سبيل المثال: http://www.[نطاق]/[مجلد]/[مجلد فرعي]/ من أجل عنوان على الإنترنت أو \\[خادم]\[مجلد]\[مجلد فرعي]\ من أجل مكان على الشبكة المحلية.

    • لتجميع بيانات النموذج على هيئة ملحقات بالبريد الإلكتروني، اكتب mailto: متبوعاً بعنوان البريد الإلكتروني. على سبيل المثال، mailto:nobody@adobe.com.

  6. حدد خيارات لـ Export Format وField Selection وDate Options وانقر OK.

  7. انقر فوق Close.

  8. لمعاينة الزر واختباره، انقر فوقPreview في الجهة اليمنى من شريط الأدوات. بعد الانتهاء، يمكنك إما النقر فوق Edit للعودة إلى الأداة Prepare Form أو النقر فوق رمز علامة الزائد في الجهة اليمنى من شريط الأدوات لإغلاق الأداة.

ملاحظة:

إذا رجعت البيانات في تنسيق FDF أو XFDF، فإن عنوان ربط الخادم يجب أن ينتهي بلاحقة #FDF؛ على سبيل المثال، http://myserver/cgi-bin/myscript#FDF.

خيارات Submit Form Selections

تتوفر الخيارات التالية في مربع الحوار Submit Forms Selections:

Enter a URL for this link

يحدد عنوان URL لتجميع بيانات النموذج.

FDF

يرجع مدخلات المستخدم بدون إرجاع ملف PDF التحتي. يمكنك اختيار خيارات لتضمين Field Data وComments وIncremental Changes To The PDF.

ملاحظة:

تحديد الخيار للتغيرات التراكمية يفيد في استلام التواقيع الرقمية بطريقة تسهل قراءتها ومعاد تكوينها من قبل الخادم.

HTML

يؤدي إلى إعادة النموذج بلغة تمييز النص التشعبي.

XFDF

يرجع مدخلات المستخدم على هيئة ملف XML. يمكنك تضمين التعليقات مع بيانات الحقل أو بيانات الحقل فقط.

PDF

يرجع ملف PDF بأكمله مع مدخلات المستخدم.

Field Selection

يحدد أي حقل يتم إرجاعه. لاستلام بعضٍ من بيانات الحقل المكتملة فقط حدد Only These وانقر فوق Select Fields وحدد الحقول المطلوب تضمينها أو استبعادها في مربع الحوار Field Selection.

على سبيل المثال، قد تستخدم هذا لتستبعد بعض الحقول الحسابية أو المكررة التي تظهر في النموذج من أجل مصلحة المستخدم لكنها لا تضيف معلومات جديدة.

Date Options

يجعل التواريخ التي يقوم المستخدم بإدخالها قياسية.

عمل الأزرار تغير المظهر

يمكن أن يكون للزر علامة، أيقونة، أو كلاهما. يمكنك تغير كيف يظهر الزر في كل حالة للماوس (لأعلى، لأسفل، وعند المرور). على سبيل المثال، يمكنك إنشاء زر بالتسمية "Home" حتى ينتقل المؤشر فوق الزر، عندها يمكن أن تكون التسمية "Click to return to home page".

يمكنك عمل أيقونات الزر من أي تنسيق ملف التي يمكن أن يعرضها Acrobat، بما في ذلك PDF، JPEG، GIF، وتنسيقات الصور الأخرى. لأي تنسيق تختاره، يتم استخدام الصفحة بأكملها، بحيث إن رغبت في استخدام جزء فقط من صفحة كأيقونة، تحتاج لحصد الصورة أو الصفحة قبل عمل هذا الإجراء. أصغر حجم صفحة PDF مسموح به هو 1- في -1 بوصة (2.54-في - 2.54 سم). إذا كنت تريد أن تظهر الأيقونة أصغر من 1-في - 1 بوصة، قم بالقياس لتلائم حجم المربع المرسوم باستخدام أداة الزر. يتيح لك النقر فوق Advanced في الصفحة Options من مربع الحوار Button Properties تحديد كيفية تعديل حجم أيقونة الزر حتى يمكن ملاءمته داخل الزر.

تخطيطات الزر
تخطيطات الزر

A. العنوان فقط B. الأيقونة فقط C. الأيقونة أعلى والعنوان أسفل D. العنوان أعلى والأيقونة أسفل E. الأيقونة يسار والعنوان يمين F. العنوان يسار والأيقونة يمين G. العنوان فوق الأيقونة 

زر تحرير

  1. إذا لم تكن في وضع تحرير النموذج، فاختر Tools ‏> Prepare Form.

  2. حدد حقل Button، ثم قم بتنفيذ أي من الأمور التالية:
    • لتحرير خصائص حقل الزر، قم بالنقر المزدوج على الزر.

    • لتغيير مظهر الأزرار، استخدم خيارات المظهر في صفحة Appearance من مربع الحوار Button Properties.

    • لمحاذاة، توسيط، أو توزيع الزر مع حقول النموذج الأخرى، أو لتغيير حجم أو مضاعفة الزر، انقر فوق بزر الماوس الأيمن على الزر ثم اختر خياراً من قائمة السياق.

  3. أغلق كل مربعات الحوار المفتوحة، إن وُجدت. انقر فوق رمز علامة الزائد في الجهة اليمنى من شريط الأدوات Prepare Form لإغلاق الأداة.

تحديد خصائص عرض زر Acrobat

  1. إذا لم تكن في وضع تحرير النموذج، فاختر Tools ‏> Prepare Form.

  2. انقر نقرًا مزدوجًا فوق زر موجود ثم انقر الصفحة Options في مربع الحوار Button Properties.
  3. للتخطيط، اختر نوع عرض العلامة الذي تريد. (لمعلومات عن قياس أيقونات الزر، راجع الإجراء التالي.)
  4. للسلوك، حدد عرض الزر عند نقره.
  5. لتعريف العلامة أو الأيقونة التي تظهر على الزر، قم بما يلي:
    • إذا تم تحديد خيار تسمية من القائمة Layout، فاكتب النص في المربع Label.

    • إذا تم تحديد خيار رمز من القائمة Layout، فانقر فوق Choose Icon ثم انقر فوق Browse وحدد الملف. (انقر فوق Clear لإزالة الرمز المحدد.)

  6. أغلق كل مربعات الحوار المفتوحة، إن وُجدت. انقر فوق رمز علامة الزائد في الجهة اليمنى من شريط الأدوات Prepare Form لإغلاق الأداة.

خيارات Button Behavior

None

يبقي مظهر الزر نفسه.

Push

يحدد مظاهر لحالات الماوس لأعلى، لأسفل، والمرور. حدد خيار تحت حالة، ثم قم بتحديد خيار علامة أو أيقونة:

Up

يحدد ما سيبدو عليه الزر عندما يكون زر الماوس غير مضغوط.

Down

يحدد ما سيبدو عليه الزر عندما يتم ضغط زر الماوس، لكن قبل أن يتم إطلاقه.

Rollover

يحدد ما سيبدو عليه الزر عندما يكون المؤشر فوق الزر.

Outline

يبرز حد الزر.

Invert

يعكس الظلال الداكنة والفاتحة من الزر.

قياس ووضع الأزرار

  1. إذا لم تكن في وضع تحرير النموذج، فاختر Tools ‏> Prepare Form.

  2. انقر نقرًا مزدوجًا فوق زر موجود لفتح مربع الحوار Button Properties.
  3. انقر فوق علامة التبويب Options وحدد أحد خيارات الرمز من القائمة Layout ثم انقر فوق Advanced.

    ملاحظة:

    لا يتوفر الزر Advanced إذا حددت Label Only من القائمة Layout.

  4. حدد خيارًا من القائمة When To Scale:

    Always

    يقيس الأيقونة كما تم تعريفها بغض النظر عن الحجم بالنسبة لحجم الزر.

    Never

    يحافظ على حجم الأيقونة الأصلي؛ يقطع حد الزر الأيقونة إذا لم تتلاءم. إذا تم تحديد Never، فإن خيارات القياس غير متاحة.

    Icon Is Too Big

    يقيس الأيقونة كما تم تعريفها فقط إذا كانت أكبر من الزر.

    Icon Is Too Small

    يقيس الأيقونة كما تم تعريفها فقط إذا كانت أصغر من الزر.

  5. من القائمة Scale، حدد ما إذا يتم قياس الرمز بالتناسب أم لا. إذا تم قياس الأيقونة بالتناسب، فقد تشوه.

  6. لتتأكد من أن الجوانب العليا والسفلى أو اليمنى واليسرى للرمز ملاصقة لحواف الزر، حدد Fit To Bounds.

  7. لتعريف أين يتم وضع الأيقونة في الزر، اسحب أسهم شريط التمرير. يتم تعريف وضع الأيقونة طبقاً لنسبة المسافة المحافظ عليها بين الأيقونة وحد الحقل الأيسر، وبين الأيقونة وحد الحقل الأسفل. الإعداد الافتراضي (50،50) يضع الأيقونة في وسط الحقل. يمكنك النقر فوق Reset في أي وقت للعودة إلى إعداد الوضع الافتراضي.

  8. انقر فوق OK ثم انقر فوق Close.

  9. لمعاينة الزر واختباره، انقر فوق Preview في الجهة اليمنى من شريط الأدوات بعد الانتهاء، يمكنك إما النقر فوق Edit للعودة إلى الأداة Prepare Form أو النقر فوق رمز علامة الزائد في الجهة اليمنى من شريط الأدوات لإغلاق الأداة.

إخفاء زر Acrobat ماعدا أثناء المرور

في بعض الحالات، قد ترغب في أن تكون المساحة السفلية مرئية حتي يتحرك الماوس فوقها. بتبديل الإظهار والإخفاء لزر ما، يمكنك إنشاء تأثير بصري مثير في الوثيقة. على سبيل المثال، عندما تحرك المؤشر فوق مدينة على خريطة، يمكن عرض خريطة مفصلة للمدينة، ويمكن أن تختفي الخريطة المفصلة عندما يتحرك الماوس بعيداً عن المدينة.

إظهار وإخفاء الأيقونات
إظهار وإخفاء الأيقونات

A. المؤشر ليس فوق منطقة الزر B. المؤشر يدخل في منطقة الزر C. المؤشر يخرج من منطقة الزر 
  1. إذا لم تكن في وضع تحرير النموذج، فاختر Tools ‏> Prepare Form.

  2. باستخدام الأداة Button ، اسحب عبر المنطقة المطلوب ظهور الزر المنبثق فيها. على سبيل المثال، إذا احتوى ملف PDF على خريطة فرنسا، اسحب عبر المساحة التي تريد أن تنبثق عندها خريطة مفصلة لباريس.

  3. انقر نقرًا مزدوجًا فوق الزر وانقر فوق علامة التبويب Options واختر Icon Only من القائمة Layout.

  4. اختر Push من القائمة Behavior ثم اختر Rollover من القائمة State.

  5. انقر فوق Choose Icon ثم انقر فوق Browse. حدد نوع الملف من File Of Type وانتقل إلى موقع ملف الصورة ثم انقر نقرًا مزدوجًا فوق الملف. في هذا المثال، قد تحدد خريطة باريس. انقر فوق OK لقبول الصورة التي تمت معاينتها على أنها الزر.

  6. انقر صفحة Appearance. وإذا لزم الأمر، فقم بإلغاء تحديد Border Color وFill Color ثم انقر فوق Close.

  7. إذا كنت في وضع التحرير، فانقر فوق Preview. يظهر حقل الصورة التي قمت بتعريفها عندما يمر المؤشر فوق مساحة الزر ويختفي عندما يخرج.

    ملاحظة:

    إذا كنت تريد أن تكون الصورة أكبر من مساحة المرور، أو إذا كنت تريد الصورة أن تصبح في مكان مختلف عن صورة الزر التي تنبثق، استخدم عملية Show/Hide A Field. أولاً، تقوم بتعيين أيقونة للزر الذي ستظهر وتختفي. بعد ذلك، تقوم بإنشاء زر ثاني يعمل كمنطقة حساسة عندما يمر الماوس فوقها. لا تقوم بتعيين أيقونة لمظهر الزر الثاني. بدلاً من ذلك، استخدم صفحة Actions لإظهار الزر الأول عندما يدخل الزر الثاني، وإخفاء الزر الأول عندما يخرج المؤشر.

  8. بعد الانتهاء، يمكنك إما النقر فوق Edit للعودة إلى الأداة Prepare Form أو النقر فوق رمز علامة الزائد في الجهة اليمنى من شريط الأدوات لإغلاق الأداة.

تم ترخيص هذا العمل بموجب الترخيص العام غير المعدل الخاص بالإسناد وعدم التجارة والمشاركة الإصدار 3.0 ‏من ‏‏Creative Commons‏‏  إن بنود Creative Commons لا تشمل منشورات Twitter™‎ وFacebook.

إشعارات قانونية   |   سياسة الخصوصية على الإنترنت