В этом документе рассматриваются основы создания композиций в After Effects

Сведения о композициях

Композиция — это основа видеофильма. Каждая композиция имеет собственный таймлайн. Обычно композиция содержит несколько слоев, которые представляют собой компоненты, такие как видео- и аудиоряд, анимированный текст и векторную графику, неподвижные изображения и источники света. Добавить видеоряд в композицию можно путем создания слоя, для которого этот видеоряд будет источником. Можно упорядочивать слои композиции в пространстве и времени, а также компоновать их с помощью функции прозрачности, чтобы указать, какие части подлежащих слоев следует отобразить на верхних слоях. (См. разделы Слои и свойства и Прозрачность и композиция.)

Композиция в After Effects аналогична видеоролику в программе Flash Professional или эпизоду в Premiere Pro.

Запустите рендеринг композиции для создания кадров фильма, который кодируется и экспортируется в любой формат. (См. раздел Основы рендеринга и экспорта.)

Простые проекты могут содержать только одну композицию; сложные проекты могут содержать сотни композиций для создания видеоряда большого объема или множества эффектов.

В некоторых местах пользовательского интерфейса After Effects композиция сокращается до «комп.».

Для каждой композиции на панели «Проект» имеется соответствующая запись. Для открытия композиции в отдельной панели «Таймлайн» дважды щелкните соответствующую запись на панели «Проект». Для выбора композиции на панели «Проект» щелкните правой кнопкой мыши (Windows) или нажмите клавишу CONTROL (Mac OS) на панели «Композиция» или панели «Таймлайн» и выберите в контекстном меню «Показать композицию в окне "Проект"».

Для предпросмотра композиции и изменения ее содержимого вручную используйте панель «Композиция». Панель «Композиция» содержит кадр композиции и область монтажного стола за пределами кадра, которую можно использовать для перемещения слоев в кадр и из него. Выступающие сегменты слоев — участки вне кадра композиции — отображаются в виде прямоугольных контуров. Для предпросмотра и вывода конечного результата выполняется рендеринг только область внутри кадра композиции.

Кадр композиции на панели «Композиция» в After Effects аналогичен сцене в программе Flash Professional.

При работе со сложным проектом проще всего упорядочить его, вкладывая композиции, т. е. перенося одну или несколько композиций в другую. Можно создать композицию из любого количества слоев с помощью предварительной композиции. После редактирования некоторых слоев, их можно собрать в предварительную композицию, а затем выполнить предварительный рендеринг и заменить готовым фильмом. (См. раздел Предварительная композиция, вложение и предварительный рендеринг).

С помощью навигатора композиции и графического мини-представления композиции можно перемещаться по иерархии вложенных композиций. (См. раздел Открытие вложенных композиций и перемещение между ними.)

Для просмотра структуры сложной композиции или сети композиций используйте панель «Графическое представление».

Кнопка «Таймлайн»

 Нажмите эту кнопку, расположенную в нижней части панели «Композиция», для активации панели «Таймлайн» текущей композиции.

Примечание.

Для переключения между панелью «Композиция» и панелью «Таймлайн» текущей композиции нажмите клавишу обратной косой черты (\).

Кнопка «Композиция»

 Нажмите эту кнопку, расположенную в правой верхней части панели «Таймлайн», для активации панели текущей композиции.

Кнопка «Графическое представление»

 Нажмите эту кнопку, расположенную в нижней части панели «Композиция», для активации панели «Графическое представление» текущей композиции.

Создание композиции

Можно в любой момент изменить настройки композиции. Однако такие настройки, как пропорции и размер кадра, рекомендуется задать при создании композиции, исходя из параметров ожидаемого финального фильма. Поскольку программа After Effects использует эти настройки композиции для выполнения определенных вычислений, то их изменение на более поздних этапах рабочего процесса может повлиять на конечный результат.

Примечание.

Можно переопределить некоторые настройки композиции перед рендерингом конечного фильма. Например, можно использовать разные размеры кадра для одного и того же фильма. Дополнительные сведения см. в разделах Настройки рендеринга и Модули вывода и их параметры.

При создании композиции без изменения параметров в диалоговом окне «Настройки композиции» новая композиция использует настройки предыдущей.

Примечание.

Новые композиции не наследуют следующие настройки: «Сохранить частоту кадров при выполнении вложения или в очереди рендеринга» и «Сохранить разрешение при выполнении вложения».

Джефф Алмасол (Jeff Almasol) предлагает на своем веб-сайте redefinery сценарий, который создает и сохраняет новый проект для каждой выбранной композиции в текущем проекте. Если при создании новой композиции на панели «Проект» выбрана папка, то новая композиция будет сохранена в ней.

Создание композиции и настройка параметров вручную

  1. Выберите «Композиция» > «Новая композиция» или нажмите комбинацию клавиш CTRL+N (Windows) или COMMAND+N (Mac OS).

Создание композиции из одного видеоряда

  1. Перетащите видеоряд на кнопку «Создать новую композицию» в нижней части панели «Проект» или выберите в меню «Файл» пункт «Новая композиция из выделенной области».

    Настройки композиции, такие как размер кадра (ширина и высота) и пропорции пиксела, автоматически устанавливаются в соответствии с характеристикам видеоряда.

Создание одной композиции из множества видеорядов

  1. Выберите видеоряд на панели «Проект».
  2. Перетащите выбранные видеоряды на кнопку «Создать новую композицию» в нижней части панели «Проект» или выберите в меню «Файл» пункт «Новая композиция из выделенной области».
  3. Выберите «Одна композиция» и другие настройки в диалоговом окне «Создать композицию из выбранных элементов».

    Использовать размер из

    Выберите видеоряд, из которого новая композиция определит настройки, включая размер кадра (ширина и высота) и пропорции пиксела.

    Продолжительность стоп-кадра

    Добавление длительности стоп-кадра.

    Добавить в очередь рендеринга

    Добавление новой композиции в очередь рендеринга.

    Слои эпизода, наложение, длительность и переход

    Расположите слои в эпизоде, при необходимости наложите их заранее, задайте длительность переходов и выберите тип перехода.

Создание нескольких композиции из нескольких видеорядов

  1. Выберите видеоряд на панели «Проект».
  2. Перетащите выбранные видеоряды на кнопку «Создать новую композицию» в нижней части панели «Проект» или выберите в меню «Файл» пункт «Новая композиция из выделенной области».
  3. Выберите «Несколько композиций» и другие настройки в диалоговом окне «Создать композицию из выбранных элементов».

    Продолжительность стоп-кадра

    Длительность композиций, созданных из стоп-кадров.

    Добавить в очередь рендеринга

    Добавление новых композиций в очередь рендеринга.

Примечание.

Если выбрать нескольких элементов видеоряда, отображается диалоговое окно «Создать композицию из выбранных элементов». Можно по выбору создать одну композицию со всеми элементами видеоряда или несколькими композиций для каждого отдельного элемента видеоряда.

Выбор композиции
Выбор композиции

Дублирование композиции

  1. Выберите композицию на панели «Проект».
  2. Выберите «Правка» > «Дублировать» или нажмите клавиши CTRL+D (Windows) или COMMAND+D (Mac OS).

Панель «Таймлайн»

Каждая композиция имеет собственную панель «Таймлайн». С помощью панели «Таймлайн» можно выполнять множество таких задач, как анимация свойств слоя, подготовка слоев и настройка режимов наложения. В первую очередь выполняется рендеринг слоев в нижней части стека наложения слоев на панели «Таймлайн», и в случае наличия слоев с 2D-изображениями они отображаются на самом дальнем плане на панели «Композиция» и в окончательном фильме.

Примечание.

Для перехода вперед между панелями «Таймлайн» используйте сочетание клавиш ALT+SHIFT+. (точка) (Windows) или OPTION+SHIFT+. (точка) (Mac OS). Для перехода между панелями «Таймлайн» в обратном порядке используйте клавиши ALT+SHIFT+, (запятая) (Windows) или OPTION+SHIFT+, (запятая) (Mac OS).

Текущее время композиции отображается индикатором текущего времени (CTI) — вертикальная красная линия на шкале времени. Текущее время композиции также присутствует на мониторе текущего времени в левом верхнем углу панели «Таймлайн». Дополнительные сведения о перемещении индикатора текущего времени см. в разделе Перемещение индикатора текущего времени.

В левой части панели «Таймлайн» находятся столбцы с элементами управления слоями. В правой части панели «Таймлайн» — на временной диаграмме — находятся линейка времени, маркеры, ключевые кадры, выражения, панели длительности слоев (в режиме панелей слоев) и редактор диаграмм (в режиме редактора диаграмм).

Timeline Panel AE

Примечание.

Для переключения между панелью «Композиция» и панелью «Таймлайн» текущей композиции нажмите клавишу обратной косой черты (\).

Настройки композиции

Настройки композиции можно задать вручную или использовать шаблоны настроек композиции для автоматической установки значений размера кадра (ширина и высота), пропорций пиксела и частоты кадров для наиболее распространенных форматов. Также можно создавать и сохранять собственные шаблоны настроек композиции для последующего использования. Настройки «Разрешение», «Начало тайм-кода» (или «Начальный кадр»), «Длительность» и «Дополнительные настройки» не сохраняются вместе с шаблонами настроек.

Примечание.

Максимальная допустимая длительность композиции составляет 3 часа. Можно использовать видеоряды длительностью более 3 часов, но время после 3 часов будет отображаться некорректно. Максимальный размер композиции 30 000x30 000 пикселей. Изображение с расширением 30 000x30 000 с разрядностью цвета 8 бит на канал занимает примерно 3,5 ГБ; максимальный размер композиции может быть меньше, в зависимости от операционной системы и доступной оперативной памяти.

Работа с настройками композиции

  • Для открытия диалогового окна «Настройки композиции» и изменения настроек выполните одно из предложенных ниже действий.

    • Выберите композицию на панели «Проект» или активируйте панель «Таймлайн» или панель «Композиция» и выберите «Композиция» > «Настройки композиции» или нажмите клавиши CTRL+K (Windows) или COMMAND+K (Mac OS).

    • Щелкните панель «Проект» или панель «Композиция» правой кнопкой мыши (Windows) или щелкните панель, удерживая нажатой клавишу CONTROL (Mac OS), (не на слое) и выберите в контекстном меню пункт «Настройки композиции».

  • Для сохранения пользовательского шаблона настроек композиции установите значения для параметров «Ширина», «Высота», «Пропорции пиксела» и «Частота кадров» в диалоговом окне «Настройки композиции», а затем нажмите кнопку «Сохранить» .

  • Для удаления шаблона настроек композиции выберите его в меню «Шаблон настроек» в диалоговом окне «Настройки композиции» и нажмите кнопку «Удалить» .

  • Для восстановления шаблонов настроек композиции по умолчанию в диалоговом окне «Настройки композиции» нажмите кнопку «Удалить» или «Сохранить» , удерживая нажатой клавишу ALT (Windows) или OPTION (Mac OS).

Примечание.

Пользовательские шаблоны настроек композиции нельзя перемещать из одной системы в другую, так как они встроены в файл установок.

  • Для масштабирования всей композиции выберите «Файл» > «Сценарии» > «Масштабировать Composition.jsx».

Примечание.

Убедитесь, что все слои выбранной композиции разблокированы, иначе сценарий не выполнится.

Джефф Алмасол (Jeff Almasol) предлагает на своем веб-сайте redefinery сценарий, который устанавливает частоту кадров и длительность текущей композиции и каждой вложенной в нее.

Кристофер Грин (Christopher Green) предлагает на своем веб-сайте сценарий (Selected_Comps_Changer.jsx), с помощью которого можно изменять настройки композиции, выбранной на панели «Проект».

Основные настройки композиции

«Начало тайм-кода» или «Начальный кадр»

Тайм-код или номер, присвоенный первому кадру композиции. Это значение не влияет на рендеринг; оно просто указывает на начало отсчета.

Цвет фона

Для выбора цвета фона композиции используйте палитру цветов или пипетку. (См. раздел Выбор цвета или изменение градиента.)

Примечание. При добавлении одной композиции в другую (вложение) сохраняется цвет фона принимающей композиции, а фон вложенной композиции станет прозрачным. Для сохранения цвета фона вложенной композиции создайте слой со сплошным цветом и используйте его в качестве фонового слоя во вложенной композиции.

Дополнительные сведения об определенных основных настройках композиции, не перечисленных здесь, см. в соответствующих разделах:

Дополнительные настройки композиции

Привязка

Нажмите кнопку со стрелкой, чтобы привязать слои к углу или краю композиции во время изменения размера.

Сохранить разрешение при выполнении вложения и Сохранить частоту кадров при выполнении вложения или в очереди рендеринга

Чтобы композиция сохранила свое разрешение или частоту кадров и не унаследовала эти настройки от композиции, в которой содержится. Например, если вы специально использовали низкую частоту кадров в композиции для создания ручной анимации с эффектом дрожания, необходимо сохранить частоту кадров для этой композиции при ее вложении. Аналогично, результаты ротоскопии могут выглядеть некорректно после изменения частоты кадра или разрешения. Этот параметр следует использовать вместо этого эффекта «Время постеризации», который менее эффективен.

Настройки размытия в движении

  • Угол затвора: угол затвора измеряется в градусах, имитируя экспозицию, предоставляемую вращающимся затвором. Угол затвора использует частоту кадров видеоряда для определения сымитированной экспозиции, влияющей на величину размытия в движении. Например, ввод 90° (25 % от 360°) для видеоряда с частотой 24 кадра/с создает эффективную экспозицию 1/96 секунды (25 % от 1/24 секунды). Ввод 1° практически не создает размытия в движении, а ввод 720° накладывает очень большой объем размытия.
  • Фаза затвора: фаза затвора также измеряется в градусах. Она определяет смещение, по которому определяется момент открытия затвора относительно начала кадра. Путем корректировки этого значения можно исправить ситуацию, когда объект с примененным размытием в движении отстает от объекта без размытия в движении.
  • Выборок на кадр: минимальное количество выборок. Это количество выборок, используемых для кадров, для которых After Effects не может определить адаптивную частоту дискретизации на основе движения слоя. Эта частота дискретизации используется для 3D-слоев и слоев-фигур.
  • Адаптивное ограничение выборок: максимальное количество выборок.

Дополнительные сведения об определенных дополнительных настройках композиции, не перечисленных здесь, см. в соответствующих разделах:

Настройки 3D-рендеринга

Для выбора правильного 3D-рендеринга для композиции можно использовать параметры на вкладке «3D-рендеринг». В меню «Модуль рендеринга» можно выбирать следующие варианты рендеринга:

  • Classic 3D
  • CINEMA 4D
  • 3D-рендеринг с трассировкой лучей

Функциональные возможности работы с объектами 3D в модуле рендеринга композиций CINEMA 4D и «3D-рендеринг с трассировкой лучей» практически идентичны в отношении экструзии слоев 3D-текста и слоев-фигур, а также изгиба других 3D-слоев (включая сплошные заливки, видеоряд и т. д.) в изогнутые плоскости. Однако результаты рендеринга могут отличаться, поскольку они формируются с помощью разных способов рендеринга и разных наборов функций. Например, есть различия в параметрах материала 3D-слоя и поведении других слоев. 

В модуле рендеринга композиций CINEMA 4D выполняется рендеринг 3D-слоев, включая экструдированный текст и фигуры, а также изогнутых 2D-плоскости, для упрощения процесса создания анимации 3D-текстов и логотипов с нуля. Производительность модуля рендеринга CINEMA 4D намного выше, чем производительность модуля рендеринга «3D-рендеринг с трассировкой лучей», в котором задействуется только ЦП.

Вкладка «3D-рендеринг»
Вкладка «3D-рендеринг»

Рендеринг Classic 3D

Classic 3D — стандартный режим рендеринга по умолчанию. Слои располагаются как плоскости в трехмерном пространстве.

Параметры модуля рендеринга композиций CINEMA 4D

Quality (Качество): уровень качества, задаваемый с помощью ползунка, влияет на параметры, которые определяют способ прорисовки 3D-слоев в модуле рендеринга композиций CINEMA 4D. Итоговые параметры рендеринга можно посмотреть в полях «Параметры», «Сглаживание» и «Отражающая способность». Единый параметр «Качество» упрощает выбор сбалансированной комбинации скорости рендеринга и приемлемого качества 3D-рендеринга без необходимости понимания и изменения различных параметров качества рендеринга.

При регулировке ползунка «Качество» изменяются следующие параметры:

  • Пороговое значение лучей: это значение помогает оптимизировать время рендеринга. 
  • Глубина лучей: глубина лучей определяет, через сколько прозрачных объектов (или областей, которые делаются невидимыми с помощью альфа-канала) может пройти луч во время рендеринга. 
  • Глубина отражения: когда луч направляется в сцену, он может быть отражен отражающими поверхностями. Чем выше значение глубины отражения, тем дальше лучи проходят в сцену. Результаты рендеринга меняются соответствующим образом.
  • Глубина тени: параметр глубины тени действует аналогично глубине отражения. Параметр «Глубина тени» определяет глубину тени, с которой рассчитываются видимые лучи тени. 

Сглаживание: «Геометрия» — значение параметра сглаживания по умолчанию, при котором сглаживаются все края объекта (автоматически, с подпикселами 16x16).

Отражающая способность: «Выборка слоя» — значение параметра сглаживающей способности по умолчанию, который определяет качество отражения от матовой поверхности.

При выборе значения Cinema 4D в раскрывающемся меню «Модуль рендеринга» в столбце «Включены» отображаются включенные 3D-параметры, а в столбце «Отключены» отображаются 3D-параметры, которые недоступны.

Параметры модуля рендеринга Cinema 4D
Параметры модуля рендеринга Cinema 4D

Чтобы выбрать уровень качества для 3D-рендеринга, нажмите кнопку «Параметры» после выбора модуля рендеринга Cinema 4D и задайте уровень качества с помощью ползунка Качество. Соответствующим образом изменяются значения параметров Ray Threshold (Порог луча), Ray Depth (Глубина луча), Reflection Depth (Глубина отражения), Shadow Depth (Глубина тени), Anti-Aliasing (Сглаживание) и Reflectance (Отражающая способность).

Настройки ползунка Quality (Качество)
Настройки ползунка Quality (Качество)

After Effects устанавливает на компьютер модуль рендеринга по умолчанию. Вместо него можно использовать платную полнофункциональную версию CINEMA 4D, если она установлена в системе.

В качестве редактора по умолчанию используется самая актуальная установленная версия CINEMA 4D или CINEMA 4D Lite.

Чтобы выбрать другую установку Cinema 4D, щелкните Choose Installation (Выбрать установку) и выберите путь к программе установки в полях Rendering (Рендеринг) и Editing (Редактирование).

Выбор установки CINEMA 4D
Выбор установки CINEMA 4D

Параметры модуля 3D-рендеринга с трассировкой лучей

Для открытия диалогового окна «Параметры модуля 3D-рендеринга с трассировкой лучей» нажмите кнопку «Параметры». Открыть это диалоговое окно можно также нажав кнопку «Текущий индикатор модуля рендеринга», расположенную в правом верхнем углу панели «Композиция», удерживая нажатой клавишу CTRL (Windows) или COMMAND (Mac OS).

Доступные параметры:

  • Качество трассировки лучей. Для изменения качества в соответствии с рабочим процессом щелкните настройку качества трассировки лучей.
    • Более высокие значения качества трассировки лучей уменьшают шум, но значительно увеличивают время рендеринга.
      Качество трассировки лучей определяет число лучей, светящихся в пикселе (например, значение 4 означает 16 лучей (или 4x4), а 8 — это 64 луча).
    • Чем больше значение, тем более точно отрисовывается пиксель за счет увеличения времени вычисления.
    • Значение 1 обеспечивает наилучшую производительность, но тогда не будет никакого размытия отражения (например, оно всегда резкое), мягкой тени, глубины поля или размытия в движении.

Увеличение значения качества трассировки лучей не улучшает резкость. Вместо этого оно снижает шум, возникающий при выборке точки. Используйте самое низкое значение, которое генерирует приемлемый уровень шума или вообще не создает шума.

  • Фильтр сглаживания. Управляет методом усреднения количества лучей, светящихся в пикселе. Нет все лучи светятся в границах пиксела, в то время как через смежные пиксели частично распространяется сетка светящихся лучей для получения лучшего усредненного значения. Значения «Рамка», «Палатка» и «Куб» (не бикубический) перечислены в порядке улучшения качества.
    • Нет
    • Рамка
    • Палатка
    • Куб

Фильтр сглаживания управляет степенью размытия. Значение «Нет» позволяет добиться максимальной резкости, однако края улавливателя проекции при этом можно сделать сглаженными, в то время как размытие «Рамка», «Треугольник» и «Куб» дают более размытые результаты.

Примечание.

Слои с 3D-рендерингом с трассировкой лучей используют качество трассировки лучей для управления отображением размытия в движении.

Вычисления глубины поля в 3D-рендеринге с трассировкой лучей более точные, чем в Classic 3D (ранее Advanced 3D).

Миниатюры композиции

Для отображения миниатюры (афиши) выберите кадр композиции на панели «Проект». По умолчанию в качестве миниатюры используется первый кадр композиции, прозрачные области которого показаны черным.

  • Чтобы задать миниатюру для композиции, переместите индикатор текущего времени на нужный кадр на панели «Таймлайн» и нажмите «Композиция» > «Задать время афиши».
  • Для добавления сетки прозрачности в представление миниатюр выберите «Сетка "Прозрачность миниатюр"» в меню панели «Проект».
  • Для скрытия миниатюр на панели «Проект» выберите «Правка» > «Установки» > «Экран» (Windows) или «After Effects» > «Установки» > «Экран» (Mac OS) и выберите «Отключить миниатюры на панели "Проект"».

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет