Пути маски и формы можно анимировать тем же способом, что и остальные свойства: задать ключевые кадры для свойств «Путь маски» или «Путь», задать пути для каждого ключевого кадра, и After Effects выполнит интерполяцию между заданными значениями.

Введение в ротоскопирование и соответствующие ресурсы

Ротоскопирование (или ротоскопия) является рисованием на кадрах фильма с использованием визуальных элементов фильма в качестве основы. Общий тип ротоскопирования представляет собой отслеживание контуров вокруг объекта в фильме и использование этого контура в качестве маски для разделения объекта и фона. Это позволяет работать с объектом и фоном по отдельности и выполнять по отношению к ним различные действия, например применять различные эффекты к объекту и фону или заменять фон.

Примечание.

After Effects включает инструменты «Кисть для ротоскопии» и «Уточнить края», которые позволяют затрачивать значительно меньше времени на выполнение множества одинаковых задач, например обычного ротоскопирования. Дополнительные сведения об использовании инструмента «Кисть для ротоскопии» см. в разделе Инструменты «Кисть для ротоскопии», «Уточнить края» и «Уточнить подложку».

Примечание.

Если объект фона или переднего плана имеет четкий, определенный цвет, для удаления фона или объекта вместо ротоскопирования можно использовать цветовое наложение. Если особенности съемки видеоряда позволяют использовать цветовое наложение, то это будет гораздо проще, чем ротоскопирование. (См. раздел Введение в работу с прозрачным наложением и рабочий процесс.)

Ротоскопирование в After Effects в основном состоит из рисования масок, анимирования контуров масок, а затем использование этих масок для детализации подложки. Многие дополнительные задания и методы облегчают выполнение этой работы. Например, использование отслеживание движения объекта перед началом рисования маски, а затем использование данных отслеживания движения для создания маски или подложки, которая автоматически следует за объектом.

Советы по ротоскопированию

  • Сразу после начала рисования маски, нажмите ALT+SHIFT+M (Windows) или OPTION+SHIFT+M (Mac OS), чтобы включить для этой маски кадрирование изображений и задать ключевой кадр. Таким образом, не придется тратить лишние несколько минут на покадровое редактирование маски в случае потери результатов работы над предыдущими кадрами из-за того, что не была нажата кнопка секундомера для анимации пути маски.
  • Рисуйте маски на белом сплошном слое с отключенным переключателем «Видео» (зрачок) над (заблокированным) слоем видеоряда. Это позволит избежать случайного перемещения слоя видеоряда во время выполнения манипуляций с маской. Кроме того, это намного облегчает применение к маске данных отслеживания. (Данные отслеживания применяются к невидимому сплошному слою, содержащему маску.) Это также исключает потерю кэшированных в памяти кадров предпросмотра при выполнении любых манипуляций с маской. (См. разделы Включение и выключение видимости или влияния слоя или группы свойств и Блокировка или снятие блокировки со слоя.)
  • Включите параметр «Сохранить номер постоянной вершины». (См. раздел Определение первой вершины для контура Безье.)
  • По возможности преобразуйте (поворот, масштабирование, перемещение) всю маску или подмножество вершин маски вместо перемещения вершин по отдельности. Это более эффективно и позволяет избежать вибрации, которая является следствием несогласованного движения через кадры. (См. раздел Перемещение вершин в режиме свободного преобразования.)
  • Отслеживание движения вручную занимает меньше времени, чем ротоскопирование вручную. Чем больше внимания уделяется получению точных данных отслеживания для разных частей сцен и объекта, тем меньше времени тратится на рисование и настройку маски. (См. раздел Отслеживание и стабилизация движения.)
  • Для более тщательного контроля растушевки объектов используйте функцию Растушевка маски с переменной шириной.

Ресурсы в Интернете, посвященные ротоскопированию

Это видео из серии «After Effects CS5: изучаем по видео» показывает, как объединять отслеживание трассировки движения и ротоскопирование, чтобы изолировать и сделать выборочную цветокоррекцию лица актера.

Скотт Сквайрс (Scott Squires) на своем веб-сайте Effects Corner предлагает несколько видео, которые демонстрируют как использовать ротоскопирование для рисования и маскирования.

Матиас Мёль (Mathias Möhl) опубликовал на своем веб-сайте сценарий KeyTweak, с помощью которого можно одновременно изменить несколько ключевых кадров свойства. С помощью сценария KeyTweak можно вручную изменить несколько ключевых кадров, а сценарий сам изменит остальные ключевые кадры между ними соответствующим образом. Сценарий KeyTweak особенно полезен для ключевых кадров «Путь маски» в технологическом процессе ротоскопирования.

Рич Янг (Rich Young) предлагает несколько ресурсов для ротоскопирования на своем веб-сайте After Effects Portal.

Просмотр контуров масок и форм

  • Для просмотра путей маски для выделенных слоев на панели «Таймлайн» нажмите клавишу M.
  • Чтобы просмотреть выделенные маски или формы на панели «Таймлайн», нажмите SS (нажмите клавишу S дважды).
  • Для просмотра контуров масок и форм на панели «Композиция» нажмите кнопку «Переключить видимость контуров масок и форм» в нижней части панели «Композиция».
  • Для просмотра контуров масок на панели «Слой» выберите «Маски» из меню «Вид» на панели «Слой».
  • Чтобы скрыть контур маски при отображении других контуров, заблокируйте маску, нажав ее переключатель блокировки на панели «Таймлайн», а затем выберите «Слой» > «Маска» > «Скрыть заблокированные маски».
  • Чтобы отделить выделенные маски и скрыть остальные, выберите «Слой» > «Маска» > «Заблокировать остальные маски», а затем выберите «Слой» > «Маска» > «Скрыть заблокированные маски».

Выделение контуров форм, форм и групп форм

Слои-фигуры и их компоненты можно выбирать в любом из четырех уровней выделения, называемых режимами выделения.

Режим выделения слоя

Выбирается весь слой-фигура. Преобразования применяются к свойствам преобразования слоя в группе свойств «Преобразование», которая находится на том же уровне, что и группа свойств «Содержимое».

Режим выделения группы

Выбирается целая группа форм. Преобразования применяются к свойствам преобразования слоя в группе свойств «Преобразование», которая находится в группе слоя на панели «Таймлайн».

Режим свободного преобразования

Выбираются несколько вершин на одном или нескольких контурах Безье. Ограничительная рамка свободного преобразования отображается вокруг вершин на панели «Композиция». Работая с этой ограничительной рамкой, можно переместить несколько вершин с помощью одной операции преобразования. Преобразования применяются к вершинам, которые содержатся в свойстве «контур» на панели «Таймлайн».

Режим редактирования контура

Выбираются только вершины. В этом режиме можно выполнять операции редактирования контура, например, добавлять вершины к контуру или перемещать отдельные вершины.

Примечание.

Режим редактирования контура активен, когда активен инструмент «Перо». Чтобы оставаться в режиме редактирования контура, выберите инструмент «Перо»; при необходимости нажмите V или CTRL (Windows) или COMMAND (Mac OS), чтобы временно активировать инструмент выделения.

Режимы выделения для фигур на слоях-фигурах
Режимы выделения для фигур на слоях-фигурах

A. Выделение слоя B. Выделение группы C. Свободное преобразование D. Редактирование контура 

Дополнительные сведения о выделении масок см. в разделе Выделение масок, сегментов и вершин.

Примечание.

Чтобы выбрать все вершины контура, нажмите CTRL+A (Windows) или COMMAND+A (Mac OS), когда выбрана одна вершина контура. Нажмите еще раз, чтобы выделить все формы. Нажмите еще раз, чтобы выделить все слои.

Выделение слоя-фигуры

  • Щелкните имя слоя или панель продолжительности слоя на панели «Таймлайн».
  • Используя инструмент «Выделение», щелкните внутри границ слоя на панели «Композиция».
  • Чтобы отменить выделение всех фигур, но оставить выделенным слой-фигуру, щелкните внутри границ слоя, но за пределами всех контуров фигур.

Выбор группы форм в режиме группового выделения

  • Используя инструмент «Выделение», дважды щелкните элемент группы на панели «Композиция». С каждым двойным щелчком происходит переход на один уровень вниз в иерархии групп.
  • Для активации инструмента «Частичное выделение» удерживайте клавишу Ctrl (Windows) или Command (Mac OS), когда выбран инструмент «Выделение». Чтобы выделить группу формы, независимо от того, насколько глубоко форма находится в иерархии групп, щелкните эту форму на панели «Композиция» с помощью инструмента «Частичное выделение».
  • Чтобы выделить группу, содержащуюся внутри той же группы, что и группа, которая уже выбрана, щелкните требуемую группу.
  • Чтобы добавить группу к выделенной области, щелкните ее, удерживая нажатой клавишу SHIFT. Чтобы добавить в выделенную область более глубоко вложенные группы, можно одновременно использовать клавишу SHIFT и двойной щелчок мышью с инструментом «Частичное выделение».

Выделение контуров и вершин в режиме редактирования контуров

Примечание.

Чтобы задать размер дескрипторов направления кривой Безье и вершин для масок и форм, выберите «Правка» > «Установки» > «Общие» (Windows) или «After Effects» > «Установки» > «Общие» (Mac OS) и измените значение параметра «Размер точки контура».

  • Чтобы выбрать вершину, щелкните вершину с помощью инструмента «Выделение». Для добавления вершин к выделенной области, щелкните их, удерживая нажатой клавишу SHIFT.
  • Чтобы выбрать сегмент контура, щелкните сегмент с помощью инструмента «Выделение». Для добавления сегментов к выделенной области, щелкните их, удерживая нажатой клавишу SHIFT.
  • Чтобы выделить весь контур, щелкните сегмент или вершину с помощью инструмента «Выделение», удерживая нажатой клавишу ALT (Windows) или OPTION (Mac OS), или выберите любую часть контура и нажмите CTRL+A (Windows) или COMMAND+A (Mac OS).
  • Для выбора вершин с помощью перетаскивания, выделите контур или часть контура, чтобы войти в режим его редактирования, а затем перетащите их с помощью инструмента выделения прямоугольником , нарисовав прямоугольную область вокруг вершин, которые нужно выделить. Для добавления вершины в выделенной области при рисовании дополнительных прямоугольных областей выделения нажмите и удерживайте клавишу SHIFT.

Выделение всех точек на контуре и вход в режим свободного преобразования

  • Дважды щелкните сегмент контура в режиме редактирования контура или в режиме выделения группы для отдельной формы.
  • Выберите свойство «контур» на панели «Таймлайн» и нажмите CTRL+T (Windows) или COMMAND+T (Mac OS).

Выделение масок, сегментов и вершин

В отличие от слоев, маски могут иметь более одного уровня выделения. Маску можно выбрать как целый контур, что удобно, когда требуется переместить или изменить размеры маски. Однако если необходимо изменить контур маски, выберите одну или несколько точек на ней. Выбранные точки отображаются сплошными, а невыделенные точки — полыми.

Примечание.

Чтобы задать размер дескрипторов направления кривой Безье и вершин для масок и форм, выберите «Правка» > «Установки» > «Общие» (Windows) или «After Effects» > «Установки» > «Общие» (Mac OS) и измените значение параметра «Размер точки контура».

Выделение или отмена выбора масок на панели «Слой» или на панели «Композиция»

  • Чтобы выбрать вершину в маске, щелкните вершину с помощью инструмента «Выделение» . Для добавления вершин к выделенной области, щелкните их, удерживая нажатой клавишу SHIFT.
  • Чтобы выбрать сегмент маски, щелкните сегмент с помощью инструмента «Выделение». Для добавления сегментов к выделенной области, щелкните их, удерживая нажатой клавишу SHIFT.
  • Чтобы выделить всю маску, щелкните сегмент, вершину или дескриптор маски с помощью инструмента «Выделение», удерживая нажатой клавишу ALT (Windows) или OPTION (Mac OS), или выберите любую часть маски и щелкните «Правка» > «Выделить все», или нажмите CTRL+A (Windows) или COMMAND+A (Mac OS). Чтобы добавить маску к выделенной области, щелкните ее, удерживая нажатыми клавиши ALT+SHIFT (Windows) или OPTION+SHIFT (Mac OS).
  • Для выбора масок с помощью перетаскивания, выделите маску или часть маски, чтобы войти в режим ее редактирования, а затем перетащите их с помощью инструмента «Выделение», нарисовав прямоугольную область вокруг вершин и масок, которые нужно выделить. Для добавления масок или вершин в выделенной области при рисовании дополнительных прямоугольных областей выделения нажмите и удерживайте клавишу SHIFT.
  • Чтобы выбрать все маски на слое, выделите на слое одну маску и выберите «Правка» > «Выделить все» или нажмите CTRL+A (Windows) или COMMAND+A (Mac OS).
  • Для отмены выделения всех масок нажмите CTRL+SHIFT+A (Windows) или COMMAND+SHIFT+A (Mac OS).
  • Для выбора на слое смежной маски нажмите ALT+` (ударение) (Windows) или OPTION+` (ударение) (Mac OS), чтобы выделить следующую маску, или SHIFT+ALT+` (ударение) (Windows) или SHIFT+OPTION+` (ударение) (Mac OS), чтобы выделить предыдущую маску.
  • Для отмены выделения маски щелкните в любом месте за пределами маски.
  • Чтобы удалить из выделения вершину или сегмент, щелкните вершину или сегмент, удерживая нажатой клавишу SHIFT.

Примечание.

Для использования инструмента «Выделение», когда выбран инструмент «Перо», удерживайте нажатой клавишу CTRL (Windows) или COMMAND (Mac OS).

Выделение масок на панели «Таймлайн»

  1. Нажмите клавишу СТРЕЛКА ВПРАВО рядом с именем слоя, чтобы развернуть его.
  2. Нажмите клавишу СТРЕЛКА ВПРАВО рядом с заголовком «Маски», чтобы развернуть его и отобразить все маски слоя.
  3. Выполните любое из следующих действий.
    • Чтобы выбрать одну маску, щелкните ее имя.
    • Чтобы выделить несколько масок, расположенных рядом, щелкните имя первой и последней маски в диапазоне выделения, удерживая клавишу SHIFT.
    • Для выбора масок, расположенных в разных местах, щелкните имя всех масок, которые необходимо включить в выделение, удерживая клавишу CTRL (Windows) или COMMAND (Mac OS).

Примечание.

На панели «Таймлайн» можно выбирать только маски целиком. Чтобы выделить отдельные вершины маски, используйте панель «Композиция» или «Слой».

Блокировка или снятие блокировки маски

Блокировка маски делает невозможной ее выбор на панелях «Таймлайн», «Композиция» и «Слой» или ее размещение в качестве целевого объекта на панели «Слой». Используйте эту функцию во избежание нежелательных изменений маски.

  1. На панели «Таймлайн» разверните группу свойств «Маски».
  2. В столбце «Функции A/V» установите флажок под значком «Заблокировать» рядом с маской, которую необходимо заблокировать или разблокировать. Маска будет заблокирована и не может быть выбрана, когда функция блокировки включена (когда в окне появляется значок «Заблокировать»).

Примечание.

Чтобы одновременно разблокировать несколько масок, выделите один или несколько слоев и нажмите «Слой» > «Маска» > «Разблокировать все маски».

Примечание.

Чтобы отделить выделенные маски и скрыть остальные, выберите «Слой» > «Маска» > «Заблокировать остальные маски», а затем выберите «Слой» > «Маска» > «Скрыть заблокированные маски».

Перемещение вершин в режиме свободного преобразования

контур маски или формы целиком (или выделенные вершины в одном или нескольких контурах) можно масштабировать и поворачивать с помощью команды «Точки свободного трансформирования». При использовании этой команды выбранные вершины окружает ограничительная рамка свободного преобразования, а в центре ограничительной рамки появляется опорная точка, которая обозначает опорную точку для текущего преобразования. Масштабировать и поворачивать выбранные вершины можно путем перетаскивания ограничительной рамки или ее дескрипторов. Также можно изменять исходную точку, вокруг которой вершины поворачиваются или масштабируются, путем перемещения опорной точки ограничительной рамки. Дескрипторы ограничительной рамки свободного преобразования и опорная точка существуют независимо от дескрипторов и опорной точки слоя.

Примечание.

Когда нужно анимировать поворот с помощью команды «Точки свободного трансформирования», вершины маски интерполируются в прямую линию от одного ключевого кадра к другому. По этой причине результаты могут отличаться от ожидаемых.

  1. Отобразите слой, содержащий контуры, которые необходимо преобразовать, на панели «Композиция» или на панели «Слой».
  2. С помощью инструмента «Выделение» выполните одно из следующих действий.
    • Чтобы преобразовать любое количество вершин, выберите вершины, которые необходимо преобразовать, и нажмите «Слой» > «контур масок и форм» > «Точки свободного трансформирования».
    • Чтобы преобразовать весь контур маски или формы, выберите его на панели «Таймлайн» и нажмите «Слой» > «Контур масок и форм» > «Точки свободного трансформирования».
  3. Чтобы переместить опорную точку ограничительной рамки, наведите инструмент «Выделение» на опорную точку ограничительной рамки , пока значок инструмента «Выделение» не изменится на значок перемещения опорной точки . Перетащите, чтобы переместить опорную точку.
  4. Выполните одно из следующих действий.
    • Чтобы переместить контур или выбранные вершины, расположите курсор внутри ограничительной рамки и перетащите.
    • Для масштабирования контура или выбранных вершин поместите курсор на ограничительную рамку и, когда курсор изменится на прямую, двухстороннюю стрелку , перетаскиванием определите новый размер. Чтобы ограничить масштабирование, при перетаскивании удерживайте нажатой клавишу SHIFT. Чтобы ограничить масштабирование вокруг опорной точки ограничительной рамки, при перетаскивании удерживайте нажатой клавишу CTRL (Windows) или COMMAND (Mac OS).
    • Чтобы повернуть контур или выбранные вершины, поместите указатель за пределы ограничительной рамки свободного преобразования и, когда указатель примет вид изогнутой двухсторонней стрелки , выполните поворот посредством перетаскивания.
  5. Чтобы выйти из режима свободного преобразования, нажмите ESC, ВВОД (Windows) или RETURN (Mac OS).

Преобразование контура между кривой Безье и RotoBezier, нарисованными вручную

Любой выполненный вручную контур формы или маски по кривой Безье можно преобразовать в контур по кривой RotoBezier. Если выполненный вручную контур Безье имеет дескрипторы направления, которые были перемещены, это преобразование изменит форму пути, поскольку After Effects автоматически вычисляет кривизну сегментов RotoBezier.

Преобразование контура RotoBezier в контур Безье, нарисованный вручную, не изменяет форму пути.

  1. Выберите маску на панели «Слой», «Композиция» или «Таймлайн» или выберите контур формы на панели «Композиция» или «Таймлайн».
  2. Выберите «Слой» > «Путь маски и формы» > «RotoBezier».

Изменение пути маски или формы, созданного на основе кривой Безье

Путь маски Безье можно изменить с помощью инструментов «Выделение» и «Перо» на панели «Слой» или «Композиция». Контур формы Безье можно изменить с помощью инструментов «Выделение» и «Перо» на панели «Слой» или «Композиция».

Инструменты пера — «Добавление вершины», «Удаление вершины» и «Преобразование вершины» — сгруппированы с инструментом «Перо» на панели «Инструменты». Чтобы отобразить эти инструменты на панели «Инструменты», нажмите и удерживайте инструмент «Перо» на панели «Инструменты».

Примечание.

В большинстве случаев соответствующий инструмент пера становится активным, когда указатель инструмента «Перо» помещается в соответствующем контексте. Например, инструмент «Удаление вершины» становится активным, если указатель инструмента «Перо» помещается над существующей вершиной, а инструмент «Добавление вершины» становится активным, если указатель инструмента «Перо» помещается над сегментом контура. Для ручной активации и переключения между этими инструментами нажмите G.

При изменении контура убедитесь, что выполняется щелчок существующих вершин или сегментов; иное может привести к созданию нового контура.

Перемещение, добавление или удаление вершины

  1. Выполните одно из следующих действий.
    • Чтобы переместить вершину, щелкните вершину с помощью инструмента «Выделение» .

    Примечание.

    Чтобы временно переключиться с инструмента «Перо» на инструмент «Выделение», нажмите V или CTRL (Windows) или COMMAND (Mac OS).

    • Чтобы добавить вершину к маске, нажмите сегмент между двумя существующими вершинами с помощью инструмента «Добавление вершины» .
    • Чтобы удалить вершину из маски, нажмите вершину с помощью инструмента «Удаление вершины» .

Коррекция сегмента контура

  1. Выполните одно из следующих действий с помощью инструмента «Выделение».
    • Перетащите вершину.
    • Перетащите дескрипторы направления смежной гладкой вершины.
    • Перетащите изогнутый сегмент.

    Примечание.

    Перетаскивание изогнутого сегмента на маску RotoBezier также перемещает вершины.

Переключение вершины между точкой сглаживания и угловой точкой

  1. Щелкните вершину с помощью инструмента «Преобразование вершины» .

    Примечание.

    Для активации инструмента «Преобразование вершины», когда выбран инструмент «Перо», удерживайте нажатой клавишу ALT (Windows) или OPTION (Mac OS).

Коррекция напряжения маски RotoBezier

  1. При необходимости одновременной коррекции напряжения нескольких вершин выберите их.
  2. Перетащите вершину с помощью инструмента «Преобразование вершины» .

    Примечание.

    Для активации инструмента «Преобразование вершины», когда выбран инструмент «Перо», удерживайте нажатой клавишу ALT (Windows) или OPTION (Mac OS).

    При перетаскивании вершины маски RotoBezier появляется указатель коррекции напряжения .

    Щелчок вместо перетаскивания задает вершину в качестве угловой точки (100-процентное напряжение); повторный щелчок устанавливает вершину как точку сглаживания (33-процентное напряжение). Перетаскивание вверх или вправо снижает напряжение выделенной области, увеличивая кривизну смежных сегментов контура, перетаскивание вниз или влево увеличивает напряжение выделенной области, уменьшая кривизну смежных сегментов контура.

    Примечание.

    Во время коррекции напряжения посмотреть значение напряжения вершины можно на панели «Информация».

Числовое изменение пути маски

  1. Выделите маску.
  2. На панели «Таймлайн» разверните свойства «Маска».
  3. Нажмите подчеркнутое слово рядом со свойством «Путь маски» и укажите изменения в диалоговом окне формы маски.

Определение первой вершины для контура Безье

Чтобы анимировать контур, After Effects обозначает самую верхнюю вершину на исходном ключевом кадре как первую вершину и нумерует каждую последующую вершину в порядке возрастания от первой вершины. Затем After Effects присваивает те же номера соответствующим вершинам на всех последующих ключевых кадрах. After Effects интерполирует движение каждой вершины от исходного положения в одном ключевом кадре к позиции соответственно пронумерованной вершины на следующем ключевом кадре. В любой момент процесса анимации можно назначить первой вершиной другую вершину; это приведет к тому, что After Effects перенумерует вершины контура. Следствием перенумерации вершин станет изменение анимации контура, поскольку после этого After Effects будет сопоставлять новые номера вершин с соответствующими старыми номерами вершины, по-прежнему сохраненными в последующих ключевых кадрах.

При копировании замкнутого контура в путь движения вершина, обозначенная в качестве первой вершины замкнутого контура, используется как начало пути движения. Все пути движения являются открытыми контурами.

Некоторые операции с контурами форм, например «Обрезать контуры», также используют первую вершину в качестве исходной для определения изменений контура.

Примечание.

По умолчанию при добавлении вершины к контуру новая вершина отображается на контуре через всю длительность контура, но изменяет контур только в момент времени ее добавления. При удалении вершины из контура в определенной точке времени вершина удаляется из контура по всей длительности контура. Чтобы запретить After Effects добавление и удаление вершины на протяжении всей длительности контура, выберите «Правка» > «Установки» > «Общие» (Windows) или «After Effects» > «Установки» > «Общие» (Mac OS) и снимите флажок с параметра «Сохранить номер постоянной вершины при редактировании масок».

Примечание. В After Effects CS6 и более поздних версиях функция «Сохранить число постоянных вершин при редактировании масок» была переименована в «Сохранить число постоянных вершин и растушевок при редактировании масок».

  1. Создайте анимированный контур.
  2. На панели «Таймлайн» переместите индикатор текущего времени в точку, где необходимо установить новую первую вершину.
  3. Выберите вершину для обозначения в качестве первой.
  4. Выберите «Слой» > «Контур масок и форм» > «Задать первую вершину».

    Примечание.

    Вершина, обозначенная в качестве первой, выглядит немного больше других вершин на панели «Композиция».

Анимация пути маски с помощью функции «Интеллектуальная интерполяция маски»

Интеллектуальная интерполяция маски предлагает широкие возможности управления для процесса создания ключевых кадров пути маски и плавной, реалистичной анимации. После выбора для интерполяции ключевого кадра пути маски функция «Интеллектуальная интерполяция маски» создает промежуточные ключевые кадры на основе заданных вами параметров. На панели «Информация» отображается ход выполнения интерполяции и количество созданных ключевых кадров.

  1. Выберите «Окно» > «Интерполяция маски».
  2. Выберите по крайней мере два смежных ключевых кадра пути маски.
  3. Задайте параметры на панели интерполяции маски, а затем нажмите кнопку «Применить».

    Примечание.

    Чтобы прервать процесс интерполяции, нажмите ESC. На панели «Информация» отобразится сообщение о прерывании процесса и о количестве созданных ключевых кадров.

    Частота ключевых кадров

    Определяет количество ключевых кадров, которые функция «Интеллектуальная интерполяция маски» создает между выбранными ключевыми кадрами в секунду. Например, значение 10 создает новый ключевой кадр через каждую десятую долю секунды. Выберите вариант «Автоматически», чтобы задать частоту ключевых кадров равной частоте кадров композиции, которая отображается в скобках. Для более плавной анимации создайте большее количество ключевых кадров; для уменьшения времени рендеринга — меньшее количество ключевых кадров.

    Примечание.

    Независимо от выбранной частоты ключевых кадров функция «Интеллектуальная интерполяция маски» всегда добавляет ключевые кадры в кадр, следующий непосредственно за первым ключевым кадром пути маски, и в кадр, расположенный непосредственно перед вторым ключевым кадром пути маски. Например, при интерполяции с частотой кадров 10 ключевых кадров в секунду между ключевыми кадрами с позициями 0 секунд и 1 секунда в композиции с частотой ключевых кадров 30 кадр/с, ключевые кадры пути маски добавляются в кадры 1, 3, 6, 9, 12, 15, 18, 21, 24, 27 и 29.

    Поля ключевого кадра

    Увеличивает частоту ключевых кадров вдвое. Если этот параметр выбран, а частота ключевых кадров имеет значение частоты кадров композиции, ключевой кадр добавляется в каждое поле видео. Выберите этот параметр для анимированного маскирования видео с чересстрочной разверткой. Если этот параметр не выбран, то возможно смещение маски с объекта, который вы пытаетесь исключить. Дополнительные сведения о полях в видео с чересстрочной разверткой см. в разделе Видео с чересстрочной разверткой и разделение полей.

    Использовать пути линейных вершин

    Указывает, что вершины в первом ключевом кадре перемещаются к соответствующим им вершинам во втором ключевом кадре по прямому пути. Не выбирайте этот параметр, если некоторые вершины требуется интерполировать по изогнутым контурам; например, когда необходимая интерполяция включает вращающие части. Если этот параметр не выбран, то функция «Интеллектуальная интерполяция маски» создает для маски естественный контур.

    Сопротивление при изгибании

    Определяет, насколько интерполированный контур маски чувствителен к изгибанию вместо растяжения. Значение 0 указывает, что в процессе анимации пути маски он изгибается больше, чем растягивается; значение 100 указывает, что контур маски больше растягивается, чем изгибается.

    Качество

    Определяет, насколько точно функция «Интеллектуальная интерполяция маски» сопоставляет вершины одного ключевого кадра вершинам другого. Значение 0 указывает, что определенная вершина в первом ключевом кадре соответствует только вершине с таким же порядковым номером во втором ключевом кадре. Например, десятая вершина в первом ключевом кадре должна соответствовать десятой вершине во втором ключевом кадре. Значение 100 означает, что какая-либо вершина в первом ключевом кадре потенциально может соответствовать любой вершине во втором ключевом кадре. Более высокие значения обычно приводят к лучшей интерполяции; однако чем выше значение, тем больше времени занимает обработка.

    Добавить вершины пути маски

    Указывает, что функция «Интеллектуальная интерполяция маски» добавляет вершины для улучшения качества интерполяции. Как правило, «Интеллектуальная интерполяция маски» работает лучше всего, если контуры маски имеют большое количество вершин. Кроме того, вершина на первом контуре маски не может соответствовать середине кривой или прямолинейному сегменту на втором контуре маски, поэтому для получения необходимого результата перед сопоставлением иногда необходимо добавить вершины. «Интеллектуальная интерполяция маски» не изменяет исходные ключевые кадры. Дополнительные вершины имеют только новые ключевые кадры пути маски, вычисленные функцией «Интеллектуальная интерполяция маски».

    Установленное значение определяет, насколько точно подразделены входящие контуры маски. Параметр «Пикселы между вершинами» указывает расстояние в пикселах между двумя вершинами на контуре маски, который после подразделения имеет больший периметр. Параметр «Общее число вершин» определяет количество вершин на интерполированных контурах маски. Параметр «Процент макета» указывает, что вершина добавляется в точки указанного процента от длины пути маски. Например, значение 5 означает, что вершина добавляется для каждого последующего сегмента контура, размер которого представляет собой 5 % полного периметра. Для использования только вершин, которые находятся на контуре первого кадра, не выбирайте этот параметр.

    Примечание.

    Функция «Интеллектуальная интерполяция маски» может добавлять вершины на позиции существующих вершин, даже если параметр «Добавить вершины пути маски» не установлен. Если две вершины на одном контуре маски соответствуют одной вершине на другом контуре, эта одна вершина будет продублирована в том же самом месте для того, чтобы сегмент между двумя вершинами уменьшился в соответствии с этим местоположением.

    Метод поиска соответствий

    Определяет алгоритм, который функция «Интеллектуальная интерполяция маски» использует для сопоставления вершин на одном контуре маски и вершин на другом контуре маски. Метод «Авто» применяет алгоритм поиска соответствий для кривых, если любой из двух выбранных ключевых кадров имеет изогнутый сегмент; в ином случае он применяет алгоритм «Ломаная линия». Метод «Кривая» применяет алгоритм для путей маски, которые имеют изогнутые сегменты. Метод «Ломаная линия» применяет алгоритм для путей маски, которые имеют только прямые сегменты.

    Примечание.

    Ключевые кадры пути маски, добавленные функцией «Интеллектуальная интерполяция маски», являются ломаными линиями, если выбран метод «Ломаная линия», независимо от того, содержат ли входящие контуры маски изогнутые сегменты.

    Использовать соответствия вершин 1:1

    Указывает, что функция «Интеллектуальная интерполяция маски» создает на одном контуре маски вершину, которая соответствует вершине с таким же порядковым номером на другом контуре маски. По отношению к каждому входящему пути маски функция «Интеллектуальная интерполяция маски» сопоставляет первые вершины, вторые вершины, третьи вершины и т.д. Если два контура имеют неравное количество вершин, это действие может привести к нежелательным результатам.

    Первое совпадение по вершинам

    Указывает, что функция «Интеллектуальная интерполяция маски» сопоставляет первые вершины в двух ключевых кадрах пути маски. Если параметр не выбран, функция «Интеллектуальная интерполяция маски» выполняет поиск лучшего соответствия для первых вершин между двумя входящими контурами маски.

    Примечание.

    Чтобы получить хорошие результаты, убедитесь, что первые вершины входящих путей маски совпадают, а затем выберите параметр «Первое совпадение по вершинам».

Перемещение маски или панорамирование слоя под маской

Область, которая видима через маску, можно настроить перемещением маски на панели «Слой» или на панели «Композиция» или панорамированием (перемещением) слоя под маской на панели «Композиция». При перемещении маски значения положения маскируемого слоя остаются постоянными, а маска перемещается по отношению к другим объектам на панели «Композиция».

При использовании инструмента «Панорамирование назад» («Опорная точка») для панорамирования слоя под маской положение маски остается неизменным на панели «Композиция», но изменяется на панели «Слой». Значения положения маскируемого слоя изменяются по отношению к композиции. По мере панорамирования за края кадра слоя значения пути маски на слое также изменяются. Использование инструмента «Панорамирование назад» («Опорная точка») уменьшает количество шагов; если инструмент не используется, необходимо изменять свойства «Положение» и «Путь маски» для слоя с маской вручную. Слой можно анимировать панорамированием под другим слоем, задав ключевые кадры для свойств «Положение» и «Путь маски» маскируемого слоя.

Перемещение маски или панорамирование слоя под маской
При использовании инструмента «Панорамирование назад» («Опорная точка») на панели «Композиция» After Effects автоматически выполняет две коррекции. На панели «Слой» маска перемещается относительно слоя (сверху), а на панели «Композиция» слой перемещается по отношению к композиции (снизу).

Перемещение маски

  1. Выделите маски, которые нужно переместить.
  2. На панели «Композиция» перетащите маски в новое место. Чтобы ограничить движение масок по горизонтали или вертикали, при перетаскивании удерживайте клавишу SHIFT.

Панорамирование слоя под его маской

  1. Выберите инструмент «Панорамирование назад» («Опорная точка») на панели «Инструменты».

  2. Щелкните внутри области маски на панели «Композиция» и перетащите слой на новое место.

Отслеживание лица и маски

Можно использовать средство отслеживания масок, чтобы преобразовать маску в соответствии с траекторией перемещения одного объекта (или нескольких объектов) в фильме. Дополнительные сведения см. в разделе Отслеживание маски.

Средство отслеживания маски также можно использовать для точного определения и отслеживания лиц людей. Дополнительные сведения см. в разделе Отслеживание лиц.

Доступ к точкам контуров масок, фигур Безье и штрихов кисти с помощью выражений

Выражения можно использовать для считывания и записи координат x и y точек контуров (или вершин) следующих объектов:

  • слои-маски;
  • фигуры Безье;
  • штрихи кисти на панели «Рисование» и эффекты «Кисть для ротоскопии» и «Уточнить края».

Данные методы выражений подобны методу доступа к вершинам контура с помощью сценариев. Для ознакомления, данный метод выражений называется points(), а не vertices().

Методы выражений доступа

Далее описывается порядок доступа к таким методам выражений.

  1. Чтобы создать слой со сплошной заливкой, выберите Слой > Сплошной.

  2. Создав сплошную заливки, создайте маску. Щелкните инструмент фигуры, например многоугольник, и создайте маску над сплошным слоем.

  3. На панели Таймлайн откройте окно свойств маски и, удерживая нажатой клавишу Alt, нажмите Контур маски.

  4. Отображается поле выражения. На панели Таймлайн откройте меню Язык выражений и выберите Свойства контура.

    Меню языка выражения
    Меню языка выражения
  5. Выберите метод выражения в списке методов выражения для точек контура.

    Дополнительные сведения о методах выражений см. в разделе Доступ выражений к точкам контуров фигур, масок и штрихов кисти (справочник по выражениям).

Ниже перечислены примеры методов выражений для контурных объектов.

  • Контуры маски слоя: layer("Темно-серая заливка 1").mask("Маска 1").path or .maskPath
  • Контуры фигур Безье: layer("Слой-фигура 1").content("Фигура 1").content("Контур 1").path
  • Контуры штрихов для эффекта «Рисование»: layer("Темно-серая заливка 1").effect("Рисование").stroke ("Кисть 1").path
  • Контуры штрихов для эффектов «Кисть для ротоскопии» и «Уточнить края»: layer("Темно-серая заливка 1").effect("Кисть для ротоскопии и Уточнить края").stroke("Передний план 1").path

Советы по работе с данными методами выражений

  • Для координат вершин значения точек и касательных возвращаются как массив массивов пар чисел [x, y]. Значения координат округляются до четырех знаков после запятой.
  • Массивы точек и касательных начинаются с первой вершины на контуре. Первую вершину контуров масок и фигур Безье слоя можно изменить с помощью команды Слой > Контур масок и форм > Задать первую вершину.
  • Координаты точек контура маски слоя указываются относительно начала координат слоя в левом верхнем углу.
  • Координаты точек контура фигур Безье задаются относительно опорной точки группы фигур контура (например, «Преобразование: Фигура 1 > Опорная точка»).
  • Координаты точек контура штрихов кистью задаются относительно начала штриха. Координаты первой точки: [0,0].
  • Метод toComp() или другие методы преобразования пространства слоя могут быть полезны для преобразования координат различных слоев в общее пространство или просто для возврата значений координат относительно пространства композиции.
  • Поскольку контуры фигур Безье задаются относительно опорной точки своей локальной группы фигур, а не слоя, их значения могут быть смещенными по сравнению с ожидаемым результатом. Чтобы избежать этого, присвойте нулевое значение всем свойствам преобразования в группе фигур. Следует помнить, что преобразование параметрической фигуру в фигуры Безье может влиять на положение группы фигур.
  • Методу createPath() можно передавать методы points, tangents и isClosed для того же контура или других контуров. Эти методы можно передавать неизмененными, чтобы создать дубликат контура или преобразовать значения точек и касательных, прежде чем передать их для изменения или анимации контура.

Панель «Создать пустые значения на основе контуров»

Создать пустые значения на основе контуров scriptUI, панель, с помощью которой можно легко создавать анимации, управляемые выражениями, при этом писать выражения вручную не требуется. Можно напрямую связывать разные контуры с фигурами, фигуры со сплошными заливками и т. д. Панель Создать пустые значения на основе контуров использует доступ к точкам контуров на основе выражений для автоматической привязкипустых значений, чтобы вам не нужно было писать выражение самостоятельно.

Панель создает пустые значения для каждой точки контура маски или контура фигуры Безье. Для различных вариантов создания пустых значений используются следующие кнопки на панели:

  • Точки следуют за пустыми значениями: эта кнопка создает пустые значения, которые управляют положением точек контура. Точки контура связываются с пустыми значениями, что позволяет анимировать пустые значения, чтобы приводить в движение точки контура.
  • Пустые значения следуют за точками: эта кнопка создает пустые значения, которые управляются положением точек контура. Пустые значения связываются с точками контура, и можно анимировать точки контура для перемещения пустых значений.
  • Трассировка контура: эта кнопка создает одно пустое значение, которое следует за контуром. Положение пустого значения связывается с координатами контура. Поворот пустого значения автоматически ориентируется по контуру. Кнопка «Трассировка контура» управляет перемещением пустого значения по контуру, а также определяет, образует ли контур петлю. По умолчанию для ключевых кадров задано следование по контуру с интервалом в 1 секунду, апетлявключена.

Работа с панелью

  1. Чтобы открыть панель, выберите пункт меню Окна > Создать пустые значения на основе контуров.jsx.

  2. Чтобы добавить маску фигуры, выберите Слой > Создать > Слой-фигура. Добавьте маску фигуры на слой.

    Примечание.

    Панель работает с фигурами Безье, поэтому все параметрические фигуры, такие как прямоугольник, эллипс и звезда, необходимо преобразовать в фигуры Безье. Чтобы преобразовать параметрическую фигуру в фигуру Безье, откройте слой-фигуру, щелкните правой кнопкой мышиконтур фигуры,например Прямоугольник 1, и выберите Преобразовать в контур Безье.

    Повторите шаг 2, чтобы добавить другие фигуры.

  3. У каждой фигуры и маски Безье есть контур. На панели «Таймлайн» разверните слои, чтобы просмотреть контуры. Если требуется, чтобы пустые значения следовали за точками контура, выберите контур на панели «Таймлайн» и нажмите кнопку Пустые значения следуют за точками на панели Создать пустые значения на основе контуров.

    Сценарий создает пустое значение для каждой точки на контуре. Можно удалить любые ненужные вам пустые значения.

    Примечание.

    При преобразовании параметрической фигуры в фигуру Безье After Effects корректирует свойство «Положение» фигуры. Это приводит к смещению при вычислении положений пустых значений. Чтобы избежать этой проблемы, перед созданием пустых значений задайте свойству «Преобразование» фигуры, например свойству «Преобразование: эллипс 1», значение 0.

  4. Если необходимо, чтобы точки контура следовали за пустыми значениями, выберите контур на панели «Таймлайн». Затем нажмите кнопку Точки следуют за пустыми значениями на панели Создать пустые значения на основе контуров.

  5. После создания пустых значений для всех точек контура их можно будет присоединитьдругк другу для создания анимации. У пустых значений, созданных с помощью кнопок Точки следуют за пустыми значениями и Пустые значения следуют за точками, разные цвета. Чтобы присоединить пустые значения, выберите одно пустое значение и удерживайте клавишу Shift при выборе родительского слоя с помощью инструмента «Лассо», чтобы координаты пустого значения перешли на родительский слой.

    После присоединения всех пустых значений запустите анимацию и посмотрите, как она работает.

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет