Руководство пользователя Отмена

Выделение и упорядочивание слоев

  1. Руководство пользователя After Effects
  2. Выпуски бета-версии
    1. Обзор программы бета-тестирования
    2. Домашняя страница бета-версии After Effects
    3. Функции бета-версии
      1. Панель «Свойства» (Бета-версия)
  3. Начало работы
    1. Начало работы с After Effects
    2. Новые возможности After Effects 
    3. Сведения о выпуске | After Effects
    4. Системные требования для After Effects
    5. Сочетания клавиш в After Effects
    6. Поддерживаемые форматы файлов | After Effects
    7. Рекомендации по аппаратному обеспечению
    8. After Effects для компьютеров с процессорами Apple
    9. Планирование и настройка
    10. Настройка и установка
  4. Рабочие среды
    1. Общие элементы пользовательского интерфейса
    2. Знакомство с интерфейсом After Effects
    3. Рабочие процессы
    4. Рабочие среды, панели управления, программы просмотра
  5. Проекты и композиции
    1. Проекты
    2. Основы создания композиции
    3. Предварительная композиция, вложение и предварительный рендеринг
    4. Просмотр подробных сведений о производительности с помощью инструмента «Профайлер композиций»
    5. Модуль рендеринга композиций CINEMA 4D
  6. Импорт видеоряда
    1. Подготовка и импорт неподвижных изображений
    2. Импорт из After Effects и Adobe Premiere Pro
    3. Импорт и интерпретация видео и аудио
    4. Подготовка и импорт файлов 3D-изображений
    5. Импорт и интерпретация элементов видеоряда
    6. Работа с элементами видеоряда
    7. Определение точек редактирования с помощью функции «Определение изменения сцен»
    8. Метаданные XMP
  7. Текст и графические элементы
    1. Текст
      1. Форматирование символов и панель символов
      2. Эффекты текста
      3. Создание и редактирование текстовых слоев
      4. Форматирование абзацев и панель «Абзац»
      5. Экструзия слоев текста и слоев-фигур
      6. Анимация текста
      7. Примеры и ресурсы для текстовой анимации
      8. Шаблоны динамического текста
    2. Анимационный дизайн
      1. Работа с шаблонами анимационного дизайна в After Effects
      2. Использование выражений для создания раскрывающихся списков в шаблонах анимационного дизайна
      3. Работа с основными свойствами для создания шаблонов анимационного дизайна
      4. Замена изображений и видео в шаблонах анимационного дизайна и основных свойствах
  8. Рисование, заливка цветом и контуры
    1. Обзор слоев-фигур, контуров и векторных изображений
    2. Инструменты рисования: «Кисть», «Штамп» и «Ластик»
    3. Как изменить обводку фигуры
    4. Атрибуты фигур, операции заливки цветом и операции с контурами для слоев-фигур
    5. Использование эффекта фигуры «Cмещение контура» для изменения фигур
    6. Создание фигур
    7. Создание масок
    8. Удаление объектов из видеоматериалов с помощью панели «Заливка с учетом содержимого»
    9. Инструменты «Кисть для ротоскопии» и «Уточнить подложку»
  9. Слои, маркеры и камера
    1. Выделение и упорядочивание слоев
    2. Режимы наложения и стили слоев
    3. 3D-слои
    4. Свойства слоя
    5. Создание слоев
    6. Управление слоями
    7. Маркеры слоя и маркеры композиции
    8. Камеры, освещение и точки обзора
  10. Анимация, ключевые кадры, отслеживание движения и прозрачное наложение
    1. Анимация
      1. Основы анимации
      2. Анимация с помощью инструментов «Марионетка»
      3. Управление и анимация контуров фигур и масок
      4. Анимация фигур Sketch и Capture с помощью After Effects
      5. Инструменты анимации
      6. Работа с анимацией на основе данных
    2. Ключевой кадр
      1. Интерполяция ключевого кадра
      2. Установка, выбор и удаление ключевых кадров
      3. Редактирование, перемещение и копирование ключевых кадров
    3. Отслеживание движения
      1. Отслеживание и стабилизация движения
      2. Отслеживание лиц
      3. Отслеживание маски
      4. Ссылка на маску
      5. Скорость
      6. Растягивание по времени и перераспределение времени
      7. Тайм-код и единицы отображения времени
    4. Прозрачное наложение
      1. Прозрачное наложение
      2. Эффекты прозрачного наложения
  11. Прозрачность и композиция
    1. Обзор композиции и прозрачности и соответствующие ресурсы
    2. Альфа-каналы, маски и подложки
  12. Корректирование цвета
    1. Основы работы с цветом
    2. Использование расширения Adobe Color Themes
    3. Управление цветом
    4. Эффекты цветокоррекции
  13. Эффекты и стили анимации
    1. Обзор эффектов и стилей анимации
    2. Список эффектов
    3. Эффекты имитации
    4. Эффекты стилизации
    5. Аудиоэффекты
    6. Эффекты искажения
    7. Эффекты перспективы
    8. Эффекты канала
    9. Эффекты создания
    10. Эффекты перехода
    11. Эффект «Устранение эффекта плавающего затвора»
    12. Эффекты «Размытие» и «Резкость»
    13. Эффекты 3D-канала
    14. Программные эффекты
    15. Эффекты подложки
    16. Эффекты «Шум» и «Зернистость»
    17. Эффект «Увеличение с сохранением уровня детализации»
    18. Устаревшие эффекты
  14. Выражения и автоматизация
    1. Выражение
      1. Основы работы с выражениями
      2. Понимание языка выражений
      3. Использование элементов управления выражениями
      4. Различия в синтаксисе между движками выражений JavaScript и Legacy ExtendScript
      5. Управление выражениями
      6. Ошибки выражения
      7. Использование редактора выражений
      8. Использование выражений для изменения свойств текста и доступа к ним
      9. Справочник языка выражений
      10. Примеры выражений
    2. Автоматизация
      1. Автоматизация
      2. Сценарии
  15. Видео с погружением, VR и 3D
    1. Создание сред VR в After Effects
    2. Применение видеоэффектов с эффектом погружения
    3. Инструменты составления композиций для видеоизображений VR/360
    4. Отслеживание движений камеры в трехмерном пространстве
    5. Пространство для работы с трехмерными объектами
    6. Инструменты 3D-преобразования
    7. Дополнительные возможности 3D-анимации
    8. Предварительный просмотр изменений в 3D-дизайнах в режиме реального времени с помощью модуля режима реального времени
    9. Добавление гибкого дизайна в графику 
  16. Виды и предварительный просмотр
    1. Предпросмотр
    2. Предпросмотр видео с помощью Mercury Transmit
    3. Изменение и использование представлений
  17. Рендеринг и экспорт
    1. Основы рендеринга и экспорта
    2. Экспорт проекта After Effects как проекта Adobe Premiere Pro
    3. Преобразование фильмов
    4. Многокадровый рендеринг
    5. Автоматический рендеринг и рендеринг по сети
    6. Рендеринг и экспорт неподвижных изображений и наборов неподвижных изображений
    7. Использование кодека GoPro CineForm в After Effects
  18. Работа с другими приложениями
    1. Dynamic Link и After Effects
    2. Работа с After Effects и другими приложениями
    3. Синхронизация настроек в After Effects
    4. Библиотеки Creative Cloud Libraries в After Effects
    5. Подключаемые модули
    6. CINEMA 4D и Cineware
  19. Совместная работа: Frame.io и Team Projects
    1. Совместная работа в Premiere Pro и After Effects
    2. Frame.io
      1. Установка и активация Frame.io
      2. Использование Frame.io с Premiere Pro и After Effects
      3. Часто задаваемые вопросы
    3. Team Projects
      1. Начало работы с Team Projects
      2. Создание Team Project
      3. Совместная работа с помощью Team Projects
  20. Память, хранилище, производительность
    1. Память и хранилище
    2. Повышение производительности
    3. Установки
    4. Требования к графическому процессору и драйверу графического процессора для After Effects

Выделение слоев

Выделенные слои, которые также имеют выделенные свойства, отображаются с частичной подсветкой на панели «Таймлайн». Выделенный слой, который не имеет выделенных свойств, отображается со сплошной подсветкой.

Выделен верхний слой, но не выделены свойства; выделен нижний слой с выбранными свойствами
Выделен верхний слой, но не выделены свойства; выделен нижний слой с выбранными свойствами.

Примечание.

Для прокрутки самого верхнего выделенного слоя к верхней части панели «Временная шкала», нажмите «X».

  • Для выделения слоя щелкните слой на панели «Композиция», щелкните его имя или полосу продолжительности на панели «Временная шкала» или щелкните его имя на панели «Графическое представление».
  • Для выделения слоя, который скрыт на панели «Композиция», щелкните правой кнопкой мыши (Windows) или щелкните, удерживая нажатой клавишу CONTROL (Mac OS), слой на панели «Композиция» и выберите «Выделить» > [имя слоя].
  • Для выделения слоя, открытого на собственной панели «Слой», выберите имя слоя из меню «Окно» или меню «Средство просмотра» на панели «Слой».
  • Для выделения слоя по номеру его позиции, введите номер слоя на цифровой клавиатуре. Если номер слоя содержит более одной цифры, вводите цифры быстро, чтобы After Effects определил их как один номер.
  • Для выделения следующего слоя в порядке расположения нажмите CTRL+СТРЕЛКА ВНИЗ (Windows) или COMMAND+СТРЕЛКА ВНИЗ (Mac OS). Для выделения предыдущего слоя нажмите клавиши CTRL+СТРЕЛКА ВВЕРХ (Windows) или COMMAND+СТРЕЛКА ВВЕРХ (Mac OS).
  • Для расширения выделенной области до следующего слоя в порядке расположения нажмите CTRL+SHIFT+СТРЕЛКА ВНИЗ (Windows) или COMMAND+SHIFT+СТРЕЛКА ВНИЗ (Mac OS). Для расширения выделенной области до предыдущего слоя в порядке расположения нажмите CTRL+SHIFT+СТРЕЛКА ВВЕРХ (Windows) или COMMAND+SHIFT+СТРЕЛКА ВВЕРХ (Mac OS).
  • Для выделения всех слоев выберите «Правка» > «Выделить все», когда панель «Временная шкала» или панель «Композиция» активна. Для отмены выделения всех слоев выберите «Правка» > «Снять выделение со всех». Если переключатель «Скрыть слои, для которых выключена видимость» включен, использование команды «Выделить все» при активной панели «Временная шкала» не выделит слои, для которых выключена видимость. (См. раздел Включение и выключение видимости слоев на панели «Временная шкала».)
  • Чтобы снять выделение с выделенных в данный момент слоев и выбрать все остальные слои (должен быть хотя бы один выделенный слой), выберите «Обратить выделение» в контекстном меню на панели «Композиция» или «Временная шкала».
  • Для выделения всех слоев, использующих одинаковую цветную метку, нажмите «Цветная метка» на панели «Временная шкала», а затем нажмите «Выбрать группу меток» или выберите слой с этой цветной меткой и нажмите «Правка» > «Метка» > «Выбрать группу меток».
  • Для выделения всех дочерних слоев родительского слоя выберите родительский слой и нажмите «Выбрать дочерние элементы» из контекстного меню на панели «Композиция» или «Временная шкала». Дочерние слои добавляются к существующей выделенной области.
  • Можно выбрать несколько слоев на панели «Композиция». Перетащите инструмент «Выделение» для создания рамки выбора (области) вокруг слоев и их выделения. Для выделения дополнительных слоев или отмены выделения слоев при перетаскивании или их выборе удерживайте клавишу SHIFT.

Ллойд Альварес (Lloyd Alvarez) предлагает на своем веб-сайте After Effects Scripts сценарий, с помощью которого можно отмечать слои тегами, а затем выбирать, скрывать слои и применять к ним режим «Соло» в соответствии с их тегами. Теги добавляются к комментариям в поле комментариев на таймлайне.

Изменение порядка расположения выделенных слоев

Вертикальное упорядочение слоев на панели «Таймлайн» называется порядком расположения слоев. Он напрямую связан с порядком рендеринга. Изменив порядок расположения слоев, можно изменить порядок, в котором слои располагаются по отношению друг к другу.

Примечание.

Из-за определенных свойств глубины 3D-слоев порядок их расположения на таймлайне может не отражать их пространственное положение в композиции.  

  • Перетащите имена слоев в новое место в порядке расположения слоев на таймлайне.
  • Для перемещение выделенных слоев на один уровень вверх в порядке расположения слоев нажмите CTRL+ALT+СТРЕЛКА ВВЕРХ (Windows) или COMMAND+OPTION+СТРЕЛКА ВВЕРХ (Mac OS); Для перемещение выделенных слоев на один уровень вниз нажмите CTRL+ALT+СТРЕЛКА ВНИЗ (Windows) или COMMAND+OPTION+СТРЕЛКА ВНИЗ (Mac OS).
  • Для перемещение выделенных слоев на самый верх в порядке расположения слоев нажмите CTRL+ALT+SHIFT+СТРЕЛКА ВВЕРХ (Windows) или COMMAND+OPTION+SHIFT+СТРЕЛКА ВВЕРХ (Mac OS); Для перемещение выделенных слоев в самый низ порядка расположения слоев нажмите COMMAND+OPTION+SHIFT+СТРЕЛКА ВНИЗ (Windows) или COMMAND+OPTION+SHIFT+СТРЕЛКА ВНИЗ (Mac OS).
  • Выберите «Слой» > «Упорядочить», а затем нажмите «Переместить слой вперед», «Отправить слой назад», «Переместить слой наверх» или «Отправить слой вниз».
Примечание.

При копировании (или вырезании) и вставке слоев они отображаются на панели «Временная шкала» сверху вниз в том же порядке, в котором они были выделены перед операцией копирования (или вырезания). Для изменения порядка выбора слоев выберите слои в произвольном порядке, щелкнув их, удерживая нажатой клавишу CTRL (Windows) или COMMAND (Mac OS), а затем вырежите и немедленно вставьте их.

Джефф Альмасол (Jeff Almasol) предлагает на своем веб-сайте redefinery сценарий, с помощью которого можно изменить порядок расположения слоев в композиции путем их сортировки в соответствии с точками входа и выхода, порядком выделения, именем слоя или в случайном порядке.

Системы координат: пространство композиции и пространство слоя

Системой координат для каждого слоя является его пространство. Системой координат для каждой композиции является ее пространство. Значения свойств для элементов, которые находятся в пределах слоя, например контрольные точки эффектов и опорные точки, существуют в пространстве слоя и измеряются от начала координат в пространстве этого слоя. При этом свойство слоя «Положение» показывает, когда слой находится внутри композиции, и поэтому рассчитывается в пространстве этой композиции.

При перемещении курсора над кадром слоя на панели «Слой» на панели «Информация» отображаются координаты пиксела под указателем в пространстве слоя. Координата X обозначает положение относительно горизонтальной оси, координата Y обозначает положение на вертикальной оси. Значения этих координат указываются в пикселях. Координаты X и Y указываются относительно нулевых координат (0,0), которые находятся в верхнем левом углу слоя.

Можно изменить начальные точки осей, но нельзя изменить нулевые координаты пространства слоя. Если начальные точки осей отличаются от нулевых координат, на панели «Информация» под координатами X и Y отображаются координаты X' и Y', указывающие координаты на основе начальных точек осей.

При наведении указателя на кадр композиции на панели «Композиция» на панели «Информация» отображаются координаты в пространстве композиции. При перетаскивании слоя нижняя часть панели «Информация» показывает координаты опорной точки слоя.

Перемещение слоев в пространстве

При перемещении слоя в пространстве изменяется его свойство «Положение».

Компоненты свойства «Положение» можно разделить на отдельные свойства — «Положение по оси X», «Положение по оси Y» и (для 3D-слоев) «Положение по оси Z», чтобы каждое их них можно было изменять или анимировать отдельно. (См. раздел Разделение координат «Положение» для отдельной анимации компонентов.)

Джефф Альмасол (Jeff Almasol) предлагает на своем веб-сайте redefinery сценарий, который размещает новый пустой слой на линии между опорными точками двух выделенных слоев; используя элемент управления «Ползунок» нулевого слоя, можно менять его положение вдоль этой линии.

Примечание.

Для перемещения выделенных слоев таким образом, чтобы их опорные точки находились по центру в текущем виде, выберите меню «Слой» > «Преобразовать» > «По центру вида» или нажмите клавиши CTRL+HOME (Windows) или COMMAND+HOME (Mac OS).

Примечание.

Для перемещения слоя таким образом, чтобы его опорная точка находилась в центре композиции, щелкните правой кнопкой мыши свойство «Положение» (Windows) или щелкните свойство «Положение», удерживая нажатой клавишу CONTROL (Mac OS), затем выберите «Изменить значение», «% композиции» в меню «Единицы измерения» и введите значение «50» для каждого из компонентов свойства «Положение».

Во избежание размытия неподвижного изображения, убедитесь, что значения свойства слоя «Положение» не являются дробными. Это позволит избежать повторной выборки, которая используется, когда слой с качеством изображения «Наилучшее» помещается в субпикселях.

Перемещение слоев путем перетаскивания на панели «Композиция»

Примечание.

Чтобы привязать границы слоя к сеткам или направляющим при перетаскивании, выберите «Вид» > «Привязка к сетке» или «Вид» > «Привязка к направляющим».

  • Выберите один или несколько слоев, а затем перетащите выделенный слой с помощью инструмента «Выделение» .

    При перемещении слоя путем его перетаскивания на панели «Композиция» на панели «Информация» отображаются изменения свойства «Положение».

Перемещение слоя непосредственным изменением свойства «Положение»

  1. Выделите один или несколько слоев.
  2. Нажмите «P» для отображения свойства «Положение» на панели «Таймлайн».
  3. Измените свойство «Положение» на панели «Таймлайн».

Перемещение слоев с использованием клавиш со стрелками

  1. Выделите один или несколько слоев.
  2. Для перемещения выделенных слоев на один пиксель влево, вправо, вверх или вниз нажмите соответствующую клавишу со стрелкой. Для перемещения на 10 пикселей при нажатии на клавишу со стрелкой удерживайте нажатой клавишу SHIFT.
    Примечание.

    Клавиши со стрелками перемещают выбранный слой на один пиксель в текущем коэффициенте увеличения. Для более точного перемещения слоя с помощью стрелок используйте увеличение на панели «Композиция». (См. раздел Увеличение изображение для предварительного просмотра).

Разделение координат «Положение» для отдельной анимации компонентов

По умолчанию каждое свойство «Положение» имеет два или три компонента, каждый из которых содержит значение для одного пространственного направления (оси). Можно разделить компоненты свойства «Положение» на отдельные свойства — «Положение по оси X», «Положение по оси Y» и (для 3D-слоев) «Положение по оси Z». Разделение координат позволяет независимо изменять или анимировать положение слоя вдоль осей Х, Y и Z.

Для разбивки выбранных свойств «Положение» на отдельные свойства «Положение по оси X», «Положение по оси Y» и (для 3D-слоев) «Положение по оси Z» выполните одно из предложенных ниже действий.

  • Выберите «Анимация» > «Разделить координаты».
  • Щелкните правой кнопкой мыши (Windows) или щелкните, удерживая нажатой клавишу CONTROL (Mac OS), свойство «Положение» и выберите в контекстном меню команду «Разделить координаты».
  • Нажмите кнопку «Разделить координаты» , расположенную в нижней части редактора диаграмм.

Для восстановления набора отдельных свойств положения в одно свойство «Положение» с несколькими компонентами используйте те же команды, которые использовались для разделения координат.  

Примечание.

При повторном объединении отдельных свойств положения в одно свойство «Положение» теряется некоторая информация о пути и скорости перемещения, поскольку кривые Безье, использующиеся для представления отдельных компонентов, сжимаются в одну кривую Безье в каждом ключевом кадре. При разделении координат теряется некоторая информация о скорости, но путь перемещения не изменяется. В ходе проекта рекомендуется работать либо с разделением координат, либо без их разделения для каждого свойства, вместо их периодического разделения и соединения.

Решение о работе с разделением координат зависит от конечных целей. Использования одного свойства положения позволяет добиться более плавного движения. Кроме того, использование одного свойства положения позволяет применять подвижные ключевые кадры, что обеспечивает равномерную скорость. Работа с отдельными координатами положения ведет к некоторому ухудшению автоматической настройки плавности, но предлагает больший контроль над пространственной анимацией. Работа с отдельными координатами также упрощает некоторые имитации, особенно в случаях, когда имитирующиеся силы, воздействующие на слой, являются ортогональными (перпендикулярными) друг к другу.

Например, при применении анимации к мячу, который летит по горизонтали и прыгает по вертикали, разделение координат более предпочтительно. Анимация для свойства «Положение по оси X» создается с помощью 2 ключевых кадров (по одному для начального и конечного положения). Эта горизонтальная анимация представляет собой скорость броска. Анимация для свойства «Положение по оси Y» создается с помощью одного выражения, которое имитирует ускорение свободного падения и вертикальный отскок от пола. Аналогичным примером является шлюпка, плывущая вниз по реке при переменном ветре.

Примечание.

After Effects CS3 содержит стиль анимации «Разделить положения по осям XYZ», выполняющий функции, похожие на функции команды «Разделить координаты», хотя стиль анимации не настолько ошибкоустойчивый.

Выравнивание или распределение слоев в двухмерном пространстве

Для выравнивания или равномерного распределения слоев в пространстве используйте панель «Выравнивание». Выровнять или распределить слои можно по вертикали или по горизонтали.

  1. Выделите слои для выравнивания или распределения.
  2. Выберите «Выделение» или «Композиция» из меню «Выровнять слои по».

    Выделение

    Выравнивание выделенных слоев происходит в соответствии с границами выделенных слоев.

    Композиция

    Выравнивание выделенных слоев происходит в соответствии с границами кадра композиции.

  3. На панели «Выравнивание» нажмите кнопку, соответствующую требуемому типу выравнивания или распределения.
  • Для распределения слоев необходимо выбрать минимум три слоя. При выборе варианта «Выделение» в меню «Выровнять слои по» необходимо выбрать минимум два слоя. При выборе варианта «Композиция» в меню «Выровнять слои по» необходимо выбрать хотя бы один слой.

  • При выборе варианта «Выделение» в меню «Выровнять слои по» каждый вариант выравнивает выделенные слои по отношению к слою, который наиболее близок к варианту нового выравнивания. Например, при выравнивании по правому краю все выделенные слои выравниваются по отношению к выделенному слою, чей край является крайним правым.

  • С помощью параметра распределения слоев выделенные слои можно равномерно распределить между двумя крайними объектами. Например, параметр распределения по вертикали позволяет распределить выделенные слои между самым верхним и самым нижним слоями.

  • При распределении слоев различных размеров расстояние между слоями может быть неравномерным. Например, при распределении слоев по их центрам расстояние между центрами будет одинаковым, но слои с различными размерами занимают различные площади в пространстве между слоями.

  • Заблокированные слои не могут быть выравнены или распределены.

  • Панель «Выравнивание» не влияет на выравнивание символов в текстовом слое.

Примечание.

Для перемещения выделенных слоев таким образом, чтобы их опорные точки находились по центру в текущем виде, выберите меню «Слой» > «Преобразовать» > «По центру вида» или нажмите клавиши CTRL+HOME (Windows) или COMMAND+HOME (Mac OS).

Чарльз Борденейв (Charles Bordenave) предлагает на веб-сайте After Effects Scripts сценарий, с помощью которого можно распределять слои в трехмерном пространстве.

Обрезка, растягивание или циклический монтаж слоя

Началом продолжительности слоя является его точка входа, а окончанием — его точка выхода. Продолжительностью слоя называется интервал между точками входа и выхода, а полоса, которая идет от точки входа к точке выхода, называется панелью продолжительности слоя.

Обрезка слоя подразумевает изменение его точки входа или точки выхода таким образом, что слой приобретает другую продолжительность. При усечении слоя, который основан на исходном движущемся элементе видеоряда, определяются какие кадры элемента исходного видеоряда, которые будут отображаться в слое; первый отображаемый кадр является точкой входа, а последний — точкой выхода. Обрезка слоя не подразумевает вырезания кадров из элемента видеоряда; она влияет только на то, какие кадры будут воспроизводиться в слое.

Обрезка слоев на панели «Таймлайн»
Обрезка слоев на таймлайне

A. Исходная точка входа B. Отрицательный индикатор времени слоя для неподвижного изображения слоя C. Исходная точка входа D. Панель циклического монтажа, которая представляет собой исключенные кадры для слоя движущегося видеоряда E. Новые точки входа 

При использовании элемента видеоряда в качестве источника для разных слоев каждый слой можно обрезать по-разному для отображения различных частей источника. Обрезка слоя не изменяет элемент видеоряда или файл оригинального источника.

Слой можно обрезать, изменив точки входа и выхода на панели «Слой» или «Временная шкала». (Также можно обрезать элемент видеоряда перед его использованием для создания слоя. См. раздел Создание слоев из элементов видеоряда или изменение источника слоя.)

Значения точки входа , точки выхода и продолжительности слоя отображаются в нижней части панели «Слой». Чтобы отобразить эту информацию для всех слоев на панели «Таймлайн», нажмите кнопку «Вход/Выход/Продолжительность/Растягивание» в левом нижнем углу панели «Таймлайн». Продолжительность, точка входа и точка выхода для выделенного слоя также отображаются на панели «Информация».

На панели «Слой» точки входа и выхода показываются на времени слоя. На панели «Таймлайн» точки входа и выхода показываются на времени композиции. Продолжительность в обоих случаях является одинаковой (если только для слоя не включено перераспределение времени или растягивание времени).

Продолжительность многих типов слоев можно увеличить, расширив их точки входа и выхода за пределы исходных временных значений. Это применимо для слоев с перераспределением времени, слоев-фигур, слоев, основанных на неподвижных изображениях, слоев камеры, слоев света и текстовых слоев. При расширении слоя назад во времени таким образом, что слой переходит в отрицательное время слоя (за пределы нулевого времени слоя), значки решетки в нижней части полосы слоя обозначают части слоя, которые находятся в отрицательном времени слоя. Это представление полезно при применении к слою таких эффектов, как «Площадка для частиц» и «Размах», то есть эффектов, которые используют время слоя для вычисления своих результатов.

Ресурсы в Интернете, посвященные обрезке, растягиванию и редактированию слоев

Джефф Альмасол (Jeff Almasol) предлагает на своем веб-сайте redefinery сценарий, который создает панель с элементами управления для перемещения различных комбинаций элементов во времени: точки входа слоя, точки выхода, исходных кадров, ключевых кадров и маркеров.

Обрезка или растягивание слоев на таймлайне

Перетаскивание точки выхода на панели продолжительности слоя
Перетаскивание точки выхода на панели продолжительности слоя.

  1. Выберите один или несколько слоев на панели «Таймлайн».
  2. Выполните одно из предложенных ниже действий.
    • Перетащите любой конец панели продолжительности слоя.

    • Переместите индикатор текущего времени ко времени, на которое необходимо установить точку входа или точку выхода. Для установки точки входа на текущее время нажмите ALT+[ (Windows) или OPTION+[ (Mac OS). Для установки точки выхода на текущее время, нажмите ALT+] (Windows) или OPTION+] (Mac OS).

Обрезка или растягивание слоя на панели «Слой»

  • Откройте слой на панели «Слой» и перетащите любой конец панели продолжительности слоя.
  • Переместите индикатор текущего времени на панели «Слой» ко времени, на которое необходимо установить начало или конец видеоряда, а затем нажмите кнопку «Вход» или «Выход» , чтобы установить точку входа или выхода на текущее время.

Циклический монтаж слоя

По завершении обрезки слоя на основе движущегося видеоряда на бледной полосе циклического монтажа будут показаны кадры элемента видеоряда, исключенные из композиции. Этот бледный прямоугольник не отображается для усеченного слоя, основанного на неподвижном элементе видеоряда. Кадры, которые будут воспроизводиться в пределах усеченной продолжительности, можно выбрать перетаскиванием полосы циклического монтажа. При этом точки входа и выхода слоя не затрагиваются.

Перемещение только точки входа или точки выхода слоя не перемещает ключевые кадры. Перетаскивание панели продолжительности слоя перемещает все ключевые кадры. Перетаскивание полосы циклического монтажа перемещает выбранные ключевые кадры, но не влияет на не выделенные ключевые кадры.

Примечание.

При выполнении циклического монтажа может потребоваться перемещение некоторых ключевых кадров вместе с исходным видеорядом, например ключевых кадров маски. Другие ключевые кадры должны оставаться на том же месте во времени. Для отмены выделения ключевых кадров при сохранения выделения слоя нажмите SHIFT+F2.

  • Перетащите полосу циклического монтажа влево или вправо.
  • Перетащите слой влево или вправо с помощью инструмента «Панорамирование назад (опорная точка)».

Удаление части продолжительности слоя

  1. На панели «Таймлайн» задайте рабочую область, включающую только ту часть продолжительности слоев, которую необходимо удалить. Переместите индикатор текущего времени в точку начала рабочей области и нажмите B. Переместите индикатор текущего времени в точку окончания рабочей области и нажмите N.
  2. Выполните одно из предложенных ниже действий.
    • Выберите слои, из которых необходимо удалить отрезок.

    • Выберите переключатель «Заблокировать» для слоев, которые не предназначены для извлечения. Нажмите F2, чтобы снять выделение со всех слоев.

    Примечание.

    При отсутствии выделенных слоев следующий шаг удаляет заданный отрезок всех незаблокированных слоев.

  3. Выполните одно из предложенных ниже действий.
    • Чтобы удалить отрезок и оставить пробел с продолжительностью удаленного отрезка, выберите «Правка» > «Приподнять рабочую область».

    • Для удаления отрезка выберите «Правка» > «Извлечь рабочую область». Пробел закрывается удалением со сдвигом.

Размещение или перемещение слоя во времени

Панель продолжительности слоя визуально — это визуальное представление продолжительности слоя. Столбцы «Точка входа», «Точка выхода» и «Продолжительность» на панели «Временная шкала» представляют продолжительность слоя в числовых значениях.

Примечание.

Чтобы выбрать какие столбцы отображаются на панели «Временная шкала», выберите «Столбцы» в меню панели или щелкните заголовок столбца правой кнопкой мыши (Windows), или щелкните заголовок столбца, удерживая нажатой клавишу CONTROL (Mac OS).

Эта процедура перемещает во времени весь слой.

  • Для выражения точки входа или выхода в числах, щелкните число в столбце «Точка входа» или «Точка выхода» для данного слоя на панели «Временная шкала».
  • Для перемещения точки входа или точки выхода на текущее время щелкните число в столбце «Точка входа» или «Точка выхода» для данного слоя на панели «Временная шкала», удерживая нажатой клавишу ALT (Windows) или OPTION (Mac OS).
  • Для перемещения точки входа выделенных слоев в начало композиции нажмите ALT+HOME (Windows) или OPTION+HOME (Mac OS).
  • Для перемещения точки выхода выделенных слоев в конец композиции нажмите ALT+END (Windows) или OPTION+END (Mac OS).
  • Для перемещения выделенных слоев на один кадр вперед нажмите ALT+PAGE DOWN (Windows) или OPTION+PAGE DOWN (Mac OS). Для перемещения выделенных слоев на 10 кадров вперед нажмите ALT+SHIFT+PAGE DOWN (Windows) или OPTION+SHIFT+PAGE DOWN (Mac OS).
  • Для перемещения выделенных слоев на один кадр назад нажмите ALT+PAGE UP (Windows) или OPTION+PAGE UP (Mac OS). Для перемещения выделенных слоев на 10 кадров назад нажмите ALT+SHIFT+PAGE UP (Windows) или OPTION+SHIFT+PAGE UP (Mac OS).
  • Для перемещения всего слоя во времени путем перетаскивания, перетащите панель продолжительности слоя влево или вправо. Чтобы привязать полосу длительности слоя к важным точкам во времени (например, маркерам, началу или концу композиции), перетащите панель продолжительности слоя, удерживая клавишу SHIFT.
Примечание.

При перетаскивании слоя на таймлайне на панели «Информация» появляется имя, продолжительность, изменение во времени и точки входа и выхода слоя.  

До и после перетаскивания панели продолжительности

Джефф Альмасол (Jeff Almasol) предлагает на своем веб-сайте redefinery сценарий, который позволяет переместить выделенные слои как группу и выравнять группу по отношению к определенному времени композиции.

Последовательное упорядочение слоев во времени

Используйте помощник в работе с ключевыми кадрами «Слои эпизода», чтобы автоматически расположить слои в эпизоде. При использовании помощника в работе с ключевыми кадрами первый выделенный слой остается в его исходном времени, а другие выделенные слои перемещаются к новому времени на панели «Таймлайн» на основе того порядка, в котором они были выбраны.

Слои, выделенные на панели «Таймлайн»
Слои, выделенные на панели «Таймлайн» (вверху), и слои, упорядоченные в эпизод с помощью помощника для работы с ключевыми кадрами «Слои эпизода» (внизу)

Накладывающиеся друг на друга слои
Накладывающиеся друг на друга слои могут иметь автоматически установленные ключевые кадры непрозрачности для создания перекрестного растворения.

Для помещения слоя в последовательность его продолжительность должна быть меньше, чем длина композиции, чтобы оставалось время для остальных слоев. (См. раздел Обрезка, растягивание или циклический монтаж слоя.)

  1. На панели «Временная шкала», удерживая нажатой клавишу CTRL (Windows) или COMMAND (Mac OS), выделите слои в последовательном порядке, начиная со слоя, который будет отображаться первым.
  2. Выберите «Анимация» > «Помощник в работе с ключевыми кадрами» > «Слои эпизода».
  3. В диалоговом окне «Слои эпизода» выполните одно из предложенных ниже действий.
    • Для упорядочения слоев непрерывной цепочкой оставьте параметр «Наложение» не выбранным.

    • Для наложения слоев выберите параметр «Наложение», введите значение «Продолжительность», чтобы определить продолжительность наложения, и выберите переход. Выберите параметр «Перекрестное растворение передних и задних слоев» для использования прозрачности выделенных слоев; в противном случае выберите «Растворение переднего слоя».

    • Для сохранения пробелов между слоями, выберите параметр «Наложение» и введите отрицательное значение для продолжительности.

Копирование или дублирование слоя

При копировании слоя копируются все его свойства, включая эффекты, ключевые кадры, выражения и маски.

Дублирование слоя — это быстрый способ копирования и вставки слоя с помощью одной команды. Дублирование слоя с подложкой отслеживания сохраняет относительный порядок слоя и его подложки отслеживания.

При вставке слои располагаются в порядке их выделения перед копированием. Первый выбранный слой становится последним при вставке и размещается поверх остальных слоев в порядке расположения слоев. При выделении слоев, начиная с верхнего, они размещаются в том же самом порядке расположения при вставке.

Примечание.

Если при копировании выделен какой-либо компонент слоя, например маска или ключевой кадр, то копируется только этот компонент. Перед копированием нажмите SHIFT+F2 для отмены выделения всех компонентов слоя и выделения только самого слоя.

  • Чтобы копировать выделенные слои и установить точки входа в копиях на текущее время, выберите «Правка» > «Копировать», а затем нажмите CTRL+ALT+V (Windows) или COMMAND+OPTION+V (Mac OS).
  • Чтобы копировать выделенные слои и установить копии на то же время, что и оригиналы, выберите «Правка» > «Копировать», а затем выберите «Правка» > «Вставить».
Примечание.

Для размещения копий поверх всех слоев на панели «Временная шкала» вместо размещения непосредственно над оригиналами нажмите клавишу F2 для отмены выделения оригиналов перед вставкой.

  • Для дублирования выделенных слоев выберите «Правка» > «Дублировать» или нажмите CTRL+D (Windows) или COMMAND+D (Mac OS).

Разделение слоя

На панели «Таймлайн» в любое время слой можно разделить на два независимых слоя. Разделение слоя — альтернатива дублированию и обрезке слоя, которая помогает сэкономить время. Эту функцию можно использовать, если требуется изменить позицию слоя в порядке расположения в середине композиции.

Примечание.

Для создания новых разделенных слоев над исходным слоем на таймлайне выберите «Создать раздельные слои поверх исходного слоя» («Редактировать» > «Установки» > «Общие» (Windows) или After Effects > «Установки» > «Общие» (Mac OS)). Для отображения слоев под исходным слоем отключите этот параметр.

  1. Выделите один или несколько слоев.
  2. Переместите индикатор текущего времени ко времени, на котором требуется разделить слои.
  3. Выберите «Правка» > «Разделить слой».

При разделении слоя оба итоговых слоя содержат все ключевые кадры, которые были в исходном слое, на своих исходных позициях. Любые примененные подложки отслеживания сохраняют свой порядок расположения поверх слоя.

После разделения слоя продолжительность исходного слоя заканчивается в точке разделения, в которой, в свою очередь, начинается новый слой.

Если при нажатии «Правка» > «Разделить слой» не было выделенных слоев, все слои разделяются в точке текущего времени.

Пол Терслей (Paul Tuersley) предлагает на форуме AE Enhancers сценарий для разделения слоев в точках маркеров слоя.

Ллойд Альварес (Lloyd Alvarez) предлагает на своем веб-сайте After Effects Scripts сценарий, который автоматически обнаруживает правки в слое видеоряда и преобразует каждую правку в отдельный слой (или размещает маркер слоя в месте каждой правки).

Параметры автоориентации

Параметры автоориентации («Слой» > «Преобразовать» > «Автоориентация») определяют ориентацию каждого слоя в зависимости от траекторий движения, точек обзора и камер.

Выкл.

Слой поворачивается свободно независимо от траектории движения, точки обзора или других слоев.

Ориентировать вдоль пути

Слой повернут в направлении траектории движения. Используйте этот вариант, например, для отображения ракурса водителя, который смотрит на дорогу во время движения.

Ориентировать на камеру

Слой всегда ориентирован в направлении активной камеры. Этот параметр доступен для 3D-слоев; параметр недоступен для 2D-слоев, камер или освещения. Текстовые 3D-слои имеют дополнительный параметр «Ориентировать каждый символ отдельно», который ориентирует каждый символ вокруг его индивидуальной опорной точки. Выбор параметра «Ориентировать каждый символ отдельно» активирует посимвольные 3D-свойства для текстового слоя, если до этого они не были активированы. (См. раздел Посимвольные 3D-свойства текста.)

Ориентировать в направлении точки обзора

Камера или свет всегда направлены на точку обзора. Этот параметр недоступен для слоев, которые не являются камерами и освещением. (См. раздел Камеры, освещение и точки обзора.)

Примечание.

Если для слоя с установленным параметром автоориентации выполняется изменение его свойств ориентации или поворота по оси X, Y или Z, ориентация слоя производится на основании новых значений. Например, можно задать камере параметр «Ориентировать вдоль пути», а затем повернуть камеру на 90 градусов вправо для отображения ракурса пассажира, смотрящего в боковое стекло автомобиля во время его движения.

Автоориентация, направленная на точку обзора, будет выполнена перед применением преобразований «Поворот» и «Ориентация». Чтобы при выборе параметра «Ориентировать в направлении точки обзора» анимировать камеру или освещение для временного отклонения от точки обзора, анимируйте свойства преобразования «Поворот» и «Ориентация».

Дэн Эббертс (Dan Ebberts) предлагает на своем веб-сайте MotionScript выражение, которое выполняет автоориентацию слоя относительно одной оси. Это полезно, например, для поворота символов из стороны в сторону вслед за перемещением камеры и сохранения их в вертикальном положении.

Дополнительные ресурсы, посвященные выделению и упорядочиванию слоев

Джефф Альмасол (Jeff Almasol) предлагает на своем веб-сайте redefinery сценарий, который создает панель с элементами управления для перемещения различных комбинаций элементов во времени: точки входа слоя, точки выхода, исходных кадров, ключевых кадров и маркеров.

Логотип Adobe

Вход в учетную запись

[Feedback V2 Badge]