Общие сведения о слоях

Слои – это элементы, из которых состоит композиция. Без слоев композиция всего лишь пустой кадр. Можно использовать любое количество слоев по мере необходимости, чтобы создать свою композицию. Некоторые композиции содержат тысячи слоев, а некоторые — всего один слой.

Слои в After Effects аналогичны дорожкам в Adobe Premiere Pro. Основное различие состоит в том, что каждый слой After Effects может содержать не более одного элемента видеоряда в качестве источника, а дорожка Premiere Pro обычно содержит несколько клипов. Слои в After Effects также похожи на слои в Photoshop, хотя интерфейс для работы со слоями отличается. Работа со слоями на панели «Таймлайн» в After Effects аналогична работе со слоями на панели «Слой» в Photoshop.

Можно создавать слои нескольких типов.

  • Слои аудио и видео, созданные из импортированных элементов видеоряда, таких как неподвижные изображения, фильмы и аудиодорожки

  • Слои, которые создаются в After Effects для выполнения специальных функций, таких как камеры, источники света, корректирующие слои и нулевые объекты

  • Слои сплошного цвета, созданные в After Effects из элементов видеоряда сплошного цвета

  • Синтетические слои, содержащие визуальные элементы, созданные в After Effects, например слои фигур и текстовые слои

  • Слои предварительной композиции, которые используют композиции в качестве элементов исходного видеоряда

Изменения слоя не влияют на элементы его исходного видеоряда. Можно использовать один и тот же элемент видеоряда в качестве источника более, чем для одного слоя, и использовать его по-разному в каждом экземпляре. (См. раздел Импорт и интерпретация элементов видеоряда.)

Изменения, внесенные на один слой, не влияют на другие слои, если слои определенным образом не связаны. Например, можно перемещать, поворачивать и рисовать маски на одном слое, не затрагивая все остальные слои в композиции.

After Effects автоматически нумерует все слои в композиции. По умолчанию эти номера отображаются на панели «Таймлайн» рядом с именем слоя. Номер соответствует положению этого слоя в порядке наложения. При изменении порядка наложения After Effects изменяет соответственно все номера. Порядок наложения слоев влияет на порядок рендеринга и поэтому влияет на рендеринг композиции для предпросмотра и конечного вывода. (См. раздел Порядок рендеринга и сворачивание трансформаций.)

Слои на панелях «Слой», «Композиция» и «Таймлайн»

После добавления слоя в композицию можно изменить расположение слоя на панели «Композиция». На панели «Таймлайн» можно изменить длительность, время начала и место слоя в порядке наложения слоев. Также на панели «Таймлайн» можно изменить свойства слоя. (См. раздел Свойства слоя на панели «Таймлайн».)

Можно выполнять множество действий, таких как рисование маски, как на панели «Композиция», так и на панели «Слой». Однако другие задачи, такие как отслеживание движения и раскрашивание, должны выполняться только на панели «Слой».

Слой на панели «Слой» отображается перед любыми преобразованиями, применяемыми к слою. Например, на панели «Слой» не показывается результат изменения масштаба слоя. Используйте панель «Композиция» для просмотра слоя в сочетании с другими слоями и с результатами преобразований.

Слои, которые не основаны на элементе исходного видеоряда, называются синтетическими. Синтетические слои содержат текстовые слои и слои-фигуры. На панели «Слой» невозможно открыть синтетический слой. Однако можно предварительно собрать синтетический слой и открыть предварительную композицию на панели «Слой».

Примечание.

Для просмотра изменений (например, маски или применения эффекта) на панели «Слой» выберите «Рендеринг». Снимите флажок «Рендеринг» для просмотра исходного, неизмененного слоя.

Открытие слоев и источников слоя

  • Для открытия слоя (кроме предварительной композиции) на панели «Слой» дважды щелкните нужный слой, либо выделите его и выберите «Слой» > «Открыть слой».

  • Для открытия исходной композиции слоя предварительной композиции на панели «Композиция» дважды щелкните нужный слой, либо выделите его и выберите «Слой» > «Открыть композицию».

  • Для открытия элемента исходного видеоряда дважды щелкните слой, удерживая нажатой клавишу ALT (Windows) или клавишу OPTION (Mac OS), либо выделите его и выберите «Слой» > «Открыть источник слоя».

Примечание.

Если щелкнуть слой правой кнопкой мыши (Windows) или при нажатой клавише CONTROL (Mac OS), то можно выбрать в контекстном меню команду «Открыть видеоряд» или «Открыть композицию».

  • Чтобы открыть слой предварительной композиции на панели «Слой», дважды щелкните его, удерживая нажатой клавишу ALT (Windows) или клавишу OPTION (Mac OS), либо выделите его и выберите «Слой» > «Открыть слой».

Создание слоев из элементов видеоряда или изменение источника слоя

Слой можно создать из любого элемента видеоряда на панели «Проект», в том числе и из другой композиции. После добавления элемента видеоряда в композицию можно изменить и анимировать созданный слой.

При добавлении одной композиции в другую создайте слой, использующий композицию, которая была добавлена в качестве его источника. (См. раздел Предварительная композиция, вложение и предварительный рендеринг.)

Настройка «Видеоряд стоп-кадра» («Установки» > «Импорт») управляет длительностью слоев по умолчанию, которые используют неподвижные элементы видеоряда, как источники. По умолчанию при создании слоя, в качестве источника которого выступает неподвижное изображение, продолжительность слоя равна длительности композиции. Можно изменить длительность слоя после его создания методом отсечения.

Примечание.

По умолчанию новые слои начинаются в начале композиции. Можно настроить приложение так, чтобы новые слои начинались в текущее время. Для этого необходимо отключить параметр «Создать слои во времени начала композиции» («Правка» > «Установки» > «Общие» [Windows] или «After Effects» > «Установки» > «Общие» [Mac OS]).

Зачастую следующим шагом после добавления слоя в композицию является масштабирование и позиционирование для его подгонки под кадр. (См. раздел Масштабирование или отражение слоя.)

Создание слоя из одного или нескольких элементов видеоряда

После создания из нескольких элементов видеоряда слои отображаются в порядке наложения на панели «Таймлайн» в том порядке, в котором они были выбраны на панели «Проект».

  1. Выберите один или несколько элементов видеоряда и папки на панели «Проект».
  2. Выполните одно из предложенных ниже действий.
    • Перетащите выбранные элементы видеоряда на панель «Композиция».

    Примечание.

    Для привязки слоя к центру или краям композиции при перетаскивании удерживайте нажатой клавишу SHIFT.

    • Перетащите выбранные элементы видеоряда на панель «Таймлайн». При перетаскивании элемента в пределы слоя на нем будет подсвечено место, где слой будет отображаться после отпускания кнопки мыши. Если перетащить элемент над временной диаграммой, то маркер времени укажет точку входа, где окажется слой после отпускания кнопки мыши.

    Примечание.

    Для привязки точки входа к индикатору текущего времени при перетаскивании удерживайте нажатой клавишу SHIFT.

    • Перетащите выбранные элементы видеоряда на название композиции или значок на панели «Проект» или нажмите комбинацию клавиш CTRL+/ (Windows) или COMMAND+/ (Mac OS). Новые слои создаются непосредственно над выделенным слоем и в центре композиции. Если слой не выбран, новые слои создаются в верхней части стека слоев.

Создание слоя из усеченного элемента видеоряда

Элемент, созданный из движущегося изображения, можно обрезать на панели видеоряда перед вставкой слоя на базе этого элемента в композицию.

  1. Для открытия элемента на панели видеоряда дважды щелкните его на панели «Проект». (См. раздел Просмотр элементов на панели видеоряда.)

  2. Переместите индикатор текущего времени на панели видеоряда на кадр, который нужно использовать как точку входа слоя, и нажмите кнопку «Задать точку входа» в нижней части панели видеоряда.

  3. Переместите индикатор текущего времени на панели видеоряда на кадр, который нужно использовать как точку выхода слоя, и нажмите кнопку «Задать точку выхода» в нижней части панели видеоряда.
  4. Для создания слоя на основе данного усеченного элемента видеоряда нажмите кнопку «Правка» в нижней части панели видеоряда:

    Редактирование наложения

    Создает слой поверх наложенных слоев с точкой входа, установленной в текущее время на панели «Таймлайн».

    Правка «Вставка со сдвигом»

    Также создает слой поверх наложенных слоев с точкой входа, установленной в текущее время на панели «Таймлайн», но разделяет все остальные слои. Недавно созданные разделенные слои перемещаются позднее по времени таким образом, что их точки входа совпадают с точкой выхода добавленного слоя.

Замена источника слоя ссылками на другой элемент видеоряда

  1. Выберите один или несколько слоев на панели «Таймлайн»
  2. Удерживая нажатой клавишу ALT (Windows) или OPTION (Mac OS), перетащите элемент видеоряда из панели «Проект» на выделенный слой на панели «Таймлайн».

Слои сплошного цвета и элементы видеоряда сплошного цвета

Можно создавать слои любого сплошного цвета и любого размера (до 30 000 x 30 000 пикселей). Слои сплошного цвета используют элементы видеоряда сплошного цвета в качестве источников. Слои сплошного цвета и элементы видеоряда сплошного цвета обычно называют сплошными.

Сплошные работают так же, как и любые другие элементы видеоряда: можно добавлять маски, изменять свойства преобразований и применять эффекты к слою, который создан из сплошного элемента. Используйте сплошные цвета для закрашивания фона как основание управляющего слоя для составного эффекта или создания простого графического изображения.

Элементы видеоряда сплошного цвета автоматически сохраняются в папке «Сплошные» на панели «Проект».

Чтобы узнать, как можно изменить свойства папки сплошных заливок для более эффективной организации проекта, см. раздел Улучшенная организация папки сплошных заливок.

Джефф Альмасол (Jeff Almasol) предлагает на своем веб-сайте redefinery сценарий, который позволяет переименовывать выбранные сплошные элементы видеоряда на панели «Проект». Этот сценарий можно применять, например, для включения в название значений размеров в пикселях, пропорции и цвета RGB.

Примечание.

В After Effects CS6 и более поздних версий новые сплошные слои закрашены 17 % серого цвета (45/255), чтобы они могли контрастировать с яркостью нового, по умолчанию более темного пользовательского интерфейса

Создание слоя или элемента видеоряда сплошного цвета

  • Для создания элемента видеоряда сплошного цвета, но без создания для него слоя в композиции, выберите «Файл» > «Импорт» > «Сплошной».
  • Для создания элемента видеоряда сплошного цвета и слоя для него в текущей композиции выберите «Слой» > «Создать» > «Сплошной» или нажмите клавиши CTRL+Y (Windows) или COMMAND+Y (Mac OS).

    Для создания слоя сплошного цвета, который впишется в композицию, выберите «Задать размеры композиции».

Изменение настроек для слоев и элементов видеоряда сплошного цвета

  • Для изменения настроек для выбранных слоев сплошного цвета или элемента видеоряда выберите «Слой» > «Настройка сплошной заливки».

    Для применения изменений ко всем слоям сплошного цвета, в которых используется данный элемент видеоряда, выберите «Затрагивать все слои, использующие эту сплошную заливку». Если этот параметр не выбран, то создается элемент видеоряда, который будет источником для выделенного слоя.

Корректирующие слои

При применении эффекта к слою он применяется только к этому слою, но не к другим. Однако, эффект может существовать независимо, если для него создан корректирующий слой. Все эффекты, примененные к корректирующему слою, влияют на все слои под ним в порядке наложения слоев. Корректирующий слой, находящийся в нижней части порядка наложения, не дает видимого результата.

Поскольку эффекты в корректирующих слоях применяются ко всем слоям, находящимся под ними, они полезны для применения эффектов к нескольким слоям одновременно. В остальном корректирующий слой работает так же, как другие слои; например, можно использовать ключевые кадры или выражения для любого свойства корректирующего слоя.

Примечание.

Более точное описание: корректирующий слой применяет эффект к композиции, созданной изо всех слоев, находящихся под корректирующим слоем в порядке наложения слоя. По этой причине применение эффекта к корректирующему слою повышает производительность рендеринга в сравнении с применением того же эффекта к каждому из нижележащих слоев по отдельности.

Примечание.

Если требуется применить эффект или преобразовать в коллекцию слоев, то можно предварительно собрать слои, а затем применить эффект или преобразовать в слой предварительной композиции. (См. раздел Предварительная композиция слоя.)

Используйте маски на корректирующем слое, чтобы применить эффект только к фрагментам нижележащих слоев. Для большей наглядности перемещения объектов в нижележащих слоях можно анимировать маски.

  • Для создания корректирующего слоя выберите «Слой» > «Создать» > «Корректирующий слой» или нажмите клавиши CTRL+ALT+Y (Windows) или COMMAND+OPTION+Y (Mac OS).
  • Для преобразования выделенных слоев в корректирующие выберите переключатель «Корректирующий слой» для слоев на панели «Таймлайн» или выберите «Слой» > «Переключатели» > «Корректирующий слой».

Примечание.

Может потребоваться снять флажок «Корректирующий слой» для слоя, чтобы преобразовать его в обычный слой.

Ресурсы в Интернете, посвященные корректирующим слоям

Эндрю Крамер (Andrew Kramer) предлагает на своем веб-сайте Video Copilot видеоруководство, в котором он демонстрирует, как использовать корректирующий слой для применения эффекта только к короткому отрезку времени и только к отдельным частям фильма.

Эран Штерн (Eran Stern) предлагает на своем веб-сайте Creative COW видеоруководство, в котором иллюстрируется порядок использования источников света в качестве корректирующих слоев для точного определения, какие источники света на какие слои влияют.

Ллойд Альварес (Lloyd Alvarez) предлагает на своем веб-сайте After Effects Scripts сценарий, который создает корректирующий слой над каждым выделенным слоем, и каждый новый корректирующий слой обрезается до длительности выделенного слоя.

Создание слоя и нового элемента видеоряда Photoshop

При создании файла Adobe Photoshop из After Effects Photoshop запускается и создает PSD-файл. Этот PSD-файл состоит из пустого слоя Photoshop, который имеет те же размеры, как и композиция с соответствующими направляющими безопасной областью титров и безопасной областью действий. Разрядность цвета PSD-файла совпадает с разрядностью цвета проекта After Effects.

Последний созданный PSD-файл автоматически импортируется в After Effects как элемент видеоряда. Все изменения, сохраненные в Photoshop, отображаются в элементе видеоряда в After Effects.

  • Для создания элемента видеоряда Photoshop и его использования в качестве источника для нового слоя в текущей композиции выберите «Слой» > «Создать» > «Файл Adobe Photoshop». Слой Photoshop добавляется на передний план композиции.
  • Для создания элемента видеоряда Photoshop с настройками последней открытой композиции без добавления в композицию выберите «Файл» > «Создать» > «Файл Adobe Photoshop».

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет