Свойства слоя на панели «Таймлайн»

Каждый слой обладает рядом свойств, многие из которых можно изменять и анимировать. Основной группой свойств, характерных для каждого слоя, является группа «Преобразования», которая включает свойства «Положение» и «Непрозрачность». При добавлении некоторых функций к слою, например масок или эффектов, или преобразовании слоя в 3D-слой он приобретает дополнительные свойства, упорядоченные по группам свойств.

Все свойства слоя являются временными — они могут изменять слой со временем. Некоторые свойства слоя, например «Непрозрачность», имеют только временной компонент. Некоторые свойства слоя, например «Положение», являются также пространственными — они могут перемещать слой или его пиксели в пространстве композиции.

Для отображения свойств слоя и изменения их значений можно расширить структуру слоя.

Большая часть свойств имеют функцию секундомера . Любое свойство с секундомером может быть анимировано, то есть изменено с течением времени. (См. раздел Сведения об анимации, ключевых кадрах и выражениях.)

Свернутые свойства слоя на панели «Таймлайн»
Свернутая панель группы свойств в структуре слоя

Развернутые свойства слоя на панели «Таймлайн»
Развернутая панель группы свойств в структуре слоя


Свойства в группе свойств «Эффекты» (свойства эффектов) также являются свойствами слоя. Многие свойства эффектов можно также изменять на панели «Элементы управления эффектами».

Отображение или скрытие параметров слоя на панели «Таймлайн»

  • Чтобы развернуть или свернуть группу свойств, щелкните треугольник слева от имени слоя или имя группы свойств.
  • Чтобы развернуть или свернуть группу свойств и все ее дочерние элементы, щелкните треугольник, удерживая нажатой клавишу CTRL (Windows) или COMMAND (Mac OS).
  • Чтобы развернуть или свернуть все группы для выделенных слоев, CTRL+` (символ ударения) (Windows) или COMMAND+` (символ ударения) (Mac OS).
  • Чтобы отобразить свойство эффекта на панели «Таймлайн», дважды щелкните имя свойства на панели «Элементы управления эффектами».
  • Чтобы скрыть свойство или группу свойств, щелкните имя свойства или группы свойств на панели «Таймлайн», удерживая нажатыми клавиши ALT+SHIFT (Windows) или OPTION+SHIFT (Mac OS).
  • Чтобы отобразить только выбранные свойства или группы свойств на панели «Таймлайн», нажмите SS.

Примечание.

Сочетание клавиш SS особенно полезно для работы с обводками рисованием. Выберите обводку рисованием на панели «Слой» и нажмите SS, чтобы открыть группу свойств для этой обводки на панели «Таймлайн».

  • Чтобы отобразить только определенное свойство или группу свойств, нажмите назначенную для них комбинацию клавиш. (См. раздел Отображение свойств и групп на панели «Таймлайн» (сочетания клавиш).)
  • Для добавления свойства или группы свойств к свойствам, отображаемым на панели «Таймлайн», удерживайте клавишу SHIFT при нажатии на сочетания клавиш для свойства или группы свойств.
  • Чтобы отобразить только свойства, значения которых по умолчанию были изменены, нажмите UU или выберите «Анимация» > «Открыть измененные свойства».
  • Чтобы отобразить только свойства, имеющие ключевые кадры или выражения, нажмите U или выберите «Анимация» > «Открыть свойства анимации».

Примечание.

Команды U и UU особенно полезны для изучения работы шаблонов настроек анимации, шаблонов проектов и других анимированных элементов, поскольку они изолируют свойства, которые были изменены разработчиком этих элементов.

Слои на панели «Таймлайн» можно также фильтровать для отображения только слоев со свойствами, соответствующими строке поиска. См. раздел Поиск и фильтр на панелях «Таймлайн», «Проект» и «Эффекты и шаблоны».

Выбор свойства или группы свойств на панели «Таймлайн»

Выбрана опорная точка
  • Чтобы выбрать свойство или группу свойств, включая все значения, ключевые кадры и выражения, нажмите свойства или группы свойств в структуре слоя на панели «Таймлайн».

Копирование или дублирование свойства или группы свойств на панели «Таймлайн»

  • Чтобы скопировать свойства из одного слоя или группы свойств в другие, выберите слой, свойство или группу свойств, нажмите CTRL+C (Windows) или COMMAND+C (Mac OS), выберите целевой слой, свойство или группу свойств и нажмите CTRL+V (Windows) или COMMAND+V (Mac OS).
  • Чтобы создать дубликат группы свойств, выберите группу свойств и нажмите CTRL+D (Windows) или COMMAND+D (Mac OS).

    Дублировать можно только некоторые группы свойств, включая фигуры, маски и эффекты. Нельзя создавать дубликаты групп свойств верхнего уровня, таких как «Содержание», «Маски», «Эффекты» и «Преобразования». При попытке создать дубликат группы свойств верхнего уровня дублируется весь слой.

Копирование значения из свойства слоя, которое не содержит ключевые кадры

Можно скопировать текущее значение свойства слоя в другой слой, даже если исходный слой не содержит ключевых кадров.

  1. На панели «Таймлайн» отобразите свойство слоя, содержащее копируемое значение.
  2. Щелкните имя свойства слоя, чтобы выбрать его.
  3. Выберите команду «Правка» > «Копировать».
  4. Выберите слой, в который необходимо вставить значение.
  5. Если целевой слой содержит ключевые кадры, переместите индикатор текущего времени на то время, куда нужно вставить значение. Если целевой слой не содержит ключевые кадры, новое значение применяется ко всей продолжительности слоя.
  6. Выберите команду «Правка» > «Вставить».

Установка значения свойства

При выделении нескольких слоев и изменении свойства для одного слоя это свойство изменяется для всех выделенных слоев. Ползунки, элементы управления углом и некоторые другие элементы управления свойствами доступны только на панели «Элементы управления эффектами».

Примечание.

Чтобы изменить единицы измерения для свойства, щелкните подчеркнутое значение правой кнопкой мыши (Windows) или щелкните подчеркнутое значение, удерживая нажатой клавишу CONTROL (Mac OS), нажмите «Изменить значение» и выберите из меню «Единицы». Для различных типов свойств доступны различные единицы измерения. Для определенных свойств изменить единицы измерения нельзя.

  • Наведите курсор на подчеркнутое значение и перетащите его влево или вправо.
  • Щелкните подчеркнутое значение, введите новое значение и затем нажмите клавишу ВВОД (Windows) или ВВОД (Mac OS).

Примечание.

Для значений свойств можно ввести простые арифметические выражения и другие числовые формулы. Например, можно ввести 2 * 3 вместо 6, 4/2 вместо 2 и 2e2 вместо 200. Такие формулы могут быть особенно полезны, когда значение увеличивается на определенную величину от исходного значения.

  • Щелкните подчеркнутое значение правой кнопкой мыши (Windows) или щелкните подчеркнутое значение, удерживая нажатой клавишу CONTROL (Mac OS), и нажмите «Изменить значение».
  • Перетащите ползунок влево или вправо.
  • Щелкните точку в элементе управления углом или перетащите линию элемента управления угла.

Примечание.

После нажатия на элемент управления угла можно выполнить перетаскивание с большей точностью.

  • Для увеличения или уменьшения значения свойства на 1 единицу щелкните подчеркнутое значение и нажмите клавишу СТРЕЛКА ВВЕРХ или СТРЕЛКА ВНИЗ. Для увеличения или уменьшения значения свойства на 10 единиц при нажатии на клавишу СТРЕЛКА ВВЕРХ или СТРЕЛКА ВНИЗ удерживайте клавишу SHIFT. Для увеличения или уменьшения значения свойства на 0,1 единицы при нажатии на клавишу СТРЕЛКА ВВЕРХ или СТРЕЛКА ВНИЗ удерживайте клавишу CTRL (Windows) или COMMAND (Mac OS).
  • Для сброса свойств в группе свойств к их значениям по умолчанию нажмите кнопку «Сбросить» рядом с именем группы. Чтобы сбросить одно свойство, щелкните правой кнопкой мыши имя (не значение) свойства (Windows) или щелкните имя свойства, удерживая нажатой клавишу CONTROL (Mac OS), и выберите «Сбросить» из контекстного меню.

    Если свойство содержит ключевые кадры, ключевой кадр добавляется в текущее время со значением по умолчанию.

Примечание.

Алан Шиско (Alan Shisko) предлагает в своем блоге Motion Graphics 'n Such видеоруководство по использованию цветов метки и мультивыделения для быстрого изменения свойств для нескольких слоев одновременно.

Чарльз Борденейв (Charles Bordenave) предлагает на веб-сайте After Effects Scripts сценарий, который позволяет задать произвольные значения свойств в группе «Преобразование» для выделенных слоев в пределах заданных ограничений.

Сценарий LockProperties, блокирующий указанные свойства во избежание случайных изменений, можно найти на веб-сайте After Effects Scripts.

Опорные точки слоя

Преобразования, например поворот и масштабирование, выполняются вокруг опорной точки слоя (иногда называемой точкой преобразования или центром преобразования). По умолчанию опорной точкой для большинства типов слоев является центр слоя.

Наиболее распространенным способом анимации опорной точки является установка опорной точки слоя до начала анимации. Например, если нужно анимировать изображение человека, каждая часть тела которого содержится в отдельном слое, может потребоваться переместить опорную точку каждой руки в область запястья, чтобы рука вращалась вокруг этой точки в ходе всей анимации.

Примечание.

Самым простым способом панорамирования и сканирования большого изображения является анимирование свойств «Опорная точка» и «Масштаб».

В видеоуроке Алана Шиско (Alan Shisko), размещенном на его личном веб-сайте, описывается процедура создания сложной 3D среды из 3D-слоев, начиная с простых двухмерных слоев. В этом руководстве большое внимание уделяется управлению опорными точками слоя.

Опорные точки слоя
Опорная точка в центре текстового слоя (слева) по сравнению с опорной точкой, перемещенной в конец текстового слоя (справа)

Опорные точки слоя
При использовании инструмента «Панорамирование назад (опорная точка)» для перемещения опорной точки (слева) на панели «Композиция» After Effects автоматически компенсирует перемещение таким образом, чтобы слой сохранил свое положение относительно фрейма композиции (справа).

Примечание.

Если опорная точка не отображается на панели «Слой», выберите «Путь опорной точки» из меню «Вид» в нижней правой части панели «Слой».

Перемещение опорной точки слоя

  • Перетащите опорную точку с помощью инструмента «Выделение» на панели «Слой»

Примечание.

Слои некоторых типов, например текстовые слои и слои-фигуры, не могут быть открыты на панели «Слой».

  • Для перемещения опорной точки слоя на 1 пиксель выберите «Путь опорной точки» из меню «Вид» в правой нижней части панели «Слой» и нажмите клавишу со стрелкой. Для перемещения на 10 пикселей при нажатии на клавишу со стрелкой удерживайте нажатой клавишу SHIFT. Размеры пикселей соответствуют текущему масштабу на панели «Слой».
  • Для перемещения опорной точки слоя на панели «Композиция» без перемещения слоя выберите слой и используйте инструмент «Панорамирование назад (опорная точка)» для перетаскивания опорной точки.

Примечание.

Перемещение опорной точки с помощью инструмента «Панорамирование назад (опорная точка)» изменяет значения свойств «Положение» и «Опорная точка» таким образом, что слой остается в композиции на том же месте, где он был перед перемещением опорной точки. Для изменения только значения опорной точки выполните перетаскивание с помощью инструмента «Панорамирование назад (опорная точка)», удерживая нажатой клавишу ALT (Windows) или OPTION (Mac OS).

Чарльз Борденейв (Charles Bordenave) предлагает на веб-сайте After Effects Scripts сценарий, который перемещает опорные точки выделенных слоев без перемещения слоев в фрейме композиции.

Сброс опорной точки слоя

  • Чтобы сбросить опорную точку к ее местоположению в слое по умолчанию, дважды нажмите кнопку инструмента «Панорамирование назад (опорная точка)» на панели «Инструменты».
  • Чтобы сбросить опорную точку к ее местоположению в слое по умолчанию, дважды нажмите кнопку инструмента «Панорамирование назад (опорная точка)», удерживая нажатой клавишу ALT (Windows) или OPTION (Mac OS). Слой перемещается к центру композиции

Задание опорной точки слоя по центру содержимого

Опорную точку, которая станет центром содержимого слоя, можно задать следующими способами:

  • Выберите Слой > Трансформировать > Расположить опорную точку в содержимом слоя по центру
  • Используйте комбинацию клавиш Ctrl+Alt+Home (ОС Windows) или Command+Option+Home (Mac OS)
  • Удерживая клавишу Ctrl (Windows) или Command (Mac OS), дважды щелкните инструмент Панорамирование назад (опорная точка)

Вот несколько вариантов использования этой команды:

  • установка опорной точки слоя-фигуры по центру одной фигуры или группы фигур в слое-фигуре;
  • установка опорной точки для текстового слоя по центру текстового содержимого;
  • установка опорной точки слоя по центру видимой области внутри замаскированной области.

Масштабирование или отражение слоя

Как и в случае с другими преобразованиями, масштабирование слоя происходит вокруг опорной точки слоя. При перемещении опорной точки от центра слоя он может переместиться при отражении. Некоторые слои, такие как камера, свет и слои, содержащие только аудио, не имеют свойства «Масштаб».

Слой можно масштабировать за пределами фрейма композиции.

Сведения об экспоненциальном масштабировании, например при использовании объектива с переменным фокусным расстоянием, см. в разделе Изменение скорости масштабирования с помощью параметра «Экспоненциальный масштаб».

Сведения о масштабировании или изменении размера всего фильма (в отличие от одного слоя) см. в разделах Масштабирование фильма с увеличением и Масштабирование фильма с уменьшением.

Отражение слоя означает умножение горизонтального или вертикального компонента значения его свойства масштаба на -1. Слой отражается вокруг его опорной точки.

  • Для отражения выделенных слоев выберите «Слой» > «Преобразование» > «Отразить по горизонтали» или «Слой» > «Преобразование» > «Отразить по вертикали».
  • Для пропорционального масштабирования слоя на панели «Композиция» перетащите любой дескриптор слоя, удерживая клавишу SHIFT.
  • Для произвольного масштабирования слоя на панели «Композиция» перетащите угловой дескриптор слоя.
  • Для масштабирования только одного направления на панели «Композиция» перетащите боковой дескриптор слоя.
  • Чтобы увеличить или уменьшить масштаб для выделенного слоя на 1 %, нажмите клавишу «+» или «–» на цифровой клавиатуре, удерживая нажатой клавишу ALT (Windows) или OPTION (Mac OS).
  • Чтобы увеличить или уменьшить масштаб для выделенного слоя на 10 %, нажмите клавишу «+» или «–» на цифровой клавиатуре, удерживая нажатыми клавиши ALT+SHIFT (Windows) или OPTION+SHIFT (Mac OS).
  • Для масштабирования всей композиции выберите «Файл» > «Сценарии» > «Масштабировать Composition.jsx».
  • Для масштабирования и центрирования выделенных слоев по фрейму композиции выберите «Слой» > «Преобразования» > «Подогнать по размеру композиции».
  • Для масштабирования и центрирования выделенных слоев в соответствии с шириной или высотой фрейма композиции с сохранением пропорций слоя выберите «Слой» > «Преобразования» > «Подогнать по ширине композиции» или «Слой» > «Преобразования» > «Подогнать по высоте композиции».
  • Для пропорционального масштабирования слоя на панели «Таймлайн» выберите слой, нажмите S для отображения свойства масштаба, щелкните значок «Сохранить пропорции» слева от значений масштаба и введите новое значение параметра X, Y или Z.

Примечание.

Для активации значка «Сохранить пропорции» и согласования высоты и ширины, щелкните значок, удерживая нажатой клавишу Alt (Windows) или Option (Mac OS).  

  • Для достижения определенного масштаба в пикселях щелкните значение масштаба на панели «Таймлайн» правой кнопкой мыши (Windows) или щелкните значение масштаба, удерживая нажатой клавишу CONTROL (Mac OS), выберите «Изменить значение» и измените единицы на пиксели в диалоговом окне масштабирования. Выберите «Включить пропорции пикселя» для просмотра и изменения размеров в соответствии с пропорциями пикселя композиции.

Уменьшение масштаба растрового слоя (не векторного) иногда вызывает небольшое смягчение или размытие изображения. Увеличение масштаба растрового слоя с большим коэффициентом может вызвать пикселизацию или блочность изображения.

Эффект «Увеличение с сохранением уровня детализации»

Эффект «Увеличение с сохранением уровня детализации» используется для сильного увеличения изображений с сохранением их деталей.

Дополнительные сведения см. в разделе Эффект «Увеличение с сохранением уровня детализации».

Билинейная и бикубическая выборка

Можно использовать режим бикубической или билинейной выборки для выделенных слоев, который определяет, как будет выполняться выборка пикселей для масштабирования и для всех преобразований, примененных с помощью эффекта «Преобразование».

Дополнительные сведения см. в разделе Качество изображения слоя и субпиксельное позиционирование.

Другие инструменты и ресурсы для масштабирования

Примечание.

Adobe Photoshop обеспечивает точный контроль над методами повторной выборки, используемыми для масштабирования изображений. Чтобы добиться точного контроля над повторной выборкой, можно экспортировать кадры в Photoshop для изменения размера изображения, а затем импортировать кадры обратно в After Effects.

Хотя функция масштабирования в Photoshop не совсем подходит для фильмов, она очень удобна для расширения и масштабирования неподвижных изображений. Эта функция полезна при изменении изображений, которые были созданы для стандартных форматов разрешения, под широкоэкранные форматы.

Сценарий, который масштабирует несколько композиций одновременно, можно найти на форуме AE Enhancers.

Ллойд Альварес (Lloyd Alvarez) предлагает на веб-сайте After Effects Scripts сценарий, который масштабирует выделенные слои по размеру фрейма композиции и предлагает возможности кадрирования и леттербоксинга.

Аарон Рабиновиц (Aharon Rabinowitz) представляет на веб-сайте Creative COW видеоруководство, которое демонстрирует изменение и анимацию свойства «Масштаб» 3D-слоя, включая изменение только Z-координаты масштабирования.

Поворот 2D-слоя

Как и в случае с другими преобразованиями, поворот слоя происходит вокруг опорной точки слоя.

Примечание.

Для отображения значения свойства «Поворот» для выделенных слоев на панели «Таймлайн» нажмите клавишу R.

Первая часть значения свойства «Поворот» является количеством всех поворотов, вторая часть — фракционным поворотом в градусах.

Сведения о вращении 3D-слоев см. в разделе Вращение или ориентация 3D-слоя.

  • Чтобы повернуть слой путем перетаскивания на панели «Композиция», перетащите его, используя инструмент «Поворот» . Чтобы ограничить поворот углом, кратным 45°, при перетаскивании удерживайте клавишу SHIFT.
  • Чтобы повернуть выделенные слои на 1 градус, нажмите «плюс» (+) или «минус» (-) на цифровой клавиатуре.
  • Чтобы повернуть выделенные слои на 10 градусов, нажмите «плюс» (+) или «минус» (-) на цифровой клавиатуре, удерживая клавишу SHIFT.

Регулировка уровней громкости звука

При использовании видеоряда, содержащего аудио, уровень звука для воспроизведения по умолчанию равен 0 дБ, что означает, что уровень не отрегулирован в After Effects. Установка положительного значения для уровня децибел увеличивает громкость; установка отрицательного значения — уменьшает громкость.

Примечание.

Двойной щелчок ключевого кадра уровней аудио активирует панель «Аудио».

Индикатор VU на панели аудио отображает громкость звука при воспроизведении аудио. Красные блоки в верхней части индикатора обозначают ограничения громкости системы.

Примечание.

Для дополнительной точности при настройке уровней звука переместите ползунки, чтобы увеличить высоту панели «Аудио».

  1. Для регулировки громкости на панели «Аудио» выполните одно из следующих действий.
    • Чтобы установить сразу уровень левого и правого каналов, перетащите центральный ползунок вверх или вниз.

    • Чтобы установить уровень левого канала, перетащите левый ползунок вверх или вниз или введите новое значение в поле уровней в нижней части левого ползунка.

    • Чтобы установить уровень правого канала, перетащите правый ползунок вверх или вниз или введите новое значение в поле уровней в нижней части правого ползунка.

Родительские и дочерние слои

Для синхронизации изменений слоев путем применения преобразований одного слоя к другому слою используйте функцию родительской связи. После того как слой назначен родительским по отношению к другому слою, другой слой становится дочерним. При назначении родительского слоя свойства преобразования дочернего слоя становятся связанными со свойствами родительского слоя, а не композиции. Например, если родительский слой перемещается на 5 пикселей вправо от его начального положения, дочерний слой также перемещается на 5 пикселей вправо от своего положения. Родительская связь подобна группированию; преобразования, примененные к группе, связаны с опорной точкой родительского слоя.

Родительская связь влияет на все свойства преобразования, за исключением непрозрачности: положение, масштаб, поворот и ориентация (для 3D-слоев).

Примечание.

На панели слоя под курсором мыши и на панели «Информация» отображается справочный текст, описывающий изменения в поведении родительских слоев.

Слой может иметь только один родительский слой, при этом слой может быть родительским для любого количества слоев в той же композиции.

Дочерние слои можно анимировать независимо от их родительских слоев. Родительскими можно также назначать нулевые объекты, которые представляют собой скрытые слои.

Нельзя анимировать назначение и удаление родительского слоя, то есть нельзя назначить один слой в качестве родительского в один момент времени, но указать его как обычный слой в другой момент времени.

При создании родительской связи можно указать, наследует ли дочерний слой значения свойств преобразования родительского слоя или сохраняет собственные. При назначении дочернему слою значений свойств преобразования родительского слоя дочерний слой переходит в положение родительского слоя. При сохранении собственных значений свойств преобразования дочерний слой остается на своем месте. В обоих случаях последующие изменения значений свойств преобразования родительского слоя применяются и к дочернему. Аналогичным образом можно выбрать переход дочернего слоя при удалении родительской связи.

Примечание.

При применении к слоям родительских связей для перемещения дочернего слоя на позицию родительского можно использовать клавишу SHIFT. Это полезно, если требуется прикрепить слой к пустому объекту и переместить слой на позицию пустого родительского слоя (например, прикрепить текстовый 3D-слой к пустому слою, созданному с помощью функции 3D Camera Tracker).

Перетаскивание инструмента «Лассо» на панели «Таймлайн»
Перетаскивание инструмента «Лассо» на панели «Таймлайн» со слоя-фигуры 1 (дочерний слой) для обозначения слоя-фигуры 2 как родительского

Примечание.

Чтобы отобразить или скрыть столбец «Родительские» на панели «Таймлайн», выберите «Столбцы» > «Родительские» в меню панели «Таймлайн».

  • Чтобы обозначить слой как родительский, в столбце «Родительские» перетащите инструмент «Лассо» из слоя, который необходимо сделать дочерним, к слою, который требуется назначить родительским.
  • Чтобы обозначить слой как родительский, в столбце «Родительские» откройте меню слоя, который необходимо сделать дочерним, и выберите в меню имя родительского слоя.
  • Чтобы удалить родительскую связь, в столбце «Родительские» откройте меню слоя, из которого требуется удалить такую связь, и выберите «Нет».
  • Чтобы расширить выделенную область для включения всех дочерних слоев выбранного родительского слоя, на панели «Композиция» или панели «Таймлайн» щелкните слой правой кнопкой мыши (Windows) или щелкните слой, удерживая нажатой клавишу CONTROL (Mac OS), и нажмите «Выбрать дочерние слои».
  • Чтобы дочерний слой выполнял переход при назначении или удалении родительского слоя, удерживайте нажатой клавишу ALT (Windows) или OPTION (Mac OS) при назначении или удалении родительского слоя.
  • Чтобы удалить из слоя связь с родительским слоем (то есть установить «Нет» для родительской связи), щелкните на панели «Таймлайн» родительское лассо выбора дочернего слоя, удерживая клавишу CTRL (Windows) или COMMAND (Mac OS). Чтобы удалить из слоя связь с родительским слоем с последующим переходом дочернего слоя, щелкните родительское лассо выбора дочернего слоя, удерживая клавиши ALT+CTRL (Windows) или OPTION+COMMAND (Mac OS).

Ресурсы в Интернете, посвященные родительским и дочерним слоям

Пол Терслей (Paul Tuersley) предлагает на форуме AE Enhancers сценарий для дублирования родительского слоя и всех его дочерних слоев с сохранением родительской иерархии.

Карл Ларсен (Carl Larsen) представляет на веб-сайте Creative COW видеоруководство, которое показывает, как использовать выражения и родительские связи, чтобы связать поворот колес с горизонтальным движением транспортного средства.

Роберт Пауэрс (Robert Powers) опубликовал на веб-сайте Slippery Rock NYC видеоурок, в котором показано использование наследования и инструментов «Марионетка» для анимации персонажа.

Слои нулевых объектов

Чтобы назначить родительский слой, но отключить его видимость в проекте, используйте нулевой объект. Нулевой объект является невидимым слоем, который имеет все свойства видимого слоя и может выполнять функции родительского слоя для любого слоя в композиции. Настройка и анимация нулевого объекта выполняется так же, как для любого другого слоя. Для изменения параметров нулевого объекта используются те же команды, что и для слоя сплошного цвета («Слой» > «Настройка сплошной заливки»).

Примечание.

К нулевым объектам можно применять эффекты элементов управления выражениями, затем нулевой объект можно использовать как контрольный слой для эффектов и анимации в других слоях. Например, при работе со слоем камеры или света создайте слой нулевого объекта и привяжите свойство «Точка обзора» камеры или света со свойством «Положение» нулевого слоя, используя выражение. После этого можно анимировать свойство «Точка обзора» путем перемещения нулевого объекта. Зачастую проще выбрать и просмотреть нулевой объект, чем выбрать и просмотреть точку обзора.

Композиция может содержать любое число нулевых объектов. Нулевой объект отображается только на панели «Композиция» и панели «Слой», на панели «Композиция» он представлен как прямоугольный контур с дескрипторами слоя. Эффекты на нулевых объектах не видны.

  1. Для создания нулевого объекта выберите панель «Таймлайн» или «Композиция» и нажмите «Слой» > «Создать» > «Нулевой объект».

Примечание.

Опорная точка нового слоя нулевого объекта отображается в левом верхнем углу слоя. Слой прикрепляется к центру композиции в его опорной точке. Изменить опорную точку можно так же, как и для любого другого слоя.

Примечание.

Если нулевой объект в фрейме композиции выглядит неорганично, можно перетащить его из фрейма на монтажный стол.

Эндрю Крамер (Andrew Kramer) предлагает на своем веб-сайте Video Copilot видеоруководство по использованию нулевого объекта для анимации 3D-обводки.

Слои направляющих

Слои направляющих создаются из существующих слоев для использования в качестве справки на панели «Композиция» в целях упрощения позиционирования и редактирования элементов. Например, можно использовать слои направляющих для визуальной справки, синхронизации аудио, ссылки на тайм-код или хранения комментариев.

Значок слоя направляющей отображается рядом с именем слоя направляющей или его источника на панели «Таймлайн».

По умолчанию при создании конечного вывода рендеринг слоев направляющих не выполняется, но при необходимости они могут быть визуализированы через изменение параметров рендеринга композиции.

Примечание.

Просмотр слоев направляющих во вложенных композициях невозможен в основной композиции.

  • Для преобразования выделенных слоев в слои направляющих выберите «Слой» > «Слои направляющей».
  • Для рендеринга композиции с видимыми направляющими слоями нажмите «Настройки рендеринга» на панели «Очередь рендеринга» и выберите «Текущие настройки» в меню «Слои направляющих» в диалоговом окне «Настройки рендеринга».
  • Для рендеринга композиции без направляющих слоев нажмите «Настройки рендеринга» на панели «Очередь рендеринга» и выберите «Все выкл.» в меню «Слои направляющих» в диалоговом окне «Настройки рендеринга».

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет