Видео с чересстрочной разверткой и разделение полей

Чересстрочная развертка — это технология, разработанная для передачи телевизионных сигналов с ограниченной пропускной способностью. В системах с чересстрочной разверткой одновременно передается только половина всего количества горизонтальных линий в видеокадре. Из-за скорости передачи, остаточного свечения экрана и инерции зрительного восприятия зритель видит кадры в полном разрешении. Чересстрочная развертка используется во всех аналоговых телевизионных стандартах. Среди цифровых телевизионных стандартов могут быть варианты с чересстрочной разверткой и без чересстрочной развертки. Как правило, чересстрочные сигналы генерируются благодаря технологии чересстрочной развертки, а построчные сигналы — технологии прогрессивной развертки.

Каждый кадр с чересстрочной разверткой состоит из двух полей. В каждом поле находится половина горизонтальных строк кадра; в верхнем поле (или Поле 1) находятся строки с нечетными номерами, а в нижнем поле (или Поле 2) — строки с четными номерами. На экране с чересстрочным видео при отображении кадра сперва рисуются все строки одного поля, а затем все строки второго поля. Какое из полей будет рисоваться первым, определяется порядком полей. В видео формата NTSC новые поля рисуются на экране примерно с частотой 60 раз в секунду, что приблизительно соответствует 30 кадрам в секунду.

Кадры видео с построчным изображением не разделяются на поля. На мониторе с прогрессивной разверткой кадр с построчным видео отображается посредством рисования всех горизонтальных строк сверху вниз за один проход. Почти все компьютерные мониторы работают по принципу прогрессивной развертки, также как и большая часть видеоряда, отображаемого на таких мониторах, имеет построчную развертку.

Таким образом, термины «прогрессивный» и «построчный» имеют близкие значения и часто взаимозаменяемы. Однако прогрессивная развертка относится к процессу записи или рисования строк развертки, которую осуществляет камера или монитор, в то время как построчная развертка подразумевает, что сами видеоданные не разделены на поля.

Чересстрочное сканирование полей чересстрочного видео в сравнении с построчным сканированием кадра построчного видеоизображения
Чересстрочное сканирование полей чересстрочного видео в сравнении с построчным сканированием кадра построчного видеоизображения.

A. В видеоизображении с чересстрочной разверткой за один проход сверху вниз на экране сперва рисуется все верхнее поле (строки с нечетными номерами). B. Затем сверху вниз за один проход на экране рисуется все нижнее поле (строки с четными номерами). C. В видеоизображении с построчной разверткой на экране сверху вниз за один проход рисуется весь кадр (все строки в порядке отсчета). 

Разделение полей видеоизображения

Если в проекте After Effects будет использоваться видео с чересстрочной разверткой (в том числе видео в формате NTSC), при импорте видеоряда наиболее эффективным будет разделить поля видеоизображения. After Effects разделяет поля видеоизображение, создавая для каждого подобного поля целый кадр, в котором сохраняются все данные об изображении, полученные из оригинального видеоряда.

Разделение полей очень важно, если изображение будет претерпевать значительные изменения. При масштабировании, поворотах или применении эффектов в видеоизображении с чересстрочной разверткой часто появляются нежелательные артефакты, такие как перекрещивающиеся поля. При разделении полей After Effects качественно преобразует два кадра с чересстрочной разверткой в кадры с построчной разверткой, сохраняя, при этом, максимально возможное качество изображения. Благодаря кадрам с построчной разверткой After Effects позволяет применять элементы правки и эффекты упорядоченно и в наилучшем качестве.

After Effects создает видеоряд с разделенными полями из одного кадра, в прошлом имевшего чересстрочную развертку, разбивая его на два независимых кадра. Каждый новый кадр содержит только половину данных оригинального кадра, поэтому при просмотре в черновом качестве разрешение некоторых кадров может оказаться хуже, чем в остальных. При рендеринге окончательной композиции в конечном продукте After Effects воспроизводятся высококачественные кадры с чересстрочной разверткой. При рендеринге фильма в максимальном качестве After Effects производит интерполяцию между строками развертки с целью получить наилучшее изображение.

Если конечный продукт не будет иметь чересстрочную развертку, наиболее эффективным будет использовать исходный видеоряд с построчной разверткой, благодаря чему необходимость в разделении полей исчезнет. Если версия с построчной разверткой недоступна, достаточно воспользоваться видеорядом с чересстрочной разверткой.

При работе с видеорядом, имеющим чересстрочную развертку, всегда разделяйте поля. Никогда разделяйте поля при работе с элементами видеоряда, имеющем построчную развертку.

Преобразование можно удалить только после разделения полей.

При рендеринге композиции с раздельным видеорядом, имеющим разделенные поля, установите параметр «Рендеринг полей» на значение порядка полей, соответствующее используемой видеоаппаратуре. Если рендеринг композиции выполняется без разделения полей или с разделением полей, но с неверными параметрами, окончательный вариант фильма может оказаться слишком неярким, с подергиваниями или искажениями.

Примечание.

Чтобы быстрее придать видеоряду вид готового фильма можно импортировать его дважды и интерпретировать каждый элемент видеоряда, используя различный порядок полей. Затем оба варианта следует включить в одну и ту же композицию и совместить. Неправильно интерпретированный слой придает изображению незначительный эффект размытости.

При работе с элементами видеоряда в форматах D1 или DV, After Effects разделяет поля автоматически. Можно вручную разделить поля для всех других типов видеоряда в диалоговом окне «Интерпретировать видеоряд».

  1. Выделите элемент видеоряда на панели «Проект».

  2. Выберите «Файл» > «Интерпретировать видеоряд» > «Основной».

  3. В меню «Разделить поля» выберите параметр.

  4. Чтобы повысить качество изображения в неподвижных областях при рендеринге изображениям в самом высоком качестве, щелкните «Сохранить края (только максимальное качество)». Затем нажмите кнопку «ОК».

Примечание.

Если настройки полей для входящего видеоряда в диалоговом окне «Интерпретировать видеоряд» и настройки полей для устройства вывода в диалоговом окне «Настройки ренденринга» верны, можно смешивать элементы видеоряда с различным порядком полей внутри композиции. Если какая-либо из этих настроек неверна, кадры все равно будут располагаться в правильном порядке, но порядок полей может быть обратным. Из-за этого изображение будет прерывистыми и непригодными для просмотра.

Определение первоначального порядка расположения полей

Порядок расположения полей в видео с чересстрочной разверткой задает порядок, в котором будут отображаться два поля видео (верхнее и нижнее). Система, в которой верхние строки рисуются перед нижними, называется «Верхнее поле первое»; система, в которой нижние строки рисуются перед верхними — «Нижнее поле первое». Многие форматы со стандартным разрешением (например, DV NTSC) работают по принципу «Нижнее поле первое», а форматы высокой четкости (например, DVCPRO HD 1080i) — по принципу «Верхнее поле первое».

Порядок, в котором отображаются поля, особенно важен, если в полях есть движущиеся объекты. Если разделить поля видеоизображения в неправильном порядке, движение в изображении будет неровным.

Некоторые программы, включая After Effects, при рендеринге файлов видео с чересстрочной разверткой помечают порядок расположения полей. При импорте файла видео с пометками After Effects автоматически учитывает метки порядка расположения полей. Данный порядок расположения полей можно заменить на другой, применив иные настройки интерпретации видеоряда.

Если файл не содержит метку порядка расположения полей, можно сымитировать изначальный порядок, существующий в видеоряде. Чтобы узнать, какой порядок расположения полей использовался для чересстрочной развертки элемента видеоряда, воспользуйтесь описанной ниже процедурой.

  1. Выделите элемент на панели «Проект».

  2. Выберите «Файл» > «Интерпретировать видеоряд» > «Основной».

  3. В диалоговом окне «Интерпретировать видеоряд» в меню «Разделить поля» выберите «Верхнее поле первое» и нажмите кнопку «ОК».

  4. На панели «Проект» дважды щелкните элемент видеоряда, удерживая нажатой клавишу ALT (Windows) или OPTION (Mac OS). Элемент откроется на панели «Видеоряд».

  5. Если панель предпросмотра не видна, выберите «Окно» > «Предпросмотр».

  6. На панели «Видеоряд» найдите сегмент, в котором есть одна или более движущихся областей.

  7. С помощью кнопки «Следующий кадр» на панели «Предпросмотр» переместитесь как минимум на пять кадров вперед на панели «Видеоряд». Движущиеся области теперь должны упорядоченно перемещаться в одном направлении. Если движущиеся области на каждом последующем кадре перемещаются назад, значит к видеоряду применен неверный параметр разделения полей.

Ресурсы в Интернете, посвященные полям и видео с чересстрочной разверткой

На своем веб-сайте Lurker's Guide to Video Крис Пирацци (Chris Pirazzi) дает подробное техническое описание полей и процесса чересстрочной развертки.

Триш и Крис Мейер (Trish и Chris Meyer) предлагают серию материалов по чересстрочной развертке, порядку расположения полей, доминированию полей, рендерингу и разделению полей.

  • статья, рассказывающая о чересстрочной развертке и порядке полей на сайте ProVideo Coalition

Удаление преобразований 3:2 или 24Pa из видео

При преобразовании пленки с частотой кадров 24 кадр/с в видео с частотой кадров 29.97 кадр/с используется процесс, который называется «преобразование 3:2», во время которого кадры распределяются по полям видеозаписи по схеме 3:2. Первый кадр пленки копируется в поля 1 и 2 из первого кадра видео, а также в поле 1 второго кадра. Второй кадр пленки затем располагается на двух следующих полях видео — поле 2 второго видеокадра и поле 1 третьего кадра. Такая схема 3:2 повторяется до тех пор, пока четыре кадра пленки не будут размещены в пяти кадрах видео, после чего схема повторяется снова.

В результате преобразования 3:2 получаются целые кадры (обозначены как W) и кадры с разделенными полями (обозначены как S). Три полных кадра видео содержат два поля из того же самого кадра пленки. Оставшиеся два кадра с разделенными полями содержат кадр видео из двух других кадров пленки. Два кадра с разделенными полями всегда являются соседними. Фазой преобразования 3:2 называется точка, в которой два кадра с разделенными полями совпадают с первыми пятью кадрами видеоряда.

Фаза является результатом двух типов преобразований 3:2: пленка с частотой кадров 24 кадр/с перераспределяется внутри видео с частотой кадров 30 кадр/с, так что каждые четыре кадра оригинальной пленки распределяются по пяти кадрам получаемой видеозаписи с частотой кадров 30 (29,97) кадр/с. Во-первых, с целью синхронизировать скорости воспроизведения пленка замедляется на 0,1 %. Затем все кадры пленки по определенной схеме повторяются и распределяются по полям видеозаписи.

Удаление преобразований 3:2 или 24Pa из видео
При применении к видеоряду преобразования 3:2 один кадр пленки (А) разделяется на два или три чередующихся поля видеозаписи (B), которые группируются в кадры видео, имеющие по 2 поля каждый.

При импорте видео с чересстрочной разверткой, первоначально снятого на пленку, можно очистить результаты преобразования 3:2, которое пришлось выполнить при изменении формата пленки на формат видео. Благодаря этому эффекты, будут применяться в After Effects, не будут иметь искажений.

Рекомендуется обязательно удалить результаты преобразования 3:2 из видеоряда, который был изначально отснят на пленку. Это позволит идеально синхронизировать эффекты, используемые в After Effects, с частотой кадров оригинальной пленки. Вследствие удаления результатов преобразования 3:2 частота кадров уменьшается на 1/5, т. е. с 30 до 24 кадр/с или с 29,97 до 23,976 кадр/с. Одновременно с этим уменьшается количество кадров, которые придется изменять. Чтобы удалить результаты преобразования 3:2, необходимо также указать фазу этого преобразования.

After Effects также поддерживает преобразование материала формата Panasonic DVX100 24p DV, которое называется 24P DV Advance (24Pa). Некоторые камеры использующие этот формат для захвата изображений с частотой передачи кадров 23,976 и прогрессивной разверткой посредством стандартных пленок формата DV.

Прежде чем удалить преобразование 3:2 разделите поля по принципу «Верхнее поле первое» или «Нижнее поле первое». После разделения полей After Effects позволяет проанализировать видеоряд, точно определить фазу преобразования 3:2 и порядок расположения полей. Если фаза и порядок расположения полей известны, выберите их в меню «Разделить поля» и «Удалить» в диалоговом окне «Интерпретировать видеоряд».

  1. На панели «Проект» выберите элемент видеоряда, из которого требуется удалить результат преобразования 3:2.
  2. Выберите «Файл» > «Интерпретировать видеоряд» > «Основной».
  3. В разделе «Поля и преобразование» в меню «Разделить поля» выберите «Верхнее поле первое» или «Нижнее поле первое».
  4. Выполните одно из предложенных ниже действий и нажмите кнопку «ОК».
    • Если фаза преобразования 3:2 или 24Pa известна, выберите её в меню «Удалить».

    • Чтобы After Effects правильно определил параметры, щелкните «Примерный расчет преобразования 3:2» или «Примерный расчет преобразования 24Pa».

    Примечание.

    Если файл видеоряда содержит кадры из других источников, фазы могут не совпасть. В этом случае видеоряд следует импортировать несколько раз — по одному разу на каждую фазу — и интерпретировать каждый элемент видеоряда с его собственной настройкой. Затем следует добавить каждый элемент видеоряда в композицию и обрезать каждый слой так, чтобы в нем оставались только необходимые кадры. Другими словами, если имеется материал с несколькими фазами преобразования, его необходимо поделить на отрезки и отдельно удалить результаты преобразования для каждого из этих отрезков. Такое происходит в случаях, когда в качестве материала выступает фильм, который редактировался одновременно из нескольких источников в NLE.

Импорт ресурсов в формате Panasonic P2

Карта P2 представляет собой устройство хранения данных в виде твердого носителя, который вставляется в слот PCMCIA видеокамеры Panasonic P2. Цифровое видео и аудио с видеокамеры записывается на карту в виде структурированного и независимого от кодеков формата, известного под названием MXF (Media eXchange Format). В частности, Adobe Premiere Pro и After Effects поддерживают вариант Panasonic Op-Atom формата MXF с видео в форматах AVC-Intra 50, AVC-Intra 100, DV, DVCPRO, DVCPRO50 и DVCPRO HD. Наличие аудио и видео в виде содержимого файлов Panasonic Op-Atom MXF и расположение этих файлов в папках, структурированных определенным образом говорит о том, что клип имеет формат P2.

Корневым каталогом структуры папки P2 является папка CONTENTS. Каждый элемент основного содержимого (т. е. видео или аудио) содержится в отдельном файле-оболочке MXF; файлы видео MXF находятся в подпапке VIDEO, а файлы аудио MXF — в подпапке AUDIO. Связь между файлами с основным содержимым и их метаданными отслеживается файлами XML в подпапке CLIP.

Примечание.

Adobe Premiere Pro и After Effects не поддерживают прокси, записанные с помощью видеокамер Panasonic P2 на карту P2 в папки PROXY.

Видео и аудио на карте P2 уже имеют цифровой формат, т. е. карта P2 служит аналогом жесткого диска. Поэтому при импортировании данных мультимедиа с карты P2 операция захвата данных не требуется. Процесс прочтения данных с карты и их преобразования в формат, который может быть использован в проекте, иногда называется вставкой.

Чтобы компьютер смог выполнить чтение карт P2, требуется установка соответствующего драйвера, который можно загрузить на веб-сайте Panasonic. Panasonic также предоставляет приложение P2 Viewer, с помощью которого можно просматривать и воспроизводить медиаданные, сохраненные на карте P2.

Поскольку карты Panasonic P2 имеют файловую систему FAT32, размер каждого файла ограничен до 4 ГБ. При записи фрагмента, превышающего 4 ГБ, камера P2 создает другой файл и продолжает запись фрагмента в новый файл (без остановки). Так как фрагмент размещается в нескольких файлах или клипах, эта операция называется объединением клипов. Аналогичным образом, камера может объединять части фрагмента, находящиеся на разных картах P2. Если в камере установлено более двух карт, фрагмент будет записываться до того, как свободное пространство на карте закончится, а затем на следующей карте будет создан новый файл, куда и будет записываться оставшаяся часть фрагмента. Хотя один фрагмент может быть записан в виде группы из нескольких объединенных клипов, в приложении для редактирования видео эти несколько файлов будут восприниматься как один клип или элемент видеоряда. Чтобы After Effects автоматически импортировал целые группы объединенных клипов и собирал их в один элемент видеоряда, они все должны быть записаны на одну карту P2. При этом ни один из файлов не должен отсутствовать, в том числе сопровождающий их файл метаданных XML.

  1. (Необязательно) Скопируйте все содержимое карты P2 на жесткий диск.

    Можно импортировать материал в Adobe Premiere Pro и After Effects прямо с карты P2, однако более целесообразно перед импортом данных скопировать содержимое карты на жесткий диск.

  2. Выберите «Файл» > «Импорт».
  3. Перейдите к папке CONTENTS.
  4. Выберите один или несколько файлов MXF.
    • Чтобы импортировать элемент с основным видеосодержимым и соответствующие элементы с аудиосодрежимым, в папке VIDEO выделите файлы MXF.

    • Чтобы импортировать только элементы с аудиосодержимым, в папке AUDIO выделите файлы MXF.

    • Чтобы импортировать группу сцепленных клипов, записанных на одной карте P2, в папке VIDEO выберите один из файлов MXF, входящих в группу. Группа будет импортирована как один элемент видеоряда, а продолжительность видео будет равна суммарной продолжительности входящих в неё сцепленных клипов. Если выбрать несколько сцепленных клипов, будут импортированы копии всей группы сцепленных клипов, которые отобразятся на панели «Проект» в виде дубликатов элементов видеоряда.

    Вы не можете импортировать сцепленные клипы из фрагмента, который представлен одним элементом видеоряда, но располагается на двух разных картах. Вместо этого на обеих картах вам следует выбрать один файл MXF, принадлежащий фрагменту, и создать отдельный элемент видеоряда для части фрагмента, записанного на каждой карте. Например, если группа, состоящая из сцепленных клипов одного и того же фрагмента, располагается на двух картах, вы должны выбрать один сцепленный клип из группы на карте №1 и еще одни — из группы на карте №2. Это позволяет импортировать содержимое фрагмента в два элемента видеоряда, отображаемые на панели «Проект».

В столбце «Дата» на панели «Проект» указывается, когда был вставлен клип. После импорта сцепленных клипов с помощью даты можно определить их правильный хронологический порядок внутри фрагмента.

Примечание.

After Effects не позволяет осуществлять прямой экспорт в формат P2. Для рендеринга и экспорта в формат P2 используйте Adobe Media Encoder или Premiere Pro.

Дополнительные сведения о формате Panasonic P2 и порядке работы с видеоприложениями Adobe можно найти на веб-сайте компании Adobe:

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет