Руководство пользователя Отмена

Камеры, освещение и точки обзора

  1. Руководство пользователя After Effects
  2. Выпуски бета-версии
    1. Обзор программы бета-тестирования
    2. Домашняя страница бета-версии After Effects
  3. Начало работы
    1. Начало работы с After Effects
    2. Новые возможности After Effects 
    3. Сведения о выпуске | After Effects
    4. Системные требования для After Effects
    5. Сочетания клавиш в After Effects
    6. Поддерживаемые форматы файлов | After Effects
    7. Рекомендации по аппаратному обеспечению
    8. After Effects для компьютеров с процессорами Apple
    9. Планирование и настройка
  4. Рабочие среды
    1. Общие элементы пользовательского интерфейса
    2. Знакомство с интерфейсом After Effects
    3. Рабочие процессы
    4. Рабочие среды, панели управления, программы просмотра
  5. Проекты и композиции
    1. Проекты
    2. Основы создания композиции
    3. Предварительная композиция, вложение и предварительный рендеринг
    4. Просмотр подробных сведений о производительности с помощью инструмента «Профайлер композиций»
    5. Модуль рендеринга композиций CINEMA 4D
  6. Импорт видеоряда
    1. Подготовка и импорт неподвижных изображений
    2. Импорт из After Effects и Adobe Premiere Pro
    3. Импорт и интерпретация видео и аудио
    4. Подготовка и импорт файлов 3D-изображений
    5. Импорт и интерпретация элементов видеоряда
    6. Работа с элементами видеоряда
    7. Определение точек редактирования с помощью функции «Определение изменения сцен»
    8. Метаданные XMP
  7. Текст и графические элементы
    1. Текст
      1. Форматирование символов и панель символов
      2. Эффекты текста
      3. Создание и редактирование текстовых слоев
      4. Форматирование абзацев и панель «Абзац»
      5. Экструзия слоев текста и слоев-фигур
      6. Анимация текста
      7. Примеры и ресурсы для текстовой анимации
      8. Шаблоны динамического текста
    2. Анимационный дизайн
      1. Работа с шаблонами анимационного дизайна в After Effects
      2. Использование выражений для создания раскрывающихся списков в шаблонах анимационного дизайна
      3. Работа с основными свойствами для создания шаблонов анимационного дизайна
      4. Замена изображений и видео в шаблонах анимационного дизайна и основных свойствах
      5. Быстрая и простая анимация с помощью панели «Свойства»
  8. Рисование, заливка цветом и контуры
    1. Обзор слоев-фигур, контуров и векторных изображений
    2. Инструменты рисования: «Кисть», «Штамп» и «Ластик»
    3. Сглаживание обводки фигуры
    4. Атрибуты фигур, операции заливки цветом и операции с контурами для слоев-фигур
    5. Использование эффекта фигуры «Cмещение контура» для изменения фигур
    6. Создание фигур
    7. Создание масок
    8. Удаление объектов из видеоматериалов с помощью панели «Заливка с учетом содержимого»
    9. Инструменты «Кисть для ротоскопии» и «Уточнить подложку»
  9. Слои, маркеры и камера
    1. Выделение и упорядочивание слоев
    2. Режимы наложения и стили слоев
    3. 3D-слои
    4. Свойства слоя
    5. Создание слоев
    6. Управление слоями
    7. Маркеры слоя и маркеры композиции
    8. Камеры, освещение и точки обзора
  10. Анимация, ключевые кадры, отслеживание движения и прозрачное наложение
    1. Анимация
      1. Основы анимации
      2. Анимация с помощью инструментов «Марионетка»
      3. Управление и анимация контуров фигур и масок
      4. Анимация фигур Sketch и Capture с помощью After Effects
      5. Инструменты анимации
      6. Работа с анимацией на основе данных
    2. Ключевой кадр
      1. Интерполяция ключевого кадра
      2. Установка, выбор и удаление ключевых кадров
      3. Редактирование, перемещение и копирование ключевых кадров
    3. Отслеживание движения
      1. Отслеживание и стабилизация движения
      2. Отслеживание лиц
      3. Отслеживание маски
      4. Ссылка на маску
      5. Скорость
      6. Растягивание по времени и перераспределение времени
      7. Тайм-код и единицы отображения времени
    4. Прозрачное наложение
      1. Прозрачное наложение
      2. Эффекты прозрачного наложения
  11. Прозрачность и композиция
    1. Обзор композиции и прозрачности и соответствующие ресурсы
    2. Альфа-каналы и маски
    3. Подложки дорожек и перемещающиеся подложки
  12. Корректирование цвета
    1. Основы работы с цветом
    2. Управление цветом
    3. Эффекты цветокоррекции
    4. Управление цветом OpenColorIO и ACES
  13. Эффекты и стили анимации
    1. Обзор эффектов и стилей анимации
    2. Список эффектов
    3. Диспетчер эффектов
    4. Эффекты имитации
    5. Эффекты стилизации
    6. Аудиоэффекты
    7. Эффекты искажения
    8. Эффекты перспективы
    9. Эффекты канала
    10. Эффекты создания
    11. Эффекты перехода
    12. Эффект «Устранение эффекта плавающего затвора»
    13. Эффекты «Размытие» и «Резкость»
    14. Эффекты 3D-канала
    15. Программные эффекты
    16. Эффекты подложки
    17. Эффекты «Шум» и «Зернистость»
    18. Эффект «Увеличение с сохранением уровня детализации»
    19. Устаревшие эффекты
  14. Выражения и автоматизация
    1. Выражения
      1. Основы работы с выражениями
      2. Понимание языка выражений
      3. Использование элементов управления выражениями
      4. Различия в синтаксисе между движками выражений JavaScript и Legacy ExtendScript
      5. Управление выражениями
      6. Ошибки выражения
      7. Использование редактора выражений
      8. Использование выражений для изменения свойств текста и доступа к ним
      9. Справочник языка выражений
      10. Примеры выражений
    2. Автоматизация
      1. Автоматизация
      2. Сценарии
  15. Видео с погружением, VR и 3D
    1. Создание сред VR в After Effects
    2. Применение видеоэффектов с эффектом погружения
    3. Инструменты составления композиций для видеоизображений VR/360
    4. Модуль рендеринга Advanced 3D
    5. Импорт и добавление 3D-моделей в композицию
    6. Импорт 3D-моделей из Creative Cloud Libraries
    7. Освещение на основе изображения
    8. Извлечение и анимация источников света и камер из 3D-моделей
    9. Отслеживание движений камеры в трехмерном пространстве
    10. Отбрасывание и принятие теней
    11. Встроенные анимации 3D-моделей
    12. Ограничитель тени
    13. Извлечение 3D-данных о глубине
    14. Изменение свойств материалов 3D-слоя
    15. Пространство для работы с трехмерными объектами
    16. Инструменты 3D-преобразования
    17. Дополнительные возможности 3D-анимации
    18. Предварительный просмотр изменений в 3D-дизайнах в режиме реального времени с помощью модуля Mercury 3D
    19. Добавление гибкого дизайна в графику 
  16. Виды и предварительный просмотр
    1. Предпросмотр
    2. Предпросмотр видео с помощью Mercury Transmit
    3. Изменение и использование представлений
  17. Рендеринг и экспорт
    1. Основы рендеринга и экспорта
    2. Кодирование H.264 в After Effects
    3. Экспорт проекта After Effects как проекта Adobe Premiere Pro
    4. Преобразование фильмов
    5. Многокадровый рендеринг
    6. Автоматический рендеринг и рендеринг по сети
    7. Рендеринг и экспорт неподвижных изображений и наборов неподвижных изображений
    8. Использование кодека GoPro CineForm в After Effects
  18. Работа с другими приложениями
    1. Dynamic Link и After Effects
    2. Работа с After Effects и другими приложениями
    3. Синхронизация настроек в After Effects
    4. Библиотеки Creative Cloud Libraries в After Effects
    5. Подключаемые модули
    6. Cinema 4D и Cineware
  19. Совместная работа: Frame.io и Team Projects
    1. Совместная работа в Premiere Pro и After Effects
    2. Frame.io
      1. Установка и активация Frame.io
      2. Использование Frame.io с Premiere Pro и After Effects
      3. Часто задаваемые вопросы
    3. Team Projects
      1. Начало работы с Team Projects
      2. Создание Team Project
      3. Совместная работа с помощью Team Projects
  20. Память, хранилище, производительность
    1. Память и хранилище
    2. Как After Effects справляется с проблемами нехватки памяти при предварительном просмотре    
    3. Повышение производительности
    4. Установки
    5. Требования к графическому процессору и драйверу графического процессора для After Effects
  21. База знаний
    1. Выявленные неполадки
    2. Исправленные ошибки
    3. Часто задаваемые вопросы
    4. After Effects и macOS Ventura
    5. Как After Effects справляется с проблемами нехватки памяти при предварительном просмотре

Создание слоя камеры и изменение настроек камеры

3D-слои можно просматривать с любого угла и расстояния с помощью слоев камеры. Так же, как и в реальном мире, проще перемещать камеру вокруг сцены, чем перемещать и поворачивать сцену, часто наиболее простым способом получить различные ракурсы композиции является создание слоя камеры и перемещение его вокруг композиции.

Можно изменять и анимировать настройки камеры для конфигурации камеры в соответствии с существующей камерой и параметрами, используемыми для записи видеоряда композиции. Можно также использовать настройки камеры для имитации функций камеры — от размытия глубины поля до панорамирования и от получения кадров, снятых при наезде или отъезде камеры, до синтетических эффектов и анимации.

Камеры воздействуют только на 3D- и 2D-слои с эффектом, имеющим атрибут «Камера композиции». Эффекты с атрибутом «Камера композиции» позволяют использовать активную камеру композиции или источники света для просмотра или освещения эффекта с разных углов с целью имитации более сложных трехмерных эффектов.

Можно просмотреть композицию через активную или пользовательскую камеру. Активная камера является самой верхней камерой на панели Временная шкала, для которой в текущее время выбран переключатель Видео. Представлением активной камеры является точка обзора, используемая для создания конечного вывода и вложения композиций. Если пользовательская камера не создавалась, активная камера совпадает с видом композиции по умолчанию.

Все камеры перечислены и доступны в меню 3D-вид в нижней части панели Композиция.

Зачастую проще всего настроить камеру, используя один из пользовательских 3D-видов. Нельзя увидеть камеру и манипулировать ею, если смотреть через нее.

Пример камеры
Пример камеры

A. Точка обзора B. Кадр C. Камера 

Создание слоя камеры

  1. Выберите Слой > Создать > Камера или нажмите CTRL+ALT+SHIFT+C (Windows) или COMMAND+OPTION+SHIFT+C (macOS).

    Примечание.

    По умолчанию новые слои начинаются в начале композиции. Можно настроить приложение так, чтобы новые слои начинались в текущее время. Для этого необходимо отключить параметр Создать слои во времени начала композиции (Правка > Установки > Общие (Windows) или After Effects > Установки > Общие (macOS)).

Изменение параметров камеры

Можно в любой момент изменить настройки камеры.

  1. Дважды щелкните значок камеры на панели Временная шкала или выделите слой и выберите Слой > Настройки камеры.

Примечание.

По умолчанию параметр Предпросмотр выбран в диалоговом окне Настройки камеры. Этот параметр позволяет отображать изменения в композиции по мере их внесения в диалоговое окно Настройки камеры.

Также можно выбрать слой Камера и использовать панель Свойства для быстрого доступа и настройки параметров камеры, а также работы с преобразованиями слоя.

На панели «Свойства» отображаются «Преобразование слоя» и «Параметры камеры» выбранного слоя камеры. Существует несколько вариантов указания преобразований слоя и настроек камеры.
«Преобразование слоя» и «Параметры камеры» на панели «Свойства» при выборе слоя камеры в композиции с использованием модуля рендеринга Classic 3D.

Настройки камеры

Тип

Выберите или Одноузловая камера, или Двухузловая камера. Одноузловая камера ориентируется вокруг себя, а двухузловая камера имеет точку обзора и ориентируется вокруг этой точки. Установка камеры как двухузловой аналогична установке для камеры параметра автоориентации (Слой > Преобразовать > Автоориентация) Ориентировать в направлении точки обзора.

Имя

Имя камеры. По умолчанию Камера 1 — имя первой камеры, созданной в композиции. Любые последующие камеры нумеруются в порядке возрастания. Для удобства различения нескольких камер выбирайте для них разные имена.

Шаблон настроек

Тип параметров камеры, который необходимо использовать. Шаблоны настроек называются на основе фокусного расстояния пленки. Предполагается, что каждый шаблон имитирует поведение камеры 35 мм с объективом, имеющим определенное расстояние фокусировки. Поэтому шаблон настроек также устанавливает значения параметров Угол обзора, Масштаб, Фокусное расстояние, Расстояние фокусировки и Диафрагма. Шаблон настроек по умолчанию: 50 мм. Можно также создать пользовательскую камеру, указав новые значения для любого параметра.

Масштаб

Расстояние от объектива до плоскости изображения. Другими словами, слой, который находится на расстоянии Масштаба отображается в полном размере, слой, который находится на двойном расстоянии Масштаба, отображается в половину его высоты и ширины, и т. д.

Угол обзора

Ширина сцены в изображении. Угол обзора определяют значения параметров «Фокусное расстояние», «Размер пленки» и «Масштаб». Более широкий угол обзора создает тот же эффект, что и широкоугольный объектив.

Глубина поля

Применяет пользовательские настройки для Фокусного расстояния, Диафрагмы, Светосилы и Уровня размытия. С помощью этих переменных можно управлять глубиной поля для создания более реалистичных эффектов фокусировки камеры. (Глубина поля — расстояние, в пределах которого изображение находится в фокусе. Изображения за пределами этого расстояния являются размытыми).

Фокусное расстояние

Расстояние от камеры до плоскости, которая находится в идеальном фокусе.

Совет.

Для привязки фокальной плоскости к точке обзора камеры таким образом, чтобы точка обзора находилась в фокусе, добавьте следующее выражение к свойству Фокусное расстояние: length(position, pointOfInterest)

Зафиксировать для масштабирования

Делает значение параметра Фокусное расстояние равным значению параметра Масштаб.

Примечание.

Если изменить параметры Масштаб или Фокусное расстояние на панели Временная шкала, то значение Фокусное расстояние больше не будет привязано к значению Масштаб. Если требуется изменить значения и сохранить их связь, используйте диалоговое окно Настройки камеры вместо панели Временная шкала. В качестве альтернативы можно добавить выражение к свойству Фокусное расстояние на панели Временная шкала; выберите свойство Фокусное расстояние и нажмите Анимация > Добавить выражение, затем перетащите лассо выражения к свойству Масштаб.

Диафрагма

Степень раскрытия диафрагмы объектива. Параметр Диафрагма также влияет на глубину поля — увеличение диафрагмы увеличивает размытие глубины поля. При изменении параметра «Диафрагма» значение Светосила изменяется в соответствии с ним.

Примечание.

В реальной камере увеличение диафрагмы также приводит к увеличению освещения, что влияет на экспозицию. Как и большинство приложений 3D-композиции и анимации After Effects игнорирует этот результат изменения значения диафрагмы.

Светосила

Представляет собой соотношение фокусного расстояния пленки к диафрагме. Большинство камер определяют размер диафрагмы с помощью измерения светосилы; поэтому многие фотографы предпочитают устанавливать размер диафрагмы в единицах светосилы. При изменении значения параметра «Светосила» значение параметра «Диафрагма» изменяется в соответствии с ним.

Уровень размытия

Степень размытия глубины поля в изображении. Значение 100 % создает естественное размытие в соответствии с установленными параметрами камеры. Более низкие значения уменьшают размытие.

Размер пленки

Размер открытой области пленки, который непосредственно относится к размеру композиции. При изменении Размера пленки значение Масштаба изменяется в соответствии с перспективой реальной камеры.

Фокусное расстояние

Расстояние от плоскости пленки до объектива камеры. В After Effects положение камеры является центром объектива. При изменении параметра Расстояние фокусировки значение Масштаб изменяется в соответствии с перспективой реальной камеры. Кроме того соответственно изменяются значения Стиль, Угол обзора и Диафрагма.

Единицы

Единицы измерения, в которых выражаются значения параметров камеры.

Измерить размер пленки

Размеры, используемые для отображения размера пленки.

Команды камеры

В After Effects предусмотрены команды камеры, которые можно использовать отдельно или с функцией Создать оснастку "Stereo 3D". Для использования команд камеры, выделите слой камеры, а затем выберите Слой > Камера.

Привязать фокусное расстояние к точке обзора

Создает выражение в свойстве Фокусное расстояние выбранного слоя камеры, привязывая значения свойства к расстоянию между камерой и точкой обзора.

Привязать фокусное расстояние к слою

Создает выражение в свойстве Фокусное расстояние выбранного слоя камеры, определяя расстояние между положением камеры и другим слоем. Этот метод позволяет фокусу автоматически следовать за другим слоем.

Задать фокусное расстояние для слоя

Задает текущее значение свойства Фокусное расстояние, определяя расстояние между камерой и выделенным слоем.

Создание источника света и изменение настроек освещения

Слой источника света может влиять на цвета 3D-слоев, которые он освещает, в зависимости от настроек освещения и свойств Параметры материала 3D-слоя. Каждый источник света по умолчанию направлен на его точку обзора.

Освещение можно использовать для иллюминации 3D-слоев и создания теней. Можно использовать свет для создания условий освещения сцены, на которую накладывается изображение, или для создания более интересных визуальных эффектов. Например, можно использовать слои освещения, чтобы создать впечатление потока света, проходящего через слой видео, как если бы он был сделан из цветного витражного стекла.

Можно применить анимацию ко всем параметрам освещения, за исключением типа освещения и свойства Отбрасывает тени.

Типы освещения: прожектор (вверху слева); точечное (вверху справа); параллельное (внизу слева); окружающее (внизу справа)
Типы освещения: прожектор (вверху слева); точечное (вверху справа); параллельное (внизу слева); окружающее (внизу справа)

A. Точка обзора B. Значок освещения 

Можно указать, какие 3D-слои затрагивает источник света, указав источник света в качестве корректирующего слоя. Поместите источник света на панель Временная шкала над слоями, на которые он будет направлен. Слои, которые находятся над корректирующим слоем освещения в порядке расположения слоев на панели Временная шкала, не получают свет, независимо от положения слоев на панели Композиция.

Создание освещения

  1. Выберите Слой > Создать > Освещение или нажмите CTRL+ALT+SHIFT+L (Windows) или COMMAND+OPTION+SHIFT+L (macOS).

    Созданное освещение включает в себя название его типа. Так, при добавлении направленного источника света ему присваивается название Направленный источник света 1.

    При изменении типа освещения название типа освещения изменяется автоматически. Название освещения изменяется только в том случае, если на панели Временная шкала название и тип освещения не были изменены. Например, при изменении названия Направленный свет 1 на точечный свет, After Effects автоматически выполняет переименование источника света в Точечный свет 1.

Изменение настроек освещения

  1. Дважды щелкните слой освещения на панели Временная шкала или выделите слой и выберите Слой > Настройки освещения.

    Примечание.

    В диалоговом окне Настройки освещения выберите Предпросмотр для отображения результатов изменения параметров этого диалогового окна на панели Композиция.

Также можно выбрать слой Освещение слой и использовать панель Свойства для быстрого доступа и настройки параметров освещения, а также работы с преобразованиями слоя.

На панели «Свойства» отображаются параметры «Преобразование слоя» и «Параметры освещения» выбранного слоя освещения. Есть несколько вариантов указания преобразований слоев и настроек освещения.
Используйте «Преобразование слоя» и «Параметры освещения» на панели «Свойства», чтобы работать с выбранным слоем «Освещение».

Настройки освещения

Тип освещения

Параллельное освещение создает направленный естественный свет из бесконечно удаленного источника, моделируя солнечный свет. Прожектор генерирует свет из источника конической формы, например фонаря или прожектора, используемых в сценических постановках. Точечное освещение создает естественный ненаправленный свет, похожий на лучи обычной лампочки. Окружающее освещение создает свет, у которого нет источника. Вместо этого оно повышает общую яркость сцены и не приводит к созданию теней. Среда создает реалистичное освещение, отражения и тени, используя карту среды на основе изображения.

Примечание.

Так как положение Окружающего освещения в пространстве не затрагивает его влияние на другие слои, у него нет значка на панели Композиция.

Цвет

Цвет освещения.

Интенсивность

Яркость освещения. Отрицательные значения создают «антиосвещение». Антиосвещение вычитает цвет из слоя. Если слой уже освещен, создание прямого света с отрицательными значениями, направленного на этот слой, затемняет область слоя.

Угол конуса

Угол конуса, окружающего источник света, который определяет ширину луча на расстоянии. Этот элемент управления активен, только если в качестве Типа освещения выбран Прожектор. Угол конуса света прожектора показывается формой значка освещения на панели Композиция.

Примечание.

В After Effects CS6 или более поздних версиях выбранный угол конуса прожектора можно расширить к точке обзора.

Растушевка конуса

Мягкость краев луча прожектора. Этот элемент управления активен, только если в качестве Типа освещения выбран Прожектор.

Спад

Тип рассеивания света для параллельного, направленного или точечного освещения. Спад определяет уменьшение интенсивности света на расстоянии.

Существуют следующие типы Cпада.

  • Нет. Освещение не уменьшается по мере того, как расстояние между слоем и источником света увеличивается.
  • Плавно. Обозначает плавный линейный спад, которое начинается в радиусе «Начала спада» и распространяется на расстояние, определяемое Расстоянием спада.
  • Обратные квадраты с фиксацией. Обозначает физически точный спад, начинающийся в радиусе Начала спада и уменьшающийся обратно пропорционально квадрату расстояния.

Радиус

Указывает радиус рассеивания света. В пределах этого расстояния освещение является постоянным. За пределами этого расстояния свет рассеивается.

Расстояние спада

Определяет расстояние рассеивания света, исходящего от источника.

Отбрасывает тени

Определяет, отбрасывает ли слой тень при попадании на него света от источника освещения. При Включении параметра материала Принимает тени слой принимает тень; этот параметр задан по умолчанию. При Включении параметра материала Отбрасывает тени слой отбрасывает тень; этот параметр не является параметром по умолчанию.

Примечание.

Нажмите ALT+SHIFT+C (Windows) или OPTION+SHIFT+C (macOS) для включения/выключения параметра Отбрасывает тени для выделенных слоев. Нажмите AA для отображения свойств Параметры материала на панели Временная шкала.

Темнота тени

Определяет степень затемнения тени. Этот элемент управления активен при выборе параметра Отбрасывает тени.

Диффузия тени

Задает мягкость тени на основе ее расстояния от слоя теней. Большие значения создают более мягкие тени. Этот элемент управления активен при выборе параметра Отбрасывает тени.

Настройка 3D-вида либо перемещение камеры, источника света или точки обзора

Слои камеры и света включают свойство Точка обзора, определяющее точку в композиции, на которую направлены камера или свет. По умолчанию точка обзора находится в центре композиции. Точку обзора можно переместить в любое время.

Одноузловая камера игнорирует точку обзора. Подробнее о настройках камеры.

Чтобы освещение не учитывало точку обзора, выберите любой другой параметр за исключением Ориентировать в направлении точки обзора в параметрах автоориентации света.

Примечание.

Как и в случае с другими свойствами, свойства камеры или света можно изменить непосредственно на панелях Временная шкала и Свойства.

Перемещение камеры, источника света или точки обзора с помощью инструментов «Выделение» и «Поворот»

  1. Выберите слой Камеры или Cвета.

  2. С помощью инструмента Выделение или Поворот выполните одно из предложенных ниже действий.

    • Для перемещения камеры или источника света и соответствующей точки обзора наведите указатель на ось, которую требуется настроить, и перетащите ее.

    • Чтобы переместить камеру или свет вдоль одной из осей без перемещения точки обзора, перетащите ось, удерживая нажатой клавишу CTRL (Windows) или COMMAND (macOS).

    • Чтобы произвольно переместить камеру или источник света без перемещения точки обзора, перетащите значок камеры или значок источника света.

    • Для перемещения точки обзора перетащите значок точки обзора .

Перемещение или настройка камеры и рабочего 3D-вида с помощью инструментов камеры

Свойства камеры Положение и Точка обзора можно изменить с помощью инструментов Камеры на панели Композиция.

Инструменты Камеры также можно использовать для настройки рабочего 3D-вида, 3D-вида, который не связан со слоем камеры. 3D-виды можно представить как виртуальные камеры, через которые можно предварительно просматривать композицию. Рабочие 3D-виды включают пользовательские виды и фиксированные ортографические виды (передний план, слева, сверху, сзади, справа и снизу). Рабочие 3D-виды полезны для размещения и предпросмотра элементов в 3D-сцене. При использовании инструмента камеры для настройки рабочего 3D-вида значения свойств слоя не изменяются.

После изменения 3D-вида его можно сбросить, выбрав Вид > Сбросить 3D-вид. Подробнее о выборе и использовании 3D-видов.

Примечание.

Для настройки фиксированных ортографических видов нельзя использовать инструмент Перемещение камеры по орбите.

  1. В меню 3D-вида в нижней части панели Композиция выберите камеру или 3D-вид, которые нужно настроить.

  2. Активируйте инструмент Камеры.

    Инструмент Камеры можно активировать, выбрав его на панели Инструментов или нажав клавишу C для перелистывания инструментов Камеры. Самый простой способ переключения между различными инструментами Камеры — выбрать инструмент Универсальная камера и использовать кнопки трехкнопочной мыши.

    Перемещение камеры по орбите

    Поворачивает 3D-вид или камеру путем перемещения вокруг точки обзора. (Чтобы временно активировать инструмент Перемещение камеры по орбите при выделенном инструменте Универсальная камера, удерживайте левую кнопку мыши.)

    Примечание.

    Перетаскивание выделенного инструмента Универсальная камера при нажатой клавише SHIFT временно активирует инструмент Перемещение камеры по орбите и ограничивает поворот одной осью.

    Отслеживать камеру по осям XY

    Настраивает 3D-вид или камеру по горизонтали или по вертикали. (Чтобы временно активировать инструмент Отслеживать камеру по осям XY при выделенном инструменте Универсальная камера, удерживайте среднюю кнопку мыши.)

    Отслеживать камеру по оси Z

    Настраивает 3D-вид или камеру вдоль линии к точке обзора. При использовании ортографического вида этот инструмент регулирует масштаб просмотра. (Чтобы временно активировать инструмент Отслеживать камеру по оси Z при выделенном инструменте Универсальная камера, удерживайте правую кнопку мыши.)

  3. Выполните перетаскивание на панели Композиция. Операцию перетаскивания можно продолжить за пределами панели после выполнения перетаскивания на панели.

После изменения 3D-вида его можно сбросить, выбрав Вид > Сбросить 3D-вид.

Перемещение или настройка камеры и рабочего 3D-вида для просмотра слоев

Можно переместить камеру или настроить 3D-вид для просмотра выделенных слоев или всех слоев. After Effects изменяет точку обзора и направление обзора, чтобы включить в просмотр выделенные слои.

  • Чтобы настроить 3D-вид или переместить камеру для просмотра выделенных слоев, выберите Вид > Просмотр выбранных слоев.
  • Чтобы настроить 3D-вид или переместить камеру для просмотра всех слоев, выберите Вид > Просмотр всех слоев.

Комбинации клавиш для этих команд см. в разделе 3D-слои (комбинации клавиш).

Свойства «Параметры материала»

3D-слои имеют свойства Параметры материала, которые определяют, как 3D-слой взаимодействует со светом и тенью.

Отбрасывает тени

Определяет, отбрасывает ли слой тени на другие слои. Направление и угол тени определяется направлением и углом источников света. Установите параметр Отбрасывает тени на значение Только, если необходимо, чтобы слой не отображался, но отбрасывал тень.

Примечание.

Используйте настройку Только и ненулевую настройку Передача света для проецирования цветов невидимого слоя на другой слой.

Передача света

Процент света, который проходит через слой, передавая цвета слоя другим слоям в качестве тени. Значение 0 % определяет, что через слой не проходит свет и слой отбрасывает черную тень. Значение 100 % указывает, что цвет слоя, отбрасывающего тень, проецируются на слой, принимающий тень, в полном объеме.

Примечание.

Используйте частичную передачу света, чтобы создать видимость прохождения света через витражное стекло.

Принимает тени

Определяет, отображает ли слой тени, отбрасываемые на него другими слоями. Установка Только доступна в параметре Принимает тени для случаев, когда необходимо выполнить рендеринг тени слоя.

Принимает свет

Указывает, зависит ли цвет слоя от падающего на него света. Этот параметр не влияет на тени.

Освещение

Окружающая (ненаправленная) отражательная способность слоя. Значение 100 % указывает на максимальную отражательную способность; значение 0 % задает отсутствие окружающей отражательной способности.

Диффузия

Рассеянная (всенаправленная) отражательная способность слоя. Применение рассеянной отражательной способности к слою похоже на накладывание приглушенного синтетического полотна поверх него. Свет, падающий на такой слой, отражается одинаково во всех направлениях. Значение 100 % указывает на максимальную отражательную способность; значение 0 % задает отсутствие рассеянной отражательной способности.

Интенсивность зеркального отражения

Зеркальная (направленная) отражательная способность слоя. Блики отражаются от слоя, как от зеркала. Значение 100 % указывает на максимальную отражательную способность; значение 0 % задает отсутствие зеркальной отражательной способности.

Зеркальный блеск

Определяет размер зеркальной подсветки. Эта настройка активна, только если значение параметра Цвет блика больше нуля. Значение 100 % подразумевает отражение с малой зеркальной подсветкой. Значение 0 % подразумевает отражение с большой зеркальной подсветкой.

Металл

Добавление цвета слоя к цвету зеркальной подсветки. 100 % указывает, что цвет зеркальной подсветки является цветом слоя. Например, если значение Металл равно 100 %, изображение золотого кольца отражает золотой свет. 0 % указывает на то, что цвет зеркальной подсветки является цветом света от источника. Например, слой со значением Металл равным 0%, расположенный под белым светом, имеет белую подсветку.

Задание разрешения для рендеринга теней

Модуль рендеринга Advanced 3D используется для рендеринга композиций, состоящих из пересекающихся 3D-слоев. Для рендеринга тени модуль использует карты теней, которые являются изображениями, визуализированными из точки обзора каждого источника света. Обычно разрешение тени вычисляется автоматически на основе разрешения композиции и настроек качества слоев. Если обычное разрешение не приводит к созданию нужного качества или рендеринг выполняется слишком медленно, можно настроить разрешение карты теней. Если тени размыты и параметр материала Диффузия тени равен 0, увеличьте разрешение карты теней. Если рендеринг теней выполняется слишком медленно, уменьшите разрешение карты теней.

Если слой, отбрасывающий тень, пересекает другой слой, иногда в месте пересечения, которое должно быть затенено, появляется небольшой зазор. Чтобы уменьшить размер зазора, увеличьте разрешение карты теней.

Стереоскопическое 3D-изображение

С помощью Adobe After Effects можно создавать стереоскопические 3D-видео.

Оснастка стереоскопической 3D-камеры

В After Effects есть команда меню Создать оснастку Stereo 3D, которая позволяет превратить 3D-композицию в стереоскопическую 3D-композицию. Команда Создать оснастку Stereo 3D создает все элементы, включая эффект Витраж 3D.

Чтобы создать шаблон стереоскопической 3D-камеры, сначала создайте композицию с элементами 3D. Это должна быть композиция, которая содержит такие элементы, как свернутая предварительная 3D-композиция или 3D-объекты. При создании оснастки стереоскопической 3D-камеры выберите существующую камеру (если таковая имеется). Если камера не выбрана, создается новая камера. Выберите Слой > Камера > Создать оснастку Stereo 3D. Оснастка работает только с двухузловыми камерами.

Оснастка генерируется посредством создания основной камеры или использования существующей выделенной камеры в композиции. Существуют композиции «Левый глаз» [ср. «Левый глаз»] и «Правый глаз» [ср. «Правый глаз»]. В каждой композиции имеется камера, связанная с основной камерой, оригинальная вложенная композиция и выходная композиция Stereo 3D [ср. Stereo 3D]. Выходная композиция Stereo 3D содержит обе композиции «Глаз», а также слой элементов управления Stereo 3D. Этот слой содержит эффект Элементы управления Stereo 3D для управления шаблоном и эффект Витраж 3D, который объединяет композиции для левого и правого глаза в стерео изображение.

Примечание.

Эффект Элементы управления Stereo 3D является частью оснастки Stereo 3D и не отображается на панели Эффекты и шаблоны.

Ниже приведены параметры эффекта Элементы управления Stereo 3D для разделения и конвергенции камеры.

Конфигурация

Центр: левая и правая камеры устанавливаются по обеим сторонам основной камеры. Hero слева: левая камера устанавливается в той же точке, что и основная камера, а правая камера — справа от основной. И наоборот, Hero справа: правая камера устанавливается в той же точке, что и основная камера, а левая камера — слева от основной.

Глубина стереосцены

Управляет межосевым разделением между камерами в процентах от ширины композиции. Таким образом, если размер композиции изменяется, величина разделения остается неизменной. Самое низкое значение этого параметра равно 3 % для сохранения едва различимого эффекта. Для получения качественного 3D-видеоряда значение не должно превышать 14–30 %. Однако оно может быть больше — это зависит от содержимого сцены (объекты расположены слишком близко) и обзора камеры.

Примечание.

Изменение этого значения влияет на глубину, на которую оснастка «Stereo 3D» погружается или выходит за пределы сцены. При использовании слишком большого значения может возрастать нагрузка на глаза.

Конвергенция камер

При выключении параметра камеры остаются параллельными основной камере, но смещаются в стороны. При включении параметра положение остается смещенным. Вместе с тем Точки обзора левой и правой камер соединяются в позиции, которая основывается на следующих двух свойствах.

«Конвергировать в» и «Смещение конвергенции по оси Z»

Определяет расстояние от камеры по оси Z, на котором располагается экран при просмотре через очки 3D. Все, что расположено дальше по оси Z, кажется вставленным в экран, а все, что расположено ближе, — выступающим из экрана. Если флажок конвергенции камер снят и камеры располагаются параллельно, изменение конвергенции сцены имеет тот же результат, что и изменение смещения по оси Z. В этом случае используйте различные режимы, чтобы разместить на сцене разные элементы для заполнения области экрана. Подробнее об Эффекте «Витраж 3D».

Начало работы с стереоскопическим 3D-видео

При работе с стереоскопическим 3D-видео 3D-телевизор не требуется. Можно использовать двухцветные (красно-голубые) очки 3D и просматривать стереоскопический 3D-видеоряд на панели Композиция. Однако для редактирования в реальном времени можно использовать 3D-телевизор и активные стереоскопические очки. Для начала работы требуются указанные ниже инструменты.

  • Монитор или телевизор, поддерживающий просмотр стереоскопического 3D-видео.
  • Очки для стереоскопического 3D-телевизора.
Примечание.

Для работы используйте активные стереоскопические очки для которых требуется устройство-излучатель. Убедитесь, что используемые очки рекомендованы изготовителем телевизора.

  • Стереоскопический видеоряд или 3D-композиция.

При наличии всех необходимых инструментов выполните приведенные ниже действия.

  1. Подключите 3D-телевизор к компьютеру с помощью кабеля HDMI (если использование HDMI невозможно, можно использовать DVI).

  2. Создайте 3D-композицию в After Effects. Убедитесь, что размер композиции соответствует текущему разрешению монитора.

  3. Создайте для своей стереоскопической 3D-композиции новую панель Композиция. Зафиксируйте композицию, а затем перетащите ее на 3D-монитор.

  4. Убедитесь, что панель Композиция развернута на 100%.

  5. Дважды нажмите CONTROL + \(обратная косая черта), чтобы установить для композиции полноэкранный режим на 3D-мониторе. Задайте для композиции и 3D-монитора одинаковые размеры.

  6. Установите для 3D-вида в эффекте Витраж 3D одно из представленных ниже значений.

    • стереопара;

    • поверх снизу;

    • с чересстрочной разверткой.

  7. Включите на 3D-мониторе режим 3D в соответствии с форматом, установленным в 3D-виде для эффекта Витраж 3D. («Стереопара» и «Поверх снизу» поддерживаются в большинстве 3D-телевизоров.)

  8. Оденьте очки 3D и отредактируйте композицию в формате настоящего стереоскопического 3D-видео.

Советы по стереоскопическому 3D-видео

  • При работе со стереоскопическим 3D-видеорядом на панели Композиция без 3D-телевизора используйте формат анаглифа. Обычные двухцветные (красно-голубые) очки 3D идеально подходят для работы со стереоскопическим 3D-видео.

  • Увеличивайте или уменьшайте Глубину стереосцены, чтобы изменить глубину отображения 3D-среды.

  • Включите параметр Конвергенция камер и измените Смещение конвергенции по оси Z для перемещения различных объектов на передний и задний план экрана. Объекты, расположенные к камере ближе расстояния смещения по оси Z, отображаются на переднем плане экрана, а объекты, расположенные дальше, — на заднем плане.

  • Чтобы согласовать глубину резкости композиции с конвергенцией стереоскопической камеры, выполните одно из предложенных ниже действий.

    • Глубина поля и конвергенция стереоскопического 3D-видео совпадают при использовании параметра Привязать фокусное расстояние к точке обзора на основной камере и конвергенции камер для шаблона.

    • Чтобы со временем изменить глубину поля, можно применить анимацию к фокусному расстоянию основной камеры. Установите точку конвергенции от Положения камеры, а затем задайте выражение, связывающее смещение по оси Z с фокусным расстоянием основной камеры

 Adobe

Получайте помощь быстрее и проще

Новый пользователь?

Adobe MAX 2024

Adobe MAX
— творческая конференция

С 14 по 16 октября очно в Майами-Бич и онлайн

Adobe MAX

Творческая конференция

С 14 по 16 октября очно в Майами-Бич и онлайн

Adobe MAX 2024

Adobe MAX
— творческая конференция

С 14 по 16 октября очно в Майами-Бич и онлайн

Adobe MAX

Творческая конференция

С 14 по 16 октября очно в Майами-Бич и онлайн