Пути движения

Если нужно анимировать пространственные свойства (включая «Положение», «Опорная точка» и точку управления эффектом), движение отображается как путь движения. Путь движения представляет собой последовательность точек, где каждая точка обозначает положение слоя в каждом кадре. Маркер на пути обозначает положение ключевого кадра.

Пути движения — это просто другой визуальный способ просмотра и работы с пространственными свойствами и их ключевыми кадрами. Он дополняет методы, используемые при работе со свойствами на панели «Таймлайн». Путь движения можно изменить, отредактировав существующий ключевой кадр или добавив новый ключевой кадр. Форму пути движения также можно изменить, изменив методы пространственной интерполяции для его ключевых кадров. (См. раздел Сведения о пространственной и временной интерполяции ключевого кадра.)

Плотность точек между рамками на пути движения показывает относительную скорость слоя или точки управления эффектом. Чем ближе точки расположены друг к другу, тем ниже скорость, и наоборот.

Примечание.

Щелкните ключевой кадр правой кнопкой мыши (Windows) или левой кнопкой мыши, удерживая нажатой клавишу COMMAND (Mac OS), чтобы открыть его контекстное меню.

Редактирование ключевых кадров для пространственного свойства с помощью инструмента «Перо» или «Выделение» на панели «Композиция» или «Слой» похоже на изменение кривой Безье для маски или фигуры в слое-фигуре. (См. раздел Сведения о путях.)

Если для пути движения использовать меньше ключевых кадров, он будет менее сложным и его будет легче изменить. С помощью инструмента сглаживания из пути движения можно удалить лишние ключевые кадры.

Отображение элементов пути движения

Пути движения положений отображаются на панели «Композиция». Пути движения опорной точки и точек управления эффектом отображаются на панели «Слой».

  • Чтобы отобразить элементы пути движения на панели «Композиция», выберите команду «Вид» > «Параметры просмотра» и выберите параметры «Элементы управления эффектом», «Ключевые кадры», «Пути движения» и «Дескрипторы движения». Чтобы отобразить путь движения положения на панели «Композиция», необходимо выбрать свойство «Положение».
  • Чтобы отобразить элементы пути движения на панели «Слой», выберите свойство или эффект в меню «Вид» в нижней части панели «Слой».
  • Чтобы определить количество ключевых кадров, отображаемых для пути движения, выберите команду «Правка» > «Установки» > «Отображение» (Windows) или «After Effects» > «Установки» > «Отображение» (Mac OS) и выберите параметр в разделе «Путь движения».
  • Чтобы указать размер дескрипторов направления кривой Безье для путей движения, выберите команду «Правка» > «Установки» > «Общие» (Windows) или «After Effects» > «Установки» > «Общие» (Mac OS) и измените значение размера точки пути.

Перемещение ключевых кадров пути движения

  1. На панели «Таймлайн» выберите слой, для которого нужно изменить путь движения.
  2. Если ключевой кадр, который нужно изменить, не виден на панели «Композиция» или на панели «Слой», переместите индикатор текущего времени на нужный ключевой кадр.
  3. На панели «Композиция» или «Слой» с помощью инструмента «Выделение» переместите ключевой кадр или его дескрипторы.

    Примечание.

    Индикатор текущего времени не должен обязательно находиться в ключевом кадре перед его перетаскиванием.

    Чтобы переместить один ключевой кадр «Положение», перетащите ключевой кадр на панели «Композиция».
    Чтобы переместить один ключевой кадр «Положение», перетащите ключевой кадр на панели «Композиция».

    Можно одновременно переместить несколько ключевых кадров. Для этого выделите их на панели «Таймлайн» перед перетаскиванием на панели «Композиция» или «Слой». Чтобы переместить весь путь движения, выделите все ключевые кадры, щелкнув название свойства на панели «Таймлайн» перед перетаскиванием ключевого кадра на панели «Композиция».

    Перетаскивание всех ключевых кадров на пути движения с помощью одного ключевого кадра
    Перетаскивание всех ключевых кадров на пути движения с помощью одного ключевого кадра

Добавление ключевого кадра в путь движения с помощью инструмента «Перо»

  1. Отобразите путь движения, который нужно изменить, на панели «Композиция» или «Слой».
  2. На панели «Инструменты» выберите инструмент «Перо» или «Добавить вершину» .
  3. На панели «Композиция» наведите инструмент «Перо» на точку пути движения, в которую нужно добавить новый ключевой кадр, и щелкните левой кнопкой мыши.

    Новый ключевой кадр появится в кадре, выбранном на пути движения, и на панели «Таймлайн». Для перемещения ключевого кадра используйте инструмент «Выделение».

    Примечание.

    Хотя результат будет отличаться, методы работы с кривыми путей движения с помощью инструмента «Перо» похожи на методы создания и изменения других путей на основе кривой Безье, таких как пути маски и формы.

Создание наброска пути движения с помощью инструмента «Набросок движения»

Путь движения для выбранного слоя можно нарисовать с помощью инструмента «Набросок движения», который записывает положение слоя и скорость рисования. В процессе рисования ключевой кадр «Положение» создается в каждом кадре.

Инструмент «Набросок движения» не влияет на ключевые кадры, настроенные для других свойств. Например, если были заданы ключевые кадры «Поворот» для изображения мяча, с помощью инструмента «Набросок движения» можно создать такие ключевые кадры, чтобы казалось, что мяч катится вдоль созданного пути.

Джон Дикинсон (John Dickinson) демонстрирует работу с инструментом «Набросок движения» в своем видеоуроке на веб-сайте Motionworks.

  1. На панели «Композиция» или «Таймлайн» выберите слой, для которого нужно сделать набросок пути движения.
  2. На панели «Таймлайн» установите маркеры рабочей области на продолжительности, в которой нужно сделать набросок движения.
  3. Чтобы слышать звук в своей композиции при создании наброска, убедитесь, что на панели «Предпросмотр» не нажата кнопка отключения звука.
  4. Выберите команду «Окно» > «Набросок движения».
  5. Выберите соответствующие параметры для наброска движения.

    Показать каркас

    Включает каркасное представление слоя при создании наброска пути движения.

    Показать фон

    Отображает статическое содержимое кадра, в котором создается набросок на панели «Композиция». Этот параметр полезен, если нужно сделать набросок движения по отношению к другим изображениям в композиции.

    Сглаживание

    Исключает ненужные ключевые кадры из пути движения. Этот параметр аналогичен использованию параметра «Допуск» с инструментом сглаживания. Более высокие значения дают более сглаженные кривые, но при слишком высоком значении не сохранится форма создаваемой кривой.

    Примечание.

    Путь движения можно сгладить после его создания, использовав выражение сглаживания или инструмент сглаживания.

    Скорость захвата

    Отношение скорости записанного движения к скорости воспроизведения. Если скорость захвата равна 100 %, движение воспроизводится с той же скоростью, с которой оно было записано. Если скорость захвата больше 100 %, движение воспроизводится медленнее, чем оно было записано.

  6. Нажмите кнопку «Начать захват», щелкните левой кнопкой мыши на панели «Композиция» и, не отпуская ее, нарисуйте путь движения. Отпустите кнопку мыши, чтобы остановить захват.

    Примечание.

    After Effects автоматически завершит захват, когда время захвата достигнет конца рабочей области (которое по умолчанию совпадает с продолжительностью композиции).

Создание пути движения из пути маски, формы или заливки

Путь движения можно создать из пути любого типа.

  • Свойство «Путь маски»

  • Свойство «Контур фигуры» в слое-фигуре

  • Свойство «Путь» для обводки рисованием

  • Путь, скопированный из Illustrator или Photoshop

Любой из этих путей можно вставить в свойство «Положение» или «Опорная точка» слоя или в свойство «Положение» опорной точки эффекта. Вставленные ключевые кадры задаются с привязкой ко времени (за исключением первого и последнего), чтобы обеспечить постоянную скорость вдоль пути.

По умолчанию продолжительность вставленного пути движения составляет 2 секунды. Продолжительность можно настроить, перетащив первый или последний ключевой кадр на панели «Таймлайн».

  1. Копирование пути в буфер обмена.
    • Выберите свойство «Путь» на панели «Таймлайн» и выберите команду «Правка» > «Копировать».

    • Выделите контур в Illustrator или Photoshop и выберите команду «Правка» > «Копировать».

  2. На панели «Таймлайн» выберите свойство, в которое нужно вставить путь.
  3. Поместите индикатор текущего времени в точку времени для первого ключевого кадра пути движения.
  4. Выберите команду «Правка» > «Вставить».

В этом видео на веб-сайте Creative COW Эндрю Дэвис (Andrew Devis) показывает, как использовать пути из Illustrator в качестве путей движения в After Effects.

Размытие в движении

При просмотре одного кадра кинофильма или видео, содержащего движущийся объект, картинка часто бывает смазанной или размытой, так как кадр представляет один фрагмент времени (на кинопленке время одного кадра составляет 1/24 секунды). За это время движущийся объект успевает оказаться в нескольких разных местах на кадре, поэтому он не отображается как резкий неподвижный объект. Чем быстрее движется объект, тем сильнее он смазывается. Угол и фаза затвора камеры также влияют на размытие, так как они определяют время нахождения затвора в открытом состоянии и момент открытия затвора по отношению к началу кадра.

С другой стороны, иногда один кадр компьютерной анимации не позволяет определить, какие объекты перемещаются, потому что все движущиеся объекты могут выглядеть четкими и резкими, как будто они неподвижны. Без размытия в движении анимация слоя будет похожа на набор кадров, выхваченных стробоскопом, а не на плавное изменение картинки. Добавление размытия в движении в слои, которые анимируются в After Effects, делает движение более плавным и естественным.

Размытие в движении добавляется в каждый слой по отдельности, и также его можно включить для предпросмотра и конечного вывода. Для включения или отключения размытия в движении для предпросмотра используйте переключатель «Включить размытие в движении» в верхней части панели «Таймлайн». Измените параметры визуализации на панели «Очередь рендеринга», чтобы включить или отключить рендеринг размытия в движении для окончательного вывода. Если в категории «Общие установки» включен параметр «Переключатели изменяют вложенные композиции», для вложенных композиций наследуются параметры родительских композиций. (См. раздел Сведения о создании предварительных и вложенных композиций.)

Размытие в движении замедляет рендеринг, поэтому при работе можно отключить изменение композиций и включить его, когда надо просмотреть конечный результат.

Чтобы включить размытие в движении для слоя, выполните одно из предложенных ниже действий.

  • Щелкните переключатель «Размытие в движении» для слоя на панели «Таймлайн».
  • Выберите слой, а затем — команду «Слой» > «Переключатели» > «Размытие в движении».

Количество образцов, которые After Effects использует для расчета размытия в движении, адаптируется для каждого слоя в зависимости от движения этого слоя. Эта адаптивность обеспечивает высокое качество размытия в движении без необходимости дискретизировать движение медленно движущегося слоя с частотой дискретизиации движения быстро движущегося слоя. Чем выше частота дискретизации, тем ниже скорость рендеринга.

Если для композиции включено размытие в движении, а масштаб панели «Таймлайн» увеличен настолько, что можно видеть отдельные кадры, вокруг индикатора текущего времени светло-серая область, обозначающая фазу и угол затвора. Ширина столбца обозначает угол затвора, а смещение столбца — фазу затвора. Это визуальное представление показывает, как дискретизируются отдельные кадры для расчета размытия в движении в этой композиции.

Размытие в движении можно использовать при анимации слоя, например когда слой текста движется на экране. Размытие в движении нельзя добавить движение, которое уже существует в слое, с помощью переключателей «Размытие в движении» для слоя и композиции.

Для большей плавности и естественности видео, частота кадров которого намного меньше или больше, чем у оригинала, используйте наложение кадров, а не размытие в движении.

Чтобы создать искусственное размытие в движении, см. раздел Применение размытия в движении.

Параметры размытия в движении на вкладке «Дополнительно» раздела «Настройки композиции»

Выборок на кадр

Минимальное количество выборок. Это количество выборок, используемых для кадров, для которых After Effects не может определить адаптивную частоту дискретизации на основе движения слоя. Эта частота дискретизации используется для 3D-слоев и слоев-фигур.

Адаптивное ограничение выборок

Максимальное количество выборок.

Угол затвора

Угол затвора измеряется в градусах, имитируя экспозицию, предоставляемую вращающимся затвором. Угол затвора использует частоту кадров видеоряда для определения сымитированной экспозиции, влияющей на величину размытия в движении. Например, ввод 90° (25 % от 360°) для видеоряда с частотой 24 кадра/с создает эффективную экспозицию 1/96 секунды (25 % от 1/24 секунды). Ввод 1° практически не создает размытия в движении, а ввод 720° накладывает очень большой объем размытия.

Фаза затвора

Фаза затвора также измеряется в градусах. Она определяет смещение, по которому определяется момент открытия затвора относительно начала кадра. Путем корректировки этого значения можно исправить ситуацию, когда объект с примененным размытием в движении отстает от объекта без размытия в движении.

Примечание.

Значение фазы затвора, составляющее –1/2 от значения угла затвора, лучше всего подходит для слоя, который наложен на другой слой с использованием данных отслеживания движения. (Пример: фаза затвора = –90°, угол затвора = 180°.) Такая комбинация параметров обеспечивает размытие по центру на исходном объекте.

Применение размытия в движении к маске

Эффект размытия в движении создается на основе движения маски в композиции. Размытие в движении можно применить к отдельным маскам. Чтобы отобразить размытие в движении для любого слоя или маски в пределах слоя каждой композиции, необходимо щелкнуть переключатель «Включить размытие в движении».

  1. Выделите одну или несколько масок.
  2. Выберите команду «Слой» > «Маски» > «Размытие в движении» и выберите один из предложенных вариантов.

    Так же, как слой

    Маска будет иметь размытие в движении, только если для слоя включено размытие в движении.

    Вкл.

    Маска будет иметь размытие в движении независимо от переключателя «Размытие в движении» для слоя.

    Выкл.

    Маска не будет иметь размытие в движении.

Дополнительные материалы по эффекту размытия в движении

При съемке быстро двигающегося объекта в процессе рендеринга объекта возникает размытие в движении. Кроме того, при съемке движущихся объектов с более высокой выдержкой будет казаться, что объекты перепрыгивают между кадрами, как в стробоскопическом эффекте.

Эффект «Размытие пикселей в движении» в After Effects CC отслеживает движение пикселей между кадрами. Эффект анализирует клип, чтобы определить, какие части двигаются, создает набор векторов движения, а затем использует эти данные для добавления размытия в движениив пределахкадра.

Если объект двигается слишком быстро, увеличьте значение параметра Образцы затвора, чтобы создать больше промежуточных кадров. Увеличьте значение параметра Данные вектора, чтобы свести к минимуму возможность возникновения ошибок при анализе групп пикселей между кадрами. 

Крис и Триш Мейер (Chris and Trish Meyer) предлагают видеоруководство по эффекту «Размытие пикселей в движении» на веб-сайте ProVideo Coalition.

Тодд Коприва (Todd Kopriva) опубликовал статью об этом эффекте в официальном блоге After Effects.

Дополнительные сведения о других эффектах времени в After Effects см в документе Эффекты времени.

Марк Кристиансен (Mark Christiansen) объясняет некоторые концепции, касающиеся размытия в движении, скорости затвора и угла затвора, на веб-сайте ProVideo Coalition.

Эндрю Крамер (Andrew Kramer) опубликовал на веб-сайте Video Copilot видеоурок, посвященный преимуществам использования 32-битного цвета для размытия в движении. (См. раздел Разрядность цвета и высокий динамический диапазон цветов.)

Обеспечение плавного движения и скорости путем удаления дополнительных ключевых кадров

Пути движения, кривые значений и кривые скорости можно сгладить с помощью инструмента сглаживания, чтобы исключить «выпадение» отдельных ключевых кадров или убрать избыточные ключевые кадры. При этом добавляются новые или удаляются лишние ключевые кадры.

Примечание.

Для этой цели можно также использовать выражение сглаживания без удаления ключевых кадров. (См. раздел Атрибуты свойств и методы (справочник по выражениям).)

Хотя кривую можно сгладить для любого свойства, инструмент сглаживания лучше применять к кривым, которые были автоматически созданы инструментом «Набросок движения», так как они могут содержать лишние ключевые кадры. Применение инструмента сглаживания к ключевым кадрам, которые были установлены вручную, может привести к неожиданным изменениям к кривой.  

Примечание.

Чтобы не пришлось использовать инструмент сглаживания для пути, созданного инструментом «Набросок движения», включите параметр «Сглаживание» на панели «Набросок движения» перед созданием наброска пути.

При применении сглаживания к свойствам, которые изменяются в пространстве (например, «Положение»), сгладить можно только пространственную кривую (кривую, определяемую движением). При применении сглаживания к свойствам, которые изменяются только во времени (например, «Непрозрачность»), сгладить можно только кривые значений и скорости (кривые, определяемые значением или скоростью).

В дополнение к добавлению новых или удалению ненужных ключевых кадров инструмент сглаживания также применяет интерполяцию по кривой Безье к каждому ключевому кадру при сглаживании временной кривой. (См. раздел Методы интерполяции ключевого кадра.)

  1. На панели «Таймлайн» можно выделить все ключевые кадры для свойства, чтобы сгладить всю кривую, или выделить не менее трех ключевых кадров, чтобы сгладить только часть кривой.
  2. Выберите команду «Окно» > «Сглаживание». В меню «Применить к» будет автоматически выбран пункт «Пространственный путь» или «Временная диаграмма» в зависимости от типа свойства, для которого в шаге 1 были выбраны ключевые кадры.
  3. Укажите значение для параметра «Допуск». Единицы допуска совпадают с единицами сглаживаемого свойства. Отклонения новых значений ключевых кадров от исходной кривой не будут превышать указанное значение. Более высокие значения дают более сглаженные кривые, но при слишком высоком значении не сохранится исходная форма кривой.
  4. Нажмите кнопку «Применить» и предварительно просмотрите результат.
  5. При необходимости выберите команду «Правка» > «Отменить сглаживание», чтобы восстановить ключевые кадры, установите нужное значение для параметра «Допуск» и повторно примените сглаживание.

Случайное изменение значений свойства с помощью инструмента «Колебание»

У любого свойства можно хаотично изменять значения с течением времени, используя инструмент «Колебание».

Примечание.

Для этой цели можно также использовать выражение покачивания. В большинстве случаев проще использовать выражение, чем инструмент «Колебание». (См. раздел Атрибуты свойств и методы (справочник по выражениям).)

В зависимости от свойства и указанных параметров инструмент «Колебание» вносит в свойство определенное количество отклонений, добавляя ключевые кадры и меняя случайным образом интерполяцию данных, входящих в существующие ключевые кадры и исходящих из них. Для использования инструмента «Колебание» требуется не менее двух ключевых кадров.

С помощью инструмента «Колебание» можно более точно имитировать естественные отклонения в заданных пределах. Например, добавьте хаотичность в движения анимированной бабочки, чтобы создать эффект порхания. Добавьте хаотичность для яркости или непрозрачности, чтобы сымитировать мерцание старого проектора.

  1. Выберите диапазон ключевых кадров для свойства.
  2. Выберите команду «Окно» > «Колебание».
  3. В меню «Применить к» выберите тип кривой, к которой нужно применить инструмент «Колебание». Если для изменяющегося в пространстве свойства были выбраны ключевые кадры можно выбрать пункт «Пространственный контур», чтобы добавить отклонения в движение, или «Временная диаграмма», чтобы добавить отклонения в скорость. Если ключевые кадры были выбраны для не изменяющегося в пространстве свойства, выбрать можно только «Временную диаграмму».
  4. Если выбрать вариант «Тип шума», можно указать тип отклонения вследствие случайного распределенными пикселей (шум).

    Плавный шум

    Создает отклонения, которые происходят более плавно, без резкого изменения.

    Неровный шум

    Создает неожиданные изменения.

  5. Выберите измерения свойства, которое нужно откорректировать.

    X, Y или Z

    Добавляет отклонения только в одно измерение выбранного свойства. Выберите измерение в меню.

    Все отдельно

    Добавляет различный набор отклонений во все измерения независимо.

    Все одинаково

    Добавляет один набор отклонений во все измерения.

  6. Задайте частоту, определяющую количество отклонений (ключевых кадров) в секунду, которые After Effects будет добавлять к выбранным ключевым кадрам. При низком значении будет создано только несколько случайных отклонений, а при высоком значении будут получены более переменчивые отклонения. При значении меньше 1 ключевые кадры будут создаваться с интервалом менее одного в секунду. Например, при значении 0,5 будет создаваться один ключевой кадр каждые 2 секунды.
  7. Задайте амплитуду, определяющую максимальный размер отклонений. After Effects установит указанную амплитуду для единиц выбранного свойства, чтобы на основании значения для одного свойства могло быть получено совершенно другое значение в другом свойстве.
  8. Нажмите кнопку «Применить» и предварительно просмотрите результат.
  9. При необходимости выберите команду «Правка» > «Отменить колебание», чтобы сбросить ключевые кадры, задайте значения для частоты и амплитуды, а затем повторно примените инструмент «Колебание».

Преобразовать аудио в ключевые кадры

Помощник «Преобразовать аудио в ключевые кадры» анализирует амплитуду звука в рабочей области и создает для нее ключевые кадры.

  1. Если на панели «Композиция» или «Таймлайн» включена композиция, выберите команду «Анимация» > «Помощник в работе с ключевыми кадрами» > «Преобразовать аудио в ключевые кадры».

Помощник в работе с ключевыми кадрами создает слой «Амплитуда аудио», представляющий все источники звука в композиции, с тремя эффектами «Элементы управления выражения» и свойствами «Ползунок», которые содержат ключевые кадры: «Левый канал», «Правый канал» и «Оба канала».

Чтобы использовать ключевые кадры, созданные этим помощником, свяжите изменения в амплитуде аудио с другими свойствами слоя. Например, с помощью выражения свяжите ключевые кадры звука со свойством «Масштаб» слоя, чтобы слой уменьшался и увеличивался вместе с амплитудой.

Ресурсы в Интернете, посвященные преобразованию звука в ключевые кадры

Аарон Рабинович (Aharon Rabinowitz) опубликовал на веб-сайте Creative COW видеоурок, в котором показано, как связать ключевые кадры амплитуды звука с другими свойствами (в данном этомслучаесвойства эффекта «Волнообразная деформация»), чтобы синхронизировать анимацию со звуком.

Натан Гэмблс (Nathan Gambles) опубликовал на веб-сайте Video Copilot выражение, которое приглушает (уменьшает громкость) звука в одном слое, когда громкость звука в другом слое увеличивается. Этот метод полезен, например, для автоматического уменьшения громкости звуковой дорожки при открытии диалогового окна. Выражение для эффекта стереомикшера зависит от того, применена ли к другому слою звука команда «Преобразовать аудио в ключевые кадры».

Ллойд Альварес (Lloyd Alvarez) опубликовал на веб-сайте After Effects Scripts сценарий, который добавляет маркеры, разделяет слой или добавляет новый текстовый слой с увеличивающимися числами на основе интенсивности звука.

Эндрю Дэвис (Andrew Devis) опубликовал на веб-сайте Creative COW два видеоурока, в которых подробнопоказано,как использовать метод линейных выражений в сочетании с командой «Преобразовать аудио в ключевые кадры».

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет