Примечание.

Инструменты фигур позволяют легко создавать кнопки, навигационные панели и другие элементы веб-страниц. Для обзора всех возможностей рисования в Photoshop см.Сведения о рисовании.

Рисование фигур в Photoshop

Рисование фигур в Photoshop
Джулианна Кост (Julieanne Kost)

Создание фигуры в слое-фигуре

  1. Выберите инструмент из группы «Фигура» или инструмент «Перо». Убедитесь, что в меню на панели параметров выбран инструмент «Фигура».

  2. Чтобы задать цвет фигуры, щелкните образец цвета на панели параметров и выберите цвет в палитре цветов.
  3. (Необязательно) Установите параметры инструмента на панели параметров. Щелкните стрелку вниз рядом с кнопками «Фигура» для показа дополнительных параметров инструмента. (См. раздел Параметры группы инструментов «Фигура».)

  4. (Необязательно) Чтобы применить к фигуре стиль, выберите готовый стиль во всплывающем меню «Стиль» панели параметров. (См. раздел Применение ранее заданных стилей.)

  5. Для отрисовки фигуры протащите указатель мыши по изображению.
    • Чтобы ограничить форму прямоугольника с прямыми или скругленными углами квадратом, а форму эллипса кругом или сделать угол наклона линии кратным 45 градусам, удерживайте нажатой клавишу «Shift».
    • Чтобы нарисовать фигуру от центра, установите курсор в точке, в которой должен располагаться центр фигуры, нажмите клавишу «Alt» (Windows) или «Option» (Mac OS) и перетаскивайте курсор по диагонали в направлении любого угла или края, пока фигура не достигнет желаемого размера.
    Рисование от угла (слева) и рисование от центра (справа)
    Рисование от угла (слева) и рисование от центра (справа)

    Примечание.

    Рисование от центра используется по умолчанию для инструмента «Звезда» в приложении Illustrator и инструмента «Многоугольник» в приложениях Illustrator и Photoshop.

Видео | Создание, редактирование и работа

Жанна Руббо (Jeanne Rubbo), член команды Photoshop, демонстрирует создание, редактирование и использование слоев-фигур в серии информативных видеороликов. Ознакомьтесь со следующими видеороликами:

Дополнительные сведения см. в разделе Рисование и галерея инструментов «Текст».

Отрисовка нескольких фигур в одном слое

Существует возможность нарисовать несколько фигур в одном слое либо воспользоваться параметрами «Добавление», «Вычитание», «Пересечение» или «Исключение» для изменения текущей фигуры.

  1. Выберите слой, в который необходимо добавить фигуры.
  2. Выберите инструмент рисования и настройте его параметры (см. раздел Параметры группы инструментов «Фигура»).

  3. Нажмите одну из следующих кнопок на панели параметров:

    Добавить к области фигуры

    Добавляется новая область к существующей фигуре или контуру.

    Удалить из области фигуры 

    Удаляется перекрывающаяся область из существующих фигур или контура.

    Пересечение областей фигур 

    Ограничение области до пересечения новой области с существующими фигурами или контурами.

    Исключение пересекающихся областей 

    Исключается наложение областей в объединении новой и существующей областей.

  4. Нарисуйте изображение. Сменить инструмент рисования можно путем простого нажатия кнопки инструмента на панели параметров.

Рисование фигуры в форме колеса

Из существующей фигуры можно вырезать другую фигуру, делая видимыми нижележащие слои. Данная процедура показывает, как создать фигуру в форме бублика, но тот же метод может использоваться с любой комбинацией инструментов группы «Фигура», в том числе и с заказными фигурами.

  1. Выберите в палитре инструментов инструмент «Эллипс» . Он может быть скрыт одним из других инструментов группы «Фигура» или инструментом «Линия» .

  2. Убедитесь, что в меню на панели параметров выбран инструмент «Фигура».

  3. Перетаскивайте указатель мыши в окне документа для отрисовки фигуры. При перетаскивании удерживайте нажатой клавишу «Shift», чтобы ограничить форму эллипса кругом.
  4. Выберите на панели параметров кнопку «Вычесть из области фигуры» .

  5. Перетаскивайте указатель мыши внутри новой фигуры, чтобы определить область отсечения. Как только кнопка мыши будет отпущена, изображение, находящееся под новой фигурой, станет видимым.
  6. Для изменения положения одной из фигур выберите в палитре инструментов инструмент «Выделение контура»  (он может быть скрыт инструментом «Стрелка» ) и выделите контур. Перетащите его в новое место или сдвигайте его на один пиксел за один раз при помощи клавиш со стрелками.

    Примечание.

    Удерживайте нажатой клавишу «Shift» для выделения более одного контура.

Рисование произвольной фигуры

Рисовать произвольные фигуры можно, выбрав фигуры в раскрывающейся панели «Произвольная фигура». Можно также сохранить фигуру или контур и использовать их в дальнейшем как произвольную фигуру.

  1. Выбор инструмента «Произвольная фигура» . (Если инструмент не отображается, удерживайте в одном положение инструмент «Прямоугольник» рядом с нижней частью панели инструментов.)

  2. Выберите фигуру в раскрывающейся панели «Произвольная фигура» на панели параметров.

    Если необходимая фигура отсутствует на панели, нажмите стрелку в правом верхнем углу панели и выберите другую категорию фигур. В ответ на вопрос, заменять ли текущие фигуры, выберите или «Да», чтобы отображались только фигуры в новой категории, или «Добавить», чтобы новые фигуры были добавлены к уже отображаемым.

  3. Для отрисовки фигуры протащите указатель по изображению.

Сохранение фигуры или контура в качестве произвольной фигуры

  1. Выберите контур на панели «Контуры» — векторную маску для слоя-фигуры, рабочий контур или сохраненный контур.
  2. Выберите меню «Редактирование» > «Определить произвольную фигуру» и введите имя для новой произвольной фигуры в диалоговом окне «Имя фигуры». Новая фигура появится на всплывающей панели «Фигура» на панели параметров.
  3. Для сохранения новой произвольной фигуры в новой библиотеке выберите пункт «Сохранить произвольные фигуры» в меню раскрывающейся панели.

Дополнительные сведения см. в разделе Работа со средством «Управление наборами.

Создание растровой фигуры

При создании растровой фигуры фигура отрисовывается, растрируется и заливается основным цветом. Растровую фигуру нельзя редактировать как векторный объект. Растровые фигуры создаются с использованием текущего основного цвета.

  1. Выберите слой. Растровую фигуру нельзя создать в векторном слое (например, текстовом).
  2. Выберите инструмент группы «Фигура» и нажмите на панели параметров кнопку «Выполнить заливку пикселов» .
  3. Установите на панели параметров следующие параметры:

    Режим

    Управляет воздействием фигуры на имеющиеся в изображении пикселы. (См. раздел Режимы наложения.)

    Непрозрачность

    Определяет, в какой мере фигура скрывает или раскрывает пикселы, находящиеся ниже. Фигура со значением этого параметра, равным 1 %, выглядит почти прозрачной, в то время как значение 100 % обеспечивает полную непрозрачность.

    Сглаживание

    Сглаживает и смешивает граничные пикселы за счет изменения цвета окружающих пикселов.

  4. Установите дополнительные параметры для выбранного инструмента. См. раздел Параметры группы инструментов «Фигура».

  5. Нарисуйте фигуру.

Параметры группы инструментов «Фигура»

Каждый инструмент фигуры предоставляет уникальную комбинацию перечисленных ниже параметров. Чтобы получить доступ к этим параметрам, нажмите стрелку справа от строки кнопок с фигурами на панели параметров.

Доступ к параметрам работы с фигурами на панели параметров (параметры работы с линиями отображаются)
Доступ к параметрам работы с фигурами на панели параметров (параметры работы с линиями отображаются)

Стрелки в начале и конце

Добавляются стрелки на концах линии. Выберите инструмент «Линия», а затем установите флажок «Начало», чтобы добавить стрелку в начале линии, или флажок «Конец», чтобы добавить стрелку в конце линии. Установите оба флажка, чтобы добавить стрелки на обоих концах. Параметры фигуры отображаются во всплывающем диалоговом окне. Введите значения «Ширина» и «Длина», чтобы указать пропорции стрелки в процентном отношении к толщине линии (от 10 до 1000 % для ширины, от 10 до 5000 % для длины). Введите значение кривизны стрелки (от -50 до +50 %). Значение кривизны определяет степень изогнутости самой широкой части стрелки в месте, где она встречается с линией.

Примечание.

Можно отредактировать стрелку и непосредственно с помощью векторных инструментов выделения и рисования.

Круг

Ограничивает форму эллипса кругом.

Сохранить пропорции

Визуализирует заказную фигуру с использованием пропорций, которые она имела при создании.

Сохранить размеры

Визуализирует произвольную фигуру с использованием размера, который она имела при создании.

Заданный размер

Визуализирует прямоугольник с прямыми или скругленными углами, эллипс или заказную фигуру в виде фигуры фиксированного размера с использованием значений, введенных в текстовых полях «Ширина» и «Высота».

От центра

Визуализирует прямоугольник с прямыми или скругленными углами, эллипс или заказную фигуру от центра.

Глубина лучей

Визуализирует многоугольник в виде звезды. Введите в текстовом поле значение в процентах, указывающее, какая часть радиуса звезды будет занята лучами. При выборе значения 50 % лучи будут занимать половину общего радиуса звезды. При выборе большего значения лучи будут длиннее и острее, при выборе меньшего значения лучи будут более широкими.

Задать пропорции

Визуализирует прямоугольник с прямыми или скругленными углами, эллипс или произвольную фигуру в виде фигуры с пропорциями, введенными в текстовых полях «Ширина» и «Высота».

Радиус

Для прямоугольников со скругленными углами — радиус скругления углов. Для многоугольников — расстояние от центра многоугольника до внешних точек.

Стороны

Число сторон многоугольника.

Сгладить внутренние углы или внешние углы

Визуализирует многоугольник со сглаженными внутренними или внешними (в случае звезды) углами.

Привязать к пикселам

Края прямоугольника с прямыми или скругленными углами привязываются к границам пикселов.

Квадрат

Ограничение формы прямоугольника с прямыми или скругленными углами квадратом.

Произвольно

Произвольный выбор ширины и высоты прямоугольника с прямыми или скругленными углами, эллипса или заказной фигуры путем перетаскивания указателя мыши.

Толщина

Задает ширину в пикселах для инструмента «Линия».

Примечание.

Чтобы изменить ширину штриха для других инструментов группы «Фигура», выберите команду «Слой» > «Стиль слоя» > «Обводка». (См. раздел Применение и редактирование пользовательского стиля слоя.)

Редактирование фигур

Фигура — это слой-заливка, связанный с векторной маской. При редактировании слоя-заливки фигуры несложно изменить цвет, градиент или узор заливки. Можно отредактировать и векторную маску фигуры, чтобы изменить границы фигуры и применить к слою произвольный стиль.

  • Для изменения цвета фигуры дважды щелкните ее миниатюру на панели слоев и выберите другой цвет с помощью палитры цветов.
  • Для заливки фигуры узором или градиентом выделите нужный слой-фигуру на панели слоев, выберите команду «Слой» > «Стиль слоя» > «Наложение градиента».
  • Чтобы изменить ширину штриха, выделите нужный слой-фигуру на панели «Слои» и выберите команду «Слой» > «Стиль слоя» > «Обводка».
  • Для изменения границы фигуры, щелкните миниатюру векторной маски слоя-фигуры на панели слоев или панели контуров. После этого можно изменить фигуру с помощью групп инструментов «Фигура» и «Перо».
  • Чтобы переместить фигуру, не изменяя ее размер или пропорции, используйте инструмент «Перемещение».

Дополнительные сведения см. в разделах Настройка компонентов контура и /Свободное трансформирование.

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет