Оптимизация производительности Photoshop

Попробуйте применить советы и приемы, приведенные в этом документе, когда Photoshop на вашем компьютере работает медленнее, чем ожидалось.

 Прекращение поддержки 3D-функций в Photoshop

3D-функции Photoshop будут удалены в будущих обновлениях. Пользователям, работающим с 3D-функциями, рекомендуется ознакомиться с новой коллекцией Adobe Substance 3D, которая представляет собой новое поколение 3D-инструментов от Adobe. Дополнительная информация о прекращении поддержки 3D-функций в Photoshop представлена здесь: Photoshop 3D | Распространенные вопросы о прекращении поддержки 3D-функций в Photoshop.

Основные шаги по повышению производительности

Конфигурация каждого пользователя уникальна и может потребовать своего набора методов для обеспечения максимально эффективной работы Photoshop. Из предложенных в этой статье способов выберите те, которые подходят для конфигурации компьютера, используемых типов фалов и вашего конкретного рабочего процесса. Существует четыре основных способа повлиять на производительность в Photoshop: оптимизировать настройку оборудования, оптимизировать операционную систему для Photoshop, задать настройки, связанные с производительностью, и настроить функции Photoshop.

Самый простой способ повысить производительность, не тратя деньги, — это задать оптимальные установки Photoshop и тонко настроить его функции под свой стиль работы и чаще всего используемые файлы.

Значительного увеличения производительности можно добиться, приобретя более быстрое и мощное аппаратное обеспечение.Для оптимальной работы Photoshop компьютер должен соответствовать минимальным системным требованиям. Запуск Photoshop на маломощном или неподдерживаемом оборудовании, например на компьютере с несовместимым графическим процессором (GPU), может привести к проблемам с производительностью. 

Изменение установок, связанных с производительностью

Просмотрите это короткое видео, чтобы узнать, как быстро оптимизировать настройки, связанные с производительностью в Photoshop.

В Photoshop есть ряд установок (Установки > Производительность), которые помогут оптимально использовать такие ресурсы компьютера, как память, кеш, графический процессор, мониторы и т. д. В зависимости от основного использования Photoshop и типов документов, с которыми вы в основном работаете, вам могут подойти различные комбинации этих параметров.

Такие дополнительные параметры, как Рабочие диски, доступные на других вкладках диалогового окна «Установки», также могут непосредственно влиять на скорость и стабильность работы компьютера.

Установки производительности в Photoshop

Настройка выделенной памяти для Photoshop

Производительность можно повысить путем увеличения количества памяти/оперативной памяти, выделяемой на Photoshop. В разделе Использование памяти в диалоговом окне установок производительности (Установки > Производительность) указывается, какой объем ОЗУ доступен для приложения Photoshop. Там же указывается оптимальный диапазон выделения памяти на Photoshop для вашей системы.

По умолчанию приложение Photoshop использует 70% доступного объема ОЗУ.

  1. Увеличьте количество оперативной памяти, выделяемой на Photoshop, изменив значение в поле Занято под Photoshop. В качестве альтернативы можно изменить положение ползунка «Использование памяти».
  2. Перезапустите приложение Photoshop, чтобы изменения вступили в силу.

Чтобы определить оптимальный объем выделенного ОЗУ для вашей системы, изменяйте соответствующее значение с шагом 5 % и следите за изменением производительности с помощью индикатора эффективности. 

Мы не рекомендуем выделять на Photoshop более 85 % памяти компьютера. Это может повлиять на производительность, поскольку другим важным системным приложениям может не хватить памяти.

Примечание.

Если приложение Photoshop выдает ошибки «Недостаточный объем ОЗУ», попробуйте увеличить объем ОЗУ, выделенный на Photoshop. Однако, если задать слишком высокое значение для выделенной памяти на Photoshop (>85 %), это может сказаться на производительности других запущенных приложений и сделать работу системы нестабильной. 

В данном случае лучшее решение — увеличить объем ОЗУ в компьютере. Узнайте у производителя вашего компьютера о характеристиках ОЗУ и его совместимости.

Настройка уровней кэширования

Основы работы с кэшем

Приложение Photoshop использует технологию кэширования изображений для более быстрой перерисовки документов с высоким разрешением пока вы работаете с ними. Вы можете указать до восьми уровней кэширования данных изображений и выбрать один из четырех доступных размеров мозаичного размещения в кэше.

Повышение значения уровней кэширования позволяет улучшить производительность работы Photoshop, однако загрузка изображений может выполняться медленнее. Размер мозаичного размещения в кэше определяет количество данных, которые Photoshop обрабатывает за раз. Больший размер фрагментов мозаики ускоряет выполнение сложных операций, таких как применение фильтров резкости. Небольшие изменения, например, мазки кистью, выполняются быстрее при меньшем размере фрагментов мозаики.

Наборы параметров кэширования

На панели «Параметры производительности» доступны три набора параметров кэширования. Выберите тот из них, который соответствует основному использованию (назначению) Photoshop:

  • «Веб-дизайн / дизайн пользовательских интерфейсов»: выберите этот вариант, если Photoshop в основном используется для дизайна веб-сайтов, приложений или графического интерфейса. Этот вариант подходит для документов с большим количеством слоев с ресурсами, состоящими из малого или среднего количества пикселей.
  • «По умолчанию / Фотографии»: выберите этот вариант, если Photoshop в основном используется для ретуши и редактирования изображений умеренного размера. Например, это вариант подходит, если вы обычно редактируете в Photoshop фотографии с мобильного телефона или цифровой камеры.
  • «Очень большой размер в пикселях»: выберите этот вариант, если вы много работаете в Photoshop с большими документами — например, с панорамами, мэт-пэйнтингом и т. д.

Уровни кэша

Для более точного контроля укажите уровни кэша вручную. Значение по умолчанию составляет 4.

  • При обработке относительно небольших файлов – примерно 1 мегапиксель или 1 280 до 1 024 пикселей и много слоев (50 и больше) – задайте значение уровней кэширования 1 или 2. Настройка значения уровней кэширования 1 отключает кэширование изображений; кэшируется только изображение, которое отображается на экране.
  • При обработке файлов с пикселями большего размера – например, 50 мегапикселей и более – задайте значение уровней кэширования больше 4. Более высокий уровень кэширования обеспечивает более высокую скорость перерисовки изображений.
Примечание.

Вам не удастся добиться впечатляющих результатов с помощью определенных функций приложения Photoshop при настройке значения уровней кэширования 1.

Ограничение количества состояний в истории

Вы можете освободить пространство рабочего диска и повысить производительность путем ограничения или уменьшения числа шагов истории состояний, которые сохраняет приложение Photoshop, на панели «История». Пространство, используемое для сохранении, варьируется в зависимости от количества пикселей, которые изменяются в результате соответствующей операции. Например, история состояний, сохраняемая при мазке кисти или выполнении операции без разрушения, например, создании или изменении корректирующего слоя, требует меньше свободного пространства. Применение фильтра ко всему изображению, с другой стороны, занимает намного больше свободного пространства.

Photoshop может сохранять до 1 000 шагов истории состояний; значение по умолчанию – 50.

Чтобы уменьшить это значение, перейдите к диалоговому окну «Параметры производительности».В разделе История и кэш
установите меньшее значение для параметра Состояния истории.

Настройка параметров графического процессора (GPU)

Лучшим способом оптимизации ускорения с помощью GPU, который ускоряет перерисовку изображений, является использование самой новой версии драйвера видеоадаптера.  Инструкции по обновлению драйверов видеоадаптера

см. в разделе об обновлении графического драйвера.

Для получения дополнительной информации о том, как Photoshop использует графический процессор, протестированных платах и минимальных требованиях к графическому процессору и дисплею 

см. вопросы и ответы о графических процессорах и видеокартах.

Установки графического процессора

В Photoshop предусмотрены специальные настройки ГП в разделах «Производительность» и «3D» диалогового окна «Установки».

Настройки в разделе «Установки» > «Производительность»

Если на вашем компьютере обнаружена видеокарта, ее название и модель появятся в разделе «Обнаружение графического процессора» в области «Настройки графического процессора» раздела «Производительность».

  • Если ваша видеокарта поддерживается, флажок «Использовать графический процессор» будет активен и установлен по умолчанию.
  • Если ваша графическая карта не поддерживается, флажок будет выделен серым цветом и не будет установлен по умолчанию.
  • Если ваша видеокарта поддерживается, и флажок для параметра «Использовать графический процессор» не установлен, это, скорее всего, связано с тем, что программа Photoshop обнаружила сбой, вызванный дефектным графического драйвера или конфигурацией. См. раздел Устранение проблем Photoshop, связанных с графическим процессором и графическим драйвером.

Дополнительные расширенные настройки

  • Использовать OpenCL: отключите этот параметр, если функции «Галерея размытия», «Умная резкость», «Выбор области фокусировки» или «Размер изображения с сохранением деталей» работают неправильно.
  • Сглаживание направляющих и контуров: отключите, если направляющие и контуры кажутся слишком тяжелыми или слишком широкими
  • 30-битный дисплей: позволяет увеличить точность цветопередачи на мониторе, поддерживающем 30-битный режим.
Отключение Open CL

Примечание.

Включение OpenCL вероятнее всего позволит улучшить производительность при использовании следующих функций приложения Photoshop:

  • Галерея размытия - Размытие по полю, Размытие по диафрагме, наклон-смещение, Размытие контура, вращение запачкает (с ускорением OpenCL)
  • Умная резкость (уменьшение шума – с ускорением OpenCL)
  • Уточнить края (с ускорением OpenCL)

Настройки в разделе «Установки» > 3D

Раздел «3D» диалогового окна «Производительность» содержит ползунок видеопамяти, который работает аналогично ползунку управления памятью в разделе «Производительность». Этот ползунок используется для определения верхнего предела видеопамяти, доступной для средства 3D-моделирования в Photoshop. Итоговое значение равно процентному значению всей доступной видеопамяти. При выборе значения 100 % все равно остается резервная видеопамять для операционной системы. При выборе высоких значений повышается 3D-производительность в целом, однако это может препятствовать нормальной работе других приложений, для которых используется ГП.

3D: использование памяти

Управление рабочими дисками

Примечание.

Если Photoshop не запускается из-за переполнения рабочего диска, удерживайте при запуске клавиши Cmd + Option (macOS) или Ctrl + Alt (Windows), чтобы задать новый рабочий диск.

Рабочий диск — это жесткий диск или твердотельный накопитель (SSD-диск), используемый для временного хранения данных при работе в Photoshop. Photoshop использует это пространство для хранения фрагментов документов и их состояний панели «История», для которых не хватает объема оперативной памяти компьютера. 

Дополнительные сведения об установках и рекомендуемых настройках рабочих дисков см в разделе Настройка рабочих дисков.

Также см. дополнительные сведения об устранении ошибок рабочего диска в Photoshop.

Индикатор «Эффективность»

Следите за индикатором эффективности для контроля производительности во время работы в приложении Photoshop.Нажмите на всплывающее меню в нижней части окна, в котором отображается изображение, и выберите «Эффективность» во всплывающем меню.

Если значение индикатора ниже 100%, это означает, что приложение Photoshop использует весь доступный объем оперативной памяти и дополнительно использует пространство на рабочем диске, за счет чего снижается производительность. Если эффективность ниже 90%, необходимо выделить больше ОЗУ для приложения Photoshop в «Параметрах производительности». Вы также можете добавить дополнительный объем ОЗУ в вашей системе.

Индикатор «Эффективность»

Тонкая настройка параметров Photoshop для повышения производительности

Отключение линеек и наложения

Отображение линеек и наложений (таких как «Сетки», «Фрагменты» и «Быстрые направляющие») может замедлять выполнение некоторых операций, таких как рисование, преобразование и перетаскивание слоев на холсте.

  • Чтобы отключить линейки, снимите флажок Линейки в меню Вид.
  • Чтобы отключить наложения, перейдите в меню Вид > Показать, выберите Нет или отключите отдельные элементы.

См. Отображение или скрытие непечатных вспомогательных элементов.

Обрабатывайте файлы с ограниченным размером

Очень большой размер файлов зачастую может стать причиной снижения производительности приложения.

Photoshop поддерживает файлы максимальным размером 300 000 x 300 000 пикселей, за исключением файлов PDF, которые ограничены размером 30 000 x 30 000 пикселей и 200 x 200 дюймов, и Camera Raw, где поддерживаются изображения высотой или шириной до 65 000 пикселей и общим размером до 512 мегапикселей.

Ограничение размера файлов в приложении Photoshop:

  • Файлы PSD: 2 Гб
  • Файлы TIFF: 4 Гб
  • Файлы PSB: 4 экзабайта (4 096 петабайт или 4 миллиона терабайт)
  • Файлы PDF: 10 Гб (максимальный размер страниц – 200 х 200 дюймов)

Закройте ненужные окна с открытыми изображениями

Если приложение Photoshop выдает ошибку «Недостаточный объем ОЗУ» или работает медленно, это может быть вызвано тем, что вы открыли слишком много изображений. Если вы открыли несколько окон с изображениями, попробуйте закрыть некоторые из них.

Сокращение количества стилей

Чтобы уменьшить объем пространства, используемого приложением Photoshop на рабочем диске, необходимо уменьшить количество загруженных стилей. Узоры и кисти — одни из самых объемных составляющих стилей. Сохраните в соответствующий файл стили, которые не требуются прямо сейчас, затем удалите их и загружайте только тогда, когда они вам понадобятся.

См. дополнительные сведения об управлении наборами.

Уменьшите или отключите панель предварительного просмотра миниатюр

Каждый раз при изменении документа приложение Photoshop обновляет все миниатюры, отображаемые на панелях «Слои» и «Каналы». Этот процесс обновления может повлиять на скорость отклика при быстром рисовании, перемещении или искажении слоев. Чем большее количество миниатюр отображается, тем значительнее проявляется данный эффект.

Для того чтобы уменьшить или отключить предварительный просмотр миниатюр, нажмите на меню соответствующей панели и выберите «Параметры панели». Выберите меньший размер миниатюр или опцию «Нет», а затем нажмите кнопку «ОК».

Измените параметры совместимости файлов

Если вам не нужно работать с файлами PSD и PSB в старых версиях Photoshop или в приложениях, которые не поддерживают слои, можно отключить эту функцию совместимости файлов для повышения скорости сохранения документов:

  1. Для документов по 16-битным и 32-битным PSD и PSB в разделе «Установки» > «Обработка файлов» выберите «Отключить сжатие файлов PSD и PSB».

  2. В меню «Максимизировать совместимость файлов PSD и PSB» выберите «Спрашивать» или «Никогда».

Обрабатывайте 8-битные изображения

Photoshop может выполнять множество стандартных операций c 16-битными и 32-битными изображениями. Однако для обработки этих изображений требуется больше памяти, больше свободного пространства на рабочем диске и больше времени по сравнению с 8-битными изображениями.

Для того чтобы преобразовать изображение в 8-битный формат, выберите Изображение > Режим > 8 бит/канал.

См. Битовая глубина и установки.

Примечание.

Преобразование в формат 8 бит на канал удаляет некоторые данные из изображения. Сохраните копию исходного изображения в 16-битном или 32-битном формате прежде чем выполнить преобразование в формат 8 бит на канал.

Отключите предварительный просмотр шрифтов

Чтобы ускорить обработку шрифтов в приложении Photoshop, отключите предварительный просмотр списка шрифтов, выбрав Тип > Размер просматриваемого шрифта > Нет.

Уменьшите разрешение изображения

Чем выше разрешение изображения, тем больше памяти и свободного дискового пространства требуется приложению Photoshop для отображения, обработки и печати такого изображения. В зависимости от вашего конечного устройства вывода, более высокое разрешение не обязательно обеспечивает более высокое качество изображения, но в то же время оно может снижать производительность, требовать дополнительное дисковое пространство и снижать скорость печати. Оптимальное разрешение изображений зависит от того, каким образом эти изображения будут отображены и печатаны. 

Для изображений, отображаемый на экране, следует руководствоваться полным размером в пикселях. Чтобы уменьшить размер изображения, выберите «Изображение» > «Размер изображения». В диалоговом окне «Размер изображения» убедитесь, что выбран параметр «Ресамплинг». Введите новое значение ширины или высоты (при вводе значения одного параметра изменяется и второй параметр).

Увеличение разрешения печатных изображений выше 360 точек на дюйм (DPI) в большинстве случаев практически не приносит никаких преимуществ. Если вы часто распечатываете изображения, опытным путем определите для себя разрешение, обеспечивающее приемлемые результаты. Чтобы уменьшить разрешения изображения, выберите «Изображение» > «Размер изображения». В диалоговом окне «Размер изображения выберите «Ресамплинг». Измените значения ширины и высоты таким образом, чтобы размеры изображения соответствовали физическим размерам печатного документа. После этого уменьшите значение параметра «Разрешение» и нажмите кнопку «ОК».

Если вы планируете увеличить, а не уменьшить разрешение изображения для печати, это следует сделать на завершительном этапе непосредственно перед печатью. Таким образом, вам не придется обрабатывать всю эту дополнительную информацию на предварительном этапе.

Очистите память

Вы можете улучшить производительность системы путем очистки неиспользованной памяти и свободного пространства на рабочих дисках в приложении Photoshop, чтобы обеспечить к нему доступ других программ. Для этого выберите один из следующих вариантов:

  • «Редактирование» > «Очистить» > «Все»
  • «Редактирование» > «Очистить» > «Отменить»
  • Удерживая клавишу Option (macOS) или Alt (Windows), выберите О Photoshop

Если другие программы активно пытаются выделить или использовать память, очистка неиспользуемой памяти в приложении Photoshop позволит увеличить производительность системы. Выполнить очистку пространства рабочего диска будет полезно, если в каталоге диска не осталось свободного пространства. После очистки значительного объема памяти и пространства на диске Photoshop в следующий будет открывать крупные файлы медленнее, так как Photoshop будет распределять освободившееся пространство.

Если вы хотите, чтобы Photoshop всегда использовал меньше памяти, выберите Редактирование > Установки > Производительность (Windows) или Photoshop > Установки > Производительность (macOS) и переместите ползунок Использование памяти влево.

См. раздел «Настройка используемого объема памяти».

Примечание.

Для мониторов активности, диспетчеров задач и программ, использующих диск, может потребоваться несколько секунд для регистрации изменения. В действительности, в отдельных утилитах требуются выполнить запрос на обновление параметров вручную.

Очистите буфер обмена

Буфера обмена зачастую содержит большой объем информации при копировании и вставке данных в процессе обработки крупных файлов. Кроме того, этот объем информации практически не используется после завершении вставки. Чтобы освободить буфер обмена, выберите пункт меню «Редактирование » > «Удалить из памяти» > «Буфер обмена».

Примечание.

Команду «Удалить из памяти» невозможно отменить.

Использование галереи фильтров

Галерея фильтров позволяет протестировать один или несколько фильтров на изображении перед тем как применить соответствующие эффекты, за счет чего экономится значительное количество времени и свободной оперативной памяти.

См. Обзор галереи фильтров.

Перетаскивайте изображения между файлами вместо того чтобы копировать и вставлять их

Перетаскивание слоев или файлов является более эффективным методом по сравнению с копированием и вставкой. Перетаскивание выполняется в обход буфера обмена, при этом данные перемещаются непосредственно в конечную точку. Копирование и вставка могут существенно увеличить объем передаваемых данных и являются гораздо менее эффективными.

Сохраняйте файлы TIFF без сжатия ZIP

Для повышения скорости экспортирования файлов TIFF не используйте сжатие ZIP. (Тем не менее, сжатие ZIP позволяет создавать файлы TIFF с самыми малыми размерами.)

Не экспортируйте буфер обмена

Опция «Экспорт буфера обмена» в Photoshop позволяет другим приложениям использовать содержимое буфера обмена. Если вы копируете большой объем данных в Photoshop, но не используете их в других приложениях, отключите эту опцию для повышения производительности:

  1. Выберите пункт меню Photoshop > Установки > Производительность (macOS) или Редактирование > Установки > Производительность (Windows).

  2. Снимите флажок Экспорт буфера обмена.

  3. Нажмите кнопку ОК.

Отключите панель «Библиотеки»

  1. Во всплывающем меню «Библиотеки» выберите «Закрыть».

  2. Перезапустите Photoshop.

Отключите Генератор

  1. Выберите Правка > Установки > Внешние модули.

  2. Снимите флажок Включить Генератор.

  3. Нажмите кнопку ОК.

Совмещение в Photoshop

Композитинг — это процесс объединения нескольких визуальных элементов в один фрейм, представляющий документ. Внутренний компоновщик в Photoshop выполняет тысячи вычислений во время использования программы, постоянно отображая каждое изменение, внесенное в ваше изображение, вместе как одно совмещенное изображение.

Многопотоковый композитинг

В выпуске Photoshop 22.3 за апрель 2022 г. теперь можно активировать многопоточный композитинг, выбрав Настройки > Производительность и установив флажок Многопоточный композитинг. Вам не нужно перезапускать Photoshop, чтобы это изменение вступило в силу.

Многопотоковая композиция

Корректирующие слои, маски слоев, режимы наложения, фильтры, стили и эффекты усложняют обработку документа, что может снизить скорость обработки в Photoshop. Вы можете заметить, что различные настройки ползунка не обновляют экран так быстро, как раньше, до того, как были добавлены все эти слои и эффекты. Многопотоковая композиция помогает задачам совмещения на основе процессора и графического процессора работать быстрее, разделяя вычислительную работу на более мелкие части, которые могут выполняться параллельно, часто быстрее, чем они могли бы быть вычислены в одном «потоке».

Хотя существует множество причин, по которым документы могут стать менее отзывчивыми при работе в Photoshop, ускорение совмещения от 100% до 250% с помощью многопотоковой композии имеет большое значение для обеспечения того, чтобы Photoshop мог быть настолько отзывчивым и плавным, насколько это необходимо.

Если вы заметили ошибки перерисовки и подозреваете, что проблема заключается в многопоточном композитинге, вы можете отключить эту функцию в разделе Настройки > Производительность. Если у вас есть вопрос или вы хотите поделиться своей проблемой с этой настройкой, сообщите нам об этом в сообществе Adobe Photoshop. Мы будем рады узнать ваше мнение!

Примечание.

Многопотоковая композиция заменяет предыдущее предупреждение об удалении устаревшей композиции, которая больше не требуется и теперь удалена.

Композитинг с ускорением на GPU

В выпуске Photoshop 22.3 за апрель 2022 года в Photoshop был добавлен композитинг с использованием графического процессора, чтобы повысить скорость отклика некоторых операций со слоями в документе. Создание композиции с помощью графического процессора можно использовать только в том случае, если Photoshop правильно обнаруживает графический процессор при запуске. Чтобы подтвердить это, перейдите в Настройки > Производительность и убедитесь, что ваш графический процессор указан в разделе Настройка графического процессора с галочкой рядом с пунктом Использовать графический процессор.

Чтобы установить галочку для включения или выключения создания композиции с помощью графического процессора, нажмите кнопку Дополнительные настройки... .

Создание композиции с помощью графического процессора

С небольшими и менее сложными документами, содержащими несколько слоев и настроек на основе слоев (например, режимы наложения, корректирующие слои), вы можете не заметить снижения производительности при включении или выключении режимов наложения или видимости слоев. Но по мере увеличения сложности и размера ваших документов от компоновщика в Photoshop может потребоваться обработка в реальном времени, и время, необходимое для отображения результатов на экране, может увеличиться. В очень сложных документах вы, возможно, заметили, что перемещение содержимого слоя или изменение непрозрачности занимает на долю секунды больше времени, пока экран обновится и отобразит результаты. При включенном композитинге с использованием графического процессора Photoshop будет использовать больше вычислительной мощности вашего графического процессора, чтобы ускорить композитинг и обеспечить вам более плавный процесс редактирования.

Если при внесении этих изменений на основе слоев возникают неожиданные результаты, можно попробовать отключить композитинг графического с использованием графического процессора, чтобы проверить, изменятся ли от этого результаты. 

Логотип Adobe

Вход в учетную запись