Перемещение, скрытие или инверсия выделенной области

Можно перемещать границы выделенной области по изображению, скрывать границы выделенной области и инвертировать выделенные области так, чтобы ранее невыделенная часть изображения была выделена.

Примечание.

Чтобы переместить саму выделенную область, а не ее границы, воспользуйтесь инструментом «Перемещение». См. раздел «Перемещение выделенной области».

Перемещение границ выделенной области

  1. При работе с любым инструментом выделения выберите на панели параметров режим «Новая выделенная область»  и переместите курсор внутрь границ выделенной области. Курсор изменяется , сообщая о том, что выделенную область можно перемещать.
  2. Перетащите границу, чтобы выделить другую область изображения. Можно частично перетащить границу выделенной области за границы холста. При перетаскивании ее обратно исходная граница окажется целой. Также можно перетащить границы выделенной области в окно другого изображения.
    Перемещение границы выделенной области в Photoshop
    Исходная граница выделенной области (слева) и перемещенная граница выделенной области (справа)

    Примечание.

    Можно применить геометрические преобразования для изменения формы границ выделенной области. (См. раздел «Применение преобразований».)

Управление перемещением выделенной области

  • Чтобы направление перемещения было кратно 45°, удерживайте нажатой клавишу «Shift» во время перемещения.
  • Чтобы перемещать выделенную область по одному пикселу, воспользуйтесь клавишами со стрелками.
  • Чтобы перемещать выделенную область по 10 пикселей, воспользуйтесь клавишами со стрелками, удерживая нажатой клавишу «Shift».

Отображение или скрытие краев выделенной области

Выполните одно из следующих действий.

  • Выберите меню «Просмотр» > «Вспомогательные элементы». С помощью этой команды можно показать или скрыть границы выделенной области, сетки, направляющие, целевые контуры, фрагменты, комментарии, границы слоев, счетчик и «быструю» направляющую.
  • Выберите меню «Просмотр» > «Вспомогательные элементы». Этот параметр позволяет отобразить (или скрыть) границы выделенной области, при этом действие производится только с текущей выделенной областью. Границы выделенной области появятся снова при создании другого выделения.

Выделение невыделенных частей изображения

  1. Выберите меню «Выделение» > «Инверсия».

    Примечание.

    Этот параметр можно использовать для выделения всей области изображения, расположенной за пределами выделенной области. Выделите фон при помощи инструмента «Волшебная палочка», а затем произведите инверсию выделения.

Настройка выделенных областей вручную

Инструменты выделения можно использовать для добавления или вычитания из существующих выделений пикселов.

Перед добавлением или вычитанием выделенной области можно установить параметр «Сглаживание» и значение для параметра «Растушевка» на панели параметров аналогично тем, что использовались в исходном выделении.

Добавление к выделенной области или выбор дополнительной области

  1. Выделите область.
  2. С помощью любого инструмента выделения выполните одно из следующих действий.
    • Выберите параметр «Добавление к выделенной области»  на панели параметров, а затем перемещайте курсор при нажатой кнопке мыши для добавления к выделенной области.

    • Удерживайте нажатой клавишу «Shift» и нажмите и удерживайте кнопку мыши для добавления к выделенной области.

При добавлении к выделенной области рядом с курсором появится знак плюса.

Вычитание из выделенной области

  1. Выделите область.
  2. С помощью любого инструмента выделения выполните одно из следующих действий.
    • Выберите параметр «Вычитание из выделенной области»  на панели параметров, а затем перемещайте курсор при нажатой кнопке мыши для вычитания из выделенной области.

    • Удерживайте нажатой клавишу «Alt» (Windows) или «Option» (Mac OS) и нажмите и удерживайте кнопку мыши для вычитания из выделенной области.

При вычитании из выделенной области рядом с курсором появится знак минуса.

Выделение области, пересекающейся с другими выделенными областями

  1. Выделите область.
  2. При помощи любого инструмента выделения выполните одно из следующих действий.
    • Выберите параметр «Пересечение с выделенной областью»  на панели параметров, а затем перемещайте курсор при нажатой кнопке мыши.

    • Для выделения пересечения выделенных областей удерживайте сочетание клавиш «Alt» и «Shift» (Windows) или «Option» и «Shift» (Mac OS) и, нажав и удерживая кнопку мыши, проведите указателем над исходной выделенной областью, создав новую выделенную область, пересечение с которой нужно получить.

При выделении пересечения рядом с курсором появится знак x.

Пересечение выделенных областей в Photoshop
Пересечение выделенных областей

Расширение или сжатие выделенной области на определенное число пикселов

  1. Воспользуйтесь одним из инструментов выделения для создания выделенной области.
  2. Выберите меню «Выделение» > «Модификация» > «Расширить» или «Сжать».
  3. В полях «Расширить на» и «Сжать на» введите количество пикселов от 1 до 100 и нажмите кнопку «ОК».

    Граница увеличится или уменьшится на заданное число пикселов. (Любая часть границы выделенной области, которая идет вдоль края холста, не затрагивается командой «Расширить».)

Создание выделенной области рядом с границей выделенной области

Команда «Граница» позволяет выделить полосу пикселов внутри существующих границ выделенной области и снаружи. Это полезно, когда возникает необходимость выделения границы или полосы пикселов вокруг изображения, а не самого изображения, например для того чтобы удалить ореол вокруг вставленного объекта.

Команда «Граница» в Photoshop
Исходная выделенная область (слева), выделенная область после выполнения команды «Граница»: 5 пикселов (справа)

  1. Воспользуйтесь одним из инструментов выделения для создания выделенной области.
  2. Выберите меню «Выделение» > «Модификация» > «Граница».
  3. Введите количество пикселов от 1 до 200 для выделения полосы пикселов вокруг исходной выделенной области и нажмите «ОК».

    Новая выделенная область окружает исходную выделенную область, ее центр находится на границе исходной выделенной области. Например, полоса из 20 пикселов является новой выделенной областью с гладкими краями, которая выступает на 10 пикселов от исходного выделения и углубляется на 10 пикселов внутрь его.

Расширение выделенной области для включения областей с похожим цветом

Выполните одно из следующих действий.

  • Выберите меню «Выделение» > «Смежные пикселы» для включения в выделенную область всех смежных пикселов, которые попадают в диапазон допуска, установленный в параметрах инструмента «Волшебная палочка».
  • Выберите меню «Выделение» > «Подобные оттенки» для включения из изображения в выделенную область пикселов, необязательно смежных, попадающих в диапазон допуска.

    Чтобы увеличить выделение в кратное число раз, запустите эту команду еще раз.

Примечание.

Команды «Подобные оттенки» и «Смежные пикселы» нельзя использовать в изображениях в битовом режиме или в изображениях с 32 битами на канал.

Удаление изолированных пикселов из выделенных областей на основе цвета

  1. Выберите меню «Выделение» > «Модификация» > «Оптимизировать».
  2. В поле «Радиус» введите количество пикселов от 1 до 100 и нажмите «ОК».

    Для каждого пиксела в выделенной области программа Photoshop анализирует пикселы вокруг него, находящиеся в пределах расстояния, указанного в параметре «Радиус». Если выделено более половины окружающих пикселов, то пиксел остается в выделенной области, а невыделенные пикселы вокруг него добавляются к выделенной области. Если выбрано меньше половины окружающих пикселов, то пиксел удаляется из выделенной области. В итоге происходит удаление мозаичности и сглаживание острых углов и зубчатых линий выделения.

Уточнение края выделенной области

Видеопособие: Идеальное выделение

Видеопособие: Идеальное выделение
Infinite Skills

Параметр «Уточнить край» улучшает качество краев выделенной области, позволяя вам с легкостью извлекать объекты. Параметр «Уточнить край» можно использовать также для улучшения свойств слоя-маски. (См. раздел Коррекция непрозрачности и краев маски.)

  • Щелкните «Уточнить край» на панели параметров или выберите «Выделение» > «Уточнить край». Затем задайте значения для следующих параметров.

Режим просмотра

Во всплывающем меню выберите режим, чтобы изменить вид выделенной области. Чтобы получить сведения о каждом режиме, наведите на него указатель и прочитайте всплывающую подсказку. При выборе «Показать оригинал» отображается исходная выделенная область для сравнения. Инструмент «Показать радиус» отображает границу выделенной области, где осуществляется уточнение краев.

Обнаружение краев

Инструменты «Уточнить радиус» и «Стереть уточнение»

Эти инструменты позволяют точно откорректировать область границы, в которой выполняется уточнение краев. Чтобы быстро переключиться от одного инструмента к другому, используйте клавиши «Shift+E». Чтобы изменить размер кисти, используйте клавиши квадратных скобок.

Примечание.

Проведите кистью по мягким поверхностям, таким как волосы или мех, чтобы увеличить детализацию выделенной области.

Инструмент «Умный радиус»

автоматически корректирует радиус для четких и нечетких краев, обнаруженных в области границы. Отмените выбор этого параметра, если граница по всей длине имеет одинаково четкие или одинаково нечеткие края или если вам необходимо более точно контролировать настройку радиуса и уточняющие кисти.

Радиус

определяет размер границы выделенной области, для которой выполняется уточнение краев. Используйте маленький радиус для резких краев и большой для более мягких краев.

Коррекция края

Плавное

сокращает искривленные области («выпуклости и впадины») в границе выделенной области, создавая более плавные очертания.

Растушевка

Размывает переход между выделенной областью и окружающими ее пикселями.

Контрастность

При увеличении переходы с мягкими краями вдоль границы выделенной области становятся более неровными. Обычно более эффективные результаты дают инструменты «Умный радиус» и «Уточнить края».

Инструмент «Сместить край»

Перемещает границы с мягкими краями внутрь с отрицательными значениями или наружу с положительными значениями. Смещение этих границ внутрь помогает убрать нежелательные цвета фона с краев выделения.

Вывод

Инструмент «Очистить цвета»

Заменяет цветную кайму на цвет полностью выделенных близлежащих пикселов. Эффект замены цвета вычисляется пропорционально мягкости краев выделенной области.

Примечание.

Поскольку этот параметр изменяет цвет пикселов, он требует вывод в новый слой или документ. Сохраните исходный слой, чтобы его можно было вернуть в случае необходимости. (Чтобы наглядно оценить изменение цвета пиксела, выберите режим просмотра «Показать слой».)

Эффект

изменяет уровень очистки и замены кромки.

Вывод в

определяет, становится ли уточненная выделенная область выделением или маской на текущем слое, либо образует новый слой или документ.

Смягчение краев выделенных областей

Сгладить острые края выделенной области можно при помощи сглаживания и растушевки.

Сглаживание

Сглаживает зубчатые края выделения, смягчая цветовой переход между краевыми пикселами и пикселами фона. Так как изменяются только пикселы на краях, то детализация изображения не ухудшается. Сглаживание полезно при вырезании, копировании и вставке выделений во время создания коллажей.

Сглаживание доступно для инструментов «Лассо», «Прямолинейное лассо», «Магнитное лассо», «Овальная область» и «Волшебная палочка». (Выберите инструмент для отображения его панели параметров.)

Примечание.

Этот параметр необходимо установить перед использованием данных инструментов. После создания выделенной области нельзя добавить сглаживание.

Растушевка

Размывает границы посредством создания перехода между выделенной областью и окружающими ее пикселами. Данное размытие приводит к потерям детализации на краях выделенной области.

Растушевку можно установить для инструментов «Область», «Лассо», «Прямолинейное лассо» и «Магнитное лассо» как во время использования инструмента, так и после создания существующей выделенной области.

Примечание.

Растушевка заметна только при перемещении, вырезании, вставке, копировании и заливке выделенной области.

Выделение пикселов при помощи сглаживания

  1. Выберите инструмент «Лассо», «Прямолинейное лассо», «Магнитное лассо», «Овальная область» или «Волшебная палочка».
  2. Установите параметр «Сглаживание» на панели параметров.

Определение растушеванного края для инструмента выделения

  1. Выберите любой из инструментов групп «Область» или «Лассо».
  2. Укажите значение параметра «Растушевка» на панели параметров. Это значение определяет ширину растушеванного края и может находиться в диапазоне от 0 до 250 пикселов.

Определение растушеванного края для существующей выделенной области

  1. Выберите пункты меню «Выделение» > «Модификация» > «Растушевка».
  2. Введите значение в поле «Радиус растушевки» и нажмите кнопку «ОК».

    Примечание.

    Маленькая область выделения, созданная с большим радиусом растушевки, может быть настолько расплывчатой, что ее края будут невидимы, и, таким образом, это не будет являться выделенной областью. При появлении сообщения «Ни один пиксел не выделен более чем на 50 %» нужно либо уменьшить радиус растушевки, либо увеличить размер выделенной области, либо нажать кнопку «ОК» для принятия маски с текущими настройками и создать выделенную область, в которой не будут видны края.

    Выделение с растушевкой и без нее в Photoshop
    Выделение с растушевкой и без растушевки

    A. Выделение без растушевки, то же самое выделение, залитое узором B. Выделение с растушевкой, то же самое выделение, залитое узором 

Удаление пикселов каймы из выделенной области

При перемещении или вставке сглаженной выделенной области некоторые окружающие границу выделения пикселы попадают в выделенную область. Это может привести к появлению каймы или ореола вокруг краев вставленной выделенной области. Группа команд «Слой» > «Обработка краев» позволяет редактировать нежелательные пикселы на краях.

  • Команда «Очистка цвета» заменяет цвета фона в пикселях каймы на цвет полностью выделенных близлежащих пикселей.

  • Команда «Убрать кайму» заменяет цвет любого пикселя каймы на цвет пикселей, удаленных от края выделения так, что уже не содержат фоновый цвет.

  • Команды «Удалить черный ореол» и «Удалить белый ореол» полезны, когда сглаживание выделения происходило на черном или белом фоне, а потом выделение будет вставляться в другой фон. Например, сглаженный черный текст на белом фоне имеет серые пикселы на краях, которые будут видны на цветном фоне.

Примечание.

Также можно удалить ореол при помощи ползунков дополнительных параметров наложения диалогового окна «Стили слоя», которые позволяют удалить области из слоя или сделать их прозрачными. В этом случае можно сделать прозрачными черные или белые области. Щелкните ползунки при нажатой клавише «Alt» (Windows) или «Option» (Mac OS) для их разделения, разделение ползунков позволяет удалять ореол и оставлять сглаженные края.

Уменьшение ореола вокруг выделенной области

  1. Выберите меню «Слой» > «Обработка краев» > «Устранить кайму».
  2. Введите значение в поле «Ширина» для указания области, в которой будет производиться поиск пикселов. В большинстве случаев достаточно расстояния в 1 или 2 пиксела.
  3. Нажмите кнопку «ОК».

Удаление ореола из выделенной области

  1. Выберите меню «Слой» > «Обработка краев» > «Удалить черный ореол» или «Слой» > «Обработка краев» > «Удалить белый ореол».

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет