В Photoshop можно с легкостью изменять перспективу изображений. Эта функция особенно полезна при работе с изображениями, содержащими прямые линии и плоские поверхности (например, фотографиями архитектурных объектов и зданий). Можно также применять эту функцию для составных объектов, имеющих различные углы перспективы на одном изображении.

Фон

Иногда объект на фотографии отличается от того, как он воспринимается в реальности. Такое несоответствие возникает из-за искажения перспективы. На фотографиях одного и того же объекта, снятых с разного расстояния и под разным углом, перспектива искажается по-разному.

Искажение перспективы на фотографиях одного и того же объекта, снятых под разными углами и с разных расстояний

Необходимое условие: включение графического процессора

Photoshop требует не меньше 512 МБ видеопамяти для работы функции «Деформация перспективы» в 16- и 32-битных документах. Дополнительные сведения см. в разделе Графический процессора и Photoshop: часто задаваемые вопросы.

Для коррекции перспективы необходимо включить в установках Photoshop графический процессор.

  1. Выберите команду Редактирование > Установки > Производительность.
  2. В меню «Настройки графического процессора» выберите пункт «Использовать графический процессор».
  3. Откройте меню «Дополнительные параметры». Удостоверьтесь, что выбран пункт «Использовать графический процессор для ускорения вычисления».
  4. Нажмите кнопку ОК.

Коррекция перспективы

Определение плоскостей

Перед коррекцией перспективы необходимо определить плоскости конструкции на изображении:

  1. Откройте изображение в Photoshop.
  2. Выберите меню Редактирование > Выполнить обводку. Прочитайте и закройте экранную подсказку.
  3. Нарисуйте четырехугольники, соответствующие плоскостям конструкции на изображении. Рисуя четырехугольники, старайтесь сделать так, чтобы их края шли параллельно прямым линиям конструкции.
Photoshop — Коррекция перспективы
Проводите края четырехугольников строго параллельно линиям конструкции. Как показано на иллюстрации, можно привязать друг к другу две плоскости. Здесь показан набор плоскостей, определенных для здания.

Изменение плоскостей

  1. Переключитесь в режим Деформация из режима Макет.
Photoshop — Режим деформации
Режим деформации

  1. Измените перспективу одним из доступных способов:
  • Сдвинуть метки по углам, изменив четырехугольники нужным образом. К примеру, перспективу на этой фотографии можно изменить так, чтобы края здания «заваливались» в равной мере. Получившаяся перспектива будет больше соответствовать реальному виду здания с угла.
Photoshop — Коррекция перспективы
Коррекция перспективы для равного «заваливания» краев здания.

  • Щелкнув отдельное ребро четырехугольника с нажатой клавишей Shift, можно выпрямить его и оставить вертикальным во время дальнейших операций с перспективой. Такое выпрямленное ребро в режиме Деформация будет выделено желтым цветом. Для более точного контроля над коррекцией перспективы можно перемещать углы плоскостей (метки).
Photoshop — Выравнивание отдельной стороны
Щелкнув отдельное ребро четырехугольника с нажатой клавишей Shift, можно выпрямить его и оставить вертикальным во время дальнейших операций с перспективой. Выбрано самое правое ребро на этой фотографии, которое выделено желтым цветом.

Photoshop — Выбранное ребро выпрямлено
Выбранное ребро выпрямлено. Кроме того, вертикальность ребра сохраняется во время дальнейших операций с перспективой.

Примечание.

Если больше не нужно сохранять вертикальность ребра, еще раз щелкните его с нажатой клавишей Shift.

  • Для автоматической коррекции перспективы можно нажать в режиме деформации следующие значки:

          Автоматически выравнивать вблизи горизонтальных линий

Photoshop — Выравнивание по горизонтали
Выравнивание по горизонтали

          Автоматически выпрямлять вблизи вертикальных линий

Photoshop — Выпрямление по вертикали
Выпрямление по вертикали

          Автоматически выравнивать вертикальные и горизонтальные линии

Photoshop — Выпрямление по горизонтали и по вертикали
Выравнивание по горизонтали и по вертикали

  1. По окончании коррекции перспективы нажмите на значок «Подтвердить деформацию перспективы» ().  

Комбинации клавиш

Следующие комбинации клавиш помогут облегчить коррекцию перспективы.

Клавиши со стрелками

Небольшое перемещение угла четырехугольника (булавки)

H

скрытие сетки при работе в режиме «Деформация»

L

Переключение в режим Макет

W

переключение в режим «Деформация»

Клавиша «Ввод»

В режиме «Макет» клавиша Enter помогает быстро переключиться в режим «Деформация». В режиме «Деформация» клавиша Enter позволяет подтвердить внесенные в перспективу изменения.

Щелчок при нажатой клавише «Shift»

(Режим деформации) Выпрямляет отдельное ребро четырехугольника и сохраняет его вертикальность во время дальнейших операций с перспективой. Если больше не нужно сохранять вертикальность ребра, щелкните его еще раз, удерживая клавишу Shift.

Перетаскивание ребра при нажатой клавише Shift

(Режим деформации) Сохраняет форму плоскости при ее удлинении.

Часто задаваемые вопросы

Можно ли редактировать различные перспективы на одном изображении?

Да. При редактировании различных перспектив на одном изображении можно:

  • Сохранить неизменной перспективу участка изображения, выполняя коррекцию остальной его части. Для этого:
    1. Обведите четырехугольником участок изображения, перспективу которого необходимо сохранить. Убедитесь, что этот четырехугольник не привязан ни к каким другим плоскостям, перспектива которых будет подвергнута коррекции.
    2. Работая с другими плоскостями при коррекции перспективы, не трогайте данный четырехугольник.
  • Изменить перспективу различных частей изображения независимо друг от друга.
    1. Нарисуйте четырехугольники вокруг нужных частей изображения, не соединяя их между собой.
    2. Выполните операции с этими четырехугольниками независимо.

Какой объем видеопамяти необходим для работы функции «Деформация перспективы»?

Photoshop требует не меньше 512 МБ видеопамяти для работы функции «Деформация перспективы» в 16- и 32-битных документах. Если графический процессор имеет 256 МБ видеопамяти, то функцию «Деформация перспективы» можно использовать только в 8-битных документах.

Кроме того, в данный момент функция «Деформация перспективы» не поддерживается для видеокарты nVidia GeForce GT 120.

Перестали появляться подсказки на экране. Как их вернуть?

Выполните следующие действия.

  1. Выберите команду Редактирование > Установки > Основные.
  2. Выберите пункт «Восстановить все сообщения» и нажмите кнопку «ОК».

Можно ли определить различные наборы плоскостей для одного и того же объекта архитектуры?

Да. Как показано на иллюстрациях, есть два разных способа задать плоскости для врат Тадж-Махала:

Photoshop — Плоскости
Один четырехугольник, в общих чертах окружающий объект архитектуры.

Photoshop — Другой набор плоскостей
Другой набор плоскостей, определенный для того же объекта. Такой набор плоскостей дает больше контроля над коррекцией перспективы.

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет