Редактирование текста

  1. Чтобы выбрать текстовый слой, выполните одно из следующих действий:

    • Выберите инструмент «Перемещение»  и дважды щелкните текстовый слой на холсте.
    • Выберите инструмент «Горизонтальный текст»  или «Вертикальный текст» . Выберите текстовый слой на панели «Слои» или щелкните текст на изображении для автоматического выбора текстового слоя.
  2. Поместите курсор вставки в текст и выполните одно из следующих действий.
    • Щелкните, чтобы установить курсор вставки.

    • Выделите один или несколько символов, которые необходимо редактировать.

  3. Введите нужный текст.
  4. Выполните одно из следующих действий, чтобы применить изменения к текстовому слою:

    • Выберите новый инструмент.
    • Щелкните слой на панели «Слои». (Это действие автоматически применяет изменения и выбирает слой.)
    • Нажмите кнопку «Применить»  на панели параметров.

    Чтобы отменить изменения, нажмите кнопку «Отмена»  на панели параметров или клавишу «ESC».

     

Указание фигурных или прямых кавычек

Типографские кавычки, часто называемые фигурными кавычками или просто кавычками, сочетаются с изогнутыми линиями шрифта. Они традиционно используются для обозначения цитат и в качестве апострофов. Прямые кавычки обычно используются в качестве сокращенных обозначений футов и дюймов.

  1. Выберите меню «Редактирование» > «Установки» > «Шрифты» (Windows) или «Photoshop» > «Установки» > «Шрифты» (Mac OS).
  2. В диалоговом окне «Установки» установите или сбросьте флажок «Использовать прямые кавычки».

Применение сглаживания к текстовому слою

Сглаживание позволяет получить символы текста с гладкой кромкой, реализуя частичное заполнение краевых пикселов. В результате этого края текста смешиваются с фоном.

Сглаживание в Photoshop
Сглаживание установлено в значение «Нет» (слева) и «Насыщенное» (справа)

При подготовке текста, который будет отображаться на веб-странице, следует учесть, что сглаживание значительно увеличивает количество цветов в исходном изображении. Это ограничивает возможности по снижению размера файла изображения. Сглаживание может также вызвать появление на краях символов текста случайных цветов. Когда важно снизить размер файла и уменьшить количество цветов, может оказаться предпочтительнее отказаться от сглаживания, несмотря на то, что в изображении останутся зубчатые края. Кроме того, следует рассмотреть возможность использования шрифта большего размера, чем при выводе на печать. Шрифт большого размера в веб-изображениях легче читается и позволяет лучше решить, следует ли применять сглаживание.

Примечание.

При использовании сглаживания при малых размерах и низкой разрешающей способности (например, в веб-изображениях) текст может показаться неразборчивым. Чтобы повысить разборчивость, сбросьте флажок «Дробная ширина» в меню панели «Символ».

  1. Выберите текстовый слой на панели «Слои».
  2. Установите параметр в меню сглаживания на панели параметров или на панели «Символ». Или выберите меню «Слой» > «Текст», а затем выберите параметр во вложенном меню.

    Нет

    Сглаживание не применяется

    Жесткое

    Текст выводится с максимальной резкостью

    Четкое

    Текст выводится с большой резкостью

    Насыщенное

    Текст получается более отчетливым

    Плавное

    Текст получается более плавный

Проверка и исправление орфографии

Во время проверки орфографии в документе Photoshop запрашивает пользователя обо всех словах, отсутствующих в его словаре. Если слово написано правильно, можно подтвердить правильность его написания, добавив это слово в пользовательский словарь. Если слово написано неверно, можно исправить его.

  1. При необходимости выберите язык из ниспадающего меню в нижней части панели «Символ». Это словарь, которым Photoshop пользуется для проверки орфографии.
  2. (Необязательно) Отобразите или разблокируйте текстовые слои. Проверка орфографии не выполняется в скрытых и заблокированных слоях.
  3. Выполните одно из следующих действий.
    • Выберите текстовый слой.

    • Чтобы проверить конкретный текст, выделите его.

    • Чтобы проверить слово, поместите курсор вставки внутрь этого слова.

  4. Выберите меню «Редактирование» > «Проверка орфографии».
  5. Если выбран некоторый текстовый слой и необходимо проверить орфографию только в нем, отмените выделение параметра «Проверить все слои».
  6. Если Photoshop нашел незнакомые слова или другие возможные ошибки, нажмите одну из следующих кнопок.

    Пропустить

    Проверка продолжается, не изменяя текст.

    Пропустить все

    Это слово будет пропущено при дальнейшей проверке.

    Заменить

    Ошибка исправляется. Убедитесь, что в поле «Заменить на» слово написано правильно, а затем нажмите кнопку «Заменить». Если предложено не то слово, выберите другое в поле «Варианты» или введите правильное слово в поле «Заменить на».

    Заменить все

    Все случаи неправильного написания этого слова в документе будут исправлены. Убедитесь, что в поле «Заменить на» слово написано правильно.

    Добавить

    Неопознанное слово сохраняется в словаре, чтобы в дальнейшем появление этого слова не воспринималось как ошибка.

Поиск и замена текста

  1. Выполните одно из следующих действий.
    • Выберите слой, содержащий текст, который вы хотите найти и заменить. Поместите курсор вставки в начало текста, в котором следует произвести поиск.

    • Если имеется несколько текстовых слоев и нужно искать в каждом из них, выберите нетекстовый слой.

    Примечание.

    На панели «Слои» убедитесь, что все текстовые слои, в которых необходимо производить поиск, не скрыты и не заблокированы. Команда «Поиск и замена текста» не проверяет орфографию в скрытых и заблокированных слоях.

  2. Выберите меню «Редактирование» > «Поиск и замена текста».
  3. Введите или вставьте в поле «Найти» текст, который надо найти. Для замены введите новый текст в поле «Заменить на».
  4. Выберите один или несколько параметров для уточнения поиска.

    Искать во всех слоях

    Производит поиск во всех слоях документа. Этот параметр доступен в том случае, если на панели «Слои» выбран нетекстовый слой.

    Вперед

    Производит поиск вперед от курсора вставки в тексте. Отмените выбор этого параметра, чтобы искать во всем тексте слоя, независимо от того, где находится курсор вставки.

    С учетом регистра

    Производит поиск слова или слов, в точности совпадающих с регистром символов в поле «Найти». Например, если этот параметр выбран, то при поиске «PrePress» не будут найдены варианты «Prepress» и «PREPRESS.»

    Только целые слова

    Не рассматриваются случаи, когда искомый текст является частью большего слова. Например, если надо найти «any» как отдельное слово, то слово «many» в результаты поиска не войдет.

  5. Нажмите кнопку «Найти далее», чтобы начать поиск.
  6. Нажмите одну из следующих кнопок.

    Заменить

    Заменяет найденный текст на измененный. Чтобы повторить поиск, нажмите кнопку «Найти текст».

    Заменить все

    Ищет и заменяет все вхождения искомого текста.

    Заменить/Найти

    Заменяет найденный текст измененным и производит поиск следующего совпадения.

Назначение языка тексту

Photoshop использует языковые словари для проверки правильности расстановки переноса. Эти словари используются также при проверке орфографии. Каждый словарь содержит сотни тысяч слов со стандартной разбивкой по слогам. Язык можно назначить как для всего документа, так и для выделенного текста.

Примеры расстановки переноса в разных языках в Photoshop
Примеры расстановки переноса в разных языках

A. «Cactophiles» в английском (США) B. «Cactophiles» в английском (Великобритания) C. «Cactophiles» во французском 
  1. Выполните одно из следующих действий.
    • Чтобы вводить текст с использованием языкового словаря для конкретного языка, выберите словарь из всплывающего меню в левом нижнем углу панели «Символ». После этого вводите текст.

    • Чтобы сменить словарь для существующего текста, выделите этот текст и выберите словарь из ниспадающего меню в левом нижнем углу панели «Символ».

  2. На панели «Символ» выберите нужный словарь из раскрывающегося меню в левом нижнем углу панели.

    Примечание.

    Если вы выберете текст на нескольких языках или если в текстовом слое имеется несколько языков, всплывающее меню панели «Символ» будет недоступно и в нем появится слово «Несколько».

Масштабирование и поворот текста

Настройка масштаба·текста

Можно задать пропорцию между высотой и шириной текста относительно исходной ширины и высоты символов. Для немасштабированных символов эта величина имеет значение 100 %. Некоторые гарнитуры включают настоящий широкий шрифт, символы которого специально разработаны с большей шириной, чем в обычном шрифте. Масштабирование приводит к визуальному искажению символов текста, поэтому обычно предпочтительнее использовать шрифты, специально разработанные как узкие или широкие, если они доступны.

  1. Выделите символы или текстовые объекты, которые необходимо изменить. Если текст не выделен, масштабирование применяется к вновь создаваемому тексту.
  2. В палитре «Символ» задайте значения для параметра «Масштаб по вертикали»  или «Масштаб по горизонтали» .

Поворот текста

  1. Выполните следующие действия.
    • Чтобы вращать текст, выберите текстовый слой и воспользуйтесь любой командой вращения или командой «Свободное трансформирование». Для типа абзаца можно также выделить ограничительную рамку и воспользоваться маркером для вращения текста вручную.

    • Чтобы в вертикальном иероглифическом письме повернуть несколько символов, воспользуйтесь татэ-тю-еко.

Поворот символов вертикального текста

При работе с вертикальным текстом символы можно поворачивать с шагом 90°. Повернутые символы отображаются вертикально, а неповернутые — боком (перпендикулярно линии текста).

Исходный текст (слева) и текст без вертикального поворота (справа) в Photoshop
Исходный текст (слева) и текст без вертикального поворота (справа)

  1. Выберите вертикальный текст, который необходимо поворачивать (или отменить поворот).
  2. Выберите в меню панели «Символ» пункт «Стандартная вертикальная ориентация». Флажок показывает, что параметр выбран.

    Примечание.

    Поворачивать двухбайтовые символы нельзя (полноширинные символы доступны только в китайских, японских и корейских шрифтах). Поворот не затронет двухбайтовые символы, присутствующие в выделенном диапазоне.

Изменение ориентации текстового слоя

Ориентация текстового слоя определяет направление линий текста относительно окна документа (для начала набора) или ограничительной рамки (для типа абзаца). Если текстовый слой ориентирован вертикально, текст выводится сверху вниз. Если горизонтально — слева направо. Не путайте ориентацию текстового слоя с направлением символов в строке текста.

  1. Выберите текстовый слой на панели «Слои».
  2. Выполните одно из следующих действий.
    • Выберите инструмент «Текст» и нажмите кнопку «Ориентация текста»  на панели параметров.

    • Выберите меню «Слой» > «Текст» > «Горизонтальный» или «Слой» > «Текст» > «Вертикальный».

    • Выберите пункт «Изменить ориентацию текста» в меню панели «Символ».

Растрирование текстового слоя

Некоторые команды и инструменты — средства раскраски и фильтры — для текстовых слоев недоступны. Перед их применением текст необходимо растрировать. Растрирование преобразует текстовый слой в обычный и делает его текстовое содержимое нередактируемым. Если выбрана команда или инструмент, которому требуется растрирование слоя, об этом выводится предупреждение. В некоторых предупреждениях есть кнопка ОК, которую можно нажать для растрирования слоя.

  1. Выделите текстовый слой и выберите меню «Слой» > «Растрировать» > «Текст».

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет