图表

  1. Illustrator 用户指南
  2. 了解 Illustrator
    1. Illustrator 简介
      1. Illustrator 的新增功能
      2. 常见问题
      3. Illustrator 系统要求
      4. 适用于 Apple Silicon 的 Illustrator
    2. 工作区
      1. 工作区基础知识
      2. 创建文档
      3. 工具默认键盘快捷键 | Illustrator
      4. 自定键盘快捷键
      5. 画板
      6. 自定义工作区
      7. “属性”面板
      8. 工具库
      9. 设置首选项
      10. 触控工作区
      11. Illustrator 中的 Microsoft Surface Dial 支持
      12. 恢复、还原以及自动化
      13. 旋转视图
      14. 标尺、网格和参考线
      15. Illustrator 中的无障碍功能
      16. 安全模式
      17. 查看图稿
      18. 将 Touch Bar 与 Illustrator 结合使用
      19. 文件和模板
      20. 使用 Adobe Creative Cloud 同步设置
  3. Illustrator iPad 版
    1. Illustrator iPad 版简介
      1. Illustrator iPad 版概述
      2. Illustrator iPad 版常见问题解答
      3. 系统要求 | Illustrator iPad 版
      4. 在 Illustrator iPad 版上可以或无法执行的操作
    2. 工作区
      1. Illustrator iPad 版工作区
      2. 触控快捷键和手势
      3. Illustrator iPad 版的键盘快捷键
      4. 管理应用程序设置
    3. Documents
      1. 在 Illustrator iPad 版中处理文档
      2. 导入 Photoshop 和 Fresco 文档
    4. 选择和排列对象
      1. 创建重复对象
    5. 绘图
      1. 绘制和编辑路径
      2. 绘制和编辑形状
    6. 文字
      1. 处理文字和字体
      2. 在路径上创建文本设计
      3. 添加您自己的字体
    7. 处理图像
      1. 处理图像
    8. 颜色
      1. 应用颜色和渐变
  4. 云文档
    1. 基本信息
      1. 使用 Illustrator 云文档
      2. 共享并协作处理 Illustrator 云文档
      3. 升级 Adobe Illustrator 的云存储空间
      4. Illustrator 云文档 | 常见问题
    2. 故障诊断
      1. Illustrator 云文档创建或存储问题故障诊断
      2. 对 Illustrator 云文档问题进行故障诊断
  5. 添加和编辑内容
    1. 绘图
      1. 绘图基础知识
      2. 编辑路径
      3. 绘制像素级优化的图稿
      4. 使用钢笔、曲率或铅笔工具绘制
      5. 绘制简单线段和形状
      6. 图像描摹
      7. 简化路径
      8. 定义透视网格
      9. 创建 3D 对象
      10. 符号工具和符号组
      11. 调整路径段
      12. 利用简单 5 步设计花朵
      13. 透视图
      14. 符号
      15. 绘制用于 Web 工作流程的像素对齐路径
    2. 颜色
      1. 关于颜色
      2. 选择颜色
      3. 使用和创建色板
      4. 调整颜色
      5. 使用“Adobe Color 主题”面板
      6. 颜色组(协调)
      7. “颜色主题”面板
      8. 重新着色图稿
    3. 绘画
      1. 关于绘画
      2. 使用填色和描边上色
      3. 实时上色组
      4. 渐变
      5. 画笔
      6. 透明度和混合模式
      7. 为对象应用描边
      8. 创建和编辑图案
      9. 网格
      10. 图案
    4. 选择和排列对象
      1. 选择对象
      2. 图层
      3. 编组和扩展对象
      4. 移动、对齐和分布对象
      5. 堆叠对象    
      6. 锁定、隐藏和删除对象
      7. 复制对象
      8. 旋转和镜像对象
    5. 改变对象形状
      1. 裁剪图像
      2. 变换对象
      3. 组合对象
      4. 剪切、分割和裁切对象
      5. 操控变形
      6. 缩放、倾斜和扭曲对象
      7. 混合对象
      8. 使用封套改变形状
      9. 使用效果改变对象形状
      10. 使用 Shaper 和形状生成器工具构建新的形状
      11. 使用实时转角
      12. 增强的支持触摸式变形工作流程
      13. 编辑剪切蒙版
      14. 实时形状
      15. 使用形状生成器工具创建形状
      16. 全局编辑
    6. 文字
      1. 创建文本
      2. 字体和排版
      3. 设置文字格式
      4. 导入和导出文本
      5. 设置段落格式
      6. 特殊字符
      7. 创建路径文字
      8. 字符和段落样式
      9. 制表符
      10. 文本和文字
      11. 查找缺失字体(Typekit 工作流程)
      12. 从 Illustrator 10 更新文本
      13. 阿拉伯语和希伯来语文字
      14. 字体 | 常见问题解答和故障排除提示
      15. 创建 3D 文本效果
      16. 创意排版设计
      17. 缩放和旋转文字
      18. 行距和字距
      19. 连字和换行
      20. 文本增强功能
      21. 拼写和语言词典
      22. 设置亚洲字符格式
      23. 亚洲语言脚本书写器
      24. 使用混合对象创建文本设计
      25. 使用图像描摹创建文本海报
    7. 创建特殊效果
      1. 使用效果
      2. 图形样式
      3. 创建投影
      4. 外观属性
      5. 创建素描和马赛克
      6. 投影、发光和羽化
      7. 效果小结
    8. Web 图形
      1. 创建 Web 图形的最佳做法
      2. 图表
      3. SVG
      4. 创建动画
      5. 切片和图像映射
  6. 导入、导出和存储
    1. 导入
      1. 导入图稿文件
      2. 导入位图图像
      3. 从 Photoshop 导入图稿
      4. 置入多个文件 | Illustrator CC
      5. 取消嵌入图像
      6. 导入 Adobe PDF 文件
      7. 导入 EPS、DCS 和 AutoCAD 文件
      8. 链接信息
    2. Illustrator 中的 Creative Cloud Libraries 
      1. Illustrator 中的 Creative Cloud Libraries
    3. 保存
      1. 存储图稿
    4. 导出
      1. 导出图稿
      2. 收集资源并批量导出
      3. 打包文件
      4. 创建 Adobe PDF 文件
      5. 提取 CSS | Illustrator CC
      6. Adobe PDF 选项
      7. 文件信息和元数据
  7. 打印
    1. 准备打印
      1. 设置打印文档
      2. 更改页面大小和方向
      3. 指定用于裁切或对齐的裁剪标记
      4. 大型画布快速入门
    2. 打印
      1. 叠印
      2. 使用颜色管理进行打印
      3. PostScript 打印
      4. 打印预设
      5. 印刷标记和出血
      6. 打印和存储透明图稿
      7. 陷印
      8. 打印分色
      9. 打印渐变、网格和颜色混合
      10. 白色叠印
  8. 任务自动化
    1. 使用“变量”面板合并数据
    2. 脚本的自动化
    3. 动作的自动化
  9. 故障诊断 
    1. 启动时崩溃问题
    2. 崩溃后恢复文件
    3. 文件问题
    4. GPU 设备驱动程序问题
    5. Wacom 设备问题
    6. DLL 文件问题
    7. 内存问题
    8. 首选项文件问题
    9. 字体问题
    10. 打印机问题
    11. 与 Adobe 共享崩溃报告

在 Illustrator 中,您可以创建不同类型的图表,并且为了满足您的需求,可以对这些图表进行自定义。单击并按住“工具”面板中的图表工具 (),可以看到您能创建的所有不同类型的图表。

在 Illustrator 中创建不同类型的图表
在 Illustrator 中创建不同类型的图表

创建图表

  1. 选择一个图表工具。

    您最初使用的图表工具决定了 Illustrator 生成的图表类型。例如,若要创建柱形图,请选择“柱形图”工具。不过,您可以在稍后轻松地改变图表的类型。有关详细信息,请参阅更改图表类型

  2. 要定义图表的尺寸,请执行以下操作之一:

    • 从您希望放置图表起始位置的角开始,沿对角线向另一个角拖动。按住 Alt 键 (Windows) 或 Option 键 (macOS) 的同时执行拖移操作,可以从中心绘制图表。按住 Shift 键可将图表限制为一个正方形。

    • 单击您要创建图表的位置。输入图表的宽度和高度,然后单击确定

      注意:您定义的尺寸是针对图表的主要部分,并不包括图表的标签和图例。

  3. 在“图表数据”窗口中,输入图表的数据。有关更多详细信息,请参阅输入图表数据

    注意:

    图表数据必须按特定的顺序排列,该顺序将根据图表类型的不同而有所变化。

  4. 单击“应用” 按钮 , 或者按数字键盘上的 Enter 键以创建图表。

    应用您在“图表数据”窗口中输入的值
    应用您在“图表数据”窗口中输入的值

    除非您将其关闭,否则“图表数据”窗口将保持打开。这使您可以在编辑图表数据和画板工作之间轻松转换。

输入图表数据

您可以使用“图表数据”窗口来输入图表的数据。使用图表工具时会自动显示“图表数据”窗口,除非您将其关闭,否则此窗口将保持打开。

图表数据窗口
图表数据窗口

标注

标题

说明

A

输入 文本框

输入数据

B

导入数据

导入保存为文本文件的数据

C

换位行/列

切换数据的列和行

D

切换 x/y

切换图表的 x 和 y 轴

E

单元格样式

调整单元格的列宽或小数精度

F

恢复

恢复您在图表数据中所做的更改

G

应用

应用您在图表数据中所做的更改

  1. 为现有图表显示“图表数据”窗口:使用选择工具选择整个图表,然后选取对象 > 图表 > 数据

  2. 按下列任一方式输入数据:

    • 选择工作表中的单元格,在窗口顶部的文本框中输入数据。按 Tab 键可以输入数据并选择同一行中的下一单元格;按 EnterReturn 键可以输入数据并选择同一列中的下一单元格;使用箭头键可以在单元格之间 移动; 或者,只需单击另一单元格即可将其选中。

    • 从电子表格应用程序(如 Lotus® 1-2-3 或 Microsoft Excel)中复制数据。在“图表数据”窗口中,单击某个单元格(该单元格将作为粘贴您数据的左上单元格),然后选取编辑 > 粘贴

    复制电子表格中的数据并将其粘贴到“图表数据”窗口
    复制电子表格中的数据并将其粘贴到“图表数据”窗口

    • 使用文字处理应用程序创建一个文本文件。输入数据时,通过 Tab 键分隔每个单元格的数据,并通过段落硬回车分隔每一行的数据。数据应当只包含小数点或用作小数点的逗号;否则,无法绘制此数据对应的图表。(例如,输入 732000,而不是 732,000。)在“图表数据”窗口中,单击某个单元格(该单元格将成为您导入数据的左上单元格),然后单击“导入数据” 按钮 ( ) , 并选择文本文件。

    注意:
    • 如果您不小心输入了相反的图表数据(即,将数据输入在行中而不是列中,反之亦然),请单击“换位” 按钮 ( ) ,以便 切换列和行的数据。
    • 要切换散点图的 x 和 y 轴 ,请单击“切换 X/Y” 按钮 ( ) 。
  3. 单击“应用” 按钮 或 按数字键盘上的 Enter 键以重新生成图表。

使用图表标签和数据组

标签是一些词语或数字,用于描述以下两项内容:

  • 要比较的数据组
  • 要比较的数据组所属的类别
“图表数据”窗口中的标签
“图表数据”窗口中的标签

A. 数据组标签 B. 空白单元格 C. 类别标签 

标注

标题

说明

A

数据组标签

在单元格的顶行中输入用于不同数据组的标签。这些标签会在图例中显示。

B

空白单元格

要生成图表的图例,请将左上角的单元格留为空白。

C

类别

在单元格的左列中输入用于类别的标签。

输入标签

  1. 对于柱形、堆积柱形、条形、堆积条形、折线、面积和雷达图,您可以按如下方式在工作表中输入标签:

    • 如果您希望 Illustrator 为图表生成图例,那么删除左上单元格的内容并保留此单元格为空白。

    • 在单元格的顶行中输入用于不同数据组的标签。这些标签将在图例中显示。如果您不希望 Illustrator 生成图例,则不要输入数据组标签。

    • 在单元格的左列中输入用于类别的标签。类别通常为时间单位,如日、月或年。这些标签沿图表的水平轴或垂直轴显示,只有雷达图例外,它的每个标签都产生单独的轴。

    • 要创建只包含数字的标签,请用直式双引号将数字引起来。例如,输入 "2013" 以将年份 2013 用作标签。

    创建只包含数字的标签
    创建只包含数字的标签

    • 要在标签中创建换行符,请使用竖线键将每一行分隔开。例如,键入 合计|销售|2013 可创建以下图表标签:

    合计

    销售

    2013

    在标签中创建换行符
    在标签中创建换行符

输入数据组

输入图表的标签后,您就可以在适当的列中输入各个数据组。

柱形的高度对应于参加比较的数据量值。您可以组合显示正值和负值;负值显示为在水平轴下方延伸的柱形。

柱形图数据
显示正值和负值的柱形图数据

柱形的高度对应于参加比较的数据量值。对于堆积柱形图,数字必须全部为正数或全部为负数.

堆积柱形图数据
堆积柱形图数据

条形的长度对应于参加比较的数据量值。您可以组合显示正值和负值负值显示为在水平轴下方延伸的柱形。

条形图数据
显示正值和负值的条形图数据

条形的长度对应于参加比较的数据量值。对于堆积条形图,数字必须全部为正数或全部为负数。

堆积条形图数据
堆积条形图数据

每列数据对应于折线图中的一条线。可以在折线图中组合显示正值和负值。

折线图数据
显示正值和负值的折线图数据

数值必须全部为正数或全部为负数。输入的每个数据行都与面积图上的填充区域相对应。面积图将每个列的数值添加到先前的列的总数中。因此,即使面积图和折线图包含相同的数据,它们看起来也明显不同。

面积图数据
面积图数据

散点图与其他类型的图表的不同之处在于:两个轴都要对值进行测量;没有类别。

  • 从第一个单元格开始,在沿着工作表顶行且每隔一个的单元格中输入数据组标签。这些标签将在图例中显示。
  • 在第一列中输入 y 轴数据,在第二列中输入 x 轴数据。

注意:为了移除连接线,选项连接数据点已停用。

散点图数据
散点图数据

您可以为饼图整理类似于其他图表的数据组。但是,工作表中的每行数据都可以生成单独的图表。

  • 输入柱形图、堆积柱形图、条形图、堆积条形图、折线图、面积图和雷达图的数据组标签。如果要生成图表名称,则输入类别标签。
  • 要创建单一的饼图,请只绘制一行均为正值或均为负值的数据。
单个饼图数据
单个饼图数据

  • 要创建多个饼图,则绘制均为正值或均为负值的其他数据行。默认情况下,单独饼图的大小与每个图表数据的总数成比例。
多个饼图数据
多个饼图数据

每个数字都被绘制在轴上,并且连接到相同轴的其他数字上,以创建出一个“网”。可以在雷达图中组合显示正值和负值。

雷达图数据
显示正值和负值的雷达图数据

调整列宽或小数位数

要在列中查看更多或更少的位数,请调整列宽。这项更改不影响图表中的列宽。

调整列宽

  1. 执行下列操作之一:

    • 单击“单元格样式”按钮 (),并在“列宽度”文本框中输入一个介于 0 和 20 之间的值。

    • 将指针放置到您要调整的列的边缘。指针会变为双箭头 。然后将手柄拖动到所需的位置。

    调整“列宽度”文本框以在列中查看更少的位数。

    调整“列宽度”文本框以在列中查看更多的位数。

调整单元格的小数精度

  1. 单击“单元格样式”按钮 (),并在“小数位数”文本框中输入一个介于 0 和 10 之间的值。

    当默认值为 2 位小数时,在单元格中输入的数字 2000 会在“图表数据”窗口框中显示为 2000.00

    当默认值为 4 位小数时,在单元格中输入的数字 2000 则在“图表数据”窗口框中显示为 2000.0000

组合不同的图表类型

您可以在一个图表中组合显示不同的图表类型。例如,可以让一组数据显示为柱形图,而其他数据组显示为折线图。除了散点图之外,您可以将任何类型的图表与其他图表组合。散点图不能与其他任何图表类型组合。

将柱形图和折线图结合到一个图表中
将柱形图和折线图结合到一个图表中

  1. 选择“编组选择”工具 ()。

  2. 单击要更改图表类型的数据的图例。
  3. 在不移动图例的“编组选择”工具指针的情况下,再次单击。选定用图例编组的所有柱形。
  4. 执行下列操作之一:

    • 选择对象  > 图表  > 类型
    • 双击“工具”面板中的图表工具。
  5. 选择所需的图表类型和选项。
    注意:
    • 如果图表使用多个图表类型,则可以沿右轴使用一个数据组,沿左轴使用其他数据组。这样,每个轴都可以测量不同的数据。
    • 如果和其他图表类型一起使用堆积柱形图,则确保对于由堆积柱形图表示的所有数据组都使用相同的轴。如果有的数据组使用右轴而其他数据组使用左轴,则柱形高度可能会令人误解或发生重叠。

设置图表格式和自定图表

您可以通过各种方式设置图表格式。例如,您可以更改图表轴的外观和位置,添加投影和移动图例。

此外,您还可以更改底纹颜色、字体和文字样式;移动、对称、倾斜、旋转或缩放图表的任意部分或所有部分;并且可以自定列和标记的设计。您可以对图表应用透明度、渐变、混合、画笔描边、图表样式和其他效果。需要始终应用这类自定,因为重新生成图表后会移除这些效果。

图表是一个与其数据相关的编组对象。取消图表编组可能会禁止您进行所需的更改。要编辑图表,请使用“直接选择”工具 () 或“编组选择”工具 (),在不取消图表编组的情况下,选择要编辑的部分。

图表的元素彼此间互相关联。带图例的整个图表是一个组。所有数据组是图表的次组;相反,每个带图例框的数据组是所有数据组的次组。每个值都是其数据组的次组,等等。请避免将图表内的对象取消编组或重新编组。

  1. 选择“编组选择”工具 ()。

  2. 单击要选择的柱形的图例。
  3. 在不移动图例的“编组选择”工具指针的情况下,再次单击。选定用图例编组的所有柱形。

    还可以通过单击组的一部分来选择一个组,通过再次单击来选择用图例编组的柱形、单击第三次来选择图例。从层次的下一个组开始,每次单击都将编组对象的另一图层添加到选区中。您可以按组的数量来单击组以将其添加到所选对象。

  4. 要取消选择部分选定的编组,请选择“直接选择”工具 (),并在按住 Shift 键的同时单击对象。

  1. 使用“选择”工具 () 选择您创建的图表。

  2. 请执行以下操作之一:

    • 选择对象 > 变换 > 缩放,或双击“缩放”工具 () 并在“缩放”对话框中指定所需的值。
    • 选择“缩放”工具 () 并在文档窗口中拖移到任意位置,直到对象变为所需的大小时为止。

    有关详细信息,请参阅缩放、倾斜和扭曲对象

  1. 使用“选择”工具 () 选择图表。

  2. 执行下列操作之一:

    • 单击“属性”面板中的图表选项
    • 选择对象  > 图表  > 类型
    • 双击“工具”面板中的图表工具。
  3. 在“图表类型”对话框中,单击与所需图表类型相对应的按钮,然后单击确定

    注意:

    一旦用渐变的方式对图表对象进行上色,更改图表类型就会导致意外的结果。要防止不需要的结果,请直到图表结束再应用渐变,或使用“直接选择”工具选择渐变上色的对象,并用印刷色上色这些对象;然后重新应用原始渐变。

除了饼图之外,所有的图表都有显示图表的测量单位的数值轴。您可以选择在图表的一侧显示数值轴或者两侧都显示数值轴。条形、堆积条形、柱形、堆积柱形、折线和面积图也有在图表中定义数据类别的类别轴

您可以控制每个轴上显示多少个刻度线,改变刻度线的长度,并将前缀和后缀添加到轴上的数字。

  1. 使用“选择”工具 () 选择图表。

  2. 执行下列操作之一:

    • 单击“属性”面板中的图表选项
    • 选择对象  > 图表  > 类型
    • 双击“工具”面板中的图表工具。
  3. 要更改数值轴的位置,请选择“数值轴”菜单中的选项。

  4. 要设置刻度线和标签的格式,请从对话框顶部的弹出菜单中选择一个轴,并设置如下选项:

    刻度值

    确定数值轴、左轴、右轴、下轴或上轴上的刻度线的位置。选择“忽略计算出的值”以手动计算刻度线的位置。创建图表时接受数值设置或者输入最小值、最大值和标签之间的刻度数量。

    示例:输入最小值、最大值和标签之间的刻度量

    示例:要确定刻度线的位置,请指定刻度值。

    刻度线

    确定刻度线的长度和每个刻度之间刻度线的数量。对于类别轴,选择“在标签之间绘制刻度线”以在标签或列的任意一侧绘制刻度线,或者取消选择将标签或列上的刻度线居中的选项。

    示例:选择“无”作为刻度线的长度

    示例:选择“短”作为刻度线的长度

    示例:选择“全宽”作为刻度线的长度

    添加标签

    确定数值轴、左轴、右轴、下轴或上轴上的数字的前缀和后缀。例如,您可以将美元符号或百分号添加到轴数字。

    示例:添加美元符号作为左轴上的数字的前缀。

    示例:添加美元符号作为左轴上的数字的后缀。

如果图表在两侧都有数值轴,则可以为每个轴都指定不同的数据组。这样使 Illustrator 可以为每个轴生成不同的比例。在相同图表中组合不同的图表类型时此技术特别有用。

  1. 选择“编组选择”工具 ()。

  2. 单击要指定给轴的数据组的图例。

  3. 在不移动图例的“编组选择”工具指针的情况下,再次单击。选定用图例编组的所有柱形。

  4. 执行下列操作之一:

    • 单击“属性”面板中的图表选项
    • 选择对象  > 图表  > 类型
    • 双击“工具”面板中的图表工具。
  5. 在“数值轴”弹出菜单中,选择要指定数据的轴。

  6. 单击确定

对于柱形、堆积柱形、条形和堆积条形图,您可以调整图表中每个柱形或条形之间的空间数量。您还可以调整图表中数据类别或数据群集之间的空间数量。对于折线、散点和雷达图,您可以调整线段和数据点的外观。

  1. 使用“选择”工具 () 选择图表。

  2. 执行下列操作之一:

    • 单击“属性”面板中的图表选项
    • 选择对象  > 图表  > 类型
    • 双击“工具”面板中的图表工具。
  3. 要调整柱形、堆积柱形、条形或堆积条形图中柱形和条形之间的空间,在“列宽度”、“条宽度”或“群集宽度”文本框中输入 1% 到 1000% 之间的一个值。

    大于 100% 的数值会导致柱形、条形或群集相互重叠。小于 100% 的值会在柱形、条形或群集之间保留空间。值为 100% 时,会使柱形、条形或群集相互对齐。

    示例:调整群集宽度

    示例:调整列宽

  4. 要调整折线图、散点图和雷达图中的线段和数据点,请设置以下选项:

    • 标记数据点:在每个数据点上放置方形标记。
    • 连接数据点:绘制可以更轻松地查看数据间关系的线段。
    • 线段边到边跨 X 轴:沿水平 (x) 轴从左到右绘制跨越图表的线段。该选项不适用于散点图。
    • 绘制填充线:根据“线宽”文本框中输入的值可创建更宽的线段,并且“绘制填充线”还会根据该系列数据的规范来确定用何种颜色填充线段。只有在选中“连接数据点”时,此选项才有效。

    示例:标记散点图中的数据点

    示例:标记和连接散点图中的数据点

    示例:沿水平轴横跨边到边的线段

    示例:绘制填充线并调整其宽度

  5. 要更改柱形、条形和线段重叠的方式,请设置以下选项:

    第一行在前:控制图表中数据的类别或群集 重叠 的方式(在“群集宽度”大于 100% 的情况下)。当使用柱形或条形图时,该选项最有帮助。

    第一列在前:在“图表数据”窗口的顶部,放置与第一列数据相对应的柱形、条形或线段。该选项还可以确定哪一列在“列宽”大于 100% 的 柱形图 和堆积柱形图的顶部,哪一列在“条形宽度”大于 100% 的条形图和堆积条形图的顶部。

    注意:

    对于面积图,始终选择 第一列 在前。如果您没有选择此选项,某些面积可能不会显示。

您可以更改图例的位置以及在饼图中对楔形进行排序的方式。还可以指定显示多个饼图的方式。

  1. 使用“选择”工具 () 选择图表。

  2. 执行下列操作之一:

    • 单击“属性”面板中的图表选项
    • 选择对象  > 图表  > 类型
    • 双击“工具”面板中的图表工具。
  3. 请执行下列任一操作:
    • 要更改图例的位置,请在图例中选择以下选项之一:
      • 无图例:完全忽略图例。
      • 标准图例:在图表外侧放置列标签;这是默认设置。将饼图与其他种类的图表组合显示时使用此选项。
      • 楔形图例:将标签插入相应的楔形中。
    更改图例的位置
    更改图例的位置

    A. 标准图例 B. 楔形图例 C. 无图例 

    • 要指定多个饼图的显示方式,请在位置中选择以下选项之一:

    比例:按比例调整图表的大小。

    相等:让所有饼图都有相同的直径。

    堆积:每个饼图相互堆积,每个图表按相互比例调整大小。

    • 要指定楔形的排序方式,请在排序中选择以下选项之一:

    全部:在饼图顶部按顺时针顺序从最大值到最小值,对所选饼图的楔形进行排序。

    第一个:对所选饼图的楔形进行排序,以便将第一幅饼图中的最大值放置在第一个楔形中,其他将按从最大到最小的顺序排序。所有其他图表将遵循第一幅图表中楔形的顺序。

    :从图表顶部按顺时针方向输入值的顺序,将所选饼图的楔形排序:

    提示:默认情况下,百分比和图例均上色为黑色。如果带深色背景的饼图楔形遮住了图例,则重新上色深色背景。使用编组选择工具选择深色的饼图楔形,然后使用“颜色”面板或“色板”面板为楔形上色。

默认情况下,图例显示在图表右侧。但是,您可以选择在图表顶部水平显示图例。

  1. 使用“选择”工具 () 选择图表。

  2. 执行下列操作之一:

    • 单击“属性”面板中的图表选项
    • 选择对象  > 图表  > 类型
    • 双击“工具”面板中的图表工具。
  3. 在“图表类型”对话框中,选择在顶部添加图例,然后单击确定

为图表的标签和图例生成文本时,Illustrator 使用默认的字体和字体大小。然而,您可以轻松地更改文字格式以将视觉目标添加到图表中。

  1. 选择“编组选择”工具 ()。

  2. 单击一次以选择要更改文字的基线;单击两次以选择所有的文字。
  3. 根据需要更改文字属性。

可以在图表中的柱形、条形或线段后面应用投影,也可以对整个饼图应用投影。

  1. 使用“选择”工具 () 选择图表。

  2. 执行下列操作之一:

    • 单击“属性”面板中的图表选项
    • 选择对象  > 图表  > 类型
    • 双击“工具”面板中的图表工具。
  3. 在“图表类型”对话框中,选择添加投影,然后单击确定

将照片和符号添加到图表

关于图表设计

您可以使用图表设计,将插图添加到柱形和标记中。图表设计可以是图表中表示值的简单绘图、徽标和其他符号;它们还可以是包含图案和参考线对象的复杂对象。Illustrator 包含许多预设的图表设计。此外,您还可以创建新的图表设计,并将它们存储在“图表设计”对话框中。

您可以通过以下方式对柱形应用图表设计:

垂直缩放设计

在垂直方向进行伸展或压缩。它的宽度没有改变。

一致缩放设计

在水平和垂直方向同时缩放。设计的水平间距不是为不同宽度而调整的。

重复设计

堆积设计以填充柱形。您可以指定每个设计表示的值,以及您是否要截断或缩放表示分数字的设计。

 

示例:截断设计

示例:缩放设计

局部缩放设计

与垂直缩放设计类似,但可以在设计中指定伸展或压缩的位置。例如,如果正在使用一个人表示数据,您只可以伸展或压缩身体,而不是头部。使用“垂直压缩”选项就可以缩放整个人。

导入柱形或标记设计

Illustrator 包含多种预设的可在图表中使用的设计。还可以在文档之间转换您创建的图表设计。

  1. 选择窗口 > 色板库 > 其它库

  2. 执行下列操作之一:
    • 要导入预设的图表设计,请导航到 Illustrator 应用程序文件夹中的 Cool Extras/Sample Files/Graph Designs 文件夹。然后选择图表设计文件,并单击打开

    • 要从另一文档导入图表设计,请选择此文档,并单击打开

      最初,显示的全部内容是具有来自导入文件的颜色、渐变和图案的新面板。但是,当打开“图表柱形”或“图表标记”对话框时,将可以使用导入的图表设计。

创建柱形设计

  1. 创建作为设计中最后面的对象的矩形。矩形表示图表设计的边界。
    注意:

    复制并粘贴图表中最小的柱形,将其用作设计的定界矩形。

  2. 根据需要上色矩形,或者用“无”对矩形填色和描边,以使矩形不可见。

  3. 使用任意绘图工具来创建设计,或者在矩形前面放置现有的设计。
  4. 使用“选择”工具 (),选择整个设计,其中包括矩形。

  5. 选择对象 > 编组,以将设计分组。

  6. 选择对象 > 图表 > 设计

  7. 单击新建设计。所选设计的预览将会显示。只有最后面矩形内部的设计部分才是可见的,但是在图表中使用时会显示整个设计。

  8. 单击重命名,为设计命名。

    注意:

    创建图表设计的过程与创建图案类似。

创建局部缩放柱形设计

  1. 创建作为设计中最后面的对象的矩形。此矩形是图表设计的边界。
  2. 使用任意一种绘图工具来创建设计,或者在矩形前面置入现有的设计。
  3. 使用“钢笔”工具 绘制一条水平线段来定义伸展或压缩设计的位置。

  4. 选择设计的所有部分,包括水平线段。
  5. 选择对象 > 编组,将设计分组。

  6. 使用“直接选择”工具 () 或“编组选择”工具 () 来选择水平线段。务必要只选择水平线段。

  7. 选择视图 > 参考线 > 建立参考线

  8. 选择视图 > 参考线 > 锁定参考线来移除“锁定”旁边的勾选标记,这样可以解锁参考线。移动周围的设计以确保参考线和设计一起移动。

  9. 使用“选择”工具 () 选择整个设计。

  10. 选择对象 > 图表 > 设计

  11. 单击新建设计。所选设计的预览将会显示。

  12. 单击重命名,为设计命名。

对图表应用柱形设计

  1. 创建或导入柱形设计。
  2. 使用“编组选择”工具 () 来选择您要用设计填充的柱形或条形,或者选择整个图表。

  3. 选择对象 > 图表 > 柱形

  4. 选择柱形设计类型。
    注意:

    如果选择重复柱形类型,则在“每个设计表示”文本框中输入一个值。并在“对于分数”弹出菜单中,选择是截断还是缩放设计的分数字。“截断设计”根据需要切断了顶部设计的分数字;“缩放设计”可缩放上一个设计以适合柱形。

  5. 选择要使用的设计。所选设计的预览将会显示。
  6. 单击确定

在柱形设计中添加总计

  1. 创建柱形设计。
  2. 选择“文字”工具 。将指针放在对设计进行定义的矩形内或矩形附近要用来显示值的位置。

    例如,您可以将值放置在设计的上侧、下侧、左侧或右侧。

  3. 单击并键入一个百分比符号 (%),后跟两个介于 0 和 9 之间的数字。这些数字控制如何显示数据。

    第一个数字确定在小数点之前显示位数的数目。例如,如果总计为 122,则数字 3 将显示 122。如果输入的第一个数字为 0,则程序会根据值的需要添加位数。

    第二个数字确定在小数点之后显示位数的数目。根据需要添加零并对数值四舍五入。根据需要多少位数,可以更改这些数字。

  4. 要更改文字属性,请选择窗口 > 文字 > 字符,指定所需属性,然后关闭面板。

  5. 要对齐小数点,请选择窗口 > 文字 > 段落,并单击“右对齐文本”按钮。

  6. 使用“选择”工具 (),选择整个设计,其中包括矩形和任何文字。

  7. 选择对象 > 编组,将设计分组。

  8. 选择对象 > 图表 > 设计

  9. 单击新建设计。您可以看到所选设计的预览效果。

  10. 单击重命名,为设计命名。

创建标记设计

  1. 从图表选择并复制一个标记矩形,并将其粘贴到要创建设计的位置。这将是图表设计中最后面的对象,并将建立标记大小。
  2. 即使标记图稿比您复制的标记矩形大,也可在图表中将标记图稿调整为您所希望的大小。
  3. 一旦您按照自己需要的方式获得了标记设计,请选择此设计,选择对象 > 图表 > 设计,并单击新建设计

  4. 单击重命名,为设计命名。

对折线图或散点图应用标记设计

  1. 创建或导入柱形设计。
  2. 使用“编组选择”工具 (),选择图表(您要用某个设计来取代该图表)中的标记和图例。不要选择任何线段。

  3. 选择对象 > 图表 > 标记。选择一个设计,然后单击确定

    缩放此设计,以便设计中最后面的矩形与线段或散点图上默认正方形标记的大小相同。

重新使用图表设计

您可以重新使用您以前创建的图表设计,并编辑此图表设计使其成为新设计。如果您有原始图稿,您可以替代它然后使用“图表设计”对话框重新命名此设计。

如果您没有定义为图表设计的原始图稿,您可以通过将图表设计粘贴到图稿中来获得原始图稿。

  1. 选择选择 > 取消选择,以取消选择所有图稿。

  2. 选择对象 > 图表 > 设计

  3. 选择要粘贴到图稿中的图表设计,并单击粘贴设计

  4. 单击确定。图稿设计会粘贴到您的图稿中。您现在可以编辑此图稿设计并将其定义为新的图稿设计。

Adobe 徽标

登录到您的帐户