选择对象

  1. Illustrator 用户指南
  2. 了解 Illustrator
    1. Illustrator 简介
      1. Illustrator 的新增功能
      2. 常见问题
      3. Illustrator 系统要求
      4. 适用于 Apple Silicon 的 Illustrator
    2. 工作区
      1. 工作区基础知识
      2. 创建文档
      3. 工具默认键盘快捷键 | Illustrator
      4. 自定键盘快捷键
      5. 画板
      6. 自定义工作区
      7. “属性”面板
      8. 设置首选项
      9. 触控工作区
      10. Illustrator 中的 Microsoft Surface Dial 支持
      11. 恢复、还原以及自动化
      12. 旋转视图
      13. 标尺、网格和参考线
      14. Illustrator 中的无障碍功能
      15. 安全模式
      16. 查看图稿
      17. 将 Touch Bar 与 Illustrator 结合使用
      18. 文件和模板
      19. 使用 Adobe Creative Cloud 同步设置
  3. Illustrator iPad 版
    1. Illustrator iPad 版简介
      1. Illustrator iPad 版概述
      2. Illustrator iPad 版常见问题解答
      3. 系统要求 | Illustrator iPad 版
      4. 在 Illustrator iPad 版上可以或无法执行的操作
    2. 工作区
      1. Illustrator iPad 版工作区
      2. 触控快捷键和手势
      3. Illustrator iPad 版的键盘快捷键
      4. 管理应用程序设置
    3. 文档
      1. 在 Illustrator iPad 版中处理文档
      2. 导入 Photoshop 和 Fresco 文档
    4. 选择和排列对象
      1. 创建重复对象
      2. 混合对象
    5. 绘图
      1. 绘制和编辑路径
      2. 绘制和编辑形状
    6. 文字
      1. 处理文字和字体
      2. 在路径上创建文本设计
      3. 添加您自己的字体
    7. 处理图像
      1. 对栅格图像进行矢量化
    8. 颜色
      1. 应用颜色和渐变
  4. 云文档
    1. 基本信息
      1. 使用 Illustrator 云文档
      2. 共享并协作处理 Illustrator 云文档
      3. 升级 Adobe Illustrator 的云存储空间
      4. Illustrator 云文档 | 常见问题
    2. 故障诊断
      1. Illustrator 云文档创建或存储问题故障诊断
      2. 对 Illustrator 云文档问题进行故障诊断
  5. 添加和编辑内容
    1. 绘图
      1. 绘图基础知识
      2. 编辑路径
      3. 绘制像素级优化的图稿
      4. 使用钢笔、曲率或铅笔工具绘制
      5. 绘制简单线段和形状
      6. 图像描摹
      7. 简化路径
      8. 定义透视网格
      9. 符号工具和符号组
      10. 调整路径段
      11. 利用简单 5 步设计花朵
      12. 透视图
      13. 符号
      14. 绘制用于 Web 工作流程的像素对齐路径
    2. 3D 效果和 Adobe Substance 材质
      1. 关于 Illustrator 中的 3D 效果
      2. 创建 3D 图形
      3. 创建 3D 对象
      4. 创建 3D 文本
    3. 颜色
      1. 关于颜色
      2. 选择颜色
      3. 使用和创建色板
      4. 调整颜色
      5. 使用“Adobe Color 主题”面板
      6. 颜色组(协调)
      7. “颜色主题”面板
      8. 重新着色图稿
    4. 绘画
      1. 关于绘画
      2. 使用填色和描边上色
      3. 实时上色组
      4. 渐变
      5. 画笔
      6. 透明度和混合模式
      7. 为对象应用描边
      8. 创建和编辑图案
      9. 网格
      10. 图案
    5. 选择和排列对象
      1. 选择对象
      2. 图层
      3. 编组和扩展对象
      4. 移动、对齐和分布对象
      5. 堆叠对象    
      6. 锁定、隐藏和删除对象
      7. 复制对象
      8. 旋转和镜像对象
    6. 改变对象形状
      1. 裁剪图像
      2. 变换对象
      3. 组合对象
      4. 剪切、分割和裁切对象
      5. 操控变形
      6. 缩放、倾斜和扭曲对象
      7. 混合对象
      8. 使用封套改变形状
      9. 使用效果改变对象形状
      10. 使用 Shaper 和形状生成器工具构建新的形状
      11. 使用实时转角
      12. 增强的支持触摸式变形工作流程
      13. 编辑剪切蒙版
      14. 实时形状
      15. 使用形状生成器工具创建形状
      16. 全局编辑
    7. 文字
      1. 创建文本
      2. 字体和排版
      3. 设置文字格式
      4. 导入和导出文本
      5. 设置段落格式
      6. 特殊字符
      7. 创建路径文字
      8. 字符和段落样式
      9. 制表符
      10. 文本和文字
      11. 查找缺失字体(Typekit 工作流程)
      12. 从 Illustrator 10 更新文本
      13. 阿拉伯语和希伯来语文字
      14. 字体 | 常见问题解答和故障排除提示
      15. 创建 3D 文本效果
      16. 创意排版设计
      17. 缩放和旋转文字
      18. 行距和字距
      19. 连字和换行
      20. 文本增强功能
      21. 拼写和语言词典
      22. 设置亚洲字符格式
      23. 亚洲语言脚本书写器
      24. 使用混合对象创建文本设计
      25. 使用图像描摹创建文本海报
    8. 创建特殊效果
      1. 使用效果
      2. 图形样式
      3. 创建投影
      4. 外观属性
      5. 创建素描和马赛克
      6. 投影、发光和羽化
      7. 效果小结
    9. Web 图形
      1. 创建 Web 图形的最佳做法
      2. 图表
      3. SVG
      4. 创建动画
      5. 切片和图像映射
  6. 导入、导出和存储
    1. 导入
      1. 导入图稿文件
      2. 导入位图图像
      3. 从 Photoshop 导入图稿
      4. 置入多个文件 | Illustrator CC
      5. 取消嵌入图像
      6. 导入 Adobe PDF 文件
      7. 导入 EPS、DCS 和 AutoCAD 文件
      8. 链接信息
    2. Illustrator 中的 Creative Cloud Libraries 
      1. Illustrator 中的 Creative Cloud Libraries
    3. 保存
      1. 存储图稿
    4. 导出
      1. 导出图稿
      2. 收集资源并批量导出
      3. 打包文件
      4. 创建 Adobe PDF 文件
      5. 提取 CSS | Illustrator CC
      6. Adobe PDF 选项
      7. 文件信息和元数据
  7. 打印
    1. 准备打印
      1. 设置打印文档
      2. 更改页面大小和方向
      3. 指定用于裁切或对齐的裁剪标记
      4. 大型画布快速入门
    2. 打印
      1. 叠印
      2. 使用颜色管理进行打印
      3. PostScript 打印
      4. 打印预设
      5. 印刷标记和出血
      6. 打印和存储透明图稿
      7. 陷印
      8. 打印分色
      9. 打印渐变、网格和颜色混合
      10. 白色叠印
  8. 任务自动化
    1. 使用“变量”面板合并数据
    2. 脚本的自动化
    3. 动作的自动化
  9. 故障诊断 
    1. 启动时崩溃问题
    2. 崩溃后恢复文件
    3. 文件问题
    4. GPU 设备驱动程序问题
    5. Wacom 设备问题
    6. DLL 文件问题
    7. 内存问题
    8. 首选项文件问题
    9. 字体问题
    10. 打印机问题
    11. 与 Adobe 共享崩溃报告

要组织和排列您的图稿,请使用工具以便精确地选择、放置和堆叠对象。您可以测量和对齐对象;编组对象以便能够将其视为一个单元进行操作;有选择地隔离、锁定或隐藏对象。

选区选项和首选项

用于选择对象的选项

要想修改某个对象,必须先将其与周围的对象区分开来。只需选择对象,即可加以区分。只要选择了对象或者对象的一部分,即可对其进行编辑。

Illustrator 提供以下选择方法和工具:

“图层”面板

可让您快速而准确地选择单个或多个对象。您既可以选择单个对象(即使其位于组中),也可以选择图层中的所有对象,还可以选择整个组。

选择工具

可让您通过单击或拖动对象和组将其选中。您还可以在组中选择组或在组中选择对象。

编组选择工具

可让您在一个组中选择单个对象,在多个组中选择单个组,或在图稿中选择一个组集合。每多单击一次,就会添加层次结构内下一组中的所有对象。

透视选区工具

可将对象和文本置于透视中,切换现用平面,移动透视中的对象,并在垂直方向上移动对象。

套索工具

可让您选择对象、锚点或路径段,方法是围绕整个对象或对象的一部分拖动鼠标。

魔棒工具

可让您通过单击对象来选择具有相同的颜色、描边粗细、描边颜色、不透明度或混合模式的对象。

实时上色选择工具

可让您选择“实时上色”组的表面(由路径包围的区域)和边缘(路径交叉部分)。

选择命令

(位于“选择”菜单中)可让您快速选择或取消选择所有对象,以及基于对象相对其他对象的位置来选择对象。您可以选择属于某一特定类型或共享某些特定属性的所有对象,然后存储或加载所选对象。还可以选择现用画板中的所有对象。

指定选择首选项

选择复杂图像中的路径和点可能会具有一定的难度。使用“选择”和“锚点显示”首选项,可以指定像素选择的容差,并选择其他可使得选择特定文档更加容易的选项。

  1. 选择编辑 > 首选项 > 选择和锚点显示 (Windows),或 Illustrator > 首选项 > 选择和锚点显示 (macOS)。

  2. 指定下列任一“选择”选项:

    容差

    指定用于选择锚点的像素范围。较大的值会增加锚点周围区域(可通过单击将其选定)的宽度。

    仅按路径选择对象

    指定是否可以通过单击对象中的任意位置来选择填充对象,或者是否必须单击路径。

    对齐点

    将对象对齐到锚点和参考线。指定在对齐时对象与锚点或参考线之间的距离。

隔离图稿以进行编辑

隔离模式可隔离对象,以便您能够轻松选择和编辑特定对象或对象的某些部分。可以隔离下列任何对象:图层、子图层、组、符号、剪切蒙版、复合路径、渐变网格和路径。

在隔离模式下,可以相对于隔离的图稿执行以下操作:删除、替换和添加新的图稿。退出隔离模式时,替换的或新的图稿便会添加到原始隔离图稿所在的相同位置。隔离模式会自动锁定其他所有对象,因此您所做的编辑只会影响处于隔离模式的对象 - 您不必担心对象位于哪个图层上,也不必手动锁定或隐藏不希望受到编辑影响的对象。

注意:

当编辑符号的定义时,符号将在隔离模式中显示。(请参阅编辑或重新定义符号。)

隔离图稿
隔离蝴蝶编组

当隔离模式处于活动状态时,隔离的对象将以全色显示,而图稿的其余部分则会变成灰色。隔离对象的名称和位置(有时称为“面包屑”)会显示在隔离模式边框中,而图层面板则仅显示隔离的子图层或组中的图稿。当退出隔离模式时,其他图层和组将重新显示在图层面板中。

可以在轮廓模式或预览模式下查看隔离的对象。

请观看视频使用隔离模式来隔离图稿以进行编辑

隔离路径、对象或组

  1. 执行下列操作之一:

    • 使用选择工具双击路径或组。

    • 选择组、对象或路径,然后单击控制面板中的隔离选中的对象按钮

    • 右键单击 (Windows) 或按住 Control 键单击 (macOS) 组,然后单击隔离选定的组

    • 右键单击 (Windows) 或按住 Control 键单击 (macOS) 组,然后单击隔离选中的路径

    • 图层面板中选择组、对象或路径,然后从图层面板菜单中选择进入隔离模式,或单击控制面板中的隔离选中的对象按钮。

隔离组内的路径

  1. 使用直接选择工具,或通过在图层面板中定位来选择路径。

  2. 单击控制面板中的隔离选中的对象按钮

隔离图层或子图层

  1. 图层面板中选择图层或子图层,然后从图层面板菜单中单击进入隔离模式

退出隔离模式

  1. 执行下列操作之一:

    • Esc 键。

    • 单击退出隔离模式 一次或多次(如果您隔离了一个子图层,则单击一次会后退一级,单击两次会退出隔离模式)。

    • 单击隔离模式栏中的任意位置。

    • 单击控制面板中的退出隔离模式

    • 使用选择工具,在隔离组的外部双击。

    • 右键单击 (Windows) 或按住 Control 键单击 (macOS),然后单击退出隔离模式

选择下方对象

在 Illustrator 中,您可以通过按住 Ctrl 键 (Windows) 或 Command 键 (macOS) 并单击来选择位于其他对象下方的对象。第一次按住 Ctrl 键 (Windows) 或 Command 键 (macOS) 并单击时,指针会变成选择下方。接下来再次按住 Ctrl 键 (Windows) 或 Command 键 (macOS) 并单击时,将可以在指针位置正下方的对象之间进行选择。

按堆叠顺序选择下一个对象

您可以选择在堆叠顺序中位于所选对象上方或下方的对象。在隔离模式下,这些命令不起作用。

  1. 若要选择所选对象上方或下方距离最近的对象,请单击选择 > 上方的下一个对象选择 > 下方的下一个对象

使用图层面板选择对象

  1. 图层面板中,找到您要选择的对象。您可能必须单击切换箭头以扩展图层或组,或是在面板中上下滚动以定位对象。

  2. 请执行下列任一操作:

    • 要选择单一对象,请在对象的选择列(位于目标按钮与滚动条之间)中单击。按住 Shift 单击以向选区添加对象或从中删除对象。

    • 要选择位于图层或组中的所有图稿,请在图层或组的选择列中单击。

    • 要基于当前所选图稿来选择其所在图层中的所有图稿,请单击选择 > 对象 > 同一图层上的所有对象

      面板中每一个所选项目的旁边都会出现选择颜色框。

使用选区、套索或魔棒工具选择对象

用选择工具选择对象

  1. 选择选择工具

  2. 请执行下列任一操作:

    • 单击一个对象。

    • 在一个或多个对象的周围拖放鼠标,形成一个选框,圈住所有对象或部分对象。

  3. 要从选区中添加或移除对象,请按住 Shift 键并单击,或者围绕您要添加或移除的对象拖动鼠标。

    提示:当选择工具位于取消选择的对象或组上方时,其形状将变为 。当“选择”工具位于选中的对象或组上方时,其形状将变为 。当“选择”工具位于取消选择的对象的锚点上方时,箭头的旁边将会出现一个空心方框

    选择对象
    用拖放鼠标的方式来框选对象

使用套索工具选择对象

  1. 选择套索工具

  2. 绕对象或穿越对象拖动鼠标。

使用魔棒工具选择对象

使用魔棒工具选择文档中具有相同或相似填充属性(如颜色和图案)的所有对象。

您可以自定魔棒工具,以基于描边粗细、描边颜色、不透明度或混合模式来选择对象。您还可以更改魔棒工具所用的容差来识别类似对象。

使用魔棒工具基于填充颜色选择对象

  1. 选择魔棒工具

  2. 执行下列操作之一:

    • 要创建选区,请单击包含要选择的属性的对象。则所有与此对象属性相同的对象都将被选中。

    • 要添加到当前选区,请按住 Shift 键并单击包含要添加的属性的其他对象。所有具有相同属性的对象也将被选中。

    • 要从当前选区移除对象,请在按住 Alt 键 (Windows) 或 Option 键 (macOS) 的同时,单击包含要移除的属性的对象。则所有与此对象属性相同的对象都将从所选对象中删除。

自定魔棒工具

  1. 请执行下列操作之一以打开“魔棒”面板:

    • 双击“工具”面板中的魔棒工具。

    • 选择窗口 > 魔棒

  2. 要根据对象的填充颜色来选择对象,请选择填充颜色,然后输入“容差”值,对于 RGB 模式,该值应介于 0 到 255 像素之间,对于 CMYK 模式,该值应介于 0 到 100 像素之间。

    容差值越低,选择的对象就与单击的对象越相似;容差值越高,选择的对象所具有的选定属性范围就越广。

  3. 魔棒面板菜单中选择显示描边选项,然后执行下列任一操作:

    • 要根据对象的描边颜色选择对象,请选择描边颜色,然后输入“容差”值,对于 RGB 模式,该值应介于 0 到 255 像素之间,对于 CMYK 模式,该值应介于 0 到 100 像素之间。

    • 要根据对象的描边粗细选择对象,请选择描边粗细,然后输入“容差”值,该值应介于 0 到 1000 点之间。

  4. 魔棒面板菜单中单击显示透明度选项,然后执行下列任一操作:

    • 要根据对象的透明度或混合模式选择对象,请选择不透明度,然后输入“容差”值,该值应介于 0 到 100% 之间。

    • 要根据对象的混合模式选择对象,请选择混合模式

选择填充对象

仅按路径选择对象首选项决定了您是否可以使用选择工具或直接选择工具,通过单击对象区域内的任意位置来选择填充对象,还是必须使用这些工具通过单击路径片段或锚点才能选择填充对象。默认情况下,该首选项处于关闭状态。在某些情况下,您可能想要打开这个首选项 - 例如,当在处理相互重叠的多个填充对象时,您想要轻松地选择基础对象。

注意:

选择非填充对象时或按轮廓查看图稿时,仅按路径选择对象首选项都不适用。此类情况下,从来都不能通过在对象路径内部单击的方式来选择对象。(请参阅按轮廓查看图稿。)

当“仅按路径选择对象”选项处于未选中状态时,单击对象内一点并拖动,可选择并移动该对象。
当“仅按路径选择对象”选项处于未选中状态时,单击对象内一点并拖动,可选择并移动该对象。

当“仅按路径选择对象”选项处于选中状态时,用“直接选择”工具拖动,可选择选框内的点和段。
当“仅按路径选择对象”选项处于选中状态时,用“直接选择”工具拖动,可选择选框内的点和段。

  1. 单击编辑 > 首选项 > 选择和锚点显示 (Windows) 或 Illustrator > 首选项 > 选择和锚点显示 (macOS),然后选择仅按路径选择对象

选择一个组中的各个组和对象

将对象编组后,使用选择工具或套索工具选择组的任何部分时,将会选择整个组。如果不确定某个对象是否为组的一部分,应使用选择工具选择该对象。

直接选择工具和套索工具允许您选择作为一个组或多个组的一部分的单个路径或对象。如果其他组中包含对象组,可以使用编组选择工具在编组层次结构中选择下一个组。每次后续单击都会将另一个编组对象的子集添加到所选对象中。

使用选择工具选择一个或多个组

  1. 单击选择工具

  2. 对组内任一对象执行下列操作之一:

    • 单击对象。

    • 围绕部分或整个对象拖动。

  3. 要对选区添加或移除一个组,请按住 Shift 键并单击要添加或移除的组。

使用选择工具在组中选择对象和组

  1. 选择选择工具

  2. 双击一个组。该组将以隔离模式显示。

  3. 请执行下列任一操作:

    • 双击以在组结构中向下深入选择。

      提示:双击是在“实时上色”组中选择对象(与表面和边缘对比)的一种简便方法。

    • 单击以在所选组中选择一个对象。

    • 拉曳以在所选组中添加一个对象。

  4. 在组外区域双击可取消选择组。

选择一个组中的单个对象

  1. 执行下列操作之一:

    • 选择编组选择工具 ,并单击对象。

    • 选择套索工具 ,然后围绕对象路径或穿越对象路径拖动鼠标。

    • 选择直接选择工具 ,然后单击对象内部,或围绕对象的部分或全部路径拖动选框。

  2. 要使用任意选择工具从选区添加或移除对象或组,请按住 Shift 键并选择要添加或移除的对象。

使用编组选择工具选择对象和组

  1. 选择编组选择工具 ,然后单击要选择的组内对象。该对象将被选中。

  2. 若要选择对象的父级组,请再次单击同一个对象。

  3. 接下来,继续单击同一个对象,以选择包含所选组的其他组,依此类推,直到所选对象中包含了所有要选择的内容为止。

    编组选择
    用“编组选择”工具进行第一次单击,选择的是组内的一个对象(左图);第二次单击,选择的是对象所在的组(右图)。

    编组选择
    第三次单击会向所选项目中添加下一个组(左图);第四次单击则添加第三个组(右图)。

选择实时上色组中的表面和边缘

使用实时上色选择工具,可以选择“实时上色”工具的表面和边缘。如果要选择整个“实时上色”组,只需使用选择工具单击相应的组即可。

  1. 选择实时上色选择工具

  2. 实时上色组上方移动工具,直至要选择的表面或边缘突出显示为止。(当实时上色选择工具贴近边缘时,工具形状将变为 。)

  3. 请执行下列任一操作:

    • 单击可选择突出显示的表面或边缘。

    • 围绕多个表面或边缘拖动选框。完全或部分地由选框包围的任何表面或边缘都将包含在选区中。

    • 双击一个表面或边缘,可选择与之颜色相同的所有相连表面/边缘(连选)。

    • 三击一个表面或边缘,选择与之颜色相同的所有表面/边缘(选择相同项)。

      提示:如果很难选择小的表面或边缘,可以放大视图或将实时上色选择工具选项设置为仅选择填充或描边。

  4. 要从选区添加或移除表面和边缘,请按住 Shift 键并单击要添加或移除的表面/边缘。

实时上色选择工具选项

通过双击“工具”面板中的工具,您可以访问“实时上色选择”工具选项。

选择填充

选择实时上色组的表面(边缘内的区域)。

选择描边

选择实时上色组的边缘。

颜色

设置突出显示线的颜色。您可以从菜单中选择颜色,也可以单击上色色板以指定自定颜色。

宽度

指定所选项目的突出显示线的粗细。

按特征选择对象

您可以基于不同的分组方式选择对象,这些分组方式包括按格式属性、按图层或类型,例如画笔描边或剪切蒙版。

  1. 要选择文件中的所有对象,请单击选择 > 全部。(若要取消选择所有对象,请选择“选择”>“取消选择”。)

  2. 要选择具有相同属性的所有对象,请选择一个具有您所需属性的对象,然后单击选择 > 相同,之后再从以下列表中选择一种属性:混合模式填色和描边填充颜色不透明度描边颜色描边粗细样式符号实例链接块系列

    链接块系列会自动选择串接文本框。您可以选择任一文本框,然后使用此命令选择所有链接到该文本框的其他文本框。有关更多信息,请参阅串接对象之间的文本

    注意:

    您还可以使用魔棒工具选择具有相同的颜色、描边粗细、描边颜色、不透明度或混合模式的所有对象。

  3. 要选择某一特定类型的所有对象,请取消选择所有图稿,然后单击选择 > 对象,之后再选取一种对象类型(“画笔描边”、“剪切蒙版”、“游离点”或“文本对象”)。

按文本特征选择相同内容

现在,您可以一次更改文档中所有选定文本框的属性。您可以根据文本特性(例如字体大小、文本填充颜色、字体样式、字体等)选择多个文本对象的文本。 

观看此 15 秒钟长的视频,了解如何一次性更改文档中多个位置的文本字体颜色。 

要选择具有相同属性的所有文本对象,请选择文本,单击选择 > 相同,然后从列表中选择一个属性:

  • 字体系列
  • 字体系列和样式
  • 字体系列、样式和大小
  • 字体大小
  • 文本填充颜色
  • 文本描边颜色
  • 文本填充与描边颜色

将选中所有具有相似属性的文本框。现在,您可以从属性 > 字符面板中更改字体、大小等。更改会反映在所有选定的文本框中。

您可以创建键盘快捷键或根据每个属性为每个选择 > 相同文本任务创建动作。

重复、反转或存储选区

重复选择或反相选择

  • 若要重复上次使用的选择命令,请选择选择 > 重新选择

  • 若要选择所有未选中对象并取消选择所有选中对象,请选择选择 > 反向

存储所选对象

  1. 选中一个或多个对象,然后单击选择 > 存储所选对象

  2. 存储所选对象对话框的名称文本框中键入一个名称,然后单击确定

    您可以从选择菜单的最下端选择所选对象的名称,以重新载入已存储的所选对象。您还可以通过选择选择 > 编辑所选对象来删除或重命名所选对象。

Adobe 徽标

登录到您的帐户