用户指南 取消(C)

实时上色组

  1. 《Illustrator 用户指南》
  2. 了解 Illustrator
    1. Illustrator 简介
      1. Illustrator 的新增功能
      2. 常见问题
      3. Illustrator 系统要求
      4. 适用于 Apple Silicon 的 Illustrator
    2. 工作区
      1. 工作区基础知识
      2. 使用 Illustrator“发现”面板加快学习速度
      3. 创建文档
      4. 工具栏
      5. 默认键盘快捷键
      6. 自定快捷键
      7. 画板简介
      8. 管理画板
      9. 自定义工作区
      10. “属性”面板
      11. 设置首选项
      12. 触控工作区
      13. Illustrator 中的 Microsoft Surface Dial 支持
      14. 撤消编辑和管理设计历史记录
      15. 旋转视图
      16. 标尺、网格和参考线
      17. Illustrator 中的无障碍功能
      18. 安全模式
      19. 查看图稿
      20. 将 Touch Bar 与 Illustrator 结合使用
      21. 文件和模板
    3. Illustrator 中的工具
      1. 工具概览
      2. 选择工具
        1. 选择
        2. 直接选择
        3. 编组选择
        4. 魔棒
        5. 套索
        6. 画板
      3. 导航工具
        1. 抓住
        2. 旋转视图
        3. 缩放
      4. 绘图工具
        1. 渐变
        2. 网格
        3. 形状生成器
      5. 文本工具
        1. 文字
        2. 路径文字
        3. 垂直文字
      6. 绘图工具
        1. 钢笔
        2. 添加锚点
        3. 删除锚点
        4. 锚点
        5. 曲率
        6. 直线段
        7. 矩形
        8. 圆角矩形
        9. 椭圆
        10. 多边形
        11. 星形
        12. 画笔
        13. 斑点画笔
        14. 铅笔
        15. Shaper
        16. 切片
      7. 修改工具
        1. 旋转
        2. 镜像
        3. 缩放
        4. 切变
        5. 宽度
        6. 自由变换
        7. 滴管
        8. 混合
        9. 橡皮擦
        10. 剪刀
    4. 快速操作
      1. 复古文字
      2. 霓虹灯文本
      3. 老派文本
      4. 重新着色
      5. 将草图转换为矢量
  3. Illustrator iPad 版
    1. Illustrator iPad 版简介
      1. Illustrator iPad 版概述
      2. Illustrator iPad 版常见问题解答
      3. 系统要求 | Illustrator iPad 版
      4. 在 Illustrator iPad 版上可以或无法执行的操作
    2. 工作区
      1. Illustrator iPad 版工作区
      2. 触控快捷键和手势
      3. Illustrator iPad 版的键盘快捷键
      4. 管理应用程序设置
    3. 文档
      1. 在 Illustrator iPad 版中处理文档
      2. 导入 Photoshop 和 Fresco 文档
    4. 选择和排列对象
      1. 创建重复对象
      2. 混合对象
    5. 绘图
      1. 绘制和编辑路径
      2. 绘制和编辑形状
    6. 文字
      1. 处理文字和字体
      2. 在路径上创建文本设计
      3. 添加您自己的字体
    7. 处理图像
      1. 对栅格图像进行矢量化
    8. 颜色
      1. 应用颜色和渐变
  4. 云文档
    1. 基本信息
      1. 使用 Illustrator 云文档
      2. 共享并协作处理 Illustrator 云文档
      3. 共享文档以供审阅
      4. 升级 Adobe Illustrator 的云存储空间
      5. Illustrator 云文档 | 常见问题
    2. 故障诊断
      1. Illustrator 云文档创建或存储问题故障诊断
      2. 对 Illustrator 云文档问题进行故障诊断
  5. 添加和编辑内容
    1. 绘图
      1. 绘图基础知识
      2. 编辑路径
      3. 绘制像素级优化的图稿
      4. 使用钢笔、曲率或铅笔工具绘制
      5. 绘制简单线段和形状
      6. 图像描摹
      7. 简化路径
      8. 定义透视网格
      9. 符号工具和符号组
      10. 调整路径段
      11. 利用简单 5 步设计花朵
      12. 透视图
      13. 符号
      14. 绘制用于 Web 工作流程的像素对齐路径
    2. 3D 对象和材质
      1. 关于 Illustrator 中的 3D 效果
      2. 创建 3D 图形
      3. 将图稿贴在 3D 对象上
      4. 创建 3D 文本
    3. 颜色
      1. 关于颜色
      2. 选择颜色
      3. 使用和创建色板
      4. 调整颜色
      5. 使用“Adobe Color 主题”面板
      6. 颜色组(协调)
      7. “颜色主题”面板
      8. 重新着色图稿
    4. 绘画
      1. 关于绘画
      2. 使用填色和描边上色
      3. 实时上色组
      4. 渐变
      5. 画笔
      6. 透明度和混合模式
      7. 为对象应用描边
      8. 创建和编辑图案
      9. 网格
      10. 图案
    5. 选择和排列对象
      1. 选择对象
      2. 图层
      3. 编组和扩展对象
      4. 移动、对齐和分布对象
      5. 堆叠对象    
      6. 锁定、隐藏和删除对象
      7. 复制和重复对象
      8. 旋转和镜像对象
      9. 缠绕对象
    6. 改变对象形状
      1. 裁切图像
      2. 变换对象
      3. 组合对象
      4. 剪切、分割和裁切对象
      5. 操控变形
      6. 缩放、倾斜和扭曲对象
      7. 混合对象
      8. 使用封套改变形状
      9. 使用效果改变对象形状
      10. 使用 Shaper 和形状生成器工具构建新的形状
      11. 使用实时转角
      12. 增强的支持触摸式变形工作流程
      13. 编辑剪贴蒙版
      14. 实时形状
      15. 使用形状生成器工具创建形状
      16. 全局编辑
    7. 文字
      1. 添加文本并使用文字对象
      2. 创建项目符号列表和编号列表
      3. 管理文本区域
      4. 字体和排版
      5. 设置文字格式
      6. 导入和导出文本
      7. 设置段落格式
      8. 特殊字符
      9. 创建路径文字
      10. 字符和段落样式
      11. 制表符
      12. 文本和文字
      13. 查找缺失字体(Typekit 工作流程)
      14. 从 Illustrator 10 更新文本
      15. 阿拉伯语和希伯来语文字
      16. 字体 | 常见问题解答和故障排除提示
      17. 创建 3D 文本效果
      18. 创意排版设计
      19. 缩放和旋转文字
      20. 行距和字距
      21. 连字和换行
      22. 文本增强功能
      23. 拼写和语言词典
      24. 设置亚洲字符格式
      25. 亚洲语言脚本书写器
      26. 使用混合对象创建文本设计
      27. 使用图像描摹创建文本海报
    8. 创建特殊效果
      1. 使用效果
      2. 图形样式
      3. 创建投影
      4. 外观属性
      5. 创建素描和马赛克
      6. 投影、发光和羽化
      7. 效果小结
    9. Web 图形
      1. 创建 Web 图形的最佳做法
      2. 图表
      3. SVG
      4. 创建动画
      5. 切片和图像映射
  6. 导入、导出和存储
    1. 导入
      1. 置入多个文件
      2. 管理链接和嵌入文件
      3. 链接信息
      4. 取消嵌入图像
      5. 从 Photoshop 导入图稿
      6. 导入位图图像
      7. 导入 Adobe PDF 文件
      8. 导入 EPS、DCS 和 AutoCAD 文件
    2. Illustrator 中的 Creative Cloud Libraries 
      1. Illustrator 中的 Creative Cloud Libraries
    3. 保存
      1. 存储图稿
    4. 导出
      1. 在 Photoshop 中使用 Illustrator 图稿
      2. 导出图稿
      3. 收集资源并批量导出
      4. 打包文件
      5. 创建 Adobe PDF 文件
      6. 提取 CSS | Illustrator CC
      7. Adobe PDF 选项
      8. 文件信息和元数据
  7. 打印
    1. 准备打印
      1. 设置打印文档
      2. 更改页面大小和方向
      3. 指定用于裁切或对齐的裁切标记
      4. 大型画布快速入门
    2. 打印
      1. 叠印
      2. 使用颜色管理进行打印
      3. PostScript 打印
      4. 打印预设
      5. 印刷标记和出血
      6. 打印和存储透明图稿
      7. 陷印
      8. 打印分色
      9. 打印渐变、网格和颜色混合
      10. 白色叠印
  8. 任务自动化
    1. 使用“变量”面板合并数据
    2. 脚本的自动化
    3. 动作的自动化
  9. 故障诊断 
    1. 崩溃问题
    2. 崩溃后恢复文件
    3. 文件问题
    4. 支持的文件格式
    5. GPU 设备驱动程序问题
    6. Wacom 设备问题
    7. DLL 文件问题
    8. 内存问题
    9. 首选项文件问题
    10. 字体问题
    11. 打印机问题
    12. 与 Adobe 共享崩溃报告
    13. 改进 Illustrator 性能

关于实时上色

通过将图稿转换为实时上色组,您可以任意对它们进行着色,就像对画布或纸上的绘画进行着色一样。您可以使用不同颜色为每个路径段描边,并使用不同的颜色、图案或渐变填充每个封闭路径(注意,并不仅仅是封闭路径)。

“实时上色”是一种创建彩色图画的直观方法。通过采用这种方法,您可以使用 Illustrator 的所有矢量绘画工具,而将绘制的全部路径视为在同一平面上。也就是说,没有任何路径位于其他路径之后或之前。实际上,路径将绘画平面分割成几个区域,可以对其中的任何区域进行着色,而不论该区域的边界是由单条路径还是多条路径段确定的。这样一来,为对象上色就有如在涂色簿上填色,或是用水彩为铅笔素描上色。

一旦建立了“实时上色”组,每条路径都会保持完全可编辑。移动或调整路径形状时,前期已应用的颜色不会像在自然介质作品或图像编辑程序中那样保持在原处, 相反,Illustrator 自动将其重新应用于由编辑后的路径所形成的新区域。

“调整实时上色”路径
“调整实时上色”路径

A. 原稿 B. “实时上色”组 C. 路径调整后,“实时上色”进行重排 

“实时上色”组中可以上色的部分称为边缘表面。边缘是一条路径与其他路径交叉后,处于交点之间的路径部分。表面是一条边缘或多条边缘所围成的区域。您可以为边缘描边、为表面填色。

例如,画一个圆,再画一条线穿过该圆。作为“实时上色”组,分割圆的线条(边缘)在圆上创建了两个表面。可以使用“实时上色”工具,用不同颜色为每个表面填色、为每条边缘描边。

圆和线条(左图)与转换为“实时上色”组并为表面填色、为边缘描边后的圆和线条(右图)的对比图。
圆和线条(左图)与转换为“实时上色”组并为表面填色、为边缘描边后的圆和线条(右图)的对比图。

注意:

实时上色利用了多个处理器,这有助于 Illustrator 更快地执行操作。

实时上色限制

填色和上色属性附属于“实时上色”组的表面和边缘,而不属于定义这些表面和边缘的实际路径,在其他 Illustrator 对象中也是这样。因此,某些功能和命令对“实时上色”组中的路径或者作用方式有所不同,或者是不适用。

适用于整个“实时上色”组(而不是单个表面和边缘)的功能和命令

  • 透明度

  • 效果

  • “外观”面板中的多种填充和描边

  • 对象 > 封套扭曲

  • 对象 > 隐藏

  • 对象 > 栅格化

  • 对象 > 切片 > 建立

  • 建立不透明蒙版(在“透明度”面板菜单中)

  • 画笔(如果使用“外观”面板将新描边添加到"实时上色"组中,则可以将画笔应用于整个组。)

不适用于"实时上色"组的功能

  • 渐变网格

  • 图表

  • “符号”面板中的符号

  • 光晕

  • “描边”面板中的“对齐描边”选项

  • 魔棒工具

不适用于"实时上色"组的对象命令

  • 轮廓化描边

  • 扩展(可以改用“对象”>“实时上色”>“扩展”命令。)

  • “混合”

  • “切片”

  • 剪贴蒙版 > 建立

  • 创建渐变网格

不适用于"实时上色"组的其他命令

  • 路径查找器命令

  • 文件 > 置入

  • 视图 > 参考线 > 建立

  • 选择 > 相同 > 混合模式、填充和描边、不透明度、样式、符号实例或链接块系列

  • 对象 > 文本绕排 > 建立

创建"实时上色"组

如果要对对象进行着色,并且每个边缘或交叉线使用不同的颜色,请将图稿转换为"实时上色"组。

某些对象类型,如文字、位图图像和画笔,是无法直接建立到“实时上色”组中的。您首先要把这些对象转换为路径。例如,如果试图转换使用了画笔或效果的对象,则其复杂的视觉外观会在转换为“实时上色”时丢失。不过,您可以通过将对象首先转换为常规路径而使诸多外观存储下来,然后再将生成的路径转换为“实时上色”。

注意:在将图稿转换为"实时上色"组时,不能将图稿返回到其原始状态。您可以将组扩展为其各个组件,或者释放组以返回其原始路径,这些路径没有进行填充且具有 0.5 磅宽的黑色描边。

创建"实时上色"组

  1. 选择一条或多条路径或是复合路径,或者既选择路径又选择复合路径。
  2. 执行下列操作之一:
    • 选择对象 > 实时上色 > 建立

    • 选择“实时上色 工具” ,然后 单击所选对象。

注意:

某些属性可能会在转换为实时上色组时丢失(如透明度和效果),而有些对象则不能进行转换(如文字、位图图像和画笔)。

将对象转换为实时上色组

  1. 对于不能直接转换为实时上色组的对象,请执行以下任何操作:
    • 对于文字对象,请选择文字 > 创建轮廓。接下来,将生成的路径变为实时上色组。

    • 对于位图图像,请选择对象 > 实时描摹 > 建立并转换为实时上色

    • 对于其他对象,请选择对象 > 扩展。接下来,将生成的路径变为实时上色组。

扩展或释放实时上色组

通过释放实时上色组,可以将其变为一条或多条普通路径,它们没有进行填充且具有 0.5 磅宽的黑色描边。通过扩展实时上色组,可以将其变为与实时上色组视觉上相似,事实上却是由单独的填充和描边路径所组成的对象。可以使用编组选择工具来分别选择和修改这些路径。

扩展并拖到单独的表面和边缘之前(左图)和之后(右图)的实时上色组
扩展并拖到单独的表面和边缘之前(左图)和之后(右图)的实时上色组

应用“释放”命令之前(左图)和之后(右图)的实时上色组
应用“释放”命令之前(左图)和之后(右图)的实时上色组

  1. 选择“实时上色”组。
  2. 执行下列操作之一:
    • 选择对象 > 实时上色 > 扩展

    • 选择对象 > 实时上色 > 释放

选择“实时上色”组中的项目

实时上色选择工具 用于选择实时上色组中的各个表面和边缘。选择工具 用于选择整个实时上色组;直接选择工具 用于选择实时上色组内的路径。处理复杂文档时,您可以隔离实时上色组,以便可以轻松地选择所需的确切表面或边缘。

注意:

应根据要影响的实时上色组内容选一种选择工具。例如,要将不同的渐变应用于实时上色组中的不同表面,请使用实时上色选择工具;要将相同的渐变应用于整个实时上色组,请使用选择工具。

选择表面和边缘

将实时上色选择工具指针放在表面上时,指针将变为表面指针 ;将指针放在边缘上时,指针将变为边缘指针 ;将指针放在实时上色组外部时,指针将变为 x 指针

  1. 选择实时上色选择工具,然后执行以下操作:

    • 要选择单个表面或边缘,请单击该表面或边缘。
    • 要选择多个表面和边缘,请在要选择的项周围拖动选框。部分选择的内容将被包括在内。
    • 要选择没有被上色边缘分隔开的所有连续表面,请双击某个表面。
    • 要选择具有相同填充或描边的表面或边缘,请三击某个项。或单击一次,选取选择 > 相同,然后选择子菜单中的填充颜色描边颜色描边粗细
    • 要在当前选区中添加或删除项,请按住 Shift 并单击这些项,或者按住 Shift 并在这些项周围拖动选框。

选择实时上色组

  1. 通过使用选择工具,单击组。

选择实时上色组内的原始路径

  1. 通过使用直接选择工具,单击实时上色组内的路径。

将实时上色组与图稿其余部分隔离

  1. 通过使用选择工具,执行下列操作之一:
    • 双击组。

    • 选择组,然后单击“控制”面板中的“隔离选定的组”按钮

修改实时上色组

修改实时上色组中的路径时,Illustrator 将使用现有组中的填充和描边对修改的或新的表面和边缘进行着色。如果不是所希望的效果,您可以使用实时上色工具重新应用所需的颜色。

调整路径之前(左图)和之后(右图)的实时上色组
调整路径之前(左图)和之后(右图)的实时上色组

在删除边缘时,将连续填充任何新扩展的表面。例如,如果删除一条将圆分割成两半的路径,则会使用该圆中以前所用的某种填充来填充整个圆。有时,您可以帮助实现预期结果。例如,在删除分割圆的路径之前,应先移动该路径,以使要保留的填充比要删除的填充稍微大一些。

选择并删除路径之前(左图)和之后(右图)的实时上色组
选择并删除路径之前(左图)和之后(右图)的实时上色组

注意:

可以将实时上色组中使用的填充和描边颜色保存在“色板”面板中。这样,如果在修改过程中丢失了要保留的颜色,则还可以选择该颜色的色板,并使用实时上色工具重新应用填充或描边。

在实时上色组中添加路径

当您向“实时上色”组添加更多路径时,可以对创建的新表面和边缘进行填色和描边。

添加新路径之前(左图)与添加新路径并为所创建的新表面及边缘上色之后(右图)的“实时上色”组。
添加新路径之前(左图)与添加新路径并为所创建的新表面及边缘上色之后(右图)的“实时上色”组。

  1. 请执行下列任一操作:
    • 通过使用选择工具,双击实时上色组(或单击“控制”面板中的“隔离选定的组”按钮)以使其处于隔离模式。接下来,绘制另一条路径。Illustrator 将在实时上色组中添加新路径。单击“退出隔离模式” 按钮  当您 添加完新路径后。

    • 选择实时上色组和要添加到组中的路径。然后,请执行以下操作之一:
      • 选择对象 > 实时上色 > 合并
      • 单击“控制”面板中的合并实时上色
      • 在“属性”面板的快速操作部分中,单击合并实时上色按钮。
    • 在“图层”面板,将一个或多个路径拖到实时上色组中。

      注意:或许,实时上色组内的路径不能完全与该实时上色组之外相似或相同的路径对齐。

调整单个对象或路径的大小

  1. 执行下列操作之一:
    • 通过使用直接选择工具,单击路径或对象以将其选定。接下来,选择“选择”工具,然后再次单击路径或对象以进行编辑。

    • 通过使用选择工具,双击实时上色组以使其处于隔离模式。接下来,单击路径或对象以进行编辑。

使用实时上色工具上色

通过使用实时上色工具,您可以使用当前填充和描边属性为实时上色组的表面和边缘上色。工具指针显示为一种或三种颜色方块,它们表示选定填充或描边颜色;如果使用色板库中的颜色,则还表示库中所选颜色的两种相邻颜色。通过按向左或向右箭头键,可以访问相邻的颜色以及这些颜色旁边的颜色,等等。

  1. 选择实时上色工具 。单击并按住形状生成器工具即可查看并选择实时上色工具。请参阅选择工具以了解用于选择工具的其他方法。请参阅工具面板概述找到所有工具。
  2. 指定所需的填充颜色或描边颜色和大小。
    注意:

    如果从“色板”面板中选择一种颜色,指针将变为显示三种颜色 。选定颜色位于中间,两个相邻颜色位于两侧。要使用相邻的颜色,请单击向左或向右箭头键。

  3. 要对表面进行上色,请执行以下任何操作:
    • 单击表面以对其进行填充。(当指针位于表面上时,它将变为半填充的油漆桶形状 ,并且突出显示填充内侧周围的线条。)

    • 拖动鼠标跨过多个表面,以便一次为多个表面上色。

    • 双击一个表面,以跨越未描边的边缘对邻近表面填色(连续填色)。

    • 三击表面以填充所有当前具有相同填充的表面。

      提示:要切换到吸管工具并对填色或描边取样,请按住 Alt 并单击 (Windows) 或按住 Option 并单击 (Mac OS) 您需要的填色或描边。

  4. 要对边缘进行上色,请双击实时上色工具并选择“描边上色”,或者按 Shift 以暂时切换到“描边上色”选项;然后执行以下任何操作:
    • 单击一个边缘以为其描边。(当指针位于边缘上时,它将变为 上色画笔 ,并且会突出显示边缘。)

    • 拖动鼠标跨过多条边缘,可一次为多条边缘进行描边。

    • 双击一条边缘,可对所有与其相连的边缘进行描边(连续描边)。

    • 三击一条边缘,可对所有边缘应用相同的描边。

      注意:按住 Shift 键,可快速地在“仅描边上色”与“仅填充上色”之间切换。也可以在“实时上色工具选项”对话框中指定这些更改。如果当前同时选择了“填充上色”选项和“描边上色”选项,按 Shift 时将仅切换到“填充上色”。(在对已描边的边缘所环绕的小型表面进行填充时,这一功能非常有用。)

实时上色工具选项

“实时上色工具”选项用于指定实时上色工具的工作方式,即选择只对填充进行上色、只对描边进行上色还是同时对二者进行上色,以及当工具移动到表面和边缘上时如何对其进行突出显示。通过双击实时上色工具,可以看到以下选项:

上色填色

对“实时上色”组的各表面上色。

上色描边

对“实时上色”组的各边缘上色。

光标色板预览

从“色板”面板中选择颜色时显示。实时上色工具指针显示为三种颜色色板:选定填充或描边颜色以及“色板”面板中紧靠该颜色左侧和右侧的颜色。

突出显示

勾画出光标当前所在表面或边缘的轮廓。用粗线突出显示表面,细线突出显示边缘。

颜色

设置突出显示线的颜色。您可以从菜单中选择颜色,也可以单击上色色板以指定自定颜色。

宽度

指定突出显示轮廓线的粗细。

封闭实时上色组中的间隙

间隙是路径之间的小空间。如果颜料渗漏并将不应上色的表面涂上了颜色,则可能是因为图稿中存在间隙。可以创建一条新路径来封闭间隙,编辑现有路径以封闭间隙,或者在实时上色组中调整间隙选项。

注意:

可通过绘制加长的路径(即将路径扩展到相邻的路径上)来避免实时上色图稿中出现间隙。然后,可以选择并删除边缘的超出部分,或者为其应用“无”描边选项。

突出显示实时上色组中的间隙

  1. 选择视图 > 显示实时上色间隙

此命令根据当前所选实时上色组中设置的间隙选项,突出显示在该组中发现的间隙。

设置实时上色间隙选项

  1. 选择对象 > 实时上色 > 间隙选项,然后指定以下任何选项:

    间隙检测

    选择此选项时,Illustrator 将识别实时上色路径中的间隙,并防止颜料通过这些间隙渗漏到外部。请注意,在处理较大且非常复杂的实时上色组时,这可能会使 Illustrator 的运行速度变慢。在这种情况下,可以选择“用路径封闭间隙”选项,帮助加快 Illustrator 的运行。

    上色停止在

    设置颜色不能渗入的间隙的大小。

    自定

    指定一个自定的“上色停止在”间隙大小。

    间隙预览颜色

    设置在“实时上色”组中预览间隙的颜色。您可以从菜单中选择颜色,也可以单击“间隙预览颜色”菜单旁边的颜色井来指定自定颜色。

    用路径封闭间隙

    选择此选项时,将在实时上色组中插入未上色的路径以封闭间隙(而不是只防止颜料通过这些间隙渗漏到外部)。请注意,由于这些路径没有上色,即使已封闭了间隙,也可能会显示仍然存在间隙。

    预览

    将当前“实时上色”组中检测到的间隙显示为彩色线条,所用颜色根据选定的预览颜色而定。

用于合并的实时上色组的间隙规则

合并具有不同间隙设置的实时上色组时,Illustrator 使用以下规则来处理间隙:

  • 如果在选择的所有组中关闭了间隙检测,可通过将“上色停止在”设置为“小间隙”来封闭间隙并打开间隙检测。

  • 如果选择的所有组都打开了间隙检测,则会封闭间隙并保留间隙设置。

  • 如果选择的所有组并非都打开了间隙检测,则会封闭间隙并保留最下面的实时上色组的间隙设置(如果该组打开了间隙检测)。如果最下面的组关闭了间隙检测,则会打开间隙检测并将“上色停止在”设置为“小间隙”。

Adobe 徽标

登录到您的帐户