组合对象

  1. Illustrator 用户指南
  2. 了解 Illustrator
    1. Illustrator 简介
      1. Illustrator 的新增功能
      2. 常见问题
      3. Illustrator 系统要求
      4. 适用于 Apple Silicon 的 Illustrator
    2. 工作区
      1. 工作区基础知识
      2. 创建文档
      3. 工具默认键盘快捷键 | Illustrator
      4. 自定键盘快捷键
      5. 画板
      6. 自定义工作区
      7. “属性”面板
      8. 工具库
      9. 设置首选项
      10. 触控工作区
      11. Illustrator 中的 Microsoft Surface Dial 支持
      12. 恢复、还原以及自动化
      13. 旋转视图
      14. 标尺、网格和参考线
      15. Illustrator 中的无障碍功能
      16. 安全模式
      17. 查看图稿
      18. 将 Touch Bar 与 Illustrator 结合使用
      19. 文件和模板
      20. 使用 Adobe Creative Cloud 同步设置
  3. Illustrator iPad 版
    1. Illustrator iPad 版简介
      1. Illustrator iPad 版概述
      2. Illustrator iPad 版常见问题解答
      3. 系统要求 | Illustrator iPad 版
      4. 在 Illustrator iPad 版上可以或无法执行的操作
    2. 工作区
      1. Illustrator iPad 版工作区
      2. 触控快捷键和手势
      3. Illustrator iPad 版的键盘快捷键
      4. 管理应用程序设置
    3. Documents
      1. 在 Illustrator iPad 版中处理文档
      2. 导入 Photoshop 和 Fresco 文档
    4. 选择和排列对象
      1. 创建重复对象
    5. 绘图
      1. 绘制和编辑路径
      2. 绘制和编辑形状
    6. 文字
      1. 处理文字和字体
      2. 在路径上创建文本设计
      3. 添加您自己的字体
    7. 处理图像
      1. 处理图像
    8. 颜色
      1. 应用颜色和渐变
  4. 云文档
    1. 基本信息
      1. 使用 Illustrator 云文档
      2. 共享并协作处理 Illustrator 云文档
      3. 升级 Adobe Illustrator 的云存储空间
      4. Illustrator 云文档 | 常见问题
    2. 故障诊断
      1. Illustrator 云文档创建或存储问题故障诊断
      2. 对 Illustrator 云文档问题进行故障诊断
  5. 添加和编辑内容
    1. 绘图
      1. 绘图基础知识
      2. 编辑路径
      3. 绘制像素级优化的图稿
      4. 使用钢笔、曲率或铅笔工具绘制
      5. 绘制简单线段和形状
      6. 图像描摹
      7. 简化路径
      8. 定义透视网格
      9. 创建 3D 对象
      10. 符号工具和符号组
      11. 调整路径段
      12. 利用简单 5 步设计花朵
      13. 透视图
      14. 符号
      15. 绘制用于 Web 工作流程的像素对齐路径
    2. 颜色
      1. 关于颜色
      2. 选择颜色
      3. 使用和创建色板
      4. 调整颜色
      5. 使用“Adobe Color 主题”面板
      6. 颜色组(协调)
      7. “颜色主题”面板
      8. 重新着色图稿
    3. 绘画
      1. 关于绘画
      2. 使用填色和描边上色
      3. 实时上色组
      4. 渐变
      5. 画笔
      6. 透明度和混合模式
      7. 为对象应用描边
      8. 创建和编辑图案
      9. 网格
      10. 图案
    4. 选择和排列对象
      1. 选择对象
      2. 图层
      3. 编组和扩展对象
      4. 移动、对齐和分布对象
      5. 堆叠对象    
      6. 锁定、隐藏和删除对象
      7. 复制对象
      8. 旋转和镜像对象
    5. 改变对象形状
      1. 裁剪图像
      2. 变换对象
      3. 组合对象
      4. 剪切、分割和裁切对象
      5. 操控变形
      6. 缩放、倾斜和扭曲对象
      7. 混合对象
      8. 使用封套改变形状
      9. 使用效果改变对象形状
      10. 使用 Shaper 和形状生成器工具构建新的形状
      11. 使用实时转角
      12. 增强的支持触摸式变形工作流程
      13. 编辑剪切蒙版
      14. 实时形状
      15. 使用形状生成器工具创建形状
      16. 全局编辑
    6. 文字
      1. 创建文本
      2. 字体和排版
      3. 设置文字格式
      4. 导入和导出文本
      5. 设置段落格式
      6. 特殊字符
      7. 创建路径文字
      8. 字符和段落样式
      9. 制表符
      10. 文本和文字
      11. 查找缺失字体(Typekit 工作流程)
      12. 从 Illustrator 10 更新文本
      13. 阿拉伯语和希伯来语文字
      14. 字体 | 常见问题解答和故障排除提示
      15. 创建 3D 文本效果
      16. 创意排版设计
      17. 缩放和旋转文字
      18. 行距和字距
      19. 连字和换行
      20. 文本增强功能
      21. 拼写和语言词典
      22. 设置亚洲字符格式
      23. 亚洲语言脚本书写器
      24. 使用混合对象创建文本设计
      25. 使用图像描摹创建文本海报
    7. 创建特殊效果
      1. 使用效果
      2. 图形样式
      3. 创建投影
      4. 外观属性
      5. 创建素描和马赛克
      6. 投影、发光和羽化
      7. 效果小结
    8. Web 图形
      1. 创建 Web 图形的最佳做法
      2. 图表
      3. SVG
      4. 创建动画
      5. 切片和图像映射
  6. 导入、导出和存储
    1. 导入
      1. 导入图稿文件
      2. 导入位图图像
      3. 从 Photoshop 导入图稿
      4. 置入多个文件 | Illustrator CC
      5. 取消嵌入图像
      6. 导入 Adobe PDF 文件
      7. 导入 EPS、DCS 和 AutoCAD 文件
      8. 链接信息
    2. Illustrator 中的 Creative Cloud Libraries 
      1. Illustrator 中的 Creative Cloud Libraries
    3. 保存
      1. 存储图稿
    4. 导出
      1. 导出图稿
      2. 收集资源并批量导出
      3. 打包文件
      4. 创建 Adobe PDF 文件
      5. 提取 CSS | Illustrator CC
      6. Adobe PDF 选项
      7. 文件信息和元数据
  7. 打印
    1. 准备打印
      1. 设置打印文档
      2. 更改页面大小和方向
      3. 指定用于裁切或对齐的裁剪标记
      4. 大型画布快速入门
    2. 打印
      1. 叠印
      2. 使用颜色管理进行打印
      3. PostScript 打印
      4. 打印预设
      5. 印刷标记和出血
      6. 打印和存储透明图稿
      7. 陷印
      8. 打印分色
      9. 打印渐变、网格和颜色混合
      10. 白色叠印
  8. 任务自动化
    1. 使用“变量”面板合并数据
    2. 脚本的自动化
    3. 动作的自动化
  9. 故障诊断 
    1. 启动时崩溃问题
    2. 崩溃后恢复文件
    3. 文件问题
    4. GPU 设备驱动程序问题
    5. Wacom 设备问题
    6. DLL 文件问题
    7. 内存问题
    8. 首选项文件问题
    9. 字体问题
    10. 打印机问题
    11. 与 Adobe 共享崩溃报告

组合对象的方法

您可以组合矢量对象,以在 Illustrator 中用各种不同的方式创建形状。生成的路径或形状会因为组合对象时所选用的方法而有所不同。

路径查找器效果

路径查找器效果可以让您使用交互模式来组合多个对象。使用路径查找器效果时,不能编辑对象之间的交互。请参阅使用路径查找器效果组合对象

复合形状

复合形状使您可以组合多个对象,并可指定每个对象与其他对象的交互方式。复合形状比复合路径更为有用,因为它提供了四种类型的交互:相加、相减、交集和差集。此外,不会更改底层对象,因此,您可以选择复合形状中的每个对象,以对其进行编辑或更改其交互模式。请参阅使用复合形状组合对象

复合路径

复合路径使您可以用一个对象在另一个对象中开出一个孔洞。例如,您可以通过两个嵌套的圆形来创建一个圆环形状。在创建复合路径后,路径将用作编组对象。您可以使用直接选择工具或编组选择工具分别选择并处理各个对象;或者,也可以选择和编辑复合路径。请参阅使用复合路径组合对象

注意:

也可以使用斑点画笔工具向对象添加内容。使用此画笔时,绘制的路径会添加到具有相同的填充属性的相邻路径中。请参阅使用斑点画笔工具绘制和合并路径以及使用形状生成器工具构建新形状

使用路径查找器效果组合对象

导航至“路径查找器”面板

可以使用“路径查找器”面板(“窗口”>“路径查找器”)将对象组合为新形状。

路径查找器面板概述
路径查找器面板

使用面板中的第一排按钮来创建路径或复合路径。要创建复合形状,请按住 Alt 或 Option 键并使用这几排按钮。 

从下列形状模式中选择:

添加到形状区域

将组件区域添加到底层几何形状中。

从形状区域中减去

将组件区域从底层几何形状中切除。

与形状区域相交

和蒙版功能一样,可使用组件区域来剪切底层几何形状。

排除重叠形状区域

使用组件区域来反转底层几何形状,将填充区域变成孔洞,反之亦然。

使用面板中最下面一排名为“路径查找器效果”的按钮,只需单击一下这些按钮即可创建最终形状组合。(请参阅应用路径查找器效果。)

路径查找器效果
形状模式

A. 所有处于“相加”模式的组件 B. 应用于方块的“相减”模式 C. 应用于方块的“交集”模式 D. 应用于方块的“差集”模式 

指定路径查找器选项

从“路径查找器”面板菜单中设置“路径查找器选项”,或者双击“外观”面板中的路径查找器效果以进行设置。

精度

可以影响“路径查找器”效果计算对象路径时的精确程度。计算越精确,绘图就越准确,生成结果路径所需的时间就越长。

删除冗余点

在您单击“路径查找器”按钮时删除不必要的点。

分割和轮廓将删除未上色图稿

在您单击“分割”或“轮廓”按钮时删除选定图稿中的所有未填充对象。

应用路径查找器效果

路径查找器效果使您能够从重叠对象中创建新的形状。通过使用“效果”菜单或“路径查找器”面板来应用路径查找器效果。

  • “效果”菜单中的路径查找器效果仅可应用于组、图层和文本对象。应用效果后,仍可选择和编辑原始对象。也可以使用“外观”面板来修改或删除效果。请参阅使用效果菜单应用路径查找器效果

  • “路径查找器”面板中的路径查找器效果可应用于任何对象、组和图层的组合。在您单击“路径查找器”按钮时即创建了最终的形状组合;此后,将不能再编辑原始对象。如果这种效果产生了多个对象,这些对象会被自动编组到一起。请参阅使用路径查找器面板应用路径查找器效果

使用效果菜单应用路径查找器效果

  1. 执行下列操作之一:
    • 将要使用的对象编组到一起,并选择该组。

      -或-

    • 将要使用的对象移动到单独的图层中,并定位此图层。

  2. 选择“效果”>“路径查找器”,然后选择一个路径查找器效果。
    注意:

    要再次快速应用相同的路径查找器效果,请选择“效果”>“应用 [效果]”。

使用路径查找器面板应用路径查找器效果

  1. 选择要应用效果的对象。

    若要对组或图层应用“路径查找器”效果,请定位该组或图层。

  2. 在“路径查找器”面板中,单击一个路径查找器按钮(最下面一排),或者按住 Alt (Windows) 或 Option (Mac OS) 并单击一个“形状模式”按钮(最上面一排)。

路径查找器效果汇总

添加

描摹所有对象的轮廓,就像它们是单独的、已合并的对象一样。此选项产生的结果形状会采用顶层对象的上色属性。

交集

描摹被所有对象重叠的区域轮廓。

差集

描摹对象所有未被重叠的区域,并使重叠区域透明。若有偶数个对象重叠,则重叠处会变成透明。而有奇数个对象重叠时,重叠的地方则会填充颜色。

相减

从最后面的对象中减去最前面的对象。应用此命令,您可以通过调整堆栈顺序来删除插图中的某些区域。

减去后方对象

从最前面的对象中减去后面的对象。应用此命令,您可以通过调整堆栈顺序来删除插图中的某些区域。

分割

将一份图稿分割成由组件填充的表面(表面是未被线段分割的区域)。

注意:使用“路径查找器”面板中的“分割”按钮时,可以使用“直接选择”工具或“编组选择”工具来分别处理生成的每个面。应用“分割”命令时,您还可以选择删除或保留未填充的对象。

修边

删除已填充对象被隐藏的部分。删除所有描边,且不合并相同颜色的对象。

合并

删除已填充对象被隐藏的部分。删除所有描边,且合并具有相同颜色的相邻或重叠的对象。

裁剪

将图稿分割成由组件填充的表面,然后删除图稿中所有落在最上方对象边界之外的部分。这还会删除所有描边。

轮廓

将对象分割为其组件线段或边缘。准备需要对叠印对象进行陷印的图稿时,此命令非常有用。请参阅创建陷印

注意:使用“路径查找器”面板中的“轮廓”按钮时,可以使用“直接选择”工具或“编组选择”工具来分别处理每个边缘。应用“轮廓”命令时,还可以选择删除或保留未填充的对象。

实色混合

通过选择每个颜色组件的最高值来组合颜色。例如,如果颜色 1 为 20% 青色、66% 洋红色、40% 黄色和 0% 黑色;而颜色 2 为 40% 青色、20% 洋红色、30% 黄色和 10% 黑色,则产生的实色混合色为 40% 青色、66% 洋红色、40% 黄色和 10% 黑色。

透明混合

使底层颜色透过重叠的图稿可见,然后将图像划分为其构成部分的表面。您可以指定在重叠颜色中的可视性百分比。

陷印

通过在两个相邻颜色之间创建一个小重叠区域(称为陷印)来补偿图稿中各颜色之间的潜在间隙。

使用复合形状组合对象

复合形状是可编辑的图稿,由两个或多个对象组成,每个对象都分配有一种形状模式。复合形状简化了复杂形状的创建过程,因为您可以精确地操作每个所含路径的形状模式、堆栈顺序、形状、位置和外观。

复合形状用作编组对象,它在“图层”面板中显示为 <复合形状> 项。可以使用“图层”面板来显示、选择和处理复合形状的内容,例如,更改其组件的堆叠顺序。您还可以使用“直接选择”工具或“编组选择”工具来选择复合形状的组件。

当您创建一个复合形状时,此形状会采用“相加”、“交集”或“差集”模式中最上层组件的上色和透明度属性。随后,您可以更改复合形状的上色、样式或透明度属性。当您选择整个复合形状的任意部分时,除非在“图层”面板中明确定位某一组件,否则 Illustrator 将自动定位整个复合形状以简化这一过程。

复合形状
使用组合形状

A. 原始对象 B. 创建的复合形状 C. 应用于每个组件的单独形状模式 D. 应用于整个复合形状的样式 

创建复合形状

  1. 选择要作为复合形状一部分的所有对象。

    复合形状中可包括路径、复合路径、组、其他复合形状、混合、文本、封套和变形。您选择的任何开放式路径都会自动关闭。

  2. 执行下列操作之一:
    • 在“路径查找器”面板中,按住 Alt 键 (Windows) 或 Option 键 (Mac OS) 单击“形状模式”按钮。复合形状的每个组件都会被指定为所选择的形状。

      -或-

    • 从“路径查找器”面板菜单中选择“建立复合形状”。复合形状的每个组件都会被默认指定为“相加”模式。

  3. 更改任何组件的形状模式,方法是:使用直接选择工具或“图层”面板选择该组件,然后单击“形状模式”按钮。

    注意:您完全不需要更改最后面组件的模式,因为其模式与组合形状无关。

    注意:

    为了保持最高运行性能,请以嵌套其他复合形状的方式(每个形状最多可包含约 10 个组件)来创建复杂的复合形状,而不要使用大量单独的组件。

修改复合形状

  1. 使用直接选择工具或“图层”面板选择复合形状的单个组件。
  2. 在“路径查找器”面板中查找突出显示的“形状模式”按钮,以确定当前应用于选定组件的模式。
    注意:

    如果选择了两个或多个使用不同模式的组件,“形状模式”按钮上便会出现问号。

  3. 在“路径查找器”面板中,单击一个不同的“形状模式”按钮。

释放和扩展复合形状

释放复合形状可将其拆分回单独的对象。扩展复合形状会保持复合对象的形状,但不能再选择其中的单个组件。

  1. 使用选择工具或“图层”面板选择复合形状。
  2. 执行下列操作之一:
    • 在“路径查找器”面板中,单击“扩展”。

      -或-

    • 从“路径查找器”面板菜单中选择“扩展复合形状”。

      根据所使用的形状模式,复合形状将转换为“图层”面板中的 <路径> 或 <复合路径> 项。

      -或-

    • 从“路径查找器”面板菜单中选择“释放复合形状”。

在 Illustrator 和 Photoshop 之间移动复合形状

Adobe Photoshop 中的形状图层和图层剪贴路径(矢量蒙版)属于复合形状的类型。您可以将形状图层和图层剪贴路径作为复合形状导入到 Illustrator 中,并继续对其进行操作。此外,您还可以将复合形状导出到 Photoshop。在 Photoshop 中使用复合形状时请注意下列事项:

  • 只有位于图层最上层的复合形状才可作为形状图层导出到 Photoshop。

  • 采用圆角连接以外的连接方式描边上色的复合形状,或所使用的粗细点数不是整数的复合形状,在导出为 PSD 文件格式时将被栅格化处理。

使用复合路径组合对象

复合路径包含两个或多个已上色的路径,因此在路径重叠处将呈现孔洞。将对象定义为复合路径后,复合路径中的所有对象都将应用堆栈顺序中最后方对象的上色和样式属性。

复合路径用作编组对象,在“图层”面板中显示为 <复合路径> 项。使用直接选择工具或编组选择工具选择复合路径的一部分。您可以处理复合路径的各个组件的形状,但无法更改各个组件的外观属性、图形样式或效果,并且无法在“图层”面板中单独处理这些组件。

注意:

如果希望在创建复合路径的过程中具有更多的灵活性,则可以创建一个复合形状,然后对其进行扩展。

使用复合路径在对象中开出一个孔洞

  1. 选择要用作孔洞的对象,然后将其放置在与要剪切的对象相重叠的位置。对任何要用作孔洞的其他对象重复此步骤。
  2. 选择要包含在复合路径中的所有对象。
  3. 选择“对象”>“复合路径”>“建立”。

将填充规则应用于复合路径

您可以指定复合路径是非零缠绕路径,还是奇偶路径。

非零缠绕填充规则

使用数学方程来确定点是在形状外部还是内部。Illustrator 将非零缠绕规则用作默认规则。

奇偶填充规则

使用数学方程来确定点是在形状外部还是内部。此规则的可预测性更高,因为无论路径是什么方向,奇偶复合路径内每隔一个区域就有一个孔洞。一些应用程序(如 Adobe Photoshop)默认情况下使用奇偶规则,因此,从这些应用程序导入的复合路径将使用奇偶规则。

自交叠路径是与自身相交叠的路径。根据您所需的外观,您可以选择将这些路径作成非零缠绕路径或奇偶路径。

复合路径
使用“非零缠绕填充规则”的自交叠路径(左图)与使用“奇偶填充规则”的自交叠路径(右图)的对比图

创建非零缠绕复合路径时,可以在“属性”面板中单击“反转路径方向”按扭,以指定重叠路径是以孔洞显示还是以填充显示。

四个环形路径
填充规则

A. 四个环形路径 B. 选定的环形路径,转换为复合路径 C. 应用于最内侧路径的反转路径方向 

更改复合路径的填充规则

  1. 使用选择工具或“图层”面板选择复合路径。
  2. 在“属性”面板中,单击“使用非零缠绕填充规则”按钮 或“使用奇偶填充规则”按钮

将复合路径中的孔洞变为填充区域

  1. 确保复合路径使用的是非零缠绕填充规则。
  2. 使用“直接选择”工具,选择复合路径中要反转的部分。不要选择整个复合路径。

  3. 在“属性”面板中,单击“反转路径方向(关)”按钮 或“反转路径方向(开)”按钮

将复合路径恢复为其原始组件

  1. 使用选择工具或“图层”面板选择复合路径。
  2. 选择“对象”>“复合路径”>“释放”。
Adobe 徽标

登录到您的帐户