若要创建可以在 Flash Player 中播放的幻灯片类型的内容,则既可以导出 SWF,也可以导出 FLA。二者主要的区别在于:SWF 文件可以立即进行查看且无法进行编辑,而 FLA 文件则必须先在 Adobe Flash Professional 中进行编辑后才能在 Adobe Flash Player 中查看。

SWF

导出的 SWF 文件可以在 Adobe Flash Player 中立即进行查看,其中可能含有一些交互式元素(如页面过渡效果、超链接、影片剪辑、声音剪辑、动画和导航按钮)。

FLA

导出的 FLA 文件只包含一些交互式元素。FLA 文件可以在 Flash Pro 中打开,为此,您或 Flash 开发人员可以在导出 SWF 之前,为该软件添加一些高级效果。

导出 Flash
导出 Flash

A. 直接导出 SWF B. 导出 FLA 以便在 Flash Professional 中进行编辑 

创建适用于 Web 的交互式 SWF (Flash) 文件

导出 SWF 即表示您创建的交互式文件可以在 Adobe Flash Player 或 Web 浏览器中查看。SWF 文件可以包含在 InDesign 中添加的按钮、页面过渡效果、影片文件、音频文件、动画以及超链接。导出 SWF 是一种基于 InDesign 文档创建交互式幻灯片或手翻书的非常好的方式。

如果希望在创建 SWF 文件之前先在 Flash Pro 中编辑该文档,请导出 FLA 而非 SWF。请参阅创建适用于 Web 的 FLA 文件

SWF 导出
SWF 导出

A. SWF 导出前 InDesign 中的文档 B. Web 浏览器中的 SWF 交互文件 
  1. 创建或编辑 InDesign 文档以准备导出 Flash。有关设置导出文档的更多详细信息,请参阅 Flash 导出问题

    • 添加导航按钮,以便允许用户在导出的 SWF 文件中进行页面导航。您可以创建按钮,方法是:先使用“按钮”面板(选择“窗口”>“交互”>“按钮”)绘制一个对象,然后将该对象转换为按钮。您也可以使用“样本按钮”面板向文档中拖入预定义的导航按钮。请参阅创建按钮

    • 使用“页面过渡效果”面板(选择“窗口”>“交互”>“页面过渡效果”)可以添加诸如擦除、溶解之类的页面过渡效果。导出 SWF 时,您也可以选择“包含交互卷边”选项,通过该选项,查看者可以拖动一个页角来翻页。

    • 使用“动画”面板(选择“窗口”>“交互”>“动画”)可以添加移动预设。请参阅动画

  2. 要将文档导出为 SWF 格式,请选择文件 > 导出

  3. 如果您希望随后导出的文件名称与文档的名称相同,请选择使用 InDesign 文档名称作为输出文件名

  4. 存储类型 (Windows) 或格式 (Mac OS) 菜单中选择 Flash Player (SWF),然后单击存储

  5. 在“导出 SWF”对话框中,指定以下选项,然后单击“确定”。请参阅 SWF 导出选项

导出 SWF 文件时,会创建单独的 HTML 和 SWF 文件。如果 SWF 文件包含影片和声音剪辑,则同时还会创建一个 Resources 文件夹。要向 Web 递交或上传文件,请您确保要发送所有资源。

SWF 导出选项

这些选项显示在“导出 SWF”对话框的“常规”和“高级”选项卡上。

导出

指示导出文档中的选定范围、所有页面或一个页面范围。当您希望存储所导出的 SWF 文件以便在导出的 PDF 文件中使用时,选择“选定范围”尤为有用。如果您选择“范围”,请指定一个页面范围,例如,将范围指定为“1-7, 9”,则可以打印第 1 至第 7 页以及第 9 页。请参阅指定要打印的页面

生成 HTML 文件

选择此选项将生成回放 SWF 文件的 HTML 页面。对于在 Web 浏览器中快速预览 SWF 文件,此选项尤为有用。

导出后查看 SWF

选择此选项将在默认 Web 浏览器中回放 SWF 文件。只有生成 HTML 文件才可使用此选项。

大小(像素)

指定 SWF 文件是根据百分比进行缩放,适合您指定的显示器大小,还是根据您指定的宽度和高度调整大小。

背景

指定 SWF 的背景是为透明,还是使用“色板”面板中的当前纸张颜色。选择“透明”将会停用“页面过渡效果”和“包含交互卷边”选项。

交互性和媒体

选择“包含全部”,允许影片、声音、按钮和动画在导出的 SWF 文件中进行交互。选择“仅限外观”,将正常状态的按钮和视频海报转变为静态元素。如果选中“仅限外观”,则动画将以其导出时版面的显示效果导出。当您在“高级”面板中选中“拼合透明度”时,会选中“仅限外观”。

页面过渡效果

指定一个页面过渡效果,以便在导出时将其应用于所有页面。如果您使用“页面过渡效果”面板来指定过渡效果,请选中“通过文档”选项来使用这些设置。

包含交互卷边

如果选中此选项,则在播放 SWF 文件时用户可以拖动页面的一角来翻转页面,从而展现出翻阅实际书籍页面的效果。

帧速率

较高的帧速率可以创建出较为流畅的动画效果,但这会增加文件的大小。更改帧速率不会影响播放的持续时间。

文本

指定 InDesign 文本的输出方式。选择“Flash 传统文本”可以按照最小的文件大小输出可搜索的文本。选择“转换为轮廓”可以将文本输出为一系列平滑线条,类似于将文本转换为轮廓。选择“转换为像素”可以将文本输出为位图图像。转换为像素的文本在放大时可能会显示锯齿效果。

栅格化页面

此选项可将所有 InDesign 页面项目转换为位图。选择此选项将会生成一个较大的 SWF 文件,并且放大页面项目的时候可能会有锯齿现象。

拼合透明度

此选项会删除 SWF 中的实时透明度效果,并保留透明外观。但是,如果选中此选项,导出的 SWF 文件中的所有交互性都将会删除。

压缩

选择“自动”可以让 InDesign 确定彩色图像和灰度图像的最佳品质。对于大多数文件,此选项可以产生令人满意的结果。对于灰度图像或彩色图像,可以选择“JPEG(有损式压缩)”。JPEG 压缩是有损式压缩,这意味着它会删除图像数据并且可能会降低图像的品质;然而,它会尝试在最大程度减少信息损失的情况下缩小文件的大小。因为 JPEG 压缩会删除数据,所以这种方式可以大大地缩小文件的大小。选择“PNG(无损式压缩)”可以导出无损式压缩的文件。

注意:

如果您在导出 SWF 时发现透明图像中的图像品质降低,请选择“PNG(无损式压缩)”以提高品质。

JPEG 品质

指定导出图像中的细节量。品质越高,图像大小越大。如果选择“PNG(无损式压缩)”作为压缩方式,则此选项将变为灰色不可用状态。

分辨率

指定导出的 SWF 中位图图像的分辨率。如果查看者要在导出的 SWF 内放大基于像素的内容,则选择高分辨率尤为重要。选择高分辨率会显著地增加文件的大小。

创建适用于 Web 的 FLA 文件

如果将 InDesign 文档导出为 FLA 文件格式,则可以在 Adobe Flash® CS5 Professional 中打开导出的文件以进行编辑。在 InDesign CS5 中,“导出 Flash CS5 Professional (FLA)”取代了 InDesign CS4 中的“XFL 导出”。使用 Flash 创作环境可以编辑或添加视频、音频、动画和复杂的交互性内容。

如果要将 InDesign 文档直接导出为可以直接在 Web 浏览器中打开的格式,请使用 SWF 格式而非 FLA 格式。请参阅创建适用于 Web 的交互式 SWF (Flash) 文件

FLA 导出
FLA 导出

A. 导出 FLA 前 InDesign 中的文档 B. 在 Flash Pro 中打开的 FLA 文件 
  1. 创建或编辑 InDesign 文档以准备导出 Flash。有关设置导出文档的更多详细信息,请参阅 Flash 导出问题

  2. 要将文档导出为 FLA 格式,请选择“文件”>“导出”。从“存储类型”(Windows) 或“格式”(Mac OS) 菜单中选择“Flash CS5 Professional (FLA)”,然后单击“存储”。

  3. 在“导出 Flash CS5 Professional (FLA)”对话框中,指定相应的选项,然后单击“确定”。有关导出选项的信息,请参阅 FLA 导出选项

  4. Flash Professional 中打开导出的 FLA 文件。

FLA 导出选项

“导出 Flash CS5 Professional (FLA)”对话框中显示有以下选项。

导出

指示导出文档中的选定范围、所有页面或一个页面范围。如果您选择“范围”,请指定一个页面范围,例如,将范围指定为“1-7, 9”,则可以打印第 1 至第 7 页以及第 9 页。请参阅指定要打印的页面

栅格化页面

此选项可将所有 InDesign 页面项目转换为位图。选择此选项会生成较大的 FLA 文件,并且在放大页面项目时会出现锯齿现象。

拼合透明度

选择此选项将会拼合所有具有透明度的对象。在 Adobe Flash Pro 中,可能难以对拼合的对象实施动画处理。

大小(像素)

指定 FLA 文件根据百分比进行缩放、适合您指定的显示器大小,或者根据您指定的宽度和高度来调整大小。

交互性和媒体

选择“包含全部”,可以在导出的 FLA 文件中包含影片、声音、按钮和动画。如果文档包含多状态对象,则该对象会转换为影片剪辑符号,其中每种状态都以独立的帧显示在时间轴中。

选择“仅限外观”,将正常状态的按钮和视频海报转变为静态元素。如果选中“仅限外观”,则动画将以其导出时版面的显示效果导出。如果您选取“拼合透明度”,则会选中“仅限外观”。

文本

指定 InDesign 文本的输出方式。选择“Flash TLF 文本”,可以利用 Flash Professional 中丰富的“文本布局框架”属性集。如果选中此选项,请选择“插入自由连字点”以允许使用连字。选中“Flash 传统文本”,可以采用最小的文件大小输出可搜索的文本。选择“转换为轮廓”可以将文本输出为一系列平滑线条,类似于将文本转换为轮廓。选择“转换为像素”可以将文本输出为位图图像。转换为像素的文本在放大时可能会显示锯齿效果。

压缩

选择“自动”可以让 InDesign 确定彩色图像和灰度图像的最佳品质。对于大多数文件,此选项可以产生令人满意的结果。对于灰度图像或彩色图像,可以选择“JPEG(有损式压缩)”。JPEG 压缩是有损式压缩,这意味着它会删除图像数据并且可能会降低图像的品质;然而,它会尝试在最大程度减少信息损失的情况下缩小文件的大小。因为 JPEG 压缩会删除数据,所以这种方式可以大大地缩小文件的大小。选择“PNG(无损式压缩)”可以导出无损式压缩的文件。

JPEG 品质

指定导出图像中的细节量。品质越高,图像大小越大。如果选择“PNG(无损式压缩)”作为压缩方式,则此选项将变为灰色不可用状态。

分辨率

指定所导出的 FLA 文件中位图图像的分辨率。如果查看者要在导出的 SWF 内放大基于像素的内容,则选择高分辨率尤为重要。选择高分辨率会显著地增加文件的大小。

Flash 导出问题

设计用于 SWF 或 FLA 输出的 InDesign 文档时,应考虑以下因素。

文档设置问题

如何转换 InDesign 页面

如果导出 SWF 或 FLA,InDesign 跨页将会成为时间轴中的单独剪辑,类似于幻灯片放映中的幻灯片。每个跨页都将映射到一个新的关键帧。在 Flash Player 中,按下箭头键或单击交互式按钮可以浏览导出文档的跨页。

注意:

创建适用于 Web 的文档时,请从“新建文档”对话框的“用途”菜单中选择“Web”。

页面大小

创建文档时,可以从“新建文档”对话框的“页面大小”菜单中选择特定分辨率,例如 800 x 600。导出过程中,您还可以调整导出的 SWF 或 FLA 文件的缩放比例或分辨率。

交互功能

导出的 SWF 和 FLA 文件中可以包含按钮、页面过渡效果、超链接、动画和媒体文件。

按钮

对于导出的 SWF 或 FLA 文件中的按钮,“下一页”和“上一页”动作控件对于在 Flash Player 中执行回放功能尤为有用。然而,PDF 交互文件中的某些有效动作会在 Flash Player 中失效。在“按钮”面板中选择动作时,请不要选择“仅限 PDF”部分中的选项。

注意:

可以添加使用“转到下一页”和“转到上一页”动作预定义格式的导航按钮。从“按钮”面板菜单中选择“样本按钮”。请参阅从“样本按钮”面板中添加按钮

页面过渡效果

所有页面过渡效果都能在 Flash Player 中正常使用。除了翻页时所显示的页面过渡效果,还可以在导出期间添加交互卷边效果,从而可以通过拖动页角进行翻页。

超链接

创建指向网站或文档中其他页面的链接。FLA 文件中的超链接是断开的。

影片和声音剪辑

如果影片和声音剪辑属于被支持的格式(如用于影片的 SWF、FLV、F4V 和 MP4 格式以及用于声音剪辑的 MP3 格式),则导出的 SWF 文件中可以包含这些内容。

导出 FLA 时,FLA 文件中只会包含海报图像。支持的媒体文件显示在与导出的 FLA 文件存储在同一位置的资源文件夹中。

转换问题

颜色

SWF 和 FLA 文件使用 RGB 颜色。将文档导出为 SWF 或 FLA 时,InDesign 会将所有色彩空间(如 CMYK 和 LAB)转换为 RGB。InDesign 会将专色转换为等效的 RGB 印刷色。

若要避免在包含透明文本的图稿中发生不必要的颜色变化,请选择“编辑”>“透明混合空间”>“文档 RGB”。为了避免在具有透明度的图像中发生不必要的颜色更改,请不要在导出过程中使用有损式压缩。

文本

导出 SWF 或 FLA 时,您可以决定是将文本输出为 Flash 文本,还是将其转换为轮廓或像素。如果将文本导出为 Flash 传统文本,则在 Adobe Flash CS5 Professional 中打开 FLA 文件之后仍然可以彻底地对其进行编辑;如果存储为 SWF 文件,则可在 Web 浏览器中搜索该文本。

图像

将图像导出为 SWF 或 FLA 时,可以更改导出过程中的图像压缩方式、JPEG 品质和分辨率设置。

将图像导出为 FLA 时,如果 InDesign 文档中存在置入多次的图像,则会使用一个共享位置将该图像存储为单个图像资源。请注意,InDesign 文档中的大量矢量图像可能会产生导出文件中的性能问题。

若要减小文件大小,请将重复图像放在主页上,并避免复制和粘贴图像。如果同一图像在文档中多次置入且未经转换或裁切,则 FLA 文件中只会导出该文件的一个副本。复制和粘贴的图像将被视为单独对象。

默认情况下,置入的 Illustrator 文件在 FLA 文件中将作为单个图像处理,而复制和粘贴的 Illustrator 文件则会生成许多单独的对象。若要获得最佳效果,请将 Illustrator 图像以 PDF 文件置入,而不要从 Illustrator 复制和粘贴。复制和粘贴将会产生多个可编辑的路径。

注意:

您可以更改首选项选项,以确保 Illustrator 对象作为一个对象而不是小矢量的集合进行粘贴。在 Illustrator 的“文件处理和剪贴板”首选项中,选择“PDF”并取消选择“AICB”(不支持透明度)。在 InDesign 的“剪贴板处理”首选项中,同时选择“粘贴时首选 PDF”和“将 PDF 复制到剪贴板”。

透明度

在导出为 SWF 之前,请确保透明对象不与任何交互式元素(例如按钮或超链接)重叠。如果某个透明对象与交互式元素重叠,导出过程中则有可能会丧失交互功能。您可能需要在导出 FLA 之前拼合透明度。

在某些情况下,选择有损式压缩会降低具有透明度的图像的品质。导出时,选择“PNG(无损式压缩)”可以提高品质。

3D 属性

导出的 SWF 和 FLA 文件不支持 3D 属性。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略