יצירת נכסי תמונות משכבות

עודכן לאחרונה בתאריך 29 באוקטובר 2026

השתמשו ב-Generator כדי ליצור קבצים באופן אוטומטי על ידי הוספת סיומות פורמט כמו .png או .jpg לשמות ה-Layer (שכבה)ים.

הוספת סיומות קבצים לשמות ה-Layer (שכבה)ים מפעילה את Generator של Photoshop כדי ליצור קובצי תמונה באופן אוטומטי בכל פעם שאתם שומרים. כך נחסכים שלבי ייצוא חוזרים ונשנים עבור פרויקטים לאינטרנט, יישום ומספר מכשירים הדורשים כמה פורמטים או גדלים.

תהליך העבודה פועל בצורה הטובה ביותר כשאתם צריכים ייצוא עקבי וחוזר בכמה פורמטים או רזולוציות – למשל ביצירת גרסאות @1x,‏ @2x ו-@3x עבור עיצובים מגיבים.לייצוא חד-פעמי או כשאתם צריכים פקדי בקרה ייעודיים לפורמט, השתמשו במקום זאת ב-קובץ > ייצוא > ייצוא כ-

ה-Generator יוצר תיקייה ייעודית עבור הנכסים שלכם ומעדכן את הקבצים באופן אוטומטי בזמן שאתם עובדים.אפשר ליצור כמה פורמטים מ-Layer (שכבה) יחיד, לציין הגדרות איכות, לשנות את קנה המידה של נכסים לגדלים שונים ולארגן את הפלט בתיקיות משנה – הכול באמצעות כללי מתן שמות ל-Layer (שכבה)ים.

  • מסמך Photoshop עם Layer (שכבה)ים או קבוצות Layer (שכבה)ים בעלי שמות
  • המסמך נשמר במיקום ידוע (אחרת הנכסים יופיעו בשולחן העבודה)
  • היכרות עם פורמטי הפלט הנדרשים לפרויקט שלכם

הפעלת יצירת נכסי תמונה

בחרו קובץ > אוטומציה > תוספי Generator > נכסי תמונה.

בלוח Layers, אתרו את ה-Layer (שכבה) או הקבוצה שברצונכם לייצא.

שנו את שם ה-Layer (שכבה) על ידי הוספת סיומת קובץ: ‎.jpg,‏ ‎.png,‏ ‎.gif או ‎.svg.לדוגמה, שנו את השם "logo" ל-"logo.png".

שמרו את המסמך באמצעות Ctrl + S ‏(Windows) או Command + S ‏(macOS).

Photoshop יוצר את קובץ התמונה בתיקיית משנה לצד המסמך השמור שלכם. אם המסמך עדיין לא נשמר, הנכסים יופיעו בתיקייה חדשה בשולחן העבודה שלכם.ה-Generator נשאר פעיל – כל שינוי ב-Layer (שכבה)ים שמופעל בהם Generator גורם לעדכונים אוטומטיים של הנכסים המתאימים.

פתק

שמות של Layer (שכבה)ים לא יכולים להכיל את : (נקודתיים) או * (כוכבית), כי התווים האלה מונעים יצירת נכסים.

יצירת כמה פורמטים מ-Layer (שכבה) אחד

Layer (שכבה) יחיד יכול להפיק נכסים בפורמטים, גדלים ורמות איכות שונות בו-זמנית. הפרידו בין כל מפרט נכס בשם ה-Layer (שכבה) באמצעות פסיק או סימן פלוס.

בחר בשכבה בחלונית Layers.

שנו את שם ה-Layer (שכבה) באמצעות פורמט מופרד בפסיקים – לדוגמה: button.png, button.jpg90, 200% button@2x.png.

שמור את המסמך.

Photoshop יוצר שלושה קבצים נפרדים מתוכן אותו Layer (שכבה), ומבטל את הצורך לייצא את אותה גרפיקה באופן ידני בפורמטים שונים.

בקרת איכות והתאמת נכסים ל-Screens שונים

בחר בשכבה בחלונית Layers.

הוסיפו פרמטרים של איכות או גודל לשם הקובץ.לדוגמה: "button.jpg90" מגדיר את איכות ה-JPEG ל-90%, או "200% logo@2x.png" מכפיל את גודל הנכס.

ברזולוציות מרובות, הפרידו בין כל מפרט באמצעות פסיקים: "icon.png, 200% icon@2x.png, 300% icon@3x.png".

שמרו את המסמך כדי ליצור את כל הווריאציות.

סיומות איכות קובעות את רמת הדחיסה לקבצי JPG (1-100) ואת עומק הביט לקבצי PNG (8, 24 או 32).קידומות גודל מקבלות אחוזים להתאמה יחסית או מידות אבסולוטיות ב-px.אפשר לשלב יחידות מידה – לדוגמה, "10in x 5cm banner.jpg" – ולהשמיט מידה אחת כדי לשנות קנה מידה באופן יחסי: "1080 x icon.png" מגדיר את הרוחב ל-1080 px, ושומר על יחסי הגודל.

עצה

השתמשו בכינויי השמות @2x ו-@3x כדי ליצור באופן אוטומטי גרסאות retina ו-high-DPI עבור פרויקטי אינטרנט רספונסיביים ויישומים למכשירים ניידים.

דוגמאות להתאמת קנה מידה יחסית:

200% logo.png מכפיל את גודל הנכס

50% thumbnail.jpg מקטין את הנכס לחצי מהגודל

דוגמאות למידות אבסולוטיות:

300 x 200 hero.png יוצר תמונה בגודל 300×200 פיקסל

10in x 5cm banner.jpg משלב יחידות מידה (10 אינץ׳ לרוחב, 5 ס״מ לגובה)

1080 x icon.png מגדיר את הרוחב ל-1080 פיקסלים, והגובה משתנה פרופורציונלית

עצה

כשמציינים מידות בפיקסלים, כתבו את המספרים ישירות ללא ציוני יחידות.השתמשו ב-"300 x 200" במקום "300px x 200px".

ארגנו נכסים בתיקיות משנה

כברירת מחדל, כל הנכסים שנוצרים נשמרים בתיקייה אחת לצד קובץ ה-PSD.הוספת שם תיקיית משנה לפני שם הקובץ מורה למייצא ליצור ולהשתמש בתיקיית המשנה הזו באופן אוטומטי.כך הנכסים הקשורים נשארים מאורגנים בלי צורך בניהול תיקיות באופן ידני.

כללו את נתיב תיקיית המשנה בשם ה-Layer (שכבה) שלכם, באמצעות קו נטוי קדימה: subfolder/filename.png או icons/logo.svg.אפשר לקנן כמה רמות: assets/icons/logo.png.

ייצוא נכסים לתיקיות מסוימות

שנו את שם ה-Layer (שכבה) בעזרת נתיבי תיקיות משנה בשם הקובץ. לדוגמה: mobile/button.png, desktop/button.png.

שמור את המסמך.

Photoshop יוצר את מבנה התיקיות באופן אוטומטי ומציב כל נכס במיקום שנקבע לו. שילוב של תיקיות משנה עם קידומות גודל והגדרות איכות מעניק שליטה מלאה על ארגון הנכסים: mobile/200% button@2x.png, desktop/button.jpg90.

הגדרת ברירות מחדל לכל המסמך

צרו Layer (שכבה) מיוחד כדי לקבוע הגדרות בסיס שיחולו על כל הנכסים שנוצרים. כך נמנעים מהצורך לציין פרמטרים חוזרים בשמות ה-Layer (שכבה) הפרטניים.

צרו Layer (שכבה) ריק ותנו לו שם שמתחיל ב-"default" ולאחריו ההגדרות המועדפות עליכם. תצורות נפוצות כוללות את "default 200%" כדי לשנות את קנה המידה של כל הנכסים ל-200%, את "default assets/" כדי לשמור את הכול בתיקיית משנה בשם assets, או את "default @2x" כדי להוסיף את הסיומת @2x לכל שמות הקבצים.

אפשר לשלב כמה ברירות מחדל: "default 200% retina/ @2x" משנה את קנה המידה של כל הנכסים ל-200%, שומר אותם בתיקיית משנה בשם retina, ומוסיף את הסיומת @2x לשמות הקבצים. הגדרות של Layer (שכבה) ספציפי גוברות על ברירות המחדל של המסמך – אם ברירת המחדל שלכם קובעת "default 200%" אבל שם ה-Layer (שכבה) כולל "50% thumbnail.png", אותו Layer (שכבה) ייוצר ב-50%.

עבודה עם מסמכי ענן

מסמכי ענן שומרים נכסים שנוצרו באופן מקומי, ולא ישירות לצד קובץ ה-PSD. Photoshop שומר על ההפרדה הזו כדי להבחין בין תוכן מקומי לתוכן מסונכרן בענן.

נכסים של מסמכי ענן מופיעים במיקומים האלה:

  • Windows: C:\Usersusername>\Documents\Adobe\Photoshop Cloud Associates
  • macOS: /Users//Documents/Adobe/Photoshop Cloud Associates

כל מסמך ענן יוצר תיקיית משנה משלו בתוך הספריה הזו. הנכסים נוצרים באופן אוטומטי בזמן העבודה, אך הם נשארים במחשב המקומי שלכם עד שתבצעו שיתוף או סנכרון שלהם ב-Creative Cloud באופן מפורש.

השבתת יצירת נכסים

יצירת נכסי תמונה נשארת פעילה עבור מסמך לאחר ההפעלה, ונמשכת בין הפעלות.התכונה יוצרת מחדש את הנכסים באופן אוטומטי בכל פעם שאתם שומרים, מה שעלול להאט את הביצועים במסמכים מורכבים.

כדי לכבות את היצירה במסמך הנוכחי, בטלו את הבחירה באפשרות File > Automate > Generator Plugins > Image Assets. פעולה זו עוצרת את יצירת הנכסים האוטומטית אך משאירה את כל הנכסים הקיימים ואת שמות ה-Layer (שכבה) כפי שהם.

כדי לכבות את הגנרטור באופן גלובלי בכל המסמכים, בחרו בעריכה > העדפות > תוספים, הסירו את הסימון מהאפשרות הפעלת גנרטור, ובחרו אישור.פעולה זו מכבה לחלוטין את הפונקציונליות של הגנרטור, עד שתפעילו אותה מחדש בהעדפות.