תקנו את שגיאת ה-Generator בעת הפעלת Adobe Photoshop

עודכן לאחרונה בתאריך 29 באוקטובר 2026

למדו כיצד לתקן את שגיאת ה-Generator ב-Adobe Photoshop על ידי בדיקת הגדרות האבטחה, הסרת תוספים מתנגשים ובדיקת היומנים.

Generator הוא יישום Node.js שמטפל בתקשורת בין Photoshop לבין תוספי Generator. הוא מספק את לוגיקת יצירת הנכסים עבור ייצוא בשם ועבור נכסי תמונה.

כאשר אתם מפעילים את Photoshop או בוחרים קובץ > ייצוא > ייצוא בשם, מופיעה תיבת דיאלוג שמציינת: "יש בעיה עם Generator. Please quit Photoshop and try again. אם הבעיה נמשכת, הסירו תוספים של צד שלישי או נסו להתקין מחדש את Photoshop."

נסה את הפתרונות הבאים, לפי הסדר.

תוכנת אבטחה חוסמת את Generator

תוכנת אבטחה או אנטי-וירוס עלולה לחסום תקשורת מה-Generator בפורט 8010 או למנוע מתהליך ה-node לפעול.

פתחו את הגדרות האבטחה או האנטי-וירוס שלכם.

הוסיפו את Photoshop לרשימת היישומים המותרים.

הקפידו שפורט 8010 פתוח עבור ה-Generator.

הוסיפו את node.exe לרשימת היישומים המותרים בנתיב C:\Program Files\Adobe\Adobe Photoshop <version>\node.exe ב-Windows.

ב-macOS, אפשרו לתהליך ה-node בנתיב /Applications/Adobe Photoshop <version>/Adobe Photoshop <version>.app/Contents/MacOS/node.

ב-Windows, אפשרו ל-Photoshop לגשת לתיקיות מוגנות.

הפעילו מחדש את Photoshop, ולאחר מכן בחרו קובץ > ייצוא > ייצוא בשם כדי לבדוק את ה-Generator.

תוסף של צד שלישי מתנגש עם Generator

תוספים של צד שלישי בתיקיית ה-Generator של Photoshop עלולים להיות לא תואמים לגרסה הנוכחית שלכם או להתנגש עם תוסף נכסי התמונה שמוגדר כברירת מחדל.

Windows: C:\Program Files\Adobe\Adobe Photoshop <version>\Plug-ins\Generator

macOS: /Applications/Adobe Photoshop <version>/Plug-ins/Generator

צרו תיקייה זמנית בשולחן העבודה בשם Disabled Generator Plug-ins.

העבירו את תיקיות התוספים של צד שלישי לתיקייה הזמנית. השאירו את תוסף ברירת המחדל Image Assets בתיקיית Generator.

הפעילו את Photoshop ובחרו קובץ > ייצוא > ייצוא בשם.

אם השגיאה נעלמה, הוסיפו את התוספים בחזרה אחד בכל פעם, והפעילו מחדש את Photoshop אחרי כל הוספה עד שהשגיאה תחזור.

השאירו את תוסף ברירת המחדל Image Assets בתיקיית Generator. העבירו רק תוספים שהתקנתם בנפרד.

ה-Generator נכשל בהפעלה, ואין צורך בו

אם אתם לא משתמשים בExport As או בImage Assets, כבו את Generator כפתרון חלופי.

הפעילו את Photoshop.

ב-Windows, בחרו בעריכה > העדפות > תוספים. ב-macOS, בחרו בPhotoshop > הגדרות > תוספים.

בטל את סימון האפשרות הפוך Generator לזמין.

בחרו באפשרות OK, ולאחר מכן הפעילו מחדש את Photoshop.

בחירה בקובץ > ייצוא > ייצוא בשם מפעילה שוב את Generator. אם אתם צריכים את ייצוא בשם, פתרו את שגיאת Generator במקום להשאיר את Generator מכובה.

יומני Generator מציגים שגיאות הפעלה

יומני Generator יכולים להכיל מידע על תוספים שנכשלים בטעינה או על בעיות מערכת שמונעות מ-Generator להיפעל.

ב-Windows, נווטו אל C:\Users\<username>\AppData\Roaming\Adobe\Adobe Photoshop <version>\Logs\Generator.

ב-macOS, נווטו אל /Users/<username>/Library/Logs/Adobe/Adobe Photoshop <version>/Generator.

פתחו את יומן ה-Generator העדכני ביותר וחפשו הודעות שגיאה.

אם תיקיית Generator לא קיימת, ודאו שיש לכם הרשאת כתיבה לתיקיית האב.

אם אתם צריכים עזרה נוספת, השתמשו בAdobe Log Collector Tool כדי לאסוף יומני אבחון.

תיקיות Windows AppData ו-macOS Library מוסתרות כברירת מחדל. ההוראות להצגת קבצים ותיקיות מוסתרים ב-Windows יכולות לעזור לכם לאתר את יומני Windows.

שגיאות Generator מתרחשות במעבדי Apple Silicon

אם ה-Generator ממשיך להיכשל ב-Mac עם מעבד Apple Silicon, הפעלת Photoshop עם Rosetta יכולה לעזור לקבוע אם התאמה למצב מקורי היא הגורם לבעיה.

צא מ-Photoshop.

בFinder, פתחו את יישומים ואתרו את Adobe Photoshop.

Control-לחצו על Adobe Photoshop, ולאחר מכן בחרו בקבלת מידע.

בחרו בפתיחה באמצעות Rosetta, ולאחר מכן הפעילו את Photoshop ובדקו את Generator.

אם השגיאה ממשיכה להתרחש, מסרו את יומני Generator כשאתם פונים לתמיכה של Adobe לקבלת עזרה. לבעיות ב'ייצוא בשם' שאינן קשורות ל-Generator, השתמשו בהנחיות לפתרון בעיות בפעולות ייצוא ושמירה.